fedora-meeting
LOGS
14:12:48 <randomuser> #startmeeting fedora docs Weekly meeting
14:12:48 <zodbot> Meeting started Mon May  4 14:12:48 2015 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:12:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:12:58 <randomuser> #topic roll call
14:13:00 * Capesteve is here
14:13:10 * pbokoc 
14:13:24 <randomuser> my captive portal token was eaten by wolves :)
14:13:29 * rkratky is here
14:13:53 * smccann is here
14:13:53 <pkovar> /me is here
14:15:22 * bexelbie is here from his bed
14:15:25 <randomuser> #link https://fedoraproject.org/wiki/Docs_Project_meetings#Standing_Agenda
14:15:46 <randomuser> #chair pkovar pbokoc
14:15:46 <zodbot> Current chairs: pbokoc pkovar randomuser
14:16:23 <randomuser> ok, let's get on with it
14:16:33 * randomuser has another meeting backing this one, unfortunately
14:16:42 <randomuser> #topic new writers
14:17:12 <randomuser> I'm pleased to have sponsored smccann and grundblom into docs-writers after their hard work updating the virt quickstart guide
14:17:27 <pbokoc> cool
14:17:32 <randomuser> you are no longer new writers, congrats!
14:17:33 <Capesteve> \o/
14:17:52 <smccann> huzzah!!!
14:18:34 <pbokoc> now you have to bring in someone new so we have something to discuss in the first part of these meetings
14:18:45 <randomuser> yep, that's the deal
14:19:04 <valebes> hi
14:19:04 <randomuser> once you're in, you have secondary recruitment responsibilities :)
14:19:18 <randomuser> hey, valebes, welcome!
14:19:42 <pbokoc> yeah, we're basically Amway :))
14:19:55 <randomuser> heh
14:20:11 <smccann> ahahah... doc pyramid scheme much?
14:20:17 <randomuser> valebes, would you like to introduce yourself or ask questions, or shall we move on?
14:21:43 * randomuser moves on
14:21:49 <randomuser> #topic Publishing
14:22:11 <pbokoc> so what's new?
14:22:25 <randomuser> I've brought up a couple things in recent meetings that were deferred to the list, but there wasn't much discussion on the list
14:22:54 <randomuser> so, I intend to go with a certain approach
14:23:35 <randomuser> share ideas for comment, allow some time for discussion, implement a well documented executive decision, and make room for it to be questioned or changed
14:24:12 <randomuser> ...anyway, I went to a conference and it ate up a bunch of time, so no new stuff to report, really
14:25:02 <pbokoc> what about the website design problem? You mentioned you talked to someone from the design team before, and nothing significant happened, so you were going to open a ticket or something
14:25:06 <randomuser> I discovered https://github.com/ralphbean/bootstrap-fedora - the site theming used for basically all Fedora sites
14:25:24 <randomuser> right, a ticket... I'll do that today
14:25:31 * randomuser hangs head
14:26:15 <pbokoc> :))
14:26:27 <randomuser> #action randomuser to open design ticket for collaboration, already
14:26:55 <randomuser> anyway, for the new stuff, I want to use this fedora bootstrap theme
14:27:39 <pbokoc> sounds good, there's little sense on building the look from scratch if this exists
14:27:58 <randomuser> I also looked more closely at what `publican publish --embedtoc` does, and there's a reference to a toc.html and toc.js that does the menu magic; this is created/maintained by the publican site commands
14:28:34 <randomuser> so, the plan is to generate the toc.html using anerist instead of publican, then we can have a known good docbook->html conversion
14:29:25 <randomuser> I *think* that also implies some automated conversion of the bootstrap-fedora css to publican-expected css
14:30:34 <randomuser> The infrastructure folks have graciously consented to my converting their process documentation to restructuredtext, so soon I'll have a git repo full of small RST articles to experiment with
14:31:37 <randomuser> help at any point is welcome, but I think we could best agree on the category structure, etc
14:32:00 <randomuser> so I'll start a wiki page on that in the next day or two and send a mail to the list asking for participation
14:32:32 <Capesteve> randomuser: what format are or were the infrastructure docs in?
14:32:52 <pbokoc> well, as always, I don't think I'd be able to help (don't know the first thing about websites or css) and I think a lot of us here in docs have the same problem :I
14:33:01 <randomuser> Capesteve, they were displayed as simple plain text, so it ranges from none to writer's habit (rst, markdown)
14:33:48 <Capesteve> ta ( I not little of the advantages of the different types, just  curious )
14:34:03 <Capesteve> know
14:34:25 <randomuser> pbokoc, well, I think we're all agreed that organizing documentation by subject rather than applicable release is a good
14:34:47 <Capesteve> I have bad experience with markdown, I found that it the end DocBook is quicker if you include time to fix and improve
14:35:03 <randomuser> collaborating on a predefined list of categories doesn't take webdev experience
14:35:20 <randomuser> Capesteve, yeah, jhradilek was adamantly against md as well
14:35:23 <pbokoc> yeah, ok, but it makes my head hurt :))
14:36:07 <randomuser> restructuredtext seems better, and it's not much more complicated than markdown, so here we are
14:37:15 * pbokoc notes that bexelbie is often full of ideas on categories, personas and other meta stuff
14:37:27 * randomuser nods
14:37:34 * bexelbie is full ...
14:37:44 <randomuser> we should hang out sometime, bexelbie :)
14:38:16 <bexelbie> :)
14:39:11 <bexelbie> md has issues on the meta-data side but is dirt simple for intro/new writers
14:39:18 <bexelbie> the formatting is kind of a disaster though
14:39:31 <bexelbie> as for structure/categories, perhaps we should start lighter at first and see what we have
14:39:37 <randomuser> I haven't ever been able to use md without coopting extensions
14:39:37 <bexelbie> rather than trying to define the tree and then fill it
14:40:11 * bexelbie has been trying to find time to read this: https://randomdeterminism.wordpress.com/2012/06/01/how-i-stopped-worring-and-started-using-markdown-like-tex/
14:40:38 <randomuser> that's a familiar article and intent ...
14:41:06 <bexelbie> in the end though, it may not matter - if we can go with a meta-data standard, it can be supplied by a side-file if the main format doesn’t support it
14:41:40 <bexelbie> and perhaps we allow for a dynamic structure defined by the meta-data instead of curated by hand, with the idea that we can shape it up by fixing the files, not by forcing the writing to fit
14:42:24 <randomuser> bexelbie, sure - but I recall at one point you pointed out the problems with allowing arbitrary metadata values when using the metadata for dynamic structure generation
14:42:52 <bexelbie> arbitrary values, yes, but if we only have this field with variations we may be able to control this
14:42:59 <randomuser> so, a defined taxonomy sounded prudent and a good opportunity for collaboration
14:43:02 <bexelbie> and I suspect this would be a stop-gap for the start-up period
14:43:16 <bexelbie> we can freeze where we are and formalize the taxonomy once we have lived with it for a bit
14:43:30 <bexelbie> it can’t be worse than what we have (famous last words) and forward motion seems like a win
14:43:34 <randomuser> rihgt
14:44:00 <bexelbie> ala https://sivers.org/walkways
14:44:00 <randomuser> basic stuff for now
14:44:15 <randomuser> hey, I have to bail, apparently that other meeting is starting early
14:44:25 <randomuser> pbokoc, pkovar you have the chairs
14:44:38 <pbokoc> right
14:44:45 <randomuser> thanks
14:45:04 <pbokoc> well, I guess that concludes the debate on publishing then
14:45:31 <pbokoc> if you have anything, please write to the mailing list
14:45:55 <pbokoc> #topic Release Notes
14:46:34 <pbokoc> anyone got anything? Did anyone get yelled at because we missed a huge feature in relnotes, etc.?
14:48:02 <pbokoc> yeah, I guess not
14:48:11 <pbokoc> #topic Guide Status
14:48:44 <pbokoc> Capesteve pushed a bunch of commits to the Sysadmin Guide about DNF, yayyyyy
14:49:01 * Capesteve is waiting for DNF devs to review DNF chapter, but has pushed it in the mean time
14:49:18 <Capesteve> please pull, build, review
14:49:54 <Capesteve> I will chase DNF devs for their review during this week
14:50:18 <pbokoc> yeah, that's not a bad idea. The repo is here if anyone wants to take a look: https://git.fedorahosted.org/cgit/docs/system-administrators-guide.git/
14:52:56 <pbokoc> #topic Open floor
14:53:07 <pbokoc> I've got nothing, but if anyone else does, now's your time
14:59:31 <bexelbie> pbokoc, time to call it I think
15:00:08 <pbokoc> #endmeeting