kde-sig
LOGS
15:09:26 <Kevin_Kofler> #startmeeting KDE SIG Meeting
15:09:26 <zodbot> Meeting started Tue Mar 24 15:09:26 2015 UTC.  The chair is Kevin_Kofler. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:09:30 <Kevin_Kofler> #meetingname kde-sig
15:09:30 <zodbot> The meeting name has been set to 'kde-sig'
15:09:33 <Kevin_Kofler> #topic Roll call
15:09:38 * Kevin_Kofler is present, who else?
15:09:43 * jgrulich is present
15:09:44 <pino|work> me
15:09:53 <dvratil> semi-present (from phone)
15:10:10 <pino|work> dvratil: busy as always, eh? ;)
15:10:36 <than> present
15:10:37 <rdieter> .hello rdieter
15:10:38 <zodbot> rdieter: rdieter 'Rex Dieter' <rdieter@math.unl.edu>
15:11:08 <dvratil> pino|work My laptop fs seems to have crashed again,  so I went shopping to IKEA :)
15:11:28 <pino|work> makes sense
15:11:34 <rdieter> not just btrfs problems?
15:11:46 <tosky> hi
15:12:11 <jgrulich> dvratil: heh, I even didn't notice you went away :)
15:12:27 <dvratil> rdieter: yep,  might be hdd failing...running some diags and recovery now
15:13:44 <Kevin_Kofler> #chair jgrulich pino|work dvratil than rdieter tosky
15:13:44 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich pino|work rdieter than tosky
15:13:56 <Kevin_Kofler> #info Kevin_Kofler, jgrulich, pino|work, dvratil, than, rdieter, tosky present.
15:13:59 <Kevin_Kofler> #topic Agenda
15:14:23 <Kevin_Kofler> Formal KDE SIG position for https://fedorahosted.org/famsco/ticket/376
15:14:59 <rdieter> +1 to any solution that results in media that includes kde somehow :)
15:15:04 <dvratil> Kf5 apps Localization
15:15:37 <rdieter> oops, sorry still on agenda, f22/plasma5 blockers
15:16:07 <Kevin_Kofler> Anything else?
15:16:16 <Kevin_Kofler> Otherwise we start with the first topic.
15:18:03 <Kevin_Kofler> #chair ltinkl
15:18:03 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl pino|work rdieter than tosky
15:18:21 <Kevin_Kofler> #topic https://fedorahosted.org/famsco/ticket/376 – KDE-SIG requests media
15:18:24 <danofsatx> I'm here, really.....fighting with a windows workstation
15:18:31 <Kevin_Kofler> #chair danofsatx
15:18:31 <zodbot> Current chairs: Kevin_Kofler danofsatx dvratil jgrulich ltinkl pino|work rdieter than tosky
15:18:44 <Kevin_Kofler> So I'd like to have a formal KDE SIG position on this.
15:19:07 * heliocastro is here
15:19:10 <rdieter> +1 to any solution that results in media that includes kde somehow :)  (that includes kde only media or multi-spin media)
15:19:43 <tosky> +1 for the position you (rdieter and Kevin_Kofler) mentioned in the ticket (and here)
15:19:46 <Kevin_Kofler> Proposal: The KDE SIG is fine with multi-spin, multi-desktop or multi-edition media as long as KDE is included on that media. The KDE SIG is of course also fine with specific KDE media.
15:19:48 <danofsatx> +1
15:20:04 <dvratil> +1, fine with me
15:20:18 <heliocastro> +1
15:20:19 <jgrulich> +1
15:20:19 <Kevin_Kofler> (That's basically just restating the aforementioned position.)
15:20:36 <than> +1
15:21:03 <rdieter> +1 (to specific proposal)
15:21:11 <ltinkl> +1 obviously
15:21:32 <Kevin_Kofler> Looks like we have agreement.
15:21:45 <Kevin_Kofler> #agreed The KDE SIG is fine with multi-spin, multi-desktop or multi-edition media as long as KDE is included on that media. The KDE SIG is of course also fine with specific KDE media.
15:23:13 <Kevin_Kofler> #link https://fedorahosted.org/famsco/ticket/376#comment:4
15:23:19 <Kevin_Kofler> So let's move on.
15:23:33 <Kevin_Kofler> #topic Kf5 apps Localization
15:23:38 <Kevin_Kofler> dvratil: Your turn.
15:24:14 <dvratil> ltinkl found problem with localizations -  since kf5 apps and frameworks now ship their own complete localizationds,  we need to also somehow make sure to install qt5 localization
15:24:49 <dvratil> Otherwise you have app localized,  but stuff that comes from qt (buttons etc)  is in English
15:25:05 <ltinkl> yup, (partially) solved now in the ki18n framework
15:25:26 <dvratil> So the question is what should Requires: qt5-qttranslations
15:25:57 <ltinkl> in theory this should be every Qt app
15:26:14 * rdieter thinks of way to get -langpacks plugin to handle this
15:26:22 <dvratil> We could have it in qtbase and simply force localization on everyone :)  or each framework and app that have localization should require the package explicitly
15:26:36 <ltinkl> yup, langpacks should work there
15:26:37 <Kevin_Kofler> Just add Recommends: qt5-qttranslations to qt5-qtbase?
15:26:54 <ltinkl> Kevin_Kofler: yup, that was our other idea :)
15:27:07 <ltinkl> a soft-dependency
15:27:10 <rdieter> first, can someone file a bug to track this?
15:27:17 <dvratil> Kevin_Kofler: that won't work before f23 :(
15:27:38 <Kevin_Kofler> Uh, it's supposed to work in F22.
15:27:42 <rdieter> dvratil: recommends should work now
15:27:47 <dvratil> Ah ok
15:27:52 <rdieter> (well, for dnf anyway)
15:28:00 <rdieter> but probably not yum
15:28:00 <dvratil> But still not on f21
15:28:08 <Kevin_Kofler> Even in F21 when using DNF.
15:28:12 <Kevin_Kofler> Only in F20 it won't work at all.
15:28:27 <Kevin_Kofler> Not sure what PackageKit-hif does with it though.
15:29:42 <dvratil> ltinkl could you file the bug? We should also make sure ro have it on live images, to get full localization there is important
15:29:43 <Kevin_Kofler> #info We need to ensure qt5-qttranslations gets installed so that strings coming from Qt get translated.
15:29:56 <rdieter> I'll try to reach out to langpack plugin folk(s), I forget if Provides: are good enough, or if it needs real subpkgs
15:30:15 <rdieter> I *think* Provides: are good enough
15:30:23 <Kevin_Kofler> dvratil: So far the KDE live images have always been English-only, due to the size of kde-l10n-*.
15:30:46 <dvratil> But with plasma 5 we now get partial localization
15:31:06 <rdieter> then it's just a matter of matching up <installed_pkg> with <installed_pkg>-l10n-locale Provides
15:31:42 <rdieter> or maybe it's <pkg> and <pkg>-locale
15:31:53 <Kevin_Kofler> rdieter: Provides were supposed to be good enough, but the code doesn't really work with them right now and I don't think it got fixed (because we ended up just renaming kde-l10n – by the way, the renames need to get pushed to the releases, too).
15:32:29 <Kevin_Kofler> The problem is, they now use PackageKit to install the packages, and they use an interface that only accepts real package names.
15:32:31 <rdieter> Kevin_Kofler: was renaming *really* requires?
15:32:45 <Kevin_Kofler> At least that's what system-config-language does.
15:32:50 <rdieter> I think the *real* fix was my adding to kdelibs: Requires: kde-l10n
15:33:03 <Kevin_Kofler> The yum-langpacks plugin probably still works with the Provides, but s-c-l does not.
15:33:04 <rdieter> (or maybe both of those changes fixed it)
15:33:17 <rdieter> ok, boo
15:33:39 <rdieter> is there at least a bug tracking that s-c-l problem
15:33:40 <rdieter> ?
15:34:05 <rdieter> (I'd rather that get fixed properly, then us having to rename stuff and create subpkg's all over to work around it)
15:34:31 <rdieter> renaming kde-l10n subpkgs was easy, but changing qt5-qttranslations packaging will be  more work
15:34:51 <Kevin_Kofler> There was a bug, but it got closed when we changed kde-l10n.
15:35:24 <rdieter> let's reopen then :-/
15:35:35 <Kevin_Kofler> .bug 1170730
15:35:37 <zodbot> Kevin_Kofler: Bug 1170730 system config language selects wrong kde-l10n-* language packages - https://bugzilla.redhat.com/1170730
15:36:41 <rdieter> thx, I'll open it, reassign
15:39:24 <Kevin_Kofler> I still don't understand why a Recommends is not good enough, instead of relying on funky plugins.
15:39:51 <Kevin_Kofler> (PackageKit doesn't use those plugins, and does DNF have a langpacks plugin yet?)
15:40:21 <Kevin_Kofler> Soft dependencies should be good enough, and if PackageKit doesn't handle them right, we need to get PackageKit fixed (and if even DNF doesn't handle them right, we need to get DNF fixed).
15:40:42 <Kevin_Kofler> If nobody uses soft dependencies because they're not well-tested, they will never get well-tested.
15:41:24 <rdieter> Kevin_Kofler: these options are not mutually exclusive, I'm ok with Provides: too
15:41:41 <rdieter> Err, Recommends: that is
15:42:42 <Kevin_Kofler> dvratil, ltinkl: So I take it that mixed gettext and Qt translations finally work now in kf5-ki18n world (since Qt and some Frameworks ship .qm translations now)?
15:42:50 <ltinkl> Kevin_Kofler: yup
15:43:02 <dvratil> ltinkl fixed it :)
15:43:10 <ltinkl> Kevin_Kofler: the ki18n framework preloads the global Qt QM catalog
15:43:13 <Kevin_Kofler> In KDE 4, KDE used to ship gettext translations for Qt and the .qm ones were ignored entirely, right?
15:43:24 <ltinkl> Kevin_Kofler: roughly yes
15:44:00 <ltinkl> now a KDE app (Qt in fact) will preload the Qt QM translation once it uses the KDE's own i18n() function
15:44:01 <dvratil> ltinkl: is it upstreamed already?
15:44:05 <ltinkl> dvratil: yup
15:44:27 <ltinkl> note that mixing both tr() and i18n() is not supported
15:45:06 <Kevin_Kofler> But Qt's own code is still calling tr, isn't it?
15:45:09 <ltinkl> yes
15:45:21 <Kevin_Kofler> So what do you mean by "mixing"?
15:45:38 <ltinkl> mixing as within one app
15:45:46 <ltinkl> KDE apps should still use i18n()
15:46:04 <Kevin_Kofler> All this mess because Qt had to reinvent the translation wheel instead of just using gettext as everything else in Free Software. :-( Now KDE has 2 separate translation systems. :-(
15:46:15 <ltinkl> sad but true
15:48:51 <Kevin_Kofler> Let's move on.
15:48:56 <Kevin_Kofler> #topic f22/plasma5 blockers
15:50:46 <dvratil> I have 5.2.2 ready in f22-kde -  do we want that in Fedora now, or after release?  (sorry,  bit offtopic)
15:50:53 <rdieter> have a few things still listed on tracker, need to get to fixing fast or decide they're not blockers
15:50:56 <rdieter> .bug 1135103
15:50:59 <zodbot> rdieter: Bug 1135103 Plasma 5 Tracker - https://bugzilla.redhat.com/1135103
15:51:06 <rdieter> dvratil: yes to 5.2.2 imo
15:51:42 <rdieter> apper-kf5 can be dropped, little chance of that getting fixed
15:52:02 <dvratil> We have ltinkls applet instead,  right?
15:52:07 <rdieter> I'd still like to see muon get reviewed, and consider shipping muon-discover at least
15:52:40 <dvratil> (i looked at muon over weekend, look fine,  the pk backend needs some work but shouldn't be much to get the basic updates working)
15:52:47 <rdieter> plasma-pk-updater is queue'd for -testing
15:53:07 <Kevin_Kofler> +1 to 5.2.2 from me as well, it's a bugfix release, should be 100% safe.
15:53:13 <rdieter> which I think is preferable to muon-updater, but having options is always nice
15:53:26 <dvratil> I managed to get it show me updates at least, but still failed to install them :)
15:53:32 <Kevin_Kofler> I'd like to get 5.3.0 into the final release, but that might be more of a problem.
15:53:37 <rdieter> kf5 kde-connect ... probably is nice-to-have
15:53:47 <Kevin_Kofler> It may be something for early (0-day or small-n-day) updates.
15:53:52 <jgrulich> given how simple ltinkl's applet is, it should be a problem to backport this functionality to muon
15:54:02 <jgrulich> shouldn't be
15:54:21 <rdieter> kf5 kde-print-manager, not sure if it's blocker-worthy really
15:54:38 <Kevin_Kofler> rdieter: We can split the muon package into muon-discover and muon-updater.
15:54:43 <jgrulich> rdieter: kde-print-manager should be part of KDE Applications 15.04
15:54:45 <Kevin_Kofler> Then ship only muon-discover.
15:54:46 <rdieter> Kevin_Kofler: yes, probably good idea
15:54:56 <ltinkl> ye, I was also thinking of splitting muon
15:54:59 <Kevin_Kofler> That'd also make future upgrade path handling easier.
15:55:20 <Kevin_Kofler> Right now we have the problem of migrating from one big apper package to a package manager and an updater.
15:55:20 <rdieter> jgrulich: <nod>, no one's worked on importing that yet
15:55:32 <jgrulich> rdieter: aha, I can do that tomorrow
15:55:52 <rdieter> sucker!, err... yay! :)
15:56:09 <ltinkl> ;)
15:56:39 <dvratil> We still have some KTp package reviews pending iirc that need to be done for 15.04
15:56:40 <ltinkl> we might want to pull the ki18n fix
15:56:42 <ltinkl> dvratil: ^^
15:56:57 <dvratil> ltinkl: will do
15:57:13 <rdieter> oh gosh, ktp yes
15:57:26 <ltinkl> dvratil: http://commits.kde.org/ki18n/fded87b06de0c956131b0763716b1100e46e1408
15:57:40 <rdieter> can those be added to the plasma5 tracking bug ?
15:58:04 <dvratil> They block kde-reviews
15:58:05 <rdieter> (ktp related reviews)
15:58:11 <jgrulich> I can also look at those tomorrow, so it gets resolved soon
15:58:14 <rdieter> ok, I'll find and add
15:58:32 <dvratil> I can do so when I get home
15:58:45 <dvratil> I'm not going to fight bugzilla from touchscreen :)
16:00:40 <jgrulich> dvratil: just add them to plasma5 tracking bug when you get home and I'll kill some of them tomorrow
16:00:54 <dvratil> Ack
16:00:59 * rdieter added kaccounts-* ones to plasma5 tracker
16:01:30 <dvratil> There should br signon-* too
16:03:08 <rdieter> yeah, kaccounts already depends on those
16:04:17 <Kevin_Kofler> For the summary:
16:04:21 <Kevin_Kofler> #link https://bugzilla.redhat.com/1135103
16:04:35 <jgrulich> libaccounts-glib, libaccounts-qt, signond, signon-kwallet-extension, signon-plugin-oauth2, signon-ui, kaccounts-providers, kaccounts-integration
16:04:45 <jgrulich> are all those pushed for review?
16:04:59 <dvratil> Some are already in Fedora
16:05:01 <Kevin_Kofler> jreznik also reminded us of the Beta TC testing going on:
16:05:04 <Kevin_Kofler> #link https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
16:05:25 <Kevin_Kofler> KDE doesn't have great test coverage there.
16:05:53 <jgrulich> should we also do a test day for KDE as usual?
16:06:02 <danofsatx> yes
16:06:05 <Kevin_Kofler> jgrulich: Sigh, 8 (!) packages for 1 single KTP feature. :-(
16:06:41 <dvratil> Kevin_Kofler: eventually the Kaccounts should be used more widely than just ktp
16:07:48 <Kevin_Kofler> Still, why is this split into 8 packages?
16:08:33 <rdieter> for "reasons(tm)"
16:09:39 <dvratil> Hehe, we have 70 packages for frameworks, what is 8 more :))
16:10:59 <Kevin_Kofler> This splitomania is making our packaging work a pain in the … neck. :-(
16:11:14 <Kevin_Kofler> But not much we can do about it.
16:11:22 <rdieter> having a monolithic source, and downstream splitting would be even more work, imo
16:12:53 <dvratil> Yep, this way is easier to automate :)
16:13:17 <Kevin_Kofler> Well, I'd think one library would be enough here.
16:13:25 <Kevin_Kofler> Even one single .so.
16:13:27 <Kevin_Kofler> But whatever.
16:14:24 <Kevin_Kofler> I guess I'm just thinking things in a too simplistic way and not understanding the wonderful flexibility being able to exactly choose your dependencies brings.
16:14:58 <Kevin_Kofler> So instead of depending on 1 KDE library and 49 system libraries, we now depend on only 10 system libraries and 40 KDE libraries, yay progress! ^^
16:15:05 <dvratil> Well,  you have libaccounts glib and qt split,  then signond (daemon)  and it's plugins, and signon-ui is completely different upstream,  so different project. Kaccounts merges all those together.  The only split i don't understand is the Kaccounts split
16:15:18 <Kevin_Kofler> (The 40 KDE libraries being a subset of the 100 ones the 1 old library was split into. ^^)
16:16:02 <jgrulich> can we move on? :)
16:16:07 <Kevin_Kofler> Yeah.
16:16:14 <Kevin_Kofler> We're getting off topic. :-)
16:16:14 <rdieter> moveon++
16:16:18 <Kevin_Kofler> #topic Open discussion
16:16:22 <Kevin_Kofler> Is there anything else?
16:16:49 <Kevin_Kofler> We're out of topics, except if you want me to put up the Beta TC testing as a separate topic.
16:16:52 <dvratil> jgrulich is eager to go home to watch more Arrow :))
16:17:55 <jgrulich> dvratil++
16:17:55 <zodbot> jgrulich: You have already given 1 karma to dvratil
16:18:16 <Kevin_Kofler> ^^
16:18:20 <jgrulich> dvratil: oh, I cannot give you more cookies to be quiet :D
16:18:46 <Kevin_Kofler> OK, so let's close the meeting, we're way over time already anyway.
16:18:59 <Kevin_Kofler> See you next week (unless everyone's off for Easter).
16:19:05 <Kevin_Kofler> #endmeeting