fesco
LOGS
18:00:05 <nirik> #startmeeting FESCO (2015-03-18)
18:00:05 <zodbot> Meeting started Wed Mar 18 18:00:05 2015 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:06 <nirik> #meetingname fesco
18:00:06 <nirik> #chair ajax dgilmore jwb mitr nirik paragan rishi thozza sgallagh
18:00:06 <nirik> #topic init process
18:00:06 <zodbot> The meeting name has been set to 'fesco'
18:00:06 <zodbot> Current chairs: ajax dgilmore jwb mitr nirik paragan rishi sgallagh thozza
18:00:11 <mitr> Hello
18:00:16 <paragan> Hi
18:00:37 <sgallagh> Hello
18:00:49 <jwb> i am here-ish
18:01:07 * jreznik will try to be around if needed by FESCo :)
18:01:12 <nirik> short meeting today hopefully. ;)
18:01:18 <thozza> hi all
18:01:26 * decause waves
18:01:46 <nirik> ok, lets go ahead and get started.
18:01:53 <nirik> hello decause. ;)
18:01:56 <nirik> #topic #1419 provenpackager request (FAS - nonamedotc)
18:01:56 <nirik> https://fedorahosted.org/fesco/ticket/1419
18:01:56 <nirik> .fesco 1419
18:01:58 <zodbot> nirik: #1419 (provenpackager request (FAS - nonamedotc)) – FESCo - https://fedorahosted.org/fesco/ticket/1419
18:01:58 <decause> nirik: hi there :)
18:02:10 <nirik> so, by our policy this didn't get 3 +1s in a week so it goes to meeting....
18:02:18 <nirik> sgallagh voted +1 in ticket
18:02:32 * mattdm is lurking
18:03:09 <nirik> any other votes? I'm +1 (as I was in the ticket)
18:03:39 <ajax> +1
18:03:53 <mitr> +1, considering the variety of different kinds of packages
18:04:05 <thozza> sure, I'm +1
18:04:51 <nirik> #agreed request is approved (+5, 0, 0)
18:05:05 <nirik> ok, do we want to discuss the dnf vs yum ticket? or leave it for next week?
18:05:43 <thozza> I would leave the discussion in the ticket for now
18:05:57 <thozza> I'm not sure if there is anything to discuss for F22
18:06:13 <thozza> we already agreed we don't want dnf-yum to be installed by default in F22
18:06:35 <nirik> ok, we can bring up next week if there's proposals in ticket.
18:06:37 <ajax> remind me which ticket that is?
18:06:49 <nirik> https://fedorahosted.org/fesco/ticket/1312
18:06:54 <nirik> .fesco 1312
18:06:55 <zodbot> nirik: #1312 (F22 System Wide Change: Replace Yum With DNF - http://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF) – FESCo - https://fedorahosted.org/fesco/ticket/1312
18:07:24 <thozza> ahh, there are new comments I didn't see
18:07:33 <paragan> yes there are :)
18:07:35 <nirik> lets touch on it then I suppose...
18:07:40 <nirik> #topic #1312: F22 System Wide Change: Replace Yum With DNF - http://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF
18:07:41 <nirik> https://fedorahosted.org/fesco/ticket/1312
18:07:41 <nirik> .fesco 1312
18:07:42 <zodbot> nirik: #1312 (F22 System Wide Change: Replace Yum With DNF - http://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF) – FESCo - https://fedorahosted.org/fesco/ticket/1312
18:07:48 <mitr> nirik: If we do go with the dnf-yum-in-/usr/bin/yum rote, we should do so very soon.  But that proposal has been only 5 hours ago, so getting all information an everybody involved today is probably impossible.
18:08:02 <nirik> mitr: yeah.
18:08:28 <paragan> yes if we need to propose any such changes good to implement it soon
18:08:47 <ajax> you'd think PackageKit-command-not-found would cover this already
18:08:50 <nirik> in particular I'd like to hear what the yum folks have to say...
18:09:00 <mitr> I’d say: Make sure jzeleny, dgilmore, and whoever else we can think of, is Cc:ed, ask for specific feedback on this plan, and aim to get a decision in the ticket before the next meeting.
18:09:13 <mattdm> fwiw I'm in favor of kevin/nirik's "middle ground" suggestion
18:09:49 * paragan also likes nirik's suggestion in ticket
18:10:34 <paragan> I have already asked dnf developers to CC themselves in that ticket, it was having Ales as CC
18:11:07 <nirik> if someone could point the packaging-team (who I think 'owns' yum ?) at this also that might be good...
18:11:42 <paragan> nirik, I already asked them
18:11:50 <mitr> Hum, /usr/lib/python2.7/site-packages/mockbuild/package_manager.py actually invokes the yum _command_
18:12:05 <mitr> paragan: Just edit the Cc:s directly
18:12:08 <nirik> #info please add stakeholders to ticket and see if we can gather consensus before next meeting
18:12:34 <paragan> Both rholy and jsilhan are in CC in that ticket
18:12:35 <nirik> mitr: sure, some things call /usr/bin/yum, some use a yum object...
18:12:49 <nirik> and mock has been ported. :)
18:13:05 <nirik> it's things like mash, pungi, etc... that still need work.
18:13:10 <jwb> i'm confused why this is just now coming up
18:13:29 <thozza> jwb: it did before
18:13:43 <sgallagh> jwb: It's coming up again because people started installing the Alpha
18:13:46 <nirik> jwb: someone filed a bug on the cloud image...
18:13:55 <jwb> we discussed this ticket like 3 times.  how did anyone fail to raise these concerns in a manner that made us notice and expect dnf-yum to be the default?
18:14:05 <dgilmore> sorry i am late
18:14:39 <nirik> jwb: also, the change page still says dnf-yum will be installed, I asked them to change that in the change bug... or clarify...
18:14:46 <nirik> but I guess I should just edit the wiki.
18:14:53 <mitr> jwb: IIRC the concerns have been raised but without a proposal we could either go with no dnf-yum or delay the dnf switch.
18:15:10 <mitr> jwb: Now we have a proposal, which, if it were practical, would IMHO be so much better that reopening this is well worth it.
18:15:12 <jreznik> nirik: I can poke jsilhan tomorrow, he sits a few meters away from me
18:15:28 <nirik> cool
18:15:55 <nirik> I'm fine with no dnf-yum, but it seems others dont like that.
18:16:12 <thozza> I think it makes sense to have it there
18:16:21 <jwb> the amount of waffling and back and forth is disappointing
18:16:37 <jwb> so let's figure it out and stop doing that
18:16:57 <nirik> well, I don't think I have been waffling... I just tried to come up with something that would make more people happy.
18:17:16 <dgilmore> jwb: the only way to stop the discussion for good is to say the dnf is ready and they need to follow the original plan and rename to yum
18:17:23 <jwb> nirik, none of this information is new at all.  we said we'd switch to DNF.  we knew it wasn't 1:1
18:17:41 * rishi drops in & reads back log
18:17:51 <jreznik> jwb: exactly
18:17:56 <nirik> jwb: yeah. Agreed.
18:17:58 <jwb> now we're worried about it not being called yum.  it wasn't called yum the first 3 times we talked about it
18:18:08 <dgilmore> there is so much investement in Fedora, RHEL, CentOS etc that changing the package installer/updater's name is never going to satisfy a large number of people
18:18:16 <nirik> jwb: I think there's some confusion tho about dnf-yum...
18:18:19 <mattdm> I don't think I'm waffling. And the original proposal said that it *might* be named yum.
18:18:52 <dgilmore> mattdm: the original plan years ago was for the re-write to be named back to yum when ready.
18:19:02 <rishi> Unfortunately I got to run home today. If we are going to vote on the dnf vs. yum issue, then you can assume that I am with the majority (whatever that is).
18:19:07 <nirik> the current approved change still says that dnf-yum will be used.
18:19:12 <dgilmore> the only way to not have a huge docs, mindshare etc cost is to follow that through
18:19:25 <nirik> "package 'dnf-yum' is installed by default. It obsoletes Yum and provides its own /usr/bin/yum, a short script that redirects to /usr/bin/dnf with an appropriate warning message that DNF is the preferred package manager now. Notice that upgrading F21 to F22 will not cause the compat package to be installed so will not disturb any upgrading users."
18:19:33 <mitr> jwb: Upstream doesn't really want it to be called yum, but several FESCo members do.  It is not that surprising that DNF upstream is not spending huge amount of time on making /usr/bin/yum a possibility, nor that FESCo members take time to figure alternatives out.
18:19:59 <mitr> or s/called/available as/
18:20:04 <ajax> dgilmore: some of us remember up2date...
18:20:11 <dgilmore> ajax: :)
18:20:21 <nirik> anyhow, I am +1 to no dnf-yum, I am +1 to a dnf-yum that doesn't conflict with or obsolete yum, and -1 to one that does. ;)
18:20:25 <dgilmore> ajax: it had a huge cost and there was less investment in it
18:21:44 <mitr> So, assuming we are not deciding this now, who all needs to be on Cc:?
18:21:44 <nirik> ok, so what do we want to do today?
18:22:28 <thozza> nirik: nothing I guess :)
18:22:53 <rishi> mitr: In that case, I would lean towards upstream's judgement and never install dnf-yum.
18:23:06 <rishi> "never" == "even post-F22"
18:23:51 <dgilmore> rishi: we can never say never
18:23:55 <mitr> rishi: I think I see their viewpoint but ultimately I disagree; the breakage is just not worth it (both alone, and as a precedent/reinforcing the way we do migrations)
18:24:23 <rishi> mitr: You disagree with what? Got confused.
18:25:59 <nirik> ok, lets continue in ticket I guess and see what comes up next week?
18:26:15 <ajax> yeah
18:26:17 <sgallagh> ack
18:26:30 <nirik> #info continue in ticket with proposals, etc.
18:26:33 <nirik> #topic Next weeks chair
18:26:36 <nirik> who wants it?
18:27:20 <paragan> I can next week
18:27:27 <nirik> thanks paragan
18:27:32 <nirik> #info paragan to chair next week
18:27:36 <nirik> #topic Open Floor
18:27:40 <nirik> anything for open floor?
18:28:13 <ajax> i'd like to revisit the hardening change for F23
18:28:30 * decause raises hand for next in queue
18:28:37 <ajax> i should really have been aware that it implied -z now, which is a rather drastic change
18:28:40 <nirik> ajax: ok, you want to discuss that now? or next week?
18:29:05 <ajax> nirik: just raising awareness really.  i'd like to get a concrete set of changes by next week
18:29:10 <ajax> which i'm happy to work on
18:29:25 <ajax> just want to see if that raises any red flags for anyone
18:29:39 * nirik is ok with adjusting things if we have good reason to do so.
18:29:57 <ajax> this isn't exactly apples-to-apples, but mockbuild of xorg-x11-proto-devel takes significantly longer against f23 than f22
18:30:02 <mitr> ajax: Is there a writeup anywhere of the cases that are broken by this?  ISTM that this would break mostly wrong/cyclical/unusual dependency setups (which is not to say that we would be justified in ignoring them)
18:30:30 <ajax> since the build process for that package is almost entirely the time spent executing ./configure
18:30:40 <nirik> ajax: that might also be gcc changes? one of the hardening things mentioned was gcc would be slower...
18:30:45 <nirik> ah, nevermind then
18:30:47 <ajax> it implies that we're doing a _lot_ more work on every exec, which is consistent with -z now forcing all the bindings up front
18:31:18 <ajax> so what i'd like is basically _just_ defaulting executables to PIE
18:31:36 <ajax> it wouldn't give you "full relro" as checksec.sh has it, but
18:31:55 <ajax> mitr: not as such, but i can come up with a couple.
18:32:07 <dgilmore> ajax: would we be better off moving some flags from the hardened build into the standard cflags
18:32:09 <mitr> I should also look into at least the guile issue
18:32:16 <dgilmore> and still having the hardened option?
18:32:35 <nirik> I am reminded of: http://harald.hoyer.xyz/2015/03/05/libtool-getting-rid-of-180000-sed-forks/
18:33:11 <ajax> dgilmore: basically yeah
18:33:22 <dgilmore> ajax: I would be good with doing that
18:33:31 <ajax> anyway.  i'll write it up in the ticket.
18:33:49 <ajax> hopefully with patch in hand.
18:33:58 * ajax passes the mic
18:34:06 <nirik> decause: you had something?
18:34:25 <decause> nirik: yep
18:35:44 <nirik> fire when ready. ;)
18:35:50 <decause> There is this new thing called FOSCo that is going to be spinning up over the next couple of weeks
18:36:13 <decause> in anticipation for it, we've got some infrastructure set up that I wanted to get onto your collective radars
18:36:33 <decause> there is now #fedora-outreach on freenode
18:36:47 <decause> and we just got our trac instance up at http://fedorahosted.org/fosco
18:37:18 <decause> these are the places where we'll be gathering input about (firstly) the structure of FOSCo, and then the goals/strategies/actions for the group
18:37:24 <nirik> #info FOSCo is starting up over the next few weeks. IRC: #fedora-outreach Trac/ticketing: https://fedorahosted.org/fosco
18:37:49 <nirik> cool. ;)
18:37:53 <decause> I'm still finding my way around, but thanks to threebean and lmacken I think I'm starting to tread water
18:38:08 <nirik> Anything in particular you need from FESCo at this point? or just letting us know about things...
18:39:23 <decause> nirik: mostly I'll be spending my time in the next couple of weeks listening and reading, and I would like to schedule some kind of call with FESCo folks in the near future
18:39:54 * decause has a lot of history to grok
18:40:13 <nirik> decause: ok. We are a pretty widely spread group to manage a call, but you can find most all of us on irc at various times of the day. :)
18:40:20 <decause> I'll be posting something more detailed to the mail lists in the near future, but wanted to drop by today also
18:40:33 <nirik> excellent. :) Looking forward to it.
18:40:34 <decause> s/call/irc-meeting
18:40:45 <jwb> we're here every week :)
18:40:48 <decause> :)
18:41:08 <nirik> ok, anything else decause ? or anyone else for open floor?
18:41:31 <decause> nirik: nope :)
18:42:09 <nirik> ok, will close out the meeting in a minute if nothing else.
18:43:01 <nirik> Thanks for coming everyone!
18:43:04 <nirik> #endmeeting