i18n
LOGS
06:00:02 <pravins> #startmeeting i18n
06:00:02 <zodbot> Meeting started Wed Mar  4 06:00:02 2015 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:00:06 <pravins> #meetingname i18n
06:00:06 <zodbot> The meeting name has been set to 'i18n'
06:00:09 <pravins> #topic agenda and roll call
06:00:12 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2015-03-04
06:00:14 <pravins> hi all
06:00:34 <paragan> hi
06:00:44 <mfabian> Hi!
06:00:52 <tagoh_> hi
06:00:52 <anish_> hi
06:01:11 <pravins> hi paragan mfabian tagoh_ anish_ :)
06:01:14 <epico> hi
06:01:36 <pravins> while other joins lets go through upcoming schedule
06:01:39 <pravins> #topic Upcoming schedule
06:01:41 <fujiwarat> hi
06:01:45 <pravins> #info 2015-03-10 	Alpha Release
06:01:46 <pravins> #info 2015-03-24 	Software Translation Deadline
06:01:46 <pravins> #info 2015-03-31 	Beta Freeze
06:01:46 <pravins> #info Change Checkpoint: 100% Code Complete Deadline
06:01:55 <pravins> hi epico and fujiwarat :)
06:02:57 <pravins> Next milestone is Alpha release. Freeze is already done.
06:03:05 <pravins> Fedora 22 Alpha Go/No-Go Meeting, Thursday, March 05 @ 17:00 UTC
06:03:29 <pravins> Lets move ahead and discuss other things in coming tickets.
06:03:33 <pravins> #topic Outstanding topic
06:03:36 <pravins> #info #36: gnome redesign plans for control-center Region and Languages (i18n@lists.fedoraproject.org)
06:03:39 <pravins> #link https://fedorahosted.org/i18n/ticket/36
06:03:45 <pravins> anish_: did you got reply from whot?
06:03:46 <juhp> hi
06:03:54 <pravins> hi juhp :)
06:04:13 <anish_> pravins, yeah he said it does not have any impact on x11 as such
06:04:26 <pravins> anish_: thats nice.
06:04:34 <anish_> so we can black list it
06:04:45 <pravins> do we have any other blocker?
06:05:29 <anish_> Nope prob you can close the ticket
06:06:16 <pravins> anish_:  sure, what are the next steps to get patch in?
06:06:30 <anish_> pravins, i will provide patch
06:07:26 <pravins> anish_: let it be open for one more meeting then we can close :)
06:07:36 <anish_> pravins, okay
06:07:37 <pravins> thanks anish_ for an update.
06:07:46 <anish_> pravins, thanks no problem
06:08:08 <pravins> paragan: any chance to update xkb layouts on wiki?
06:08:42 <pravins> once we update on wiki, may be we can drop an email on devel list and ask if any particular layout not in use.
06:08:45 <paragan> ah so sorry forgot about it. I will get it done now
06:08:59 <pravins> and try to black list it as well.
06:09:14 <juhp> cool
06:09:15 <pravins> hoping i am correct and that in in plan :) please correct me.
06:09:54 <pravins> lets move ahead
06:09:55 <pravins> #topic Outstanding task
06:09:58 <pravins> #info #42: Fedora 22 i18n test day (tagoh)
06:10:01 <pravins> #link https://fedorahosted.org/i18n/ticket/42
06:10:21 <pravins> thanks you all for participating in i18n test case cleaning activity last week.
06:10:51 <pravins> I think highlight of the acitivity was, we understood what is new process of updating test case results in testday app. And also gone through available test cases.
06:12:16 * pravins created testcase of Lohit_Odia change last week
06:12:40 <pravins> https://fedoraproject.org/wiki/QA:Odia
06:13:04 <pravins> anish_: mfabian should we add test cases for other change proposals as well in testday  test cases?
06:13:39 <pravins> like Minglish? NewDefaultConsoleFont and Glibc_Unicode_7
06:13:49 <anish_> pravins, good idea i will add it
06:14:13 <pravins> do we normally add change proposals test cases in test day? or is there any other way for its testing
06:14:14 <mfabian> How couild one test the new default console font?
06:14:42 <pravins> mfabian: i saw some test cases written on https://fedoraproject.org/wiki/Changes/NewDefaultConsoleFont#How_To_Test
06:14:57 <pravins> mfabian: we are also struggling for Glibc Unicode7 test cases :(
06:15:19 <mfabian> For the glibc Unicode update, the user impact is really small, I think.
06:15:35 <mfabian> The character classes like upper, lower, ... can be tested with small C-programs.
06:15:45 <mfabian> Using toupper(), ...
06:16:15 <pravins> so, we will just do the testing happened in glibc test scripts, right?
06:16:36 <mfabian> You mean the test cases in our generation scripts?
06:16:52 <tagoh_> pravins: well, it may depends on the impact but even if it's not visible or small to users, good to do it for making sure if there are no regressions with it perhaps
06:16:53 <pravins> not, the one available in glibc test suite
06:17:55 <pravins> tagoh_: sure. In that case we will add our changes to list. Wherever possible to test from users perspective.
06:18:17 <pravins> paragn: Do we need any updates to https://fedoraproject.org/wiki/QA:Langpack_Dnf_Application  and https://fedoraproject.org/wiki/QA:Langpack_Yum_Application ?
06:18:18 <tagoh_> continuing testing for each release may be different issue though.
06:18:24 <juhp> I guess everyone who runs the scripts will get same result?
06:18:38 <paragan> pravins, I think they are already updated :)
06:18:47 <pravins> paragan: great, thank you :)
06:18:58 <mfabian> http://paste.fedoraproject.org/193121/54498961/ <- something like that could be used to check whether the width and printable, upper, lower, ... has changed as intended.
06:19:52 <pravins> juhp: yes.
06:20:14 <pravins> dunno is it good to re-run same script by different users?
06:20:28 <juhp> would it make sense to run the tests as part of the glibc build (%check)?
06:20:32 <tagoh_> juhp: good point - if everything can be tested by the script and it doesn't make any different with env, we may  not need to do it for test day.
06:20:52 <pravins> yes.
06:22:03 <pravins> glibc already has good check scripts and those are already ran on our unicode7 changes.
06:22:20 <pravins> mfabian: i think, good if we just update our change proposal with results.
06:22:31 <pravins> that will be sufficient.
06:22:44 <pravins> we will skip it for test case.
06:23:10 <pravins> #agreed to skip glibc_unicode7 test case from test day as it is just re-running some scripts.
06:23:25 <mfabian> I still wonder whether the CHARMAP section in the UTF-8 file has other impacts except from printing warnings when using localedef.
06:24:31 <juhp> warnings?
06:24:54 <pravins> for now we will just mention that in change proposal.
06:25:05 <mfabian> juhp: When the source of a locale contains a character which is not listed in the UTF-8 file, localedef prints a warning that there is an unassigned character.
06:25:30 <juhp> ah
06:26:02 <pravins> not noticed any other place where it gets use.
06:26:25 <pravins> i wanted to bring up one more point in testday topic
06:26:39 <pravins> do you think it is good idea to group test case region wise?
06:26:41 <mfabian> juhp, pravins: a bit disappointing if this is the  only place where it is used ☹
06:27:04 <pravins> mfabian: agree. it can be done more better way as well.
06:27:24 <pravins> i was thinking if we can group test cases, like Generic, America, EMEA and APAC
06:27:57 <pravins> right now if i see https://fedoraproject.org/wiki/I18N/TestdayApp/F22   i do not get clear idea, how many test case make sense to me.
06:28:53 <tagoh_> pravins: what we need to separate for langs is to test engines at this moment.
06:29:02 <pravins> do you think its worth doing? or just we can add language tag before particular test case?
06:29:46 <tagoh_> I didn't see any confusion for that in the past. so that should works this time as well I suppose
06:31:20 <pravins> tagoh_: sure, may be we can just add lang tag before test case. Like ibus-bogo  is related to Vietnamese input.
06:31:24 <juhp> tagoh_, +1
06:31:24 <pravins> may be something like this?
06:31:34 <juhp> sounds good
06:32:16 <juhp> (if there were other lang specific tests we could have lang sections...)
06:33:05 <smaitra> For Indic I think, all will be more or less same. so, tagging "Indic" should be ok.
06:33:30 <pravins> yes, that will help to users at least.
06:33:39 <tagoh_> yep. okay, let's add lang like (Vietnamese) for bogo and others as well
06:34:22 <pravins> great. lets move ahead.
06:34:51 <pravins> #action if any test case is language specific, good to add tags before it.
06:35:01 <smaitra> correct
06:35:34 <pravins> i proposed badge for i18n testday https://fedorahosted.org/fedora-badges/ticket/360
06:35:36 <pravins> #link https://fedorahosted.org/fedora-badges/ticket/360
06:35:44 <pravins> but looks less chance to get it approved.
06:35:51 <bochecha> hi everyone, just happened to lurk in here and realize I didn't know there were test days for ibus engines, how can I get mine added? (ibus-cangjie)
06:36:18 <pravins> bochecha: hi
06:36:44 <pravins> see available test cases AT https://fedoraproject.org/wiki/I18N/TestdayApp/F22
06:37:12 <pravins> copy related test case and rename and modify it for ibus-cangjie
06:37:12 <tagoh_> bochecha: and you need to create the test cases to add. please see others there.
06:37:27 <bochecha> cool, will try to get to it this afternoon then :)
06:37:35 <pravins> yes. that will work.
06:37:51 <pravins> dont forget to add link back to https://fedoraproject.org/wiki/I18N/TestdayApp/F22 :)
06:38:20 <bochecha> alright
06:38:23 <bochecha> thanks!
06:38:27 <pravins> welcome :)
06:38:29 <pravins> lets move ahead
06:38:30 <pravins> #topic New topics
06:38:36 <pravins> #info #40: Fedora 22 planning (pravins)
06:38:41 <pravins> #link https://fedorahosted.org/i18n/ticket/40
06:38:56 <pravins> I think all proposed i18n changes are 100% complete.
06:39:04 <pravins> anything we missing?
06:39:31 <pravins> time to update change proposal pages.
06:40:35 <pravins> anish_: i think minglish is missed for f22 alpha freeze, right?
06:40:56 <pravins> so, one need to update for minglish testcase.
06:41:34 <anish_> pravins, ah yeah it would be in next cycle
06:41:47 <pravins> #action all change proposal owners to update Change proposal page for present status.
06:42:20 <pravins> anish_:  nice, it is also 100% complete now :)
06:42:24 <pravins> #info #43: I18n FAD in 2015 (pravins)
06:42:27 <pravins> #link https://fedorahosted.org/i18n/ticket/43
06:42:44 <pravins> please add your name to https://fedoraproject.org/wiki/FAD_I18nTeam_2015
06:43:02 <pravins> in next step i am thinking to drop an email to FPL and OSAS team for budget.
06:43:12 <anish_> pravins, cool
06:44:23 <pravins> hmm, lots of topics today :(
06:44:25 <pravins> #info #44: Fedora badge for i18n team member (pnemade)
06:44:29 <pravins> #link https://fedorahosted.org/i18n/ticket/44
06:44:42 <pravins> paragan: any further movement on this?
06:44:55 <pravins> i think we can close this ticket, no further input required from meeting.
06:45:36 <paragan> no progress. I think ticket is waiting for some designer to design badge
06:46:12 <paragan> yes you can close. We just need to to let people know of this initiative and they are knowing about this
06:46:34 <pravins> paragan: nice, thanks for taking this initiative :)
06:46:41 <paragan> np
06:46:47 <pravins> #action pravins to close #44 ticket.
06:46:53 <pravins> #topic New tasks
06:46:59 <pravins> #info #45: Docs beat for Fedora 22 (pravins)
06:47:05 <pravins> #link https://fedorahosted.org/i18n/ticket/45
06:47:13 <pravins> tagoh will be very helpful, if you can guide on this. :)
06:47:50 <juhp> pravins, FAD proposal looks nice - though how about remove "Team" from the title? :)
06:48:24 <pravins> juhp: aha, so instead of TEAM, add SIG something?
06:48:42 <anish_> SIG would be better
06:48:58 <tagoh_> https://fedoraproject.org/wiki/Documentation_I18n_Beat
06:49:05 <juhp> dunno "i18n FAD" sounds ok to me
06:49:38 <juhp> technically we are not a SIG
06:49:49 <pravins> yes.
06:49:51 <juhp> perhaps we could be
06:49:56 <paragan> I think just i18n FAD is okay
06:50:17 <juhp> just putting Team there sounds a bit exclusive :)
06:50:25 <pravins> in that case i need to create new page :)
06:50:30 <anish_> ohh okay
06:50:33 <juhp> you can rename I guess
06:50:34 * pravins will update it.
06:50:43 <juhp> cool
06:51:00 <pravins> #action pravins to rename update FAD name.
06:51:11 <tagoh_> just added a section for doc beats
06:51:22 <pravins> tagoh_: thanks you :)
06:51:22 <juhp> no ideas on date at all?
06:51:43 <pravins> juhp: we did not had discussion on date.
06:51:47 <juhp> ok
06:52:00 <pravins> we have sometime to discuss it now.
06:52:15 <juhp> sure
06:52:50 <pravins> i think good to have this before Fedora 23 release
06:53:01 <pravins> Fedora 22 release is happening on End of May
06:53:23 <pravins> Fedora 22 - 2015-05-19
06:53:42 <pravins> basically i want to say good to have this in development cycle of particular Fedora release.
06:53:54 <pravins> looks difficult to happen this now for F22.
06:54:11 <pravins> in between processing one more ticket :)
06:54:12 <pravins> #info #46: Wiki update required for yum to dnf (pravins)
06:54:12 <pravins> #link https://fedorahosted.org/i18n/ticket/46
06:54:20 <pravins> paragan: have you done with this?
06:54:54 <paragan> yes mostly added/changed yum to dnf
06:55:17 <pravins> paragan: nice, will close this after meeting.
06:55:24 <paragan> sure
06:55:25 <pravins> #topic Open Floor
06:56:01 <pravins> lets continue discussion on dates for FAD
06:56:22 <mfabian> bochecha, epico, fujiwarat: ibus-cangjie, ibus-libpinyin, ibus-anthy, and ibus-table are active again in gdm when the password is typed (in TC8).
06:56:40 <mfabian> ibus-kkc seems OK.
06:56:48 <epico> ah
06:56:58 <mfabian> What changed that this happens again?
06:57:04 <pravins> ohh
06:57:38 <mfabian> (Sorry, TC7, did not test TC8 yet but I guess it is the same).
06:58:31 <bochecha> mfabian, nothing changed in ibus-cangjie at least
06:59:24 <fujiwarat> mfabian: thx
06:59:24 <mfabian> bochecha: was ibus-cangjie OK in previous Fedora versions? ibus-table was OK in previous Fedora versions and nothing relevant changed in ibus-table, so I guess something outside must have changed.
06:59:46 <bochecha> mfabian, iirc gdm was just blocking all input sources before
06:59:54 <pravins> mfabian: yes, since its affecting all the IME's.
07:00:06 <mfabian> pravins: not ibus-kkc!
07:00:22 <bochecha> mfabian, then the plan was for ibus to emit a signal when typing in a password area, and the shell would listen on that signal and disable IMEs for password fields
07:00:26 <pravins> aha yes.
07:00:33 <bochecha> mfabian, fujiwarat or rtcm might know better
07:00:33 * pravins will test TC8 later today.
07:01:24 <pravins> Time to close the meeting. I think good to continue discussion on #fedora-i18n
07:01:35 <pravins> closing in two minutes.
07:01:42 <bochecha> wow, didn't know that channel existed :)
07:02:25 <pravins> happens :)
07:02:28 <mfabian> bochecha: ibus-table checks IBus.InputPurpose.PASSWORD in the key event handler, which used to work, but apparently doesn’t work anymore.
07:03:00 <pravins> #endmeeting