fedora-qa
LOGS
16:00:33 <adamw> #startmeeting Fedora QA meeting
16:00:33 <zodbot> Meeting started Mon Mar  2 16:00:33 2015 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:36 <adamw> #meetingname fedora-qa
16:00:36 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:41 <adamw> #topic Roll call
16:00:48 * kparal is here
16:00:52 <adamw> ahoyhoy folks, who's around for some qa...ing
16:01:01 * nirik is lurking if he can help with anything
16:01:04 * Kinokoio is here
16:01:09 * satellit listening  but have to leave early
16:01:14 * jreznik is here
16:01:22 * tflink is here
16:01:31 * pschindl is here
16:02:49 * smccann is here
16:02:56 * pwhalen is here
16:05:38 <adamw> good turnout :)
16:05:55 <adamw> #chair pschindl satellit
16:05:55 <zodbot> Current chairs: adamw pschindl satellit
16:06:08 <adamw> how's everyone doing so far this cycle? having fun?
16:06:38 <pwhalen> always :)
16:07:20 <jreznik> having fun is the only way how to survive sad world :)
16:07:56 <adamw> hehe
16:08:06 <tflink> wow, we're off to a cheerful start :)
16:08:06 * satellit_e does coconut report warnings or failed on Test results page?
16:08:12 <adamw> 'hey, if i squint a little bit these tears look like laughter!'
16:08:18 <adamw> satellit: not yet, it only reports passes
16:08:23 <satellit_e> k
16:08:28 <adamw> satellit: so far we figure it's not reliable enough to report fails
16:08:48 <adamw> (sometimes its failures are simply bad test cases or bugs in autoqa or small changes in the installer's appearance or whatever)
16:08:56 <adamw> er, openqa :)
16:09:26 <adamw> i'd like to teach it to recognize the crash screen and file a bug when it sees it, that might be on my project list for this week
16:09:41 <satellit_e> nice
16:09:57 <adamw> ok, let's have a quick impromptu coconut topic since it came up
16:10:01 <adamw> #topic Project Coconut / OpenQA
16:10:09 * Kinokoio is going to reboot, will leave kinokoio_mobile for a while
16:10:21 * roshi is here
16:10:32 <adamw> #info Coconut (the openQA-based automatic testing thing) does not report failures at present as they're too often false alarms
16:10:56 <adamw> satellit: i have my own instance of coconut up at https://openqa.happyassassin.net/ now
16:11:34 <adamw> satellit: i'm planning to have it run the test suite regularly (haven't set that up yet but I will), so you'll be able to look through its recent runs and maybe spot interesting failures and reproduce them for bug filing
16:11:53 <satellit_e> ok
16:12:25 <adamw> #info adamw has his own experimental instance of Coconut up at https://openqa.happyassassin.net/ where people can see the system in operation and maybe look for test fails that can be reported as bugs
16:12:38 <adamw> a lot of the time failures are just going to be me messing around, though :P
16:13:08 <adamw> anything else on the topic while we're at it?
16:14:07 <adamw> kparal: jskladan: any interesting news on your end?
16:14:23 <jskladan> nope, not really
16:14:30 <adamw> okey dokey
16:14:32 * kparal is only ankle's deep in openqa testing
16:14:39 <adamw> i'll send a PR for my firewall test(s) at some point
16:15:08 <roshi> can anyone submit tests to your instance adamw ?
16:15:31 <adamw> roshi: no-one but me at present, sorry
16:15:57 <adamw> i haven't entirely looked into the mechanics of safely granting perms to others yet
16:15:57 <roshi> np, just wondering if it was a means to get ones feet wet with it
16:16:13 <adamw> roshi: you can't really do much interesting messing around from the web UI only
16:16:20 <adamw> it's mostly meant as a result-viewing tool i think
16:16:36 <roshi> I didn't figure - just wondered if there was some way to submit testcases
16:16:37 <amita> hi everyone
16:16:40 <adamw> hi amita
16:16:40 <roshi> which are in perl, right?
16:16:43 <roshi> o/
16:16:55 <adamw> roshi: so what you can do is check the fedora ones out of git:
16:17:13 <adamw> https://bitbucket.org/rajcze/openqa_fedora
16:17:27 <adamw> and poke around from there...then ask me or jskladan to test them i guess
16:17:34 <adamw> or at least add them into our instance for testing
16:17:38 <adamw> it's all a bit ad hoc atm :)
16:17:56 <roshi> fair enough
16:18:06 <adamw> roshi: the tests are technically perl but really it's mostly a restricted subset which isn't horribly insane
16:18:21 <adamw> i had to go and learn some perl to submit a bugfix for openqa itself though. i'm still getting over the trauma.
16:18:25 <jskladan> as long as one sticks with the basics
16:18:58 * roshi hands adamw a cold one
16:19:06 * satellit_e it might be nice to mark which test coconut has tried  and not passed  I see it progresses thru them
16:19:08 <adamw> the hell is with all this 'shift' and '@_' crap :8
16:19:15 <roshi> we'll get through this adamw :p
16:19:18 <adamw> alllllrighty
16:19:20 <adamw> :P
16:19:27 <adamw> let's not take up too much time, moving along!
16:19:45 <jskladan> satellit_e: the thing is, that "not passed" is "failed test result" as often as "failed test execution"
16:19:51 <jskladan> so I'm not really willing to go there
16:20:02 <adamw> #topic Previous meeting follow-up
16:20:09 <jskladan> We can mark which testcases coconut tries to test, though, in some way
16:20:12 <jskladan> but not with results
16:20:17 <satellit_e> +1
16:20:46 <adamw> jskladan: we could actually do something fairly easily with extra {{result states
16:20:49 <adamw> i was already  thinking about that
16:20:50 * satellit_e like koji
16:21:16 <adamw> one thing i was thinking of was having the template know which users are bots and indicate that
16:21:26 <adamw> so results from coconut and colada would have 'BOT' in bold stuck in them somewhere
16:21:51 <adamw> and we can easily add a state like condfail or possfail or something, just a case of coming up with a sensible way to render it visually
16:22:49 <adamw> the nice thing is all the tools run off the wikitext, so we have leeway to fiddle around with the appearance of the rendered template without screwing up wikitcms or anything
16:23:37 <adamw> aaanyhoo. i really ought to've planned this meeting topic before we got here, sorry folks - let me check the last meeting log...
16:24:33 <adamw> hum, looks like we didn't really have much to follow-up on from last time
16:24:48 <adamw> am i missing anything?
16:25:00 * danofsatx has arrived
16:25:16 <roshi> hey danofsatx
16:25:31 <roshi> can't think of anything from last meeting adamw
16:27:16 <adamw> okely dokely
16:27:18 <adamw> morning dan
16:27:35 <adamw> #topic Fedora 22 status
16:27:53 <adamw> so we have blocker review coming up in a half hour and we'll go into  things there too, but always worth doing a check-in...
16:28:04 <adamw> it feels like we spent the whole of last week firefighting showstoppers, right? :/
16:28:13 <roshi> for sure
16:28:33 <satellit_e> seeing i386 lives problems in boxes  not sure it is real need more testing
16:28:58 <roshi> we got networking working in cloud images again
16:29:00 * satellit_e install and sometimes boot
16:29:03 <jreznik> how's latest TC is looking?
16:29:16 <adamw> satellit: that's the known bug IIRC
16:29:21 <adamw> TC7 doesn't have every last fix we figured out
16:29:28 <adamw> I'm planning to fire TC8 / RC1 today
16:29:34 <roshi> but direct kernel boot doesn't work anymore in the cloud images
16:30:04 <adamw> roshi: oh fun :/
16:30:12 <adamw> satellit: you're very likely hitting https://bugzilla.redhat.com/show_bug.cgi?id=1197224 , which isn't fixed in TC7
16:30:26 <satellit_e> thanks
16:30:32 <adamw> i figured people must be getting TC fatigue and it'd be kinda rude to spin a TC8 with just that fix :P
16:30:38 <nirik> so I have a quick topic... what are the chances of us getting a xfce update in before alpha? ;) I guess if rc1 goes today not too good.
16:31:12 <adamw> well, personally i'm not hugely opposed because hey, if xfce breaks it's not like we slip...but if you file/propose an FE we can discuss it in blocker review?
16:31:26 <nirik> yep. we hope to do builds today and create the update...
16:31:42 <nirik> and we need comps changes so it wouldn't happen until tomorrow.
16:31:47 <nirik> at best
16:31:51 <adamw> ok
16:31:59 <nirik> but we will do what we can
16:32:38 <adamw> roshi: so how far are we from full coverage for at least Alpha testing for cloud?
16:33:22 <roshi> well, since networking works - pretty close
16:33:29 <adamw> we haven't covered all the server testing yet which worries me a bit
16:33:33 <roshi> the only issue is local testing at this point
16:33:43 <adamw> if anyone's able to look at the non-covered server tests that'd be a big  help
16:33:53 <roshi> since most people use testCloud or the docs it's based on and create a seed.img to provide the metadata
16:33:54 <nirik> the tc7 image didn't come up right in our old cloud or our new one
16:34:14 <danofsatx> roger, I'll take the Server tests
16:34:21 <danofsatx> at least the ones I can do, anyhow
16:34:22 <adamw> thanks dan
16:34:25 <roshi> yeah, we still need to look into that - I have reports that it does work in some flavors of openshift
16:34:30 <adamw> i'm gonna try and get some done too, just the more the merrier...
16:34:50 <roshi> something isn't letting dracut see /dev/vda1 during boot for direct kernel boots
16:35:00 <adamw> we are coming up on go/no-go, so we definitely need to be aiming to cover any tests we haven't done yet
16:35:03 <roshi> and I suspect we'll need some discussion as to if that's blocking or not
16:35:10 <adamw> is it on the proposed list?
16:35:15 <jreznik> thanks for go/no-go reminder adamw
16:35:25 <roshi> no, I need to file a bug for it
16:35:31 <adamw> yeah, get it in there :)
16:36:18 <roshi> will do
16:36:24 <roshi> going to be a longer meeting today
16:36:40 <adamw> yeah, looks that way :/ lots of fun bugs
16:36:54 <adamw> anyone have any other f22 discussion topics?
16:37:09 <adamw> oh, and remember about testcase_stats , folks - https://www.happyassassin.net/testcase_stats/22/
16:37:24 <adamw> it was broken for a little while but it's working now - use it to help spot the tests we didn't run yet (or for a long time)(
16:37:50 * danofsatx was just going to ask for that link
16:38:28 <roshi> just the yum/dnf migration
16:40:37 <adamw> yah, that has its own topic
16:40:40 <adamw> which we're coming to...now!
16:41:01 <adamw> #topic Yum -> DNF test planning
16:41:09 <adamw> so many thanks to roshi for doing a preliminary overview of the scope of testing required for this
16:41:45 <adamw> #info roshi's overview of the scope of the yum->dnf migration for testing purposes can be seen at https://lists.fedoraproject.org/pipermail/test/2015-February/125166.html
16:41:50 <adamw> apologies for not replying to it yet :)
16:42:34 <roshi> no worries :)
16:42:49 <adamw> so we have to decide what our next move is
16:42:59 <adamw> jskladan: nirik: where is fesco at with the Change process right now?
16:43:11 <adamw> has the 'broadly complete and testable' check been done yet?
16:43:27 <nirik> for dnf? not sure, but I thought it was supposed to be all ready
16:43:29 <jskladan> adamw: I do not really know, maybe jreznik does ;)
16:43:36 <jreznik> adamw: https://fedorahosted.org/fesco/ticket/1416
16:43:48 <nirik> the only outstanding question was the dnf-yum thing, and they aren't going to do that part.
16:43:49 <jreznik> it's after review
16:43:55 <nirik> the change likely needs updating to note that
16:44:38 <jreznik> jskladan: me? why me? :D
16:45:32 <adamw> so as things stand the Change is going ahead as planned, right?
16:45:46 <nirik> AFAIK, except with no dnf-yum
16:45:51 <nirik> (by default)
16:45:54 <adamw> ok.
16:46:15 <nirik> and I assume dnf python2... not dnf-3...
16:46:17 <adamw> so i guess the first question is whether we're worried about that given the scope roshi identified
16:46:53 <nirik> but rawhide/f23 has moved to dnf-3
16:47:00 <adamw> or whether we want to focus on implementing as much of the test plan as possible
16:47:13 <adamw> roshi: what's your feeling?
16:49:04 <roshi> well
16:49:11 <roshi> it's a lot to test
16:49:46 <roshi> my guess would be to split up areas and have people focus down on those areas
16:49:52 <roshi> divide and conquer, if you will
16:50:07 <adamw> sounds reasonable
16:50:19 <roshi> assuming that the scope I laid out is, you know, correct :p
16:50:27 <adamw> anaconda testing looks like we're mostly going to hit in the course of regular validaiton testing
16:50:34 <roshi> I'm assuming that I missed something that's going to come back and bite us
16:50:40 <adamw> (and anything in there that *isn't in the validation tests probably should be)
16:50:41 <roshi> but that's a standing assumption
16:50:46 <adamw> roshi: oh, that's always entirely safe to assume, yeah :P
16:51:16 <adamw> to me abrt looks like something we could hit nicely with a test day
16:51:32 <roshi> for our case, are we sticking with my interpretation of which bits QA is responsible for?
16:51:40 <roshi> (release images and updates)
16:52:03 <adamw> i think it's reasonable to say those are the bits we're going to primarily *concerned* with
16:52:30 <adamw> if you get down to theoretical brass tacks about what we're allegedly 'responsible' for it might be more than that, but it's kind of pointless if we're clearly not going to have the reosurces
16:52:45 <adamw> so i'd say we try to cover this stuff first, then we can worry about more stuff if we have time, which we inevitably won't. :P
16:52:48 * satellit_e afk
16:53:00 <adamw> does that sound reasonable?
16:54:21 <roshi> sounds reasonable to me
16:54:52 <danofsatx> reasonable aye
16:56:03 * kinokoio wonders where to start
16:56:25 <roshi> which ever bit is closest to you kinokoio :p
16:57:17 <adamw> anyone have any other thoughts on this?
16:57:43 <adamw> roshi: maybe a good next step would be to break it down into actionable things, as trac tickets or phab or anything else you're comfortable with, and we can work on doing them from there
16:58:28 <roshi> sounds good
16:58:50 <roshi> #action roshi to break down the migration testing into doable chunks
16:59:00 <adamw> i don't think you have a chair do you?
16:59:01 <roshi> actually, I'm not chair I don't think
16:59:05 <adamw> #action roshi to break down the migration testing into doable chunks
16:59:15 * adamw still following the time-honored jlaska Random Chair Throwing tradition
16:59:36 <roshi> also, before we quit out - kparal had timezone questions about the slew of meetings we have monday mornings
16:59:53 <adamw> right
16:59:54 * kparal was waiting for open floor
16:59:56 <adamw> let's get to open floor quickly
16:59:59 <adamw> #topic Open Floor
17:00:09 <adamw> +1 have blocker meetings follow DST changes
17:00:16 <kparal> here's the request: https://lists.fedoraproject.org/pipermail/test/2015-March/125277.html
17:00:20 <adamw> since they're lined up with the other meetings it just makes sense.
17:00:38 <roshi> +1
17:00:46 <kparal> I also prefer following local time
17:01:08 <adamw> we'll just have to make sure we switch all three at the same time
17:01:18 <pwhalen> +1
17:01:18 <adamw> (since the actual dst switchover points tend to vary between countries)
17:01:54 <adamw> anyone opposed?
17:01:56 <tflink> true, but I also think we should just pick something and stick with it
17:02:06 <adamw> tflink: how do you mean?
17:02:28 <tflink> adamw: one time to switch, which I suspect is what you meant
17:02:29 <kparal> we always followed north america summer switch time for QA meetings, so I think it makes sense to stick with it for all meetings
17:02:45 <adamw> ah i see. yes
17:03:12 <roshi> makes sense to me
17:03:16 <tflink> I think we've usually followed NA DST in the past (I think all of NA switches at the same time)
17:03:16 <adamw> even within NA I'm not sure it's the same everywhere...but let's just say whoever announces a meeting with the switch first, we switch all the others at the same time :)
17:03:22 * roshi hates the spring timechange
17:03:39 <adamw> and try to get that week's announcements out nice and early
17:03:44 <adamw> (like i always don't)
17:03:54 <kparal> all our meetings except blocker bug are tied to New York timezone in fedocal
17:04:01 <kparal> I can adjust blocker bug meeting to the same
17:04:15 <adamw> sounds fine
17:04:25 <kparal> just make sure to mention it in the next announcement
17:04:26 <kparal> thanks
17:04:32 <adamw> #agreed blocker review meetings will move with DST changes as the other two meetings do
17:04:52 <adamw> #action kparal to adjust fedocal to tie blocker review meetings to New York DST (as the other two are)
17:05:02 <adamw> alrighty, anything else? if not let's move right on over to #fedora-blocker-review :)
17:05:15 * adamw sets the Acme Necessarily Short Fuse
17:05:24 <roshi> I propose a 10 minute coffee break before we start the blocker review
17:05:32 <roshi> since I have to make coffee :)
17:05:32 <adamw> pfeh, if you must :P
17:05:37 <adamw> so XX:15 ?
17:05:53 <roshi> ack
17:05:58 <Corey84> i'm game for :15
17:06:09 <roshi> and we can give warning to other channels since I haven't yet
17:06:13 <pwhalen> wfm
17:06:25 <kinokoio> blocker review is in this channel?
17:06:39 <roshi> kinokoio: #fedora-blocker-review
17:06:45 <danofsatx> yeah ^^
17:06:52 <danofsatx> roshi types faster than me
17:07:12 <adamw> alriiiighty then
17:07:13 <kinokoio> thanks
17:07:52 * adamw wonders if it's possible to draw a point in time at which the cultural zeitgeist switched from Carrey to McConnaghoweveryouspellit
17:08:24 * danofsatx looks askew at adamw
17:08:35 <adamw> danofsatx: 'well alllriiiiighty then!' to 'alright alright alright'
17:08:51 <adamw> IT IS THE KEY QUESTION OF OUR TIMES
17:09:10 <danofsatx> if you say so. Is the fuse set yet?
17:09:53 * adamw checks fus-
17:09:54 * kparal has adjusted fedocal
17:09:56 <adamw> #endmeeting