fedora_base_design_working_group
LOGS
15:00:50 <haraldh> #startmeeting Fedora Base Design Working Group (2015-02-27)
15:00:50 <zodbot> Meeting started Fri Feb 27 15:00:50 2015 UTC.  The chair is haraldh. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:54 <haraldh> #meetingname  Fedora Base Design Working Group
15:00:54 <zodbot> The meeting name has been set to 'fedora_base_design_working_group'
15:01:06 <haraldh> ping jreznik dgilmore vpavlin pknirsch masta dwalsh
15:01:11 <pknirsch> present :)
15:01:23 <haraldh> #chair haraldh pknirsch
15:01:23 <zodbot> Current chairs: haraldh pknirsch
15:02:21 <haraldh> hmm
15:02:41 <pknirsch> :)
15:02:57 * jreznik is here
15:03:06 * haraldh goes and grabs a fresh cup of coffee.
15:03:14 <haraldh> #addchair jreznik
15:03:20 * jreznik needs tea
15:03:33 <haraldh> #chair jreznik haraldh pknirsch
15:03:33 <zodbot> Current chairs: haraldh jreznik pknirsch
15:07:52 <haraldh> wow.. I think we can skip this meeting then..
15:08:16 <jreznik> pknirsch: good to still see you here!
15:08:27 <haraldh> ping dgilmore vpavlin masta dwalsh
15:08:27 <jreznik> haraldh: thanks for the replacement call on the list
15:08:56 <haraldh> so, it's me here, and two members, who want to leave :)
15:09:03 <haraldh> success
15:09:05 <pknirsch> :)
15:09:21 <haraldh> well, then I'll run the show :)
15:09:30 <pknirsch> wohoo!
15:09:31 <haraldh> Mr Base
15:09:42 <haraldh> It's all about that base
15:10:15 <pknirsch> do you shake your stuff, too? ;)
15:10:18 * pknirsch runs
15:11:00 <Rathann> it was suggested that an FPC member would be useful to have here
15:11:26 <Rathann> so while I can't devote too much time, I'm open to joining if there are no other volunteers
15:12:10 <haraldh> Rathann, :-)
15:13:25 <haraldh> #topic New members for the Base Design Working Group
15:14:00 <haraldh> #info Rathann  applies for membership
15:14:15 <haraldh> jreznik, so, you want to leave definitely?
15:14:29 <haraldh> pknirsch, and you? voluntarily be part of it?
15:14:50 <haraldh> pknirsch, or do you want to have your Fridays off early? :)
15:15:17 <haraldh> Rathann, thanks for wanting to join
15:15:18 <jreznik> well, it depends, if we would need both two seats and we would have good candidates, I'll leave
15:15:58 <haraldh> So, pknirsch: do you have any candidates, which were not chosen in the first run?
15:15:59 <jreznik> and I'm not saying I do not like you guys :)
15:16:07 <haraldh> :)
15:16:19 <jreznik> fpc member in base is a great idea
15:16:46 <haraldh> pknirsch, http://s677.photobucket.com/user/thisismusicltd_bucket/media/disco-stu.gif.html btw
15:17:55 <pknirsch> well, i'd like to fly low for a while, focus on my personal stuff for a bit. I may come back to work more on Fedora and Base again, but no promises
15:20:01 <dgilmore> hey haraldh
15:20:16 <haraldh> #chair jreznik haraldh pknirsch dgilmore
15:20:16 <zodbot> Current chairs: dgilmore haraldh jreznik pknirsch
15:20:53 <haraldh> <haraldh> So, pknirsch: do you have any candidates, which were not chosen in the first run?
15:21:09 <Rathann> so having said that, I have to leave now, but I'll read the log later
15:21:12 <Rathann> if you have other candidates, do let them join first
15:21:27 <haraldh> Rathann, I doubt it.. but have a nice weekend
15:21:34 <Rathann> also, if you have any questions, I can answer via e-mail or later on IRC
15:21:38 <haraldh> ok
15:21:42 <haraldh> thx
15:21:43 <haraldh> !
15:21:47 <Rathann> you're welcome
15:21:49 <pknirsch> hm, good question haraldh. I don't think there were any left over candidates though, lemme check
15:23:22 <haraldh> so, any other candidates here for the base design wg?
15:24:23 <pknirsch> haraldh: check https://fedoraproject.org/wiki/Fedora.next/WG_Nominations
15:24:33 <haraldh> thanks!
15:24:35 <pknirsch> Maybe there are a few left that would still be interested
15:24:53 <haraldh> #topic Vote for new chairman of the Base Design WG
15:25:07 <pknirsch> harald +1 :P
15:25:12 <haraldh> :)
15:25:26 <haraldh> msekleta also had a +1
15:25:37 <haraldh> dgilmore, jreznik ?
15:25:49 <dgilmore> i am +1 for haraldh
15:26:08 <jreznik> +1 for haraldh, hail to the chair
15:26:14 <haraldh> :)
15:26:16 <pknirsch> hail to the new leader!
15:26:18 * pknirsch bows
15:26:19 <haraldh> 4/7
15:26:23 * masta is here
15:26:40 <haraldh> #chair jreznik haraldh pknirsch dgilmore masta
15:26:40 <zodbot> Current chairs: dgilmore haraldh jreznik masta pknirsch
15:26:50 <masta> + Harald
15:26:55 <haraldh> 5/7
15:27:11 <haraldh> dwalsh and vpavlin are missing
15:27:12 <masta> thx pknirsch
15:27:21 <haraldh> yeah, thank you pknirsch
15:27:48 <haraldh> pknirsch, maybe you can send me any missing infos you have before you leave about the base design WG
15:27:52 <pknirsch> thank you guys! keep up the flag for base and clean up stuff :)
15:28:18 <haraldh> #info haraldh accepted as new chairman with 5 of 7 votes
15:28:41 <haraldh> #accepted haraldh
15:28:54 <haraldh> #topic Open Floor
15:29:05 <haraldh> thanks for your vote
15:29:38 <pknirsch> haraldh: most of it is really codified in the Base wiki and been discussed during our meetings. The main topics right now are still the cleanup that daso and nphilipp are working on from what i tracked and the changes in the future with docker and atomic and some of the image ownerships
15:29:49 <pknirsch> no hidden sikrits at least from what i can recall
15:29:49 <haraldh> next week I like to bring up a follow up the "reproducible builds" discussion on devconf
15:30:13 <haraldh> also a followup on the new rpm tags (recommends suggests)
15:30:49 <dgilmore> haraldh: meeting time with DST
15:30:52 <haraldh> my goal is to have  "reproducible builds" at least for the minimal base
15:30:59 <haraldh> dgilmore, good point
15:31:07 <masta> haraldh: you had a script at one point that ran a dependency graph & generate dot files for visualizing. Are you still maintaining those? I'd like to run those periodically
15:31:29 <haraldh> dgilmore, also we may want reevaluate the time of this meeting
15:31:31 <haraldh> and day
15:31:33 <dgilmore> haraldh: us DST starts March 8 here
15:32:01 <haraldh> masta, https://harald.hoyer.xyz/2014/01/14/self-hosting-fedora-base/
15:32:08 <haraldh> masta, all info should be in there
15:32:10 <dgilmore> haraldh: mikem and I talked to the guy doing reproducable builds at fosdem
15:32:22 <haraldh> ah, cool
15:32:25 <dgilmore> haraldh: we have most of the changes they have had to do
15:32:29 <haraldh> I missed that talk :-(
15:32:33 <dgilmore> koji has done it since day 1
15:32:48 <haraldh> hopefully the video is availble
15:32:59 <dgilmore> the thing where there is issues is when upstreams do things that inject build time in
15:33:19 <haraldh> or build tools
15:33:21 <haraldh> or gzip
15:33:24 <haraldh> or cpio
15:33:24 <dgilmore> debian at teh last has done a bit of work in getting upstreams fixed tehre
15:33:44 <haraldh> timestamps in documentation
15:33:53 <dgilmore> yep
15:33:53 <haraldh> labels in documentation
15:34:12 <dgilmore> there is things we can do better in
15:34:23 <dgilmore> but we have a lot of what we need already in place
15:34:33 <haraldh> cool
15:34:40 <haraldh> lets make a check list, what is missing
15:34:59 <dgilmore> mikem was very interested in it
15:37:04 <haraldh> also the bootstrap build for new archs
15:37:27 <haraldh> will show, what has to be done for minimal builds
15:38:28 <haraldh> http://developerconference2015.sched.org/event/bc305973fe23d9e723a777c9c4f24b57#.VPCPcbvopH4
15:39:10 <haraldh> Maybe I can invite some more people
15:39:30 <haraldh> so we can work out an action plan
15:40:25 <dgilmore> having bootstrapped fedora a couple of times I know the pain
15:40:52 <haraldh> http://developerconference2015.sched.org/event/11e9e2f0e59d450c05b4c56d07d8cfe7
15:41:12 <haraldh> I will have to ask ffesti about any further outcome of his workshop
15:41:28 <haraldh> just mentioning it here, so that I don't forget
15:42:06 <dgilmore> :)
15:42:37 <haraldh> [FOSDEM 2014] Reproducible Builds for Debian  https://www.youtube.com/watch?v=E-YYKdtjsmI
15:43:27 <haraldh> https://fosdem.org/2015/schedule/event/stretching_out_for_trustworthy_reproducible_builds/
15:43:46 <haraldh> dgilmore, ^ was that the talk?
15:44:35 <dgilmore> haraldh: yes
15:44:45 <dgilmore> I have had a few emails with the guy since
15:45:25 <haraldh> nice
15:45:48 <haraldh> so, if there are no other topics, I'll close this meeting
15:45:56 <pknirsch> o/
15:46:04 <pknirsch> thanks haraldh !
15:46:05 <haraldh> at least we have some topic for next time
15:46:10 <haraldh> pknirsch, welcome
15:46:18 <haraldh> pknirsch, have a good time!!!!!
15:46:21 <pknirsch> and good luck guys! it's been a blast the past 14 years :)
15:46:26 <haraldh> pknirsch, and thanks for the fish!
15:46:31 <pknirsch> :)
15:46:37 <pknirsch> and keep your towels!
15:46:40 <haraldh> pknirsch, 14 years..
15:46:44 <haraldh> omg
15:46:48 <pknirsch> :)
15:46:51 * haraldh feels old.
15:47:01 <pknirsch> Ich sach nur "BOA" ;P
15:47:08 <haraldh> :-P
15:47:17 <haraldh> #endmeeting