fedora_docs
LOGS
14:01:07 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:01:07 <zodbot> Meeting started Mon Jan 12 14:01:07 2015 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:01:07 <randomuser> #meetingname Fedora Docs
14:01:07 <randomuser> #topic Roll Call
14:01:07 <zodbot> The meeting name has been set to 'fedora_docs'
14:01:24 <pkovar> /me is here
14:01:26 <randomuser> #chair pkovar
14:01:26 <zodbot> Current chairs: pkovar randomuser
14:01:52 * rkratky is here
14:02:20 <randomuser> #chair rkratky
14:02:20 <zodbot> Current chairs: pkovar randomuser rkratky
14:03:24 <pbokoc> .
14:04:00 <randomuser> #couch pbokoc
14:04:20 <pbokoc> you know me so well
14:04:29 <randomuser> :)
14:06:57 <randomuser> #topic Follow up on action items
14:07:25 <randomuser> Looks like I was supposed to republish release notes and send an email
14:08:08 <randomuser> hm.. and I republished the IG instead, and sent other emails.
14:08:22 * randomuser groans
14:08:47 <pbokoc> haha nice
14:08:48 <randomuser> #action randomuser to ask for writers to participate in working groups
14:09:17 <randomuser> #topic New Writers
14:09:31 <randomuser> any new writers around today?
14:09:52 <kvaldivia> yes, I am
14:10:00 <randomuser> hello, kvaldivia !
14:10:06 <kvaldivia> hello
14:10:13 <pbokoc> hi :)
14:10:27 * lnovich runs in and grabs a chair
14:10:36 <lnovich> hi!
14:10:42 <randomuser> #bench lnovich
14:11:05 <kvaldivia> hello everyone =)
14:11:24 <randomuser> kvaldivia, have you had a chance to skim over our intro wiki pages, or the documentation guide, yet?
14:11:36 <randomuser> any questions while we're all here?
14:12:43 <kvaldivia> randomuser, yes, I had, I also send an email for self-introduction to the mailing list
14:12:49 <kvaldivia> sent*
14:13:17 <randomuser> yes, and I like your enthusiasm
14:14:35 <randomuser> Please feel free to bring up any questions you develop in #fedora-docs or on the mailing list, we want to see you succeed
14:14:54 <kvaldivia> thanks
14:15:08 <randomuser> if you are more comfortable contacting someone individually, there is a list of mentors at http://fedoraproject.org/wiki/Docs_Project_mentors
14:16:13 <randomuser> some people worry about asking foolish questions - don't!  even questions with answers that seem obvious to us will still let us know where there is room for improvement in the introductory info we provide
14:16:40 <randomuser> okay, enough putting you on the spot :)
14:16:50 <randomuser> #topic F22 Schedule
14:17:01 <randomuser> #info Change Proposals for F22 have started
14:17:31 <randomuser> there are some interesting ones, especially if you've been following along with the stateless systems work for systemd
14:17:57 <pbokoc> the factory reset thing?
14:18:12 <randomuser> According to the schedule, https://fedorapeople.org/groups/schedule/f-22/f-22-docs-tree-tasks.html , we are in free play time now
14:18:20 <randomuser> pbokoc, yeah, that one
14:18:23 <pbokoc> I heard people whine about that
14:18:59 <randomuser> I like the idea of a predictable division between packaged /usr/ and /etc/, personally
14:19:10 <randomuser> with nice friendly admin overrides in the latter
14:20:48 <randomuser> So now is a good time for cleanup type work, but also keep track of what's happening on devel@, if you have time
14:21:03 <pbokoc> yeah, I should write the upgrade chapter
14:21:14 <pbokoc> or if someone else wants to do that... :)
14:21:23 <pbokoc> wink wink
14:21:39 <pbokoc> oh, and ARM
14:21:40 <pbokoc> damnit
14:22:10 <randomuser> good timing, talking about upgrade docs just as wwoods joins
14:22:18 <randomuser> :P
14:23:05 <randomuser> It might be a good idea to approach the ARM sig and just ask what we can do to enable them
14:23:29 <randomuser> so it's easier for them to document what they're doing in a digestable way
14:24:40 <randomuser> if they want to do a defined set of wiki pages or markdown in git or whatever, we can convert and mark up, but 'it would be nice to...' doesn't get much traction
14:26:14 <randomuser> #topic Publican & Publishing
14:26:30 <randomuser> #info randomuser has no new information for this week on the topic
14:26:46 <randomuser> jsmith, did you happen to spend any time on it?
14:27:51 <randomuser> well, let us know
14:28:06 <randomuser> #topic fedora.next product updates
14:28:35 <randomuser> the big thing in this area is getting writers hooked into the various working groups
14:29:01 <randomuser> pkovar, you're still playing along with envs-and-stacks, right?
14:29:52 <randomuser> #link http://fedoraproject.org/wiki/Fedora.next
14:32:09 <randomuser> #info docs people should follow along with the various working groups so we know what's going on, volunteers needed
14:32:23 <randomuser> #topic Guide Status
14:33:42 <randomuser> I merged in roger's branch of the multiboot guide, and spent a little time reviewing it
14:33:53 <randomuser> and added an entry-level FAQ
14:33:57 <pbokoc> cool
14:34:22 <pbokoc> also what's with the orphaned (or not?) virt guides? I saw something on the list and Laura is here :)
14:34:37 <randomuser> #info questions from new user perspective for multiboot FAQ welcome
14:34:51 <randomuser> oh, good call
14:35:07 <randomuser> lnovich, can you speak to the status of any virt guides?
14:35:44 <lnovich> I am embarrassed to admit that I can't speak of any of the guides - none of the authors seem to be able to contribute
14:36:09 <lnovich> and I am not sure how to handle the situation
14:36:33 <lnovich> I would rather someone who can take over, and I do something that isn't so time crucial
14:37:06 <randomuser> lnovich, perhaps something more scope-limited would be better?
14:37:19 <lnovich> any suggestion is welcome\
14:37:25 <pkovar> in that case we should probably mark the guides as unmaintained in the guide table
14:37:28 <lnovich> at the moment there is a large gap
14:37:33 <pkovar> that could attract new contributors
14:37:49 <pkovar> also, we should mark them as read-only in zanata
14:38:01 <pkovar> so that translators don't waste their time on them
14:38:02 <randomuser> keeping the virt getting started guide going would be less effort than the whole set
14:38:12 <randomuser> pkovar, I thought that was done?
14:38:37 <pkovar> randomuser: was it? i haven't checked yet
14:39:03 <randomuser> I'm just recalling the mails, I haven't checked in zt
14:39:12 <lnovich> the issue is that the guide is out of sync
14:39:17 <lnovich> all of them are
14:39:34 <lnovich> they would need to be brought up to speed
14:40:43 <randomuser> and noone to do it, hrm
14:40:55 <lnovich> i am hoping to be able to get some time in at the end of the month, but I can't be certain
14:41:39 <randomuser> lnovich, would it compound your embarrassment to send a status mail to the list, so we can sort out a plan there?
14:41:55 <lnovich> i guess it can't get much worse
14:42:00 <randomuser> hehe
14:42:46 <lnovich> if I wasn't on 2 projects at the moment already I would gladly be able to contribute I just simply didn't realize how much time would pass until I had free time.
14:43:17 <randomuser> NOt having time for it is understandable, I worry more about people not working on things because they presume someone else has it covered
14:43:32 <lnovich> which is why my meeting attendance has been lacking lately
14:43:56 <lnovich> so sure - if we can get someone on it - please I am willing to give all the content I have
14:44:08 <randomuser> okay, cool
14:44:47 <randomuser> #action lnovich to send virt guide status mail
14:44:50 <lnovich> and if you need someone to QA or edit / review - then that would probably be better for me at the moment
14:45:03 <randomuser> work for you, and we can continue the discussion there?
14:45:29 <lnovich> sure I'll send an email - which list?
14:45:42 <randomuser> docs@lists.fedoraproject.org please
14:45:58 <lnovich> ok consider it done
14:46:02 <randomuser> thanks
14:46:24 <randomuser> #topic outstanding bz tickets
14:46:35 <randomuser> #link http://tinyurl.com/lbrq84
14:46:40 <randomuser> there are bugs
14:47:14 <randomuser> bah - a guide thing I didn't file a bug on, but am reminded of now
14:47:49 <randomuser> pbokoc, we need to find someone to verify the option arch stuff works properly, ideally an SME and someone with the hardware
14:48:35 <randomuser> I dumped packets from my machines' dhcp request, it isn't doing EFI PXE and it doesn't look like there's a straightforward way to add a boot entry for that
14:48:49 <pbokoc> randomuser, you mean in DHCP configs in the pxe chapter? So you can use one config for multiple arches, and select the appropriate one based on who's asking?
14:49:00 <randomuser> yes, that bit
14:49:02 <pbokoc> right
14:49:24 <pbokoc> yeah, that's a bit complicated
14:49:48 <pbokoc> I can try a few people, but no promises
14:49:51 <randomuser> I probably *could* add an entry, if I knew how to find the ACPI address of the NIC, but ran away screaming after 30 minutes of reading ACPI reference documentation
14:50:00 <pbokoc> haha, yeah
14:50:35 <randomuser> if all else fails, maybe open a bug with our copy in the body, and needinfo the dhcp maintainer
14:51:13 <pbokoc> alright
14:51:19 <randomuser> pbokoc, there's also a bug cited in the dhcp changelog that's blocked to me but seems relevant
14:51:57 <randomuser> Sparks could probably tell us if it's important, if you can't see it
14:51:59 <pbokoc> #action pbokoc to find out how to make a multiarch DHCP config for PXE boot
14:52:12 <pbokoc> randomuser, got a link?
14:52:24 <randomuser> .bz 1129500
14:52:31 <randomuser> ... i think
14:52:56 <randomuser> no, hang on
14:52:58 <pbokoc> oh that just makes my head hurt
14:54:02 <randomuser> https://bugzilla.redhat.com/show_bug.cgi?id=1058674
14:54:45 <pbokoc> hmmm
14:55:25 <pbokoc> well, that's a specific DHCP UUID, unique to every system, not about arch identification
14:55:33 <pbokoc> option 97 in http://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xhtml
14:56:03 <randomuser> ah, right, pxe-client-id not pxe-system-id or whatever
14:56:32 <pbokoc> yeah, we should worry about option 93
14:56:35 <randomuser> what confuses me is that there's this list of options in dhcp.git/common/tables.c that I can't just use in 'options' directives
14:57:01 <pbokoc> I mean, having a config for specific systems instead of groups of systems could be cool, too, but I'd focus on the architectures, that sounds useful to more people
14:57:35 <randomuser> yeah; mac address matching even is usually going to be more palatable than GUID matching
14:57:47 <pbokoc> true
14:58:06 <randomuser> although, if you do use the GUID, tftp requests happen really fast because it's the first thing the system requests
14:58:43 <randomuser> anyway, we have a semblance of a plan there
14:58:47 <randomuser> #topic open floor
14:59:13 <randomuser> time for two minutes of uninhibited discussino
14:59:55 <pbokoc> discussino sounds like a kind of coffee for philosophy majors
15:00:47 <randomuser> heh
15:00:51 <randomuser> #endmeeting