fesco
LOGS
18:00:06 <nirik> #startmeeting FESCO (2014-12-17)
18:00:06 <zodbot> Meeting started Wed Dec 17 18:00:06 2014 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:06 <nirik> #meetingname fesco
18:00:06 <nirik> #chair dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh stickster t8m thozza
18:00:06 <nirik> #topic init process
18:00:06 <zodbot> The meeting name has been set to 'fesco'
18:00:06 <zodbot> Current chairs: dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh stickster t8m thozza
18:00:19 <sgallagh> .hello sgallagh
18:00:19 <nirik> who all is around today?
18:00:20 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:00:28 <kushal> .hellomynameis kushal
18:00:29 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
18:00:38 <dgilmore> hey
18:00:45 <jwb> hello
18:01:11 <thozza> hi all
18:01:38 <mattdm> hi!
18:01:52 <nirik> looks like we do in fact have quorum today. ;)
18:01:54 <kalev> hi all
18:01:59 <thozza> I'll have to leave in an hour
18:02:18 <thozza> but I think we can make it till then
18:02:19 <nirik> ok, lets go ahead and dive in then....
18:02:22 <nirik> #topic ticket #1349	Fedora 22 scheduling strategy (and beyond)
18:02:22 <nirik> .fesco 1349
18:02:24 <zodbot> nirik: #1349 (Fedora 22 scheduling strategy (and beyond)) – FESCo - https://fedorahosted.org/fesco/ticket/1349
18:02:30 <nirik> any further thoughts or actions on this?
18:02:47 <mattdm> Phoronix tells me that there's a draft schedule in place :)
18:03:17 <nirik> yeah, we decided that 2 weeks ago...
18:03:31 <nirik> roughly may release and a deadline for changes I guess.
18:03:33 <jreznik> I don't think if there's more
18:03:54 <jreznik> at least not now unless we decide to change deadlines/freezes somehow
18:04:00 <kushal> nirik, https://fedoraproject.org/wiki/Releases/22/Schedule?rd=Releases/22 this one?
18:04:02 <jreznik> changes are already in progress
18:04:10 <mattdm> kushal: yeah
18:04:21 <nirik> right
18:04:57 <sgallagh> jreznik: Since it worked well for F21 Final, could we try to codify a two-week freeze for every milestone?
18:05:57 <dgilmore> sgallagh: I do not think it really worked well for f21 final
18:05:57 <nirik> sgallagh: you mean 3 week
18:06:06 <nirik> ?
18:06:24 <sgallagh> dgilmore: We didn't have to slip and we had more time between QA catching bugs and Go/No-Go.
18:06:28 <jreznik> sgallagh: I don't think it was that difference, the real difference was earlier testing/TCs
18:06:33 <sgallagh> I got the impression it was generally well received
18:06:46 <nirik> yeah, diving right into tc's helped I think.
18:06:57 <sgallagh> jreznik: Right, but without a freeze, earlier testing isn't always going to be useful
18:07:03 <jwb> sgallagh, i think it was received well by QA
18:07:12 <nirik> if in f22 we can get to the point of basically full composes nightly, that might help out.
18:07:13 <jwb> i'm not sure anyone else commented either way
18:07:17 <dgilmore> sgallagh: i do not think that was because of the extra week of freeze, and we still came very close to slipping and did not get out of QA having to do hero work
18:07:32 <dgilmore> sgallagh: i am not saying its a bad thing, just that it really did not work well
18:07:38 <jreznik> sgallagh: post beta, there are usually not many changes... and we try to limit freezes to minimum but ask folks to be responsible
18:08:02 <sgallagh> jreznik: "post beta, there are usually not many changes" would be nice if it was true...
18:08:23 <dgilmore> there was way too much invasive change post beta in f21
18:08:40 <nirik> biggest win might be doing full anaconda testing pre-alpha/beta so we identify blockers there and they have time to fix up things...
18:08:55 <dgilmore> I am not opposed to having the extra week of freeze
18:09:13 <dgilmore> nirik: right
18:09:23 <dgilmore> more complete and earlier testing
18:09:27 <sgallagh> nirik: Absolutely, and that's been agreed between the anaconda and QA folks as of last week
18:09:32 <nirik> yep.
18:09:45 <jreznik> sgallagh: but changes that would go in even with freeze or without as it was considered "as the must"
18:09:48 <sgallagh> Turns out that there was an old misunderstanding that was the reason some tests didn't happen until Beta or Final freeze
18:09:49 <nirik> so, I don't think another week of freeze will help. :)
18:10:05 <jreznik> nirik: me neither
18:10:09 <dgilmore> me either
18:10:13 <sgallagh> ok
18:10:41 <sgallagh> If we can *actually* get earlier testing and contributors to respect the meaning of the phases, I'm all for it.
18:10:59 <sgallagh> (And yes, I realize I am personally guilty of post-Beta changes for the branding stuff)
18:11:13 <nirik> just eariler anaconda testing/fixes and having nightly full composes I think will be a big win over 21.
18:11:24 <jreznik> sgallagh: we have pretty early testing but we can't force qa to death by constant testing
18:11:26 <nirik> well, and basically knowing what we are making which we didn't really starting in on f21.
18:11:37 <dgilmore> sgallagh: you were by far the biggest offender in f21
18:11:48 <jreznik> btw. early freeze means huge untested zero day updates...
18:12:36 <nirik> anyhow, proposal: keep ticket open to revisit in early jan meeting, move on for now.
18:12:43 <sgallagh> Fine
18:13:13 <dgilmore> nirik: +1
18:13:25 <jwb> nirik, sure
18:13:49 <thozza> nirik: +1
18:14:04 <kalev> +1
18:14:29 <nirik> #agreed keep ticket open for early jan meeting. (+6,0,0)
18:15:10 <nirik> #topic ticket #1370	requesting exception for linking include-what-you-use with llvm-static
18:15:11 <nirik> .fesco 1370
18:15:12 <zodbot> nirik: #1370 (requesting exception for linking include-what-you-use with llvm-static) – FESCo - https://fedorahosted.org/fesco/ticket/1370
18:15:36 <kalev> might make sense to redirect this to FPC
18:15:44 <nirik> we already did that.
18:15:45 <thozza> kalev: we already did
18:15:54 <nirik> but the issue is that this is not a bundling request
18:15:59 <nirik> it's a static linking request
18:16:07 <nirik> which currently fesco is supposed to approve.
18:16:17 <jwb> and i still think is fine
18:16:45 <nirik> so, we could just approve it, or we could decide fpc needs to approve these moving forward or both.
18:16:59 <kalev> not sure fesco can do much here besides approve it, we don't really have anyone working on llvm
18:17:05 <mattdm> does FPC _want_ to approve these?
18:17:15 <mattdm> or disapprove them, whichever?
18:17:17 <jwb> let's just approve it and revisit the FPC part in january
18:17:20 <nirik> mattdm: they didn't say so either way.
18:17:26 <nirik> +1 approve
18:17:37 <kalev> +1 approve
18:17:58 <thozza> +1 approve
18:18:01 <dgilmore> +1 approve
18:18:59 <mattdm> +1 approve, then
18:19:07 <nirik> #agreed static linking approved (+6,0,0)
18:19:33 <nirik> #topic ticket #1372	"Workstation" Product defaults to wide-open firewall
18:19:34 <nirik> .fesco 1372
18:19:35 <zodbot> nirik: #1372 ("Workstation" Product defaults to wide-open firewall) – FESCo - https://fedorahosted.org/fesco/ticket/1372
18:19:43 <nirik> so, several stakeholders are not going to be here today.
18:19:48 <nirik> proposal: defer to january
18:19:52 <jwb> +1
18:19:54 <thozza> nirik: +1
18:19:55 <kalev> +1
18:20:01 <dgilmore> +1
18:20:03 <mattdm> I'm okay with defering but I wanted to note something....
18:20:08 <kalev> although I'd like to mention something too
18:20:13 <mattdm> The request strongly implies that something nefarious is going on
18:20:15 <nirik> sure.
18:20:25 <thozza> mattdm: I think it would be best to note in the ticket for everyone
18:20:44 <mattdm> The previous FESCo decision was to ask the WG to come up with a resolution based on the contingency plan.
18:20:47 <mattdm> That's exactly what happened.
18:21:07 <mattdm> And even for people who missed it, that's easy to see with a little research.
18:21:10 <nirik> FWIW, my opion is: I don't feel any need to override the excellent workstation working group here, nor do a feel it's a particuarly concerning security issue.
18:21:16 <kalev> I'd suggest that this falls strictly in the Workstation WG territory and it might make sense to pass this ticket on to them
18:21:30 <kalev> what nirik said :)
18:21:33 <mattdm> So I'm disappointed and frustrated by the tone.
18:22:11 <Mohamed_Fawzy> hi all am I late to the meeting
18:22:12 <nirik> That said, I think they are in their rights to ask us to override, we are just as much able to tell them that their argument is uncompelling and the answer is no.
18:22:32 <jwb> yes
18:22:33 <mattdm> nirik: yes, agreed. we can certainly revisit the decision and anyone can request that we do so.
18:22:37 <nirik> anyhow, do we want to defer here? or decide something?
18:23:04 <sgallagh> Why not see if a decision would pass?
18:23:28 <jwb> sgallagh, uh... a decision on what
18:23:42 <jwb> because if it's anything other than "do nothing/defer to WG" then we don't have the stakeholders here
18:23:43 <nirik> well, there may be people who would have input on a decision that are not here...
18:23:50 <mcatanzaro> sgallagh: Because twoerner is not here, and he should probably have a chance to speak if the decision is to reaffirm the WG's decision.
18:23:52 <sgallagh> Proposal: FESCo trusts the Workstation WG (and all other WGs) to properly evaluate the firewall security concerns for their product. Further discussion on this topic should happen with the Workstation WG.
18:24:39 <sgallagh> (FWIW, I intend to involve myself in that discussion. I've been talking with the stakeholders privately for the last week.)
18:24:43 * nirik thinks that might be too generic.
18:24:44 <jwb> hm
18:24:52 <dgilmore> I think we should stick with defering until we have the stakeholders
18:24:58 <randomuser> s/evaluate/work with the community to evaluate/ . Just because there's a perceived communication problem.
18:25:01 <mcatanzaro> But he could equally well participate in the WG discussion, so I guess it doesn't matter much.
18:25:02 <dgilmore> otherwise we will be dealing with it again later anyway
18:25:14 <sgallagh> randomuser: That's a reasonable adjustment to the statement, sure.
18:25:33 <jwb> dgilmore, i'm not sure that's a foregone conclusion?
18:26:17 <dgilmore> jwb: never a guarantee but i strongly suspect its true
18:26:35 <nirik> I think defer for at leask twoerner would be good.
18:26:40 <nirik> least
18:26:45 <jwb> i fail to see how.  we defer to the WG, people still aren't happy, the reopen to FESCo?  that's a broken process loop
18:27:15 <mattdm> "defer to WG with prejudice"?
18:27:30 <jwb> wth does that even mena
18:27:32 <jwb> mean
18:27:50 <sgallagh> jwb: I think it means "FESCo would refuse to entertain the subject again"
18:28:15 <jwb> then say that because "with prejudice" is unnecessarily obfuscated
18:28:24 <nirik> anyhow, I think we had 5 votes to defer already? or does anyone want to change?
18:29:01 <thozza> I don't
18:29:15 <nirik> #agreed defer to january meeting (+5,0,0)
18:29:38 <nirik> ok, next up are some changes...
18:29:48 <nirik> #topic ticket #1373	F22 System Wide Change: Perl 5.20 - https://fedoraproject.org/wiki/Changes/perl5.20
18:29:48 <nirik> .fesco 1373
18:29:49 <zodbot> nirik: #1373 (F22 System Wide Change: Perl 5.20 - https://fedoraproject.org/wiki/Changes/perl5.20) – FESCo - https://fedorahosted.org/fesco/ticket/1373
18:29:51 <nirik> +1 here
18:30:08 <dgilmore> +1
18:30:17 <nirik> new fedora, new perl. ;)
18:30:50 <thozza> +1
18:31:02 <sgallagh> +1 rubber stamp
18:31:37 <sgallagh> (Actually, isn't it too early for this vote, technically? It hasn't been on the list for a week)
18:31:51 <kalev> +1
18:31:54 <mattdm> +1 stamp
18:32:06 <nirik> #agreed Change approved (+6,0,0)
18:32:11 <nirik> sgallagh: it's 6 days, but meh
18:32:17 <jwb> i didn't vote
18:32:22 <nirik> oops.
18:32:26 <jwb> but +1
18:32:28 <jwb> ;)
18:32:29 * nirik checks his glasses. ;)
18:32:39 <sgallagh> jwb: I'd have been more amused to see a -1 there :)
18:32:49 <nirik> #undo
18:32:49 <zodbot> Removing item from minutes: AGREED by nirik at 18:32:06 : Change approved (+6,0,0)
18:33:00 <nirik> #agreed Change approved (+7,0,0)
18:33:08 <nirik> #topic ticket #1374	F22 Self Contained Changes
18:33:08 <nirik> .fesco 1374
18:33:09 <zodbot> nirik: #1374 (F22 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1374
18:33:27 <nirik> +1 to these
18:33:35 <sgallagh> BIND should be a system-wide change
18:33:43 <jwb> +1 though i think i need to follow up with pjones on the EFI one
18:33:49 <pjones> Oh?
18:33:49 <sgallagh> Since it's directly relevant to the now-release-blocking Domain Controller feature of Fedora Server
18:33:49 <jreznik> sgallagh: I created tickets for changes with less than one week but no complaints so far to spread it a bit over time/fesco meetings... I'm aware of it... libinput is still waiting because of discussion ongoing
18:33:50 <thozza> sgallagh:  why?
18:34:20 <sgallagh> jreznik: I was being pedantic. Ignore that.
18:34:22 <jwb> pjones, yeah, we can follow up offline
18:34:25 <pjones> okay.
18:34:42 <dgilmore> +1 to the two changes in the Self contained list
18:34:44 <thozza> sgallagh: do you have some link?
18:34:53 <sgallagh> thozza: For what?
18:35:03 <thozza> for the server feature
18:35:36 <thozza> with some additional info. I would like to see how this affects the feature
18:35:51 <sgallagh> thozza: https://fedoraproject.org/w/index.php?title=Fedora_21_Final_Release_Criteria#Domain_controller_role
18:36:05 * dgilmore wonders what he is missing here
18:36:25 <sgallagh> thozza: BIND 9 isn't a self-contained feature because other major features of Fedora depends on it
18:36:29 <dgilmore> since there is only preupgrade and bind in the self contanined changes that I see
18:36:33 <sgallagh> Therefore, it should be tracked as a system-wide feature
18:36:58 <nirik> sgallagh: so anything shipped in any product becomes system-wide?
18:37:00 <dgilmore> sgallagh: then it probably should be merged into the feature depending on it
18:37:28 <thozza> btw I talked with the owner of the Preupgrade assistant feature and they might need some additional packaging guidelines sections for packaging the contents for the assistant per package
18:37:32 <jreznik> sgallagh: in such case, talk to change owner and join the change as co-owner -> it can stay self contained
18:37:32 <sgallagh> nirik: I didn't say that, but it's a release-blocking feature of a product. One that very heavily depends on this working.
18:37:47 <mattdm> do we need a third category between self-contained and system-wide, for things that block product deliverables?
18:37:48 <sgallagh> I think it's a judgement call, but I would fall on the side of treating it as system-wide, not as a leaf
18:38:22 <nirik> it seems kinda like overkill to me, but ok
18:38:24 <dgilmore> sgallagh: its self contained, just because something depends on it doesnt change that fact
18:38:38 <randomuser> sgallagh, that is the categorization for "changes where maintainers must work with other maintainers to ensure it works", +1 from the benches
18:38:54 <dgilmore> sgallagh: the thing depending on it needs to incorpoate it or ensure that the self contained change it needs is complete
18:38:55 <jreznik> mattdm: I already added field "blocks product" but I really can't think about all features in all products that are somehow interconnect even I try to do it
18:38:58 <sgallagh> " Examples include addition of a group of leaf packages, or a coordinated effort within a SIG with limited impact outside the SIG's functional area."
18:39:03 <sgallagh> That doesn't fit this description...
18:39:10 <thozza> sgallagh: I still don't see what would break for your feature. But we can figure that out together
18:39:29 <sgallagh> thozza: The Change expressly describes a set of changes to setting formats
18:39:44 <sgallagh> That sounds like it might break our setup and management tools
18:40:07 <jreznik> sgallagh: it's easy - raise it that you want to promote to system wise... it's really not only in my hands
18:40:54 <sgallagh> Proposal: BIND 9 should be treated as a system-wide change due to its status as a tight dependency of the Domain Controller feature of Fedora Server.
18:40:59 <nirik> so, what do we want to do here?
18:41:00 <jreznik> and forecast what are changes will land or were implemented in tha past - bind is in default category of leaf package
18:41:06 <dgilmore> sgallagh: nak
18:41:13 <thozza> sgallagh: + please propose what additional steps you need from me. There is COPR repo and the change was announced on devel ages ago but nobody cared
18:41:41 <jreznik> thozza: sorry for delay on the announcement part :(
18:42:12 <sgallagh> thozza: I missed the devel announcement, sorry.
18:42:35 <thozza> I'll be +0 on this one, since it is my change
18:42:44 <sgallagh> thozza: The only thing that moving to system-wide really means is that someone from FESCo (you, me or both) will monitor its impact on other parts of the sysetm.
18:42:50 <pjones> jwb: worth noting that I'm pretty sure my change doesn't count as self-contained?
18:43:07 <thozza> sgallagh: sure, that's why I promoted is as a change
18:43:15 <jwb> pjones, nah
18:43:17 <thozza> I don't see any problem with that
18:43:27 <jreznik> sgallagh: could you co-own the change?
18:43:36 <sgallagh> jreznik: I'd be happy to do so.
18:43:41 <sgallagh> Is that alright with you, thozza?
18:43:46 <thozza> sgallagh: sure
18:44:03 <jreznik> good :)
18:44:44 <nirik> ok, so we have +3 to the one self contained change left here.
18:44:44 <thozza> anyway I still have a question for the preupgrade assistant
18:44:47 <nirik> more votes?
18:44:54 <nirik> thozza: fire away
18:45:21 <thozza> I talked with the owner of the Preupgrade assistant feature and they might need some additional packaging guidelines sections for packaging the contents for the assistant per package
18:45:30 * thozza write it before but nobody relier
18:45:44 <thozza> is this ok for self-contained change?
18:46:05 <thozza> nirik: I'll be +1 for the BIND to be system-wide....
18:46:08 <thozza> to prevent issues
18:46:09 <nirik> sure, I would think so.
18:46:16 <sgallagh> thozza: That's fine unless those packaging changes would affect a wide swath of existing packages
18:46:42 <thozza> sgallagh: I don't think so
18:46:44 <thozza> only those which decide to ship the content
18:47:00 <sgallagh> Seems self-contained to me, then
18:47:26 <sgallagh> +1 to the preupgrade-assistant Change
18:47:45 <nirik> ok, thats +4
18:48:08 <mattdm> +1
18:48:35 <nirik> #agreed preupgrade-assistant change approved (+5,0,0) Bind change will be moved to system wide
18:48:50 <jreznik> thozza: could you please update your change?
18:48:54 <nirik> do we want to vote on the bind one too now? or ?
18:49:25 <dgilmore> i already voted +1 to both
18:49:51 <nirik> dgilmore: ok, but it's hard to keep track with everyone moving all the stuff around. ;)
18:50:11 <nirik> please revote: bind system wide change
18:50:13 <nirik> +1
18:50:25 <dgilmore> nirik: sure, I don't think that bind should be moved to system wide but im not going to stop it being done so
18:50:32 <dgilmore> +1
18:50:43 <nirik> yeah, it's administravia.
18:50:52 <sgallagh> +1 to including bind
18:51:44 <mattdm> +1
18:53:06 * nirik waits for people
18:53:18 <thozza> sure
18:53:18 <thozza> +1 for preupgrade to be self-contained
18:53:18 <thozza> anybody here? :D
18:53:29 <sgallagh> Network hiccup?
18:53:49 <nirik> guess so
18:53:53 <nirik> thats +4 on bind
18:54:05 <thozza> sorry, my connection dropped
18:54:05 <mattdm> (did you get my +1?)
18:54:08 <nirik> anymore votes? should we just close out because everyone wandered off to holidays?
18:54:24 <nirik> mattdm: yeah
18:54:35 <nirik> thozza: we are voting on the bind chaneg
18:54:53 <thozza> I voted +1 in the end for system-wide
18:55:55 <nirik> ok, great
18:56:13 <nirik> #agreed bind system wide change approved (+5,0,0)
18:56:19 <nirik> #topic ticket #1375	F22 System Wide Change: Ruby on Rails 4.2 - https://fedoraproject.org/wiki/Changes/Ruby_on_Rails_4.2
18:56:19 <nirik> .fesco 1375
18:56:20 <zodbot> nirik: #1375 (F22 System Wide Change: Ruby on Rails 4.2 - https://fedoraproject.org/wiki/Changes/Ruby_on_Rails_4.2) – FESCo - https://fedorahosted.org/fesco/ticket/1375
18:56:25 <nirik> +1
18:57:12 <dgilmore> +1
18:57:29 <thozza> +1
18:58:25 <sgallagh> +1
18:58:31 <jwb> +1
18:58:32 <mattdm> +1
18:58:45 <nirik> #agreed Change is approved (+6,0,0)
18:58:53 <nirik> #topic ticket #1376	F22 System Wide Change: UEFI Secure Boot Blacklist Updates -  https://fedoraproject.org/wiki/Changes/UEFISecureBootBlacklistUpdates
18:58:53 <nirik> .fesco 1376
18:58:56 <zodbot> nirik: #1376 (F22 System Wide Change: UEFI Secure Boot Blacklist Updates - https://fedoraproject.org/wiki/Changes/UEFISecureBootBlacklistUpdates) – FESCo - https://fedorahosted.org/fesco/ticket/1376
18:59:01 <pjones> Hello party people.
18:59:09 <pjones> I strongly encourage you to approve this change.
18:59:14 <nirik> -1 because it's proposed by pjones. :)
18:59:15 <mattdm> +1 party
18:59:17 <nirik> kidding. ;)
18:59:18 * pjones waves his hand slowly across the scene
18:59:19 <dgilmore> +1
18:59:22 <jwb> +1
18:59:27 <nirik> +1
19:00:16 <thozza> +1
19:00:35 <sgallagh> +1
19:00:40 <nirik> #agreed Change is approved (+6,0,0)
19:00:47 <nirik> #topic next meeting chair
19:01:01 <nirik> anyone want it for the jan meeting?
19:01:04 <mattdm> when is that?
19:01:09 <sgallagh> The 7th
19:01:12 * dgilmore would but will not be here
19:01:26 <mattdm> I'm travelling back from vacation on the 6th....
19:01:39 <mattdm> and knowing january weather along the great lakes....
19:01:43 <dgilmore> i am taking 3 weeks off work
19:01:48 <jzb> howdy
19:01:50 <mattdm> I feel like I shouldn't commit to being anywhere on the 7th
19:01:51 <nirik> dgilmore: good for you. ;)
19:01:55 <jzb> ...
19:02:29 <nirik> so anyone be able to do it?
19:02:40 <sgallagh> I can probably take it
19:02:52 <sgallagh> Though I admit freely that I expect I'll forget to send the agenda until that morning
19:03:04 <nirik> sold. ;)
19:03:13 <nirik> #action sgallagh to chair jan 7th meeting
19:03:17 <nirik> #topic Open Floor
19:03:24 <nirik> anyone have anything for open floor?
19:03:41 <sgallagh> I have this nice rug I found laying around.
19:03:58 <nirik> does it really tie the room together? ;)
19:04:03 <jwb> jzb, did you have something?
19:04:58 <jzb> jwb: I did not. Wrong room. Sorry!
19:05:04 <jwb> ok np
19:05:19 <thozza> I have to go, so merry Christmas to everyone and happy new year ;) see you in January...
19:05:22 <nirik> ok, will close out in a minute if nothing else...
19:05:30 <nirik> you too thozza!
19:05:35 <sgallagh> thozza: To you as well!
19:05:50 <sgallagh> And everyone else (or whichever holidays you choose to celebrate)
19:06:19 <nirik> #endmeeting