env-and-stacks
LOGS
12:01:19 <hhorak> #startmeeting Env and Stacks (2014-12-17)
12:01:19 <zodbot> Meeting started Wed Dec 17 12:01:19 2014 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:01:24 <hhorak> #meetingname env-and-stacks
12:01:24 <zodbot> The meeting name has been set to 'env-and-stacks'
12:01:32 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp ncoghlan vpavlin sicampbell
12:01:32 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan pkovar samkottler sicampbell tjanez vpavlin
12:01:34 <hhorak> #topic init process
12:01:56 <vpavlin> hi
12:02:28 <hhorak> Hello!
12:03:07 <hhorak> I'm wondering who else is here and who enjoys Christmas time already :)
12:03:43 * jzeleny is here
12:04:11 <jzeleny> although my vacation has officially already started
12:04:33 <hhorak> jzeleny: great to see you enjoy it this way :)
12:04:55 <jzeleny> well ...
12:05:08 <jzeleny> let's just say I want to have a clear head when I get home today :-)
12:06:27 * langdon lurks
12:07:07 * langdon wonders if jzeleny is trying to encourage a holiday environment ...
12:08:02 <hhorak> since bkabrda is not here and ncoghlan is afk for now, we can probably leave language repositories for later
12:08:11 <ncoghlan> back
12:08:26 <ncoghlan> although if bkabrda isn't here, it's going to be a short update...
12:08:48 <hhorak> ncoghlan: ah, fine, so if you have something...
12:08:52 <jzeleny> is he at least supposed to show up later?
12:08:56 <bkabrda> hi everyone, sorry I'm late
12:09:02 <hhorak> #topic Follow-up: languages repositories
12:09:02 <jzeleny> ah, here he is :-)
12:09:09 <jzeleny> bkabrda: welcome
12:09:34 <hhorak> good, so let's get back to original agenda :) any updates from last week about lang. repos?
12:10:15 <ncoghlan> on the Python upstream side, we still don't have a great answer for wheel compatibility tags
12:10:29 <ncoghlan> on OS's other than Windows and Mac OS X
12:11:11 <ncoghlan> that won't block the pilot
12:11:22 <bkabrda> I have to say I didn't have any time to work on it. too much internal work has kept me from it. although I have one good news - it seems that devpi upstream likes the proposal for whitelisting mirrored PyPI packages, so it's very likely to get accepted upstream in some form
12:12:01 <hhorak> #info on the Python upstream side, there is still no great answer for wheel compatibility tags on OS's other than Windows and Mac OS X, which won't block the pilot
12:14:47 <hhorak> ok, thanks, it looks we're done with that topic..
12:15:35 <hhorak> #topic Follow-up: SCL
12:15:48 <juhp_> sorry for being late ...
12:15:57 <hhorak> juhp_: hi
12:16:34 <hhorak> juhp_: just closed the lang. repos. topic for today, if you don't have anything to add..
12:16:44 <juhp_> cool :)
12:18:56 <ncoghlan> oh, I did have one other thing that would be useful to capture
12:19:14 <ncoghlan> the Pulp devs consider their Python support to be in an alpha state
12:19:53 <ncoghlan> so picking that up *after* the initial pilot is a good approach
12:19:59 <juhp_> aha
12:20:00 <hhorak> #undo
12:20:00 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x5318d50>
12:20:32 <hhorak> #info the Pulp devs consider their Python support to be in an alpha state, so picking that up *after* the initial pilot is a good approach
12:20:58 <hhorak> ncoghlan: thanks
12:21:11 <hhorak> #topic Follow-up: SCL
12:21:39 <hhorak> So, for SCL in Fedora -- I've looked at the tickets, discussions, meeting logs and found that there seemed to be concensus about files location, then that we want some *limited* reviews for scls..
12:22:22 <langdon> hhorak, is that per FPC or this group?
12:24:26 * juhp_ assumes that means the previous FPC etc discussions
12:24:33 <juhp_> not that I have read them...
12:24:43 <hhorak> IIRC the files location per both and FPC did not vote about the reviews..
12:25:18 <hhorak> the reviews was more discussed in this group..
12:25:25 <juhp_> okay
12:25:51 <langdon> hhorak, ok.. thats the part i meant.. and I thought it was "playground = light reviews" not scl per se
12:27:06 <ncoghlan> I think there's a similar level of review we're after for a few things here (playground, scls, language specific repos, COPR in general)
12:27:18 <ncoghlan> which is "can we legally publish it?"
12:27:30 <ncoghlan> actually, that's just the licensing check part
12:27:50 <juhp_> ncoghlan, yes that's the very minimal :)
12:27:53 <ncoghlan> there's also the "do we trust it isn't malicious?" part
12:29:06 <juhp_> hhorak, maybe can you recap what does "SCL in Fedora" mean exactly here? :)
12:29:21 <hhorak> ncoghlan: nice put..
12:29:52 <juhp_> we're talking about Ring 2, correct?
12:29:55 <hhorak> juhp_: good point and to be honest I wanted to sync on that too, because it may be understood differently by anyone
12:30:13 <juhp_> yea
12:30:57 <juhp_> or do we still want to consider SCLs in main fedora/epel?
12:31:31 <juhp_> personally I think that is attractive
12:32:03 <ncoghlan> I'm wary of the idea - being able to run in an SCL suggests to me its an independent application
12:32:04 <juhp_> langdon, particularly for epel ;-P
12:32:09 <ncoghlan> rather than an integrated part of the OS
12:33:17 <juhp_> hmmm
12:33:29 <ncoghlan> perhaps have a repo file for softwarecollections.org in EPEL?
12:33:37 <ncoghlan> rather than the software collections themselves?
12:33:41 <langdon> personally i think "main fedora" and epel are 2 very different things.. epel, while maintained by fedora is used by a very different audience.. i would much rather see epel-scl or some such to avoid breaking promises to users who don't regularly follow fedora (cause they are EL users)
12:33:52 <langdon> ncoghlan, +1
12:34:17 <juhp_> langdon, that's true
12:34:38 <juhp_> and also a much larger user base apparently
12:34:56 <ncoghlan> I definitely agree with the idea of trying to make it easy for Fedora and EPEL users to get access to software collections
12:35:31 <hhorak> and there are also SLCs into CentOS comming, so since EPEL is build above CentOS, do we need anything else for epel?
12:35:55 <ncoghlan> hhorak: that's a good point
12:36:00 <langdon> i also want to disagree with ncoghlan in that "scls shouldn't be in main"... i think there are lots of "non-nec" things in main fedora... so I am not sure scl is really any different.. at some point, one might even see an scl being the only way to deliver some functionality.. that said, I think the "rings" means there should be next to nothing in ring0 (and/or ring1?) scl or no..
12:36:36 <ncoghlan> langdon: yeah, true - I was thinking in the old context of one big flat integrated system
12:36:49 <langdon> hhorak, ncoghlan i think centos should be building the package to access scl.org in epel :)
12:37:48 <langdon> which, i would think would be modeled on a similar, main package, for fedora (to access scl.org) ?
12:37:48 <hhorak> langdon: parsing the sentence :) ... so build in centos, provide in scl.org and use also in epel?
12:38:10 <langdon> hhorak, no.. sorry.. i was talking about people..
12:38:50 <langdon> like a "centos person" should build a repo file for centos that is shipped in a rpm in epel for access to scl.o in centos.. :)
12:38:55 <langdon> but only to avoid work :)
12:39:11 <juhp_> aha
12:39:53 <hhorak> langdon: aha, interesting..
12:39:55 <juhp_> only problem I see there is there will be a split between centos and fedora scls then
12:40:14 <langdon> juhp_, why?
12:40:15 <hhorak> #idea "centos person" builds a repo file for centos that is shipped in a rpm in epel for access to scl.o in centos.
12:40:22 <langdon> or.. split how?
12:40:47 <juhp_> or overhead potentially if person wants to maintain both
12:41:27 <juhp_> but maybe we're not even in Ring 1 so ... maybe it's all moot
12:42:20 <juhp_> anyway seems possible that we might see different scl maintainers for epel and fedora but maybe that is okay dunno
12:42:31 <juhp_> erm s/epel/centos/
12:42:35 <langdon> i would imagine that there is a "repo file" for scl.o in fedora too.. for all the stuff that is not accepted in to "main" (whether that is ring0-3 or playground )... i thought centos was doing similar.. liek some of the scls were to be considered "main" in centos as well, no?
12:42:58 <juhp_> so centos would provide fedora scls too?
12:43:23 <langdon> juhp_, scls? or "repo file to access scl.o"? I am more talking about the latter
12:43:36 <ncoghlan> Perhaps we could we get an SCLs project page, like the one for language repos?
12:43:41 <juhp_> I am talking about the former :)
12:43:45 <ncoghlan> As I'm confused :)
12:43:58 <juhp_> ncoghlan, sounds good
12:44:41 <hhorak> ncoghlan: I want to resurrect (or create) such a page, but wanted to discuss where we're heading, since it is not clear to me..
12:45:34 <ncoghlan> hhorak: perhaps phrase it in terms of questions you think need answers?
12:46:02 <hhorak> ncoghlan: I'm afraid it will be full of questions and no answers :)
12:46:07 <juhp_> "what are we trying to solve?" for example
12:46:11 <juhp_> hhorak, that's okay
12:46:13 <ncoghlan> I think that's fine, though
12:46:15 <juhp_> that would be a start :)
12:46:36 <ncoghlan> defining the problem to be solved is often the hardest part anyway
12:46:41 <hhorak> yeah, true.
12:47:15 <ncoghlan> (and oh the "hilarity" that can ensue when you skip that step and don't realise it until the arguing starts)
12:47:27 <juhp_> nod
12:47:30 <langdon> ncoghlan, i thought that made it more fun?
12:47:42 <hhorak> #action hhorak will prepare (or resurrect old one) wiki page for SCLs in Fedora (with connection to EPEL, CentOS)
12:48:06 <juhp_> thanks!
12:48:29 <ncoghlan> langdon: :)
12:48:33 <juhp_> and lots of questions :)
12:50:09 <hhorak> I'm also feeling that the Ring (whatever) level where I always imagined SCLs does not include only SCLs but various stacks (whether that are lang. repos. or just alternative repositories -- coprs?)
12:50:20 <hhorak> does anybody feel it the same way?
12:51:10 <hhorak> (and this is not about playground where we want to allow "testing" stuff)
12:51:23 <langdon> hhorak, i think there are more than one ring at which an scl can live .. based on its quality.. and, in a sense, same for any lang-repo.. but an scl, by virtue of being an rpm, can get a lot closer to ring0 than a gem file
12:51:40 <bkabrda> hhorak: yeah, SCL is just one method of achieving a certain goal, but this goal can be achieved with different means, too
12:51:56 <juhp_> even if SCLs are not in Ring 1, I feel like they should be important in Ring 2 say
12:52:35 <langdon> juhp_, i think that is what the q&a are for.. and, in a related sense, where is the wiki page for what exactly is ring0-22 ? ;)
12:52:49 <juhp_> but maybe the linear approach to rings is oversimplified perhaps
12:52:57 <juhp_> langdon, :)
12:52:59 <juhp_> right
12:53:08 * langdon loves the multi-dimensional space...
12:53:12 <juhp_> maybe we should start there even :)
12:53:41 <hhorak> so we need spheres!
12:53:51 <ncoghlan> I took it as ring 0 = Core, ring 1 = Products, ring 2 = everything else, but that's probably an oversimplification
12:54:12 <juhp_> yeah I feel like we are often still defining these spaces
12:54:20 <juhp_> or trying to
12:54:48 <ncoghlan> it's almost like we're completely redefining what it means to be a Linux distribution! :)
12:54:57 <juhp_> (-:
12:55:06 <langdon> ncoghlan, "products" = fedora products, e.g. server?
12:55:11 <ncoghlan> langdon: yeah
12:55:17 <juhp_> editions :)
12:55:31 * langdon wonders is there is a fedora standard on direction of smilies...
12:55:37 <langdon> :)
12:55:39 <hhorak> #idea ring 0 = Core, ring 1 = Products, ring 2 = everything else?
12:56:28 <hhorak> Ok, thanks for the input so far...
12:56:37 <juhp_> I thought ring 2 was more stacks and scl etc and ring 3 was applications?
12:57:47 <hhorak> I'll try to get something written hopefully for the next meeting..
12:58:03 <juhp_> awesome that will be very helpful
12:58:04 <ncoghlan> juhp_: ah, I think you're right - I though I was missing something
12:58:09 <langdon> juhp_, personally i like core, stacks, products, everything else
12:58:20 <ncoghlan> yeah
12:58:43 <hhorak> #idea another view on rings: core, stacks, products, everything else
12:58:50 <langdon> well.. actually core, stacks, products, playground, everything else
12:58:59 * langdon slow typer :)
12:59:13 <juhp_> langdon, yep
12:59:52 <hhorak> langdon: I though playground == everything else, so what could be everything else in your case?
13:00:06 <langdon> but i do think there is something to be said for non-linear.. but .. it should probably be explained linearly unless someone can drag in a really good designer..
13:00:44 <langdon> hhorak, i guess i was thinking "playground" vs "rpm fusion"...
13:01:01 <juhp_> anyway I think we basically agree - I was mostly trying to say there is a ring outside 2 for applications in Matt's original design iirc :)
13:01:41 <juhp_> langdon, factoring out stacks does make sense though
13:02:35 <hhorak> so, last thoughts for scl for todat?
13:02:38 <hhorak> *today
13:02:51 <juhp_> but but not sure if those would be user apps or what - so maybe needn't worry about it here - seems outside our scope anyway :)
13:03:36 <juhp_> (maybe more like container/docker/web apps etc built over ring 2?)
13:04:04 <langdon> juhp_, sounds like good questions/answers for the wiki page :)
13:04:18 <juhp_> ok
13:04:28 <ncoghlan> juhp_: yes, I think we'll start to see a clearer split between "part of the OS" and "application running on the OS"
13:04:34 <hhorak> juhp_: that would also make sense, something not being in fedora does not mean we do not care about it, we want to support development/building of 3rd party apps..
13:04:43 <juhp_> sure
13:07:24 <hhorak> I'll shortly switch to un-announced topic -- elections, since there are already results about who wants to offer the chair for next elections..
13:07:33 <hhorak> #topic elections -- who wants to offer the chair
13:07:59 <hhorak> #info first, who wants to continue to be a voting member: hhorak ncoghlan vpavlin sicampbell juhp
13:08:23 <hhorak> #who explicitly wants to offer the chair: bkabrda tjanez
13:08:44 <hhorak> #who did not responded and thus his chair will be offered: samkottler pkovar
13:08:58 * ncoghlan suspects meetbot won't understand those last two...
13:09:11 <hhorak> ncoghlan: ah, thanks
13:09:18 * langdon brb
13:09:19 <hhorak> #info who explicitly wants to offer the chair: bkabrda tjanez
13:09:31 <hhorak> #info who did not responded and thus his chair will be offered: samkottler pkovar
13:10:17 <juhp_> so we have enough open seats?
13:10:40 <hhorak> juhp_: I think we have exactly what we need :)
13:10:52 <juhp_> great
13:11:14 <hhorak> (depends on the math whether half of 9 is 4 or 5, but I guess 4 is good enough)
13:11:43 <juhp_> okay
13:12:29 <hhorak> So, that's it.. Anybody has something to add? (we may skip chairman picking unless somebody wants to volunteer..)
13:12:51 <juhp_> have we announced to fesco about the elections?
13:12:56 <hhorak> Ah, one important thing, does anybody wants to hold meeting Dec 24th?
13:13:03 <hhorak> Or 31st?
13:13:30 <hhorak> I guess we can set the next one for Jan 7th, right?
13:13:40 <juhp_> sounds fine to me
13:13:44 <bkabrda> I won't make either of them, Jan 7th is the first that works for me
13:14:05 <hhorak> ok
13:14:15 <hhorak> #info the next meeting will be Jan 7, 2015
13:14:16 <ncoghlan> I'll still be on PTO on the 7th, and then at LCA in Auckland on the 14th
13:14:29 <juhp_> ncoghlan, nice
13:14:50 <hhorak> ncoghlan: ok, have a nice trip!
13:15:06 <hhorak> and enjoy the Xmas everybody!
13:15:24 <juhp_> thanks hhorak - and you too
13:15:25 <ncoghlan> indeed - catch you next year, folks!
13:15:52 <bkabrda> have a great new year everyone! bye
13:15:55 <hhorak> #endmeeting