i18n
LOGS
06:01:11 <pravins> #startmeeting i18n
06:01:11 <zodbot> Meeting started Wed Nov 12 06:01:11 2014 UTC.  The chair is pravins. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:01:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:01:16 <mfabian> Hi!
06:01:18 <pravins> #meetingname i18n
06:01:18 <zodbot> The meeting name has been set to 'i18n'
06:01:24 <pravins> #topic agenda and roll call
06:01:37 <pravins> Hi mfabian :)
06:01:39 <pravins> hi all
06:01:45 <paragan> hi
06:02:04 <juhp> hi
06:02:11 <epico> hi
06:02:20 <shilpa> hi
06:02:31 <anish_> Hi!
06:02:52 <tagoh_> hi
06:03:10 <pravins> almost all here except fujiwarat
06:03:14 <pravins> lets start the meeting
06:03:31 <pravins> hi juhp epico shilpa paragan anish_ tagoh_ :)
06:04:00 <pravins> Agenda is available AT
06:04:01 <pravins> #link https://fedoraproject.org/wiki/I18N/Meetings/2014-11-12
06:04:17 <pravins> please add if we are missing anything or anything you want to bring up.
06:04:22 <pravins> #topic Upcoming schedule
06:04:28 <pravins> #info 2014-11-04	Beta Release
06:04:28 <pravins> #info 2014-11-18 [https://fedorahosted.org/fesco/ticket/1364 Fesco] 	Final Freeze (Former Final Change Deadline)
06:04:28 <pravins> #info 2014-12-09 	Fedora 21 Final Release
06:04:37 <pravins> Minor change from last week schedule
06:04:46 <pravins> QA agreed that it was acceptable to declare Final Freeze as November 18th instead of November 25th to give us more time to run through Final release validation and find blockers without slipping into - and past - the holidays.
06:06:16 <pravins> so only 3 weeks between final freeze and final release.
06:07:47 <juhp> so soon
06:07:57 <pravins> yes
06:08:14 <pravins> We are almost there :)
06:08:30 <juhp> so really last chance to get builds in to Final
06:08:33 <pravins> only 6 days for final freeze, do build if anything missing.
06:09:17 <pravins> to me only looks missing one is Noto CJK
06:10:03 <pravins> epico: will you get chance to do it before deadline?
06:10:32 <epico> F21 may still use adobe fonts...
06:11:13 <tagoh_> I suppose it's not much important for GA. it could be done by updates if needed.
06:11:17 <juhp> yes I wanted to ask about Noto CJK too in general...
06:11:24 <juhp> true
06:11:53 <juhp> it would be nice to have the packages available though - I would like to see them tested in general
06:12:38 <epico> okay, I will try.
06:12:44 <juhp> should they be separate packages? (I mean for C, J and K?)
06:13:08 <juhp> if separate then perhaps it makes more sense to have individual owners for them
06:13:35 <epico> for Chinese fonts.
06:13:46 <tagoh_> how does upstream ship the archive?
06:13:55 <juhp> though there is also the CJK font - would could be interesting to experiment with too
06:13:57 <pravins> there are around 70 ttf file in Noto third party folder
06:14:03 <pravins> tagoh_: we are using git snapshot
06:14:11 <pravins> upstream packaging is not good.
06:14:33 <pravins> epico: should i add action item for you?
06:15:10 <juhp> no thoughts on separation?
06:15:35 <juhp> epico, so you will package the noto zh?
06:15:54 <pravins> juhp: its in single archive so not make sense to make new package for same. It will be definitely different subpackages.
06:15:59 <pravins> since family name is different
06:16:18 <juhp> hmm ok
06:16:37 <pravins> lets move on..
06:16:43 <pravins> #topic Outstanding topics
06:16:44 <juhp> pravins, so you're asking for contributions?
06:16:47 <epico> pravins, okay
06:16:55 <epico> juhp, for SC and TC.
06:17:18 <pravins> juhp: epico mentioned once he is interested in doing it. So i pinged him.
06:18:15 <pravins> #action epico to add CJK fonts in google-noto-fonts
06:18:17 <juhp> okay - I thought earlier we were thinking a separate package so bit confused
06:18:23 <pravins> thanks epico :)
06:18:35 <pravins> #info #34: need Fedora i18n Mission Statement (i18n@lists.fedoraproject.org)
06:18:38 <pravins> #link https://fedorahosted.org/i18n/ticket/34
06:18:39 <epico> pravins, welcome.
06:18:51 <pravins> thanks juhp to ping everyone for this task before the meeting
06:19:15 <juhp> we had a little discusion before in #fedora-i18n
06:19:32 <pravins> juhp:  suggested one "Users can use Fedora in their own languages effortlessly and effectively."
06:19:48 <pravins> so important thing is we need vision statement first
06:20:16 <pravins> mission statements are more task oriented so can be decide quickly
06:20:18 <juhp> I was thinking maybe we could buy some time by renaming this ticket to Vision statement
06:20:41 <pravins> looks good.
06:21:26 <pravins> in between i also proposed one :)
06:21:59 <pravins> Vision: To make Fedora respect each individuals diversity of languages and support it.
06:24:24 <pravins> how about discussing other topics first and then continue this topic at the end. ?
06:24:47 <juhp> sure
06:24:52 <pravins> thanks
06:24:59 <pravins> #info #36: gnome redesign plans for control-center Region and Languages (i18n@lists.fedoraproject.org)
06:25:05 <pravins> #link https://fedorahosted.org/i18n/ticket/36
06:26:00 <pravins> juhp: any more updates after last meeting?
06:26:22 <juhp> no
06:27:45 <pravins> i think we need be proactive for this and make this happens. So once we will have some more time, we will allot time and make this happen.
06:28:12 <pravins> lets plan in next meeting
06:28:25 <pravins> #topic Outstanding tasks
06:28:29 <pravins> #info #32: Fedora 21 i18n test day (i18n@lists.fedoraproject.org)
06:28:35 <pravins> #link https://fedorahosted.org/i18n/ticket/32
06:28:44 <pravins> thanks tagoh_ for updating ticket.
06:30:42 <pravins> tagoh_: would you like to comment any observations for test day after summary?
06:32:58 * pravins quickly going through bugs reported.
06:34:24 <pravins> Bug 1136177 - PyGTKDeprecationWarning messages on terminal  - Fixed
06:34:36 <pravins> Bug 1136172 - should requires: dnf-plugins-core - Fixed
06:34:51 <pravins> Bug 501414 - [kn_IN]Cursor stays in the middle of char when moving it to the right hand of the char. - WONT FIX
06:35:13 <pravins> Bug 635961 - [Pango][Cursoring][mr_IN] - Composed Character Deletion is wrong with DELETE Button - NEW (reported in upstream by behdad)
06:35:25 <pravins> i think we can close this ticket now.
06:35:38 <paragan> +1 to close this ticket
06:36:50 <pravins> lets move to next
06:37:03 <pravins> #info #35: http://fedoraproject.org/wiki/I18N cleanup (i18n@lists.fedoraproject.org)
06:37:06 <pravins> #link https://fedorahosted.org/i18n/ticket/35
06:37:31 <pravins> We planned work on this after this meeting. So will discuss more there.
06:38:36 <pravins> 1 hrs after this meeting. will discuss on #fedora-i18n
06:39:30 <juhp> yeah
06:40:19 <pravins> lets move on to next topic
06:40:20 <pravins> #topic New topic
06:40:24 <pravins> #info #38: Adding metainfo for font packages (pravins)
06:40:28 <pravins> #link https://fedorahosted.org/i18n/ticket/38
06:40:57 <pravins> if one see https://docs.google.com/spreadsheets/d/1o2sPWF7PEe6BKnBeZUI23m51nfFHUMx61IRsdNDozig/edit#gid=0 spreadsheet now. It is in good shape
06:42:00 <paragan> I think only 5-6 packages are remaining now
06:42:19 <pravins> paragan: nice.
06:42:26 <pravins> and i new some of those are mine :)
06:42:41 * pravins pravins to add metainfo in his packages
06:42:46 <paragan> yep you got 3-4 packages ;-)
06:43:02 <juhp> great
06:43:17 <pravins> i am hoping we can close this ticket by next week.
06:43:32 <paragan> sure
06:43:40 <pravins> next topic is open floor, prior that we decided to discuss on vision statement
06:43:51 <pravins> we still have 17 minutes
06:45:05 <pravins> https://fedorahosted.org/i18n/ticket/34
06:45:58 <juhp> ah
06:46:18 <juhp> forgot we were returning...
06:46:29 <pravins> juhp: thanks for uploading Fedora vision statement link
06:46:33 <pravins> https://fedoraproject.org/wiki/Vision_statement
06:46:38 <pravins> The Fedora Project creates a world where
06:46:38 <pravins> free culture is welcoming and widespread,
06:46:38 <pravins> collaboration is commonplace, and
06:46:38 <pravins> people control their content and devices.
06:46:41 <juhp> yea
06:47:00 <mfabian> https://fedorahosted.org/i18n/ticket/34 [14年11月12日 07:45:02]
06:47:00 <mfabian> <juhp> ah [14年11月12日 07:45:55]
06:47:04 <pravins> It does not mention any technology, open source..just values of project
06:48:10 <pravins> now comparing with it ours.
06:48:38 <pravins> "Users can use Fedora in their own languages effortlessly and effectively."
06:48:40 <juhp> yes I was thinking some reference to community would be good too
06:49:12 <pravins> right, we need to make it interesting for our stakeholders.
06:49:47 <pravins> users, developers and other project in Fedora (Workstation, server, cloud and base)
06:50:13 <pravins> in between if someone missed
06:50:30 <juhp> yes maybe above a bit passive
06:50:42 <pravins> epico: tagoh_ shilpa paragan mfabian anish_ we are discussing mission/vision statement again.
06:51:46 <mfabian> “People who have visions should go see a doctor” — Helmut Schmidt, German Chancellor 1974-1982
06:52:01 <juhp> haha
06:52:06 <anish_> :)
06:52:07 <pravins> mfabian: yes, there are funny quotes about vision :)
06:52:30 <mfabian> I still like Ankit’s suggestion best.
06:52:37 <pravins> i remembered one talk from guy kawasaki saying, no need to waste time in making vision statement just copy it from somewhere ;)
06:52:53 <juhp> so I was thinking: not just good i18n for users but also developers and their users
06:53:06 <juhp> (:
06:53:24 <pravins> juhp: exactly
06:53:45 <anish_> ohh yeah developers needs are different than users
06:53:45 <pravins> - To make sure we will have latest development in i18n domain in FEdora
06:53:47 <juhp> but maybe our vision is too limited if we think in terms of the Fedora Vision
06:54:23 <juhp> what does i18n mean in terms of the Fedora Vision
06:54:26 <juhp> ?
06:54:47 <pravins> free culture in i18n development
06:55:04 <pravins> collaborate with using open source.
06:55:22 <pravins> everyone has freedom to use things they like (fonts and IME)
06:57:05 <juhp> right freedom to express in our own language
06:57:55 <pravins> where we are going to draft our vision statement, on wiki?
06:58:46 <tagoh_> draft to the ticket may works. once we agreed on it, update the wiki then.
06:59:04 <pravins> sure
06:59:55 <pravins> do we still have some more inputs?
06:59:58 <juhp> or we could use Pirate pad
07:00:11 <juhp> http://piratepad.net/zt6yXxFcOb
07:00:34 <pravins> nice
07:01:19 <pravins> juhp: lets add most of the statement there.
07:01:21 <pravins> have some voting
07:01:24 <pravins> and decide final?
07:01:58 <pravins> how do you all find this approach?
07:02:53 <juhp> I feel better to have consensus than voting
07:04:04 <pravins> my only intention is that select one statement and work on polishing it
07:04:04 <juhp> but seems more suggestions would be good I think
07:04:16 <juhp> s/seems/seeing/!
07:04:26 <juhp> ah right
07:04:48 <juhp> well let's see the suggestions first :)
07:04:55 <pravins> we will try to add more words, line to it and make it perfect and acceptable :)
07:05:01 <pravins> yes
07:05:27 <pravins> #action all add there suggestion in http://piratepad.net/zt6yXxFcOb
07:06:14 <pravins> unfortunately we still bit unclean on vision and mission statement. :(
07:06:20 <pravins> s/unclean/unclear
07:06:39 <pravins> and we are almost ahead of meeting closing time.
07:06:58 <pravins> lets move and next time prior meeting have some discussion and final in meeting
07:07:06 <pravins> #topic Open Floor
07:07:19 <pravins> lets close the meeting in couple of minutes if nothing there.
07:08:55 <mfabian> https://bugzilla.redhat.com/show_bug.cgi?id=1161858
07:09:23 <mfabian> Kind of a weird bug, the user has *only* ibus-typing-booster configure, no other input method, especially no keyboard layout.
07:09:43 <mfabian> I wonder whether this has something to do with gnome-initial-setup offering only one choice.
07:10:32 <pravins> umm with Indic keyboard, english remain as a default there.
07:10:42 <pravins> s/as a/by
07:11:09 <mfabian> Maybe the user did do this manually, I asked in the bug whether he did this on purpose.
07:11:29 <juhp> oh
07:11:38 <pravins> interesting bug :)
07:11:47 <juhp> btw too late but should we have a ticket for F21 bugs?
07:12:49 <pravins> juhp: not yet :(
07:14:01 <pravins> mfabian: yes, its obvious that use will get irritated with that message after sometime.
07:14:10 <juhp> pravins, +1
07:14:16 <pravins> possible alternative
07:14:19 <mfabian> The message to install the hunspell dictionary?
07:14:24 <pravins> yes
07:14:29 <mfabian> That message disappears soon after some typing.
07:14:51 <tagoh_> juhp: dunno if that would really helps. one who are interested in bugs could be interested in bugs without a ticket...
07:14:51 <juhp> mfabian, well it annoyed him enough to file a bug report :)
07:15:01 <pravins> means once user have some user db, it goes out?
07:15:09 <mfabian> At the start, no user input has been remembered and when no hunspell dictionary is there as well, no suggestions are possible and this message appears.
07:15:26 <pravins> aha
07:15:28 <mfabian> After typing a bit, suggestions are available from the remembered user input and that message disappears.
07:15:37 <mfabian> pravins: yes.
07:15:57 <juhp> mfabian, how about PK integration instead - it would be more clear-cut perhaps: yes/no
07:16:08 <mfabian> I thought that is “good” enough, it is just a hint whichcan be ignored.
07:16:25 <mfabian> There is the option to install the package in the setup dialog.
07:16:25 <juhp> mfabian, or otherwise maybe just display warning?
07:16:31 <juhp> just don't *
07:16:48 <mfabian> I have on my todo list to make that installation also possible by selecting that special hint message.
07:16:50 <pravins> juhp: right. Ask user to install dictionary rather than simple text msg. It gives more chances that user will install dictionary by clicking "yes"
07:17:08 <mfabian> Although I am wondering whether that really would be a good idea.
07:17:47 <juhp> or make it a config option?
07:17:48 <mfabian> Maybe I should better remove that message.
07:17:58 <mfabian> juhp: config option?
07:17:59 <juhp> perhaps
07:17:59 <pravins> mfabian: if we are only once prompting user for installation of hunspell. it is even better to prompt him with simple click and install.
07:18:10 <juhp> mfabian, not sure - install from config perhaps?
07:18:26 <juhp> config = setup
07:18:29 <juhp> anyway
07:18:31 <mfabian> Install from the setup dialog  is already possible. Did you mean that?
07:18:38 <juhp> ah yes forgot
07:18:40 <juhp> okay :)
07:18:54 <juhp> then maybe that is good enough?
07:20:12 <mfabian> So I wonder whether selecting that special hint message should also do the installation, or should I reword the message to say "You may install hunspell dictionary if you like but you don’t have to.” (but that is getting long then) or just remove that message because the hunspell dictionary is not that important for ibus-typing-booster?
07:20:50 <pravins> "Installing hunspell dictionary will give you better predictions"
07:21:22 <mfabian> pravins: yes, maybe I try rewording the message first ...
07:21:22 <tagoh_> how about add "Suggests:" to the spec?
07:21:42 <tagoh_> and drop the message
07:21:59 <mfabian> tagoh_: good idea maybe.
07:22:22 <juhp> tagoh_, it is not supported yet by yum I think
07:22:33 <mfabian> tagoh_: But *which* hunspell dictionary? Which language?
07:22:34 <tagoh_> juhp: true. dnf does.
07:23:02 <pravins> mfabian: yes that is problem, we dont know which language hunspell to install
07:23:16 <juhp> mfabian, I haven't tried recently but sounds to me like dropping the message might give a better UX
07:23:23 <pravins> if suggestion to install hunspell only appearing once, its is not much problem i think
07:23:53 <tagoh_> dunno if it could be improved by using langpacks or so?
07:23:59 <juhp> aha
07:24:18 <juhp> I think I suggested something similar a good while ago
07:24:41 <pravins> mfabian: msg is not going away
07:24:49 <mfabian> You just tried?
07:24:53 <pravins> it remain in candidate window
07:24:54 <pravins> yes
07:24:57 <mfabian> I should go away pretty soon.
07:25:10 <pravins> mfabian: thanks for bring this bug
07:25:13 <mfabian> Because if you type some stuff, you own suggestions will go on top.
07:25:18 <pravins> juhp: i agree. we are missing discussion on bugs
07:25:23 <juhp> it sounds kind of intrusive
07:25:35 <mfabian> And that message goes lower and lower in the candidate list until it drops out.
07:25:52 <pravins> mfabian: yes, it should not happen like that. once i hit commit
07:25:53 <juhp> one week to final freeze - does it still make sense to open a f21 bugs ticket?
07:26:03 <juhp> we may still want to track day 0 bugs etc
07:26:06 <pravins> it should go away forever. then no one will complain :)
07:26:08 <mfabian> pravins: Remove  the message after first commit?
07:26:15 <pravins> mfabian: yes
07:26:22 <mfabian> OK.
07:26:59 <juhp> or message could say "go to setup" to install dict
07:27:01 <pravins> juhp: sure, i will create ticket for same.
07:27:09 <juhp> thanks
07:27:14 * pravins create ticket for F21 bugs discussion
07:27:31 <pravins> lets close the meeting then?
07:27:59 <juhp> 30min to wiki fun ;o)
07:28:05 <pravins> juhp: yes :)
07:28:16 <pravins> Thanks everyone for meeting.
07:28:18 <pravins> #endmeeting