env-and-stacks
LOGS
12:03:56 <hhorak> #startmeeting Env and Stacks (2014-11-12)
12:03:56 <zodbot> Meeting started Wed Nov 12 12:03:56 2014 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:03:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:04:00 <hhorak> #meetingname env-and-stacks
12:04:00 <zodbot> The meeting name has been set to 'env-and-stacks'
12:04:04 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp ncoghlan vpavlin sicampbell
12:04:05 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan pkovar samkottler sicampbell tjanez vpavlin
12:04:18 <hhorak> #topic init process
12:04:25 <vpavlin> Hey:)
12:04:29 <hhorak> Hi guys, who do we have around?
12:04:59 <bkabrda> hi!
12:06:40 <juhp_> hi
12:07:00 <juhp_> hhorak, no go for it :)
12:07:29 <hhorak> juhp_: ok, np
12:07:45 <juhp_> I had my fun last week ;-P
12:07:45 <hhorak> so, anything we would like to add to the agenda from the last week?
12:08:46 <hhorak> we can add something on the way, so let's start with the first
12:08:54 <hhorak> #topic  Follow-ups
12:09:18 <hhorak> anyone got a chance to move some of the work-in-progress tasks?
12:10:39 <bkabrda> well, I've created a copr repo for the testing devpi instance that we'll try to deploy with nick
12:10:43 <bkabrda> let me find a link...
12:10:51 <bkabrda> https://copr.fedoraproject.org/coprs/bkabrda/devpi21/
12:11:36 <bkabrda> but we haven't actually deployed it. I'm hoping I'll be able to give it some time next week. I still have to release new version of DevAssistant this week :)
12:11:36 <hhorak> bkabrda: well done!
12:12:11 <bkabrda> (it's an SCL for EL7, built on top of python33 from the RHSCL rebuild)
12:12:26 <juhp_> cool
12:12:56 <bkabrda> so, hopefully I'll have something interesting to report in two weeks or so
12:14:08 <hhorak> #info packaged devpi is available in copr as SCL depended on python33 SCL for el7
12:14:15 <hhorak> #link https://copr.fedoraproject.org/coprs/bkabrda/devpi21/
12:15:04 <hhorak> bkabrda: great!
12:15:15 <hhorak> I was thinking we should create some "task page" for on-going tasks so we can track progress better than in https://fedoraproject.org/wiki/Env_and_Stacks/Tasklist
12:15:43 <juhp_> OT but I created/submitted a llvm34 package for Rawhide
12:15:54 <juhp_> hhorak, +1
12:16:09 <hhorak> which would make it easier also for volunteers that would like to contribute
12:17:14 <juhp_> hhorak, what would you change though?
12:17:15 <hhorak> it doesn't have to be verbose, but we should probably have some more info than we have in the table
12:17:22 <juhp_> ah ok
12:17:34 <juhp_> different format perhaps?
12:17:40 <ncoghlan> (sorry I'm late - didn't have a reminder set for the new time. Do now)
12:18:11 <hhorak> juhp_ it'd be mainly about providing more info, some more detailed things that someone can pick to work on
12:18:38 <hhorak> since so far we have quite general description and it is quite non-easy to join and help us (imho)
12:18:49 <hhorak> ncoghlan: Hi, great to see you here
12:20:30 <juhp_> hhorak, ah okay - subtasks etc - makes sense I think
12:20:49 * hhorak thinking how to summarize it nicel
12:20:54 <hhorak> *nicely
12:21:07 <juhp_> then probably it should replace Env_and_Stacks/Tasklist ?
12:21:25 <juhp_> or link from there
12:22:24 <hhorak> juhp_: right, there could still be links or tasks where we have only some rough thought with no specifics
12:22:46 <juhp_> ok
12:23:29 <hhorak> bkabrda: ncoghlan: vpavlin: what do you think? does it seem to be a good way to go?
12:23:47 <ncoghlan> I missed the start, but I think writing down clearing plans when we have them would be a good idea
12:24:10 <hhorak> ncoghlan: ah, sorry, but you got the idea
12:24:36 <ncoghlan> when we're still experimenting (e.g. the devpi idea), then it isn't really practical for anyone else to help anyway, so notes can be briefer
12:24:37 <bkabrda> hhorak: I'd keep everything as minimal and compact as possible. I think that if people have lots of text to read/lots of pages to go through, they tend to give up
12:25:12 <bkabrda> so maybe just creating a single wiki page with "half baked ideas", "ideas being worked on", etc. might work best
12:25:13 <vpavlin> hhorak: Yes, I agree - I don't think more text would help, but break task we have to smaller pieces might help
12:25:18 <ncoghlan> also, we don't want to replicate the overall Fedora change process
12:25:40 <ncoghlan> and once an idea is ready to graduate from "half-baked notion" the change process is likely where it should be promoted to
12:26:23 <ncoghlan> actually, there'd probably be a middle ground in there for "proof of concept/preliminary design/etc"
12:28:26 <ncoghlan> e.g. we should probably have a page for the language specific repos idea
12:28:37 <hhorak> I agree with that, unnecessary text is always bad. However, I'm thinking about it this way -- suppose someone would like to join and work on some task -- does he find enough info about the task (how it was meant) or does he have to ask us?
12:28:48 <ncoghlan> to collect links, note different design directions, etc
12:29:13 <juhp_> project pages?
12:29:18 <hhorak> ncoghlan: right, that's something I have on my mind
12:29:23 <ncoghlan> I don't think it's possible to ever get away from needing to talk to people
12:29:46 <ncoghlan> but I think we want to have enough written down that folks can get an idea of our areas of interest
12:31:06 <ncoghlan> it also provides something to point folks at - e.g. dgilmore has some reservations re koschei, and would be keen to see something more robust in Brew itself
12:31:13 <hhorak> ncoghlan: yeah, people will come to use to discuss anyway, they shouldn't just come with "what did you meant with this task"
12:31:57 <ncoghlan> right, if we have any projects at that stage of maturity, it would be nice if folks can just pick something up and run with it
12:32:31 <ncoghlan> the language specific repo idea is *loooong* way from that level :)
12:33:14 <ncoghlan> on the other hand, once a project is at that level of maturity, it might have an issue tracker somewhere
12:33:35 <hhorak> ok, so let's keep it for case by case basis, I can just add some  suggestion to create a separate page if there is more to say..
12:33:52 <juhp_> having a bit of a breakdown of project tasks may also make progress easier to track anyway
12:34:13 <ncoghlan> aye. definitely +1 for not trying to jam any more info directly into the task list
12:35:41 <hhorak> it seems to me like we're all on the same page, just making some statement from it....
12:36:48 <vpavlin> Maybe something like Env_and_Stacks/Projects/Project_XY ? With some defined structure like summary, description, owner(s), status, concrete tasks to be solved...
12:37:37 <vpavlin> And these would be linked from tasklist...
12:37:42 <juhp_> yeah
12:37:46 <ncoghlan> vpavlin: yeah, that sounds reasonable to me
12:37:53 <hhorak> #info if there is more information for tasks in https://fedoraproject.org/wiki/Env_and_Stacks/Tasklist, which people wanting to collaborate on the task can need, it is suggested to create some separate page where some subtasks and more info would be included
12:38:28 <hhorak> #info it can be in format of Env_and_Stacks/Projects/Project_XY  with some a structure like summary, description, owner(s), status, concrete tasks to be solved
12:38:55 <hhorak> ok, quite a lot of time spent on this, let's move on to the next topic
12:39:10 <hhorak> #topic Integration tests
12:40:12 <hhorak> this is being discussed on ML, which can continue there as well, but I just wanted to ask if somebody has a better term for these tests, that should cover more components and would be run outside of %build section (not during RPM build)
12:40:50 <hhorak> the term I like the best now is "functional tests" but still not feel it's perfect
12:41:05 <ncoghlan> I think they're all a bit fuzzy at the edges
12:41:22 <ncoghlan> but functional tests or integration tests are a reasonable fit
12:42:10 <juhp_> functional integration tests? :)   mm bit long
12:42:56 <ncoghlan> if we call RPM #check sections unit tests (from the distro perspective), then functional tests would fit well
12:43:12 <ncoghlan> %check sections, even
12:43:23 <juhp_> yeah I quite like "functional tests" too
12:44:55 <hhorak> ok, thanks for the feedback, I'd like to make some more concrete proposal so I'd rather start using some term that has as little ambiguity as possible; will use functional tests if nobody suggests better ")
12:45:44 <hhorak> #info integration tests is not a perfect term for tests, that should cover more components and would be run outside of %build section (not during RPM build); "functional tests" seem a bit better
12:46:12 <hhorak> #topic Election planning
12:46:59 <hhorak> does anybody have some experiences with elections within Fedora other than voting?
12:48:39 <juhp_> what is the time frame on the WG election?
12:48:58 * ncoghlan = Fedora noob, really
12:48:59 <juhp_> I mean when is it due?  I forget... :)
12:50:24 <hhorak> well, I don't have more info than what we discussed a year back: https://fedoraproject.org/wiki/Env_and_Stacks/Governance_Charter
12:52:15 <vpavlin> So what? Does that mean Env&Stacks members should be elected again? I probably missed some important information about why or what are we solving here
12:53:42 <ncoghlan> I personally have two main concerns with the WG make up at the moment:
12:54:00 <ncoghlan> - too high a proportion of @redhat.com addresses
12:54:31 <vpavlin> ncoghlan: agreed, but you cannot force community to participate:(
12:54:34 <ncoghlan> - not enough representation from different language communities
12:54:46 <ncoghlan> I think longer term, elections would help
12:55:00 <ncoghlan> but at the moment, I don't think they'd be very meaningful
12:55:09 <ncoghlan> without growing the group first
12:55:12 <juhp_> also some members seem less active
12:56:41 <hhorak> juhp_ that's also my concern and that's the main reason for me to re-elect.
12:56:48 <juhp_> okay
12:57:05 <ncoghlan> sure, that seems reasonable
12:57:24 <vpavlin> +1
12:57:31 <bkabrda> +1
13:00:55 <hhorak> I can send some more detailed proposal how it could work after consulting what the infrastructure about voting
13:00:57 <juhp_> according to the Charter the first elections would be around the same time as Fesco's.  In January?
13:02:01 <hhorak> juhp_ that's how I understand it
13:03:08 <juhp_> sounds okay - maybe my only concern is not sure how closely the general fedora contributors are following this WG but maybe we won't have too many candidates anyway? :)
13:03:45 <hhorak> yeah, that might be also true
13:03:48 <hhorak> #action hhorak will consult what the infrastructure for voting is needed and will send some proposal with more detailed steps
13:03:56 * vpavlin is curious if there will be any:)
13:04:04 <juhp_> hhorak, thanks
13:04:50 <hhorak> anybody has anything more for elections?
13:04:59 <ncoghlan> vpavlin: I'll at least nudge some of our internal Java devs to get involved :)
13:05:22 <juhp_> I guess our meeting time is quite early for US now
13:05:50 <vpavlin> ncoghlan: good
13:08:26 <hhorak> juhp_: well, it is but nobody from US voted for some better time, so should we bother?
13:08:42 <juhp_> true
13:09:35 <juhp_> I was just thinking of tflink etc
13:10:06 <vpavlin> I think we should vote about new time after new members are elected...
13:10:08 <ncoghlan> it shouldn't be too bad for East coast folks
13:10:10 <juhp_> the new time is great for me anyway :)
13:10:17 <vpavlin> (or they should vote...)
13:10:18 <juhp_> vpavlin, sure
13:10:30 <ncoghlan> but yeah, combining west coast with Australia and Europe isn't pretty :)
13:10:33 <hhorak> vpavlin: right
13:10:36 <juhp_> anyway was just a side comment
13:13:01 <hhorak> #topic Chairman for next meeting
13:13:08 <juhp_> anyway as part of the process probably good to confirm interest with current voting members
13:13:19 <juhp_> or reconfirm
13:13:46 <hhorak> juhp_: not sure I follow, what would you like to re-confirm?
13:13:57 <hhorak> interest being a voting member?
13:14:02 <juhp_> right
13:15:13 <hhorak> juhp_: I agree, that's something I will involve in the proposal about voting, but thanks for pointing to that
13:15:19 <juhp_> okay
13:15:39 <vpavlin> "Elections for half the seats will be held" - who will be the half?:-P
13:16:08 <juhp_> we'll toss coins  <justkidding/>
13:16:41 <juhp_> anyway there is nothing to stop people from nominating themselves again :)
13:18:02 <juhp_> I guess half the members are here today?
13:19:08 <bkabrda> I volunteer for the half. I feel like I'm not a great asset to this WG (and I do things that I would do anyway)
13:19:19 <bkabrda> *the half to be reelected, that is :)
13:19:42 <hhorak> vpavlin: I kind of hope that the half to be not-elected won't raise their hand as want to continue (as they're non active)
13:19:54 <hhorak> bkabrda: and I did not mean you ^ :)
13:20:01 <juhp_> hhorak, +1
13:20:58 <hhorak> bkabrda: I must disagree with your thinking, I think you're big asset, but won't force anybody to stay for sure..
13:21:09 <juhp_> +1
13:21:29 <juhp_> bkabrda, or at least stand again :)
13:21:29 <ncoghlan> hhorak: +1
13:21:33 <vpavlin> Speaking about languages not being represented in WG....bkabrda - you cannot leave:-P
13:21:40 <juhp_> lol
13:21:44 <ncoghlan> heh
13:21:58 <bkabrda> hhorak: I know, it's probably just about my feeling. I feel like I'm better contributor to Fedora if I contribute my time by direct work instead of going to this meeting. this doesn't mean that the WG is useless or that I'm not doing anything... it's just about my feeling that I'm more  useful to fedora otherwise
13:22:41 <bkabrda> but I can stand again and let other Fedora contributors decide that
13:23:24 <hhorak> bkabrda: +1
13:23:35 <ncoghlan> I think as the group grows, it may be easier to have folks that are working on Env & Stacks activities, without being voting members of the WG
13:24:13 <hhorak> ncoghlan: right, that's fine with me as well
13:26:19 <bkabrda> yeah, I'll become such an informal member if not reelected
13:26:53 <hhorak> ok, it seems we can move to picking up a chair for the next week, anybody interested?
13:27:47 * juhp_ thinks hhorak is doing a great job as chair
13:28:04 * vpavlin agrees but if hhorak wants to pass it for next week, I can take it
13:28:51 <hhorak> vpavlin: It would be great, thanks!
13:29:08 <hhorak> #info vpavlin will chair the meeting the next week
13:29:10 <juhp_> :)
13:30:26 <hhorak> #topic Open Floor
13:31:08 <hhorak> time-out for closing the meeting if nobody speaks up set to 3 mins.
13:34:09 <hhorak> #endmeeting