env-and-stacks
LOGS
12:59:45 <hhorak> #startmeeting Env and Stacks (2014-10-07)
12:59:45 <zodbot> Meeting started Tue Oct  7 12:59:45 2014 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:59:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
12:59:49 <hhorak> #meetingname env-and-stacks
12:59:49 <zodbot> The meeting name has been set to 'env-and-stacks'
12:59:55 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp ncoghlan vpavlin sicampbell
12:59:55 <zodbot> Current chairs: bkabrda hhorak juhp ncoghlan pkovar samkottler sicampbell tjanez vpavlin
13:00:03 <hhorak> #topic init process
13:00:26 <vpavlin> hey
13:00:34 <hhorak> Hi all!
13:02:18 <hhorak> #topic FollowUp: mapping CVEs to Docker images that need rebuilding
13:02:42 <juhp_> hi
13:02:47 <hhorak> #info summary from Nick (who talked to stano) is on ML, feel free to read details there
13:03:27 <hhorak> do we have anything else to discuss about this topic for now?
13:04:15 <vpavlin> Nothing from me
13:06:08 * juhp_ is reading
13:06:21 <hhorak> IMO, the approach of dividing the problem for base and layered images makes sense, but we should then keep looking how to solve the layered images vs. CVEs (or generally bugs) problem
13:06:33 <ncoghlan> evening all
13:06:39 <zdover> evening ncoghlan
13:06:48 <hhorak> Hi!
13:07:18 <ncoghlan> hhorak: yeah, the exchange with Stano made me realise that the layered image problem is one *nobody* has properly solved yet
13:07:38 <vpavlin> hhorak: Yes, but as long as we ship only Dockerfiles we have nothing to rebuild actually:)
13:07:52 <ncoghlan> OpenShift v3 currently appears to be one of the *most* mature solutions for building them
13:08:07 <ncoghlan> so as vpavlin says, it's likely best to stick with just Dockerfiles for now
13:08:31 <ncoghlan> it kicks the can down the road a bit
13:08:36 <vpavlin> I'd love to see layered images being built in Koji
13:08:36 <juhp_> vpavlin, haha
13:08:50 <vpavlin> But...that loooong way to go
13:08:59 <ncoghlan> vpavlin: yeah
13:09:01 <juhp_> ah true
13:10:00 <vpavlin> I've talked to few openshif guys and yes, they probably got farthest
13:10:17 <vpavlin> Question is - does Openshift fit into Fedora infrastructure?
13:10:31 <ncoghlan> vpavlin: open question at this point
13:10:46 <ncoghlan> however, there's a live project called OpenStack Kolla
13:10:53 <bkabrda> hi!
13:10:57 <ncoghlan> no, wait, that's not the one I meant
13:11:22 <ncoghlan> that's running OpenStack *on* Kubernetes+Atomic, not the other way around
13:11:49 <bkabrda> nothing from me either
13:12:18 <vpavlin> ncoghlan: And that's interesting for us at the moment because...?
13:12:34 <ncoghlan> vpavlin: it's not, I had the dependencies inverted in my head for a moment
13:12:49 <ncoghlan> vpavlin: and was thinking it was a way to run OpenShift on Fedora's OpenStack instance
13:13:00 <hhorak> #info we do not need to solve the CVE vs. layered image for now, as we are going to ship Docker files first, but it will come up in the future
13:13:00 <hhorak> #info building layered images in koji is not going to be done any soon
13:13:27 <vpavlin> ncoghlan: Ok
13:14:33 <hhorak> I'm kind of disoriented by mentioning OpenShift -- why do we talk about it?
13:14:49 <ncoghlan> hhorak: they're tackling the layered image building problem
13:14:53 <ncoghlan> for v3
13:15:35 <ncoghlan> and the whole area is changing fast enough, it's hard to keep track of what's going on
13:16:31 <hhorak> ncoghlan: exactly.. do they still use pure docker images or something above it?
13:16:41 <vpavlin> hhorak: Both
13:16:51 <vpavlin> They can run/build Docker images from Dockerfiles
13:17:13 <vpavlin> and also run STI - Source To Image
13:17:37 <ncoghlan> https://openshift.github.io/documentation/openshift-pep-010-docker-cartridges.html has all the gory details
13:17:41 <vpavlin> Which is basically just bunch of scripts that are run in container and container is then committed as image
13:18:46 <ncoghlan> their model makes sense, but how they're going to wrap a coherent user experience around it, I don't know
13:18:49 <hhorak> #info openshift is tackling the layered image building problem, so they might know more about this issue
13:18:49 <hhorak> #link https://openshift.github.io/documentation/openshift-pep-010-docker-cartridges.html
13:19:23 <ncoghlan> and it isn't clear how easy it will be to extract the built images for use elsewhere
13:19:53 <vpavlin> And also the reproducibility and trackability is the question
13:20:00 <ncoghlan> OTOH, their model could also form the basis for a possible future solution for layered image builds in Koji
13:20:35 <vpavlin> If they are going to provide enough information about builds and resulting images
13:20:35 <ncoghlan> yeah, OpenShift gets to punt on that question a bit, but leaving it up to the individual dev teams
13:21:06 <ncoghlan> that doesn't scale to layered images provided as part of a distro like Fedora
13:22:01 <ncoghlan> still, we're far from the only ones interested in the topic, so I see a lot of value in sticking with Dockerfiles for now
13:22:31 <vpavlin> +1
13:22:33 <ncoghlan> and following the progress of OpenShift v3 and anything RCM efforts around Koji when it comes to layered images
13:23:00 * ncoghlan tries to parse the second half of that last sentence
13:23:23 <ncoghlan> ah, I think I meant "anything RCM comes up with around Koji"
13:23:56 <hhorak> vpavlin: I also heard about putting some docker-related work to copr (was that also about creating layered images?), but I'm not sure how far is this effort, if still on the plan -- vpavlin, happen to have any news?
13:24:16 <juhp_> ncoghlan, +1
13:24:46 <vpavlin> Yes, I wanted copr based layered images to be available
13:24:47 <hhorak> #info we're far from the only ones interested in the topic, so let's stick with Dockerfiles for now and follow the progress of OpenShift v3
13:25:07 <vpavlin> Sadly, no progress yet
13:26:33 <hhorak> https://bugzilla.redhat.com/buglist.cgi?product=copr does not include any bug/rfe related to docker, shoudn't we add it there?
13:26:56 <vpavlin> hhorak: I'll talk to msuchy once more and add it there then
13:27:17 <hhorak> vpavlin: thanks, that will help to track it
13:27:53 <hhorak> #action vpavlin will talk to msuchy once more and add a RFE bug for copr project then
13:28:50 <hhorak> #action hhorak will add this issue to the task list at https://fedoraproject.org/wiki/Env_and_Stacks/Tasklist
13:29:56 <hhorak> let's move to another docker topic..
13:30:01 <hhorak> #topic Docker Documentation for Fedora
13:30:59 <zdover> zdover here -- I probably have a lot of the Docker documentation already written.
13:31:03 <zdover> I just need to know what you guys need.
13:31:12 <vpavlin> zdover: Hey
13:31:19 <zdover> vpavlin, hi
13:31:36 <hhorak> zdover: Welcome!
13:31:57 <vpavlin> We woule like to create simple web site where people could find all important and useful information about Docker in Fedora
13:32:25 <pkovar> you mean like a docs site?
13:32:27 <vpavlin> I'd imagine some How tos
13:32:33 <zdover> Do you have a website set up already, or would we have to build it from the ground up?
13:32:42 <vpavlin> Links to wiki pages
13:32:47 <hhorak> I thought this could be something between documentation and marketing
13:32:58 <hhorak> zdover: nothing setup yet
13:33:20 <pkovar> we were talking about creating a developer-oriented docs site for fedora at flock
13:33:30 <pkovar> similar to readthedocs
13:33:42 <vpavlin> Yeah, exactly - Docker is "cool", so we should also have some "cool" place were to go to get info about it in Fedora
13:33:48 <pkovar> based on some lightweight markup language
13:34:03 <pkovar> zdover: what is the format of your docs?
13:34:13 <pkovar> markdown?
13:34:20 <zdover> pkovar, right now they're in Docbook 4.5, but I can change them to whatever language you'd like.
13:34:23 <ncoghlan> pkovar: that would be cool
13:35:15 <ncoghlan> I'm wondering if there's some broader effort we should be aiming to align with, though
13:35:26 <pkovar> we could go with Docbook 4.5 and publish it at docs.fp.o, but XML is not very developer-friendly
13:35:46 <ncoghlan> such as https://fedoraproject.org/wiki/Marketing
13:35:50 <zdover> I can convert them to markdown. It is not a very big cost to me.
13:36:01 <pkovar> ok
13:36:40 <pkovar> zdover: do those docker docs also include topics on packaging?
13:37:20 <zdover> pkovar, they don't right now. The only docs I have written on packaging are internal RH packaging procedures and practices.
13:37:34 <zdover> I could generate docs on packaging probably also without very much trouble.
13:37:47 <zdover> I just need to be pointed in the direction of the content that you want to present.
13:39:05 <zdover> ncoghlan, are you suggesting that we write the docs in mediawiki?
13:39:09 <zdover> If so, that's also no problem.
13:39:26 <vpavlin> So, I'd really like to see something like this:  https://www.softwarecollections.org/en/
13:39:48 <vpavlin> Fancy landing site for people looking for Docker and Fedora
13:40:40 <ncoghlan> zdover: I know MediaWiki is the option they went with for ovirt.org
13:41:15 <zdover> ncoghlan, that's true. I used to work on RHEV. It was indeed MediaWiki.
13:41:52 <ncoghlan> vpavlin: that seems to be getting us into some level of overlap with http://www.projectatomic.io/
13:41:57 <zdover> vpavlin, pkovar, if you're RH-internal, I can link you to my docs so that you can see the content.
13:42:17 <ncoghlan> since most of the Project Atomic bits are actually being developed in Fedora
13:42:28 <hhorak> I thought such a landing page would be more focused on users of docker, where to get docker files, images, etc.. the documentation pkovar mentioned could then be more focused on people who want to create new fedora docker files..
13:42:29 <zdover> (However, I'm not used to working here on freenode, so I'm not sure if it's cool for me to post an internal link.)
13:42:36 <ncoghlan> (well, I think they are - I lose track sometimes)
13:42:44 <zdover> ncoghlan, I am also the docs guy for projectatomic.
13:44:20 <ncoghlan> zdover: ah, I should introduce you to Amit Saha - he's working on Beaker's Atomic support
13:44:24 <ncoghlan> however, back on topic
13:44:35 <ncoghlan> hhorak's suggestion makes sense to me
13:44:59 <zdover> I have the content for hhorak's landing page ready to go, as soon as the page exists somewhere.
13:45:37 <vpavlin> yes, I don't want to have just another docs page - it should be more a hub with directions where to get info you need
13:46:00 <zdover> I don't mean to shirk the creation of the page, I just am not accustomed to creating pages in this kind of situation. The way that we used to create documentation was in Publican. It seems that we're moving past that, so I just need a place to start building the page.
13:46:26 <zdover> I can absolutely build a hub that directs people to the documentation pitched at their level of understanding.
13:47:32 <ncoghlan> vpavlin, hhorak: to avoid getting too bogged down, perhaps we could just go with a page on the main wiki to start with?
13:47:48 <ncoghlan> and if we later decide to move it elsewhere, we can do that
13:48:45 <ncoghlan> https://fedoraproject.org/wiki/Getting_started_with_docker exists currently
13:48:51 <hhorak> ncoghlan: why not, to define basic content, that could work fine. we'll then see it in a better light..
13:48:54 <zdover> ncoghlan, that sounds fine to me. We can work on presentation later.
13:49:19 <vpavlin> Yes, that might work
13:49:20 <zdover> Do I have permission to add material to this wiki page?
13:49:23 <ncoghlan> https://fedoraproject.org/wiki/Docker doesn't exist yet, and could make a good home for a hub
13:49:31 <zdover> If so, I will spend an hour or two filling it this evening.
13:49:43 <ncoghlan> o.O nightowl :)
13:50:48 <zdover> ncoghlan, the flipside of that is that I won't be in the office early tomorrow.
13:50:55 <hhorak> zdover: signing Fedora Project Contributor Agreement should be all you need imho
13:51:04 <ncoghlan> I put some placeholder text at https://fedoraproject.org/wiki/Docker
13:51:21 <ncoghlan> beyond that, you should just need a Fedora account in order to sign in
13:51:40 <zdover> I believe I do have a Fedora account.
13:51:52 <hhorak> zdover: so you should be fine..
13:52:14 <zdover> I'll create https://fedoraproject.org/wiki/Docker and add material to it.
13:52:23 <zdover> Is this meeting weekly or nightly, or what?
13:52:28 <ncoghlan> weekly
13:52:29 <vpavlin> weekly
13:53:04 <ncoghlan> I'm a nightowl myself, but I wouldn't cope if it was every day :)
13:53:21 <juhp_> 8)
13:54:13 <hhorak> #info the idea is to create simple web site where people could find all important and useful information about Docker in Fedora (some landing page that would be more focused on users of docker, where to get docker files, images, etc.. the documentation more focused on people who want to create new fedora docker files would be only linked from this, not actually kept here)
13:54:13 <hhorak> #action zdover will create some initial content at https://fedoraproject.org/wiki/Docker
13:54:20 <zdover> So be it.
13:54:51 <hhorak> zdover: feel free to use the mailing list if the meeting time doesn't fit to you
13:55:03 <hhorak> zdover: and thanks for helping us with this!
13:55:21 <zdover> hhorak, I appreciate the opportunity to get my work into the community.
13:55:25 <zdover> thanks, everyone
13:56:03 <hhorak> pkovar: about the developer documentation portal we talked on flock and which was supposed to be better than just a wiki -- anything happend since Flock?
13:57:47 <ncoghlan> it would be cool to have somewhere to do docs that are managed via source control
13:58:09 <ncoghlan> one of the best features markdown/sphinx/asciidoc offer over a wiki
13:59:25 <hhorak> not sure if I have correct perception, but docs.fedoraproject.org is managed by source control, but problem is the format - xml, right?
14:00:25 <juhp_> ncoghlan, http://gitit.net/ :)
14:03:02 <ncoghlan> hhorak: yeah, that and publican's "book" focused assumptions
14:03:30 <ncoghlan> (although it's not clear how many of those are actually baked into publican itself, and how many just related to the way it's historically been used)
14:04:18 <ncoghlan> technically you can use markdown and asciidoc as inputs to the publican toolchain, though
14:04:29 <ncoghlan> just requires a bit of scripting
14:04:39 <ncoghlan> juhp_: nice :)
14:05:05 <ncoghlan> we used to maintain the internal docs for several tools in DocbookXML
14:05:27 <ncoghlan> switching made it a lot easier to get developers to actually write docs :)
14:06:51 <ncoghlan> however, unlike zdover, I actually have a meeting this morning, so I'm going to have to bail at this point
14:06:58 <hhorak> the wiki has advantage that everyone is able to edit the content; we could probably have something like that with git as well + having reasonable structure could also be editable easily
14:07:14 <ncoghlan> g'night all - see you next week
14:07:17 <zdover> I am already putting some F19 content into the wiki. You guys can get a look at it in about five minutes.
14:07:22 <zdover> goodnight, ncoghlan
14:07:51 <hhorak> ncoghlan: ok, by
14:07:54 <hhorak> *bye
14:08:32 <hhorak> anyway, pkovar might have some other idea already discussed, but he seems to be afk right now, so we can discuss it in some of the next meetings..
14:09:39 <hhorak> #info we'll discuss the idea about documentation with source control on some of the next meetings.
14:11:05 <hhorak> We're over 70 minutes already, do we have energy to discuss "Idea: Ability to define dependencies between coprs (correctly)"?
14:11:51 <bkabrda> hhorak: I'd like to discuss that, but preferrably not today...
14:12:12 <hhorak> we may continue on ML then...
14:12:41 <hhorak> #topic Picking chairman for the next meeting
14:12:52 <hhorak> anybody interested?
14:13:12 <vpavlin> I will be travelling fo Plumbers conference next Tuesday
14:13:21 <vpavlin> So I won't be on the meeting
14:14:24 <juhp_> I will be in Tokyo next week but I will try to join the meeting if I can
14:14:25 <hhorak> vpavlin: ok :)
14:15:38 <hhorak> so it seems I will have to do it :)
14:15:48 <hhorak> #action hhorak will chair the next meeting
14:15:55 <hhorak> #topic Open Floor
14:16:08 <hhorak> timeout 2minutes :)
14:17:38 <hhorak> #endmeeting