workstation
LOGS
15:00:55 <jwb> #startmeeting
15:00:55 <zodbot> Meeting started Wed Sep 24 15:00:55 2014 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:55 <jwb> #meetingname workstation
15:00:55 <jwb> #meetingtopic Workstation WG meeting
15:00:55 <jwb> #topic init
15:00:55 <jwb> #chair juhp cwickert otaylor mclasen cschalle ryanlerch ltinkl jwb kalev
15:00:55 <zodbot> The meeting name has been set to 'workstation'
15:00:55 <zodbot> Current chairs: cschalle cwickert juhp jwb kalev ltinkl mclasen otaylor ryanlerch
15:01:03 <jwb> hi all.  who's around?
15:01:09 * mclasen_ realizes it is that time already
15:01:17 * stickster here
15:01:18 * elad661 is here but will probably not be able to stay for the whole meeting
15:01:36 * kalev waves.
15:02:09 <juhp_> hi
15:02:37 <jwb> we'll wait for just a minute or two and see if the rest show up
15:03:03 <jwb> i don't think we have quorum at the moment
15:03:42 <mclasen_> cschalle is probably booked for the whole day in meetings
15:04:18 <jwb> ok
15:05:11 * bitlord says hello to Ws WG and others!
15:05:14 <jwb> let's get started
15:05:22 <jwb> #topic GNOME Classic in default install
15:05:43 <jwb> so a while ago sgallagh noticed that Classic was offered under GDM in a default WS install
15:05:55 <jwb> there was some discussion on-list, and i think Alpha shipped like that still
15:05:55 <mclasen_> from a maintenance perspective, I don't think it hurts us to have it there
15:06:17 <bitlord> alpha_rc1 here, yes there is two sessions in gdm (alpha_rc1 == alpha?)
15:06:17 * sgallagh lurks
15:06:40 <elad661> Would removing it have any benefit, actually? If we still have to maintain it, and there's no graphical way to install it
15:06:46 <elad661> then maybe removing it is not a good idea.
15:06:50 <sgallagh> It was also screenshotted in the Phoronix review: http://www.phoronix.com/scan.php?page=article&item=fedora_21_alpha&num=2
15:06:55 <jwb> i'd prefer to leave it in any case
15:07:17 <jwb> sgallagh, yes... well. phoronix
15:07:25 <sgallagh> (Sidebar: they reviewed Fedora Workstation very positively)
15:07:42 <mclasen_> to be fair, he probably wanted to show the wayland session showing up there ?
15:07:48 <elad661> Yep, I think so
15:08:05 <bitlord> as not part of this WG, I just want to say, classic session is not fallback anymore, it also needs proper driver and 3d acceleration support?
15:08:09 <kalev> if we ship the classic session, should also make sure it actually works
15:08:15 <kalev> I guess it means adding it to QA test pages
15:08:24 <mclasen_> anyway, I'm in favor of leaving it in too
15:08:25 <otaylor> bitlord: Yes
15:08:27 <jwb> kalev, sure.  i think it's worth doing
15:08:39 <elad661> kalev: yep, if upstream supports it, and we ship it, then it should work
15:08:40 <jwb> ok, so it sounds like we have consensus to leave it in by default
15:08:55 <kalev> sure, sounds good to me
15:09:09 <jwb> #agreed leave Classic included by default.  Work with QA to ensure it gets properly tested
15:09:20 <mclasen_> kalev: adding a testcase sounds good; I tried it with 3.14 this morning and it worked fine, ftr
15:09:21 <jwb> anything else on this before we move on?
15:09:52 <jwb> ok, moving on
15:09:59 <jwb> #topic Target image size
15:10:18 <jwb> so in the libreoffice discussions, mclasen_ mentioned it might be more productive to see if we have a target size in mind for our deliverable
15:10:29 <jwb> Alpha shipped at 1.3GB for the live image
15:11:08 <jwb> it would seem logical that 1GB or 1.5GB would be the 2 targets, but i think 1.5 (or less) is likely the most reasonable
15:11:21 <elad661> Yep I was just about to say this
15:11:24 <jwb> i don't think we're going to get down to 1GB and still keep things useful
15:11:24 <elad661> hey cwickert
15:11:39 * cwickert is sorry to be late
15:11:40 <juhp_> hm
15:11:49 <otaylor> mclasen_: Why do you think a target is necessary?
15:12:08 <cwickert> otaylor: because rel-end and ambassadors need to plan
15:12:09 <otaylor> 1.5 or 1 seem pretty arbitrary - smaller than any USB stick normally found, larger than a CD
15:12:16 <mclasen_> we seem to be going in circles a bit, discussing to add interesting things and to cut big things...
15:12:19 <kalev> I personally think it should be less than 2 GB, but the exact number doesn't overly matter
15:12:20 <elad661> we can't possibly make the image that small without removing stuff we can't remove (we install two versions of webkit, for example, that takes quite a bit of space, and the consensus on list is to keep libreoffice in)
15:12:43 <juhp_> F20 was under 1GB
15:12:48 <mclasen_> if we have a target size, we have a natural point to say 'do we need to discuss cutting things or are we fine ?'
15:13:00 <jwb> F20 didn't include libreoffice (iirc) and none of the QT stuff
15:13:06 <jwb> we're expanding the scope here
15:13:10 <elad661> yes, for F20 we didn't ship qt, two versions of webkit, libreoffice, etc etc
15:13:13 <mclasen_> elad661: the 2 webkits hurts
15:13:20 <mclasen_> but it is not something we can fix for f21
15:13:23 <elad661> yep.
15:13:29 <kalev> F20 included libreoffice IIRC, but didn't include boxes and the qt stuff
15:13:41 <mclasen_> we should aim for that for f22
15:13:46 <jwb> mclasen_, yes, i think having a limit (arbitrary or not) helps with those kinds of discussions
15:13:48 <elad661> it was a long time ago, I can't remember accurately :)
15:14:25 <bitlord> I think kalev is right no qt and boxes, but libreoffice was there (I can load a f20 live now and see if you want)
15:14:26 <otaylor> I dont't find a target here useful - anything less than 2GB is OK technically, and making it smaller than that is pretty much linearly better for download time
15:14:30 <jwb> 2GB is also fine with me.  i just went with 1.5 because it's the closest round-ish number to what we have now
15:14:49 <jwb> bitlord, not necessary, but thank you
15:15:32 <elad661> 2GB is big, but yeah there's no reason we'll go near that soon
15:15:38 <elad661> so it should be fine I guess
15:16:04 <jwb> so by keeping it larger, we're implying that the benefits it provides outweight the increased download time
15:16:55 <elad661> That's the consensus on list, yes
15:16:58 <juhp_> I thought part of WS was about post-installing apps etc - anyway I feel 0.5GB steps is rather big
15:17:24 <otaylor> jwb: I'm more saying that the benefits of adding Java for libreoffice extensions or whatever need to argued on their merits, not based on "that would put us over 1.5GB, sorry"
15:17:45 <elad661> I'd also want to make it smaller, but the consensus is clear that we can't remove libreoffice or any of the other big things
15:17:54 <juhp_> otaylor, I guess that is true
15:18:07 <jwb> otaylor, we can do it that way.  it just means a lot more scrutiny on everything, which isn't necessarily bad
15:19:02 <juhp_> the java dependency is painful though in terms of space
15:20:08 <jwb> so i think we've agreed (mostly) that libreoffice stays.  do we want to review additions/removals regardless of their size impacts, or do we set a limit/target?
15:20:46 <juhp_> I feel at least a soft limit is a helpful guideline
15:20:55 <kalev> the java dependency is a bit weird, because it's the headless version
15:21:01 <kalev> if we wanted to support libreoffice java extensions, I think it would make sense to ship the full version
15:21:02 <juhp_> nod
15:21:03 <elad661> juhp_: +1
15:21:03 <mclasen_> seem so; 2G was mentioned as possible hard limit and 1.5G as a possible soft limit
15:21:05 <kalev> but the headless version is weird midway that doesn't really support all java extensions properly but still takes up space
15:21:21 <orc_fedo_> why is Libreoffice un-removable ?  it is the gorilla that blows up the image? -- abiword and gnumeric work for all I do ...
15:21:30 <elad661> kalev: we can't ship the non headless one - it's against the launcher guidelines :)
15:21:37 <elad661> orc_fedo_: that's a different issue
15:22:14 <kalev> elad661: easy enough to fix ...
15:22:19 <jwb> otaylor, do you have an issues with having the soft/hard limits and still discussing things on merit?
15:22:28 <jwb> the limits could just be another factor to take into account
15:22:39 <juhp_> how about 1.5G as a hard limit?
15:22:42 <elad661> kalev: technically: yes, politically: not so much
15:22:58 <bitlord> orc_fedo, I think libreoffice is better when you need compatibility with other mostly proprietary office suites
15:23:21 <bitlord> orc_fedo, and most people who do office stuff, need that, when they send or receive documents from other people
15:23:27 <otaylor> jwb: it feels like a crutch - basically taking "is a) worth it" and turning it into "is a) worth it more than anything else in the distro" - but maybe that's a useful crutch
15:23:35 <mclasen_> libreoffice is also what we have a sizable team working on
15:23:38 <jwb> bitlord, orc_fedo: let's not discuss that right now.  it's a tangent
15:23:57 <bitlord> jwb, ok
15:24:19 <jwb> otaylor, yes it's a crutch.  but i view it more as something you'd fall back on only if there wasn't overwhelming opinions one way or another
15:24:53 <jwb> ignoring the size impacts entirely seems wrong to me
15:25:06 <juhp_> given that we are only installing headless currently which is only midway, would it be better to make the java requirement be a post install addition?
15:25:35 <otaylor> jwb: Does this mean that if we say 1.5GB is the soft limit, and we're < 1.5GB now, we stop discussing things like java?
15:26:20 <jwb> otaylor, doesn't have to be, no.  if people find it odd and not useful to include, then we can certainly still discuss it
15:26:50 <jwb> i'm thinking of the limits more like "hm.  thing X is kind of useful, but i'm not sure if most people would use it or not.  Oh and it pushes us over the size limit"
15:27:22 <juhp_> jwb, right
15:28:45 <otaylor> jwb:  I'm not convinced about usefulness,  but not opposed if people want to declare a soft limit - as I see it, it would basically comes down to us declaring a goal to keep F22 download size under 1.5GB
15:29:30 <jwb> sure.  i think that's something worth trying.  and if it starts proving impractical i think we can always revisit it
15:30:28 <jwb> so we start with a soft limit of 1.5GB?
15:30:45 <mclasen_> +1
15:30:48 <juhp_> +1
15:30:53 <kalev> sure, +1
15:30:55 <otaylor> +1
15:31:05 <jwb> cwickert, ?
15:31:45 <jwb> i'm +1 fwiw
15:32:03 <jwb> which means this passes, but i want to give cwickert a sec to vote
15:32:03 <kalev> I can do a report for the next meeting showing package additions and removals compared to the F20 image
15:32:08 <kalev> and we can then go over these and if anything is questionable, vote if it should remain included or not
15:32:14 <jwb> kalev, i think that would be very useful
15:32:24 <juhp_> kalev, that would be informative thanks
15:32:35 <jwb> #agreed Workstation image size has a soft limit of 1.5GB for F21/F22
15:32:56 <jwb> #action kalev to produce a report of additions/removals compared to F20 for review
15:33:03 <jwb> ok, moving on
15:33:09 <jwb> #topic WG member re-affirmation
15:33:14 <jwb> so two things on this
15:33:25 <jwb> mostly just to re-affirm that the WG members are still interested in being WG members
15:33:34 <jwb> and then we need to figure out how to replace ltinkl
15:33:45 <jwb> he has said he's fine with stepping down
15:33:50 <jwb> and he hasn't been active in some time
15:34:03 <jwb> so for the WG members present, are you still interested?
15:34:05 <jwb> i am :)
15:34:09 <kalev> I am
15:34:22 <juhp_> yes
15:34:26 <otaylor> i am
15:34:42 * mclasen_ too
15:35:04 <jwb> i'll follow up with ryanlerch and cschalle
15:35:13 <kalev> as for the vacant seat, I would like to nominate aday, but haven't still asked him if he'd be interested :)
15:35:15 <cwickert> jwb: sorry for the late reply, I'm +1 to the 1,5 gb
15:35:32 <jwb> cwickert, great.  and you're still interested in being a WG member, yes?
15:35:38 <cwickert> jwb: yes
15:35:38 <aday> thanks for the vote of confidence, kalev :)
15:35:49 <kalev> oh, you are here!
15:36:23 <aday> kalev, yep. sorry, prepping the 3.14 release marketing
15:36:35 <aday> we're in a countdown situation...
15:36:48 <jwb> i have no issues with aday as a candidate.  however, i was thinking of asking rdieter_work as he has expressed interest in working on the KDE aspects
15:37:04 <otaylor> I think aday would be great, but we are very RH heavy at the moment. Are we concerned with that?
15:37:12 <jwb> otaylor, tbh, i am
15:37:21 <mclasen_> I would love to have somebody more from the developer/tools side on board, but no candidate suggestions
15:37:48 <jwb> we don't need to settle this today, so if people would like more time to discuss with people and come up with nominations, that's fine
15:38:01 <jwb> i just wanted to make sure we were actively looking for a replacement
15:38:48 <jwb> shall we defer today and discuss on-list in the meantime?
15:38:49 <mclasen_> jwb: how will this work; we suggest a replacement to fesco and they confirm ?
15:38:55 <jwb> mclasen_, no, it's entirely up to us
15:39:11 <mclasen_> autonomy! I love it
15:39:19 <jwb> the candidate needs to be FCPA+1 in FAS.  other than that, we don't have any requirements
15:39:37 <jwb> (per our own governance doc)
15:40:00 <kalev> let's see if my candidate fits
15:40:03 <kalev> fasinfo aday
15:40:14 <kalev> .fasinfo aday
15:40:15 <zodbot> kalev: User: aday, Name: None, email: aday@redhat.com, Creation: 2012-05-20, IRC Nick: None, Timezone: None, Locale: None, GPG key ID: None, Status: active
15:40:17 <zodbot> kalev: Approved Groups: fedorabugs cla_fpca cla_done
15:40:24 <kalev> wohoo, fedorabugs!
15:40:32 <jwb> heh
15:40:36 <aday> yeah, don't tell anyone ;)
15:40:59 <jwb> ok, i have one other topic i found after creating the agenda.  let's defer on this for today and try and discuss on-list
15:41:02 <jwb> sound reasonable?
15:41:06 <juhp_> kalev, lol
15:41:09 <otaylor> jwb: sounds good to me
15:41:22 <kalev> jwb: sounds good, I'm itching to go back to my blog post too
15:41:36 <jwb> #info present WG members all wish to remain on the WG.  jwb to follow up with absent members
15:41:41 <jwb> #info discuss open seat on the list
15:41:44 <jwb> ok, last topic
15:42:08 <jwb> #topic CUPS
15:42:12 <jwb> #link https://fedorahosted.org/workstation/ticket/8
15:42:25 <jwb> twaugh filed the above ticket a while ago
15:42:41 <jwb> he's asking for CUPS to be enabled for socket activation by default in Workstation
15:42:47 <elad661> I think it's reasonable
15:42:58 <jwb> i agree
15:43:16 <kalev> especially since it's coming from the printing tools maintainer
15:43:27 <stickster> +1
15:43:31 <mclasen_> +1 from me too
15:43:37 <stickster> Not that my vote counts, but I wanted to say something useful :-)
15:43:47 <kalev> +1, and I'm happy to do the legwork to actually make the change happen
15:43:58 <stickster> s/useful// :-D
15:44:07 <mclasen_> something we wanted to have for a long time, speed up boot by moving things to demand-activated
15:44:32 <jwb> otaylor, cwickert: any concerns?
15:44:37 <elad661> Boot is already quite fast, but there's no reason to not make it faster :)
15:44:40 <otaylor> +1 ... probably most boots of fedora, nothing will be printed
15:44:40 <jwb> juhp_, ?
15:45:09 <juhp_> +1
15:45:18 <mclasen_> one thing to look at is if we can arrange for automatically going to activate-on-boot when we export a printer
15:45:27 <cwickert> +1, yes please!
15:45:33 <jwb> ok, great.
15:45:44 <jwb> mclasen_, want to work with twaugh and kalev on that?
15:46:03 <jwb> #agreed enable CUPS on demand in Workstation
15:46:03 <mclasen_> it might already work that way, I'll inquire
15:46:18 <jwb> #action kalev and mclasen_ to follow up with twaugh on implementation
15:46:21 <jwb> excellent
15:46:25 <jwb> ok, that's all i have for today
15:46:30 <jwb> does anyone else have a topic to discuss?
15:47:11 <bitlord> jwb, not sure is it right place and time to mention two bugs which affect f21 workstation? (one is a lot less important, but nice to have)
15:47:32 <jwb> bitlord, sure
15:47:36 <jwb> #topic open floor
15:47:43 <sgallagh> I have an item as well (when we get there)
15:47:55 <bitlord> this is the first one, more important, I proposed it as a beta blocker https://bugzilla.redhat.com/show_bug.cgi?id=1145952
15:48:16 <kalev> .bug 1145952
15:48:19 <zodbot> kalev: Bug 1145952 right click on the background locks mouse clicks - https://bugzilla.redhat.com/1145952
15:48:30 <bitlord> second, just to make things more right, we ship rhythmbox, but totem still defaults for music (in my case ogg) https://bugzilla.redhat.com/show_bug.cgi?id=1146001
15:48:59 * mclasen_ reproduces :-(
15:49:06 <kalev> I looked briefly at shared-mime-info and application/ogg mime type seemed to default to rhythmbox correctly
15:49:23 <kalev> but I could reproduce this too, yes
15:49:35 <sgallagh> I can also reproduce the right-click thing.
15:49:35 <bitlord> and actually third thing, is there any progress on making captive portal support easily excluded by user, its config package still depends on 'gnome-shell'?
15:49:40 <otaylor> bitlord: on the first bug, would you mind filing it upstream in gnome bugzilla against gnome-shell?
15:49:48 <sgallagh> bitlord: Heh, that was the topic I was going to raise.
15:49:50 <bitlord> otaylor, done,  already
15:49:51 <otaylor> It seems to be a regression 3.1.91 => 3.1.92
15:49:59 <bitlord> otaylor, linked in rh bugzilla
15:50:14 <otaylor> bitlord: OK, thanks
15:50:16 <mclasen_> sgallagh,bitlord: what is the motivation for making it configurable ?
15:50:21 <mclasen_> does it get in your way ?
15:50:27 <bitlord> otaylor, https://bugzilla.gnome.org/show_bug.cgi?id=737233
15:51:14 <bitlord> mclasen_, just for people who don't need it, and don't want it to run in the background, most people wouldn't know what is going on in the background and maybe they don't want that to run?
15:51:20 <sgallagh> mclasen_: There have been users who don't like the idea of pinging external servers every five minutes. It's a waste of bandwidth.
15:51:38 <bitlord> also, relying on one server doesn't make things work, it can fail on multiple levels
15:51:54 <mclasen_> sgallagh: you could probably talk the nm guys to improve the implementation
15:51:55 <elad661> bitlord: it's mirrored.
15:52:10 <elad661> it's not "one server"
15:52:15 <otaylor> bitlord: so, it's a theeretical concern? You want it for yourself but are worried that some user might want to disable it or that something might go wrong?
15:52:23 <bitlord> I just want to make it optional and easy to exclude, nothing more
15:52:26 <mclasen_> I don't think there's a strong need to keep pinging if there's regular traffic on the net
15:52:54 <mclasen_> it is optional, there's a nm config file to turn it off
15:53:00 <bitlord> otaylor, no, I don't need it, I discovered it by monitoring traffic/connections which is bad way to find out about things :(
15:53:25 <juhp_> ah
15:53:39 <sgallagh> mclasen_: The other concern is that in a tightly-firewalled environment, it might misbehave.
15:53:40 <elad661> mclasen_: if, for example, your ADSL connection goes down, it'll change the indicator icon to a question mark... I think it is useful to have
15:53:48 <otaylor> bitlord:  I can't see us having an opt-in dialog for this
15:53:57 <elad661> having UI for this would be silly
15:53:59 <otaylor> (meaning, I'd be very opposed to that)
15:54:02 <sgallagh> i.e. if outgoing connections are restricted to known hosts, then you're going to end up with a captive portal UI with a 404.
15:54:05 <sgallagh> Not a great experience :)
15:54:14 <bitlord> and some people don't like the way it is introduced (don't want to say this is malicious feature, or it is done in secret to spy on somebody ..., just "silently" where most people won't realize it is there pinging random server without asking)
15:54:31 <elad661> sgallagh: you'd get captive only if there's a redirect. If it's a DROP or REJECT firewall rule, you wouldn't get the captive portal UI
15:54:35 <jwb> aside: i think the first two bugs raised will be looked into.  thanks.
15:54:44 <sgallagh> elad661: OK, I hadn't tried that
15:54:44 <bitlord> elad661, when? (it can still fail in the 300second time frame?)
15:54:50 <mclasen_> sgallagh: that sounds like a case for installing a custom nm configuration to match your environment
15:55:00 <elad661> bitlord: silently? We enabled it after discussing it on the mailing list
15:55:05 <otaylor> bitlord: do you have a concrete proposal here for a change you'd like to see made for F21?
15:55:12 <bitlord> elad661, not everyone follow devel mailing lists ...
15:55:30 <elad661> bitlord: saying we did it "silently" is an outright lie.
15:55:31 <mclasen_> bitlord: I would suggest to nominate the stuck mouse grab as a beta blocker
15:55:45 <bitlord> elad661, read what I typed up ^^^
15:56:13 <elad661> bitlord: all major OSs in both mobile and desktop are doing the exact same thing
15:56:32 <elad661> it's something users expect.
15:56:40 <bochecha> mclasen_, bitlord already nominated it
15:56:58 <juhp_> bitlord, so can you be more explicit about what would make you happy/happier?
15:57:20 <bitlord> elad661, that is why I want to use this os, not those other where I don't know what is doing in the background and cannot turn it off (and I think a lot of other people do the same)
15:57:20 <mclasen_> owen: would you be opposed to an opt-out switch in the privacy panel as well ?
15:57:49 <bochecha> bitlord, you can turn it off
15:57:51 <elad661> mclasen_: an opt out switch in the privacy panel would only be useful if there's an actual privacy concern
15:58:06 <bitlord> juhp_, just make it optional, I think nice fit will be in nm settings/dialog, so you can make it optional per connection (it is mostly used on wifi?)
15:58:16 <elad661> I should note that nobody in the safety BoF in GUADEC thought it's a privacy issue.
15:58:21 <drago01> fwiw I am not convinced that an opt out is needed
15:58:22 <sgallagh> The information shared is essentially "A machine exists at this IP address"
15:58:25 <bitlord> mclasen_, also good way to do it
15:58:25 <sgallagh> Nothing else is shared.
15:58:32 <drago01> the only reason seems to be "just because"
15:58:47 <elad661> sgallagh: right, and the mirror metalink get this info too
15:59:05 <elad661> so it's really not a reason for concern
15:59:06 <bitlord> drago01, it is about options, and also openess (if that is the word)
15:59:07 <drago01> and every other website / service you connect to
15:59:09 <sgallagh> Yes, I will stand and assert that there is no privacy leak here that I can discover.
15:59:12 <mclasen_> elad661: fine, thats an ok answer for me
15:59:15 <stickster> sgallagh: Yeah, I wouldn't call that a privacy concern either. "Privacy concern" in common usage implies personally identifying information.
15:59:26 <drago01> bitlord: no you don't add options for the sake of having options
15:59:27 <sgallagh> bitlord: Let's not get into that discussion again. Choice for its own sake is not a goal.
15:59:34 <drago01> bitlord: options are added to solve problems
15:59:57 <drago01> so in short "no problem" -> "no need for a solution"
16:00:07 <drago01> present a problem and we can try to come up with a solution
16:00:08 <bitlord> also for those who didn't saw this https://fedorahosted.org/fesco/ticket/1337
16:01:17 <bitlord> ok, I just thing "we" fedora need to be more open, and care about users, that is why I filed fesco ticket, and that is why I informed users mailing list (no other plans here, if you don't want to accept it, I don't care, I can move on ...)
16:01:32 <bitlord> think*
16:01:39 <elad661> more open?
16:01:43 <elad661> ...
16:01:56 <drago01> ok this is going no where
16:02:00 <jwb> i think we should let this one go now
16:02:05 <jwb> we're past time anyway
16:02:06 <elad661> drago01: +1
16:02:17 <bitlord> yes elad661, so people know what their system do, not all people track connections, or check for unwanted traffic, but still don't want such feature enabled by default
16:02:20 <jwb> sgallagh, did your question/concern get addressed above?
16:02:40 <bitlord> elad661, also it is advertised as captive portal support (but no "normal" person know how it works)
16:03:00 <juhp_> https://fedorahosted.org/fesco/ticket/1337#comment:12
16:03:02 <jwb> a naming change was already filed upstream
16:03:44 <bitlord> as for the fesco ticket, not all people agree with the feature, or what elad661 says
16:03:49 <elad661> ...
16:04:01 <bitlord> so, it is not just me, and check mailing list thread (on users mailing list)
16:04:08 <stickster> juhp_: Were you indicating that URL to note FESCo is looking for a resolution here?
16:04:17 <juhp_> nod
16:04:17 <bitlord> and, btw. this is still not "live" pre-release
16:04:39 <bitlord> I'm not against the feature, just make it easily optional
16:04:41 <sgallagh> jwb: My question was essentially going to be "Can we advertise the captive portal as a major new feature?"
16:04:55 * stickster also not clear on whether someone has committed to making a change (comps? deps?) to alter this?
16:04:56 <juhp_> why not? :)
16:04:59 <sgallagh> I think that would address the concerns about not knowing it was there, if nothing else
16:05:03 <elad661> stickster: why make a change?
16:05:06 <jwb> fwiw, in the fesco meeting kalev said he'd work on this and likely go with:
16:05:10 <jwb> "Ask Workstation to move the strict dependency to fedora-release-workstation and include the captive portal as a default package that can be removed instead of as a dependency for gnome-shell."
16:05:16 <stickster> elad661: I'm not saying it should be made, I'm saying FESCo has resolved to ask for one.
16:05:39 <jwb> i'll follow up on the gnome-shell dep with kalev
16:05:43 <stickster> OK jwb
16:05:51 <elad661> jwb: that's acceptable, I think, but also a waste of time imo - what we have now works and has no actual issue
16:06:08 <jwb> elad661, not everyone thinks it's a waste of time
16:06:11 <elad661> the only issues are purely theoretical "what if someone doesn't want this".
16:06:28 <otaylor> I'm only OK with that at all if we make sure that fedup gets fedora-release-workstation installed for upgrades to F21 (which would be good anyways...)
16:06:33 <stickster> I'm not convinced we should be managing features based on the misconception most users care about this level of scrutiny.
16:06:40 <jwb> #action jwb to follow up with kalev on moving the dependency for capitve portal to fedora-release-workstation instead of gnome-shell
16:06:41 <sgallagh> This is a perfect example of a case for soft dependencies, honestly
16:06:43 <stickster> But... again, I'm not voting :-)
16:06:53 <otaylor> But I don't think package installation is the right way to configure system behavior
16:07:02 <elad661> surprisingly enough I managed to stay here until now, but now I really should get going (I can't be late to the holiday dinner) - bye all.
16:07:10 <stickster> elad661: Thanks for dedication :-)
16:07:21 <jwb> otaylor, that sounds like a topic for next week's meeting...
16:07:29 <jwb> in general
16:07:36 <otaylor> elad661: Thanks for staying. Happy new year.
16:07:59 <stickster> +1
16:08:05 <sgallagh> The original plan of record was for upgrades to not do that silently
16:08:06 <jwb> ok, we should probably end now.  thanks for coming everyone
16:08:14 <jwb> sgallagh, next meeting.
16:08:15 <sgallagh> Because it's making assumptions about the existing usage
16:08:18 <sgallagh> ok
16:08:23 <jwb> #endmeeting