fedora-meeting
LOGS
17:01:43 <jzb> #startmeeting
17:01:43 <zodbot> Meeting started Fri Sep 19 17:01:43 2014 UTC.  The chair is jzb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:55 <jzb> #chair mattdm kushal roshi number80
17:01:55 <zodbot> Current chairs: jzb kushal mattdm number80 roshi
17:02:00 <jzb> roll call
17:02:03 <roshi> .hellomynameis roshi
17:02:03 <jsmith> .hellomynameis jsmith
17:02:04 <kushal> .fasinfo kushal
17:02:04 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:02:08 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
17:02:08 <jzb> .hellomynameis jzb
17:02:10 <zodbot> kushal: User: kushal, Name: Kushal Das, email: kushaldas@gmail.com, Creation: 2006-02-17, IRC Nick: kushal, Timezone: Asia/Kolkata, Locale: en, GPG key ID: 9DD5346D, Status: active
17:02:11 <number80> .hellomynameis hguemar
17:02:13 <kushal> oops wrong command
17:02:13 <zodbot> kushal: Approved Groups: +ambassadors @gitpym @gitpathagar cla_fedora cla_done fedorabugs packager docs cvsl10n gitliveusb-creator web gitfedora-web @gittranslation-filter sysadmin art gitfedoratv @gitgach @gitlekhonee sysadmin-darkserver @gitpony @git-boog @gitsparcy cla_fpca
17:02:16 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:02:19 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:02:23 <kushal> .hellomynameis kushal
17:02:24 <mattdm> .hellomynameis mattdm
17:02:24 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:02:27 <zodbot> mattdm: mattdm 'Matthew Miller' <mattdm@mattdm.org>
17:02:30 <jzb> #chair jsmith
17:02:30 <zodbot> Current chairs: jsmith jzb kushal mattdm number80 roshi
17:02:34 <kushal> We use that one in other meetings.
17:02:59 <jzb> kushal: the fasinfo one is fine too, but it doesn't work quite right all the time
17:03:01 <agrimm> .hellomynameis arg
17:03:02 <zodbot> agrimm: arg 'Andy Grimm' <agrimm@redhat.com>
17:03:03 <jzb> kushal: for example
17:03:08 <jzb> .fasinfo jzb
17:03:11 <zodbot> jzb: User: jzb, Name: Joe Brockmeier, email: jzb@redhat.com, Creation: 2010-04-20, IRC Nick: jzb, Timezone: America/Chicago, Locale: en, GPG key ID: A0207CD4, Status: active
17:03:14 <zodbot> jzb: Approved Groups: @magazine atomic marketing cla_done cla_fpca cla_fedora
17:03:19 <jzb> hrm.
17:03:24 <kushal> :)
17:03:24 <roshi> fasinfo dies when I do it
17:03:28 <jzb> it used to also expand to another user
17:03:28 <roshi> .fasinfo roshi
17:03:31 <zodbot> roshi: User: roshi, Name: Mike Ruckman, email: mruckman@redhat.com, Creation: 2013-08-24, IRC Nick: roshi, Timezone: US/Mountain, Locale: en, GPG key ID: , Status: active
17:03:34 <zodbot> roshi: Approved Groups: marketing docs +qa magazine fedorabugs qa-admin cla_done cla_fpca
17:03:34 <imcleod> .hellomynameis imcleod
17:03:36 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
17:03:44 * mattdm feels like a script could maybe do this part of the meeting :)
17:03:47 <jzb> #chair imcleod agrimm
17:03:47 <zodbot> Current chairs: agrimm imcleod jsmith jzb kushal mattdm number80 roshi
17:03:58 <roshi> what the what? It works now?
17:04:10 <agrimm> roshi, sometimes people fix bugs. :)
17:04:19 <roshi> kudos to whoever fixed it :)
17:04:31 <jzb> Indeed
17:04:42 <jzb> ok, as agreed a couple of meetings ago, let's start with AIs from last week
17:05:53 <dustymabe> jzb: :)
17:06:05 <jzb> roshi: you had an AI to reach out to me on the coordination of test days
17:06:05 <jzb> #topic Atomic Image Test Days / Cloud Test Days
17:06:28 <jzb> I sent a note on this to the mailing list this morning. One person in favor of 1 & 2 October
17:06:38 <jzb> any objections to those days - they'd overlap with RDO Test Days
17:06:55 <dustymabe> jzb: i thought RDO test days were sept 25/26?
17:06:59 <dustymabe> jzb: did they move?
17:07:03 <jzb> dustymabe: yes, they moved
17:07:15 <roshi> most test days moved with the last slip
17:07:30 <roshi> I have no complaints with pretty much any days
17:07:33 <jzb> #info https://openstack.redhat.com/RDO_test_day_Juno_milestone_3
17:07:59 <jzb> let me reverse the polarity on that question
17:08:06 <dustymabe> jzb: thanks... i need to follow the mailing list better probably
17:08:08 <dustymabe> :)
17:08:22 <roshi> I think some overlap with RDO could be good
17:08:39 <dustymabe> thursday the 2nd is best for me
17:08:54 <jzb> show of hands folks who can attend + help facilitate the test days if we do 1 & 2 October
17:08:54 * jzb raises hand.
17:09:03 <roshi> o/
17:09:05 * number80 waves too
17:09:08 * mattdm looks at calendar
17:09:20 <mattdm> I can attend; will let someone else facilitate!
17:09:22 * dustymabe will do the best I can to be there
17:09:49 <kushal> That whole week is biggest festival for Bengalis, I will have to skip.
17:10:09 * jsmith can't, as he'll be traveling :-(
17:11:05 * oddshocks here
17:11:13 <jzb> OK, so let's go with those dates + try to recruit more help
17:11:13 <jzb> anything else on that topic?
17:11:27 <jzb> number80: under action items we also have "test day for base image"
17:11:36 <jzb> number80: is that cloud base image, or docker base image? Assuming cloud.
17:11:53 <number80> you're right
17:11:54 * dustymabe smiles at the ambiguity
17:11:58 <jzb> OK
17:12:19 <roshi> cloud base image was the intent
17:12:24 <jzb> so that's also covered here. I'll also reach out to base WG folks about the Docker image and see if they want to triple up on test days
17:12:45 <jzb> so they can test Fedora Docker Image on Fedora Atomic Image and maybe run that on RDO...
17:13:19 <jzb> #topic Working Group Composition
17:13:24 <jzb> #chair oddshocks
17:13:24 <zodbot> Current chairs: agrimm imcleod jsmith jzb kushal mattdm number80 oddshocks roshi
17:13:35 <jzb> mattdm: you did raise that on the list
17:13:44 <jzb> mattdm: do we have any additional discussion there?
17:13:47 <jzb> or here
17:14:07 <mattdm> sure...
17:14:25 <mattdm> I was thinking of putting together a list that said "okay these people have been active -- let's make that the WG"
17:14:41 <mattdm> with room for "we should add ____" and for people to say "no thanks", of course
17:15:11 <mattdm> anyone have a better or different suggestion?
17:15:19 <jzb> mattdm: that makes sense. I will ask - have we used the "official" status of folks for voting at all?
17:15:36 <mattdm> jzb not since the very beginning. it just hasn't come up.
17:15:45 <mattdm> perhaps we're not being edgy enough :)
17:15:47 <jzb> mattdm: I have (happily) noticed we do most everything by consensus and only really vote on things like "what day do we do X"
17:15:56 <jsmith> WORKSFORME
17:16:07 <number80> *nods*
17:16:37 <roshi> wfm
17:16:40 <jzb> I'm +1 with mattdm's proposal, just noting that we've done a good job of being inclusive and consensus driven so far.
17:16:47 <jzb> at least as far as I can tell.
17:16:56 <kushal> jzb, +1
17:17:05 <imcleod> far be it from me to break the consensus: +1
17:17:09 <mattdm> heh
17:17:11 * dustymabe +1
17:17:22 <agrimm> +1, for completeness
17:17:24 <number80> +1 (if that wasn't clear)
17:17:28 <mattdm> okay so i'll do that. :)
17:17:31 <jzb> groovy
17:17:37 * mattdm notes that this vote is ironic given the topic
17:17:46 <roshi> -1
17:17:50 <mattdm> noooooooooo
17:17:54 <roshi> just so that it's not all the same :p
17:18:00 <roshi> mwahahaha
17:18:01 <jzb> #info ironic vote taken, passes
17:18:03 <number80> mattdm: this is our last time we could use our voting power, don't remove that from us !
17:18:09 <number80> :)
17:18:58 <jzb> #action mattdm will follow up on wg composition with list of suggestions.
17:19:05 <jzb> that's all the AIs from last week
17:19:22 <jzb> did we go over the week before last week?
17:19:34 <roshi> that's too far in the past for me to rememver
17:19:43 <roshi> remember, even
17:20:05 <jzb> I'm looking at the week of the 5th, and it seems complete
17:20:09 <dustymabe> jzb: I have one
17:20:20 <jzb> dustymabe: terminology?
17:20:46 <dustymabe> jzb: I was able to make contact within digital ocean this week. Am going to work on getting some hard answers to questions and perhaps send an email to the list or I'll update in the meeting next week
17:20:58 <mattdm> cool!
17:20:59 <number80> :/
17:21:05 <jzb> dustymabe: ah, cool.
17:21:12 <kushal> dustymabe, Nice.
17:21:29 <number80> oh hard, in that sense ? awesome :)
17:21:34 * number80 slow today
17:21:37 <jzb> roshi: so I am going from the meeting minutes from 2014-09-05, my memory isn't any better ;-)
17:21:37 <dustymabe> sorry about the slow process. I've been swamped with other things :)
17:22:11 <jzb> #info http://meetbot.fedoraproject.org/fedora-meeting/2014-09-05/fedora-meeting.2014-09-05-17.05.html
17:22:12 <dustymabe> number80: in what sense? I mean in writing (email) rather than in passing conversation
17:22:28 <roshi> I don't beleive you jzb - I think you're just trying to make me not feel bad, you remember all
17:22:36 <number80> ok
17:24:03 <jzb> Let me skim through these AIs very quickly
17:24:14 <jzb> #topic generate comps, spin kickstart and environments changes
17:24:28 <jzb> imcleod: you had an AI two weeks ago on the above - was that done?
17:24:42 <jzb> I'm thinking yes
17:24:52 <imcleod> jzb: Yes.  Committed upstream and it seems to be working.
17:24:57 <jzb> woot!
17:25:05 <jzb> imcleod: thanks!
17:25:06 <imcleod> jzb: I was ably assisted by dgilmore, who did the spin kickstart changes.
17:25:36 <imcleod> I am now in the comps file git log.  My name in print.  Things are going to start happening to me now.....
17:25:48 <jzb> dgilmore is awesome. That team has been really helpful.
17:26:06 <number80> great :)
17:26:31 <jzb> number80: you had an AI to close ticket 65 - which you did. Awesome.
17:26:48 <jzb> let's look at the meeting tickets
17:27:10 <number80> :)
17:27:27 <jzb> #topic Automatic Smoketests on Image Build
17:27:34 <jzb> looks like this one is for agrimm
17:27:52 <dgilmore> jzb: we try
17:28:44 <roshi> for my bit on this, it's still a work in progress
17:28:46 * jzb can never tell if someone has stepped away or is typing slowly
17:29:40 <jzb> roshi: can you and/or agrimm update the ticket this week?
17:30:10 <agrimm> sorry
17:30:13 <roshi> sure
17:30:17 <agrimm> having a conversation in the other channel
17:31:24 <jzb> OK
17:31:51 <jzb> #action roshi or agrimm update ticket on smoketests
17:31:57 <jzb> #topic Article for Fedora Magazine on "state of cloud SIG/product" for alpha release
17:32:10 <jzb> #info https://fedorahosted.org/cloud/ticket/75
17:32:27 <jzb> Did a draft and sent that to the mailing list today. Looking for feedback.
17:32:48 <dustymabe> number80: what was the link of the wiki page we started?
17:33:27 <number80> dustymabe: well, I think we should just go with jzb article
17:33:40 * mattdm will look, provide feedback
17:33:46 * jsmith will provide feedback as well
17:33:55 * number80 the same
17:34:02 <jzb> dustymabe: was there another in-progress piece there?
17:34:02 <roshi> I read it and thought it looked good
17:34:03 <dustymabe> number80: yeah I agree. there was something I added that I thought might be useful.. let me see if I can find it
17:34:05 <number80> dustymabe: https://fedoraproject.org/wiki/User:Hguemar/marketing/cloud_image_f21_status
17:34:13 <roshi> will go over it with a finer toothed comb later though :)
17:34:47 <dustymabe> number80: here it is: https://fedoraproject.org/wiki/User:Hguemar/marketing/cloud_image_f21_status
17:34:58 <jzb> #action jzb take feedback and finish article for Tuesday or Wednesday next week
17:35:06 <kushal> both sharing links to each other :)
17:35:13 <jzb> If I can get all feedback by Monday, that'd be awesome.
17:35:32 <jzb> I'm thinking maybe publish it on Wednesday or Thursday to keep the attention going on the alpha.
17:35:37 * dustymabe should read scrollback
17:35:44 <jzb> rather than have everything go out in a burst on Tuesday
17:36:21 <jzb> we already tackled test days, so I'll skip that one.
17:36:31 <dustymabe> jzb: I haven't seen your email but it might be good to have a pointer to people who want to use the cloud image with just virt-manager
17:36:40 <mattdm> jzb +1 to staggering the messages
17:36:54 <jzb> dustymabe: because of cloud-init?
17:37:11 <dustymabe> jzb: yeah.. they have to figure out how to get in
17:37:16 <jzb> +1
17:37:19 <roshi> yeah
17:37:24 <dustymabe> jzb: see https://fedoraproject.org/wiki/User:Hguemar/marketing/cloud_image_f21_status
17:37:24 <jzb> #action jzb add info on cloud-init / virt manager
17:37:27 <roshi> I fought with that in the beginning
17:37:35 <jzb> that's sub-optimal...
17:37:36 <kushal> jzb, there were people who tried those images in virt-manager and had no clue how to login.
17:37:37 <roshi> got it figured now though
17:37:42 <kushal> eh I should type fast.
17:37:44 <jzb> kushal: Yeah. OK
17:38:01 <jzb> I hope we can eliminate that at some point.
17:38:15 <jzb> it's not a big hurdle once you know about it, but it's still a hurdle.
17:38:21 <jzb> Do we have a default ISO image we can provide?
17:38:30 <jzb> so people don't have to create their own?
17:38:47 <roshi> not that I know of
17:38:54 <jzb> K
17:39:10 <jzb> I think there's one somewhere in walters' Atomic work
17:39:19 <number80> it should be added in the cloud doc
17:39:38 <dustymabe> jzb: this might be the best answer http://rwmj.wordpress.com/2013/08/02/new-in-virt-sysprep-set-root-and-user-passwords/
17:39:39 <roshi> I have ugly code to run it locally, automagically generates all that stuff
17:40:08 <dustymabe> would be nice to have first class support in virt-install/virt-manager for defining user-data
17:40:17 <kushal> dustymabe, +1
17:40:33 <jzb> #info look at virt-sysprep for cloud-init http://rwmj.wordpress.com/2013/08/02/new-in-virt-sysprep-set-root-and-user-passwords/
17:40:49 <jzb> dustymabe: were you volunteering to add that? ;-)
17:41:05 <dustymabe> jzb: I would love to!!
17:41:10 * mattdm thinks libvirt should provide a minimal metadata service
17:41:26 * dustymabe wishes he had a time machine
17:41:47 <jzb> dustymabe: me too. The 20s sound awesome.
17:42:07 <jzb> OK...
17:42:25 <dustymabe> I cann follow up with cole and see if that is something they are working on
17:42:33 <jzb> dustymabe: awesome
17:42:48 <number80> there are technical answers
17:42:49 <jzb> #topic start communication/collaboration on cloud image updates
17:42:59 <jzb> #info https://fedorahosted.org/cloud/ticket/51
17:43:11 <jzb> Anything on this for this week?
17:43:13 <jzb> roshi: ^^
17:43:30 <roshi> nothing more moving that I know of
17:43:46 * roshi looks for the draft we had
17:45:01 <roshi> nvm, it's in the ticket
17:45:03 <agrimm> roshi, I put a long comment in there after our conversation.  still plenty hand-wavy, though.  really need more opinions on how often we want to respin, and what the estimated "expense" of respinning is
17:45:11 <roshi> any other comments from anyone else?
17:45:20 <roshi> yeah
17:45:36 <roshi> then to work with releng about getting things done when those triggers get tripped
17:46:36 <jzb> agrimm: monthly barring security updates that require an update, would be my suggestion
17:46:37 <agrimm> I'm thinking that there are generally two scenarios:  1) at our weekly meeting, we ask "is it time for a respin this week?", and 2) some big obvious security thing happens, and we reactively respin
17:46:47 <jzb> agrimm: that was basically my suggestion for the Atomic image.
17:47:33 <agrimm> jzb, that seems generally reasonable.  I'd leave the door open for major bugfix respins that may not be security-related, but I would hope it wouldn't happen often.
17:48:12 <jzb> agrimm: +
17:48:13 <mattdm> sounds good to me
17:48:15 <jzb> agrimm: +1
17:48:16 <agrimm> jzb, what level of security issue would you deem sufficient to trigger an update?
17:48:51 <jzb> #info respin for base image agreed ~1 month + any security/major bugfix
17:49:11 <jzb> agrimm: I would say any security issue. The package pool should be small enough we're not pelted with constant updates for security.
17:51:07 <roshi> seems sane enough
17:51:10 <agrimm> jzb, ok, we'll see how that goes.  I'm thinking we wouldn't respin for a buffer overflow in some corner case of "tar" usage.  not remotely exploitable, trivial to run "yum update" to fix, etc.
17:51:11 <jzb> I think the other tickets in the trac are pretty well covered atm
17:51:17 <roshi> time will tell though I guess, right?
17:51:37 <jzb> agrimm: maybe let's see how it goes for F21 and revisit for F22
17:51:49 <agrimm> jzb, agreed
17:51:53 <roshi> if we could get more people involved in blocker meetings, we could hold a similar meetings for respins
17:52:04 <roshi> get together, look over the bug like we do for blockers
17:52:19 <roshi> just a thought
17:52:30 <jzb> roshi: that's a worthy goal
17:52:36 <jzb> at least IMO
17:52:46 <jzb> OK
17:52:54 <jzb> #topic new business
17:52:57 <mattdm> I think we should not say "any security". too many things are corner-case -- the tar example is a good one
17:53:01 <mattdm> (sorry slow typing)
17:53:31 <roshi> it's hard to attend these meetings via phone, amirite? :p
17:53:53 <mattdm> this was just thinking as i wrote. can't do both
17:54:01 <mattdm> good thing I don't also have gum
17:54:12 <mattdm> because i am also walking on my treadmill desk
17:54:37 <jzb> nice!
17:54:45 <roshi> I want one of those
17:54:48 <agrimm> I think the obvious ones that matter are kernel, systemd, glibc, sshd
17:54:54 <jzb> agrimm: maybe open a thread on the list and we'll tighten the definition?
17:54:58 * dustymabe gets an interested visual of a hamster on a hamster wheel
17:55:05 <agrimm> jzb, sure
17:55:06 <number80> cloud-init
17:55:16 * agrimm awaits a #action
17:55:17 <mattdm> yeah and that way we can pull in security team
17:56:00 <jzb> #action agrimm start thread to decide which security updates trigger rebuild
17:56:26 <jzb> number80: cloud-init is a topic?
17:56:52 <agrimm> jzb, I think he means a security bug in cloud-init would trigger an update
17:57:18 <number80> exactly
17:57:19 <agrimm> something that would allow insertion of malicious metadata?
17:57:34 <number80> cloud-init is a sensitive component of the cloud images and he should be monitored
17:57:47 <dustymabe> number80: I agree.
17:58:06 <mattdm> yes. agree. also, details, details :)
17:58:12 <dustymabe> as far as cloud-init goes.. is it just me or does it seem like documentation and new development are lacking?
17:58:44 <dustymabe> I sent an email to the mailing list but it seems like you have to have a launchpad account, etc...
17:58:47 <number80> there are documentation and development is well sketchy
17:58:55 <jzb> agrimm: sure
17:59:07 * number80 thanks gholms for his awesome work to improve it
17:59:12 <dustymabe> number80: agreed. It's amazing to me how much adoption is has in spite of that
17:59:16 <jzb> dustymabe: there's been discussions about forking it or replacing it.
17:59:26 <jzb> dustymabe: but it's tricky
17:59:32 <dustymabe> jzb: do you know where those discussions take place?
17:59:32 <agrimm> AWS forked it long ago
17:59:43 <agrimm> because they refuse to sign Canonical's CLA
17:59:44 <mattdm> coreos replaces it with a mostly-compatible version
18:00:00 <jzb> dustymabe: well, we'd talked about problems here and wanting min-metadata (?)
18:00:26 <jzb> mattdm: right, so they've already kind of forked it, right? I think centos may be interested in a different version too.
18:00:33 <mattdm> our main goal, I think, would be to get python out of the base.
18:00:36 <number80> agrimm: I think we should go ask a former FPL to see if we could join forces about cloud-init
18:00:37 * jsmith has to run to another meeting, sorry :-(
18:00:43 <dustymabe> jzb: got it. I think it would be great if we could put a bigger community together.. along with the current cloud-init guys and make it better
18:00:50 <mattdm> which would fit with coreos' golang verison or colin's c-based one
18:00:51 * number80 can't unluckily do that
18:01:20 <agrimm> number80, doesn't fix the python dep issue, or the fact that cloud-init doesn't really do what we want for cases like GCE
18:01:33 <jzb> so - we probably can't do anything on cloud-init for F22
18:01:41 <jzb> shall we make that an action / change for F22
18:01:47 <jzb> meant F21 the first time
18:01:58 <number80> agrimm: either we accept dropping features or stick to cloud-init or whatever
18:02:37 <agrimm> number80, yeah, that is true.  cloud-init's feature set is sort of all over the place, though, and a lot of it is not very well tested outside of ubuntu
18:02:47 <number80> *nods*
18:03:12 <jzb> if AMZ forked their versio
18:03:13 <dgilmore> agrimm: for f21 we should be happy if people can log in
18:03:14 <jzb> vrsion
18:03:24 <jzb> are they making changes public?
18:03:33 <dgilmore> we can look at making the experience better as it goes along, and make things right for f22
18:03:36 <jzb> e.g. is it on github somewhere or are they just throwing one out?
18:03:40 <agrimm> dgilmore, it's that bad?
18:03:53 <jzb> dgilmore: +1 - pretty much my suggestion
18:04:07 <kushal> dgilmore, :)
18:04:20 <jzb> it's probably too late in the game for major cloud-init changes for F21
18:04:23 <dgilmore> agrimm: i don't know how bad it is. but at this point we need to make sure the basics work
18:04:36 <mattdm> dgilmore: +1
18:04:39 <dustymabe> jzb: yes. this is discussion about the "future"
18:04:51 * agrimm was definitely not suggesting any changes for f21
18:05:25 <dustymabe> dustymabe: I think long term thought it would be great to have an active larger community that we are a part of
18:05:29 <dgilmore> agrimm: going forward and for f22 we really must make it betetr and work with the google experience
18:05:30 <dustymabe> and that we can help steer
18:05:53 <agrimm> dgilmore, agreed, we've had email conversations with google about that
18:05:57 <dgilmore> for now im happy if it works like outher cloud providers that an account is created on bootup and you can get ina nd on with life
18:06:18 <dgilmore> and i can learn to type
18:06:35 <dgilmore> agrimm: f22 planning now is awesome :)
18:06:41 * oddshocks has to step out, feel free to leave him messages *wave*
18:06:51 <jzb> oddshocks: thanks for attending
18:06:56 <jzb> jsmith: ^^ as well
18:07:31 <jzb> #action jzb start change page for F22 on cloud-init
18:07:46 <jzb> #action jzb move discussion on cloud-init to mailing list.
18:07:54 * mattdm nods
18:07:56 <jzb> OK
18:08:00 <jzb> any other topics?
18:08:10 <jzb> we're nearly 10 minutes over
18:08:14 <jzb> oh
18:08:35 <jzb> #topic Docker Image for F21 Alpha
18:08:45 * roshi has no other topics
18:08:50 <jzb> Talking to mattdm earlier we were discussing the Docker Image
18:09:04 <mattdm> this is a base WG thing now but we have a vested interest in making sure it is available
18:09:09 <jzb> I know that's base WG, but we wanted to make sure that the docker image is getting pushed to the Docker Hub for alpha
18:09:17 <mattdm> dgilmore: do you know if this is on track to be part of the f21 deliverables?
18:10:02 <dgilmore> mattdm: we have it. we need to work out how to glue it into the docker registry
18:10:14 <dgilmore> mattdm: we did get the okay from legal for it
18:10:23 <dgilmore> I think i need to create an account at docker
18:10:50 <number80> dgilmore: you should contact Docker Inc, they already have an account for us
18:11:04 <mattdm> for this, I don't think so -- it should be pulled in to the official library via stackbrew
18:11:21 <dgilmore> mattdm: we just need to work out how
18:11:25 <mattdm> let's not pile this on dennis, though
18:11:30 <number80> ok
18:11:41 <dgilmore> mattdm: I think we need a fedorahosted project for it so that they have a git repo to pull from
18:11:55 <dgilmore> and we need to do some glue magic
18:11:59 <mattdm> dgilmore yeah. that would be nicer than them pulling it from github
18:12:50 <dgilmore> mattdm: from memory they said they dont care where it is. just needs to be in a git repo
18:12:52 <mattdm> does anyone want to take the action of making sure that happens? should connect with base wg and with lsm5 who was working on the unofficial attempt
18:13:34 <mattdm> *crickets*
18:13:39 <mattdm> okay :)
18:13:48 <dgilmore> mattdm: I guess you and me
18:14:00 <mattdm> #action mattdm connect with base wg, lsm5, docker, rel-eng about docker base image upload to registry
18:14:12 <dustymabe> mattdm: I hope to be able to take on more responsibility one day.. right now I have too much other stuff going on
18:14:18 <mattdm> dgilmore: yep.
18:14:18 <jzb> mattdm: is there any way to tally actions during the meeting?
18:14:29 <dgilmore> jzb: no
18:14:33 <mattdm> you mean as "done"?
18:14:35 <jzb> ah, too bad
18:14:39 <dgilmore> at least not that i am aware of
18:14:52 <jzb> mattdm: no, run a command to see how many actions have been taken during a meeting in real time.
18:14:58 <dgilmore> i assume jzb means a summary of actions to date in teh meeting
18:14:59 <jzb> mattdm: kind of a scoreboard, if you will
18:15:03 <jzb> dgilmore: +1
18:15:09 <mattdm> ahhh. i don't think so. zodbot rfe
18:15:14 <dgilmore> jzb: a nice RFE :)
18:15:20 <jzb> OK
18:15:28 <mattdm> .moar features zodbot
18:15:28 <zodbot> here zodbot, have some more features
18:15:33 <jzb> #action jzb file RFE for zodbot on actions during meeting
18:15:44 <jzb> that's sort of ironic or something
18:15:52 <jzb> OK, we're 15 over
18:15:57 * mattdm is done
18:16:01 <jzb> going to close unless anyone else has a topic or anything
18:16:09 <number80> +1
18:16:12 * jzb waits a minute for folks to type
18:16:42 * roshi has nothing :)
18:16:43 <jzb> OK
18:16:50 <roshi> thanks for running the meeting jzb
18:16:52 <jzb> everybody have an excellent day and weekend
18:16:57 <jzb> #endmeeting