fedora-qa
LOGS
15:01:34 <adamw> #startmeeting Fedora QA meeting
15:01:34 <zodbot> Meeting started Mon Sep  8 15:01:34 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:38 <adamw> #meetingname fedora-qa
15:01:38 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:43 <adamw> #topic Roll call
15:01:47 <adamw> ahoyhoy, folks
15:01:50 * pschindl is here
15:02:01 * satellit listening
15:02:03 * roshi is here
15:02:04 * jreznik is here, ahojahoj
15:02:11 * Southern_Gentlem lurking
15:02:19 <mdolezel> is here
15:03:51 * tflink is here
15:03:54 * kalev lurks
15:05:29 <adamw> a good turnout :)
15:05:36 <adamw> thanks for coming!
15:05:38 * pwhalen is here
15:05:41 <adamw> #topic Previous meeting follow-up
15:06:05 <adamw> "FranciscoD or amita or roshi to write GNOME Test Day post for Fedora Magazine"
15:06:15 <roshi> that was done by amita :)
15:06:54 <adamw> yup
15:07:13 <adamw> #info "FranciscoD or amita or roshi to write GNOME Test Day post for Fedora Magazine" - Amita did this, see http://fedoramagazine.org/gnome-wayland-test-day-2014-08-28/ , thanks to her!
15:07:57 <adamw> #info "adamw and apeter to sync up on trialling moztrap for l10n test day" adamw took a look at an appropriate moztrap schema for this and sent some notes to apeter, also exposed some more limitations in Moztrap, see http://piratepad.net/FedoraMozTrap
15:08:21 <adamw> so yeah, when i sat down and thought about how to set up a test day through moztrap it sorta suggested some more weaknesses in it, see the piratepad for a lengthy write-up (do I do any other kind of write-up?)
15:08:53 <roshi> lol
15:10:51 <adamw> I think that's it for follow-up, right?
15:11:23 <adamw> ok then!
15:11:25 <adamw> #topic Fedora 21 status
15:11:41 <adamw> #chair roshi satellit Southern_Gentlem
15:11:41 <zodbot> Current chairs: Southern_Gentlem adamw roshi satellit
15:11:48 <adamw> (always forget that)
15:12:29 <adamw> so...we have a TC6, at least.
15:12:32 <satellit> did some testing this week https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Install#Default_boot_and_install
15:12:45 <adamw> test coverage is getting there (thanks satellit!) although still missing a lot
15:12:59 <adamw> we really need to grind through the missing Alpha tests folks, even though we know there are 'bigger issues' with netinst etc
15:13:07 <adamw> we need to catch blockers as early as possible
15:13:46 <adamw> satellit: you note "netinstall "Pane is dead"" as a fail for network install from workstation, is that the same as one of the currently nominated/accepted blockers? it doesn't look quite the same
15:14:13 <jreznik> adamw: +1 to "catch blockers as early as possible"
15:14:18 <satellit_e> note I did Fedora-Live-Workstation-x86_64-rawhide-20140907 to VB and screenshot worked
15:14:33 <adamw> satellit: you also reported a failure for Server offline with "default formatting" but there's no bug report?
15:14:50 <Toledo|sat6bomga> randomuser: yeah i will let me update you after this remote session with a customer
15:14:52 <adamw> brb, call of nature
15:14:54 <satellit_e> I need to retest it  may have been bad HD
15:15:05 <randomuser> Toledo|sat6bomga, in -docs, our meeting is over :)
15:15:15 <Toledo|sat6bomga> :) ok
15:15:28 <satellit_e> though used same disk for custom install
15:19:28 <adamw> satellit: OK, i guess others can check and see what we see
15:19:45 <adamw> if other folks can run the tests satellit hit problems with and confirm if there's an issue, that'd be great
15:20:23 <satellit_e> also looked at SoaS https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Desktop#Sugar_.28non-blocking.2C_all_arches.29
15:21:07 <kalev> how does it look, are we any closer to an alpha RC this week?
15:21:20 <adamw> the big stumbling block now is https://bugzilla.redhat.com/show_bug.cgi?id=1134524
15:21:34 <jreznik> kalev: it would be actually question on you workstation guys
15:21:37 <adamw> we really need releng and anaconda and whoever else wants to get involved to decide the approach on that
15:22:01 <jreznik> (partially)
15:22:05 <adamw> jreznik: eh, if you're referring to 1134524 it's kinda bigger than just 'do we want a workstation netinst'...so yeah, partially
15:23:12 <adamw> kalev: so in case you didn't see it, the question we had for Workstation was: we understand that you want any image branded as "Workstation network install" to offer only the Workstation package group choices, but would you be happy with a situation where there was just a generic "Fedora network install" and it offered Workstation as one of the choices, much like we have now?
15:23:44 <kalev> sgallagh and I were talking about offering a netinst with options to choose between the Server and Workstation
15:23:55 <kalev> and he had a plan how to get there
15:24:18 <jreznik> kalev: so it could be "one would be ok"?
15:24:19 <adamw> kalev: did it handle the issue of default filesystems (and other install-time variances)?
15:24:24 * sgallagh hears his name
15:24:56 <kalev> sgallagh thought Server could postpone the filesystem differences for this cycle to get somewhere with netinstall
15:25:01 <sgallagh> adamw: No, it didn't handle the default filesystem question. I proposed it as a stop-gap mechanism for F21 so we can get something out the door.
15:25:08 <adamw> rgr
15:25:13 <sgallagh> Server is willing to postpone the default FS divergence for a release
15:25:26 <adamw> and here i've been getting the anaconda folks to fix things up so we can do the FS divergence :)
15:25:45 <sgallagh> adamw: Well, that's work that has to happen sometime anyway
15:26:08 <sgallagh> I was just figuring it would be wiser to think that through properly without the axe hanging over us
15:26:15 <jreznik> if we could postpone it, it would be very generous from server wg
15:27:27 <jreznik> even better - https://www.damejidlo.cz/en/tag/pizza?filters-maxDeliveryTime=75 :)))
15:27:35 <jreznik> ops, sorry, bad IRC channel :)
15:27:43 <adamw> sgallagh: note, i wasn't necessarily suggesting ditching the Server netinst, it would be possible to do both, I guess?
15:27:59 <sgallagh> jreznik: I could go for some pizza :)
15:28:27 <sgallagh> adamw: What I was trying to suggest was that we could have a single netinst for both Server and Workstation as long as we're okay with the defaults not being different
15:28:31 <jreznik> sgallagh: it's for our hungry #akademy friends :)
15:28:33 <sgallagh> That's easier on the mirrors as well
15:29:30 <adamw> sure, both are possible
15:30:23 <sgallagh> Anyway, I haven't really had a chance to discuss this at length with rel-eng, which is the part that matters
15:30:29 <adamw> right
15:30:56 <jreznik> well, if we would like to ditch one of neinst, then server makes more sense for netinst than ws but this sounds like a good compromise
15:31:08 <adamw> dgilmore: can you and sgallagh and kalev/mclasen/whoever and anyone from anaconda get together and work this through ideally today or at least early this week?
15:31:11 <jreznik> dgilmore: are you around? ^^^ see sgallagh
15:32:23 * handsome_pirate stumbles in late
15:32:28 <adamw> hi, pirate
15:32:45 <sgallagh> I'll try to find the time. I'm heavily booked today and tomorrow
15:33:10 * amita joining really late :P
15:33:13 <kalev> sgallagh: I'll be around -- poke me when you want to discuss this and let's make sure bcl is around too
15:35:26 <adamw> hi amita
15:35:41 <adamw> dgilmore was responding on -devel earlier, let's try and grab him later
15:35:53 <adamw> kalev, did you want to slide the GNOME 3.13.91 question in here?
15:36:16 <amita> hello adamw ..hi every one
15:36:37 <kalev> right, so I mentioned GNOME 3.13.91 at the end of last blocker meeting
15:37:03 <kalev> with the idea of possibly asking to pull it in through the alpha freeze to get more testing for the latest code
15:37:19 <kalev> in the mean time, it's been in updates-testing and gotten overwhelmingly positive feedback
15:37:32 <kalev> there was one regression with caribou starting that got fixed
15:37:42 <kalev> and I haven't heard of any other regressions
15:37:52 <kalev> adamw is a happy .91 user too :)
15:38:08 * kalev find the link.
15:38:08 <adamw> i'm just completing a test install from a 3.13.91-ified live image, it seems to be OK
15:38:20 <kalev> https://admin.fedoraproject.org/updates/FEDORA-2014-10210 -- that's the .91 update
15:38:37 <kalev> so I was wondering how people feel about it, should I ask for a freeze exception?
15:38:58 <adamw> yeah, all systems seem to be go with a test live. it's a bit late, but i think i'd +1 an FE given the quality of current TCs and the outstanding issues
15:39:01 <kalev> I could file the ticket in a bit and put the link in the #fedora-qa channel so that people could vote in the ticket, if you think it makes sense
15:39:18 <adamw> well i'd suggest we could vote on it right *now*, so if it's approved it goes in the next build
15:39:21 * jreznik is ok with latest gnome in alpha
15:39:29 <roshi> I think I would be +1 as well, all things considered
15:39:37 <sgallagh> +1
15:39:40 <roshi> +1
15:39:45 <adamw> .91 does pull in some useful improvements to g-i-s (it lets you use 'bad' passwords again for e.g.)
15:39:53 <satellit_e> looked good to me after update
15:41:59 * jreznik can't test it but trusts karma
15:42:24 <dgilmore> im just starting the releng meeting right now
15:42:48 <adamw> propose #agreed notional bug "include GNOME 3.13.91 in 21 Alpha" bug is granted freeze exception status, bureaucracy can be applied later
15:43:00 <roshi> ack
15:43:06 <adamw> dgilmore: in meeting-1 ?
15:43:24 <adamw> dgilmore: will the netinst issue be a topic?
15:43:39 <dgilmore> adamw: yes and no
15:45:25 <sgallagh> Ack
15:45:48 <adamw> okay, well, maybe discuss it after, i guess
15:47:08 <adamw> any other acks?
15:47:13 <adamw> (or nacks, or patches?)
15:47:42 <kalev> ack
15:48:39 <handsome_pirate> ack
15:48:48 <tflink> ack
15:48:57 <jreznik> ack
15:49:12 * jreznik has to leave for local org #akademy meeting to plan daytrip soon
15:49:38 * sgallagh has to depart for other meetings.
15:49:59 <adamw> #agreed notional bug "include GNOME 3.13.91 in 21 Alpha" bug is granted freeze exception status, bureaucracy can be applied later
15:50:04 <adamw> thanks jreznik, sgallagh
15:50:25 <adamw> anything else for f21? any particular issues with any of the other blockers, for e.g.?
15:50:37 <adamw> there are probably some on the accepted list we can verify and close out, and we should also check karma status of the updates...
15:50:41 <adamw> (that's mostly a note-to-self)
15:51:15 <jreznik> let me know if you need help with anything from that list
15:52:02 <amita> list of .. ?
15:52:19 <amita> bugs.. I guess
15:53:00 <adamw> amita: the accepted blocker list
15:53:07 <adamw> https://qa.fedoraproject.org/blockerbugs/milestone/21/alpha/buglist
15:53:13 * amita clicks
15:53:41 <adamw> for anything where the fix went into TC6, we need to test and make sure it's fixed, provide karma for the update, and ensure releng pushes the update stable (further note to self: is there an SOP for stable push requests?)
15:54:20 <amita> is there any list of bugs which are fixed in TC6 and to be verified ?
15:55:04 <amita> are they the accepted one - 6 Accepted Blockers
15:55:10 <adamw> amita: more or less
15:55:35 <adamw> so, any bug on that list with status ON_QA may be fixed, but you have to check the individual bug report and see when the fix was released exactly
15:55:45 <adamw> amita: a short cut is to check the TC compose request:
15:56:02 <adamw> https://fedorahosted.org/rel-eng/ticket/5940#comment:8
15:56:03 <amita> we dn't have them listed at https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Install, may be helpful to add
15:56:10 <amita> adamw, ok
15:56:19 <adamw> and look at the list of packages explicitly listed to be pulled in there
15:56:38 <amita> ah ok
15:56:56 <adamw> amita: i usually kind of 'human-expedite' this process by sending out emails periodically with action items like 'test this fix, karma that update'. it's certainly a process that could be made smoother :/
15:56:57 <amita> so these rpms needs to be focused for TC6
15:57:26 <amita> adamw, yes.. many people wants to test new compose
15:57:29 <adamw> amita: yes indeed, once we freeze, anything that gets pulled in as a freeze exception or blocker fix needs special attention to ensure it gets pushed as a stable update.
15:57:37 <amita> every one has same question ,.. what to test
15:57:41 <adamw> yupyup
15:57:47 <amita> which component to be focused
15:58:17 <adamw> note the TC announcement does usually link to the compose request - e.g. the TC6 announcement says "Content information, including changes,
15:58:17 <adamw> can be found at https://fedorahosted.org/rel-eng/ticket/5940#comment:9 ."
15:58:44 <amita> adamw, yes..  it has
15:58:59 <adamw> there is as plan to do better automated/scripted integration of the whole TC/RC process between qa and releng, so it's not all manual tickets and stuff
15:59:08 <amita> but I read and thinks https://fedoraproject.org/wiki/Test_Results:Fedora_21_Alpha_TC6_Install will have most of the info
15:59:14 <adamw> i expect that if that gets done, we can do better communication as a side effect
15:59:29 <amita> adamw, indeed
15:59:54 <tflink> adamw: is that something we want to try for F21 (beta, if not alpha)?
16:00:09 <amita> but thanks for links .. they are helpful and explanation too ..
16:00:16 <adamw> amita: the problem with doing it in the wiki page is it then has to be duplicated between all four. generating the wiki pages is a somewhat more fiddly task than writing the email - we usually try to make the amount of work needed to produce the wiki pages for each TC/RC as small as possible
16:00:16 <amita> thanks adamw
16:00:26 <tflink> the features in blockerbugs should be working, as far as I know
16:00:36 <adamw> tflink: it'd depend on dgilmore i guess
16:00:42 <adamw> i suspect he may be swamped in higher priority issues
16:00:46 <amita> adamw, I understand
16:00:56 * satellit_e I try to link to bugs I see on install page
16:01:05 <tflink> if that needs tweaking or other supporting features, that seems like a high priority to me
16:01:24 <adamw> tflink: sure, i guess i'd say sync up with dgilmore and see where that is on his personal priority list
16:01:29 <tflink> it's been on the back burner due to perceived lack of interest
16:01:43 <amita> that is interesting
16:01:45 <adamw> for me it's kind of a "it would be really nice" - i can handle doing the tickets and writing the emails and so on but it's kind of silly monkey work
16:02:00 <amita> :)
16:02:23 <adamw> tflink: well it doesn't cause anything to burn down, but between us and releng we've probably wasted far more cycles on doing it all manually than it would've cost to do the scripting, we're way off to the right of that xkcd graph
16:02:40 <adamw> and whoops, we're over time :(
16:02:42 <tflink> adamw: true, but I think most of the bits are already in place
16:03:19 <adamw> does anyone really want to do the multiboot release criterion discussion?
16:03:35 <adamw> or is it OK if we try and reset that and pass the OS X / Windows ones through the ML?
16:03:53 <amita> do we have time?
16:04:08 <adamw> we're over the hour already, i don't like to drag these things on too far...that's what blocker meetings are for :P
16:04:31 * amita feels adam likes ML much more :P
16:04:49 <adamw> i can talk on IRC forever, but other folks might want the room and i think everyone else gets bored ;)
16:04:54 <danofsatx> we're over time, and I just got here :(
16:04:58 <adamw> hi dan
16:05:09 <adamw> ok, let's do a quick:
16:05:11 <adamw> #topic open floor
16:05:15 <adamw> in case anyone has anything really urgent?
16:05:17 * danofsatx has been lurking, setting up Redmine/Mercurial/FreeIPA and such
16:05:23 <adamw> nice
16:05:38 <adamw> well, except mercurial.
16:06:08 <danofsatx> I didn't pick it. I was just told to "make it work", which is, after all, my job.
16:06:40 * roshi has nothing for open floor
16:07:22 * amita will also read mail from adamw . nothing for open floor
16:07:36 <adamw> danofsatx: no, your job is to tell your bosses how silly they are
16:07:39 <adamw> they love it when you do that
16:08:11 <amita> adamw, they gonna love you too if they will read this meeting logs :P
16:08:20 <danofsatx> That's why I'm trying to get hired by RH. I really don't enjoy my workplace any longer.
16:08:28 <danofsatx> wait, did I say that out loud?
16:09:53 * satellit_e notes from buzilla are not as clear lately  list of many files
16:10:29 <adamw> danofsatx: we'll burn the minutes.
16:10:47 <adamw> #action adamw to try and expedite discussion of the OS X / Windows multiboot criteria revision
16:10:57 <roshi> we *do* have the fuses to light the logs with...
16:11:11 <adamw> #action adamw to file and marked as approvedFE the GNOME 3.13.91 bug
16:11:20 <adamw> acceptedfe, whatever, i don't remember my own jargon
16:11:31 <adamw> thanks for coming, folks!
16:11:34 * adamw lights the fuse
16:12:01 * tflink runs to avoid the explosion
16:12:37 <jreznik> h-bomb, you have to be really fast
16:12:46 * roshi gets behind some cover
16:13:19 <jreznik> fridge should help, I saw it in the movie!
16:14:15 * amita runs to remove roshi's cover :P
16:14:29 <adamw> don't worry, we QA'ed the fridges.
16:14:31 <adamw> #endmeeting