fesco
LOGS
17:05:41 <sgallagh> #startmeeting FESCO (2014-09-03)
17:05:41 <zodbot> Meeting started Wed Sep  3 17:05:41 2014 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:05:41 <sgallagh> #meetingname fesco
17:05:41 <sgallagh> #chair dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh t8m thozza
17:05:41 <sgallagh> #topic init process
17:05:41 <zodbot> The meeting name has been set to 'fesco'
17:05:41 <zodbot> Current chairs: dgilmore jwb kalev mattdm mitr mmaslano nirik sgallagh t8m thozza
17:05:48 <t8m> hi all
17:05:49 <jwb> hi
17:05:53 <mattdm> hello!
17:05:57 <sgallagh> Sorry for the late start. Got caught up in the blocker bugs meeting
17:06:00 * nirik is here, but also fighting mirrormanager.
17:06:58 <sgallagh> I count minimum quorum. Shall we start?
17:07:10 * jreznik has to leave in a few minutes... if he would be needed, he'll try to start IRC on phone
17:07:19 <dgilmore> hey all
17:07:29 <t8m> sgallagh, let's start
17:07:35 <kalev> hello
17:07:52 <sgallagh> Ok, so follow-up business:
17:07:56 <sgallagh> #topic #1178 Fedora 21 scheduling strategy
17:07:56 <sgallagh> .fesco 1178
17:07:56 <sgallagh> #link https://fedorahosted.org/fesco/ticket/1178
17:08:01 <zodbot> sgallagh: #1178 (Fedora 21 scheduling strategy) – FESCo - https://fedorahosted.org/fesco/ticket/1178
17:08:42 <sgallagh> So we're still lacking a working TC (though not for lack of effort)
17:09:05 <jwb> we are?
17:09:27 <sgallagh> jwb: TC5 is completely broken for Server and IIRC there are missing Cloud images
17:09:38 <jwb> oh.  guess that's what i get for only trying workstation
17:09:42 <jwb> YAY WORKSTATION WINS
17:09:45 <sgallagh> :)
17:10:01 <mattdm> lol :)
17:10:10 * mattdm also tried workstation on vacation
17:11:10 <sgallagh> I don't know that there's much for us to discuss here.
17:11:22 <sgallagh> Presumably the Go/No-Go meeting tomorrow will advise another slip
17:11:37 <sgallagh> Unless we get a working TC6 today and tested in time for that meeting.
17:12:26 <sgallagh> There are still 9 open blockers for Alpha
17:12:39 <sgallagh> But only one is still NEW
17:12:49 <nirik> we need to start getting in gear. ;)
17:13:16 <sgallagh> The others appear to be ready when TC6 arrives
17:13:35 <sgallagh> dgilmore: Do you know anything about the Server comps issue? https://bugzilla.redhat.com/show_bug.cgi?id=1135746
17:13:37 * mattdm has the kids back to school, and is mostly through pile of vacation email :)
17:13:40 * sgallagh wonders if he broke it
17:14:31 <mattdm> let's not diagnose it here...
17:14:50 <dgilmore> sgallagh: I suspect that its the kickstart needs tweaking
17:14:56 <dgilmore> sgallagh: Cloud has the same issue
17:15:01 <sgallagh> ok
17:15:22 <sgallagh> mattdm: I was more looking for "I know what's causing it, we'll have it fixed today/tomorrow/next week..."
17:15:43 <mattdm> sgallagh +1 if that's true :)
17:16:09 <dgilmore> sgallagh: well pungi removes incomplete groups and environments
17:16:35 <sgallagh> actually, adamw just updated that BZ with what he believes to be the source of the problem as we were talking
17:16:46 <dgilmore> so for some reason we dont have any complete environmnets
17:16:48 <sgallagh> So I think it *is* my bug and I'll have a fix before I leave for the day.
17:17:08 <adamw> dgilmore: i don't believe the server install kickstart actually includes any environments.
17:17:18 <adamw> looks like it should have at least server-product-environment (and probably some others).
17:17:21 <dgilmore> adamw: that will be a problem
17:18:01 <sgallagh> OK, so let's take the solution to #fedora-server
17:19:27 <sgallagh> Any action here, or shall we just let things proceed for now?
17:19:44 <jwb> move on
17:20:23 <sgallagh> #topic #1322 F21 Changes - Progress on Changes Freeze
17:20:23 <sgallagh> .fesco 1322
17:20:23 <sgallagh> #link https://fedorahosted.org/fesco/ticket/1336
17:20:24 <zodbot> sgallagh: #1322 (F21 Changes - Progress on Changes Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/1322
17:20:46 <sgallagh> jreznik jreznik_: Around?
17:21:31 <jreznik_> yeah, for current status - I removed your change from the list as you asked but not much progress... more watching docs guys updating release notes
17:22:26 <sgallagh> Anything you need from FESCo?
17:22:46 <sgallagh> (Should we take this off the agenda and just ask you to re-add the 'meeting' keyword if you have something for us?)
17:23:29 <jwb> yes
17:23:55 <sgallagh> #action sgallagh to remove the meeting keyword from this ticket
17:24:02 <sgallagh> Ok, on to new business
17:24:14 <jreznik_> yep, I asked for it some time ago :) and also the other way, if you have any issues with any change, let me know and I'll push it
17:24:28 <sgallagh> Will do. Thanks
17:24:28 <sgallagh> #topic #1335 provenpackager request: hguemar
17:24:29 <sgallagh> .fesco 1335
17:24:29 <sgallagh> #link https://fedorahosted.org/fesco/ticket/1335
17:24:30 <zodbot> sgallagh: #1335 (provenpackager request: hguemar) – FESCo - https://fedorahosted.org/fesco/ticket/1335
17:24:42 <sgallagh> Lots of +1s in the ticket.
17:25:00 <t8m> Is there actually any -1?
17:25:07 <sgallagh> No
17:25:09 <jwb> yeah.  i see no reason to disagree with a unanimous vote
17:25:19 <sgallagh> nirik: Mind finishing this one off?
17:25:28 <nirik> yeah, it's not supposed to need to go to fesco without -1's. ;)
17:25:38 <t8m> nirik, +1
17:25:40 <sgallagh> True, but it's been left unattended.
17:25:43 <nirik> yeah, I can finish it up and add them
17:25:45 <sgallagh> Thanks
17:25:58 <sgallagh> #action nirik to sponsor hguemar into provenpackager
17:26:08 <sgallagh> #topic #1336 32 bit ppc support
17:26:08 <sgallagh> .fesco 1336
17:26:08 <sgallagh> #link https://fedorahosted.org/fesco/ticket/1336
17:26:09 <zodbot> sgallagh: #1336 (32 bit ppc support) – FESCo - https://fedorahosted.org/fesco/ticket/1336
17:26:46 <nirik> I thought we decided this last week? perhaps I failed to update it. ;(
17:27:08 <t8m> nirik, +1 again :)
17:27:15 <sgallagh> Yeah, looks like it's just missing the update
17:27:26 <sgallagh> "AGREED: any arch that wants to call itself fedora needs to build up     and host their own infrastructure, along with building up enough     packages to show that they can do a working remix of fedora. Then     request that FESCo consider them as a secondary arch (+7,0,0)     (nirik, 17:41:06)"
17:27:51 <sgallagh> #info We came to a decision last week but forgot to update the ticket
17:27:53 <nirik> sorry about that.
17:27:57 <nirik> I can update it
17:27:58 <sgallagh> No problem. It happens.
17:28:03 <sgallagh> #action nirik to update the ticket
17:28:04 <sgallagh> Thanks
17:28:11 <mattdm> you can add another +1 from me if you want :)
17:28:13 <sgallagh> One ticket left.
17:28:19 <sgallagh> #topic #1337 F21 privacy issue, pinging fedora servers every 300seconds (Workstation only?)
17:28:19 <sgallagh> .fesco 1337
17:28:20 <sgallagh> #link https://fedorahosted.org/fesco/ticket/1337
17:28:21 <zodbot> sgallagh: #1337 (F21 privacy issue, pinging fedora servers every 300seconds (Workstation only?)) – FESCo - https://fedorahosted.org/fesco/ticket/1337
17:29:08 <sgallagh> #proposal Ask Workstation to move the strict dependency to fedora-release-workstation and include the captive portal as a default package that can be removed instead of as a dependency for gnome-shell.
17:29:14 <t8m> I think this should be opt out feature but I don't see big security concern with it. For the extra sensitive environments the opt out should be sufficient
17:29:22 <t8m> sgallagh, +1
17:29:31 <kalev> +1 from me too
17:29:54 <jwb> i'm fine with the move.  i don't see a security concern though and if we move it i'd like it to be for reasons other than that
17:30:45 <nirik> +1 to the move to make it easier for our users to choose not to use this functionality.
17:30:46 <kalev> sgallagh didn't include this in his #proposal above, but this just means moving the hard dependency elsewhere, to fedora-release-workstation
17:30:52 <nirik> I also don't see a security concern.
17:31:02 <sgallagh> I don't see a security issue either, but perception can be as bad as actual behavior if the wrong journalist reads about something.
17:31:11 <drago01> the ip address isn't really a secret
17:31:26 <nirik> I'll note for the record:
17:31:33 <sgallagh> kalev: Right, so you just have to stop calling your install "Workstation" if you disable it (since that would require moving back to self-determined Fedora)
17:31:43 * kalev nods.
17:31:54 <nirik> a) we do keep normal httpd type logs with ip address and file, but we don't gather anything else there.
17:32:06 <nirik> b) we never publish this data outside fedora infrastructure.
17:32:49 <t8m> nirik, well it can be tracked on the route to you, but still not much is revealed other than there is something fedora-like behind the ip
17:33:01 <nirik> right
17:33:04 <randomuser> nirik, maybe a proactive fedoramagazine/blog article about the sysadmin-$sensitive vetting process would help?
17:33:17 <sgallagh> I think it might not be the worst idea to talk to legal about publishing a data privacy policy
17:33:23 <nirik> which you can get 10,000 other ways if you are intercepting data.
17:33:27 <sgallagh> Making it clear that we don't gather personally-identifying data
17:33:28 <mattdm> I can see wanting to have a machine be silent on a network unless a user intentionally initiates something. But I don't think that that's been a design concern for Gnome or Fedora before, and this is only one of a number of things that does similar. Trying to lock that down would be a challenge. (And probably worth a planned fedora change)
17:33:38 <nirik> sgallagh: we already have a privacy policy...
17:33:40 <mattdm> sgallagh: we have that
17:33:48 <mattdm> http://fedoraproject.org/wiki/Legal:PrivacyPolicy
17:34:34 <sgallagh> That document doesn't say anything about server logs for updates or connectivity polling
17:34:41 <sgallagh> But I'm not going to argue loudly
17:35:59 <nirik> well, those aren't really identifyable...
17:36:06 <t8m> mattdm, +1
17:36:15 <sgallagh> nirik: Then a line stating exactly that would be nice
17:36:16 <nirik> in fact this case of the hotspot file could be... anyone with internet connectivity.
17:36:33 <nirik> if NM is using this, it could well be very cross distro as well
17:36:41 <dgilmore> I do not see any security or privacy concerns. but I see no harm in allowing opt out
17:36:45 <mattdm> nirik -- there is a per-distro config.
17:36:46 <sgallagh> nirik: Well, it's contacting a Fedora-controlled server
17:37:05 <sgallagh> Yeah, I think we're all more or less agreeing on that, or am I mistaken?
17:37:16 <nirik> sgallagh: sure, but we don't ask everyone who hits our servers to identify that they are a fedora user. ;)
17:37:19 <t8m> mattdm, I think making this opt-out is one small step towards this change
17:37:19 <dgilmore> what if we made the url be mirrormanager?
17:37:29 <sgallagh> I'm okay with weakening my proposal to just state "Must be opt-out" and letting the Workstation group figure out the best method
17:37:36 <dgilmore> will people complain then?
17:37:46 <mattdm> we could look at making that specific server/URL have special rules (discard all logs) and privacy policy, but I think that is a lot of work for infrastructure for unclear gain
17:37:51 <nirik> dgilmore: they need to know the exact contents of the file so they can know if it's been hyjacked.
17:37:54 <nirik> mm might still work tho
17:38:15 <t8m> I think there is not much concern on the server side.
17:38:22 * sgallagh wonders if it shouldn't be a challenge-response app if they really want to trust it
17:38:24 <nirik> dnssec-trigger also uses the same file.
17:38:31 <nirik> (it was added for them first long ago)
17:38:31 <sgallagh> But that's a different problem
17:38:43 <dgilmore> nirik: we could validat the metalink
17:38:46 <dgilmore> validate
17:38:52 <dgilmore> anyway just a idea
17:39:14 <jwb> i think reengineering the mechanism here isn't going to solve the question being asked.
17:39:28 <dgilmore> jwb: no it won't
17:39:37 <nirik> anyhow, I am fine with the orig proposal, or just letting the workstation group decide how best to make it easier to opt-out of.
17:39:51 <kalev> with my Workstation hat on, I'm fine with the proposal as it is
17:39:55 <jwb> same
17:40:20 <kalev> just one question: is it something to do for Alpha? Should I file a Freeze Exception / Blocker to pull this in?
17:40:45 <sgallagh> kalev: No, I think it's fine to leave that for Beta, personally
17:40:52 * nirik doesn't think it's urgent.
17:40:54 <jwb> yes, agreed
17:40:56 <sgallagh> How many people are going to install the Alpha that aren't Fedora contributors?
17:41:14 <jwb> 1 billion
17:41:20 <dgilmore> sgallagh: some.
17:41:53 * sgallagh shrugs
17:42:07 <sgallagh> Anyway, votes? (I'll reprint the proposal)
17:42:08 <nirik> is there release notes/info on this?
17:42:12 <sgallagh> #proposal Ask Workstation to move the strict dependency to fedora-release-workstation and include the captive portal as a default package that can be removed instead of as a dependency for gnome-shell.
17:42:21 <nirik> +1
17:42:26 <jwb> +1
17:42:31 <mattdm> I'm +1 if we need a vote
17:42:34 <dgilmore> sgallagh: nak, I dont think we should tell them how to do it
17:42:40 <t8m> +1
17:42:45 <randomuser> nirik, I have a mental note, fwiw
17:42:52 <dgilmore> sgallagh: ask them to make it easier to opt-out
17:43:16 <sgallagh> dgilmore: Feel free to counter-propose
17:43:16 <dgilmore> sgallagh: i personally think putting the package in a comps group would be better
17:43:26 <kalev> +1
17:43:37 <sgallagh> "include the captive portal as a default package" I assumed meant "put in a comps group"
17:43:48 <sgallagh> But maybe that was unclear
17:43:52 <dgilmore> #proposal Ask Workstation to rethinhk how to pull the package in with the goal of easily enable people to opt out
17:44:13 <nirik> sure, +1 here too
17:44:27 <sgallagh> I'm fine with +1 to either proposal
17:45:21 <dgilmore> im +1 for my proposal
17:45:31 <dgilmore> I do not think we need to tell them how to implement it
17:45:45 <sgallagh> Sure, I'm fine with not dictating the method. Just the outcome :)
17:45:55 <kalev> I'll note that in practice we'll likely still go with sgallagh's suggestion.
17:45:58 <t8m> +1 to dgilmore's proposal as well
17:46:01 * randomuser adds a brief note to RNs wiki, will add more when implementation settles
17:46:34 <sgallagh> Thanks randomuser
17:46:36 <jwb> +1 to either
17:47:13 <sgallagh> OK, I count +5 for dgilmore's proposal and I'm going to withdraw mine.
17:47:38 <sgallagh> #agreed Ask Workstation to rethink how to pull the package in with the goal of easily enabling people to opt out (+5, 0, -0)
17:47:49 <sgallagh> #topic Next week's chair
17:48:36 <drago01> dgilmore: I made gnome-shell depend on it for two reasons 1) to get it pulled in on upgrades 2) because I couldn't think of a reason to remove it
17:49:00 <drago01> dgilmore: would a config switch to disable it be good enough? would not break 1)
17:49:10 <dgilmore> drago01: people may not want it, and upgrades should pull it in as tehy sync the comps groups from memory
17:49:28 <jwb> upgrades via comps from f20 -> f21 workstation?
17:49:29 <sgallagh> drago01: Let's talk implementation elsewhere
17:49:34 <jwb> that seems... unplanned for
17:49:38 <dgilmore> drago01: sure. I personally have no issue with it. I just know people want to opt out
17:49:39 <sgallagh> We agreed to leave the implementation for the Workstation WG
17:49:44 <jwb> yeah
17:49:50 <drago01> sgallagh: the proposal mandates a specific implemenatation
17:49:54 <drago01> (i.e package level)
17:49:55 <dgilmore> drago01: but its up to the WG to decide
17:49:55 <drago01> but ok
17:50:11 <sgallagh> drago01: Poorly-phrased, then
17:50:18 <jwb> don't split hairs here
17:50:20 <jwb> just move on
17:50:36 <dgilmore> drago01: no it doesn't "Ask Workstation to rethinhk how to pull the package in with the goal of easily enable people to opt out" the goal being enabling opt out
17:51:00 <drago01> dgilmore: ok
17:52:30 <dgilmore> where were we in the meeting
17:52:39 <jwb> chair for next week
17:52:45 <jwb> i'll do it
17:53:00 <jwb> btw... the fedocal entry for this meeting is off by an hour
17:53:03 <dgilmore> thanks jwb
17:53:26 <sgallagh> #info jwb to chair next week's meeting
17:53:31 <sgallagh> #topic Open Floor
17:53:37 <sgallagh> Anything for Open Floor?
17:53:53 <jwb> just an FYI
17:53:55 * sgallagh has a hard stop in seven minutes, so if we continue past the hour, someone else will need to close out.
17:54:12 <jwb> the workstation WG has held 2 (2!) irc meetings now.  we're getting to it and publishing minutes and such
17:54:25 <nirik> awesome
17:54:35 <sgallagh> I've been reading the minutes. Good job.
17:56:11 <sgallagh> Anything else for Open Floor?
17:56:47 <sgallagh> OK, I'll close the meeting in 60s
17:57:26 <jwb> oh, curious
17:57:29 <jwb> 
17:57:31 <jwb> Announcing our "Ubuntu Loves Devs" effort! Let's make Ubuntu the developer platform of choice, whatever technology you are interested in!
17:57:37 <jwb> YAY FOR COMPETITION
17:57:45 <jwb> anyway, close the meeting out
17:58:19 <sgallagh> I think someone's been following our work on Workstation :)
17:58:24 <sgallagh> ok, thanks for coming, everyone
17:58:27 <sgallagh> #endmeeting