env-and-stacks
LOGS
13:05:26 <hhorak> #startmeeting Env and Stacks (2014-08-19)
13:05:26 <zodbot> Meeting started Tue Aug 19 13:05:26 2014 UTC.  The chair is hhorak. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:05:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:05:35 <hhorak> #meetingname env-and-stacks
13:05:35 <zodbot> The meeting name has been set to 'env-and-stacks'
13:05:41 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp mmaslano vpavlin sic
13:05:41 <zodbot> Current chairs: bkabrda hhorak juhp mmaslano pkovar samkottler sic tjanez vpavlin
13:05:51 <bkabrda> hi
13:06:09 <sicampbell> Is there a way to get my nick listed in the chairs rather than my fas username ?
13:06:48 <hhorak> sicampbell: sure, I just used what is listed on the wiki: https://fedoraproject.org/wiki/Env_and_Stacks so I'll fix it there
13:06:49 <sicampbell> Or am I misunderstanding and it should be my FAS ?
13:07:41 <Southern_Gentlem> sicampbell,  not really the person starting the meeting just needs to add your nick
13:07:50 <Southern_Gentlem> instead of your fas
13:08:12 <Southern_Gentlem> which meetingbot has no connection anyways
13:08:40 <hhorak> sicampbell: I don't think so.. trying again:
13:09:00 <hhorak> #chair pkovar tjanez samkottler bkabrda hhorak juhp mmaslano vpavlin sicampbell
13:09:00 <zodbot> Current chairs: bkabrda hhorak juhp mmaslano pkovar samkottler sic sicampbell tjanez vpavlin
13:09:31 <Southern_Gentlem> hhorak,  and if you need to add anyone else just do #chair nick
13:09:53 <hhorak> Southern_Gentlem: ok, probably the first time chairing... :)
13:10:11 <hhorak> #topic Flock -- what we learnt
13:10:25 <Southern_Gentlem> no problem just giving a suggestion
13:11:26 <hhorak> So the first important feedback on all working groups was lack of communication.
13:11:47 <hhorak> I've heard that several times on the Flock
13:12:28 <sicampbell> Was that just from this working group or fedora in general ?
13:13:30 <pkovar> (i think that flock helped quite a bit with that. people could meet face to face and some of the conversations we had were pretty productive)
13:13:58 <hhorak> sicampbell: I understood it like communication between our working group and other working groups should be better.
13:14:36 <hhorak> pkovar: yes, I think that was great
13:15:30 <pkovar> some ideas for improvements: more blog posts?  CCing general MLs when sending reports?
13:15:44 <pkovar> or minutes
13:17:42 <sicampbell> All good ideas
13:18:03 <hhorak> pkovar: reports are already being sent to fedora-devel afaict, but blogs seems to be great idea; marcela wrote something, but we can definitely do better
13:18:32 <hhorak> pkovar: I meen meeting minutes, or did you mean something else, some other reports?
13:18:55 <pkovar> oh yeah, i meant meeting minutes
13:20:04 <sicampbell> was there an issue with people just not knowing what this working group's area of responsibilities are in relation to other WGs
13:25:06 <hhorak> sicampbell: I understood that that was one issue, the other issue could be the opposite direction (or result), that we do not have much info from other WGs, what their needs are etc.
13:26:08 <hhorak> One idea to stay more informed was to provide quick summary of what other WGs did; sent to our ML weekly or every two weeks, so all members are up to date (I can try for the next time)
13:26:35 <sicampbell> hhorak: sounds good
13:27:43 <hhorak> #action hhorak will send a summary about what other WGs did before the next meeting
13:30:37 <sicampbell> Do we need a way of telling people how to request things of this WG ?
13:31:17 <sicampbell> This could just be a sentence on the wiki page, or a ticketing/issue system, or somewhere in between
13:31:49 <pkovar> maybe a sentence on the wiki page asking people to email our ML?
13:32:08 <hhorak> sicampbell: I hope it is obvious from the wiki page, but we can encourage them more directly to talk to us
13:32:33 <hhorak> so yeah, why not.. anybody willing to adjust the wiki?
13:32:42 <sicampbell> I can do it
13:32:50 <hhorak> sicampbell: thanks
13:32:52 <pkovar> ty
13:33:43 <hhorak> #action sicampbell will adjust wiki page to tell people how to request things of this WG
13:34:08 <hhorak> any other ideas how to make the communication better?
13:34:20 <bkabrda> maybe we should also mention the irc channel there? I think that's more "casual" and people who don't know exactly what they want might want to use it and formulate their ideas together with us
13:35:26 <hhorak> bkabrda: sounds fine to me
13:35:36 <sicampbell> bkabrda: I'll add it to the sentence on the wiki
13:38:56 <hhorak> Ok, let's move to some other topics from flock -- Stephen Smoogen talked about epel vs. epic (https://www.youtube.com/watch?v=CDmkg9V_NzU)
13:39:52 <hhorak> I think this is something we should not only follow but should be part of -- or in other words we should participate in this movement
13:42:58 <hhorak> the idea is basically to have set of packages (stacks) that have different maintaining model (some maintained for the whole RHEL life, some only for a limited period)
13:44:28 <hhorak> I'm not sure if we need to talk about it more now, just mentioning to let others (who were not on Flock) to be aware..
13:44:56 <hhorak> It might be a topic for some of the next meetings
13:46:30 <hhorak> #info we might talk during some of the next meetings about (and start to participate in) the epel/epic proposal from Stephen Smoogen (https://www.youtube.com/watch?v=CDmkg9V_NzU)
13:46:47 <bkabrda> hhorak: looks interesting in connection with python3 in EPEL 7, which is kind of a sticky situation. thanks for that, I'll watch the talk
13:48:41 <hhorak> bkabrda: yes, python3 is related and imho also the general concept of ring 2 in (above) Fedora -- this might be solved in the same manner (similar approach)
13:48:56 <sicampbell> hhorak: I think we can discuss it further once we have all watched the talk
13:49:17 <hhorak> sicampbell: right
13:49:21 <sicampbell> hhorak: looks interesting though
13:51:07 <hhorak> another topic I heard on flock -- software collections -- basically we should find a way to deliver this concept to Fedora users (somehow)
13:51:49 <hhorak> again probably a topic for some of the next meetings
13:53:14 <hhorak> And of course Docker (was there a talk where Docker was not mentioned at all?)
13:54:48 <hhorak> This is something we need to continue to talk about (and start to implement missing pieces)
13:57:02 <hhorak> also I should mention pkovar's documentation workshop, that I missed unfortunately -- petre, was there anything you would like to share?
13:57:42 <pkovar> a couple of ideas were brought up that are worth mentioning i think...
13:58:31 <pkovar> some work has been done on an devassistant "assistant" for documentation writers
13:58:49 <pkovar> which will first support docbook + publican toolchain
13:59:06 <pkovar> other formats will hopefully be implemented later
13:59:15 <pkovar> that leads us to the second topic
13:59:17 <pkovar> doc formats
13:59:29 <pkovar> turns out many developers
13:59:36 <pkovar> hate authoring xml documents
13:59:41 <pkovar> such as docbook
14:00:08 <pkovar> instead, they strongly prefer simple xml-less formats such as asciidoc or markdown
14:00:41 <pkovar> so we should start looking into creating a platform for fedora devs as well as writers
14:01:01 <pkovar> that would allow for easy and simple submission of docs
14:01:31 <pkovar> targeting all audiences, even though the primary focus should probably be developers
14:01:58 <pkovar> i expect some discussion on the fedora docs ML this week
14:02:11 <pkovar> will let you know / CC our ML if that happens
14:02:16 <pkovar> so you can chime in :)
14:02:57 <hhorak> pkovar: great, thanks for the update
14:02:59 <pkovar> that new platform for docs would also fix the issue with our fedora wiki
14:03:04 <pkovar> hopefully
14:03:27 <pkovar> as we could easily move some of the docs from wiki to formats like markdown
14:03:45 <pkovar> well, we will see
14:06:01 <hhorak> OK, so, was there anything important for our WG on the Flock I haven't mentioned yet? Anyone?
14:06:29 <pkovar> looks like we covered it all :)
14:07:14 <hhorak> Yeah, if anybody remembers something else, worth mentioning to others, feel free to send it to the ML.
14:07:38 <hhorak> #topic OpenFloor
14:07:50 <hhorak> Any other topic we should cover today?
14:11:39 <hhorak> It does not seems so.. That means we can end the meeting for today. Thanks everybody! Bye!
14:11:48 <hhorak> #endmeeting