fedora-meeting
LOGS
16:07:39 <walters> #startmeeting
16:07:39 <zodbot> Meeting started Fri Aug  1 16:07:39 2014 UTC.  The chair is walters. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:08:04 <walters> Looks like there wasn't an agenda beforehand - is this our first meeting with the new time?
16:08:27 <walters> (Apologies that I missed previous meetings, had a conflict, this one should be better for me at least)
16:09:17 <walters> anyone have agenda items?
16:09:42 <geppetto> jzb: ping
16:10:06 <walters> I think we're waiting on a python-blivet fix before image generation works again
16:10:22 <imcleod> walters: That sounds about right.
16:11:00 <walters> on the Atomic side I have been working on more Fedora 22 stuff - since there will be an installer ISO and such in addition to a cloud image
16:11:17 <imcleod> I can give a brief update on getting a Fedora account in the HP cloud.  We had a productive meeting yesterday with their "open source" contracts person.  It looks as if we should be able to get an account under terms that are acceptable to us on the RH/Fedora side.
16:11:45 <mattdm> huh. I have this down as 1pm :)
16:12:02 <walters> My work is https://github.com/cgwalters/fedora-atomic-work if anyone is interested (I think the shell scripts suck and am open to better ideas)
16:12:08 <imcleod> walters: I also have, I believe, a full set of builds now for Factory and related tools on epel7.  Last obstacle was a rebuild of Oz to address a SPEC bug.  So we can start to have you try using it under RHEL7.
16:12:32 <walters> imcleod, awesome!  I think on the Fedora side we're ok since the compose hosts are now F20
16:12:43 <walters> but downstream that el7 build will be quite important
16:12:51 <imcleod> walters: Roger.
16:13:03 <walters> mattdm, it's possible that I am timezone challenged...
16:15:04 <mattdm> walters: or I am. number80 set it up in paris timezone so it's even more confusing than normal :)
16:15:22 <mattdm> imcleod: that's great news re hp cloud!
16:16:12 <imcleod> mattdm: Indeed.  It was an encouraging meeting.  Earlier conversations hadn't really captured the fact that this is a public/non-monetized image we are talking about.
16:16:22 <walters> why doesn't fedocal show the time in local time as well?  it's a browser app so it has my local time zone...
16:17:01 <walters> and yeah, looks like 1pm
16:17:01 <walters> sorry
16:17:33 <mattdm> walters: we can talk really slowly until then :)
16:17:46 <imcleod> Or we can give our positive updates _twice_!
16:17:52 <mattdm> imcleod +1
16:17:54 <mattdm> or +2, as it were
16:18:07 <mattdm> actually, I think my plan is to get some lunch :)
16:59:47 <number80> mattdm: I don't know why it was set up like this because even in my timezone, it doesn't make sense :/
16:59:56 <number80> (I tried to fix it twice)
17:00:05 <mattdm> number80: oh hi. :)
17:00:22 <mattdm> maybe we need someone who lives in Greenwich to set up all of our meetings
17:00:47 <number80> I think I'll just change my timezone to UTC in FAS
17:01:45 <mattdm> okay, soooo -- who do we have around?
17:01:48 * walters is here again
17:02:51 <mattdm> hi walters
17:03:06 <mattdm> number80: do we have an agenda? i've been scrambling to finish up all my pre-flock procrastination :)
17:03:38 <number80> mattdm: I don't think that we updated it since these last 2 or 3 weeks
17:03:39 * agrimm arrives
17:04:32 * geppetto is here
17:05:44 <agrimm> no oddshocks today?
17:06:31 <number80> since walters is here, we may start with the atomic items ?
17:07:11 <number80> https://fedorahosted.org/cloud/report/9 (meeting items for anyone who wants to check)
17:08:01 <agrimm> sounds okay to me
17:08:20 <agrimm> so who's chairing this meeting?
17:08:31 <number80> with geppeto around, I think we almost have quorum
17:08:36 <walters> i think i am since I did #startmeeting too early =)
17:09:03 <agrimm> walters, well, you can chair others, of course.  :)
17:09:12 <walters> on the atomic status i don't have much to add at the moment on top of what I said earlier; working on the compose scripts, and will look at what agrimm has done for imagefactory
17:09:13 * agrimm is not too swift with the fedbot command set yet
17:09:15 <number80> agrimm: shushhh :)
17:09:33 <mattdm> walters any particular blockers that need focus/escalation?
17:09:40 <number80> http://fedoraproject.org/wiki/Zodbot#Meeting_Functions
17:10:23 <walters> mattdm, i think there's the python-blivet issue that agrimm knows about; beyond that i'd say a risk is knowing that we can do the full koji -> compose -> koji cycle for cloud images
17:10:45 <mattdm> right now "koji -> compose" doesn't seem to be working :)
17:10:56 <mattdm> never mind ostree :-/
17:11:01 <agrimm> walters, the blivet issue was fixed (by moving the code into anaconda and refactoring)
17:11:10 <agrimm> but now there are other, weirder issues
17:11:22 <walters> yeah, two uses of the word "compose" here - the mainline sense of repomd, the rpm-ostree sense of repo -> tree
17:12:11 <agrimm> walters, so the hold-up on doing real koji builds is still having a populated ostree mirror in a particular koji-friendly place?
17:12:46 <agrimm> (just making sure we're all on the same page about why we're living in standalone imagefactory today)
17:12:56 <walters> agrimm, yes, as well as rel-eng scripting side in terms of passing that data from the git repos to koji
17:14:42 <walters> should we iterate over the tickets?
17:14:55 <walters> (sorry, haven't chaired a meeting before, happy to pass the baton if anyone knows this better)
17:15:50 <number80> walters: since not everyone is here, let's ask before :)
17:15:56 <walters> k
17:16:20 <number80> since roshi is away, maybe we could skip testing items ?
17:16:39 <number80> from our last informal meeting, he said that we have enough test cases for alpha
17:16:57 <number80> I hope to grab someone from QA to help them completing the suite
17:17:01 <number80> (at flock)
17:17:11 <mattdm> (iterating over tickets is a good way to do it)
17:18:40 <walters> any updates on https://fedorahosted.org/cloud/ticket/65 ?
17:19:35 <mattdm> walters: I don't have any, but the Base WG is apparently interested in taking this over
17:19:50 <walters> ah right
17:19:55 <mattdm> i'll update the ticket now
17:20:59 <walters> k, i added a comment too
17:21:41 <mattdm> walters: oh your comment just says what mine was going to :)
17:22:37 <walters> ok, moving on to https://fedorahosted.org/cloud/ticket/50
17:22:44 <number80> mattdm: I thought it was to be taken over by the stacks-and-env WG :/
17:24:04 <mattdm> number80: that was the suggestion, and they punted to base. *shrug*
17:24:24 <number80> amen
17:25:23 <mattdm> walters: I think this one can be closed. we have the spin kickstarts
17:26:10 <walters> k, added a comment and closed
17:26:27 <walters> skipping #38 per previous comment
17:26:39 <walters> anything for https://fedorahosted.org/cloud/ticket/72 ?
17:27:07 <mattdm> walters: um, I dropped the ball on followup for that.
17:27:25 <mattdm> walters: let's assign that to me, drop from meeting keyword
17:27:41 <mattdm> and i'll re-meeting-keyword it if there's some need
17:28:05 <walters> done
17:28:22 <walters> next is https://fedorahosted.org/cloud/ticket/36
17:28:54 <walters> i saw some discussion on this in an earlier meeting?
17:29:03 <mattdm> yeah. jzb around to give an update?
17:29:18 <mattdm> if not, skip til next week?
17:29:29 <mattdm> (where next week = two weeks from now beause of flock)
17:29:51 <walters> k, noted
17:30:01 <number80> well, we could have a face 2 face meeting if there are enough peeps around :)
17:30:31 <walters> next is https://fedorahosted.org/cloud/ticket/51
17:30:31 <mattdm> number80 yeah, and jzb actually suggested that on the list. it's a good idea.
17:30:35 <number80> (lately, it was very hard to gather at least 4 people)
17:31:00 <mattdm> ooh look more of me not following up on things. we should do this ticket review more often
17:31:09 <walters> this is basically in a state where we *can* do it right?
17:31:24 <mattdm> walters: yeah. we just need the policies.
17:31:26 <walters> just don't have a formal process for testing/releasing?
17:31:56 <mattdm> walters right, exactly.
17:32:19 <mattdm> this flock talk http://flock2014.sched.org/event/d34e1c4f14d40000649c0b134c49a8f0
17:32:20 <agrimm> mattdm, I volunteered a few weeks ago to help with some portion of this.  still willing to
17:32:22 <mattdm> might be relevant
17:32:28 <walters> this seems to boil down to https://fedorahosted.org/cloud/ticket/43
17:32:40 <mattdm> agrimm awesome.
17:32:48 <mattdm> and yes, those tickets are duplicates
17:33:19 <mattdm> #action agrimm to do something about https://fedorahosted.org/cloud/ticket/43 and https://fedorahosted.org/cloud/ticket/51
17:33:22 <mattdm> :)
17:33:50 <walters> next is https://fedorahosted.org/cloud/ticket/59
17:34:03 <walters> hmm
17:34:09 <agrimm> mattdm, I suspect I'll end up writing up more questions than answers.  :)
17:34:14 <walters> isn't this blocked on fedora rel-eng even being able to upload them?
17:34:24 <walters> i don't think we have that done yet, right?
17:34:58 <mattdm> agrimm: that's fine
17:35:27 <mattdm> walters: they can be done by hand, worst case
17:35:54 <mattdm> and I haven't talked to oddshocks about the state of fedimg but last I saw it was production-ready
17:36:08 <walters> personally i'd like to see fedora have a registry
17:36:58 <walters> there's also a question of which we want to ship...right now the Dockerfiles are in many cases what i'd call demos/examples
17:37:03 <walters> they have fixed passwords for example
17:37:31 <walters> some of i mean
17:38:20 <mattdm> walters: yeah. I think us having a registry is a good longer-term plan
17:38:45 <mattdm> and separating out the different demo/example ones from any that are "launch and go"
17:39:25 <mattdm> (on fedimg comment earlier -- sorry, that was badly worded. the docker stuff is a feature request not production ready, but the _rest_ of it is, so integrating uploading is a possibility)
17:39:31 <number80> walters: do you know if infra is ok with docker-registry ?
17:39:49 <number80> (since it's a flask app, it should be but need to be checked)
17:40:56 <walters> not sure why the programming language would be as primary a concern versus say storage/networking, transport security and signing etc
17:41:56 <walters> should we leave the meeting tag on this so it comes up again?
17:42:08 <mattdm> walters sounds good, yeah
17:42:08 <walters> or try to break it into smaller tickets?
17:42:14 <walters> ok
17:42:27 <walters> next is https://fedorahosted.org/cloud/ticket/61
17:42:41 <number80> walters: they need to be able to do hotfix and stuff like that
17:43:03 <mattdm> sooo anyone want to help roshi here? :)
17:43:08 <mattdm> I think this one might be....
17:43:20 <mattdm> #help still need help with QA and test plan
17:43:40 <number80> I helped him for the first scenario and willing to keep going
17:43:49 <mattdm> number80: cool
17:43:58 <mattdm> can you check with him about next steps at this point?
17:44:02 <walters> hum, do we really want to require Xen DomU?
17:44:02 <number80> yup
17:44:13 <walters> i guess EC2
17:44:28 <mattdm> walters: yeah ec2. also some eucalyptus.
17:44:43 <mattdm> #action number80 to contact roshi about next qa steps
17:45:10 <walters> ok
17:45:38 <walters> finally there is https://fedorahosted.org/cloud/ticket/64
17:45:54 <walters> i think this has been covered earlier, things are moving somewhat
17:46:04 * mattdm nods
17:46:21 <number80> +1
17:47:01 <mattdm> thanks walters for chairing and going through the tickets!
17:47:22 <walters> np!
17:47:27 <number80> thanks :)
17:47:38 <walters> if no one has other agenda items, i had a few quick ones
17:47:42 <mattdm> okay go!
17:47:45 <walters> first, Google Compute
17:48:01 <mattdm> yeah. we've had a number of people with interest, including from google.
17:48:09 <mattdm> ticket at https://fedorahosted.org/cloud/ticket/5
17:48:16 <walters> i think right now we have cloud-init 0.7.5 which is good enough
17:48:42 <walters> the reason i thought about this is the qa criteria
17:48:55 <mattdm> i know it's on the todo list for fedimg
17:49:18 <agrimm> I've booted rawhide images on GCE ... they work fine in my experience
17:49:29 <agrimm> we just need to do something official. :)
17:49:30 <mattdm> walters hmmm, yeah. once we support it, we'll want to test and make sure it works
17:49:55 <walters> agrimm, yeah, i'd say we have enough interest to be committed to supporting it
17:50:21 <agrimm> walters, right, there was something about getting an official account to which we can upload
17:50:27 <agrimm> and make images public
17:50:45 <walters> makes sense
17:51:03 <agrimm> mattdm, is there still something that has to go through legal there?
17:52:05 <walters> there was another item i was thinking of but i didn't write it down and have forgotten now =/
17:52:08 <agrimm> I know we are blocked.  I just don't know why or how I can help (that's all too common in this channel)
17:53:25 <mattdm> agrimm I'm not quite sure about the legal status overall. it is possible that that's where it's blocked
17:53:40 <mattdm> maybe we can get imcleod to help with that since he has untangled the situation with HP cloud nicely :)
17:54:31 <agrimm> ok
17:54:36 <imcleod> mattdm, agrimm, anyone: Do we have any commercial contact points at Google?
17:54:57 <number80> we had at some point
17:55:01 <mattdm> imcleod: I have some technical ones
17:55:33 <walters> there's at least two trying to push the cloud image forward on the list no?
17:55:46 <walters> or at least they were commenting on the google agent bits i think
17:56:06 <imcleod> Bah.  Cloud-specific agents. Boo.
17:56:16 <walters> two tech contacts who would likely also know who to talk to for commercial/legal
17:56:48 <imcleod> walters: Roger.  I can give it a go.  Who knows, perhaps someone from Google will be at Flock.
17:56:54 * mattdm has to go -- apologies. please #action me for anything I need to do and I'll try to not drop it :)
17:56:57 <walters> ok cool
17:57:07 <walters> mattdm, i think we're about done - anyone have anything else?
17:57:44 <walters> ok, thanks all!
17:57:47 <agrimm> imcleod, I would like us to move forward without those bits.  using cloud-init for a standard image is fine
17:57:54 <number80> thanks walters and everyone !
17:57:58 <agrimm> they can make a GCE-optimized image with those bits if they so desire
17:58:02 <agrimm> I would not discourage that
17:58:02 <walters> #endmeeting