fedora-qa
LOGS
15:01:15 <adamw> #startmeeting Fedora QA meeting
15:01:15 <zodbot> Meeting started Mon Jul  7 15:01:15 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:18 <adamw> #meetingname fedora-qa
15:01:18 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:21 <adamw> #topic Roll call
15:01:25 <adamw> ahoyhoy folks, who's around?
15:01:29 * roshi is here
15:01:30 <roshi> o/
15:01:35 * satellit listening
15:02:00 * tflink 
15:02:16 * brunowolff is here
15:03:20 <xmrbrz> here o/
15:03:22 * kparal is here
15:04:23 * cmurf is lurking
15:04:26 <kparal> pschindl and mkrizek send word that they won't come today
15:04:51 * pwhalen is here
15:05:42 <adamw> kparal: did they decide any independence day is worth a few beers? :)
15:05:44 * handsome_pirate is nomming tasty bacon
15:06:20 * danofsatx-work is here, surprisingly
15:06:50 <kparal> adamw: their today's priority was football (/soccer) I heard
15:07:35 <kparal> there is apparently some red hat organized football team here in brno
15:08:01 <adamw> oh right, go team!
15:08:07 * adamw cheerleads
15:08:42 * handsome_pirate pictures adamw in a cheerleader outfit and decides he's not drunk enough
15:09:03 <brunowolff> You or adamw?
15:09:10 <handsome_pirate> both
15:11:15 <adamw> handsome_pirate: i'll have you know my thighs are the envy of the squad
15:11:22 <adamw> and i never cheerlead sober
15:11:30 <handsome_pirate> heh
15:11:43 <adamw> allllrighty then
15:11:45 <handsome_pirate> adamw:  Now, imagine *me* in a cheerleader outfit
15:11:51 <adamw> #chair tflink brunowolff
15:11:51 <zodbot> Current chairs: adamw brunowolff tflink
15:12:04 <adamw> handsome_pirate: oh, i've always pictured you more in a sailor fuku
15:12:12 <handsome_pirate> lol
15:13:07 <adamw> #topic Fedora 21 test planning status
15:14:00 <adamw> so, in case anyone was unaware, we are supposed to do F21 Alpha TC1 tomorrow
15:14:08 <adamw> yeah, that kinda crept up on us
15:14:18 <handsome_pirate> ouch
15:14:19 * kparal is surprised and unaware
15:14:23 <adamw> #info tomorrow (2014-07-08) is the date for branching and Alpha TC1
15:14:37 <adamw> it's been on http://fedorapeople.org/groups/schedule/f-21/f-21-quality-tasks.html all along ;)
15:14:43 * satellit no boot.iso or lives atm ?
15:14:54 <handsome_pirate> satellit:  Not yet
15:15:26 <adamw> so, i think everyone's really a bit behind on this
15:15:50 <roshi> I think you'd be right on that :)
15:16:08 <tflink> which makes the alpha release date that much more strange, in my mind
15:16:13 <adamw> i asked dgilmore for releng's position; he says there isn't an agreed list of deliverables (between fesco/the WGs/releng) yet, and koji does not yet have the ability to build Docker base images, which are apparently desired for F21
15:17:08 <adamw> of the products, Server hasn't really brought any product-specific change to the point where it'd actually show up in a spin yet, Workstation is probably the best positioned as they can plausibly throw the 'workstation' name on whatever pops out of the workstation kickstart, and i'm not sure of the position of cloud...roshi?
15:17:47 <roshi> it's pretty cloudy :p
15:17:49 <tflink> aren't we still waiting on server deliverables before it can be built?
15:18:14 * tflink doesn't quite grok the roles bit that got an extension on the feature change freeze
15:18:18 <adamw> tflink: this is fedora! no-one really knows!
15:18:29 <roshi> aiui, cloud is still waaiting on the docker builds
15:19:03 <handsome_pirate> So, in other words, this is going to be interesting
15:19:04 <roshi> but the freeze/branch hasn't been discussed too much
15:19:07 <adamw> tflink: i mean, we can spin something with no server images and call it 'alpha tc1'. should we? will we? iunno.
15:19:39 <brunowolff> Branch is tomorrow.
15:19:40 <tflink> yeah, I'm not quite sure what's going on, either
15:19:46 <adamw> tflink: the server role API is the big new thing for Server. change freeze deadline is independent of alpha tc1 date, i believe - one got moved, not the other
15:19:47 <danofsatx-work> it should be workstation-alpha-tc1
15:19:53 <roshi> cloud WG meetings have had a hard time getting enough people the last couple times
15:19:58 <adamw> danofsatx: workstation-and-cloud-tc1? :P
15:20:13 <handsome_pirate> Except docker
15:20:42 <roshi> adamw: are we going with separate test matrices and RC?
15:20:51 <danofsatx-work> we have three products for F21. workstation-alpha-tc1, cloud-alpha-tc1, server-alpha-tc1 - iow, it should be three separate releases.
15:20:54 * roshi doesn't recall that being Decided (TM)
15:22:06 <danofsatx-work> it probably hasn't been, but that's my take on the subject
15:22:08 <adamw> anyway, i just wanted to call attention to the general lack of readiness for context and information
15:22:10 <adamw> our job is QA, so...
15:22:20 <adamw> roshi: that is indeed a thing we should decide :P
15:22:22 <roshi> what's QA again?
15:22:24 <roshi> :p
15:22:30 <brunowolff> How is testing fedup going to work for this release?
15:22:38 <adamw> Quadbike Adventuring. let's say it's Quadbike Adventuring.
15:22:42 <roshi> I was just going to ask that brunowolff
15:22:42 * adamw roars off into the distance
15:22:48 <tflink> adamw: +1
15:22:52 <roshi> +1
15:22:59 * roshi is good with adventuring
15:23:20 <adamw> OK, so, i should really start making a list of Good Questions We Can't Answer Ourselves
15:23:21 * handsome_pirate is a hipster in his giant redneck truck
15:23:31 <adamw> #info GQWCAA: how is fedup supposed to work for F21?
15:23:45 <adamw> oh good lord, i can't spell.
15:23:46 <adamw> #undo
15:23:46 <zodbot> Removing item from minutes: INFO by adamw at 15:23:31 : GQWCAA: how is fedup supposed to work for F21?
15:23:52 <tflink> handsome_pirate: there's a bit of cognitive dissonance there with "redneck hipster"
15:23:52 <adamw> #info GQWCAO: how is fedup supposed to work for F21?
15:24:00 <handsome_pirate> There's also a lot of discussion on moving from one product to another
15:24:06 <roshi> what's life without some cognitive dissonance?
15:24:16 <jzb> roshi: I wouldn't know.
15:24:17 <handsome_pirate> ie, if you install Server and want to move to Workstation
15:24:24 <roshi> me either :)
15:24:31 <tflink> handsome_pirate: IIRC, that's not supported for now
15:24:42 <handsome_pirate> Aye
15:24:47 <tflink> and it's unclear if that would ever be supported
15:24:54 <tflink> but I could be mis-remembering
15:24:58 <adamw> #info GQWCAO: Are the Products separate 'streams' for releng/testing/delivery purposes, or must they be built together?
15:25:00 <roshi> yeah - I was thinking it was an F22+ thing to think about/discuss
15:25:47 <roshi> release blocking products are what, all products?
15:26:12 <handsome_pirate> From what I understand
15:27:04 <roshi> I fear cloud won't have enough people testing it (at least enough for solid validation)
15:27:21 <tflink> business as usual, unfortunately
15:27:29 <roshi> yeah
15:27:47 <handsome_pirate> It just so happens that I just sold off the hardware that I'd have used to build a private cloud
15:27:52 <danofsatx-work> I don't have a cloud instance to test it on, or I would.
15:27:58 <roshi> there haven't been a lot of answers to my questions or calls for more test cases to be written by cloudy people
15:28:14 <handsome_pirate> Also business as usual
15:28:19 <adamw> i believe there is a test fedora openstack instance you can run things on, which releng can grant access to (and will, for testing purposes)
15:28:27 <roshi> I'm working on some documentation for running the images standalone locally with qemu
15:28:34 <danofsatx-work> in fact, my free year of AWS is set to expire soon :(
15:28:34 <roshi> so people can test the images themselves
15:28:43 <handsome_pirate> roshi:  I can help with that, if you'd like
15:28:59 <roshi> I'm down for all the help I can get :)
15:29:10 <handsome_pirate> Bang heads after the meeting?
15:29:16 <roshi> sure
15:30:11 <adamw> so in terms of actual validation testing...i'd say what we need at minimum is a plausible set of release criteria for each product (we can bear with some messy layout for a while) and decent test case coverage for them
15:30:43 <adamw> of course, i sent out that nice 'fedora 21 test plan' saying the WGs should be involved in building all that out and everyone nodded and said 'sure, that sounds good' and none of them actually *did* anything
15:30:49 <adamw> somewhere, viking-ice will be reading this log and smirking
15:30:58 <handsome_pirate> lol
15:31:09 <roshi> for sure
15:31:31 <adamw> so Workstation again probably involves the least work over Fedora.last
15:31:39 <adamw> (i just invented that, see what I did there?)
15:32:14 <adamw> #info adamw threw together Workstation-specific criteria and new test cases on Friday: https://lists.fedoraproject.org/pipermail/desktop/2014-July/009985.html
15:32:52 <adamw> #info Server-specific criteria draft is at https://fedoraproject.org/wiki/User:Adamwill/Draft_server_release_criteria (still), new test cases have not yet been written
15:33:11 <adamw> note though that none of the server stuff has actually been *built* yet, so it's kind of a dead letter at this point in time
15:33:23 <adamw> roshi: what's the status on cloud criteria / test cases?
15:33:36 <roshi> I'll work today to get my cloud stuff to roughly match yours
15:34:01 <roshi> well, largely the "yeah, that sounds good. Someone work on it." and then it's just me
15:34:19 <cmurf> is it possible/practical to have one set of criteria for all three produces, like "base"
15:34:29 <cmurf> and then each product has a list of unique criteria?
15:34:31 <roshi> so - in leiu of someone stepping up and saying they aren't complete - no one has complained so they must be good enough
15:34:58 <cmurf> so the base matrix/criteria can be met with testing any of the products?
15:34:59 <roshi> though I feel that might be a dangerous position to take :p
15:35:54 <danofsatx-work> cmurf: that makes too much sense, so of course we won't be doing it that way.
15:36:37 <adamw> cmurf: we still didn't really figure out the best presentation for the criteria for the products
15:36:44 <adamw> cmurf: but as i see it that's priority #2
15:36:49 <roshi> that also presumes that there's a significant similarity between all the products
15:36:54 <adamw> priority #1 is at least making sure all the necessary criteria are actually *written*
15:37:54 <adamw> that might mean we have a sort of chaotic mix of the Fedora.last criteria plus some pages with product-specific criteria on them, which is more or less what we have right now, but we would at least have everything actually on paper and could work with it.
15:38:34 <roshi> wait, I have to write this *on paper?*
15:38:43 * handsome_pirate wonders how arm is going to fit in the criteria
15:38:56 <adamw> cmurf: and yeah, so far as testing goes...my rough read on it so far is there will be some criteria that apply to all products, some that apply to only workstation and server, and some that apply to only a single product
15:38:59 <adamw> roshi: hehe
15:39:18 <roshi> if you tell me it has to be in cursive, you're going to have a bad time
15:39:32 <adamw> submitted to central admin in triplicate
15:39:57 <roshi> I have the handwriting of a doctor :) poor people in central admin
15:39:58 <handsome_pirate> roshi:  No, you have to print everything with capital letters
15:40:19 <cmurf> capital cursive
15:40:21 <handsome_pirate> You also have to fill in all the little bubbles
15:40:24 <tflink> roshi: as long as you follow all the rules, they're happy
15:40:37 <roshi> ah, ok - good
15:40:58 <tflink> because "technically correct" is the best kind of correct :)
15:41:03 <roshi> haha
15:41:38 <adamw> it's TECHNICAL!
15:41:44 <roshi> and all responses should start with "Actually..."
15:42:03 <handsome_pirate> Actually, I like bacon
15:42:26 <adamw> roshi: do you have any test cases for the cloud criteria yet?
15:42:57 <roshi> not wiki testcases
15:43:16 <roshi> going to work on it today
15:43:37 <roshi> since no one from cloud did it
15:44:06 <adamw> roger, thanks
15:44:43 <adamw> #info Cloud criteria drafts are at https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Cloud_Alpha_Release_Criteria , https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Cloud_Beta_Release_Criteria , https://fedoraproject.org/wiki/User:Roshi/QA/Cloud_Docs/Cloud_Final_Release_Criteria (in a different form to server/workstation drafts)
15:44:43 <handsome_pirate> http://s1.tsuki-board.net/pics/figure/big/99523.jpg?t=1329556068
15:44:47 <handsome_pirate> oops
15:45:01 <adamw> handsome_pirate: are you playing reddit One Of These Things Is Not Like The Others again?
15:45:17 <adamw> #info Cloud-specific test cases are not yet written, roshi will work on it today
15:45:34 <handsome_pirate> adamw:  Gel banana :)
15:46:11 <sgallagh> handsome_pirate: If you have access to a time machine, I could really use a "gemini event" right about now...
15:46:24 <adamw> #action adamw to look at how the Install, Base and Desktop matrices should be adjusted for Fedora.next
15:46:29 <handsome_pirate> sgallagh++
15:46:38 <roshi> I just want a hyperbolic time chamber
15:46:44 <roshi> waaay easier than a time machine
15:46:53 <adamw> #action adamw to, uh, completely revise / write all the backing process documentation for Fedora.next testing, that'll be easy
15:47:39 <adamw> since i'm a process nerd we actually have quite a lot of stuff like https://fedoraproject.org/wiki/QA:Desktop_validation_testing
15:47:50 <adamw> all of it needs adjusting for .next, and we need some new stuff written.
15:48:24 * handsome_pirate wonders if we should just roll an old-style tc1 just to get something out
15:49:02 <handsome_pirate> An Hey, does F21 at least install/boot type of image
15:49:06 <adamw> we could do something hybrid-ish, like a Workstation live, cloud images, and a network install image
15:49:26 <adamw> but as mentioned earlier...no-one's got releng, WGs and FESCo on the same page about that
15:49:41 <adamw> i guess we'll just have to file a TC request with some suggestions and see what happens
15:49:49 <adamw> oh, someone asked about ARM, that is another fun question
15:50:01 <adamw> given that ARM stands at a slightly weird angle to the Products
15:50:32 <adamw> i asked on the arm list a few weeks back if they're still expecting to ship their crop of platform-specific disk images for F21, if so what status those would have, and if they're planning to ship any Product-y images
15:51:16 * handsome_pirate admits to having fallen out of the arm thing for a while
15:51:47 * handsome_pirate will poke that ant hill a bit with a nice long stick, if y'all want
15:51:59 <pwhalen> adamw, we discussed this at the meeting last week, and plan on having the same deliverable (minus vfat)
15:52:01 <adamw> https://lists.fedoraproject.org/pipermail/arm/2014-May/007779.html was the ARM thread
15:52:10 <adamw> pwhalen: same...as F20?
15:52:32 <pwhalen> right, we would like to have a boot.iso type option, which is being looked at
15:52:43 <pwhalen> masta may have an update
15:53:21 <adamw> okay. well, that gives us a KDE-ish 'square peg in a round hole' issue, but at least it's easy from a test process perspective
15:54:05 <adamw> so...i guess my meta-plan here is that i'm going to try and pull a plausible validation process which will be a bit rough around the edges out of my ass by tomorrow afternoon
15:54:24 <adamw> i don't want to be a prima donna, but at this point it's a bit late to split up the work :(
15:54:35 <roshi> true
15:54:36 <adamw> (and as noted the WGs really didn't seem to want to do any of the lifting)
15:54:56 <roshi> perhaps do an etherpad or something?
15:54:56 * handsome_pirate imagines Viking-Ice chuckling
15:54:58 <cmurf> hopefully they are busy engineering
15:55:00 <adamw> roshi: are the cloud criteria 'drafts' pretty much what you actually want at this point?
15:55:05 <tflink> have there been any updates on what's happening with the kde spin?
15:55:10 <roshi> what I want?
15:55:28 <adamw> roshi: well, i mean, is there any more work to do in terms of writing/tweaking the criteria or are they ready to go for alpha
15:55:30 <tflink> whether it'll end up a product, part of workstation or a spin?
15:55:36 <roshi> I just want something that'll do the job :)
15:55:47 <adamw> tflink: i believe it was decided a while ago that it'll be a sort of special spin for f21
15:55:48 <roshi> I just asked in cloud if they were good to go as is, and people stopped talking
15:56:00 <adamw> basically it'll be the same as it was for f20: we'll have a KDE live which is release blocking
15:56:01 <roshi> I asked mattdm
15:56:18 <adamw> so again, that's going to be a fun one to try and message, but it kinda makes things a bit easier for us as it's just 'business as usual'.
15:56:49 <masta> pwhalen: sees his name called?
15:56:57 <roshi> since no one took issue with them as I put them up - we're left to assume that they're good to go
15:57:03 <handsome_pirate> masta:  Ahoy
15:57:04 <adamw> roshi: well unless i hear otherwise i'm just gonna go with those as the alpha cloud criteria and pull them in however seems best in a timeframe of, like, 30 hours...
15:57:06 <masta> pwhalen: am I on the hook for an iso image?
15:57:11 <adamw> roshi: ayup
15:57:20 <pwhalen> masta, we were talking deliverables - you were looking into a boot.iso option for arm
15:57:30 <pwhalen> not sure if you had any updates
15:57:48 <adamw> roshi: i could put up a kinda meta-etherpad with notes on the process, i guess, sure...mostly i usually keep that in my head but it might be nice
15:58:09 <adamw> do we have a fedora etherpad?
15:58:14 <tflink> nope
15:58:35 <adamw> eh. i don't have one on happyassassin.
15:58:39 <tflink> packaging issues, AFAIK
15:58:40 <nirik> we do have a goby tho
15:58:56 <nirik> https://fedoraproject.org/wiki/Gobby
15:59:18 <roshi> adamw: I was thinking then people like me might be able to help you work on it in said 30 hours
15:59:26 <roshi> true
15:59:31 <roshi> gobby would work
16:00:25 <adamw> roshi: you can certainly help - write cloud test cases!
16:00:30 <adamw> that's actually probably the biggest thing we're missing right now
16:00:41 <adamw> i don't care about missing server test cases so much since there's nothing to damn test
16:00:49 <roshi> for sure
16:01:18 <roshi> my top priority right now
16:01:21 <adamw> we have workstation criteria and test cases (even if they're first draft), so the main thing now is cloud test cases and getting *some* kind of viable coherent set of matrices
16:01:43 <roshi> cloud test cases are weird
16:01:59 <handsome_pirate> heh
16:02:03 <adamw> it'd be nice to split the load of that second bit, but i can't see a great way to do it because it's kinda something one person has to visualize and hack up really
16:02:10 <roshi> on the wiki anyway - since we have a small subset of people who can do EC2 testing and whatnot
16:02:44 <adamw> roshi: i'd write the test cases in Perfect Theoretical Testing Land, where there are no practical barriers to testing
16:02:44 * handsome_pirate raises his hand at that, btw
16:02:56 * handsome_pirate has amazon instances
16:02:56 <adamw> then you can deal with the barriers at test plan level or by slapping on advisory boxes later
16:03:06 <roshi> I asked the cloud people if local testing would suffice to say things are valid and never got an answer
16:03:14 <roshi> yup
16:03:25 <handsome_pirate> roshi:  I'd say go for it
16:03:28 <roshi> good to know handsome_pirate - we can link up after the meeting
16:03:33 <tflink> roshi: it works for most things
16:03:40 <roshi> yeah - if no response, that means yes :)
16:04:00 <adamw> so...i think we mostly covered things?
16:04:06 <tflink> the only ec2-specific stuff is making sure the instance boots into a usable state
16:04:07 <adamw> lots of work to do, but we should be able to pull *something* out
16:04:17 <roshi> yup
16:04:23 <roshi> gonna be a long day methinks
16:06:01 <adamw> so, we're over time, but just a quick:
16:06:04 <adamw> #topic open floor
16:06:09 <adamw> anyone have anything else to bring up?
16:06:14 <adamw> oh
16:06:21 <adamw> we should probably do a blocker review meeting wednesday
16:06:29 <roshi> can we farm most of this out to mechanical turk or something? :p
16:06:41 <adamw> anyone want to volunteer to run it? taskotron essential personnel do not qualify :P
16:06:41 <danofsatx-work> +1
16:06:55 <adamw> roshi: subcontract it to canonical
16:07:06 <roshi> heh
16:07:30 <cmurf> payment in macaroons
16:08:50 <roshi> so danofsatx-work, you're running the blocker review meeting?
16:09:03 <adamw> or were you +1ing roshi?
16:09:22 * roshi hadn't considered that
16:09:24 <roshi> lol
16:09:55 <danofsatx-work> I was agreeing with roshi
16:10:13 * danofsatx-work isn't qualified to run a meeting
16:10:26 <cmurf> no no too late, dos-w is running blocker review
16:10:29 <adamw> alright, so the plum job of blocker meeting moderator with a salary of $0 is still available
16:10:30 <roshi> bah - what does "qualified" even mean :P
16:10:51 <adamw> roshi: i think it's about meeting the required minimum level of alcohol consumption?
16:11:05 * cmurf is disqualified in that case
16:11:10 <handsome_pirate> adamw:  Well, you know I can do that :)
16:11:17 <roshi> what's the minimum on that?
16:11:20 <roshi> daily or weekly?
16:11:34 <cmurf> roshi: you're in colorado so that's two shots and a puff
16:11:41 <danofsatx-work> I have this thing called a day job that tends to interfere. That's how I lost the election to the Server WG :(
16:12:06 <roshi> zodbot can run the meeting
16:12:20 <adamw> can zodbot write the release criteria too?
16:12:21 <adamw> all hail zodbot!
16:12:28 <roshi> what's the translation from puff to shot?
16:12:44 <cmurf> roshi: well urban dictionary tells me I definitely should have said toke rather than puff
16:12:44 <roshi> because two shots isn't much...
16:12:57 <roshi> haha
16:13:00 <handsome_pirate> lol
16:13:23 * roshi wouldn't have known any better
16:13:26 <adamw> puff is so 60s, man
16:14:32 <cmurf> urban dictionary has been raided by 60's Brits apparently
16:14:48 <cmurf> anyway roshi, it is a MINIMUM
16:15:12 <adamw> roshi: i guess one of us gets to take the bullet
16:15:24 <handsome_pirate> I believe the term is "Smoke a bowl"
16:15:34 <roshi> I can do it
16:15:35 <cmurf> it's about attiude adjustment rather than personality distorting
16:15:52 <roshi> I guess now I know I'm not "taskotron essential" :p
16:16:07 * roshi was looking forward to a badge
16:16:19 <tflink> there's a badge for that?
16:16:29 <roshi> I was hoping
16:16:40 * kparal looks up
16:16:44 <kparal> badges?
16:16:45 * threebean looks up
16:16:50 <tflink> badge/bear trap ... same thing?
16:16:55 <roshi> yeah
16:17:03 <roshi> bear trap is a badge with a better story :p
16:17:09 <adamw> handsome_pirate: that would only apply to a pipe.
16:17:16 <adamw> or, you know, pipe-like apparatus.
16:17:20 <adamw> or, uh, so this guy told me once.
16:17:30 <handsome_pirate> lol
16:17:48 <adamw> we *really* need to build a fedora badge flashlight we can project on the night sky any time we need threebean.
16:17:57 <handsome_pirate> lol
16:18:09 <roshi> +1 to that
16:18:10 <tflink> adamw: it looks like he has badge highlighted in irc :)
16:18:19 <adamw> tflink: well SURE, but that's just too dull.
16:18:45 <adamw> ah crud, i'm supposed to be playing tennis on wednesday morning.
16:18:51 <handsome_pirate> threebean:  So, we need a badge for running a blocker bugs meeting, a badge for taskotron, and a badge for smoking bowls
16:18:52 <adamw> hum, blocker meeting on thursday? :P
16:18:54 <handsome_pirate> Does that cover it?
16:19:09 <roshi> if you like, I can run it either way
16:19:09 <adamw> handsome_pirate: a badge for outsourcing to zodbot?
16:19:14 <handsome_pirate> heh
16:19:22 <adamw> #action roshi to run a blocker review meeting some time this week
16:19:40 <adamw> aaand we're way over time, so i guess i'll set the quantum fuse
16:20:17 <handsome_pirate> Explosions!
16:23:13 <adamw> QUANTUM explosions!
16:23:16 <adamw> thanks for coming, folks
16:23:19 <adamw> #endmeeting