board
LOGS
17:00:43 <mattdm> #startmeeting board (2014-06-23)
17:00:43 <zodbot> Meeting started Mon Jun 23 17:00:43 2014 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:47 <mattdm> #meetingname board
17:00:47 <zodbot> The meeting name has been set to 'board'
17:00:48 <jwb> hi
17:00:59 <mattdm> #topic welcomes and stuff
17:01:04 <mattdm> hi jwb!
17:01:07 <mattdm> #chair jwb
17:01:07 <zodbot> Current chairs: jwb mattdm
17:01:24 <mattdm> who else do we have around?
17:01:53 * inode0 is around
17:02:03 <mattdm> #chair inode0
17:02:03 <zodbot> Current chairs: inode0 jwb mattdm
17:02:14 * mattdm accumulates chairs
17:02:43 <number80> .hellomynameis hguemar
17:02:44 <zodbot> number80: hguemar 'Haïkel Guémar' <karlthered@gmail.com>
17:03:09 <mattdm> #chair hguemar
17:03:09 <zodbot> Current chairs: hguemar inode0 jwb mattdm
17:04:42 * cwickert is here
17:04:48 <mattdm> #chair cwickert
17:04:48 <zodbot> Current chairs: cwickert hguemar inode0 jwb mattdm
17:04:58 <mattdm> so, we have 5...
17:05:41 <mattdm> waiting for gholms mjg59 Sparks yn1v
17:05:46 <jwb> mjg59 just sent regrets
17:07:01 <mattdm> I guess wait another minute here. We barely have quorum....
17:07:22 <Sparks> Oh geez... it's 13:00!
17:07:24 * Sparks is here.
17:07:30 <mattdm> #chair Sparks
17:07:30 <zodbot> Current chairs: Sparks cwickert hguemar inode0 jwb mattdm
17:08:18 <mattdm> okay, let's go ahead. I think the first item at least is relatively uncontroversial....
17:08:29 <mattdm> #topic Approval of guidelines for third-party press releases
17:08:33 <mattdm> https://fedorahosted.org/board/ticket/3
17:08:36 * gholms appears
17:08:41 <mattdm> #chair gholms
17:08:41 <zodbot> Current chairs: Sparks cwickert gholms hguemar inode0 jwb mattdm
17:08:54 * inode0 does have one question regarding item 1
17:09:05 <mattdm> inode0 go!
17:09:56 <inode0> in bullet point 2 is "does not primarily promote proprietary software" supposed to exclude companies who primarily deal in proprietary software but make contributions to free software?
17:10:41 <mattdm> I don't read that as the intention.
17:11:07 <mattdm> (putting emphasis on "primarily")
17:11:26 * gholms read it the same was as inode0
17:11:29 <gholms> *way
17:11:34 <inode0> so as an example think about Oracle?!
17:12:06 <mattdm> I wish mjg59 was here since he drafted this....
17:12:17 <mattdm> do you have an alternate wording?
17:13:12 <inode0> just removing those words makes me +1
17:13:16 <jwb> i would read oracle as falling out of favor with item #2
17:13:33 <mattdm> inode0 the middle bullet entirely?
17:13:36 <inode0> although even then Oracle probably isn't broadly aligned with Fedora
17:13:43 <gholms> Replace "does not primarily promote proprietary software" with "promotes free software" and I'll be okay with that part.
17:13:46 <jwb> i'd actually recommend removing all the text in the parenthesis in all of them
17:13:57 <number80> +1 with gholms proposal
17:13:57 <gholms> I'm not entirely sure that...
17:14:01 <gholms> Yeah.  What jwb said.
17:14:14 <gholms> I'd actually be happy without the examples to begin with.
17:14:41 * inode0 still wants to know if bullet 2 excludes Oracle (as an example)
17:14:54 <Sparks> jwb: By removing what's in the parenthesis are we now defininging "broadly" to... ummm... broadly?
17:14:54 <inode0> even without the parenthetical bit
17:15:07 <cwickert> +1 to gholms' change
17:15:32 <jwb> Sparks, yes.  it's a judgement call for the board to make, not something that can be codified for every single scenario
17:15:47 <inode0> if it isn't meant to then I'm happy with gholms' suggestion too
17:16:10 <jwb> inode0, i don't think oracle is aligned with fedora at all
17:16:13 <Sparks> jwb: True, I just wonder if it's worth codifying then should we explain why it should be in there at all?  It might be good to know why.
17:16:32 <jwb> i just said it wasn't worth codifying :)
17:16:47 <cschalle> I would suggest considering dropping item 2 altogether, it is just to widely worded and seems more suited to generate eternal flamewars rather than achieve anything useful. And since any press release have to be approved by the board anyway I think one should assume we can trust the judgement of our own board?
17:17:20 <inode0> jwb: I don't either but I'm not sure I would want to make it so a company like Oracle couldn't do something with Fedora and have a press release about it.
17:17:23 <Sparks> jwb: And I'm saying that maybe some direction might be nice.
17:17:44 <jwb> Sparks, the board sets the direction...  which is us.
17:17:56 <jwb> inode0, then perhaps cschalle's suggestion is best
17:18:04 <Sparks> jwb: And yet we might not be the board later.
17:18:10 <mattdm> cschalle I think the point of giving guidance is so things which do come to the board are already in reasonable shape.
17:18:44 <mattdm> I think it does become too broad to be useful if we leave item 2 without _some_ qualifier or explanation
17:18:55 <Sparks> I'm not absolutely sure that this entire thing is enforcable anyway.
17:19:34 <number80> this is a guideline, not a rule
17:19:36 <gholms> It isn't, which is why it should look like easy-to-comply-with guidance.
17:19:39 <Southern_Gentlem> it all comes down to the last line board or FPL approval
17:19:51 <Southern_Gentlem> so that is all that really matters
17:20:10 <mattdm> +1 to gholms
17:20:54 <Sparks> Southern_Gentlem: true
17:21:14 <gholms> That right there is the biggest hurdle in the proposal, yes.
17:22:01 <inode0> I think the requirement to provide notice to the board will just be something no one outside of the board is ever aware of until after the fact.
17:22:36 <mattdm> inode0: we can make Red Hat PR aware of this, and they often get press releases before publication
17:22:42 <mattdm> so that will help some.
17:22:59 <inode0> But as general guidance I'm +1 but would like bullet 2 softened personally.
17:23:13 <mattdm> inode0 do you have a phrasing for a softened #2?
17:24:42 <inode0> some more like relates to an entity that is constructively engaged with the Fedora Project maybe?!
17:25:09 <inode0> along with gholm's earlier suggestion
17:26:27 <mattdm> okay, so, second draft https://fedorahosted.org/board/ticket/3#comment:3
17:27:20 <mattdm> changes being parentheticals are all dropped  and point 2 now reads "Relate to an entity that is constructively engaged with the Fedora Project and promotes Free Software"
17:27:26 <number80> +1
17:27:27 <cschalle> what is the goal of the bullet point? I mean to me it reads like for instance saying that if Valve wanted to donate some source code to Fedora, to improve OpenGL performance as an example, we should automatically say no because they mostly deal in closed sources games. Which I have trouble understanding what is meant to achieve (not that I think there are a lot of orgs just waiting to do press releases with us)
17:27:35 <jwb> it would be awesome if email notifications were being sent for this trac instance.
17:28:01 <mattdm> jwb they are supposed to be. i'll diagnose where they're getting stuck after the meeting
17:28:03 <jwb> cschalle, eh.  why would valve donate anything like that to _fedora_ alone?  seems to be an upstream submission
17:28:21 <mattdm> cschalle see reworded point
17:28:22 <cschalle> jwb, well I was struggling to come up with examples
17:28:26 <inode0> cschalle: that is more or less what the rewording fixes
17:28:29 <gholms> cschalle: See the new wording.
17:28:40 <number80> cschalle: my interpretation is that we are judging the entity in a context, if Valve is constructively working with us, it's ok
17:29:13 <inode0> +1 to the version in comment 3
17:29:16 <mattdm> So, we're at the 20 minute mark... let's vote on this new draft.
17:29:26 <gholms> Heh
17:29:30 <mattdm> I see number80 is already +1
17:29:32 <mattdm> +1 from me
17:29:39 <Sparks> +1
17:30:01 <cschalle> number80, ok fair enough, but the amount of people who would approach us saying 'hey, want to do a shared press release about the desctructive behaviour we been exhibiting' is probably very small :)
17:30:43 <jwb> cschalle, not exactly destructive, but this came from a press release where someone claimed to have done awesome things with fedora but in truth has done nothing at all
17:30:50 <gholms> cschalle: It's more there to deal with things that are unrelated than antithetical.
17:30:51 <cschalle> ah ok
17:30:52 <mattdm> cschalle these are not necessarily shared press releases.
17:31:02 <mattdm> more votes?
17:31:05 <gholms> +1
17:31:12 <jwb> +1
17:31:34 <gholms> inode0/number80?
17:31:42 <jwb> inode0 voted
17:31:43 <gholms> Oh, you're already +1.
17:32:10 <mattdm> #agreed Guidelines draft from https://fedorahosted.org/board/ticket/3#comment:3 approved (+6)
17:32:23 <mattdm> would someone like to volunteer to put these on the wiki somewhere?
17:32:39 <number80> +1
17:32:53 <mattdm> don't all speak at once :)
17:33:06 <number80> gholms: I don't mind voting twice :D
17:33:18 * mattdm only counted you once, sorry :)
17:33:23 <cwickert> +1
17:33:32 <cwickert> (for the record)
17:33:34 <mattdm> #undo
17:33:34 <zodbot> Removing item from minutes: AGREED by mattdm at 17:32:10 : Guidelines draft from https://fedorahosted.org/board/ticket/3#comment:3 approved (+6)
17:33:38 <mattdm> #agreed Guidelines draft from https://fedorahosted.org/board/ticket/3#comment:3 approved (+7)
17:33:58 * cwickert is still at work and a little busy, sorry if I am behind a bit
17:34:04 <mattdm> cwickert: np
17:34:14 <mattdm> okay I'll do it :)
17:34:20 <mattdm> #action mattdm to add guidelines to wiki somewhere
17:34:37 <mattdm> #topic Approval of criteria for new Fedora products
17:34:40 <mattdm> https://fedorahosted.org/board/ticket/4
17:34:48 * inode0 won't slow this one down
17:34:50 <inode0> +1
17:35:02 <mattdm> this is a continuation of a discussion from previous meeting. just want to get the votes counted to make it clear.
17:35:45 <number80> the "long-term investment" is enough to differentiate a spin from a product
17:35:53 <sgallagh> mattdm: Might I suggest "Addresses a new, relevant, and broad usecase or userbase that Fedora is not currently serving" be replaced with "Addresses a new, relevant, and broad usecase or userbase that a Fedora Product is not currently serving"
17:35:55 <cwickert> number80: I see
17:36:01 <rdieter> mind a quick comment on the proposed criteria?
17:36:22 <mattdm> rdieter: go
17:36:36 <number80> cwickert: to me, spins that have a strong and structured community behind (ie: KDE) could become products
17:36:43 <Sparks> I'm confused on what this is trying to fix, exactly
17:37:06 <cwickert> number80: I fully agree, the standards for products must be significantly higher than for spins
17:37:10 <mattdm> Sparks: I don't think it's trying to 'fix" anything.
17:37:34 <rdieter> I have a big problem with it as things shook out.  As it is, there's this "gold rush" to claim this space (userbase, target audience, yada yada)
17:37:48 <cwickert> Sparks: I think it answers a question that was raised by the KDE Plasma product, that's all
17:38:57 <number80> rdieter: as long as there are commitment, I don't mind about alternative vision
17:39:01 <Sparks> cwickert: Sorry for being behind on this topic.  What, exactly, is KDE Plasma and how does it want to be integrated?
17:39:36 <Sparks> cwickert: Just the new desktop?
17:39:37 <cwickert> Sparks: the KDE SIG has submitted a product, too, see https://fedoraproject.org/wiki/Fedora_Plasma_Product
17:39:40 <jwb> rdieter, that's fair.  at the same time, i'm not sure why we'd want multiple Product offerings that overlap significantly
17:39:41 <rdieter> Now, personally, I think the best way forward is consolidating (somehow) with Workstation WG.  However, as things stand, kde-sig has a single member on the group, and progress has been frustratingly slow.  If that can't happen, then, frankly there is no viable alternative than allowing an exception to an overlapping product proposal.
17:39:41 <number80> especially on the desktop, it will be hard to share a common vision within Fedora
17:39:59 <mattdm> rdieter: I think that concern comes from a view that the products are supposed to be holes for various existing technology to fit into. that wasn't the intention.
17:40:07 <rdieter> If neiter of those things happen, it's going to end badly
17:40:11 <Sparks> cwickert: Thanks for the link.
17:40:38 <mattdm> I don't think that all desktop technologies need to be used in a product to be relevant and important to fedora
17:41:25 <Sparks> rdieter: +1
17:41:26 <mattdm> I'd like to see ways that we can promote our different desktop techologies as interesting and important that isn't requiring them to get mixed in with the products idea
17:41:55 <Sparks> mattdm: Like we used to do with the multi-desktop boot ISOs?
17:42:55 <mattdm> Sparks: I was thinking bigger than that. I don't think KDE (or Xfce, or the other desktops with significant interest/effort) should be mixed into a big bundle of spins
17:43:04 <randomuser> !
17:43:20 <number80> randomuser: go ahead
17:43:44 <rdieter> mattdm: thanks, carry on (though that still doesn't address my "gold rush" complaint)
17:44:01 <randomuser> I'm reading up, so forgive me if the point has been addressed, but..
17:44:29 <randomuser> what if a group wants to compete for a user base/use case taken by an existing product?
17:44:52 <randomuser> if a space is claimed, and another group can do it better, the policy should allow for that
17:45:05 <jwb> randomuser, i'd expect the Board and FESCo to weigh each offering and pick the one they see as the best long term investment
17:45:06 <number80> randomuser: nobody will ever forbid you to do so
17:45:28 <Sparks> jwb: That's not a really good solution, though.
17:45:47 <inode0> randomuser: this criteria is for new products  --- we'll someday need a replacement product criteria I suppose too
17:45:56 <randomuser> I'd expect that too, jwb, but a defined process would be a good idea
17:46:18 <randomuser> if nothing else, it would save a lot of vitriol on mailing lists to just be able to point to "here, do this if you think you can do it better"
17:46:27 <number80> What about having "Sub-Community Products" ?
17:46:31 <jwb> randomuser, sure.  that isn't what this ticket is covering
17:46:38 <jwb> number80, what does that mean
17:47:03 <jwb> also... the phrasing sounds insulting.  maybe you meant community sub-products?
17:47:21 <number80> jwb: allowing SIG to manage products that fills requirements for products but not approved at the project level (and the name is poor, I agree)
17:47:30 <randomuser> jwb, if the criteria set re: this ticket is "must not overlap" then it is entirely relevant
17:47:41 <number80> like spins but with stricter requirements
17:47:52 <donniezazen> Plasma is a completely different user experience. Folks want personal experience and not standard experience. And that is what makes it significantly different.
17:47:58 <sgallagh> Ultimately, the question on the table is this: What is the criteria that the Board will use to decide whether or not to dedicate the resources of The Fedora Project (rel-eng, QA, docs, websites, etc.) on a new Product?
17:48:00 <jwb> number80, that actually sounds exactly like spins already
17:48:11 <gholms> number80: That's pretty much what a spin is today.
17:48:33 <jwb> sgallagh, no... that is not the question at all.  sorry.
17:48:44 <sgallagh> jwb: How is it not?
17:48:57 <jwb> because we can't dedicate anybody on anything
17:49:01 <number80> jwb, gholms: well, I envision it with more QA, more thoughworks than just assembling a bunch of packages and monkey testing
17:49:12 <sgallagh> jwb: Ok, poor choice of words.
17:49:21 <jwb> sgallagh, which is why it's not the questino
17:49:37 <sgallagh> But adding any new Product means that the technology in question will require resources to deliver at the same quality level as other Products.
17:49:54 <jwb> yes
17:50:00 <sgallagh> This is (at minimum) a draw on the capabilities of existing resources.
17:50:16 <sgallagh> Which is what I was trying to say above (but chose the wrong word "dedicate")
17:50:26 <jwb> number80, there are several existing spins that get much more than monkey testing.
17:50:47 <randomuser> sgallagh, i think you're suggesting the board should take responsibility for making sure relevant parties are able and willing to support a new product
17:51:03 <number80> jwb: these should be allowed to become products if there's a long-term commitment
17:51:04 <sgallagh> randomuser: Absolutely, I think that should be at least one part of the criteria
17:51:07 <mattdm> A while ago, I had suggested "secondary products" as a way of dealing with the "competing spaces" idea; these would work similiarly to secondary architectures (but could be built as spins rather than remixes, in fedora infrastructure) and then eventually evaluated as described based on practical success.
17:51:21 <sgallagh> randomuser: If the Board doesn't believe a Product can follow through, it shouldn't be a Product.
17:51:24 <jwb> number80, sure, maybe.  overall, i'd rather see all spins come up to those criteria than invent some kind of mid-level between product and spin
17:51:33 <randomuser> sgallagh, that too
17:51:57 <jwb> mattdm, sounds like a spin.
17:51:58 <Sparks> mattdm: I like that idea.  That would make it very easy to upgrade/downgrade products as maturity comes and goes.
17:52:00 <number80> jwb: if we raise the bar for spins, I could see it work for me
17:52:18 <jwb> come on.  why are we inventing something that is entirely unnecessary?
17:52:29 <jwb> is there some kind of perception that spins are crap and that's OK?
17:52:51 <jwb> because if that's the perception, then that is what needs fixing.  Products and Spins should be sufficient
17:52:56 <mattdm> jwb I think certainly there is perception that spins are crap.
17:53:01 <Sparks> jwb: There is a perception that spins aren't worthy
17:53:05 <number80> jwb: not "crap", some of them are just not "up-to-date" or unmaintained
17:53:16 <jwb> number80, that would be crap, and they should be removed
17:53:29 <jwb> Sparks, so fix the perception
17:53:55 <Sparks> jwb: Okay, so lets change the name to better reflect where they are in our ecosystem
17:53:58 <sgallagh> To be fair, there's a perception that Spins aren't worthy compared to Products.
17:54:01 <gholms> jwb: Replacing it can do that.
17:54:04 <jwb> the problem isn't a lack of "levels".  it's a lack of commitment and enforcement
17:54:09 <mattdm> jwb I think in order to do that, we'd basically end up cancelling all but the desktop spins
17:54:12 * nirik notes he asked all spins in f20 to actually check off that they were tested at each milestone... and to my amazement, they were for the most part.
17:54:22 <jwb> mattdm, sounds great.  clean slates are nice.
17:54:23 <sgallagh> And that's probably *fair*, in so far as Spins aren't going to be advertised and marketed like Products are.
17:54:35 <Sparks> nirik: +1
17:54:57 <jwb> nirik, exactly what i remember as well.
17:55:05 <langdon> shouldn't the concept of a "spin" be left to the working groups? like server, cloud, workstation may all want to decide independently what "variants" are available .. and what it means for that working group...
17:55:17 <nirik> it was better than previous releases where there were spins that had serious problems. Still not perfect, but better than nothing.
17:55:22 <sgallagh> langdon: No, Spins aren't tied to working groups at all
17:55:29 <jwb> langdon, no.  Spins are a very clearly defined thing already that are not under WG jurisdiction
17:55:34 <sgallagh> They're the responsibility of the assorted SIGs
17:55:34 <langdon> in < fedora.next :)
17:55:47 <jwb> nope, sorry.  that's why we use capital S here
17:55:49 <jwb> Spins.
17:56:06 * cwickert thinks sgallagh raised an important question
17:56:52 <sgallagh> Of course I did... which one again? :)
17:56:58 <gholms> Heh
17:57:12 <mattdm> Just noting that we're at the 20 minute mark here, and almost at the hour for the meeting overall.... this seems like a relatively constructive conversation... do we want to continue or take this to the mailing lists?
17:57:12 <jwb> somehow we've gone from approving criteria we all had seen for MONTHS and had no objections to, to talking about Spins which are a big tangent to the topic at hand.
17:57:38 <jwb> i'd rather get back on topic and take this Spins stuff to the list
17:57:38 <mattdm> (also, what jwb said about tangent.)
17:57:53 * inode0 notes he voted but would accept sgallagh's slight rewording
17:58:52 <mattdm> I would like to propose... basically as an axiom... that we can find some way to make the situation better for non-"product" fedora release objects, whatever we call them
17:58:54 * langdon also has more comments on spins, Spins, and variants.. but saving for tangent decision
17:59:23 <mattdm> And so, yeah, let's vote on the criteria as we have them proposed and see where they are.
17:59:26 <number80> +1 with mattdm
17:59:47 * cwickert would like to continue here for now
17:59:47 <number80> It pains me to see the hard work of SIG not being promoted as it should
17:59:50 <mattdm> I'm also +1 to as-is or with slight rewording
17:59:59 * mattdm scrolls back for rewording
18:00:26 * gholms is begrudgingly +1, preferably with sgallagh's tweaks
18:01:46 <gholms> I didn't just netsplit, did I?
18:01:48 <cwickert> can we please have the final wording before we vote? I lost track somehow
18:01:53 <jwb> gholms, no
18:01:53 <gholms> It suddenly got very quiet in here.
18:01:54 <mattdm> yes, let's do a vote on the tweaks
18:02:47 <mattdm> so, points are:
18:02:51 <mattdm> 1. Addresses a new, relevant, and broad usecase or userbase that a Fedora Product is not currently serving
18:02:59 <mattdm> 2. The usecase should be something the Board sees as being a long term investment
18:03:05 <mattdm> 3. The Product should be coherent with all of Fedora's foundations
18:03:26 <jwb> fine with me
18:03:29 <mattdm> and so far, we have +3 (inode0, gholms, mattdm)
18:04:25 <cwickert> +1
18:04:26 <mattdm> anyone else?
18:04:26 <number80> +1 (if we add the goal of improving the situation of non-products deliverables)
18:04:41 <mattdm> number80 that's definitely a goal. let's not muddy the vote :)
18:04:53 <number80> mattdm: so, it's a full +1 :)
18:04:59 <inode0> that goal isn't part of the criteria but I'm happy to agree with it :)
18:05:05 <cwickert> number80: I don't think this is a "dependency" to this. It's on us to improve the situation of the non-products
18:05:07 * gholms absolutely agrees with that goal
18:05:21 <mattdm> so, assuming jwb's "fine with me" is a +1, that's +6...
18:05:23 <number80> so we're good
18:05:25 <jwb> +1
18:05:59 <mattdm> any other votes?
18:06:09 * cwickert notes that he as a "Fedora.next and the fate of spins" session at FLOCK
18:06:20 <Sparks> I'm concerned with the wording of #1 so I'll be a 0
18:06:21 <cwickert> s/as/has
18:06:30 <sgallagh> cwickert: I'm looking forward to it :)
18:06:45 <Sparks> cwickert: I hope it will be a talk that is recorded
18:07:01 <mattdm> #agreed proposed criteria passed (with slight rewording) (+6 with one abstention)
18:07:57 <mattdm> okay, we are 57 minutes in... should we continue with the kde plasma proposal now?
18:08:03 <mattdm> 67 i mean
18:08:20 <cwickert> I think this is quick, let's do it
18:08:26 <mattdm> okay
18:08:28 <jwb> ...
18:08:32 <inode0> really
18:08:34 <jwb> i think that's optimistic
18:08:39 <mattdm> #topic Does KDE Plasma product proposal meet these guidelines?
18:09:00 * gholms has to leave now
18:09:02 <mattdm> and if it turns out to not be quick, we can table discussion and move to the lists and come back next meeting.
18:09:20 <cwickert> +1
18:09:27 <inode0> Did anyone look at the questions I asked this morning in #fedora-board?
18:09:37 * cwickert didnt, sorry
18:09:39 <jwb> no
18:09:45 <Sparks> inode0: Sorry, I've not peeked in there yet.
18:10:03 * mattdm looks now
18:10:09 <jwb> inode0, fair questions
18:11:07 <mattdm> inode0 could you summarize or repeat for the meeting log?
18:11:16 <inode0> Sure
18:11:35 <inode0> Does it seem wise to approve additional products before we have a well-oiled machine producing the existing product mix?
18:11:50 <inode0> If adding additional products now isn't a concern to people, what is our capacity for adding them? How many can we realistically support?
18:12:05 <inode0> Assuming it is a smallish finite number would filling them with reasonable suggestions on a first come first served basis make sense or would it be better to identify the targets first and build products around those after identifying them?
18:12:21 <mattdm> I can tell you the FESCo answer to the first: we definitely don't feel ready to add more before we've launched the three already approved.
18:12:36 <mattdm> Also note, though, that the Plasma proposal is targetting F22
18:12:41 <jwb> i think the question goes a bit beyond "launched" though
18:12:56 <mattdm> jwb fair
18:13:03 <jwb> i think inode0 is asking if we should wait and see how the full fallout goes from this.  not just "can we get f21 released"
18:13:15 <mattdm> inode0 I think your second question is a perfect one. I think the targets should come first
18:13:26 <inode0> Yes, I'd like to see that things are working well.
18:14:27 <mattdm> And, ultimately, that's my feeling about this proposal. It feels like it is technology first, and then looking for a target, with the goal of becoming a product because of the previously-discussed concern that spins don't get respect
18:14:34 <number80> I agree with inode0, getting F21 released and fedora.next on rails should be our top priority
18:14:39 <cwickert> please note that "how much we can support" also includes "how much marketing can we do? how many different products can one realistically promote?"
18:15:00 <mattdm> cwickert: +1,000,000,000
18:15:04 <cwickert> I am not sure if we can promote overlapping products
18:15:26 <jwb> as it stands right now, i'm worried about f21 marketing
18:15:33 <jwb> so adding more in...
18:16:16 <cwickert> ok, so how about we just delay the decision until after F21 release? this will also give the KDE SIG more time to come up with more technical details
18:16:28 <number80> +1 with cwickert
18:16:29 <Sparks> jwb: How about for F22 or are you saying that we'll never really be able to market more than 3?
18:16:30 <mattdm> So, in some ways, this is tending towards saying "we should defer this decision". But, I don't want to seem like we're saying "maybe" when we really mean "no"
18:16:51 <mattdm> oh look. fire alarm.
18:16:52 <jwb> Sparks, i'm saying it's too early to be thinking about f22 when we don't even know how we're going to market f21
18:16:55 <cwickert> mattdm: that is my biggest concern
18:17:04 <mattdm> um. be right back.
18:17:14 <Sparks> mattdm: You've got a laptop for a reason
18:17:16 <Sparks> :)
18:17:41 <cwickert> I don't want anybody to waste time and effort, but I really don't feel like approving this now
18:18:21 <cwickert> cwickert: question to rdieter: how is the plasma product different from the KDE spin? in the other products I see significant development that does not happen elsewhere in Fedora or upstream, or development glued together in a unique way. do you have plans for anything similar in the plasma product?
18:18:23 <Sparks> I like the idea of having a working Spin before promoting it as a Product, though.
18:18:45 <cwickert> Sparks: good idea actually
18:19:12 <Sparks> cwickert: I mean, at least that shows some dedication to having "long term" support.
18:19:35 <jwb> KDE has had a working spin for years
18:19:44 <jwb> and it has been a primary one
18:20:01 <cwickert> Sparks: spins come and go, that does not necessarily mean long term support ;)
18:20:02 <rdieter> cwickert: I guess the short answer is, not much.  The initial primary deliverable likely won't be too different that then existing spin
18:20:34 <cwickert> rdieter: thanks for the answer. so what would actually be different? cooperation with the WG? governance?
18:20:41 <Sparks> cwickert: Right, but I'm hoping that if a Spin stays current for a release or two...  I mean, nothing can forecast future involvement.
18:20:58 <Sparks> cwickert: At least we'd get to test drive it.
18:22:39 <rdieter> cwickert: governance has definitely changed already, having formed a formal Workgroup now.  Beyond that, good question.  I don't know, I'm not the primary driver, mostly a messenger.  I can ask the group and get back to you though
18:23:10 * mattdm is back
18:23:17 <mattdm> (from the parking lot)
18:23:29 <inode0> rdieter: so usecase/userbase is a convenient way to limit the product sprawl which I think ultimately needs to be limited. Do you have an alternate suggestion for prioritizing the adoption of products?
18:24:27 <cwickert> thanks rdieter. I know you guys are enthusiastic and I trust you to make it, but that does not mean I can approve this, at least not now. I think we first need to think of many more questions not related to your product
18:26:06 * mattdm is now walking back into the building, which presumably didn't burn down
18:28:18 * cwickert is about to leave, sorry. can we delay this topic? I see too many open questions to make a decision anyway, inode0 raised some important ones
18:28:36 <abadger1999> inode0: How many people are working on the new product.
18:28:38 <abadger1999> ?
18:28:41 <rdieter> inode0: no suggestion.  the guidelines are good, but urge you all to consider that guidlines also need exceptions.
18:29:14 <cwickert> abadger1999: 11 according to the website
18:29:53 <cwickert> https://fedoraproject.org/wiki/Fedora_Plasma_Product/Governance#Current_Members
18:30:25 <abadger1999> <nod> cwickert, inode0: I was saying that could be an alternative criteria to limit product sprawl.
18:30:35 * mattdm is back again
18:30:46 <inode0> rdieter: guidelines are just guidelines - open to exceptions and creative interpretations :)
18:31:05 <jwb> please defer to next week.  people are dropping now, and i have some other things i need to attend to today
18:31:18 <mattdm> okay, so, 90 minutes in. losing people
18:31:24 <mattdm> #info conversation continued later
18:31:44 <mattdm> do we want to hold another IRC meeting next week or should we do a phone call?
18:31:52 <number80> ok, I have another meeting waiting for me at #fedora-meeting-1 ...
18:32:21 <mattdm> maybe even that question needs to be deferred :)
18:32:50 <mattdm> okay, thanks everyone
18:32:52 <number80> mattdm: could we start a discussion on the private list for the phone call things ?
18:32:56 <mattdm> number80: yep
18:33:00 <number80> thanks all !
18:33:04 <mattdm> #endmeeting