fesco
LOGS
17:01:09 <dgilmore> #startmeeting FESCO (2014-04-30)
17:01:09 <zodbot> Meeting started Wed Apr 30 17:01:09 2014 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:17 <dgilmore> #meetingname fesco
17:01:17 <zodbot> The meeting name has been set to 'fesco'
17:01:17 <dgilmore> #chair abadger1999 dgilmore mattdm mitr notting nirik pjones t8m sgallagh mmaslano jwb
17:01:17 <zodbot> Current chairs: abadger1999 dgilmore jwb mattdm mitr mmaslano nirik notting pjones sgallagh t8m
17:01:20 <dgilmore> #topic init process
17:01:22 <mitr> Hello all
17:01:23 <nirik> .hellomynameis kevin
17:01:24 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
17:01:34 <pjones> hello.
17:02:04 <dgilmore> we have 4
17:02:31 <abadger1999> greetings
17:03:15 * abadger1999 notes he hasn't caught up with the his post-vacation  mail barge yet :-(
17:03:30 <dgilmore> mattdm and sgallagh said they would be late on list
17:03:49 <dgilmore> lets start things and go through followups
17:03:55 <dgilmore> #topic #1221 Product working group activity reports
17:03:55 <dgilmore> .fesco 1221
17:03:56 <zodbot> dgilmore: #1221 (Product working group activity reports) – FESCo - https://fedorahosted.org/fesco/ticket/1221
17:03:56 <dgilmore> https://fedorahosted.org/fesco/ticket/1221
17:04:31 <nirik> I think we we doing this bi-weekly, and its the off week. ;)
17:04:39 <dgilmore> jwb: pknirsch: sgallagh: mmaslano: anything you want to bring up?
17:04:48 <dgilmore> go figure i messed up
17:05:02 * nirik did the same thing. ;)
17:05:07 <notting> Sorry, likely won't be at meeting for another half hour or so
17:05:23 <dgilmore> #topic #1244 F21 System Wide Change: cron to systemd time units - https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units
17:05:27 <dgilmore> .fesco 1244
17:05:28 <dgilmore> https://fedorahosted.org/fesco/ticket/1244
17:05:29 <zodbot> dgilmore: #1244 (F21 System Wide Change: cron to systemd time units - https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units) – FESCo - https://fedorahosted.org/fesco/ticket/1244
17:05:54 <Viking-Ice> this needs to be postponed until matt show up ( I would think )
17:06:11 <nirik> if there's someone that wants to work on this, great, otherwise, I would say drop meeting tag and move on?
17:06:12 <dgilmore> okawy we can move on and come back to it
17:06:33 <Viking-Ice> nirik, that feature is not prepared for "Should"
17:06:43 <dgilmore> #topic #1250 F21 Self Contained Changes
17:06:43 <dgilmore> .fesco 1250
17:06:44 <Viking-Ice> additional changes will need to be done if that is the plan
17:06:45 <dgilmore> https://fedorahosted.org/fesco/ticket/1250
17:06:46 <zodbot> dgilmore: #1250 (F21 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1250
17:07:10 <dgilmore> there is not actually any self contained changes this week
17:07:17 <nirik> so, we were waiting on some more info from remote journal folks...
17:07:20 <nirik> did we get that?
17:07:29 <dgilmore> nirik: not that I have seen
17:07:33 <mitr> Nobody asked (other than in the meeting minutes), and nobody answered AFAICS
17:07:45 <nirik> failure on our part. ;(
17:07:55 <nirik> would someone be willing to bring up concerns/questions on the list?
17:09:12 <dgilmore> #action remote journal needs concerns/questions to be raised with the change owner
17:09:21 <dgilmore> anybody?
17:09:23 <nirik> I could bring up the part about default/recommended... not sure I'm good to bring up other issues.
17:10:01 <dgilmore> nirik: thats a start
17:10:13 * nirik will do so
17:10:42 <Viking-Ice> is there such a thing as default/recommended now with the output from the WG's as in dont they themselves define their own defaults?
17:11:03 <Viking-Ice> ( for their product )
17:11:41 <dgilmore> #action nirik to follow up with change owner about default/recommended
17:12:05 <dgilmore> lets move on
17:12:11 <abadger1999> Viking-Ice: I don't think we've formalized it but there should be both fedora defaults,recommended,required  and individual product defaults,recommended,required.
17:12:15 <dgilmore> #topic #1291 F21 System Wide Change: BerkeleyDB 6 - https://fedoraproject.org/wiki/Changes/BerkeleyDB_6
17:12:18 <nirik> Viking-Ice: I'm not sure I parse your question there. If we advertise a 'remote journal logging' change, some people will assume it means thats a recommended way to handle remote logs
17:12:19 <mitr> Viking-Ice: we'd ordinarily expect the recommendations to be aligned without a specific reason to the contrary (... but this might be one of those cases)
17:12:20 <dgilmore> .fesco 1291
17:12:20 <dgilmore> https://fedorahosted.org/fesco/ticket/1291
17:12:21 <zodbot> dgilmore: #1291 (F21 System Wide Change: BerkeleyDB 6 - https://fedoraproject.org/wiki/Changes/BerkeleyDB_6) – FESCo - https://fedorahosted.org/fesco/ticket/1291
17:13:38 <mitr> (silence...)
17:13:52 <dgilmore> so the plan is to have everything movce over to the new libdb
17:13:59 <mitr> dgilmore: no
17:14:01 <mitr> AFAICS our concerns have been resolved; so this is approved implicitly, or do we vote to confirm?
17:14:07 <nirik> well, I was ok with the plan.
17:14:15 <nirik> right, we just wanted to ack that and approve the change/
17:14:16 <nirik> ?
17:14:34 <dgilmore> mitr: from nottings update in teh ticket
17:14:37 <dgilmore> ... Well, in the current plan (make libdb5 "compat" package and updating the libdb to v6), after the mass rebuild the packages would start using v6.
17:14:37 <mitr> dgilmore: the plan is that a recompile would move everything, but there will be manual review to ensure license compatibility
17:14:54 <mitr> where "ensuring" happens by not moving to v6
17:15:14 <dgilmore> mitr: as long as the check happens i am okay with the change
17:15:17 <mitr> Proposal: BerkeleyDB 6 change is accepted (with the agreed plan to ensure every package is reviewed)
17:15:30 <pjones> mitr: +1
17:15:30 <abadger1999> If we're really worried about license violations, we probably want to do something like change all packages that BR: libdb-devel to BR: libdb5-devel and then do the update.
17:15:32 <dgilmore> mitr: +1
17:15:53 <mitr> abadger1999: doing a review and not doing the redundant commits is AFAICS equivalent
17:15:59 <nirik> +1
17:16:19 <mitr> ... and it's what we asked for last week, so now going back and asking for something else would be rather annoying
17:16:37 * mitr is +1 for the record
17:17:18 <abadger1999> mitr: I'm not sure what you're saying.  But I've been away for weeks so I am defintiely missing context.
17:17:48 <dgilmore> #accepted BerkeleyDB 6 change is accepted (with the agreed plan to ensure every package is reviewed) (+4,0,0)
17:18:04 <nirik> abadger1999: the plan is for change owners to look at all packages, check which can be updated to use 6, update those and update the rest to use the compat
17:18:22 <abadger1999> dgilmore: You need 5 +1's :-/
17:18:34 <dgilmore> #undo
17:18:34 <zodbot> Removing item from minutes: ACCEPTED by dgilmore at 17:17:48 : BerkeleyDB 6 change is accepted (with the agreed plan to ensure every package is reviewed) (+4,0,0)
17:18:35 <nirik> abadger1999: before they were saying "we will make the packages and it's up to maintainers to decide"
17:18:38 <dgilmore> abadger1999: okay
17:18:42 <abadger1999> nirik: k.  thaks
17:18:43 <abadger1999> +1
17:18:49 <dgilmore> #accepted BerkeleyDB 6 change is accepted (with the agreed plan to ensure every package is reviewed) (+5,0,0)
17:18:57 <nirik> abadger1999: but we didn't like that because someone could rebuild for some reason and get the new one without knowing. ;)
17:19:24 <abadger1999> <nod
17:19:37 <dgilmore> main issue is compliance with terms of the AGPL
17:19:53 <dgilmore> anyway
17:19:59 <dgilmore> #topic open floor
17:20:13 <dgilmore> anyone have anything to bring up?
17:20:13 <Viking-Ice> well we need to settle this timer unis
17:20:47 <dgilmore> Viking-Ice: mattdm wont be here for 40 minutes according to his email to the list
17:21:04 <nirik> we could punt and discuss it next week?
17:21:08 <Viking-Ice> then punt it to the next week
17:21:13 * nirik isnt sure what there is to discuss really tho
17:22:09 <Viking-Ice> nirik, boils down to you will need to introduce multiple new targets as well as additional packaging guidelines to accommodate for those "should" components
17:22:46 <dgilmore> Viking-Ice: what do you mean by new targets?
17:22:49 <Viking-Ice> which you do not have to with my proposal since they are limited to component that already ship systemd unit and or otherwise depend on systemd one way or another
17:22:57 <nirik> Viking-Ice: well, without anyone owning the change, not sure it's going to mean any change. ;(
17:24:31 <Viking-Ice> nirik, if fesco decides to overwrite FPC I continue with the feature, if not jaroslav will need to official retire the feet and a new cron to timer units will need to be submitted which outlines by those driving it how they plan on solving various issues
17:24:54 <nirik> sure.
17:24:54 <Viking-Ice> that come with accommodating the "should"
17:25:08 <Viking-Ice> you see this is not as simple as copy paste and move forward with should
17:25:31 <Viking-Ice> and I dont think people realize it
17:27:33 <Viking-Ice> in anycase matt must have somehow formed opinion how he plans on proceeding with that and solve those issue which he can comment in the ticket so punt til next week
17:27:41 <dgilmore> so we have two options here, table until next week, or wait 30 minutes until mattdm is back
17:28:08 * nirik is for next week, but either way
17:28:19 * dgilmore is for next week also
17:28:20 <Viking-Ice> I can make a comment for fesco to vote in the ticket to overwrite
17:28:24 <Viking-Ice> fpc
17:29:51 * abadger1999 would be -1 to that on general principle and in this specific case as well.
17:29:55 <dgilmore> #topic Next week's chair
17:29:55 * nirik also
17:29:59 <Viking-Ice> and once that is done that ticket can be closed since a) I will continue working on the feature or b) Jaroslav announce me retracting the feature and another someone else will submit a new cron to timer feature which outlines how they plan on solving that should
17:30:11 <abadger1999> Viking-Ice: From reading the FPC minutes, it looks like notting and they agreed on the present wording.
17:30:12 <nirik> I will not be here next week.
17:30:29 <abadger1999> If there's a case to be made for even further wording changes, then that case should be presented to them.
17:30:43 <Viking-Ice> abadger1999, already has been twice
17:30:51 <Viking-Ice> in both cases FPC change it to should
17:31:04 <Viking-Ice> where it is a must
17:31:06 <abadger1999> It looks like they did their best to work out a compromise which was acceptable to all present parties.
17:31:39 <abadger1999> If it needs to be a must, then someone who understands why a must is better than the present wording needs to make that case.
17:31:44 <dgilmore> does someone want to take next weeks meeting?
17:31:51 <Viking-Ice> I was not present I just knew what notting planed on presenting which in the end they changed
17:32:32 <Viking-Ice> abadger1999, that has been explain plenty of times already
17:32:38 <dgilmore> Viking-Ice: then clearly make the case for why it needs to be a must, without saying its the end of the world as the reason.
17:32:49 <Viking-Ice> dgilmore, see abover
17:33:09 <dgilmore> Viking-Ice: i have not seen you make a clear case for anything.
17:33:16 <dgilmore> Viking-Ice: just state the facts
17:33:40 <dgilmore> Viking-Ice: but we have moved on now, and we are looking for a chair for next week
17:34:02 <Viking-Ice> dgilmore, carry on
17:34:21 <mitr> Viking-Ice: You have vaguely referred to new systemd targets today, I can't remember such things being mentioned before _ever_, and they certainly are neither obvious nor were they presented to FPC as rationale AFAIK.
17:34:21 <dgilmore> pjones: abadger1999: mitr: does one of you want to?
17:34:55 <mitr> dgilmore: OK, I'll chair next week.
17:35:01 <dgilmore> mitr: thanks
17:35:05 <abadger1999> mitr: thanks.
17:35:14 <dgilmore> #action mitr to chair next week
17:35:52 <dgilmore> #topic Open Floor
17:36:10 <dgilmore> sorry i should have done the chair before open floor
17:36:22 <dgilmore> so ill double back and see if there is anything else to discuss
17:36:30 <dgilmore> if not I will finish the meeting
17:37:39 <dgilmore> #endmeeting