gitlab_rpm_packaging
LOGS
19:09:09 <axil42> #startmeeting
19:09:09 <zodbot> Meeting started Thu Apr  3 19:09:09 2014 UTC.  The chair is axil42. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:09:35 <axil42> #meetingname GitLab rpm packaging
19:09:35 <zodbot> The meeting name has been set to 'gitlab_rpm_packaging'
19:10:11 <axil42> #topic Welcome
19:10:26 <axil42> so who is present? :)
19:10:35 <jchristi> moi
19:10:55 <axil42> I don't know if the mail I sent to ML yesterday reached to everyone
19:11:08 <sytse_> me, GitLab CEO
19:11:14 <axil42> hi sytse_
19:11:18 <jchristi> i got it
19:11:25 <sytse_> sorry, GitLab.com CEO
19:11:28 <axil42> jchristi, cool
19:11:46 <axil42> ah we're just the three of us?
19:12:03 <sytse_> GitLab only has a BDFL
19:12:14 <jchristi> tremble, you're here right?
19:12:27 <tremble> jchristi: I'm lurking.
19:12:51 * willo is here
19:13:04 <willo> I'm more just watching from the sidelines
19:13:45 <willo> I also prob can't stay for whole meeting this week
19:13:58 <axil42> willo, that's ok
19:14:22 <jchristi> axil42, i'll be sure to pass on the info from this meeting to relevant red hatters (if they aren't already on the ML)
19:14:38 <axil42> jchristi, that would be great thanks
19:15:37 <axil42> #topic Documentation
19:15:41 <millerjl1701> here
19:15:49 <axil42> hi millerjl1701
19:15:58 <axil42> ok next topic documentation
19:18:14 <axil42> right now we have no clear picture who is part of this team
19:18:32 <axil42> I suggest we add it to a wiki page
19:18:57 <axil42> along with all other additional info, susch as ML, irc meetings, etc
19:19:28 <sytse_> good idea, where can we make the page?
19:21:00 <willo> this page is free - https://fedoraproject.org/wiki/Gitlab
19:21:26 <willo> or https://fedoraproject.org/wiki/Infrastructure/Gitlab maybe
19:21:33 * orc_fedo arrives late
19:22:03 <willo> Depends on how infrastructure specific it might be
19:22:24 <willo> Only thing is, you'll need a FAS account to edit it
19:22:25 <axil42> let's make it in the Fedora wiki for now
19:23:00 <axil42> willo, do you think that will be a blocker?
19:23:16 <jchristi> my interest is in packaging for RHEL, which is not directly tied to Infrastructure. I'd vote for /wiki/GiLab
19:23:53 <orc_fedo> I also prefer https://fedoraproject.org/wiki/Gitlab
19:24:02 <orc_fedo> it is more than infra to me
19:24:18 <axil42> ok I started a wiki page here https://fedoraproject.org/wiki/GitLab
19:24:27 <willo> no, just was thinking above where it should live
19:24:55 <willo> agreed.  infra page can then be infra teams details on how we're using gitlab.  sounds good
19:25:28 <orc_fedo> axil42: I intentionally turned on mailing list privacy as to subscribers and would suggest that people be listed only after expressing an interest in being listed
19:26:09 <axil42> #action axil42 compile list of things that need documentation, put in https://fedoraproject.org/wiki/GitLab
19:26:25 <axil42> hmm
19:28:05 <axil42> orc_fedo, that's ok but in order to get organized we need to know each other, no?
19:28:31 <orc_fedo> axil42: sure
19:29:09 <orc_fedo> simply suggesting that people self edit into the wiki comes to mind
19:29:27 <orc_fedo> that way people behind a team exploder can also be seen
19:30:53 <axil42> orc_fedo, that's what I had in mind, self editing the wiki
19:32:19 <axil42> ok I'll see to migrate any info from my user gitlab page to the new one and add info about these meetings and the list
19:33:05 <axil42> #topic Proven packagers
19:33:44 <axil42> so, are you all that interested in packaging gitlab, proven packagers?
19:33:53 <millerjl1701> no
19:33:54 <orc_fedo> I am not
19:34:17 <orc_fedo> certainly willing, and I do it in other contexts, but not so recignized by Fedora protocols
19:34:31 <axil42> orc_fedo, I see
19:34:38 <willo> nope as well.
19:34:50 <sytse_> I'll not be packaging, just helping changing GitLab to fit
19:35:04 * tremble is, but is rather rusty
19:35:18 <millerjl1701> no = not proven packager. i package items for my day job... but have never for FP
19:36:00 <orc_fedo> axil42: one thing that helped me a lot with doing many R modules was that packaging such was mechanical , and a tool was written to emit a well formed template by pingou ...
19:36:09 <orc_fedo> is there something similar for Ruby?
19:36:13 <axil42> yeap
19:36:20 <jchristi> i haven't done any for fedora, but i can and am interested in helping out for gitlab
19:36:30 <orc_fedo> noting that in the wiki would be very useful
19:36:33 <axil42> gem2rpm is a tool that generates specs for rubygems
19:36:36 <tremble> gem2rpm works reasonably well
19:36:47 <axil42> I will document everything yes
19:37:23 <axil42> I'll update my article about ruby packaging as well and send it to the list
19:37:35 <orc_fedo> axil42: is that package somewhere?  if not, bootstrapping that in comes to mind, perhaps in the F suite of rpm maintenance tools
19:37:59 <axil42> gem2rpm? yes it's in Fedora
19:38:42 <tremble> orc_fedo: rubygem-gem2rpm
19:38:49 <orc_fedo> tremble: ty
19:38:51 <axil42> tremble, thanks :)
19:40:38 <orc_fedo> axil42: so the process would be to start with what is on hand, and then package the next needed item exposed by testing, and get it into bugzilla review, right?
19:41:21 <axil42> #topic Packaging workflow
19:41:31 <axil42> orc_fedo, more or less yes that's it
19:42:04 <orc_fedo> ... one assumes: also announce the bug number to the ML, and another can perform the review, and so also we boostrap all into becoming authorised as a 'proven packager or reviewer?
19:44:23 <orc_fedo> are ruby gem packagings sensitive to 1.8 vs 1.9 or later ruby versions?
19:45:45 <axil42> well the process to be a proven packager is this https://fedoraproject.org/wiki/Join_the_package_collection_maintainers
19:47:09 <axil42> quite a lot to read
19:47:53 <orc_fedo> * nod *
19:48:40 <orc_fedo> it seems packaging also carries an ongoing duty to monitor and respond to issues:   maintained actively and bugs, especially security issues needs to be fixed in a timely manner
19:48:47 <orc_fedo> under: UNderstand your Responsibilities
19:49:28 <orc_fedo> is there a central place that gem security issues are collated?
19:50:07 <tremble> orc_fedo: Red Hat's security alert team's pretty good at catching them and open bugs.
19:51:18 <orc_fedo> well, more imporatntly there is no particular for only one person to have that maintenance load --- is there some sort of exploder we could get set up for several person s seeing such reports?
19:51:55 <tremble> orc_fedo: You can "watch" multiple packages
19:52:23 <orc_fedo> tremble: my bugzilla watches are already too big ;)
19:53:21 <tremble> orc_fedo: If you ask the fedora infrastructure team they may be able to setup something :)
19:53:42 <orc_fedo> or the 'co maintainer' aspect may help here
19:55:01 <orc_fedo> that how-to discusses Koji building -- is this partially obsoleted or out-moded by 'copr'?
19:56:07 <axil42> orc_fedo, yes the co-maintainer thing could be good
19:57:12 <orc_fedo> axil42: given your GSOC work, having you as one for most gems seems sensible
19:57:38 <axil42> I'm fine with that
19:57:45 <orc_fedo> as I understand it, a person with an @redhat login also has functional rights that permit them to 'reach in and commit fixes'
19:58:20 <axil42> I don't know about that
19:58:21 <tremble> orc_fedo: Not true.
19:58:22 <threebean> not true.
19:58:32 <threebean> you're thinking of the provenpackager FAS group
19:58:41 <orc_fedo> very possibly
19:58:56 <tremble> orc_fedo: *proven* packagers can do that, they're not all @redhat.com, and not all @redhat.com folks are provenpackagers.
19:59:10 <threebean> https://fedoraproject.org/wiki/Provenpackager_policy
19:59:32 <jchristi> axil42: only a couple minutes left, can we add some #todo's for before next meeting in two weeks?
19:59:36 <orc_fedo> tremble threebean Venn diagrams #FTW
19:59:57 <tremble> orc_fedo: It's just that a lot of the folks who tend to get very involved are from @redhat.com because getting involved is a part of their job.
20:00:24 <axil42> jchristi, sure
20:00:51 <jchristi> so for one, we have "populate https://fedoraproject.org/wiki/GitLab"
20:01:34 <orc_fedo> axil42: were you able to get a fresh run of needs from your script?
20:01:43 <orc_fedo> if not, do oyu need help on that?
20:02:07 <axil42> orc_fedo, yes just didn't push yet
20:02:26 <orc_fedo> that is an EASYFOX #todo ;)
20:02:32 <axil42> hehe
20:02:33 <orc_fedo> FIX*
20:02:43 <jchristi> i assume you mean "axil42 to update https://github.com/axilleas/gsoc/blob/master/rubygems_missing" ?
20:03:01 <axil42> that's it yes
20:03:39 <axil42> Also i think it would make more sense to pick a gem in Gemfile and work down the dependency chain
20:04:28 <axil42> bare in mind that some gems have build dependencies not in this list
20:04:57 <orc_fedo> well, the only way to find out is to set up the build environment and start testing
20:05:08 <orc_fedo> is there a ready to go 'copr' image?
20:06:51 <jchristi> a build environment would be good...
20:07:00 * willo was distracted by kids - reads back
20:07:12 <axil42> given that the majority of gems are arch independent, they build quick locally
20:07:42 <orc_fedo> axil42: do they need teh formality of a clean build chroot, or can one scratch build locally and then test in a chroot?
20:08:06 <axil42> at least my workflow is to build them locally with rpmbuild and then test in a chrooted environment with mock
20:08:19 <orc_fedo> axil42: * nod *
20:08:39 <orc_fedo> but you do not bother w the Koji wrapping layer?
20:08:54 <orc_fedo> mock is not that bad to set for an environment
20:09:05 <axil42> sure you can submit koji scratch builds
20:09:21 <willo> until it becomes an official package
20:10:39 <orc_fedo> willo: but an 'official package' build of a noarch will primarily only be failing if a BR is missing
20:10:48 <orc_fedo> wrong version, etc
20:11:48 <willo> yep, in my experience
20:11:52 <orc_fedo> for people popping into the channel, if you have a meeting scheduled, please let us know and we can relocate
20:12:17 * orc_fedo looks at axil42's agenda again
20:12:29 <axil42> seems we have a lot more to discuss, are you ok if we met next week as well?
20:12:34 <willo> nothing scheduled in calendar
20:12:54 <orc_fedo> #todo self-add to the wiki page if interested
20:13:18 <orc_fedo> axil42: could you get the base page up so others can add to it?
20:13:26 <axil42> orc_fedo, yes
20:13:37 <orc_fedo> #todo axil42 to get base wiki page up
20:14:35 <orc_fedo> as a challenge, let's take the new list, choose three at random, and see who can get more than 3 into bugzilla items by next week
20:14:49 <orc_fedo> announce into the ML and perhaps we can get reviews as well
20:14:54 <axil42> hehe
20:14:57 <orc_fedo> heh
20:15:24 <orc_fedo> well, ten people on the list, and 3 per will get all into bugzilla, from know holes in a month
20:15:54 <orc_fedo> did we find a proven packager or reviewer to add to an #info line
20:16:37 <axil42> i guess the proven packager is a wrong term from my part
20:16:54 <axil42> I meant packager with packaging privileges
20:17:22 <orc_fedo> reading teh backscroll,  tremble seemed to be the only one present
20:17:29 <axil42> #info Make sure to read https://fedoraproject.org/wiki/Packaging:Ruby
20:17:48 <orc_fedo> jchristi: have you any in your group?
20:18:41 <jchristi> orc_fedo: i dont think so
20:18:47 <orc_fedo> ah well
20:19:10 <orc_fedo> I can ask some folks I know to work w me to get vetted and will do so
20:19:17 <jchristi> orc_fedo: actually, i do have one, but he doesnt have time to commit for gitlab stuff
20:19:35 <jchristi> orc_fedo: will get back to you on that
20:19:47 <orc_fedo> jchristi: offlist - -could he mentor a review for me to bootstrap into me being able to take that duty later?
20:19:56 <orc_fedo> thank you
20:20:47 <orc_fedo> axil42: rubygem-gem2rpm-0.8.1-1.orc6.src.rpm build under C 6
20:20:53 <orc_fedo> is that late enough to be useful?
20:21:04 <axil42> hmm i don't know
20:21:25 <orc_fedo> rawhide seems to have: /mnt/nfs/var/ftp/pub/mirror/F20-s390x-Everything/source/SRPMS/r/rubygem-gem2rpm-0.9.2-2.fc20.src.rpm
20:21:54 <axil42> vondruch (Vit Ondruch) should know more since he's maintaining it
20:21:56 <orc_fedo> ahh needs later BR Provides forms witht eh RPM change
20:22:20 <willo> gotta bail out and get ready for work.  will catch up rest of meeting on mailling list
20:22:22 <orc_fedo> I prolly can work around that and get it to build on C6
20:22:28 <orc_fedo> willo: ty for coming by
20:22:39 <axil42> orc_fedo, there have been quite some changes to rubygem macros etc
20:22:45 <axil42> willb, bb thanks for joining
20:22:56 <axil42> willo,
20:23:22 <orc_fedo> axil42: I see there is a new macro: %gem
20:23:36 <axil42> yes that facilitates a lot
20:23:38 <orc_fedo> %gem_install actually
20:23:49 <orc_fedo> will this affect us?
20:24:11 <orc_fedo> can we package to the older style for F19 and 6 enterprise series?
20:24:14 <axil42> affect how, for EPEL you mean?
20:24:19 <orc_fedo> axil42: yes
20:24:32 <orc_fedo> those new macros are post F19
20:24:50 <axil42> they are ported to latest EPEL afaik
20:24:52 <orc_fedo> one assumes that RHEL 7 will match the F19 levels
20:25:03 <orc_fedo> hmmm
20:26:00 <axil42> orc_fedo, https://lists.fedoraproject.org/pipermail/ruby-sig/2013-December/001466.html
20:26:21 <axil42> I'm not to familiar with epel packaging
20:26:56 <axil42> I'll begin porting my packages for starters and learn in the process
20:27:06 <axil42> s/to/too
20:27:07 <orc_fedo> say Hi to troy for me ;)
20:27:15 <axil42> heh
20:28:02 <axil42> I think it was my first informal review on one of his packages before i become a packager :p
20:28:29 <orc_fedo> that solves one BR, but not all .. there is a needed one: ruby(release)
20:28:29 <axil42> should we wrap it up?
20:28:38 <orc_fedo> which is anotehr rpm form
20:28:42 <orc_fedo> axil42: fine w me
20:28:54 <axil42> orc_fedo, indeed
20:30:15 <orc_fedo> the changelog to that 0.9 seems to add Ruby 2.0 support
20:30:28 <orc_fedo> axil42: when done type: #endmeeting ...
20:30:33 <axil42> :)
20:31:03 <orc_fedo> alick: if you could ask Vít Ondruch <vondruch@redhat.com> if there is more we need to know
20:31:17 <orc_fedo> urk not alick but axil42
20:31:21 <orc_fedo> silly tab completion
20:31:56 <axil42> sure thing
20:33:03 <orc_fedo> is there a SCL ruby20 ?
20:33:12 <orc_fedo> for EL 6 environments
20:33:56 <orc_fedo> it appears a 'flag day' mass rebuild was needed on 450 Ruby packages
20:35:14 <axil42> orc_fedo, I'm not familiar with SCL I'm afraid
20:35:20 <orc_fedo> axil42: * nod *
20:35:37 <orc_fedo> it is just you and I -- please end the meeting and go get a Mythos
20:35:54 <axil42> haha
20:36:10 <axil42> ok thanks everyone :)
20:36:21 <axil42> #endmeeting