fesco
LOGS
18:01:02 <dgilmore> #startmeeting
18:01:02 <zodbot> Meeting started Wed Apr  2 18:01:02 2014 UTC.  The chair is dgilmore. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:05 <t8m> hi
18:01:10 <dgilmore> #meetingname fesco
18:01:10 <zodbot> The meeting name has been set to 'fesco'
18:01:27 <nirik> cool. morning all
18:01:32 <sgallagh> hello
18:01:44 <dgilmore> #chair nirik t8m mattdm pjones- sgallagh
18:01:45 <zodbot> Current chairs: dgilmore mattdm nirik pjones- sgallagh t8m
18:02:01 <pjones> hey, so it's that time again
18:02:01 <dgilmore> #chair mitr
18:02:01 <zodbot> Current chairs: dgilmore mattdm mitr nirik pjones- sgallagh t8m
18:02:08 <mattdm> hello!
18:02:16 <dgilmore> okay who am i pissing
18:02:19 <dgilmore> missing
18:02:26 * notting is here
18:02:29 <dgilmore> #chair pjones notting
18:02:29 <zodbot> Current chairs: dgilmore mattdm mitr nirik notting pjones pjones- sgallagh t8m
18:03:10 <dgilmore> sorry for the late agenda. newbie here
18:03:31 <mattdm> I was also late with the agenda the first time I ran the meeting :)
18:04:21 <sgallagh> I'm partly here
18:04:34 <mattdm> abadger1999
18:04:40 <mattdm> = toshio
18:04:43 <abadger1999> Greetings
18:05:05 <dgilmore> #chair abadger1999
18:05:05 <zodbot> Current chairs: abadger1999 dgilmore mattdm mitr nirik notting pjones pjones- sgallagh t8m
18:05:12 <dgilmore> waiting on my email to open
18:05:48 * crobinso is here re: merge reviews
18:05:57 <mitr> Hello
18:06:38 <dgilmore> #topic #1268 Mesa 10.1 rebase in F20
18:06:38 <dgilmore> .fesco 1268
18:06:39 <zodbot> dgilmore: #1268 (Mesa 10.1 rebase in F20) – FESCo - https://fedorahosted.org/fesco/ticket/1268
18:06:40 <dgilmore> https://fedorahosted.org/fesco/ticket/1268
18:06:48 <dgilmore> okay lets start with mesa
18:07:17 <nirik> there's enough votes in tickets to pass
18:07:25 * pjones is +1
18:07:34 <nirik> but do we also want to add a ongoing exception?
18:07:41 <dgilmore> im +1 also
18:07:42 <notting> nirik: i think so, yes.
18:07:47 * nirik is +1 to this and +1 to adding an exception ongoing
18:08:02 <dgilmore> am okay with an ongoing exception also
18:08:14 <mitr> I'm +1 assuming we add an ongoing exception; without that I'd be more hesitant (but still probably +1 on balance)
18:08:15 * pjones +1 to the ongoing exception as well
18:08:23 <abadger1999> +1 (was +1 in ticket too)
18:08:40 <mattdm> +1 / +1
18:08:44 <t8m> +1
18:09:14 <t8m> and +1 to the ongoing exception as well
18:09:55 <sgallagh> I was +1 in the ticket
18:10:17 <sgallagh> as far as ongoing, that's fine too
18:11:12 <abadger1999> ongoing... I guess I'm +1 but I'd rather we could relax the policy in general to account for things we classify here.... it's more fair to other maintainers.
18:11:23 <dgilmore> proposed Agreed 6+1 0-1 for approving update and ongoing exception
18:11:32 <nirik> abadger1999: we could entertain a proposal to do that seperately?
18:12:01 <abadger1999> nirik: <nod>.
18:12:13 <nirik> dgilmore: sounds good.
18:12:40 <sgallagh> sorry folks, something urgent came up. Please assume I'm not here.
18:13:25 <dgilmore> #Agreed 6+1 0-1 for approving update and ongoing exception
18:13:40 <mattdm> (is zodbot case-sensitive?)
18:13:50 <pjones> (let's find out)
18:13:52 <pjones> #undo
18:13:52 <zodbot> Removing item from minutes: AGREED by dgilmore at 18:13:25 : 6+1 0-1 for approving update and ongoing exception
18:13:53 <dgilmore> #topic #1244 F21 System Wide Change: cron to systemd time units -
18:13:53 <dgilmore> https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units
18:13:53 <dgilmore> .fesco 1244
18:13:55 <zodbot> dgilmore: #1244 (F21 System Wide Change: cron to systemd time units - https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units) – FESCo - https://fedorahosted.org/fesco/ticket/1244
18:14:02 <pjones> doh
18:14:04 <mattdm> pjones nice
18:14:07 <dgilmore> https://fedorahosted.org/fesco/ticket/1244
18:14:09 <pjones> dgilmore was too quick ;)
18:14:10 <dgilmore> opps
18:14:14 <dgilmore> #undoo
18:14:15 <dgilmore> #undo
18:14:15 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x137b1d90>
18:14:18 <dgilmore> #undo
18:14:18 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x1016d4d0>
18:14:18 <pjones> #Agreed 6+1 0-1 for approving update and ongoing exception
18:14:24 <pjones> alright, now do that again
18:14:34 <pjones> where that is #1244
18:14:40 <dgilmore> #topic #1244 F21 System Wide Change: cron to systemd time units - https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units
18:14:51 <dgilmore> .fesco 1244
18:14:51 <dgilmore> https://fedorahosted.org/fesco/ticket/1244
18:14:53 <zodbot> dgilmore: #1244 (F21 System Wide Change: cron to systemd time units - https://fedoraproject.org/wiki/Changes/cron-to-systemd-time-units) – FESCo - https://fedorahosted.org/fesco/ticket/1244
18:15:14 <mattdm> Viking-Ice suggests that it might help get through FPC faster if it came attached with FESCo recommendation
18:15:19 * abadger1999 uts on fpc hat.
18:15:29 <abadger1999> The policy all looks acceptable to me personally but it's lacking  a draft.
18:15:45 <abadger1999> If someone can write the draft today I can make sure it goes before fpc tomorrow.
18:16:08 <Viking-Ice> you mean around ""MUST NOT (without an [FPC|FESCo] exception)""
18:16:12 <abadger1999> After tomorrow, though, I'll be away until April 27th.  So I won't be able to spearhead any efforts until then.
18:16:41 <mattdm> abadger1999 would the draft be a change to an existing section?
18:17:05 <abadger1999> Viking-Ice: no -- that part of the draft is fine.  It's the systemd-timer-unit portion that needs to be written up.
18:17:18 <abadger1999> mattdm: an addition to an existing section.
18:17:22 <Viking-Ice> oh you mean the one that should not exist there
18:17:26 <Viking-Ice> by all means add it
18:17:52 <abadger1999> Should go here: https://fedoraproject.org/wiki/Packaging:Systemd#Activation
18:18:28 <mattdm> so, a new section "Timer activation"?
18:18:42 <abadger1999> mattdm: yep.
18:19:21 <dgilmore> someone want to write it?
18:19:54 <mattdm> Viking-Ice You said you were talking to the docs team -- maybe they could draft this as well if you aren't interested?
18:20:12 <mattdm> In any case, I think the _other_ part is the urgent one, and this part can easily wait
18:20:48 <mattdm> do we want to vote on recommending the MUST/MUST NOT (without exception) policy to FPC?
18:20:55 * abadger1999 notes again -- he can't promise it will get taken care of until after april 27th if it doesn't get written today.
18:21:06 <Viking-Ice> we also need to figure out what to do with anacron now since time unit have gained anacron support
18:21:16 <Viking-Ice> anacron like support I mean
18:21:20 <pjones> pfft, it's an anacronism.
18:21:25 * pjones ducks.
18:21:28 <mattdm> pjones ouch
18:21:38 <abadger1999> mattdm: we could... like I said in the fpc ticket, I didn't see anything controversial in that portion of the policy... but without an example of what to do... it's incomplete though.
18:21:57 <abadger1999> so I am not really sure that FPC would want to pass it without the rest of the update.
18:22:10 <mattdm> As I understand it, Viking-Ice intends to actually _do_ it, so that provides examples
18:22:18 <mattdm> and there are upstream docs
18:22:21 <dgilmore> abadger1999: I agree, seems we need to have it fully complete
18:22:23 <abadger1999> I guess FPC coud vote to confirm that that portion is fine.
18:22:26 <Viking-Ice> do what exactly
18:22:32 <Viking-Ice> I'm against adding timer unit sample
18:22:42 <Viking-Ice> I can add the other stuff sure
18:23:04 <abadger1999> but it wouldn't mkake it into the guidelines and we wouldn't want to tell people to do it until it was complete.
18:23:10 <Viking-Ice> it's hard to cleanup on the base/core
18:23:24 <Viking-Ice> without people start adding dependency on systemd which should not exist there
18:23:43 <Viking-Ice> I have yet to go through all the units again and prep them for containers
18:23:48 <mattdm> Viking-Ice Look at the dbus activation section. I think having something like that for timers in our packaging docs adds value.
18:24:07 <mattdm> but it doesn't block the feature -- it is a nice thing to have as part of the feature.
18:24:20 <Viking-Ice> timer units are very tailored
18:24:30 <Viking-Ice> to the daemon
18:24:58 <nirik> a sample file doesn't have to be generic, it just has to show an example from a real package right?
18:25:12 <dgilmore> seems like if we cant document it the problem is not well defined , and the solution needs to be reviewed and refined
18:25:33 <nirik> just use say the dnf one.
18:25:47 <Viking-Ice> I'll probably have to rewrite that one lol
18:25:47 <notting> sure. but if we're listing that services can be activated via hardware, dbus, or socket, then if we want people to package timer units, we need to at least mention the concept.
18:25:52 <dgilmore> notting: seems fair
18:26:12 <abadger1999> yeah.
18:26:13 <pjones> Viking-Ice: a fair point, but... I mean write one that's adequate, and it'll be useful as an example.
18:26:31 <notting> but it's not as if the hardware activation bits there are fully documented, so we don't need a fully commented example timer unit either
18:26:32 <Viking-Ice> notting, the thing is timer unit can also be triggered by hardware activation
18:26:45 <Viking-Ice> via the usual udev tag
18:26:51 <Viking-Ice> like all them I guess
18:26:56 <Viking-Ice> of them I mean
18:27:24 <pjones> right, but the example doesn't have to be comprehensive
18:27:30 <nirik> who don't we let FPC and interested parties work on guidelines, if they aren't done, we simply activate the contingency plan for the feature?
18:27:36 <pjones> it just needs to give people a general idea of the sort of change they're looking at
18:27:46 <pjones> nirik: +1
18:27:50 <Viking-Ice> nirik,  not migrate
18:27:57 <Viking-Ice> then I wont waste my time with it
18:28:05 <pjones> nirik: the only issue there is that right now "interested parties" is nobody between now and the 27th.
18:28:13 <notting> what's the preferred form of a fpc guideline change?
18:28:13 <dgilmore> nirik: +1
18:28:17 <Viking-Ice> I'm not going to be working hours migrating stuff only to have it reverted few months later
18:28:23 <Viking-Ice> because of missing agreement in fpg
18:28:27 <nirik> I'd try and draft it, but I am pretty overcommited on time right now.
18:28:31 <abadger1999> Reading the docs, it seems like the common case is going to be OnCalendar=.. so probably write and explain an example based on that.  then mention that timers that are only started by events also exist (OnActiveSec=, OnBootSec=, OnStartupSec=, OnUnitActiveSec=, OnUnitInactiveSec=)  and point to upstream docs for that.
18:29:21 <dgilmore> abadger1999: seems reasonable
18:29:40 <nirik> I don't see this change are particularly contentious... I'd expect the FPC to pass it if there's a draft, or with just minor changes.
18:29:40 <abadger1999> if we ever start recommending people specifically write event-activated timers as part of another guideline we'd probably want to write something more about them into the guideline but we can cross that bridgfe later.
18:29:56 <abadger1999> nirik: yep, that's my expectation.
18:30:12 <mattdm> okay, so -- enough conversation here and moving on?
18:30:16 <abadger1999> just need omeone to commit to making it happen.
18:31:08 <Viking-Ice> cherry pick on or all https://fedoraproject.org/wiki/User:Johannbg/Flock#Various_Timer_unit_samples
18:31:18 <notting> *shrug* i can write something, although i don't know that i'll be able to attend the fpc meeting
18:31:26 <Viking-Ice> but I would prefer you keep the traditional stuff out from there
18:31:27 <dgilmore> proposal agreed: FESCo reccomends that FPC work with change owner to come up with suitable guidelines and we move forward with them
18:31:43 <abadger1999> notting: that would be great.
18:31:43 <Viking-Ice> those resemble closely cron behaviour
18:32:12 <abadger1999> it gives us a chance to pass something tomorrow at least :-)
18:32:23 <mattdm> dgilmore +1
18:32:33 <nirik> +1 and thanks notting.
18:33:10 <notting> (+1, if not obvious)
18:33:22 <dgilmore> any more?
18:33:29 <abadger1999> +1
18:33:29 <dgilmore> we need 4 to pass right?
18:33:39 <abadger1999> 5 I believe.
18:33:48 <dgilmore> okay well im +1
18:33:56 * pjones +1
18:33:57 <dgilmore> so thats 5
18:33:58 <nirik> 5 yeah
18:34:06 <mattdm> (5 unless we change the quorum rules.whole different topic :) )
18:34:13 <Viking-Ice> notting, you should easily be able to copy/paste from my flock page
18:34:23 <dgilmore> #agreed: FESCo reccomends that FPC work with change owner to come up with suitable guidelines and we move forward with them (5+1 0-1)
18:34:39 <dgilmore> #topic #1250 F21 Self Contained Changes
18:34:39 <dgilmore> .fesco 1250
18:34:40 <dgilmore> https://fedorahosted.org/fesco/ticket/1250
18:34:40 <zodbot> dgilmore: #1250 (F21 Self Contained Changes) – FESCo - https://fedorahosted.org/fesco/ticket/1250
18:34:51 <abadger1999> Viking-Ice, notting: hmm... the things relative to boot vs traditional time triggers is probably something we need to be able to configure differently based on workstation vs server.
18:35:26 * abadger1999 is done with tangent.
18:35:42 <dgilmore> okay there is a bunch of self contained changed
18:35:42 <Viking-Ice> ?
18:35:43 <dgilmore> changes
18:35:44 <mitr> abadger1999: Nah, this cab be just a 1-1 feature conversion.  We don't _need_ to add features for the conversion to happen
18:35:54 <abadger1999> mitr: works for me
18:36:08 <mattdm> jreznik you around?
18:36:15 <dgilmore> do we want to go through the changes 1 by 1?
18:36:17 <Viking-Ice> abadger1999, time triggers should not exist be used
18:36:26 <Viking-Ice> for the most part
18:36:34 * nirik is +1 for the self contained list this week.
18:36:47 <abadger1999> I noted a question about scala but otherwise +1
18:36:52 <notting> i'm +1 for hte list. although that reminds me of something i wanted to raise on the mailing list.
18:36:54 <t8m> dgilmore, I don't think it's necessary, does anyone one to pinpoint any selfcontained change this week<
18:36:54 * notting goes to do so
18:37:06 * abadger1999 pinpoints scala.
18:37:06 <t8m> I'm +1 for all of them
18:37:09 * pjones is also +1 for all
18:37:19 <mattdm> +1 for the list
18:37:31 * dgilmore is +1 for the list
18:37:34 <mattdm> I agree with toshio's reservation, though
18:38:34 <mitr> abadger1999, willb: Are Scala programs actually packaged differently from Java programs?
18:38:39 <mattdm> would just add "develop/update packaging guidelines as needed" to the proposal.
18:39:07 <willb> mitr, the main issue is that Ivy is much more prevalent in Scala
18:39:12 <abadger1999> I don't know -- a quick google this morning didn't find any guidelines for using sbt in the Packaging: guidelines though.
18:39:32 <abadger1999> mattdm: +1  that would work for me.
18:39:36 <notting> willb: does the ivy change affect scala as well?
18:39:40 <notting> willb: (affect or help)
18:39:41 <willb> I'm working on getting better Fedora integration (standing on the shoulders of mizdebsk's work)
18:39:41 <mitr> willb: ... The real question is; do we need separate packaging guidelines for Scala applications?
18:40:01 <dgilmore> abadger1999: so we recomend that packaging guidelines be written for Scala?
18:40:08 <willb> mitr, I'd say yes (and have been sort of keeping track of best practices and gotchas), but it's still a little premature
18:40:22 <abadger1999> dgilmore: yeah
18:40:29 <willb> happy to come up with a draft based on the stuff I've written on the big data SIG page and my experiences
18:40:44 <willb> notting, yeah, the Ivy change was a big help
18:40:55 <abadger1999> willb: Traditionally I think we'd say, get something into the guidelines and then propose changes to those guidelines as you gain experience with what works.
18:41:06 <dgilmore> proposal #agreed self contained changes approved with addition to scala that they work to develop packaging guidelines
18:41:13 <willb> abadger1999, ack, I'll write something up
18:41:18 <abadger1999> willb: cool.  thanks.
18:41:18 <mattdm> dgilmore +1
18:41:21 <nirik> +1
18:42:14 <t8m> dgilmore, +1
18:42:17 <abadger1999> dgilmore: +1
18:42:28 * pjones +1
18:42:38 <mitr> dgilmore: +1
18:42:52 <dgilmore> #agreed self contained changes approved with addition to scala that they work to develop packaging guidelines (7+1 0-1)
18:43:23 <dgilmore> #topic #1270 F21 System Wide Change: Java 8 - https://fedoraproject.org/wiki/Changes/Java8
18:43:30 <mattdm> The OpenJDK 7 EOL issue kind of clinches this one for me
18:43:32 <dgilmore> .fesco 1270
18:43:34 <dgilmore> https://fedorahosted.org/fesco/ticket/1270
18:43:34 <zodbot> dgilmore: #1270 (F21 System Wide Change: Java 8 - https://fedoraproject.org/wiki/Changes/Java8) – FESCo - https://fedorahosted.org/fesco/ticket/1270
18:43:43 <dgilmore> +1 from me
18:43:48 <nirik> +1
18:43:52 <mattdm> dgilmore +1 from me too
18:43:55 <abadger1999> +1
18:43:58 <notting> +1
18:44:48 <t8m> +1
18:44:51 <mitr> +1, reemphasizing that an early build test would be very desirable (if the tales of 80% of builds breaking are true)
18:44:51 <pjones> +1
18:45:23 <dgilmore> #agreed Java 8 change accepted (8+1 0-1)
18:45:27 <omajid> mitr: afaik the java sig folks (especially mizdebski) are working on that
18:45:38 <mitr> omajid: great
18:45:54 <dgilmore> #topic #1271 F21 System Wide Change: PrivateDevices=yes and PrivateNetwork=yes For Long-Running Services - https://fedoraproject.org/wiki/Changes/PrivateDevicesAndPrivateNetwork
18:46:01 <dgilmore> .fesco 1271
18:46:02 <zodbot> dgilmore: #1271 (F21 System Wide Change: PrivateDevices=yes and PrivateNetwork=yes For Long-Running Services - https://fedoraproject.org/wiki/Changes/PrivateDevicesAndPrivateNetwork) – FESCo - https://fedorahosted.org/fesco/ticket/1271
18:46:02 <dgilmore> https://fedorahosted.org/fesco/ticket/1271
18:46:35 <mitr> Not a big fan of namespace games in general... but, well, another layer.
18:46:39 <mitr> +1
18:46:59 <mattdm> I also like the sideeffect of fewer spurious avcs
18:47:01 <mattdm> +1
18:47:12 <pjones> +1
18:47:14 <nirik> +1
18:47:16 <t8m> we'll see what breaks but +1 anyway
18:47:37 * nirik notes this would hopefully have a guidelines update as well.
18:47:39 <dgilmore> +1 im sure stuff will break
18:47:44 <mitr> t8m: The SELinux policy already has similar restrictions, so we shouldn't need rediscovering that
18:47:48 <abadger1999> t8m: I think I agree entirely with you :-)  +1
18:47:49 <notting> +1. is disconnecting the netlink and audit namespace truly required, or just merely a choice of what they decided to remove?
18:48:54 <abadger1999> I think the biggest issue will be if packagers use Privatenetwork for things that optionally can use the network.
18:49:16 <nirik> yeah, but then it can be reverted...
18:49:27 <abadger1999> Right.  so i'm still +1.
18:49:40 <dgilmore> #agreed PrivateDevices=yes and PrivateNetwork=yes For Long-Running Services Change accepted (8+1 0-1)
18:49:57 <abadger1999> dgilmore: and note notting's question to the ticket?
18:50:38 <dgilmore> #info notting has question to note: is disconnecting the netlink and audit namespace truly required, or just merely a choice of what they decided to remove?
18:50:42 <dgilmore> abadger1999: will do
18:50:46 <abadger1999> cool.
18:50:51 <dgilmore> #topic #1269 Closing all 'Merge Review' bugs
18:50:52 <dgilmore> .fesco 1269
18:50:53 <dgilmore> https://fedorahosted.org/fesco/ticket/1269
18:50:53 <zodbot> dgilmore: #1269 (Closing all 'Merge Review' bugs) – FESCo - https://fedorahosted.org/fesco/ticket/1269
18:51:00 <dgilmore> last ticket
18:51:03 <mattdm> Okay, so, I'm interested in helping sort this out constructively, but I'd like to beg for a few weeks break.
18:51:17 <dgilmore> I need to run in 5 minutes for about 10-15 to pick up my daughter
18:51:18 <mattdm> Because I really need to get the cloud wg features into shape
18:51:21 <pjones> +1 to letting mattdm do the work
18:51:27 <nirik> I'm torn on this... I'd hate to give up so close to the end, but there's likely some that are just old and no longer very interesting.
18:51:30 <abadger1999> pjones: +1
18:51:32 <dgilmore> +1 to letting mattdb do the work
18:51:34 <nirik> sure. ;)
18:51:41 <mattdm> there are about 120.
18:51:44 <drago01> mattdm is going to review all those packages? ;)
18:51:49 <mattdm> a few of those are no longer in the distribution :)
18:51:51 <crobinso> mattdm: I'm fine with delaying, but what does 'straighten this out' mean?
18:52:00 <crobinso> *sort this out :)
18:52:09 <mattdm> abadger1999 tells me that we should be able to find _reviewers_.
18:52:20 <abadger1999> mattdm: at least in the past, that was true.
18:52:29 <mattdm> What I'd like to do is a) work with the base design to figure out which of the packages are likely part of that
18:52:41 <mattdm> b) find out who the maintainers are (and how many of them work at red hat)
18:53:02 <abadger1999> reviewers got discouraged because package maintainers didn't respond.
18:53:13 <mattdm> c) talk to the managers of the packagers who _do_ work at rh and see if we can make time for them to respond
18:53:25 <nirik> I think we tried that in the past without much luck
18:53:33 <ajax> the two-phasedness of the merge reviews always bothered me
18:53:35 <pjones> abadger1999: that seems like the answer is "make sure one of the people looking at this has provenpackager+"
18:53:42 <pjones> and you know, just /fix/ it.
18:53:43 <ajax> like, we have provenpackagers, jfdi
18:53:44 <nirik> I think the provenpackager+reviewer teams has a better chance
18:53:46 <pjones> quit asking, start telling
18:53:50 <nirik> yeah
18:53:52 <crobinso> despite that I'd rather see them just be closed, I'll volunteer a few cycles for reviews. but honestly if it just stalls in 6 weeks I'm going to put up a stink :)
18:54:10 <dgilmore> seems like a vfad for a day could knock them all out
18:54:11 <mattdm> getting provenpackagers involved seems excellent too
18:54:17 <abadger1999> pjones: yeah, that was something I was getting at in the ticket.
18:54:29 <mattdm> But I would like to do a little more to identify which ones are high value
18:54:32 * nirik recalls sitting in a room at fudcon boston 2007 doing merge review after merge review. ;) We really got quite a lot of them done over time
18:54:32 <mattdm> and which ones are sox
18:54:54 <dgilmore> nirik: right
18:55:09 <abadger1999> tell provenpackagers to just fix things and make sure they know we'll support them if an unresponsive package maintainer suddenly wakes up and complains that the provenpackager did what we asked them to do.
18:55:20 <t8m> abadger1999, +1
18:55:22 <pjones> abadger1999: +1
18:55:27 <nirik> +1
18:55:32 <mattdm> +1
18:55:38 <drago01> mattdm: just to get complaints "omg why did you touch my package?" ... ?
18:55:52 <pjones> drago01: feel free to refer those complaints to fesco ;)
18:56:01 <drago01> ;)
18:56:02 <pjones> where we're all going to say "look, you had 7 years..."
18:56:17 <crobinso> drago01: if someone whines about that, they need a clue-sticking anyways
18:56:30 <pjones> crobinso: exactly.
18:56:34 <notting> +1
18:56:38 <pjones> and we'll be more than happy to give it to them
18:56:52 <crobinso> but we can just start every re-review with a comment: "this is a concerted effort to finish off the merge reviews: [link to these meeting minutes]" or similar
18:57:04 <pjones> also a good idea.
18:57:08 <mattdm> yeah
18:57:31 <abadger1999> +1
18:57:41 <mattdm> so does someone want to plan/schedule a FAD?
18:58:13 <dgilmore> proposal  #agreed tell provenpackagers to just fix things and make sure they know we'll support them if an unresponsive package maintainer suddenly wakes up and complains that the provenpackager did what we asked them to do. organise a vfad to get them done in a a day.
18:58:36 <mattdm> +1
18:58:39 <nirik> +1
18:58:49 <dgilmore> +1
18:58:49 <pjones> +1
18:58:50 <mattdm> and I can help organize that vfad but I am not going to for at least two weeks
18:58:54 <mitr> +1
18:58:54 <t8m> +1
18:58:57 <dgilmore> vfad can be organised by anyone
18:59:05 <mattdm> possibly three. there is a red hat summit in there somewhere.
18:59:14 <mattdm> dgilmore yes, but someone needs to _do_ it
18:59:35 <dgilmore> mattdm: right, we can ask for someone to step up, if no one doeas one of us will have to
18:59:58 <dgilmore> #agreed tell provenpackagers to just fix things and make sure they know we'll support them if an unresponsive package maintainer suddenly wakes up and complains that the provenpackager did what we asked them to do. organise a vfad to get them done in a a day. (6+1 0-1)
19:00:09 <dgilmore> #topic open floor
19:00:25 <dgilmore> first up who wants to chair next week?
19:00:39 <t8m> dgilmore, I can do
19:00:52 <yassinr> Hi
19:00:59 <dgilmore> #info t8m to chair next week
19:01:17 <t8m> #action  t8m to chair next week
19:01:27 * dgilmore needs to run and pick up daughter, back soon if not finished before. mattdm can you take over
19:01:29 <mattdm> yassinr Hi! Do you have an item for open floor?
19:01:35 * mattdm takes over
19:01:45 <abadger1999> dgilmore: thanks for chairing!
19:01:52 * dgilmore would like to look at changing meeting time with DST as daughter pick up time is in the  middle of meeting now
19:02:16 <abadger1999> dgilmore: is that one hour earlier or later?
19:02:21 <pjones> abadger1999: earlier :/
19:02:44 * mattdm would like to look at keeping the meetings to an hour :)
19:02:51 <pjones> mattdm: +1
19:02:58 <t8m> mattdm, +1 :)
19:03:18 <nirik> indeed.
19:03:25 <yassinr> Nn
19:03:25 <pjones> mattdm: hey look, another reason to stick to things on the agenda only
19:03:32 <abadger1999> mattdm: wait... people can talk about fedora business for less than an hour? ;-)
19:04:00 <nirik> abadger1999: lets talk about that? ;)
19:04:38 <mattdm> Occassionally it's valuable to hash things out in an irc meeting....
19:05:01 <abadger1999> So, meeting time would appear to be an open floor item.
19:05:11 <mattdm> abadger1999 oh yes.
19:05:17 <pjones> abadger1999: except I think the person who has the biggest concern has just /left/
19:05:26 <abadger1999> <nod>
19:05:31 <pjones> so maybe we want to make it item #1 for next week
19:05:39 <mitr> The easy thing to do is for someone to organize a whenisgood
19:05:43 <mattdm> pjones +1 let's do that
19:05:48 <abadger1999> or..
19:05:57 <abadger1999> does an hour earlier *not* work for anyone here?
19:06:04 <mitr> The analytical thing to do would be to look a few years back and see what we in practice end up doing over the timezone changes, and use that to define the future convenion...
19:06:10 <mattdm> it works for me but is much less convenient.
19:06:11 <pjones> I /prefer/ this time slot, but I can make an hour earlier work
19:06:17 <mattdm> jinx
19:06:43 <abadger1999> k.  then yeah, let's talk about it next week.
19:06:46 * nirik doesn't care, although I slightly prefer keeping it the same UTC just for simplicty
19:06:47 <t8m> same as pjone
19:06:49 <t8m> same as pjones
19:07:03 <mattdm> #info talk about rescheduling meeting at next week's meeting
19:07:18 <mattdm> (um, I guess I'll file a ticket so it makes the agenda)
19:07:28 <mattdm> any other open floor?
19:08:27 <mattdm> okay then.
19:08:29 <mattdm> #endmeeting