kde-sig
LOGS
15:07:18 <rdieter> #startmeeting kde-sig
15:07:18 <zodbot> Meeting started Tue Mar 11 15:07:18 2014 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:23 <rdieter> #meetingname kde-sig
15:07:23 <zodbot> The meeting name has been set to 'kde-sig'
15:07:28 <rdieter> #topic roll call
15:07:41 * ltinkl is here
15:07:44 <rdieter> hi, who's present today? (besides dvratil :)
15:08:20 <Kevin_Kofler> Present.
15:09:31 <rdieter> than: ping
15:09:45 <rdieter> anyone else we should be pinging?
15:10:01 <rdieter> #info rdieter dvratil ltinkl Kevin_Kofler present
15:10:04 <rdieter> #chair dvratil ltinkl Kevin_Kofler
15:10:04 <zodbot> Current chairs: Kevin_Kofler dvratil ltinkl rdieter
15:10:23 <rdieter> oh well... moving on.
15:10:25 <rdieter> #topic agenda
15:10:38 <rdieter> what to discuss today? ltinkl, anything good yet?
15:10:58 <ltinkl> rdieter: I was thinking of discussing the Plasma Product proposal but oh well... not many people around
15:11:41 <rdieter> can still do it
15:11:43 <Kevin_Kofler> The Product stuff is definitely something worth discussing.
15:12:01 <ltinkl> yup, ok
15:12:08 <mbriza> hey
15:12:09 <ltinkl> https://fedoraproject.org/wiki/Fedora_Plasma_Product
15:12:13 <rdieter> kde-4.12.80
15:12:19 <rdieter> #info mbriza present
15:12:21 <rdieter> #chair mbriza
15:12:21 <zodbot> Current chairs: Kevin_Kofler dvratil ltinkl mbriza rdieter
15:12:30 <jgrulich> I'm present as well
15:12:40 <ltinkl> #info jgrulich present
15:12:40 <rdieter> #chair jgrulich
15:12:40 <zodbot> Current chairs: Kevin_Kofler dvratil jgrulich ltinkl mbriza rdieter
15:12:49 <ltinkl> than: around?
15:12:54 <rdieter> alrighty, let's do it then
15:12:59 <rdieter> #topic https://fedoraproject.org/wiki/Fedora_Plasma_Product
15:13:13 <rdieter> ltinkl: can you give a brief intro/summary?
15:13:28 <ltinkl> so, the plan is to create a 4th product, named Fedora Plasma
15:13:32 <ltinkl> (in short)
15:13:43 <ltinkl> you can read the details at https://fedoraproject.org/wiki/Fedora_Plasma_Product
15:14:51 <ltinkl> #info tosky present
15:15:50 <rdieter> cat's out of the bag, ltinkl, could you post this to kde@lists.fpo for feedback now too?
15:15:56 <Kevin_Kofler> The wording for "Case 2: Student/Pupil/Teacher" looks like copy&paste from Workstation. ;-)
15:16:12 <rdieter> (or want to wait for some bit of polish first?)
15:16:14 <ltinkl> I'd like cast a vote whether the initial members of the Plasma product mentioned in the Membership approve such proposal
15:16:20 <ltinkl> together with the Governance
15:16:46 <ltinkl> rdieter, Kevin_Kofler: first the Product Mission Statement and Governance mostly
15:17:02 <ltinkl> then we can concentrate on polishing the PRD and the Tech Specs
15:17:55 <Kevin_Kofler> I think we should put the focus on different things for the students there, drop the "particular tool chain versions" and "games from commercial publishers" parts, focus on educational software (kdeedu) instead, and change "Multiple developer environments" to "Multiple activities" (Plasma activities are thought for that use case).
15:17:55 <rdieter> I'd like to reach out to get at least one WG member outside the usual kde-sig bunch of folks, if possible.
15:18:28 <rdieter> ltinkl: +1, ok good start. :)
15:19:01 <than> present
15:19:07 <rdieter> #info than present
15:19:08 <rdieter> yay
15:19:20 * pino|work lurking
15:19:25 <ltinkl> so, +1 from me
15:19:26 <rdieter> than: see /topic , dicussing product proposal
15:19:40 * rdieter reads governance bits
15:19:49 * ltinkl searching for the corresponding meetbot command
15:19:49 <Kevin_Kofler> Cases 3 and 4 (Developer and Content Creator) should probably also be adjusted to focus on what KDE is strong at (KDevelop resp. Krita).
15:19:51 <rdieter> +1 definitely to mission statement
15:20:15 <Kevin_Kofler> Too bad we can't officially advertise Kdenlive from RPM Fusion in Fedora documents.
15:20:24 <ltinkl> Kevin_Kofler: ... that is the PRD, out of scope for today, pls let's focus on the Mission and Governance for today
15:20:26 <Kevin_Kofler> That's also part of the Content Creator toolchain.
15:20:30 <rdieter> Kevin_Kofler: let's focus on mission statement, governance first, as ltinkl suggested
15:20:55 <danofsatx-work> Better late than never...
15:21:09 * danofsatx-work is catching up on backlog real quick like....
15:21:15 <rdieter> #info pino|work danofsatx-work present
15:21:44 <rdieter> ltinkl: I assume the folks listed in the governance section have all expressed interest to participate?
15:21:49 <ltinkl> dvratil, jgrulich, than, tosky: +/- 1 ?
15:21:50 <Kevin_Kofler> Meh… I think improving the PRD can't hurt (especially when it comes to removing copy&paste obvious to every one who follows the link from the main wiki page, and setting realistic expectations).
15:21:51 <ltinkl> rdieter: yes
15:22:02 <ltinkl> Kevin_Kofler: right, just not oday
15:22:02 <dvratil> +1 for mission statement
15:22:04 <ltinkl> today even
15:22:37 <tosky> +1 as well for the mission
15:22:45 <rdieter> ltinkl: whos the FESCO liason?  or to be decided?
15:22:48 <than> +1 from my side
15:22:55 <jgrulich> +1 too
15:22:55 <ltinkl> rdieter: to be decided, I was hoping for you :)
15:23:00 <rdieter> lulz
15:23:17 <mbriza> +1 mission
15:23:43 <ltinkl> Kevin_Kofler: your vote? :)
15:23:53 <rdieter> is 11 the typical size for other WG's too?
15:23:57 <mbriza> ad. governance - why exactly 11 seats?
15:24:11 <dvratil> because there's currently 11 of us?
15:24:16 <rdieter> mbriza: probably any odd number will do, as long as it's not too big
15:24:25 <ltinkl> yes, obviously, and it needs to be an odd number
15:24:37 <Kevin_Kofler> Mission Statement looks OK, I'm a bit concerned that the focus on kdeedu and scientific stuff (Cantor incl. Backends? Kile?) will lead to a bloated live image for other users though. :-(
15:24:58 <ltinkl> rdieter: yup, all the ppl listed expressed their interest
15:25:00 <Kevin_Kofler> But inside info is that FESCo wants something like that.
15:25:13 <mbriza> yeah, right but what if over time more people come up? or there isn't anybody to fill the gaps? the text seems like the count is given
15:25:25 <Kevin_Kofler> The "even in mobile space" part also makes me wonder, are we going to ship Qt Creator including some mobile SDKs?!
15:26:04 <sgallagh> Kevin_Kofler: Well, FESCo will want a clear market segment not obviously addressed by "Workstation"
15:26:05 <rdieter> Kevin_Kofler: it just gives an opportunity to say we
15:26:14 <sgallagh> Scientific and Educational is a good example (IMHO)
15:26:16 <rdieter> will consider additional support for it
15:26:18 * randomuser , lurking, idly notes that targeting a use case does not mandate including those packages on shipped media
15:34:00 <danofsatx-work> I'm just a user/tester, but genuinely interested ;)
15:34:16 <ltinkl> for the bot
15:34:22 <ltinkl> agreed Fedora Plasma Product mission statement
15:34:25 <ltinkl> #agreed Fedora Plasma Product mission statement
15:34:45 <ltinkl> alrighty, let's move on to the Governance
15:34:47 <Kevin_Kofler> IMHO, the WG should BE the SIG, getting accepted into the WG should also mean being part of the SIG and the other way round.
15:35:20 <ltinkl> Kevin_Kofler: imo, I don't agree on this, we should be an inclusive project
15:35:21 <Kevin_Kofler> And people who are not actually working on KDE in Fedora don't belong into the WG.
15:36:02 <ltinkl> Kevin_Kofler: "working on KDE" <-- here's the flaw
15:36:10 <sgallagh> Kevin_Kofler: Well "working on" != interested in the success of
15:36:27 <sgallagh> Kevin_Kofler: One doesn't need to be a KDE developer to promote KDE at a conference, for example.
15:36:30 <Kevin_Kofler> It is inclusive, you get accepted into the WG, you're officially part of the SIG. And everyone can join the SIG as an interested user (not an active/voting member) as now (see e.g. danofsatx-work).
15:36:34 <sgallagh> Would you consider them not part of the SIG?
15:36:47 <Kevin_Kofler> It's just formalizing the existing informal SIG governance.
15:36:50 <ltinkl> first, KDE is a project/community, second, people e.g. working on the GCompris port to Qt/KDE, how would you define them?
15:37:36 <ltinkl> #topic https://fedoraproject.org/wiki/Fedora_Plasma_Product/Governance
15:38:10 * rdieter re-iterates +1 support for Governance doc
15:38:11 <Kevin_Kofler> (slightly OT) GCompris is being ported to Qt/KDE? That'd be another piece of the puzzle for our student/teacher use case (targeting the youngest age range).
15:38:17 <mbriza> +1 governance
15:38:20 <ltinkl> Kevin_Kofler: yes
15:38:32 <ltinkl> +1 for governance
15:38:51 <dvratil> +1 for gov
15:39:00 <jgrulich> +1
15:39:14 <than> +1
15:39:32 <ltinkl> pino|work, tosky: ?
15:39:34 <tosky> +1 for governance
15:39:39 <pino|work> +1
15:39:55 <ltinkl> that was wuick, thanks you :)
15:39:57 <ltinkl> q
15:40:09 <ltinkl> #agreed Fedora Plasma Governance
15:40:15 <Kevin_Kofler> +1 for governance (including Current Members as on the wiki now)
15:41:23 <ltinkl> so, next point, do we want to discuss the PRD now, or let it settle for a bit; I'll send the Mission Statement and Governance docs to the ML for a wider discussion
15:41:56 * ltinkl expects a bit more work and lots of discussions around the PRD
15:42:02 <rdieter> should we formally nominate/vote the fesco liason, or just ask for a volunteer?  (I'll do it, if no one else wants to)
15:42:20 <mjg59> Not directly relevant, but before spending too much time on this it would probably be helpful to have a wider discussion about how a wider range of products fits into Fedora's goals
15:42:50 <mjg59> Adopting additional products involves us figuring out various QA and marketing goals
15:42:59 <Kevin_Kofler> rdieter: Well, simple, let's ask around: Who wants to be the FESCo liaison? If we have only you as a candidate, you're automatically elected. :-)
15:43:16 <ltinkl> mjg59: QA stays roughly the same as now with the KDE spin
15:43:47 <mjg59> ltinkl: Sure, roughly. Let's make sure that there's explicit acceptanc eof that.
15:43:54 <rdieter> good questions, harder answers
15:43:57 * Kevin_Kofler has had enough of FESCo, will happily pass on that opportunity. ;-)
15:44:36 <ltinkl> mjg59: marketing is obvious, http://www.datamation.com/open-source/why-do-users-choose-kde.html
15:44:48 <Kevin_Kofler> mjg59: FESCo explicitly deferred the decision on whether they want more products to when a product proposal is actually submitted.
15:44:49 <ltinkl> mjg59: KDE is the single most popular desktop environment, what else do you need? :)
15:45:04 <Kevin_Kofler> So if we wait for them to decide on whether they want more products first, we're in a deadlock.
15:45:06 <ltinkl> mjg59: and has been for the last few years
15:45:26 <mjg59> ltinkl: How does it fit into the Fedora brand? Does Plasma get equal billing to Workstation? If so, how do we explain that to naive users?
15:45:37 <Kevin_Kofler> mjg59: That they have a choice.
15:45:43 <Kevin_Kofler> We're not Apple.
15:45:43 <ltinkl> mjg59: naive users? cmon
15:46:08 <Kevin_Kofler> And if you want only 1 desktop, drop Workstation/GNOME. ;-)
15:46:19 <ltinkl> mjg59: how do you explain (Developer) Workstation to naive users?
15:46:27 <danofsatx-work> mjg59: as a voting member of the QA group, I can say that fedora.next is causing a major shakeup in our workflow. The Fedora Plasma product will do nothing more than add a parallel column to workstation, just as it does now for desktop.
15:46:48 <ltinkl> naive users won't even get what a Developer or Workstation is
15:46:53 <mjg59> If a user goes to fedoraproject.org and sees a choice between workstation, server and cloud then it's easy to explain which one they want. If there are two separate desktop products then that's significantly less straightforward.
15:47:17 <ltinkl> my girlfriend uses KDE every day, our whole family including kids is, and they are puzzled by the words Workstation
15:47:19 <mjg59> I'm not saying this is a blocker. I'm saying that this is a conversation that's going to have to happen
15:47:25 <ltinkl> what else do you need to explain? :)
15:47:30 <Kevin_Kofler> Also, for native users, all those containers, SCLs etc. that Workstation is going after are just perfect recipes to make a HUGE mess out of their system.
15:47:37 <Kevin_Kofler> *naive users
15:47:55 <Kevin_Kofler> (Why was I writing "native"? Oops…)
15:48:03 <danofsatx-work> heh
15:48:07 <mjg59> And it would be better to have that conversation before spending too much time on the assumption that it'll all just work out
15:48:48 <Kevin_Kofler> mjg59: The majority of FESCo decided to not have that discussion before a Product is submitted.
15:48:55 <mjg59> Kevin_Kofler: Marketing != FESCo
15:49:03 <mjg59> There are multiple stakeholders that have to be convinced
15:49:08 <ltinkl> mjg59: so marketing > fesco?
15:49:18 <mjg59> ltinkl: If marketing say no, fesco are unlikely to say yes
15:49:20 <Kevin_Kofler> The decision is a FESCo one.
15:49:34 <Kevin_Kofler> WTF, are we now ruled by the marketers?
15:49:36 <rdieter> mjg59 raises a fair point, we'll definitely have some bridges to cross
15:49:39 <mjg59> If fesco say yes, marketing are still under no obligation to put Plasma on the website
15:49:45 <ltinkl> you seem to indicate that fesco has to approve what marketing says, not vice versa
15:49:48 <Kevin_Kofler> Sales-driven development is the worst ever.
15:49:54 <mjg59> No, marketing isn't sufficient
15:50:07 <mjg59> Every group that has extra work to do has to agree to do that extra work
15:50:14 <mjg59> That's how volunteer-run organisations work
15:50:17 <sgallagh> For the record, I would think that any new Product would need Board approval before FESCo approval
15:50:21 <ltinkl> mjg59: we're fine with doing the extra work
15:50:34 <sgallagh> But that's my own opinion (not an official FESCo statement)
15:50:43 <Kevin_Kofler> mjg59: Then why was ARM forced on us all, despite package maintainers NOT having accepted the extra work and waiting?
15:50:54 <Kevin_Kofler> That principle is a joke.
15:50:59 <mjg59> Individual packagers are free to ignore ARM
15:51:08 <Kevin_Kofler> Hahaha…
15:51:23 <Kevin_Kofler> ARM build failures are fatal, we also have to wait for the builds to complete on ARM.
15:51:41 <mjg59> Hey, if it causes you problems then take it up with fesco again. But that's really not the point I'm making here.
15:51:45 <Kevin_Kofler> The only way to opt out is ExcludeArch, which requires a bug filed and put on a tracker by policy, so extra bureaucracy.
15:51:53 <ltinkl> sgallagh: can you find a link to where Board approved the Workstation Product for example?
15:51:57 <mjg59> You have to sell your product to the rest of the Fedora community
15:52:08 <sgallagh> ltinkl: Yes
15:52:12 <mjg59> If you don't figure out how you're going to do that, the chances of it being accepted are low
15:52:13 <rdieter> ltinkl: the board did (with my hat on, I remember voting)
15:52:24 <ltinkl> rdieter: ok, was just wondering
15:52:40 <sgallagh> https://fedorahosted.org/board/ticket/176
15:52:53 <Kevin_Kofler> mjg59: My point was that Fedora ALREADY forces groups to do extra work.
15:52:54 <mjg59> And so it makes sense for you to do that *before* you spend too much time writing PRDs and governanc edocuments
15:52:54 <jwb> sgallagh, private ticket.
15:52:56 <sgallagh> Ah, that's private
15:52:57 <sgallagh> Sorry
15:53:16 <mjg59> But, obviously, you're under no obligation to do that
15:53:41 <jwb> ltinkl, i also sent an email on behalf of the board to advisory-board saying we approved them.
15:54:37 <ltinkl> ok, I was suggesting to continue working on the PRD on the background and meanwhile spreading the idea around
15:54:46 <Kevin_Kofler> mjg59: And let me +1 what ltinkl said, KDE Plasma Desktop is the most popular desktop environment out there, and has a sizeable "market" share even inside Fedora.
15:55:28 <rdieter> Kevin_Kofler: mjg59 didn't mention anything about popularity
15:55:29 <Kevin_Kofler> We will lose ~⅓ of our existing user base if we stop supporting KDE Plasma, and ½-⅔ of the potential new users out there.
15:55:41 <mjg59> Kevin_Kofler: The situation at the moment is that KDE will be available to users who want KDE
15:55:55 <Kevin_Kofler> rdieter: He asked for a selling point for the Product, that's the selling point.
15:56:03 <ltinkl> mjg59: even more hidden than it is at the moment
15:56:11 <ltinkl> mjg59: with no marketing at all
15:56:16 <Kevin_Kofler> mjg59: KDE users do NOT want to install from a GNOME image and add KDE after the fact.
15:56:28 <Kevin_Kofler> If they get only offered a GNOME image, they perceive the distro as a GNOME distro and will look elsewhere.
15:56:34 <mjg59> Kevin_Kofler: Cool. That's an argument for a product. Come up with numbers that support that.
15:56:48 <mjg59> But *I'm* not the person you have to convince
15:56:49 * rdieter thinks mjg59 made a valid point, but arguing over it here/now isn't exactly productive use of our meeting time
15:56:56 <ltinkl> ye that too, why would KDE users install Gnome Shell? only to remove it? but that'đ forbidden by the Workstation Tech Specs
15:57:11 <ltinkl> so technically impossible to do
15:58:02 <Kevin_Kofler> mjg59: Some current numbers: http://www.linuxquestions.org/questions/2013-linuxquestions-org-members-choice-awards-109/desktop-environment-of-the-year-4175488210/
15:58:19 <mjg59> Kevin_Kofler: Again, I'm not the person you have to convince
15:58:22 <rdieter> ltinkl, Kevin_Kofler : so the points each of you have raised, will be good additions to any marketting/justification docs we create (sooner or later)
15:58:26 <Kevin_Kofler> It's not ½, but more than ⅓ and almost 4 times the user base of GNOME Shell.
15:59:00 <ltinkl> rdieter: yup
15:59:09 <Kevin_Kofler> For Fedora, we had some download stats for live images in the past, but I'm not sure we have current ones.
15:59:16 * mjg59 gives up
15:59:17 <rdieter> so I suppose it's good their documented for posterity in the meeting log now. yay
15:59:41 <Kevin_Kofler> We'd also need to add the counts from spins.fp.o (alias kde.fp.o) and HTTP mirrors to get a realistic number.
15:59:51 <rdieter> eek, s/their/they're/
16:00:26 <Kevin_Kofler> mjg59: You said we need numbers, I looked them up.
16:00:40 * rdieter hides from grammar police
16:00:42 <Kevin_Kofler> We can add that linuxquestions.org link to our documents in thewiki.
16:00:53 <Kevin_Kofler> *the wiki
16:01:00 <mjg59> I said you'd need numbers demonstrating that people will refuse to use a GNOME desktop to install KDE
16:01:02 <pino|work> <rdieter> eek, s/their/they're/ ← :D
16:01:06 <ltinkl> I'd probably stop the meeting right here, we're running out of time :)
16:01:07 <mjg59> But I also said that I'm not the person who needs to see them
16:01:25 <mmaslano> Env and Stacks WG people please move to #fedora-meeting-2
16:02:13 <rdieter> ltinkl: <nod>, let's wrap up.
16:02:18 <Kevin_Kofler> mmaslano: Uhm, in principle we should be done now…
16:02:28 <rdieter> #topic open discussion
16:02:39 <rdieter> any final thoughts before we close the meeting?  last chance.
16:02:46 <mmaslano> Kevin_Kofler: sure, but I saw last two sentecnes, and it usually goes for hours ;-)
16:03:06 <ltinkl> #endmeeting