env-and-stacks
LOGS
16:05:47 <mmaslano> #startmeeting Env and Stacks  (2014-01-28)
16:05:47 <zodbot> Meeting started Tue Jan 28 16:05:47 2014 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:05:52 <mmaslano> #meetingname env-and-stacks
16:05:52 <zodbot> The meeting name has been set to 'env-and-stacks'
16:05:59 <mmaslano> #chair abadger1999 pkovar tjanez samkottler bkabrda handsome_pirate hhorak juhp
16:05:59 <zodbot> Current chairs: abadger1999 bkabrda handsome_pirate hhorak juhp mmaslano pkovar samkottler tjanez
16:06:08 * samkottler is here
16:06:17 <tjanez> Hey!
16:06:59 <hhorak> Hi guys!
16:07:14 <drieden> Hello!
16:07:45 <mmaslano> and with sochotni we are at least five
16:07:48 <mmaslano> so let's start
16:08:04 <mmaslano> #topic modify PRD
16:08:26 <mmaslano> #info commetns from ticket https://fedorahosted.org/fesco/ticket/1224
16:08:44 <tjanez> I'm glad notting and sgallagh took time to read the PRD and gave their "outside" view on it
16:09:05 <mmaslano> yeah, good to have a review
16:09:28 <tjanez> I suggest we amend Vision & Mission statement first
16:09:35 <mmaslano> okay
16:10:49 <sochotni> generally Stephen gave us a good starting point I'd say
16:11:28 <abadger1999> hola
16:11:41 <sochotni> i.e. "Fedora is the preferred ecosystem of choice for new software development to occur in any language and on any framework."
16:11:46 <tjanez> sochotni, +1
16:11:49 <sochotni> abadger1999: morning :-)
16:11:55 <mmaslano> abadger1999: hi
16:12:07 <drieden> sochotni +1
16:12:11 <drieden> abadger1999 Hello
16:12:11 <mmaslano> +1
16:12:17 <hhorak> +1 I like it
16:12:18 <tjanez> I would like to also include the words stack and environment
16:12:25 <tjanez> Something like: Fedora is the preferred ecosystem of choice for new software development to occur in any language/stack and in any framework/environment.
16:12:48 <tjanez> Just don't have an elegant way to put it in.
16:13:13 <sochotni> well the problem with that is that I think stack/env can be confusing and I believe vision should be as simple as possible
16:13:30 <sochotni> yeah, maybe a rephrasing somehow would work
16:13:48 <tjanez> Ok, how about: Fedora is the preferred ecosystem of choice for new software development to occur in any language and in any environment."
16:13:56 <hhorak> tjanez: I'd stay with as simple version as possible, even if there is not env&stacks used
16:14:22 <sochotni> hhorak: indeed, that can be mentioned in the mission statement
16:16:18 <drieden> hhorak +1
16:16:30 <mmaslano> hhorak: +1
16:16:56 <mmaslano> abadger1999: do you have any comment about improved Vision?
16:17:04 <sochotni> also I'd sneak in "deployment" somewhere :-)
16:17:08 <mmaslano> samkottler: ^
16:17:26 <tjanez> Another thought about the environment/framework part, should we limit ourselves to open (FOSS) environments/frameworks?
16:17:27 <mmaslano> sochotni: so Vision is still work in progress
16:17:54 <samkottler> +1
16:18:03 <sochotni> mmaslano: I am working on some ideas
16:18:49 <tjanez> sochotni, +1 about deployment
16:19:05 <tjanez> samkottler, +1 to what?
16:19:07 <abadger1999> +0 about deployment.
16:19:37 <sochotni> "Fedora is the preferred platform for new software development and deployment of new technologies regardless of their implementation language or dependency requirements."
16:19:38 <sochotni> ?
16:19:56 <samkottler> tjanez: deployment
16:20:41 <abadger1999> I personally think we have much further to travel to make fedora a good platform for deployment (I feel that lifespan until EOL is a huge factor, for instance) but if someone wants to work on that I don't object.
16:21:10 <sochotni> abadger1999: doesn't necessarily mean production deployment (the way I thought about it)
16:21:26 <abadger1999> tjanez: Re: FOSS... I think atm fedora is probably FOSS-only (judging by recent board decision).  Could change i nthe future.
16:21:33 <abadger1999> sochotni: k
16:22:12 <tjanez> abadger1999, yea, I followed the board discussions, so I guess FOSS is implied :-)
16:22:40 <hhorak> sochotni: I'm not so sure if people can imagine something concrete under "dependency requirements", I wouldn't probably. What about "..implementation language or application stacks"?
16:24:57 <tjanez> sochotni, I would simplify your proposal to: "Fedora is the preferred platform for new software development and its deployment in any language and/or application stack."
16:25:50 <sochotni> I am not sure "application stack" is understandable enough to most people but I might be wrong
16:26:14 <sochotni> I know it took some time to just define what *we* actually mean by that
16:27:31 <tjanez> sochotni, how about "software stack"?
16:27:52 <hhorak> tjanez: I like that and would simplify even "and/or" to just "or"
16:27:54 <sochotni> IMO though all of this doesn't belong on the meeting like this...
16:28:14 <sochotni> email is much better for these kinds of modifications/drafts
16:28:23 <sochotni> or any other non-realtime thing
16:28:42 <mmaslano> so we don't have any proposal :)
16:28:42 <sochotni> usually people need to consider/come up with alternatives
16:29:18 <mmaslano> let's speak about Vision on maling list
16:29:30 <sochotni> mmaslano: that was just a suggestion :-)
16:29:41 <mmaslano> what about Mission? Is sgallagh's version acceptable?
16:30:26 <tjanez> I would modify sgallagh's version to include the word testing: "The Fedora Environment and Stacks Working Group will research and develop new or improved methods of packaging, testing and deploying software for the Fedora community."
16:30:34 <hhorak> mmaslano: It is for me, but I'd extend "packaging and deploying" to "development, packaging and deploying"
16:30:57 <sochotni> so "developing, testing, packaging and deploying" then :-)
16:30:58 <mmaslano> hhorak: fine by me
16:31:24 <tjanez> hhorak, +1 on developing
16:31:59 <abadger1999> hhorak: +1
16:32:14 <abadger1999> +1 to both additions
16:33:18 <drieden> +1 to the both additions too.
16:34:20 <hhorak> +1 for the whole statement
16:34:31 <tjanez> #proposal "The Fedora Environment and Stacks Working Group will research and develop new or improved methods of developing, testing, packaging and deploying software for the Fedora community."
16:34:57 <mmaslano> +1 for the record
16:35:00 <tjanez> +1
16:35:22 <pkovar> +1
16:35:28 <drieden> +1
16:35:52 <abadger1999> +1
16:36:12 <hhorak> +1 ;)
16:37:39 <tjanez> samkottler, will you vote on the proposal?
16:37:50 <samkottler> +1
16:37:55 <samkottler> sorry, on a call at the same time :)
16:38:58 <mmaslano> :(
16:39:15 <tjanez> mmaslano, ?
16:39:35 <mmaslano> #agreed New vision: "The Fedora Environment and Stacks Working Group will research and develop new or improved methods of developing, testing, packaging and deploying software for the Fedora community." (+7,-0,0)
16:39:43 <mmaslano> tjanez: I'm sad for samkottler
16:39:55 * samkottler sad about being on the call, too :-(
16:40:04 <tjanez> mmaslano, ok :-)
16:40:28 <mmaslano> next comment was about too specific bug in koji
16:42:30 <tjanez> mmaslano, yes, we have some pretty specific examples in the PRD
16:43:15 <tjanez> I suggest we move them into separate wiki pages when we start creating more specific task descriptions / action items
16:43:31 <mmaslano> tjanez: +1
16:43:52 <tjanez> I guess, we needed them (the specific examples) so we understood each other when drafting the PRD
16:44:01 <mmaslano> yeah
16:44:09 * tjanez will need to leave in a minute
16:44:09 <mmaslano> so if we move to devassistant...
16:44:11 <abadger1999> tjanez: +1
16:44:20 <mmaslano> #action bkabrda will write more about devassistant
16:45:41 <samkottler> I'm not opposed to directly talking about devassistant, but what about adding more info about development tooling in general?
16:45:50 <samkottler> slightly OT, but something I've been thinking about recently
16:46:18 <mmaslano> samkottler: could be good, do you have other tools on your mind?
16:46:30 <mmaslano> samkottler: I was looking at Eclipse for some time, but they are doing great
16:46:33 <tjanez> bye guys
16:46:37 <mmaslano> bye
16:46:41 <samkottler> tjanez: cya!
16:46:47 * tjanez will read the minutes later
16:46:54 <abadger1999> bye tjanez
16:47:03 <drieden> bye tjanez
16:47:12 <hhorak> tjanez: bye
16:47:20 <samkottler> mmaslano: I don't have anything directly about specific tools, more just saying that there are lots of tools people already use
16:47:28 <samkottler> and we should help make them better at a high level
16:47:38 <samkottler> (git, vim, gdb, etc)
16:48:54 <mmaslano> sure, but we "own" devassistant upstream, but what about those other tools. Do you sugest analysis of those tools and filling bugs?
16:49:49 <samkottler> I'm just suggesting that we mention the other tools since they are already adopted
16:50:41 <mmaslano> samkottler: could you add them?
16:50:52 <samkottler> yep, doing it right now
16:51:33 <mmaslano> thanks
16:51:50 <samkottler> what do people think about something like 'The Fedora Environment and Stacks Working Group will work with the maintainers of existing tools to ensure they remain relevant to the changing application development landscape'?
16:52:09 <samkottler> existing tools should also include examples like I listed above
16:53:18 <mmaslano> samkottler: I'm not willing to promise something, what I can't do
16:53:26 <mmaslano> what others think?
16:53:42 <mmaslano> it seems to me it's huge project
16:53:50 <samkottler> mmaslano: s/ensure/help them/
16:54:36 * abadger1999 agrees with mmaslano's sentiment
16:55:23 <samkottler> I do too, but I think it's important that we mention tools other than devassistant
16:55:39 <hhorak> mmaslano: I have the same feeling, I can't imagine we'll enough time for that. What we could do is to try tell users about new things, that are not used so much (I have systemtap probes on my mind now for instance)
16:56:21 <drieden> The "work with maintainers of existing tools to ensure" seems to huge.  I would change the "work with" to "coordinate" and also the "ensure" to something which implies more of an oversight and not a commitment.
16:56:32 <mmaslano> samkottler: we mentioned devassistant because it's setting up environment. Otherwise it wouldn't fit
16:58:18 <samkottler> okay, that's fine
16:58:28 <samkottler> we can move on :)
16:59:30 <mmaslano> so it's probably everything to PRD if I didn't miss anything
17:00:51 <mmaslano> #topic jdulaney aka handsome_pirate inactive
17:01:16 <mmaslano> did someone see him? I sent him email before Christmas, but no reply
17:02:22 <samkottler> I've seen him on IRC, but has he ever been to one of our meetings?
17:02:59 <mmaslano> only on first few
17:03:00 <drieden> samkottler I recall him at some of the meetings last year.
17:03:17 <mmaslano> anyway he's not very active, so I'd rather give the vote to someone else
17:03:18 <pkovar> have not seen him. i do remember him saying he would be working on wiki pages. do we still need help with them?
17:03:29 <mmaslano> pkovar: no, I created them ;-)
17:03:34 <samkottler> mmaslano: +1
17:03:36 <pkovar> ah, thank you :-)
17:03:41 <mmaslano> pkovar: I needed space for PRD
17:03:46 <pkovar> right
17:03:51 <mmaslano> pkovar: you can fix czenglish ;-)
17:04:01 <pkovar> will have a look at them
17:04:14 <mmaslano> so I proposed drieden as program manager or sochotni as representative of Java SIG
17:05:13 <mmaslano> any opinions from the WG? :)
17:05:25 <drieden> mmaslano I am very honored to be nominated.
17:05:27 <samkottler> should we maybe have drieden and sochotni write up a little statement about what they want to work on?
17:05:38 <samkottler> or explain to us here even
17:05:38 <mmaslano> samkottler: smart :)
17:05:51 <samkottler> mmaslano: hehe I try :P
17:05:54 <mmaslano> drieden: sochotni: do you have time to do it shortly now?
17:06:02 <sochotni> phew :-)
17:06:11 <samkottler> if it's too much pressure now then maybe we can have the convo on the list?
17:06:44 <drieden> Sure.  My focus is on the project management aspects of the group.
17:06:45 <sochotni> I'd just point to my original email from november mostly I guess
17:07:29 <abadger1999> sochotni I've been honored to work with via the FPC/java guideline discussions.  drieden I've only known from this group but seems to be a good candidate as well.
17:08:06 <drieden> abadger1999 thanks
17:08:45 <drieden> Also, if I'm not chosen, that's okay.  I don't do development work anymore, so if you are looking for someone who is still technical, I would not be helpful.
17:08:53 <mmaslano> sochotni: so please point to it :)
17:09:01 <sochotni> mmaslano: yeah, was looking...
17:09:07 <sochotni> https://lists.fedoraproject.org/pipermail/env-and-stacks/2013-November/000066.html
17:09:18 * abadger1999 actually thought drieden was already a member as listed here: https://fedoraproject.org/wiki/User:Toshio/Env_and_Stacks_Governance#Current_Members
17:09:21 <sochotni> but there was something else
17:09:29 <sochotni> indeed :-)
17:09:48 <sochotni> but who am I to argue with Marcela :-D
17:09:53 <hhorak> sochotni: did you seek for https://fedoraproject.org/wiki/Fedora.next/WG_Nominations ?
17:10:18 <sochotni> hhorak: I had a longer email somewhere..
17:11:03 <sochotni> ah I remember...it didn't go to mailing list because there was none at the time
17:11:46 <mmaslano> Last time I tried to picked from every group someone. So I'd prefer this time Debi, as someone good in planning schedules, doable plans etc.
17:11:56 <sochotni> but generally...I prefer to be in the background doing stuff and my meeting skills are sketchy :-)
17:11:59 <mmaslano> but I'm hoping sochotni will still do the automatization he mentioned ;-)
17:12:04 <sochotni> yeah
17:12:05 <mmaslano> great ;-)
17:12:13 <mmaslano> #info drieden is new voting member
17:12:25 <mmaslano> #action mmaslano will change wiki page accordingly
17:13:07 <drieden> Thank you
17:13:07 <sochotni> I'll have pingou here in a week and hopefully we'll get some work done on review tooling
17:13:30 <sochotni> drieden: use your powers for good :-)
17:13:43 <mmaslano> #proposal Open Floor
17:13:48 <hhorak> I guess both drieden and sochotni have already proofed us they care about env & stacks ;)
17:13:57 <samkottler> drieden: welcome :D
17:14:17 <drieden> sochotni I will do my best :)
17:14:25 <sochotni> time for me to get stuff to eat :-)
17:14:35 <drieden> samkottler Thank you.
17:14:53 <hhorak> So, who from this group could I meet on Fosdem this week?
17:15:13 <pkovar> here here
17:15:24 * samkottler will be there
17:15:32 <samkottler> mmaslano: you gonna be at fosdem?
17:15:36 <mmaslano> no
17:15:42 <samkottler> mmaslano: :C
17:15:46 <mmaslano> bkabrda will be there
17:15:49 <samkottler> I'll be at devconf, too
17:15:51 <sochotni> and hhorak as well
17:15:51 <hhorak> pkovar: great, the bus will be one big party.. :-D
17:16:42 <pkovar> hhorak: i think so :-)
17:16:50 <sochotni> samkottler: there will be a lot of people @ devconf it seems
17:17:10 <samkottler> sochotni: indeed
17:17:15 * samkottler is excited for czech beer
17:17:21 <sochotni> samkottler: :-)
17:17:51 <pingou> sochotni: I see my agenda is filling up :)
17:17:53 <sochotni> samkottler: flying in on Thursday?
17:18:06 <sochotni> pingou: yup :-P
17:18:07 <pingou> hhorak: I'll be at fosdem as well
17:18:34 <samkottler> sochotni: yep, I'm flying from brussels to prague and then taking the bus
17:18:39 <hhorak> pingou: samkottler: great, I hope we'll meet in person. pingou, will you be on devconf as well?
17:18:47 <pingou> hhorak: yes
17:19:00 <hhorak> pingou: great ;)
17:19:00 <pingou> samkottler: which day?
17:19:07 <samkottler> pingou: the 6th
17:19:22 <samkottler> pingou: psh, but we've already met
17:19:23 <mmaslano> I'll close the meeting and you can continue ;-)
17:19:30 <hhorak> mmaslano: sure ;)
17:19:34 * mmaslano envy Brusel
17:19:36 <pingou> samkottler: same day Ralph and I arrive
17:19:41 <mmaslano> #endmeeting