env-and-stacks
LOGS
13:03:19 <tjanez> #startmeeting Env and Stacks  (2014-01-21)
13:03:19 <zodbot> Meeting started Tue Jan 21 13:03:19 2014 UTC.  The chair is tjanez. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:03:25 <hhorak1> Hi guys!
13:03:31 <juhp_> evening
13:03:35 <tjanez> #meetingname env-and-stacks
13:03:35 <zodbot> The meeting name has been set to 'env-and-stacks'
13:03:43 <tjanez> #chair abadger1999 pkovar tjanez samkottler bkabrda handsome_pirate hhorak juhp
13:03:43 <zodbot> Current chairs: abadger1999 bkabrda handsome_pirate hhorak juhp pkovar samkottler tjanez
13:03:54 <samkottler> .hellomynameis skottler
13:03:56 <zodbot> samkottler: skottler 'Sam Kottler' <skottler@redhat.com>
13:04:07 <tjanez> hi guys
13:04:31 <juhp_> .hellomynameis petersen
13:04:33 <zodbot> juhp_: petersen 'Jens Petersen' <petersen@redhat.com>
13:04:46 <juhp_> hi!
13:05:00 <bkabrda> hey
13:05:29 <tjanez> #topic init process
13:05:56 * tjanez is chairing for the first time, so please have some patience
13:06:17 <juhp_> thanks for stepping up :)
13:06:30 <tjanez> juhp_, no problem
13:06:35 <hhorak> tjanez: you're doing it very well ;)
13:07:26 <tjanez> #topic PRD follow-up
13:07:58 <tjanez> So, do you have any comments about our PRD, which has been sent to review to FESCO?
13:09:18 <juhp_> look forward to cleaning it up more but I think it is a good start :)
13:10:11 <hhorak> tjanez: we should now wait for fesco's comments before further changes so we don't make any mess
13:10:20 <juhp_> good that it has been submitted finally
13:10:28 <juhp_> hhorak, right
13:10:48 <tjanez> hhorak, agreed
13:11:10 <juhp_> they might make some suggestions too perhaps
13:12:04 <tjanez> I also like the way the PRD shaped in the last two weeks. I think it showed we have a common vision in mind.
13:12:24 <juhp_> yes - it improved a lot
13:12:53 <juhp_> thanks to everyone who helped make it better
13:13:08 <tjanez> And I'm looking forward to hearing comments/suggestions from FESCO since they will be the first "outsiders" reading it
13:13:27 <hhorak> juhp_ +1, good work guys!
13:13:28 <tjanez> It may show that something are only clear to us, but not to other people in Fedora land
13:14:06 <juhp_> true - certainly good to have it reviewed and receive feedback from a different perspective
13:15:20 <tjanez> #info We will wait for FESCo's comments/suggestions on the PRD and then make further clean-ups and modifications to it.
13:15:50 <bkabrda> tjanez: +1, sounds good
13:15:54 <tjanez> #topic Making a plan for the tasks/goals set in the PRD
13:16:46 <tjanez> So, does anyone have any suggestions on how we should plan things forward?
13:18:01 <juhp_> probably we shouldn't make any drastic plans until the PRD has been reviewed, but maybe there are some smaller more obvious things we could start to think about?
13:18:43 <juhp_> there was some discussion about scl on the mailing list for example - not sure if any action items are emerging from that discussion?
13:19:49 <tjanez> juhp_, agreed, I was thinking more about the method of making a plan (i.e. should we make create a Wiki page, something else?)
13:20:02 <juhp_> ah yes
13:20:11 <tjanez> I also think it is too soon to define the actual tasks
13:21:26 <hhorak> PRD is quite brief in most of of points, so I guess every task could have it's own wiki page, that would include verbose information,
13:21:33 <hhorak> or at least links to mailing list.. it doesn't have to be right now, but as soon as we start elaborating the task..
13:21:50 <juhp_> hhorak, yes that sounds good
13:21:55 <hhorak> or do we have some alternative places to keep progress?
13:22:27 <bkabrda> hhorak: I guess wiki is the best + easiest way to do this
13:22:31 <juhp_> for larger project wiki pages sound good
13:23:02 <juhp_> as we break them into smaller tasks dunno if we will need more or not
13:23:41 <tjanez> What about a combination of Wiki and a ticketing system like Trac?
13:23:48 <juhp_> could be
13:24:15 <juhp_> ticket may be good for tracking progress on individual tasks
13:24:20 <juhp_> tickets even
13:24:28 <bkabrda> tjanez: yes, trac sounds good. at the lowest level, I guess we will refer to specific project bug trackers/bugzilla etc., so we only need the higher level overview place
13:24:50 <juhp_> yes
13:24:59 <tjanez> juhp_, bkabrda: +1
13:25:46 <tjanez> BTW, do you have good experience with Trac? To me it seems a little outdated...
13:26:27 <hhorak> yeah, wiki for summarizing the status quo and any-tool-like-trac for logging the progress..
13:27:01 <hhorak> tjanez: I like that it is very simple, do you think it misses some features we could need?
13:28:09 <tjanez> hhorak, nothing in particular about Trac, just that I feel there has been no updates on it and it feels more clumsy than say GitHub
13:29:03 <juhp_> tjanez, it works... but yeah a bit old, still within fedora the choices seem limited
13:29:46 <hhorak> tjanez: right, it is definitely not state of the art, but for me personally it seems to be enough for now
13:30:04 * mmaslano is finally here
13:30:14 <tjanez> juhp_, hhorak: Ok, agreed.
13:30:23 <tjanez> mmaslano: Hi!
13:33:17 <juhp_> btw do you think we should have an irc channel?
13:33:37 <juhp_> or is there one?
13:34:41 <juhp_> (if we do I hope the name could be less than 14 characters :) ;o)
13:34:48 <tjanez> juhp_: No, I think there is none yet.
13:34:56 <tjanez> #proposal: We will expand the tasks/goals' description in the PRD and use the Wiki for description and summary of status of the tasks/goals. For logging of progress we will use a ticketing system (e.g. Trac).
13:35:01 <juhp_> sorry bit OT perhaps
13:35:29 <hhorak> juhp_: I remember we talked about it and we decided not to have it for now, since we are from different time zones anyway and mailing list should be enough for now.
13:35:31 <juhp_> s/less than/not more than/
13:35:37 <mmaslano> hhorak: yeah
13:35:40 <juhp_> okay
13:35:46 <juhp_> fair enough
13:36:01 <juhp_> just sometimes it is nice to be able to interact in real time
13:36:45 <tjanez> juhp_: +1
13:36:51 <juhp_> anyway I guess #fedora-devel is available in general
13:36:57 <tjanez> Is there any burden in having a channel?
13:37:35 <juhp_> guess main burden is just "one more channel..."
13:37:45 <juhp_> I have too many already :)
13:38:00 <juhp_> so I don't mind having one more but ...
13:38:27 <juhp_> other problem is finding a sane name for the channel ;)
13:38:57 <tjanez> juhp_: #fedora-env-and-stacks?
13:38:58 <juhp_> maybe need more opinions
13:39:35 <juhp_> tjanez, fine, except my stupid client can't remember more than 14 letters ;)
13:39:45 <juhp_> I think
13:40:08 <juhp_> or at least my config... of course that is mostly my problem :)
13:40:51 <juhp_> tjanez, good name though
13:41:28 <hhorak> juhp_: I guess we are on #fedora anyway, which seems to be enough for me, but I'm not against creating a new chat..
13:41:47 * juhp_ is not
13:41:58 <juhp_> but I could be
13:42:17 <juhp_> is it not noisy
13:42:21 <mmaslano> I'm also not on #fedora :)
13:42:28 <mmaslano> #fedora-devel would be fine
13:42:31 <juhp_> nod
13:42:44 <mmaslano> or new channel with less than 14 letters :)
13:42:50 <hhorak> OK then, we should have a place to catch each other if necessary
13:42:56 <tjanez> yea, I'm also on #fedora-devel but not on #fedora
13:43:07 <juhp_> nice thing about own channel is it is easier to notice conversations happening
13:43:22 <bkabrda> +1 for fedora-devel. I don't want another channel-to-watch, too
13:44:08 <tjanez> Since there seem to be different opinions, maybe we should vote on it?
13:44:28 <juhp_> ok
13:44:30 <tjanez> #proposal: Create a dedicated IRC channel for our WG
13:44:43 <juhp_> +1
13:44:59 <hhorak> I'm also on fedora-devel btw.
13:45:14 <tjanez> +1
13:47:26 <juhp_> bkabrda, I don't really have to read the #fedora-devel backlog
13:47:32 <juhp_> time ^
13:48:00 <juhp_> anyway probably #fedora-devel is enough for now
13:48:02 <hhorak> +1 since we'll probably need to collaborate more when working on actual tasks -- 20 or 21 chats, who cares ;)
13:48:48 <tjanez> bkabrda, mmaslano: What's your vote?
13:48:56 <bkabrda> I'm +0 on this. it's not a big problem for me, but I don't like it that much either
13:49:01 <mmaslano> +0
13:49:47 <tjanez> Hmm, can someone help me what is the decision when we have 3x +1, 2x +0?
13:50:34 <juhp_> pkovar, we are voting on whether to have an irc channel btw
13:50:57 <juhp_> tjanez, I think that means not carried
13:51:02 <pkovar> juhp_, thanks. sorry for being late
13:51:54 <juhp_> perhaps people in the US have comments too
13:52:06 <tjanez> samkottler, we are voting on having a dedicated IRC channel?
13:52:11 <juhp_> anyway it is not such big deal for me either - just thought it could be useful
13:52:20 <samkottler> yeah I'd like that
13:52:25 <samkottler> not sure what we need it for just yet, but sure
13:53:06 <hhorak> we can move voting to mailing list then
13:53:08 <juhp_> #fedora-workstation is too long for my poor client though :-/
13:53:48 <tjanez> hhorak, ok
13:54:57 <tjanez> juhp_, want to take the proposal to the ML (can I assign you this action)?
13:55:07 <juhp_> tjanez, okay sure
13:55:35 <tjanez> #action juhp_ will create a proposal for a dedicated IRC channel and sent it to the ML
13:56:00 <tjanez> Ok, can we vote on my other proposal:
13:56:09 <tjanez> #proposal: We will expand the tasks/goals' description in the PRD and use the Wiki for description and summary of status of the tasks/goals. For logging of progress we will use a ticketing system (e.g. Trac).
13:56:51 <juhp_> on separate pages, right?
13:57:10 <tjanez> juhp_, yes
13:57:40 <juhp_> I think it is good
13:57:48 <juhp_> +1
13:57:56 <hhorak> +1
13:58:15 <samkottler> +1
13:58:22 <bkabrda> +1
13:58:53 <mmaslano> +1
14:00:15 <tjanez> +1
14:00:33 <tjanez> #agreed: We will expand the tasks/goals' description in the PRD and create separate Wiki pages for their description and the summary of their status. For logging of progress we will use a ticketing system (e.g. Trac) (+6,-0,0)
14:01:12 * tjanez improved the wording slightly based on juhp_'s comment
14:01:32 <tjanez> #topic Next week's chair
14:02:12 <mmaslano> that's very good topic
14:02:23 <tjanez> mmaslano, will you chair the next meeting or do you prefer we select the chair each time?
14:02:36 <mmaslano> could someone else do it this time?
14:02:43 <mmaslano> next time
14:02:43 <juhp_> when do we expect to hear something from fesco?
14:03:00 <mmaslano> juhp_: we, fesco, will speak about it on Wednesday
14:03:05 <juhp_> cool
14:03:30 <mmaslano> no volunteer?
14:03:35 <mmaslano> you can train new commands
14:03:49 <tjanez> #info FESCo will discuss the PRD on Wednesday's meeting (2014-01-22)
14:03:50 <juhp_> tjanez, I guess I won't be available late next Tue
14:04:14 <juhp_> (I could volunteer the week after perhaps if needed)
14:04:20 <mmaslano> ok, I'll take the chairwoman duties. I need to go to another meeting
14:04:38 <mmaslano> #action mmaslano will chair next meeting
14:04:52 <juhp_> thanks
14:05:19 <tjanez> #action juhp_ will chair the meeting the week after that (2014-02-04)
14:05:35 <juhp_> ;)
14:05:42 <juhp_> cool
14:05:45 <tjanez> juhp_, I put that in this week's minutes since you won't be here next week :)
14:06:00 <juhp_> tjanez, right - good thinking
14:06:10 <tjanez> #topic Open Floor
14:06:14 <tjanez> Ok, anything else?
14:08:14 <tjanez> One quick question from me: Is anyone coming to DevConf.cz?
14:08:38 <juhp_> I wish I was, but not this time
14:08:48 <mmaslano> I'll be there
14:08:55 <mmaslano> tjanez: when are you coming to Brno?
14:09:26 <tjanez> mmaslano, I haven't made reservations yet, but I plan on Thursday afternoon/evening
14:09:47 * juhp_ wants to go to flock though
14:10:05 <juhp_> but that is still bit far away of course
14:10:22 <tjanez> juhp_, me too
14:10:38 <mmaslano> juhp_: I plan to go too
14:11:42 <juhp_> great
14:12:46 <tjanez> It would be great to have some f2f discussions at DevConf.cz and/or FLOCK
14:13:57 <juhp_> yes
14:15:28 <tjanez> Ok, I'll close the meeting if there's nothing more
14:16:21 <tjanez> #endmeeting