fedora_docs
LOGS
14:02:10 <randomuser> #startmeeting Docs Project Meeting - Agenda: https://fedoraproject.org/wiki/Docs_Project_meetings
14:02:10 <zodbot> Meeting started Mon Jan 20 14:02:10 2014 UTC.  The chair is randomuser. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:10 <randomuser> #meetingname Fedora Docs
14:02:10 <randomuser> #topic Roll Call
14:02:10 <zodbot> The meeting name has been set to 'fedora_docs'
14:02:21 * Sparks 
14:02:25 * pbokoc 
14:02:33 * jjmcd 
14:02:47 * jreznik is lurking (and has one tough question for you guys)
14:02:56 * lnovich here
14:03:14 <Sparks> jreznik: Sorry, we don't do tough questions.
14:03:32 * jhradilek 
14:03:38 <jreznik> oh, no :)
14:04:05 * Capesteve waves
14:04:54 * randomuser yawns
14:05:21 * ciupicri stalks
14:06:00 <randomuser> #chair jreznik
14:06:00 <zodbot> Current chairs: jreznik randomuser
14:06:13 <randomuser> jreznik, you can go first if you like
14:06:28 <jreznik> ok, thank - it's a quick one but could be hard to answer
14:07:14 <jreznik> I'm trying to figure out, what Fedora.next would mean for other than WGs teams and how much time consuming it would be for you (in case the proposal would pass as it stands now - three products)
14:07:46 <jreznik> and where would be that line, it's doable for the next Fedora or we would have to slip that August timefrime or skip Fedora.next for a release
14:08:05 <randomuser> uhh... is "WGs are responsible for documenting their own product" an option?
14:08:21 <randomuser> </jest>
14:08:32 <Sparks> jreznik: Some of the guides are specific to a particular WG...  some could cover all without any change.  I think we'd have to take it on a case-by-case basis.
14:08:52 <jreznik> randomuser: that would be one question - one it's definitely one option but I expect coordination would be required
14:08:54 <sgordon> >.>
14:08:56 <randomuser> o
14:09:18 <randomuser> it's hard to say - there aren't even finalized PRDs yet, right?
14:09:29 <jreznik> randomuser: PRDs are about being finalized
14:09:56 <jreznik> https://fedorahosted.org/fesco/ticket/1222 and https://fedorahosted.org/fesco/ticket/1224
14:10:22 <randomuser> #topic jreznik's fedora.next jamboree
14:10:56 <jreznik> Workstation is now under internal's team review, so we are close now and it's probably the best time to try to get a picture of how WGs would interact with other teams, what does it mean for them and also when stuff should happen
14:12:19 <randomuser> jreznik, so the options under consideration are 1) slightly extended release schedule, slip mid-august- or 2) ship traditional product line on 6mo release schedule?
14:12:45 <jreznik> randomuser: even the traditional product would be mig-august
14:12:53 <randomuser> mmm
14:13:18 <jreznik> and there's that question - if we agree on products, what has to be done (and when) to release fedora.next thing?
14:13:34 <jreznik> so I'm trying to collect info to get into picture
14:13:39 <randomuser> that extra time alone means we would probably be as prepared as for any release
14:14:04 <randomuser> and as Sparks said, we have things targeted and things general
14:15:21 <jreznik> so for docs, decision if we go .next or .traditional F21 release is not a big deal - if decided in timely manner, right?
14:15:28 <randomuser> branding/presentatino might be our best challenge
14:16:34 <randomuser> jreznik, I would agree with that - anyone else?
14:17:59 <jreznik> seems like not
14:18:27 <randomuser> indeed
14:18:51 <randomuser> thanks for bringing the question to us, jreznik, we should be talking about it more
14:19:27 <randomuser> #topic Publican4/Publishing
14:19:29 <jreznik> thanks randomuser, it's a good start for me for now
14:19:33 <randomuser> #chair Sparks
14:19:33 <zodbot> Current chairs: Sparks jreznik randomuser
14:19:45 <Sparks_too> Oh goodie, this must be for me.
14:20:32 <randomuser> #chair Sparks_too
14:20:32 <zodbot> Current chairs: Sparks Sparks_too jreznik randomuser
14:20:47 <Sparks_too> #info Koji is setup for accepting SRPMs but we're having problems getting Koji to actually build them.  We continue to troubleshoot.
14:21:15 <randomuser> progress!
14:21:17 <jjmcd> I pretty routinely build on koji from srpms, what's different?
14:21:26 <Sparks_too> #info The new backend server is operational and is awaiting packages from Koji to be setup completely.
14:22:08 <randomuser> jjmcd, i get the impression that publican is a big wrapper in this respect, a publishing fedpkg
14:22:22 <Sparks_too> #info We'll be running Publican 4 on the backend and RPMs will be made available via the repos.
14:22:47 <jjmcd> seems like publican ought to be like any other compiler
14:22:50 <Sparks_too> Jjmcd: It's a different tag so it had to be setup from scratch.
14:23:10 <jjmcd> ahh - always a risk to start new
14:23:33 <Sparks_too> Yep, we're trying to find the bug now.
14:24:06 <randomuser> Sparks_too, so the frontend installs from the repos and the mirrors grab from the frontends. Are the repos internal, or public?
14:24:57 <Sparks_too> The repos are public, just not the same tags.  Ours go into something like docs-el6.
14:25:17 <Sparks_too> The mirrors shouldn't grab these packages though.
14:25:58 <randomuser> that was ill phrased; i meant, do we intend to distribute via the repo
14:25:58 <Sparks_too> Maybe they will but I've only been focused on getting the packages from Koji to a single server in the Fedora Infrastructure.
14:26:18 <Sparks_too> Define "distribute".
14:26:30 <randomuser> convey to end users
14:26:58 <Sparks_too> No.  This is specifically being used to get data to docs.fp.o.
14:27:03 <randomuser> ack
14:27:21 <Sparks_too> These aren't "desktop" builds...
14:27:54 <Sparks_too> They are web builds which probably wouldn't work well on a end-user's computer.
14:28:46 <randomuser> gotcha. Sparks_too, is there anything we should be doing to help?
14:29:05 <randomuser> or prepare to help, I guess
14:29:23 <Sparks_too> Not yet.  As soon as we figure out the Koji bug we'll need people to start building things.
14:30:08 <Sparks_too> I'm hoping this will be a lot easier than the way we've been doing it in the past.
14:30:31 <Sparks_too> #action Sparks to update publishing documentation.
14:30:54 <randomuser> thanks for bringing us up to speed, Sparks_too - anything else?
14:31:22 <Sparks_too> I have nothing else at the moment.  We're really close, though.
14:31:34 <randomuser> awesome
14:31:44 <randomuser> #topic Centos Docs
14:31:57 <randomuser> so, did everyone notice that thing that happened with Centos?
14:32:25 <jjmcd> didn't connect the dots to think it affected us, tho
14:32:26 <sgordon> nah
14:32:36 <pbokoc> I heard some commotion and mostly ignored it
14:32:42 <randomuser> the project is much more open now, and there has been some rumbling about a docs SIG
14:32:47 <randomuser> heh
14:33:21 <pbokoc> wait, what's SIG?
14:33:31 <Capesteve> a type of welding
14:33:33 <sgordon> special interest group
14:33:40 <pbokoc> Capesteve, thanks :)
14:33:42 <jjmcd> nice pistol
14:33:54 <randomuser> it seems like we and they have a lot in common, so I think it would be a good idea to subscribe to the centos-docs list, offer what guidance we can, and perhaps collaborate
14:34:02 <Capesteve> a bit saur
14:34:13 <jjmcd> ;)
14:34:28 <randomuser> #link http://lists.centos.org/mailman/listinfo/centos-docs
14:34:57 <randomuser> #info el7 and Fedora will have a lot in common, and centos has a docs group
14:35:08 <Sparks_too> So we should invade and take over?
14:35:22 <jjmcd> captives might be good
14:35:31 <sgordon> the only thing i would note with that is centos is much closer to rhel
14:35:39 <randomuser> ha, no, Sparks_too - we should let them catch up to el7 then pillage their content
14:35:52 <sgordon> so the rhel docs are pretty accurate for it (to the point that for centos 5 they actually just mirrored the rhel docs...)
14:35:58 <Sparks_too> Well, we're still upstream...
14:36:07 <randomuser> sgordon, a lot of our older guides are closer to RHEL than current fedora, too
14:36:16 <sgordon> sure, but that's not a good thing
14:36:27 <sgordon> per what sparks says im not sure this changes the needs of fedora docs
14:36:28 <randomuser> so if the centos group is updating for el7, we have something to offer each other
14:36:45 <Sparks_too> Except for the Security Guide which someone inside RH decided to do all by themselves and not contribute back.
14:37:04 <sgordon> i blame sparks
14:37:06 <sgordon> ;p
14:37:24 <Sparks_too> Sgordon: you are correct, this doesn't change things for us.
14:37:31 * randomuser nods
14:37:32 <sgordon> having tried to feed the sausage back through the mincer to create ovirt docs from rhev docs
14:37:38 <sgordon> im just saying it's not as easy as you would think
14:38:12 <randomuser> I bring it up merely to suggest that we could help out someone in the family, so to speak
14:38:13 <sgordon> i think what will be more relevant is how centos variants, and documentation for those, falls out
14:38:30 <sgordon> as there is more overlap there with the new fedora "products"
14:38:37 <randomuser> not any specific implementation, but the idea of communication between the two groups
14:38:50 <Sparks> sgordon: It seems that people aren't grasping the whole upstream thing.  Docs should be *easy* once we get it correct in Fedora.
14:39:27 <randomuser> and that's a good segue into guides
14:39:32 <randomuser> #topic guides
14:39:42 <Sparks> .
14:39:52 <randomuser> first, https://bugzilla.redhat.com/show_bug.cgi?id=904083
14:40:16 <randomuser> Does anyone know how to get in contact with this don domingo character, or if he is in fact a real person?
14:40:32 <sgordon> haha
14:40:35 <sgordon> he is indeed
14:41:07 <sgordon> suggest emailing him?
14:41:37 <randomuser> i can email him, I guess
14:41:49 <Capesteve> sgordon: I think e-mailing him is not the best thing
14:41:54 <sgordon> why?
14:42:09 <sgordon> if you want to contact him, that's how to contact him
14:42:16 <Capesteve> I believe him wants to pass this task to someone else
14:42:22 <Capesteve> he wants
14:42:32 <randomuser> me wants?
14:42:54 <sgordon> Capesteve, yes - but since he made that glorious notion in a private comment
14:42:59 <sgordon> it's not very useful to anyone here
14:43:17 <Sparks> If it's not public it didn't happen.  :)
14:43:33 <randomuser> see, this is why I brought it up here, i thought someone might have inside information
14:43:46 <sgordon> randomuser, i've updated the bug and pointed at another writer
14:44:15 <sgordon> i also removed the private marker on the comment because there's absolutely nothing there that deserves it
14:44:44 <randomuser> whaaaa?
14:45:03 <randomuser> very odd; I could have sworn the assignee did not change before you did that
14:45:07 <sgordon> it didnt
14:45:13 <sgordon> i set it
14:45:23 <randomuser> ah
14:45:25 <pbokoc> yeah, Don said he was reassigning it, but forgot to actually do it
14:45:39 <randomuser> thanks sgordon
14:45:42 <sgordon> but for future reference don is in fact a real person
14:45:43 <sgordon> ;)
14:46:06 <randomuser> i remain skeptical
14:46:33 <randomuser> Any other guide news? jhradilek, Capesteve ?
14:46:44 <pbokoc> I've got something
14:46:51 <pbokoc> randomuser, I'm in need of your publishing skills again
14:47:00 <randomuser> pbokoc, translations?
14:47:11 <pbokoc> randomuser, exactly
14:47:22 <pbokoc> there's a Czech (cs) translation for the Quickstart Guide available in the repo
14:47:33 <randomuser> pbokoc, while we're on the subject, what about a lang map table for zanata?
14:47:42 <randomuser> publican likes it to be cs-CZ
14:48:08 <pbokoc> really? I tried building it with --langs=cs and it worked fine
14:48:33 <Sparks> .
14:48:36 <randomuser> pbokoc, but on the site at least, the precedent is cs-CZ
14:48:41 <Sparks> randomuser: I have something on the SG
14:48:43 <pbokoc> oh right
14:48:48 <pbokoc> hmmmmmmm
14:49:16 <randomuser> pbokoc, I'll fool around with it and publish if you look into zanata settings for lang mapping
14:49:46 <randomuser> Sparks, go ahead
14:49:54 <pbokoc> randomuser, ok
14:50:29 * randomuser notes that QA doesn'
14:50:30 <Sparks> I don't like the Security GUide
14:50:33 * roshi is here
14:50:44 <randomuser> ....we can go over if we want, nothing in the next block
14:50:45 * roshi forgot about the meeting and got distracted
14:50:48 <Sparks> I'm hoping to rework the entire guide as a hardening guide.
14:51:18 <Sparks> If anyone is interested in helping please let me know
14:51:20 <Sparks> EOF
14:51:32 <randomuser> Sparks, IMO we should put the SELinux directives right in line with the non-selinux directives for a task
14:51:45 <randomuser> segregation doesn't encourage use
14:52:53 <randomuser> #info Sparks is reworking the Security Guide, talk to him if you want to help
14:53:14 <Sparks> randomuser: At this time all the SELinux stuff has been combined with the SG and I plan to keep it that way.
14:53:55 <randomuser> whoa, ok then
14:55:06 <Sparks> I'm hoping to integrate it into a single, cohesive guide.
14:55:09 <Sparks> If that makes sense.
14:55:12 <randomuser> anyone else? I'm excited to see the new Networking Guide and updated Sysadmin and Virt guides
14:55:41 <randomuser> #link https://fedoraproject.org/wiki/Category:Docs_Project_tasks
14:55:59 <randomuser> #info use the task table to ask for and find tasks
14:57:32 <randomuser> i guess that's an implied vote for wrapping up the meeting
14:57:53 <randomuser> #topic Open Floor
14:58:23 <lnovich> FAD?
14:58:28 <randomuser> FAD!
14:58:41 <lnovich> any news?
14:58:42 <Sparks> Yeah, when do we want to do this thing?
14:58:42 <jhradilek> Do we have a date yet?
14:58:57 <randomuser> we talked about 21MAR weekend last week
14:59:14 <randomuser> lnovich sadly was the only one that had questionable availability
14:59:26 <randomuser> should we just call it for that weekend?
14:59:27 <jhradilek> I need to know the date to book a meeting room, check the equipment, figure out how to connect to Releigh, etc. :)
14:59:39 <Sparks> jhradilek: Yeah, me too.
15:00:17 <randomuser> personally, I was waiting for some feedback from my boss that doesn't look like will ever come, so let's not wait on me anymore
15:00:46 <randomuser> lnovich, weekend of 21MAR good for you ?
15:00:56 * lnovich checking
15:01:16 <lnovich> should be ok
15:01:51 <randomuser> #action randomuser to send email to docs list about FAD scheduling for weekend of 21MAR2014, give opportunity for protest
15:02:17 <randomuser> if nobody objects in the next couple days, let's consider it set
15:02:24 <Sparks> randomuser: So we're arriving on Friday and working Saturday and Sunday or are we trying to work on Friday as well?
15:02:54 <lnovich> Id like to get some work done on Friday if we can
15:02:57 <randomuser> Sparks, I think we should try for friday as well, but not imperative
15:03:06 <randomuser> heh, we'll get more out of lnovich that way at least
15:03:34 <Sparks> true
15:04:23 <lnovich> do we have an agenda?
15:04:50 <randomuser> #link https://fedoraproject.org/wiki/Docs_FAD_2014
15:05:30 <randomuser> crash hack guides, listen to me rant about community oriented deliverables, etc
15:05:55 <jhradilek> randomuser: Could you please give me an action item to update the Brno part of that page?
15:06:07 <jhradilek> I keep forgetting to do that.
15:06:21 <randomuser> #action jhradilek to update docs FAD page for brno attendees
15:06:30 <jhradilek> Cheers.
15:06:31 <randomuser> i *think* you can action yourself, fwiw
15:06:39 <jhradilek> Ah, OK.
15:07:34 <lnovich> ok I need to go - but let me know if you need any assistance for the FAD
15:08:59 <randomuser> okay, we've punted the FAD conversation back to the list; anything else to cover?
15:09:42 <Capesteve> time check
15:09:57 <randomuser> we're over time, yeah
15:11:01 <randomuser> fair enough, thanks for coming everyone
15:11:05 <randomuser> #endmeeting