fesco
LOGS
18:01:33 <t8m> #startmeeting FESCO (2014-01-08)
18:01:33 <zodbot> Meeting started Wed Jan  8 18:01:33 2014 UTC.  The chair is t8m. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:34 <t8m> #meetingname fesco
18:01:34 <zodbot> The meeting name has been set to 'fesco'
18:01:34 <t8m> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:01:34 <t8m> #topic init process
18:01:34 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:01:42 <t8m> Hello all
18:01:43 <mmaslano> hi
18:01:43 <nirik> morning everyone.
18:01:45 <mattdm> hello1
18:01:46 <sgallagh> .hellomynameis sgallagh
18:01:48 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:01:54 <pjones> happy new year, everybody
18:02:03 <sgallagh> I'm splitting my attention with Server PRD planning, so apologies if I'm slow to respond
18:02:06 * notting is here
18:02:15 <t8m> Yep, happy new year to everyone
18:02:49 <t8m> I hope this time the meeting will be quite short
18:03:05 <mattdm> hahahah.
18:03:09 <mattdm> i mean yes
18:03:13 <t8m> :)
18:03:47 <t8m> abadger1999, mitr, around?
18:03:55 <mitr> Hello
18:03:58 <t8m> let's start then
18:04:05 * abadger1999 here but extricating from other discussions
18:04:10 <t8m> #topic #1132 libtool + %global _hardened_build 1 = no full hardening
18:04:14 <t8m> .fesco 1132
18:04:16 <zodbot> t8m: #1132 (libtool + %global _hardened_build 1 = no full hardening) – FESCo - https://fedorahosted.org/fesco/ticket/1132
18:05:07 <t8m> So any volunteer to apply the new %configure hack?
18:05:44 <t8m> or do we need to vote first whether it should be applied?
18:05:47 * nirik looks to see where we were.
18:07:25 <nirik> ok, yeah, sounds like we were ready to try the latest patch in rawhide.
18:07:34 * mattdm nods
18:07:48 <t8m> #proposal Apply the %configure hack (with possible opt-out) as of https://bugzilla.redhat.com/attachment.cgi?id=838954
18:08:01 <mattdm> +1
18:08:04 <t8m> +1
18:08:07 <nirik> +1
18:08:09 <abadger1999> +1
18:08:10 <notting> +1
18:08:11 <mmaslano> +1
18:08:20 <mitr> +1, please announce on fedora-devel
18:08:54 <nirik> so, who wants to apply and announce? ;)
18:09:31 * nirik listens to crickets, guess that means me.
18:09:34 <t8m> #agreed Apply the %configure hack (with possible opt-out) as of https://bugzilla.redhat.com/attachment.cgi?id=838954 (+7, 0, 0)
18:09:42 <t8m> heh :)
18:09:53 <nirik> not sure how fast I will get to it, but can try
18:09:56 <t8m> nirik, thanks for volunteering
18:10:07 <pjones> (for the record, +1)
18:10:25 <t8m> #action nirik will apply the patch and announce it on fedora-devel
18:11:02 <t8m> #topic #1198 Possible changes to Fedora EOL bug procedure
18:11:07 <t8m> .fesco 1198
18:11:08 <zodbot> t8m: #1198 (Possible changes to Fedora EOL bug procedure) – FESCo - https://fedorahosted.org/fesco/ticket/1198
18:11:32 <mattdm> I'm going to look through bugs closed as wontfix this cycle
18:11:38 <mattdm> and contact some of the users affected
18:11:42 <mattdm> and see if they can reopen
18:11:59 <mattdm> i would like to leave the ticket open but take it off the agenda
18:12:04 <mattdm> until i can do that project
18:12:15 <t8m> OK
18:12:23 <t8m> thanks, mattdm
18:12:26 <t8m> next topic
18:12:43 <t8m> #topic #1213 Please process commit access requests for spampd
18:12:49 <t8m> .fesco 1213
18:12:50 <zodbot> t8m: #1213 (Please process commit access requests for spampd) – FESCo - https://fedorahosted.org/fesco/ticket/1213
18:13:16 <nirik> oddly, I saw an email on another list from him today...
18:13:42 <t8m> So I am not sure the nonresponsive maintainers policy was followed completely
18:14:11 <nirik> the process is pretty long and unweidly sadly.
18:14:24 <t8m> yep
18:15:00 <sgallagh> Yeah, that process really seems to be weighted towards lazy owners rather than willing maintainers.
18:15:39 <pjones> I think that's a conclusion unsupported by data
18:15:49 <t8m> I could see some improvement or fasttrack process if the maintainer was not appearing anywhere for a long time.
18:15:58 <pjones> t8m: that might be a good idea
18:16:03 <jreznik> for EOL - we have one week left
18:16:05 <nirik> it's difficult, because the world isn't black and white.
18:16:14 <pjones> nirik: that's right
18:16:18 <mattdm> +1 nirik
18:16:24 <t8m> dure
18:16:29 <t8m> sure that is
18:16:43 <pjones> the biggest assumption our current process makes is that the current maintainer probably has the most domain experience with the package
18:16:50 <pjones> which may or may not be true, but often is
18:17:05 <mattdm> has anyone attempted to contact mattias in other channels?
18:17:07 <pjones> and so it's weighted heavily towards keeping the incumbent in unless there's a good reason not to
18:17:52 <nirik> mattdm: I just sent him email
18:18:04 <nirik> I see the posts to the devel list didn't cc him (as I think the policy asks)
18:18:08 <mattdm> nirik okay so i won't press send on the one i was writing. heh
18:18:49 <mattdm> policy doesn't seem to ask that, but it seems to imply other attempts at contacting the maintainer
18:18:54 <t8m> #proposal Wait a week for eventual response to direct mail from Matthias
18:18:56 <pjones> I guess the other big assumption it makes is that when people say they're following the process, they are
18:19:08 <nirik> pjones: right, it's pretty free form
18:19:16 <nirik> t8m: +1
18:19:20 <pjones> which maybe we could provide a checkbox-list form for the reporter to fill out for the ticket?
18:19:22 <notting> pjones: which is not much different than the rest of our discretionary policies
18:19:36 <mattdm> part of the process is "all reasonable efforts to contact the maintainer have failed", and that's open to a lot of interpretation
18:19:38 <pjones> [ ] the owner has been contacted directly
18:19:48 <notting> pjones: but yes, automation / acutal *processing* good
18:19:49 <pjones> [ ] the owner has been contacted on f-d-l and was on the cc list
18:20:11 <pjones> [ ] I have feelings and deserve dignity which I will demand by doing a good job at this checkybox form
18:20:14 <mattdm> #proposal note that nirik sent an email, revisit next week
18:20:19 <mmaslano> +1
18:20:28 <mattdm> lol pjones
18:20:48 <mitr> pjones: per the theoretical process we shouldn't even be getting a ticket, but reacting on fedora-devel
18:20:50 <nirik> we did have a proposal a long time ago to do a timeout on acl requests.
18:21:02 <pjones> mitr: that's true, and occasionally it even works that way
18:21:22 <nirik> ie, you ask for commit on a package, if the maintainer doesn't say yes or no after X time, it autoapproves you and you can work on the package
18:21:27 <pjones> mitr: I suspect the timing of this request in terms of holidays is to its detriment.
18:21:41 <mitr> proposal? (Really not sure) After step 5 of http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers, add "File a FESCo ticket to get an ack"
18:21:43 <t8m> +1 to myself or mattdm's proposal as it is basically the same
18:21:57 <pjones> nirik: ... which works a lot better in february than in august if the maintainer is, for example, in france...
18:21:57 <mitr> +1 to mattdm
18:22:13 <nirik> pjones: yeah, depending on how long X is.
18:22:52 * mattdm did not see t8m's earlier proposal. i agree that they're basically the same.
18:23:15 <nirik> mitr: in practice thats what seems to usually happen anyhow. ;)
18:23:47 <t8m> Please vote :)
18:24:13 <mattdm> t8m +1 to yours too if that helps :)
18:24:40 <notting> oh, for 'wait for a week'? +1
18:24:51 <pjones> mattdm: +1
18:25:54 <t8m> #agreed Nirik sent direct e-mail, we will revisit next week (+7, 0, 0)
18:26:01 <t8m> (with some sloppy counting)
18:26:19 <t8m> #topic #1216 Requesting input on FESCo Badge concept
18:26:24 <t8m> .fesco 1216
18:26:25 <zodbot> t8m: #1216 (Requesting input on FESCo Badge concept) – FESCo - https://fedorahosted.org/fesco/ticket/1216
18:27:41 <pjones> I think it should say "Ultima Ratio Regum" on it some place.
18:27:48 <nirik> ha
18:27:50 <t8m> So I don't really have any idea what should be on FESCo ex-member badge
18:27:53 * nirik doesn't too much care.
18:28:08 <nirik> the badges artwork has been outstanding so far. :)
18:28:24 <notting> maybe just a picture of the sierra madres.
18:28:25 * mitr has nothing to add
18:28:44 <mmaslano> I liked vondruch proposal in ticket
18:28:47 <nirik> "I know the treasure is here somewhere!" ? :)
18:28:52 <mattdm> rubber stamp seems fine, as long as it that stays a caricature and not reality :)
18:29:13 <mattdm> the steering wheel is good too
18:29:18 <abadger1999> adminral "it's a trap!" akbar
18:29:47 <pjones> notting: wee don't need no steenking BADges?
18:30:19 <sgallagh> No one likes the Eye of Providence? ;-)
18:30:37 <pjones> mattdm: as long as you can read it (maybe backwards) and it says "rejected" or "your idea is bad and you should feel bad" or "ultima ratio regum" ;)
18:31:07 <mattdm> sgallagh no that one needs to be reserved for members of the fedora cabal
18:31:22 <t8m> I like the "ultima ratio regum" as it is funnily ironic in many ways
18:31:39 <mattdm> that plus the rubber stamp. done.
18:31:40 <sgallagh> mattdm: So only Red Hat members of FESCo <.< >.>
18:31:54 <pjones> sgallagh: I think that's all of us right now...
18:32:03 <notting> pjones: is the latin in the badge on an actual cannon?
18:32:19 <mitr> notting: it's correct latin, if that's what you are asking
18:32:22 <pjones> notting: a cannon that says that would be perfectly fine by me ;)
18:32:47 <t8m> OK, I'll add to the ticket that the author of the badge should read this meeting log for ideas :)
18:33:16 <t8m> #topic Next week's chair
18:33:53 <t8m> anybody volunteers?
18:33:58 <abadger1999> mattdm: We should have a cabal badge that's never awarded ;-)
18:34:06 <nirik> abadger1999: +1
18:34:36 <pjones> abadger1999: don't tempt me to root the badge system ;)
18:35:03 <mattdm> abadger1999 nice :)
18:36:35 <mattdm> abadger1999 it should be awarded to no actual people but the badge page should say that it was awarded 13 times
18:36:43 <mmaslano> t8m: ok, I'll do it
18:36:59 <t8m> #action mmaslano will be the next week's chair
18:37:01 <abadger1999> mmaslano: +13 ;-)
18:37:08 <t8m> ;)
18:37:12 <mmaslano> abadger1999: I opt out ;-)
18:37:27 <t8m> #topic Open Floor
18:37:38 <t8m> Anything?
18:37:49 <t8m> except for more cabal badges proposals?
18:37:49 <mattdm> So, I'm pretty sure cloud WG prd is not going to be as good as it could be by the deadline
18:37:58 <mattdm> we made some good progress but it needs more work
18:38:16 <mattdm> I'd like to request a 1-week extension
18:38:24 <mattdm> from our arbitrary deadline
18:38:31 <nirik> well, theres still the later part of this week and early next week, no?
18:38:50 <jreznik> btw. I was getting quite a lot questions about F21 release schedule - so it's now on planet.fpo...
18:39:19 <notting> mattdm: i'd be ok with that
18:39:24 <t8m> mattdm, go ahead with #proposal
18:39:35 <mmaslano> I'm not sure with env and stacks prd too
18:39:47 <mmaslano> one week could be beneficial
18:40:27 <nirik> I'd prefer to see next week what still needs more time.
18:40:47 <mattdm> previous deadline was the 15th, right?
18:41:13 <mattdm> I'm okay with still trying to hit that but giving the warning that we might ask for an extension at that point
18:41:25 <mattdm> no wait it was the 13th
18:41:30 <mattdm> eg monday.
18:41:40 <mitr> I'd somewhat prefer that (just for the psychological effect)
18:41:46 <nirik> I thought it was 15th...
18:41:56 <mattdm> nirik https://fedorahosted.org/fesco/ticket/1196
18:42:03 <mmaslano> mattdm: yeah so 15th would be better for us
18:42:14 <mattdm> okay, so:
18:42:21 <mitr> but we've also been thinking it's >13th
18:42:35 <mattdm> #proposal bump PRD deadline by 2 days to the 15th to align with FESCo meeting
18:42:54 <mmaslano> +1
18:43:10 <mattdm> and we'll see where we are there. hopefully done. :)
18:43:16 <t8m> well fesco should have some time to study it shouldn't?
18:43:31 <sgallagh> The purpose of the 13th was to give FESCo two days to read it and formulate thoughts
18:43:38 <mattdm> t8m that might have been the original intention of giving extra days, yeah.
18:43:39 <t8m> sgallagh, +1
18:43:47 <sgallagh> Actually, were these being submitted to FESCo or the Board?
18:43:57 <nirik> fesco, IMHO
18:44:07 <mattdm> i think we agreed that fesco would review them and pass on to board with recommendation
18:44:15 <sgallagh> mattdm: Right, thanks
18:44:55 <mmaslano> so, different proposal? +7 days, so fesco has time to review those prds?
18:45:08 <t8m> mmaslano, +1
18:45:24 <mattdm> mmaslano +1
18:45:34 <notting> sure, still +1
18:45:56 <nirik> sigh, ok.
18:45:59 <mattdm> and of course if some are done earlier that's just fine. i think workstation is about ready, for example
18:45:59 <nirik> +1
18:45:59 <mmaslano> +1 to my proposal
18:46:01 <t8m> mmaslano, do you vote for yourself?
18:46:08 <sgallagh> 0. I understand the necessity for Cloud, but I don't really like forcing the date out since we're waiting for these to start scheduling.
18:46:27 <pjones> mmaslano: +1
18:46:50 <abadger1999> 0
18:47:00 <mitr> +1; we still need a Server<->Cloud conversation to happen AFAICS and that will take some back-and-forth
18:47:17 <nirik> sgallagh: yeah, this is all still too abstract for me to know really what we are producing, which worries me. The longer we take to actually figure out what we need to change the less time we have
18:47:21 * abadger1999 thinks that starting the review, feedback cycle next week might still be beneficial
18:47:28 <t8m> #agreed PRD deadline bumped by 7 days to the 20th (+7, -0, 0:2)
18:47:29 <mattdm> mitr yeah that's one of our blank sections.
18:47:35 <abadger1999> even if some of the prds were still work in progress
18:47:54 <mattdm> sgallagh attempted to get that conversation started I think but we aren't ready.
18:47:56 <mattdm> weren't
18:48:02 <mattdm> i think it's much more ready now, actually
18:48:22 <t8m> #info feel free to submit even unfinished PRDs for comments earlier
18:48:37 <mattdm> heh i was just typing that info t8m :)
18:49:29 <sgallagh> t8m: Submit where?
18:49:35 <sgallagh> devel@
18:49:36 <sgallagh> ?
18:49:52 <t8m> sgallagh, I suppose so
18:49:53 <mattdm> post to devel-announce, maybe file fesco ticket?
18:50:19 <mattdm> (we probably want a ticket for each of 'em anyway.)
18:50:27 <t8m> #undo
18:50:27 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2d5be5d0>
18:50:50 <t8m> #info feel free to submit even unfinished PRDs for comments to devel-announce@ and open a FESCo ticket earlier
18:52:12 <t8m> Anything else for Open Floor?
18:52:28 <nirik> just heard back from thias... ;)
18:52:55 <nirik> he's going to try and add folks as co-maintainers, as his life has been very busy of late.
18:53:04 <mattdm> aweome
18:53:06 <mattdm> some
18:53:07 <t8m> good
18:53:12 <mattdm> this keyboard ucks
18:54:13 <t8m> I will close the meeting in a minute if nobody has anything else.
18:55:34 <t8m> #endmeeting