infrastructure
LOGS
19:00:03 <nirik> #startmeeting Infrastructure (2013-12-05)
19:00:03 <zodbot> Meeting started Thu Dec  5 19:00:03 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:03 <nirik> #meetingname infrastructure
19:00:03 <zodbot> The meeting name has been set to 'infrastructure'
19:00:03 <nirik> #topic welcome y'all
19:00:03 <nirik> #chair smooge relrod nirik abadger1999 lmacken dgilmore mdomsch threebean pingou puiterwijk
19:00:03 <zodbot> Current chairs: abadger1999 dgilmore lmacken mdomsch nirik pingou puiterwijk relrod smooge threebean
19:00:15 * abadger1999 here
19:00:17 * ianweller here
19:00:19 * anshprat here
19:00:29 * tflink is here
19:00:30 * pingou here
19:00:41 * relrod here
19:01:02 * mirek here
19:01:14 <nirik> morning everyone.
19:01:53 <nirik> #topic New folks introductions and Apprentice tasks.
19:02:10 <nirik> any new folks want to introduce themselves? or apprentices have questions or comments to bring up?
19:02:20 * threebean sneaks in late
19:02:26 <nirik> as always you can also feel free to chime in later in the meeting too with questions or bring them up in open floor.
19:03:03 <nirik> alright...
19:03:08 <anshprat> nirik: threebean : need to build the release package
19:03:10 <anshprat> https://bugzilla.redhat.com/show_bug.cgi?id=1010166
19:03:12 <anshprat> for askbot
19:03:20 <nirik> #topic Applications status / discussion
19:03:33 <anshprat> https://bugzilla.redhat.com/show_bug.cgi?id=1010166#c33
19:03:33 <nirik> anshprat: ok. I thought multilingual was still busted on it?
19:03:42 <nirik> or did we want to push this and update for that fix later?
19:03:59 <anshprat> nirik: yes, it is, I guess easier to fix that later
19:04:13 <nirik> ok, any news on that? you asked upstream?
19:04:37 <anshprat> I did, but I need to check again
19:04:47 <nirik> ok.
19:05:44 <nirik> so stg is all up and running on the new one right?
19:05:49 <anshprat> yes
19:05:56 <nirik> we may want to wait for the prod one until after f20 freeze.
19:06:03 <nirik> but I suppose we could ask for a freeze break.
19:06:23 <threebean> ryanlerch was looking to work on the fedora theme in stg.
19:06:27 <nirik> anshprat: welcome back, BTW. ;)
19:06:28 <anshprat> mm, its ok to wait, I can ask the list to check more in the staging
19:06:30 <pingou> http://209.132.184.188/cnucnu/
19:06:32 <threebean> but we could push to prod first and then double back on the theme.
19:06:33 <anshprat> nirik: TY :)
19:06:34 <pingou> on the news side
19:06:49 <nirik> threebean: yeah, might be nice to push the theme the same time if we can...
19:06:53 * threebean nods
19:07:06 <threebean> nirik: its busted at the moment.  no eta yet.
19:07:08 <nirik> #info askbot update ready in stg, will push after freeze
19:07:28 <nirik> #info askbot outstanding issues: new fedora theme and multilungual support.
19:07:56 <nirik> threebean: ok, we can see after freeze where we are?
19:08:14 <nirik> pingou: very nice!
19:08:44 <pingou> it lacks the fedmsg integration but after that it should be alpha ready
19:08:55 <nirik> so, it works with multiple distros?
19:09:05 * lmacken excited for cnucnu+fedmsg
19:09:08 <nirik> does it have to have a mapping of versions? or ?
19:09:17 <pingou> we can broadcast fedmsg msg on the Fedora bus
19:09:25 <pingou> and I hope on the debian bus as well
19:09:29 <lmacken> pingou: could/should that be the place for DOAP integration too?
19:09:34 <pingou> it has a mapping or project in place
19:09:58 <pingou> http://209.132.184.188/cnucnu/project/keychain/
19:10:07 <pingou> you can map to as many distro as you like
19:10:16 <pingou> lmacken: that would be very cool!
19:10:37 <nirik> very nice. How does it query the distros? or thats manual?
19:10:43 <pingou> it's manual
19:10:50 <pingou> unfortunately :(
19:10:54 <pingou> maybe something for later
19:11:08 <nirik> yeah, query packages? debian at least has a packages like thing too...
19:11:35 <pingou> basically the data comes from the wiki page atm
19:11:54 <threebean> just to initialize it, right?
19:11:54 <pingou> which mean that some projects are name perl/python/php/R-* instead of *
19:12:01 <nirik> https://apps.fedoraproject.org/packages/keychain and http://packages.debian.org/search?keywords=keychain
19:12:03 <pingou> they can be edited (by anyone)
19:12:33 <pingou> nirik: indeed, but then we need to make sure, somehow, that the same name refers also to the same projects
19:12:49 <nirik> yeah. could be anoying.
19:12:51 <pingou> and that's were things get a little harder on the debian world
19:13:09 * pingou needs to ask Olasd (the debian-fedmsg contact)
19:13:16 <nirik> I guess you don't actually need to know the current version really...
19:13:24 <nirik> if there's a new release, there's a new release.
19:13:28 <abadger1999> When I looked at cross distro mapping before what seemed like it would work the best was tarball name.
19:13:41 <pingou> abadger1999: nice idea
19:13:59 <pingou> nirik: yes, cnucnu might then have to be adjusted to do
19:14:32 * nirik recalls some site... just a sec.
19:14:33 <pingou> -> if there is a cnucnuweb message -> check if package is in the list of package to watch -> check version built -> if new version > version built => bz
19:14:42 <pingou> there is sophie by mirek
19:14:47 <pingou> misc* I meant
19:14:58 <threebean> pingou: can it handle upstream projects with the same name?
19:14:58 <threebean> like the mock library from the python world and the mock tool from the fedora world?
19:15:08 <pingou> http://sophie.zarb.org/
19:15:20 <nirik> there it is: http://oswatershed.org/
19:15:37 <pingou> threebean: name = sa.Column(sa.String(200), primary_key=True) :/
19:15:58 <pingou> nirik: nice
19:16:29 <nirik> dunno if there's anything we could leverage with them or see how they are doing things.
19:16:59 <pingou> https://github.com/tannewt/open-source-watershed/tree/live might help
19:17:51 <nirik> cool.
19:17:57 <nirik> Any other application news?
19:18:07 <misc> pingou: by my roommate, not me :p
19:18:08 <nirik> FYI, we slipped another week for f20... so we will have another week of freeze.
19:18:32 <threebean> ok -- is there someone responsible for updated fedocal with that info?
19:18:48 <nirik> I can update it. (hopefully).
19:18:53 <pingou> you should :)
19:18:55 <nirik> unless someone else would like to. :)
19:19:05 <pingou> I worked some more on nuancier
19:19:21 <pingou> and what I have now I think it quite in line with what the design-team desires
19:19:29 <nirik> nice.
19:19:43 <pingou> nirik: has the old cloud instance for nuancier been cleared?
19:19:55 <nirik> #info nuancier work moving forward for full version.
19:20:00 <nirik> pingou: don't recall.
19:20:13 <pingou> ok, can't seem to log in on it anymore, we'll have to check
19:20:16 <nirik> #action nirik to update fedocal for infrastructure around slips
19:21:01 <pingou> I'll try to set up a dev instance of nuancier to have something to show the design team
19:21:30 <abadger1999> pingou: just want to say, you rock :-)
19:21:42 <nirik> +1 :)
19:21:43 <threebean> #agree pingou rocks
19:21:47 <pingou> abadger1999: just trying to catch up with you all :)
19:22:10 <pingou> (but thanks, you're making me blush)
19:22:39 <pingou> oh in the app news world there is also abadger1999 's work on python-fedora :)
19:23:08 <nirik> oh yeah, where are we there?
19:23:23 <abadger1999> yeah -- it's incomplete but it's a start at making something with a baseclient-like api that uses openid to login to web services.
19:23:37 <abadger1999> The openid-login part has been proven to work.
19:23:53 <pingou> \ó/
19:23:55 <abadger1999> but now we're trying to merge that with baseclient concepts.
19:24:21 <nirik> cool.
19:26:24 <nirik> ok, moving along then.
19:26:34 <nirik> #topic Sysadmin status / discussion
19:26:41 <nirik> lets see....
19:27:01 <nirik> been pretty quiet overall.
19:27:10 <smooge> freeze freeze freeze
19:27:19 <nirik> yeah, cold here. ;)
19:27:23 <threebean> you guys are living the freeze down in CO.  ;)
19:28:05 <nirik> 9F currently
19:28:27 <threebean> hm, so I recently started running a dnssec validator plugin in firefox.  its cool to see that fp.o is enabled and good.
19:28:41 <nirik> yep. ;)
19:28:48 <threebean> I noticed one weird thing though - USER.fedorapeople.org is busted with this in a way I don't understand.
19:29:11 <threebean> not sure if its a known issue or something worth looking into.
19:29:34 <nirik> hum, yeah, thats a wildcard....
19:29:51 <nirik> perhaps something with that zone.
19:30:11 <nirik> I can take a look.
19:30:24 <nirik> anyhow, most sysadmin stuff is on low due to freeze...
19:30:33 <threebean> cool -- I'm curious to see what's up too.  can you ping me when you take a look?
19:30:34 <nirik> I have lots of plans to poke ansible after freeze is over tho. ;)
19:30:38 <nirik> sure.
19:30:52 <nirik> #topic Upcoming Tasks/Items
19:30:52 <nirik> https://apps.fedoraproject.org/calendar/list/infrastructure/
19:31:04 <nirik> I need to update fedocal there... ;)
19:31:13 <nirik> anything upcoming that folks would like to note or schedule?
19:31:50 <nirik> we have holidays coming up. So remember that folks might be away and don't expect speedy replies. :)
19:32:28 <nirik> I expect we will meet next week as normal, but what about the 19th? I'm sure we can skip the 26th. Not sure about the 2nd.
19:32:53 <pingou> https://apps.fedoraproject.org/calendar/meeting/243/ edited
19:32:56 <smooge> I figure Jan 6th we open for business
19:33:14 <nirik> smooge: yeah, I think many folks witll take the 2nd and 3rd off.
19:33:19 <pingou> +1
19:33:41 <smooge> I might be doing so depending on my kids school schedule
19:33:44 <pingou> I won't make it on the 19th fwiw
19:34:28 <nirik> FYI, for rh folks, the 24th to the 31st is shutdown. The 1st is a holiday too.
19:34:55 <nirik> anyhow, we can decide about the 19th and 2nd meetings next week. ;)
19:35:24 <nirik> FYI, I don't have any travel plans, so I should be around the entire time, but during shutdown I might be off playing video games or playing with database replication or something. ;)
19:35:41 <anshprat> :)
19:36:37 <nirik> also, as a heads up, next week I think I am gonna send out an email to infra list to collect big dreams for next year. ;) So, start thinking... what would you love to get done next year?
19:36:46 <pingou> FAS3
19:36:54 * nirik has a long list. ;)
19:37:08 <bitlord> \o/
19:37:15 <Xeladem> :)
19:38:09 <nirik> #topic Open Floor
19:38:22 <nirik> anyone have anything for open floor? comments, suggestions, questions, ideas?
19:38:32 <smooge> LDAP
19:38:40 <smooge> that is all :)
19:39:44 <nirik> I don't know that we could get that done in a year. ;)
19:40:10 <janeznemanic> may I ask something though it's probably a little bit unrelated with this meeting
19:40:23 <nirik> janeznemanic: sure, fire away.
19:40:58 <tflink> network isolation of the qa automation clients
19:41:10 <janeznemanic> well I tried to change my email in fas to gmail but it seems that I can't, is that possible
19:41:11 <tflink> is one thing I'd like to get done in the near future
19:41:30 <nirik> tflink: sounds good.
19:41:40 <nirik> janeznemanic: should work. did it give you any errors? or ?
19:42:21 <smooge> tflink, what do you mean by network isolation.. how much?
19:42:24 <janeznemanic> no I just keep getting emails from trac to hotmail?
19:42:36 <threebean> ah!  the trac email preference is kept outside of fas.
19:42:49 <threebean> janeznemanic: try the 'preferences' menu in the trac instance you're looking at.
19:43:04 <janeznemanic> okey thank you
19:43:37 <threebean> np :)
19:43:58 <tflink> smooge: I want to have the clients isolated to the point where they can't talk with anything that's not on that subnet (if that's the right word)
19:44:48 <tflink> similar to the current qa subnet, just locked down farther
19:45:26 <nirik> tflink: those are all guests on the same virthost right?
19:45:38 <nirik> we could just make it allocate them in a private net?
19:45:54 <tflink> nirik: for the moment, all the beaker clients are on the same virthost, yes
19:46:12 <tflink> but they need to be able to talk to the beaker server and lab controller, which are on a different virthost
19:46:30 <nirik> ok, we can try and sort it out... over in #fedora-admin?
19:47:16 <tflink> sure, that works
19:48:04 <nirik> ok, if nothing else will close out in a few minutes.
19:49:11 <nirik> Thanks for coming everyone!
19:49:14 <nirik> #endmeeting