env_and_stacks
LOGS
16:02:38 <mmaslano> #startmeeting Env and Stacks (2013-12-03)
16:02:38 <zodbot> Meeting started Tue Dec  3 16:02:38 2013 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:49 <mmaslano> #meetingname Env and Stacks
16:02:50 <zodbot> The meeting name has been set to 'env_and_stacks'
16:03:00 <handsome_pirate> Ahoy
16:03:14 <mmaslano> #chair abadger1999 pkovar tjanez samkottler bkabrda handsome_pirate hhorak juhp
16:03:14 <zodbot> Current chairs: abadger1999 bkabrda handsome_pirate hhorak juhp mmaslano pkovar samkottler tjanez
16:03:14 * samkottler is here
16:03:23 <mmaslano> handsome_pirate: hi, I was looking for you. What about wiki pages?
16:03:29 <handsome_pirate> Sorry for the last couple of weeks; I've had a lot of personal stuff going on that's killed my free time
16:03:34 <tjanez> hello
16:03:34 <hhorak> Hi all!
16:03:37 <handsome_pirate> mmaslano:  ^^
16:03:47 <handsome_pirate> mmaslano:  I just haven't had time to do them
16:05:05 <mmaslano> handsome_pirate: okay
16:05:42 <handsome_pirate> mmaslano:  However, that should be cleared up, so I'll have some time again
16:06:01 <drieden> Hello
16:08:50 * pkovar is late
16:09:28 <mmaslano> abadger1999: ?
16:09:31 <mmaslano> are you here?
16:09:42 * abadger1999 here
16:09:53 <mmaslano> #action handsome_pirate will do wiki pages
16:10:04 <mmaslano> #topic init process
16:10:18 <mmaslano> does anyone have a new topic for discussion?
16:10:23 <mmaslano> new goal
16:10:55 <drieden> I have a question about the PRD, is there an outline for it?
16:11:36 <mmaslano> it shouldn't be real PRD, because we won't do a product
16:11:37 <abadger1999> drieden: I do not believe so... we don't really have a PRD as we're not producing a single product like the workstation/server/cloud groups.
16:12:21 <abadger1999> drieden: We may be able to look at what Base is doing for ideas though.... they don't have precisely the same issues but their issues are somewhat similar.
16:12:22 <drieden> abadger1999 okay, but is there a table of contents so we have some idea of the sections which will be in it?
16:13:02 <abadger1999> drieden: Nope.  We have a hard job as we're different than everyone else.
16:13:10 <abadger1999> so we have to come up with all of this from scratch.
16:13:52 <drieden> Perhaps we can use a template and take out the things which don't pertain to us.
16:13:53 <tflink> I have some questions about tooling plans but they can wait for open floor
16:14:17 <drieden> I didn't know if there was a PRD template provided that all groups would be using.
16:15:10 <mmaslano> no template
16:15:43 <abadger1999> drieden: groups are cribbing off of each other... but like I said, since we're not producing a produt.. a lot of what other groups are coming up with doesn't really match up with what we need to write up to clearly define our role.
16:15:49 <drieden> mmaslano Ok.  Do we want to propose a TOC and then we can focus on each section?
16:16:17 <drieden> abadger1999 I realize that, but if we don't have at least a TOC, then it's hard to focus on what we are supposed to provide for the PRD.
16:16:20 <abadger1999> For instance: https://fedoraproject.org/wiki/Cloud_PRD
16:16:41 <mmaslano> drieden: sure
16:16:44 <abadger1999> drieden: Right.  I agree.... but it's up to us to put together the outline/toc/etc.
16:16:56 <drieden> Terrific.  Want to use that and decide what doesn't pertain?
16:17:46 <abadger1999> drieden: basically... section 3 to the end of document don't aply to us.
16:18:34 <abadger1999> (Section 1 & 2 are boilerplate.... who is doing this?  typographic conventions, etc)
16:19:22 <tjanez> abadger1999: I use we could come up with something like section 4
16:19:25 <drieden> I think we also should have a section on "Use Cases".
16:19:34 <tjanez> *use reckon
16:19:35 <drieden> tjanez yes
16:20:23 <tjanez> So, we discussed packaging automation and tools
16:20:39 <tjanez> we could describe the intended audience, use cases
16:20:52 <abadger1999> <nod>  Use cases would be useful
16:21:01 <abadger1999> althought "users" probably not so much
16:21:07 <hhorak> Some particular headlines from Section 1 and 2 seems yet usable for us -- Tracking of Progress, Definitions and Acronyms..
16:21:43 <tjanez> abadger1999: "users" are probably developer, upstream developers, packagers, etc.
16:22:03 <abadger1999> none of that is really meat though.... what are we really working on.
16:22:17 <abadger1999> tjanez: with emphasis on the etc..
16:22:34 <tjanez> abadger1999: Hmm, care to elaborate on that?
16:23:04 <abadger1999> My thinking is that we're going to end up producing many disparate "products" and they might each have a different intended audience.
16:23:35 <mmaslano> our group should create technologies instead of products..
16:23:54 <tjanez> abadger1999, I think I get your point
16:23:54 <handsome_pirate> +1
16:24:46 <tjanez> So our PRD should be centered around topics/technologies and for each of them we should define goals, users, etc.
16:25:01 <abadger1999> Let's say we start working on automated spec review -- audience is: packagers, reviewers, and QA.  OTOH,  when we're working on a Repository for SCLs, our audience is sysadmins and web service developers.
16:26:03 <abadger1999> tjanez: <nod> or more meta than that ... I guess -- a PRD would be setting down some examples of what we're working on.  But we also want to be able to make clear what our scope is.
16:26:51 <abadger1999> does our scope include working on alternate build systems?  Does it include deploying and hosting those?
16:26:51 <drieden> Yes I agree, the scope needs to be clear in the PRD
16:27:09 <abadger1999> What are the points at which we interact with other groups instead of doing it all on our own?
16:27:57 <tjanez> Yes, the scope is crucial since it will establish our place within Fedora
16:28:27 <tjanez> The items/technologies will probably change over time
16:28:32 <abadger1999> tjanez: +1
16:28:53 <mmaslano> abadger1999: we might build some stuff on copr
16:29:27 <abadger1999> mmaslano: Right.  Or the copr+koji merge.  Or something else entirely (if we're thinking of building non-rpms)
16:30:36 <abadger1999> So we might not be thinking about doing any of those now... but we need to state how those are in the scope of this gorup.
16:31:00 <mmaslano> we are discussing what should be doing everytime with no consensus
16:31:09 <mmaslano> shouldn't we discuss actual topics?
16:31:29 <abadger1999> mmaslano: +1
16:31:57 <tjanez> mmaslano, it's sad but you're right
16:32:47 <tjanez> Well, IMO hosting and deploying e.g. new build systems should be better taken care of by some other group, like Fedora Infra
16:33:26 <mmaslano> it would be enough to think about other existing build system
16:34:10 <tjanez> mmaslano, I didn't understand what you meant
16:34:29 <abadger1999> tjanez: +1 -- OTOH, there's definitely something for us there as well... Looking at mattdm's rings, I think that everything outside of the "Fedora Commons" ring comes through us at some point (even if it goes on to another working group later).
16:35:31 <abadger1999> tjanez: so things like "RPM Repository where packages can override things in the base packageset" is something that would be in scope for us to try to implement.
16:35:59 <vpavlin> I think the right way would be to list actual technologies this group should be concerned about and then derive "the scopes" from them.. build systems (copr+koji), help for developers (DevAssistant), help for packagers (automate review tool)...
16:36:08 <abadger1999> but as you say, infra is who would actually host the packages, the buildsystem that builds those, any git repos, etc.
16:36:23 <abadger1999> vpavlin: works for me.
16:36:43 <hhorak> vpavlin: +1
16:36:50 <drieden> vpavlin +1
16:37:02 <abadger1999> So what have we got so far?
16:37:17 <mmaslano> abadger1999: what vpavlin mentioned
16:37:19 <mmaslano> we have nothing more
16:37:25 <abadger1999> #info In scope ecamples: Automated Review tools
16:37:39 <abadger1999> #info In scope example: DevAssistant
16:38:07 <abadger1999> #info In scope example: work on enhancing build systems (copr & koji)
16:38:20 <handsome_pirate> #info In scope example:  Taskotron
16:38:27 <tjanez> I was asking about SCLv2 on the ML. What do you thing of those w.r.t. our scope?
16:38:54 <tjanez> handsome_pirate: Taskotron?
16:38:58 <abadger1999> tflink: This might be a time for you to speak up too.. we seem to be talking a little about tooling.
16:39:17 <abadger1999> tjanez: I think that working on defining them would be in scope.
16:39:25 <pkovar> tjanez: would be great to get some input from jzeleny on that
16:39:44 <handsome_pirate> tjanez:  Automated task system
16:39:44 <abadger1999> tjanez: I also think if we made a new repository for them/SCL-v1 that would also be in scope
16:40:10 <abadger1999> tjanez: Packaging guidelines would need to work with FPC; hosting of any new repository would need to work with infra.
16:40:21 <tflink> I think handsome_pirate is hinting at what I was wondering about - mostly how any automation would fit into all this
16:40:25 <abadger1999> (building of new repositories would need to work with rel-eng)
16:41:16 <abadger1999> So... perhaps work on tooling in general is in scope?
16:41:18 <tflink> and what all I should be planning for and/or keeping in mind
16:41:48 <handsome_pirate> Indeed
16:41:50 <tjanez> tflink, good point
16:42:02 <abadger1999> ie -- one thing in scope for us is working closely with infrastructure/qa/releng to add features to tools, deploy new tools, and scale their manpower?
16:42:35 <tjanez> When we discussed automated package updates, automated QA would be essential for that
16:42:46 <handsome_pirate> abadger1999:  That would be wonderful
16:43:01 <handsome_pirate> abadger1999:  QA's biggest tooling issue is lack of people to work on tools
16:43:03 <abadger1999> #undo
16:43:03 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0xc2f8c10>
16:43:05 <tjanez> abadger1999: I like your wording
16:43:20 <abadger1999> #info In scope example:  Taskotron - Automated task system
16:43:58 <abadger1999> #info In scope example: scale manpower of infra/qa/releng to add features to tools and deploy new tools
16:46:12 <tjanez> Well, another thing we discussed on the ML were Packaging guidelines and the related documentation
16:46:30 <tjanez> What do you think regarding their scope?
16:46:45 <abadger1999> I've been thinking about that over the weekend and I'm a little less enthused about it.
16:47:35 <pkovar> what seems to be the problem?
16:48:07 <tjanez> If people are willing to work on it, then I'd be in favor since they would be in touch with the latest development w.r.t. tooling etc.
16:48:23 <pkovar> i personally think that manpower will be ultimately a deciding factor here
16:48:28 <abadger1999> talking with mattdm it seemed like we would Fedora Commons/mainstream/whatever repository would kinda continue to be what it is presently and we'd be working on enabling new things (including new ways to get Fedora, new things that are fedora).
16:49:20 <abadger1999> Thinking about it... I'm not sure how much we're not really changing the process of packaging guidelines any... so we'd just be adding focus to it.
16:49:43 <tjanez> But we will still need documentation and (emerging) guidelines for the new things?
16:49:45 <abadger1999> So my question would be... is it a distraction?
16:49:54 <abadger1999> tjanez: yes.
16:50:25 <mmaslano> abadger1999: many people told me, they should be improved, they are hard to follow etc.
16:50:28 <abadger1999> tjanez: I was thinking over the weekend, though, that maybe we'd be a bit like EPEL (for some of the new things)
16:50:50 <tjanez> OTOH, I think documentation is just a by-thing, not something core
16:51:22 <abadger1999> tjanez: EPEL's relation to the guidelines is "By default follow the guidelines but we differ in these listed ways: A, B, C[...]"
16:51:43 <mmaslano> pkovar would disagree, documentation is important
16:51:43 <pkovar> abadger1999: that sounds good
16:51:49 <mmaslano> pkovar: :)
16:51:50 <abadger1999> tjanez: I was thinking we could have repos where we say "Follow the guidelines but it's okay to have Conflicts"
16:52:00 <tjanez> abadger1999, I like that
16:52:01 <abadger1999> "Follow the Guidelines but it's okay to bundle libraries"
16:52:05 <abadger1999> etc.
16:52:13 <pkovar> that's actually what we are providing the software collections guide
16:52:25 <pkovar> we document differences
16:52:39 <pkovar> mmaslano: indeed! :-)
16:53:08 <pkovar> s/what/why
16:53:37 <tjanez> I think we came closer to defining the scope of our WG
16:53:40 <abadger1999> mmaslano: I agree with the hard-to-follow and so on... what I'm wondering is whether working on the guidelines within this group is within scope and valuable for this group... or if the group should concentrate on new things and the indivudals in this gorup should work on guideline reorg separately.
16:54:41 <abadger1999> I... don't want us to get bogged down in guidelines reorg if the priority should be to be solving problems relating to creating new repositories and such.
16:55:01 <handsome_pirate> +1
16:55:15 <hhorak> abadger1999: I still think that something like "new spec standards" can be taken as new thing that needs to be developed.. and would be covered under "making life of packagers easier" scope
16:55:40 <pkovar> abadger1999: i think that documentation (not just official guidelines) is important enough to be a part of our primary goals
16:55:58 <hhorak> abadger1999: but I agree it doesn't have to be our priority
16:56:35 <drieden> hhorak: +1
16:56:57 <abadger1999> Sure... I'm not opposed to work on either documenting or coming up with new standards... I'm just throwing out there the quesetoin of whether it should be our priority or not.
16:57:08 <tjanez> I'm also in favor of having less goals and more focus
16:57:42 <samkottler> +1
16:58:01 <pkovar> well, if we want people to start trying/using new things, we need proper docs for that :-)
16:58:03 <hhorak> what about to copy cloud_prd's style -- having primary scopes and secondary scopes?
16:58:34 <abadger1999> and if it's not our priority, then we might as well say, if you have an idea, just go work with FPC/docs on that -- they already exist and are interested in those areas.
16:59:28 <pkovar> abadger1999: i still think our group should be part of that
16:59:47 <pkovar> we want those people to talk to us too
17:00:24 <abadger1999> pkovar: Okay, I'll bite -- what do we add to the equation?
17:01:14 <tjanez> Another thing we should also decide on is the environment part. Mattm talked about desktop environments, etc.
17:01:25 <tjanez> I think they are clearly out of scope
17:01:35 <tjanez> and in the domain of the Workstation WG
17:01:48 <abadger1999> tjanez: Tentative +1.
17:02:07 <mmaslano> tjanez: +1
17:02:19 <handsome_pirate> +1
17:02:19 <abadger1999> I could see us touching that as part of alternate repos providing conflicting/alternate things.
17:03:05 <abadger1999> But as a "We will be producing desktop environments for end users to install".... clearly not us.
17:03:16 <tjanez> Aha, I see, but that would be us providing the means of shipping those things
17:03:29 <tjanez> Not actually caring about the DEs themselves
17:03:44 <abadger1999> tjanez: +1 That's a good way to make the distinction.
17:03:47 <vpavlin> development environment + test environment might be covered by DevAssistant + Docker integration
17:04:11 <samkottler> are there any numbers around devassistant adoption?
17:04:53 <tjanez> On the github.com web-page it says 4.9K downloads
17:05:24 <tjanez> But yea, that doesn't really tell much :-)
17:05:59 * mmaslano needs to go home
17:06:09 <mmaslano> abadger1999: could you chair the rest of the meeting?
17:06:43 <abadger1999> mmaslano: I can close it out -- would you be willing to publish the logs later/tomorrow?
17:06:58 * abadger1999 has a busy day in front of him
17:07:03 <tjanez> vpavlin, I agree with the DevAssistant part
17:07:12 <mmaslano> abadger1999: sure I can
17:07:17 <mmaslano> bye
17:07:28 <handsome_pirate> Peace, y'all
17:07:43 <hhorak> bye
17:07:50 <drieden> bye
17:08:21 <abadger1999> any action items to work on this week?
17:08:43 <drieden> How about a PRD TOC?
17:09:29 <tjanez> And maybe put in some examples of what is (not) in scope from today
17:10:02 <drieden> tjanez +1
17:11:31 <tjanez> We can put it on https://fedoraproject.org/wiki/User:Toshio/Env_and_Stacks_Charter_Brainstorming and them move it to our PRD when we have the Wiki set up
17:12:55 <drieden> tjanez sounds good to me
17:13:11 <drieden> abadger1999 is this okay with you?
17:13:20 <abadger1999> tjanez: Works for me.
17:13:24 <abadger1999> Everyone feel free to edit that.
17:14:09 <abadger1999> #action people to work on outlining the sections of https://fedoraproject.org/wiki/User:Toshio/Env_and_Stacks_Charter_Brainstorming
17:14:35 <abadger1999> Alright, anything else?
17:14:52 <tjanez> When is the deadline for the PRD?
17:16:23 <drieden> tjanez I thought it was in Jan, I'm trying to find the date.
17:17:39 <tjanez> Ok, found it, it's Jan 13 (see: https://fedorahosted.org/fesco/ticket/1196)
17:18:11 <drieden> tjanez Yikes, okay, that's going to come quickly.
17:19:14 <tjanez> drieden, yes
17:19:48 <tjanez> Should we wrap-up this meeting?
17:19:55 <drieden> tjanez +1
17:22:31 <tjanez> abadger1999, care to wrap-up the meeting?
17:22:38 <abadger1999> Yep.
17:22:40 <abadger1999> #endmeeting