env_and_stacks
LOGS
16:04:20 <mmaslano> #startmeeting Env and Stacks (2013-11-19)
16:04:20 <zodbot> Meeting started Tue Nov 19 16:04:20 2013 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:27 <mmaslano> #meetingname env and stacks
16:04:27 <zodbot> The meeting name has been set to 'env_and_stacks'
16:05:37 <mmaslano> #chair abadger1999 pkovar tjanez samkottler bkabrda handsome_pirate hhorak juhp
16:05:37 <zodbot> Current chairs: abadger1999 bkabrda handsome_pirate hhorak juhp mmaslano pkovar samkottler tjanez
16:06:06 <mmaslano> how many people is here?
16:06:14 <hhorak> Hi, I am
16:06:24 <tjanez> hi
16:06:24 <drieden> Hello
16:06:24 * pkovar is here
16:06:27 * sochotni 
16:07:36 <mmaslano> ok, we have some members here
16:07:42 <mmaslano> #topic init process
16:08:01 <mmaslano> let's go through old stuff first
16:08:27 <mmaslano> I admit I forgot to create trac request, I opened a ticket now https://fedorahosted.org/fedora-infrastructure/ticket/4124
16:08:34 <mmaslano> what about wiki pages?
16:09:15 <pkovar> keep them where they are?
16:09:34 <pkovar> i think that other WG are also using fedora wiki, no?
16:10:03 <mmaslano> someone had to create them
16:10:06 <tjanez> I believe handsome_pirate said he'll setup our Wiki page
16:10:14 <tjanez> on Fedora wiki, of course
16:10:32 <mmaslano> I understand he will put content about WG on one place
16:10:33 <pkovar> good, i can help with that
16:10:53 <mmaslano> pkovar: do you want to poke him what's the status or if we have any problem?
16:11:09 * abadger1999 here
16:11:13 <pkovar> sure, will try to hunt him down :-)
16:11:42 <drieden> is handsome_pirate in Westford?  If so, want me to follow up with him?
16:11:43 * abadger1999 nots that "space on the wiki" should just be convention.
16:11:59 <mmaslano> #action pkovar will hunt handsome_pirate for content of WG wiki pages
16:12:15 <mmaslano> drieden: I do not know, where is he located
16:12:17 <abadger1999> with mediawiki, convention is usually like [[Category: Environment and Stacks]]
16:12:50 <abadger1999> but in Fedora, we like using urls like http://fp.o/wiki/Environment and Stacks/*
16:13:15 <mmaslano> #info use urls like  http://fp.o/wiki/Environment and Stacks/*
16:13:28 <abadger1999> mmaslano: We should also use categories.
16:13:44 <abadger1999> as categories have support in mediawiki (like the listing of all pages in the categories)
16:13:52 <mmaslano> #info and categories should use [[Category: Environment and Stacks]]
16:13:59 <mmaslano> abadger1999: feel free to mark it by yourself
16:14:12 <hhorak> maybe put a link to our homepage to https://fedoraproject.org/wiki/Fedora.next
16:17:44 <mmaslano> #info put a link to our homepage to https://fedoraproject.org/wiki/Fedora.next
16:17:49 <mmaslano> more comments to wiki?
16:19:21 <mmaslano> I understand no
16:19:29 <mmaslano> #topic PRD
16:19:41 <mmaslano> let's move what we want to do or should do in our group
16:20:07 <mmaslano> I asked nirik about Formulas - it's sort of dead project, so we can move to next topics :)
16:20:42 <mmaslano> he promised some summary about it, when he has time
16:20:55 <abadger1999> Formulas is good if someone wants to push it.  Otherwise, there's no one to do the work.
16:21:05 * nirik subscribed but hasn't had time to send yet. will try today.
16:21:15 <mmaslano> nirik: thanks
16:21:21 <pkovar> what about stacks 2.0?
16:21:26 <abadger1999> AFAIK, there's no code.  Just an idea about capabilities.
16:21:45 <hhorak> btw. Dev Assistant is a bit similar project to formulas, afaict...
16:22:08 <mmaslano> pkovar: jan is not here, but he told me he'd like to plan scl-utils-2.0 with bigger changes, maybe incompatible. Re-do what we did wrong
16:22:36 <pkovar> ok, sounds interesting
16:23:08 <abadger1999> hhorak: Looks to me like they differ in scope.
16:23:26 <abadger1999> hhorak: formulas could (theoretically) be the technology that enables DevAssistant.
16:23:39 <hhorak> what we can do even now is we can submit RFE bugs for scl-utils if anybody has some ideas for enhancements..
16:23:42 <abadger1999> hhorak: but formulas would be more generic in scope.
16:24:17 <mmaslano> hhorak: yes, we'd like to do some planning meeting what Jan should do in next release
16:24:27 <abadger1999> Is there a timeframe?
16:24:29 <mmaslano> ideas are welcomed
16:24:37 <hhorak> abadger1999: thanks for explanation
16:24:44 <mmaslano> abadger1999: at Friday we will start :)
16:25:00 * abadger1999 thinks it could help with FPC if I could tell them -- identify things that can be changed in scls for scl2.
16:25:26 <abadger1999> takes some of the pressure off when you know that the next version won't have the rough edges that you found in the present one.
16:25:47 <mmaslano> abadger1999: I don't think we see same problems (packagers, fpc)
16:26:06 <mmaslano> abadger1999: could we post the plan on mailing list and comment on it?
16:26:13 <abadger1999> mmaslano: FPC is packagers.
16:26:14 <mmaslano> abadger1999: I guess we can put it on some public wiki
16:26:48 <mmaslano> abadger1999: I'm sorry, I ment scl heavy users has different issues than fpc
16:27:30 <abadger1999> mmaslano: To keep growing who is going to use scls the FPC issues should be addressed.
16:28:09 <mmaslano> abadger1999: as I said post your comments on env and stacks mailing list in short summary
16:28:20 <abadger1999> What comments?
16:28:43 <mmaslano> features?
16:28:48 <abadger1999> ?
16:28:55 <abadger1999> I don't understand the context.
16:29:06 <abadger1999> what do you want posted to the ml?
16:29:37 <mmaslano> abadger1999: you said "identify things that can be changed in scls for scl2". I'm saying ok, post list of those things on mailing list
16:29:43 <abadger1999> ah
16:30:29 <abadger1999> mmaslano: I think we probably need to reach out to the other FPC members.
16:31:01 <abadger1999> timeframe for knowing the requirements, ask if they can determine what issues exist with the current implementation by that time, etc.
16:31:38 <abadger1999> Alternately -- will there be an scls3?
16:32:43 <mmaslano> what should be there?
16:33:45 <abadger1999> Very likely.  The problem is that right now there's only one large user of scls.  As more people start using it for their purposes limitations and issues will crop up that will need to be addressed.
16:34:45 <drieden> It would be helpful to identify these use cases and add them to the prd.
16:34:46 <abadger1999> If scls2 is planned for, say 6 months from now... I don't think that enough people will be using it for fedora packages to identify most of the places where it makes things hard instead of easy for our use case.
16:35:37 <pkovar> drieden: +1. that could also help our documentation efforts
16:36:06 <abadger1999> drieden: Yep -- but I'm saying, it's too early to have identified those well.
16:36:18 <drieden> pkovar Yes, that sounds good.
16:36:43 <drieden> abadger1999 Yes, that makes sense too.  You cannot see into the future.  But if there are things we know of now, it would be helpful to document.
16:36:58 <abadger1999> We/everyone who works on an scls2 should put in the use cases they can think of but there's not enough of us/enough real scl creators to actually do a good job of that at the moment.
16:37:26 <abadger1999> That's why I'm saying, thinking about there being an scls3 would be a good idea.
16:37:53 <abadger1999> ie: we're thinking that this won't be the last opportunity to break compatibility and rethink the capabilities of hte tool.
16:38:02 <abadger1999> so we don't have to get scls2 perfect.
16:38:13 <abadger1999> it just has to be better than scls1
16:38:29 <abadger1999> Does that make sense
16:38:30 <abadger1999> ?
16:38:34 <pkovar> no software is perfect ;-)
16:38:38 <drieden> :)
16:39:03 <abadger1999> pkovar: <nod>  yes.  But sometimes we get (rightfully) more attached to stability and backwards compat than perfection.
16:39:09 <mmaslano> imho it's soon to discuss it
16:39:13 <abadger1999> For instance, rpm :-)
16:39:50 <tjanez> While I like the scls (whichever version :-)), I propose we take a step back and try to identify the "big picture" of our WG first. I think the "Charter" thread on the ML (https://lists.fedoraproject.org/pipermail/env-and-stacks/2013-November/000018.html) was a good start but it died off last week...
16:40:10 <abadger1999> tjanez: +1
16:40:22 <sochotni> tjanez: indeed, not everything is about SCLs
16:40:29 <abadger1999> So one thing in the Charter discussion -- I do not think we should be treading on the FPC ground.
16:40:51 <abadger1999> And I also think we should be careful about creating Guidelines that we want people to follow here.
16:40:52 <drieden> tjanez +1.
16:41:26 <tjanez> abadger1999: Are you referring to my email?
16:41:32 <abadger1999> We should be coming up with guideline drafts here but they should be approved elsewhere.
16:41:43 <abadger1999> tjanez: I think mmaslano's mostly, but yours as well.
16:42:06 <mmaslano> tjanez: I agree with big picture :)
16:42:26 <tjanez> abadger1999, I agree with you and I think we should invent a way to cooperate with FPC
16:42:48 <tjanez> having you on-board makes it easy, though :-)
16:44:01 <tjanez> Well, I would like to iterate our discussion/ideas a little more
16:44:06 <abadger1999> Final discussion, redrafting, and approval of guidelines is something that does require a great deal of attention to precedent and attention to the big picture in Fedora.  Whereas what we seem to be leaning towards is finding out both what does and doesn't work via experimentation with new technologies.
16:44:31 <abadger1999> tjanez: to some extent :-)  But I'm only one committee member.
16:44:48 <mmaslano> abadger1999: I disagree if we use different repository for playing with new things, it could work
16:45:12 <mmaslano> anyway that's not about what WG will do
16:45:43 <tjanez> abadger1999, I mostly agree with you
16:45:47 <abadger1999> mmaslano: I disagree but when we talk about a different repository, I could see having other bodies like FPC that can do guideline redrafting and approval for that repo.
16:46:08 <tjanez> could we say than that our WG is moving faster and is not restricted so much with current guidelines/policies
16:46:14 <mmaslano> in my opinion it slows down development
16:46:27 <abadger1999> mmaslano: also -- a different repository could be a "wild west repository"... ie: (most) anything goes.
16:46:40 <mmaslano> abadger1999: what I understood from Fedora.next proposal, some WGs should have less strict policies or no policies
16:46:52 <abadger1999> and in that sort of repo, I wouldn't have a problem with no guidelines.
16:47:05 <mmaslano> abadger1999: I would be fine with wild west for images, scl2, ...
16:47:33 <tjanez> So our WG is like "incubation" of ideas
16:47:52 <tjanez> and good ideas are then re-iterated and formalized
16:47:53 <abadger1999> mmaslano: I saw that a little different -- we would have some "repositories" with less strict policies.  But those weren't related to the WGs.
16:47:55 <mmaslano> tjanez: that's something to put in PRD :)
16:48:03 <abadger1999> mmaslano: Cool :-)
16:48:37 <abadger1999> mmaslano: So that might be something to put into our charter/prd -- one of the things we want to deliver is anything-goes repositories.
16:48:41 <mmaslano> tjanez: I asked Matt few weeks back, it shouldn't be PRD,because Env and STacks is not a real product. So starting with ideas should be ok
16:49:40 <tjanez> What we still have to do is at least somewhat define the terms environments and stacks
16:49:50 <tjanez> stacks will be easier, I think
16:50:01 <tjanez> since we all have some image of it
16:50:08 <drieden> mmaslano Is there a PRD template that we are supposed to use?
16:50:25 <tjanez> environments (from Matt slides) are not so clear, IMO
16:50:37 <mmaslano> drieden: no, I guess only Workstation has final version of PRD, but we had only list of areas/ideas
16:50:44 * abadger1999 notes -- to organize our thoughts it might be helpful to open a gobby doc.
16:51:00 <hhorak> tjanez: +1 defining the terms also seems essential to me
16:51:22 <tjanez> abadger1999: I haven't used gobby yet, but go ahead, teach us :-)
16:51:31 <drieden> mmaslano Ok.  It might be good to have our outline of what we are going to put into the PRD and then focus on those areas.  The terms is a great thing to have in the PRD.
16:51:43 <abadger1999> yum install gobby
16:52:36 <abadger1999> join session
16:52:44 <abadger1999> Host: gobby.fedoraproject.org
16:52:48 <abadger1999> Port: 6522
16:52:59 <abadger1999> Name: arbitrary to identify you
16:53:12 <abadger1999> It'll ask for a passwd
16:53:18 <mmaslano> drieden: I thought we should discuss items, which Matt mentioned here http://mattdm.org/fedora/next/#24
16:53:27 <abadger1999> You can get that by doing: ssh fedorapeople.org cat /home/fedora/lmacken/gobby
16:53:47 <abadger1999> If you don't have access to fedorapeople/the ssh command doesn't work, I can PM it to you.
16:53:50 <mmaslano> drieden: and add some parts, which are needed by other WGs, like using containers
16:54:57 <drieden> mmaslano thanks, looking now.
16:56:27 <tjanez> Ok, I'm on gobby now
16:58:13 <abadger1999> tjanez: Cool.  I started a doc:Env and Stacks Charter
16:58:34 <tjanez> abadger1999: Yea, I follow you typing live
16:59:18 <drieden> abadger1999 I am unable to get gobby I get permission denied.
16:59:42 <abadger1999> drieden: k.  When trying to connect to gobby.fedoraproject.org?
16:59:48 <tjanez> mmaslano: Regarding our charter and Matt's slide 24, how much into details regarding the implementation details we want to go?
17:00:20 <mmaslano> tjanez: now, high level, abstract.
17:00:28 <mmaslano> tjanez: I don't we need details in Charter
17:00:51 <tjanez> mmaslano: Ok, thanks for clearing that up
17:00:56 <drieden> abadger1999 I can get to gobby.fedoraproject.org.  Permission denied with ssh
17:01:31 <abadger1999> drieden: k.  Private messaging you the gobby.fp.o password.
17:01:42 <tjanez> mmaslano: I'm also in favor of a high-level document
17:03:34 <abadger1999> Okay -- we don't all have access to the gobby package it seems.
17:03:41 <abadger1999> Maybe something like etherpad?
17:03:56 <samkottler> sorry, my TZ's are apparently totally messed up today :(
17:03:59 * abadger1999 figures out where public hosting of that kind of thing is
17:04:00 <mmaslano> etherpad would be fine, if we have some public instance
17:04:16 * abadger1999 found one -- setting up a doc
17:04:53 <abadger1999> http://piratepad.net/PwUiH4MEPR
17:05:07 <abadger1999> Okay, hopefully that works better for everyone.
17:05:27 <abadger1999> Sorry everyone that just got gobby set up :-)
17:07:38 <abadger1999> when I read about env and stacks in mattdm's document... it really seemed like two words to mean the same thing.
17:08:07 <abadger1999> "stacks of software to enable running/developing other software"
17:08:19 <abadger1999> "isolated environments to enable running/developing other software"
17:08:59 <mmaslano> no, see http://mattdm.org/fedora/next/#18
17:09:08 <mmaslano> and  http://mattdm.org/fedora/next/#19
17:09:27 <mmaslano> but it's too cloud centric, we should think bigger :)
17:09:59 <mmaslano> samkottler: do you know where to put cartridges? http://piratepad.net/PwUiH4MEPR
17:10:07 <mmaslano> samkottler: and do you know everything about them?
17:10:40 <samkottler> mmaslano: I wouldn't say *everything* but yeah, I know mostly how they work :)
17:10:59 <samkottler> mmaslano: I think they fall into the environments group
17:11:00 <mmaslano> samkottler: I know a little. It's not clear to me what should we do with them
17:11:05 <samkottler> or in a third category
17:11:19 <samkottler> because they're kind of both the runtime and pull in the software
17:11:23 <samkottler> I would lean toward environments
17:12:01 <abadger1999> mmaslano: <nod>  I can agree with the examples... I just don't know that the separation he makes between them really exists :-)
17:12:01 <mmaslano> samkottler: and how should they change or should they go into some repo, to make them available easier or what?
17:12:31 * abadger1999 is a little hesitant about "desktop environments" but is willing to see where something specific takes that first.
17:12:44 <samkottler> mmaslano: hmm they're expected to be git repos so it doesn't really make sense to package them IMO
17:12:56 <samkottler> although we could work with the openshift folks to figure out a sane way to package them up
17:13:00 <samkottler> which I imagine will be useful for them, too
17:13:17 <samkottler> abadger1999: yeah, we might end up stepping on some toes with that one
17:13:20 <mmaslano> samkottler: so that's probably the goal for cartridges
17:13:26 <hhorak> Having in mind a difference between env. and stacks in a modularity aspect (http://mattdm.org/fedora/next/#17), then cartridges seem more like stacks to me
17:13:28 <abadger1999> samkottler: alternately -- the goal could be to eventually have a Fedora Cartridges git repo.
17:13:41 <abadger1999> ie: the git repos are the "packaging"
17:14:48 <samkottler> abadger1999: true, although I wonder if we're going to overlap too much with the work that the openshift team is doing
17:15:24 <tjanez> hhorak, +1, as I understand OpenShift Cartridges, they are more like stacks
17:15:42 <abadger1999> samkottler: I'm... not sure :-)  I guess Fedora got its start as providing addon packages to RHL that had a known quality to them.
17:15:42 <tjanez> also, Matt put them under Stacks (http://mattdm.org/fedora/next/#19)
17:16:11 <abadger1999> samkottler: And having community (instead of 100% paid people) making and maintaining those packages.
17:16:21 <abadger1999> I could see a similar relationship with the openshift team.
17:16:22 <mmaslano> does it matter? stacks or environment?
17:16:32 <abadger1999> mmaslano: +1 to does not matter :-)
17:16:52 <samkottler> abadger1999: yeah, we should start that conversation with the openshift team, though
17:16:56 <abadger1999> <nod>
17:17:23 <abadger1999> samkottler: So... probably coordination with both inside Fedora Groups and outside Fedora groups is one of our responsibilities?
17:17:27 <samkottler> mmaslano: not really beyond semantics IMO
17:17:57 <abadger1999> (like -- coordinate with openshift team about guidelines and what we provide vs what they provide.  Coordinate withh infra for being able to host a git repo for cartridges)
17:18:42 <samkottler> abadger1999: I'm not a huge fan of using fedorahosted for this, though
17:19:11 <abadger1999> samkottler: yeah, I.... am not sure fedorahosted is a good fit.
17:19:26 <abadger1999> samkottler: But wouldn't that be something we coordinate with infra?
17:19:48 <samkottler> abadger1999: yep, I just suspect that FH will be the first suggestion for where it should live :)
17:21:28 <abadger1999> Us: "We need git repos for hosting experimental openshift cartridges with the eventual goal of providing them similar to how we provide yum repositories".  Infra: "We currently have git hosting via fedorahosted" Us: "Once we get to $Size or $Officialness or $Other we probably want something more that satisfies those needs better"
17:21:44 <abadger1999> Infra: "Okay, let's talk about budget and timeframe for that"
17:22:08 <abadger1999> samkottler: something like that is how I suspect it might go?  Sound reasonable?
17:22:19 <samkottler> abadger1999: yep, WFM
17:27:36 * tjanez will have another meeting in 3 minutes
17:28:12 <mmaslano> abadger1999: I'm also leaving
17:28:19 <abadger1999> tjanez: Note -- we might want to implement the "definitely conflicts with pacaging guidelines" packages in a separate repo from the "experimental but aimed at eventually coming from the main fedora repos"
17:28:25 <abadger1999> as separate repositories.
17:28:31 <mmaslano> abadger1999: could you chair rest of the meeting or I can end meeting in few minutes
17:28:45 <abadger1999> mmaslano: I'm okay to end
17:29:04 <abadger1999> mmaslano: what do we want to do to continue the charter work this week?
17:29:37 <abadger1999> I can paste what we have into a wiki page.
17:29:59 <abadger1999> But people will need to add things to it if we expect it to see progress this week :-)
17:30:14 <tjanez> abadger1999: +1 regarding the eventually coming from the main Fedora repos
17:30:16 <mmaslano> abadger1999: we can continue on the piratepad, but please do backup :)
17:30:41 <abadger1999> mmaslano: Roger -- I'll copy to a wiki page after the meeting
17:31:11 <abadger1999> And set a reminder to check the piratepad later this week for updates.
17:31:54 <abadger1999> mmaslano: what should people do this week to move this forward?
17:32:37 <mmaslano> abadger1999: continue with proposal?
17:33:12 <abadger1999> mmaslano: Right :-)  I mean -- what should people actually focus on doing?
17:33:55 <mmaslano> probably on their area of expertise :) which is bad because cartridges, containers, ... not so many people
17:34:34 <mmaslano> but they can add also their ideas from their area if it fits into big plan of WG
17:34:36 <abadger1999> Something like: "Everyone send one general thing they want the WG to enable and one specific thing they'd personally want to work on to the mailing list this week"
17:35:21 <mmaslano> abadger1999: +1
17:35:40 <hhorak> and all can start learning something about cartridges..
17:36:58 <pkovar> sounds good to me
17:37:26 <abadger1999> Cool.
17:37:30 <drieden> sounds good to me too
17:37:43 <tjanez> abadger1999: +1 on making thing go forward
17:37:44 <abadger1999> #action everyone to send one general thing they want the WG to enable and one specific thing they'd personally want to work on to the mailing list this week
17:39:00 <abadger1999> we'll work on fitting those into the charter draft and maybe what we're going to actually start working on in January based on those.
17:41:10 <mmaslano> I'll close meeting in one minute
17:42:31 <hhorak> So, see you everyone!
17:42:38 <samkottler> cya!
17:42:49 <drieden> bye bye
17:42:51 <pkovar> bye
17:43:04 <mmaslano> #endmeeting