fedora-qa
LOGS
16:00:52 <kparal> #startmeeting Fedora QA meeting
16:00:52 <zodbot> Meeting started Mon Nov 11 16:00:52 2013 UTC.  The chair is kparal. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:52 <kparal> #meetingname fedora-qa
16:00:52 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:00 <kparal> #topic Roll Call
16:01:05 <kparal> who's here?
16:01:21 * satellit listening
16:01:41 * mkrizek_ is here
16:02:07 * jreznik is lurking
16:02:15 * pschindl is here
16:02:53 * kparal pokes tflink and roshi
16:03:23 * tflink is here
16:03:27 * Viking-Ice is here
16:03:38 <kparal> #chair pschindl tflink roshi
16:03:38 <zodbot> Current chairs: kparal pschindl roshi tflink
16:03:40 * roshi is here
16:04:34 <kparal> let's roll
16:04:38 <kparal> #topic Previous meeting follow-up
16:04:50 <kparal> "     viking-ice to check his possible resize issue in at least TC6 (ideally RC2) "
16:05:09 <kparal> there's bug number (bad bad adamw), but since we release Beta I guess we're good
16:05:11 <Viking-Ice> not much happened in that regard since I was dealing with death in the family
16:05:13 <kparal> *no bug number
16:05:24 <kparal> Viking-Ice: sorry to hear that
16:05:43 <kparal> Viking-Ice: what's the bug number?
16:05:46 <Viking-Ice> kparal, thans
16:05:49 <Viking-Ice> mean thanks
16:05:51 <Viking-Ice> no bug number
16:06:10 <Viking-Ice> I did not get around to duplicate the issue I encounter from tc5
16:06:16 <kparal> ok, understood
16:06:26 <kparal> do you want to keep the action item?
16:06:51 <Viking-Ice> yeah this is a final blocker for sure ( and would have been a beta blocker ) if still present
16:08:09 <kparal> #info viking-ice to check his possible resize issue in at least TC6 (ideally RC2) - not reported yet, Viking-Ice will try to reproduce and report it this week
16:08:27 <kparal> #action viking-ice to check his possible resize issue in at least TC6 (ideally RC5)
16:08:43 <kparal> ok, that's all from last week
16:08:45 <kparal> moving on
16:08:56 <kparal> #topic Fedora 20 Beta retrospective
16:09:23 <kparal> #info adamw already sent an announcement to test-announce names "Fedora 20 QA Retrospective page is up"
16:09:57 <kparal> the words of the classic say: "We use the retrospective page to track things that went well and things
16:09:57 <kparal> that didn't go so well during the Fedora 20 validation process, and for
16:09:57 <kparal> tracking ideas we have but don't have time to act on during the rush of
16:09:57 <kparal> doing validation (that's the wishlist).
16:09:57 <kparal> Please, add any feedback you have of this type to the retrospective
16:09:59 <kparal> page! There are instructions on the page for adding feedback."
16:10:26 <kparal> do you have anything Beta-related that you would like to discuss here and now?
16:10:46 <tflink> how's the commonbugs page coming?
16:11:22 <kparal> let's see https://fedoraproject.org/wiki/Common_F20_bugs
16:11:52 <kparal> not updated in a month
16:12:02 <jreznik> resize bugs should be added there at least
16:12:11 * satellit update the non-blocking tests for sugar-desktop and soas. I added an external link to some suggestions
16:12:16 <kparal> a lot of bugs not yet documented: http://bit.ly/fedora-commonbugs-proposed
16:12:39 <kparal> #info CommonsBugs page is not up-to-day, any help would be welcome
16:13:19 <kparal> does somebody feel like having an action item for this? :)
16:14:09 * tflink volunteers roshi
16:14:21 <kparal> eggscelent!
16:14:26 <roshi> works for me
16:14:40 <kparal> #action roshi to help out adamw with CommonsBugs page
16:14:43 <roshi> it was on the list of things to work on :)
16:14:44 <kparal> thanks, roshi
16:15:38 <kparal> pschindl: remind me to ask our interns to help out as well if needed
16:15:49 <pschindl> kparal: ok
16:15:49 * satellit that link is here https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_RC5_Desktop#Non_release-blocking_desktops:_x86_.2F_x86_64
16:15:53 <tflink> btw, it should really be done before tomorrow
16:16:10 <kparal> hmm, right, tomorrow is the release day, right?
16:16:13 <tflink> yep
16:16:28 <roshi> ok
16:16:31 <kparal> ok, no interns then
16:17:14 <kparal> robatino: maybe you'd like to discuss your proposal of forwarding FEs into the next milestone?
16:17:26 <kparal> kind of related
16:17:39 <robatino> i thought it should be on the mailing list?
16:17:59 <Viking-Ice> why should we not do that ?
16:18:07 <kparal> the last email I saw was roshi proposing a vote in the meeting
16:19:10 <Viking-Ice> FE's are FE's there is nothing wrong with moving them between milestones it's not like we are obligated to pull them in, in that next milestone anyway
16:19:40 <jreznik> but once on the list, especially auto generated list put into the ticket...
16:19:43 <kparal> the question was whether to move them to accepted or proposed state for the next milestone
16:20:07 <robatino> all blockers and FEs are regularly re-evaluated anyway, correct? seems like the risk is minimal, especially since if they're automatically promoted, it would be at the beginning of the next stage
16:20:10 <jreznik> kparal: proposed - I don't have any objection
16:20:45 <tflink> we don't always review the proposed FEs, though. my only concern would be if the list got huge
16:20:56 <kparal> I think roshi has a good point that between Alpha-Beta it is not that risky and we could auto-accepted. but for Final, I wouldn't recommend this
16:21:04 <jreznik> bigger issue I'd say are that bugs that were swaying from being blocker, not being blocker, then forgotten, popping for several other releases...
16:21:30 <Viking-Ice> tflink, huge list == longer meeting time ;)
16:21:57 <Viking-Ice> + I think this or next release cycle we be the last as we know it anyway
16:22:21 <roshi> yeah - fedora.next is going to change things
16:22:23 <Viking-Ice> after that main focus will be on whatever baseOS picks decides
16:22:33 <kparal> robatino: as far as I know, we don't spend time with acceptedFEs during blocker review meetings. so it's usually adamw's call when creating the request
16:23:23 <kparal> so, I give +1 to roshi's reply in that thread
16:24:14 <kparal> if more people want to voice their opinion, please do that in that thread
16:24:50 <kparal> alright
16:25:06 <kparal> let's move
16:25:10 <kparal> #topic Fedora 20 Final planning
16:25:36 <kparal> it seems we should receive first Final compose tomorrow
16:25:47 <Viking-Ice> that's fast
16:25:52 <kparal> http://fedorapeople.org/groups/schedule/f-20/f-20-quality-tasks.html
16:26:00 <tflink> they took a week off of final
16:26:06 <Viking-Ice> no rest for the wicked ay
16:26:12 <tflink> er, moved final freeze back one week
16:26:13 <kparal> but I haven't seen any compose request, or maybe adamw hasn't subscribed me
16:26:23 <Viking-Ice> tflink, not forward
16:26:24 <kparal> so, I don't know if it's going to happen
16:26:28 <Viking-Ice> who's bright idea was that
16:26:32 <Viking-Ice> jreznik, you?
16:26:39 <kparal> the go/nogo is Thu 2013-12-05
16:26:56 <kparal> so, 3 weeks and a bit
16:27:14 <jreznik> Viking-Ice: everyones from the go/no-go, actually I was not as sure about that but...
16:27:17 <kparal> #info FESCo approved a week shorter schedule for Final
16:27:51 <kparal> Viking-Ice: if we slip, we slip. nothing changes in that regard
16:28:07 <kparal> in that distant possibility that we have no blocker, we release before Christmas
16:28:11 <kparal> would be definitely nice
16:28:12 <jreznik> with this decision, TCs should come really early, so anyone to file the request?
16:28:28 <jreznik> kparal: would be nice, really...
16:28:43 <Viking-Ice> let's call that yule or winter solstice christmas is fake and filled with coca cola santas around the world
16:28:52 <sgallagh> kparal: For clarity, we approved the shorter schedule to avoid the holidays. If any slip occurs, it means the release must come after the new year.
16:29:01 <tflink> I don't think there's a point in filing the TC request before stuff moves from updates-testing to stable
16:29:08 <kparal> sgallagh: thanks for clarification
16:29:22 <jreznik> tflink: yep, that was the question how far we are
16:29:27 <kparal> since adamw is out today, does somebody have experience with filing compose requests? does somebody want to take it?
16:29:29 <Viking-Ice> sgallagh, slipping past new year would have been betterr
16:29:39 <Viking-Ice> no point in stressing everyone in QA
16:29:43 <tflink> infra doesn't unfreeze until tomorrow, so a push won't happen until then
16:29:51 <tflink> infra/releng
16:29:56 <sgallagh> Viking-Ice: Isn't stress part of the job description? (kidding)
16:30:14 <Viking-Ice> kparal, the workflow for that seemed to be utterly borken
16:30:18 <tflink> has anyone talked to the anaconda devs on whether moving things up is practical?
16:30:29 * tflink is thinking about the resize-happy-fun-time stuff
16:30:40 <Viking-Ice> it looked like the same infra ticket was always re-used
16:30:49 <kparal> #info releng unfreezes tomorrow, the compose request serves no purpose today
16:30:58 <Viking-Ice> mean releng ticket
16:31:07 <pschindl> tflink: I talked to vpodzime and he looked quite happy about that
16:31:09 <tflink> if that code isn't going to be done in time, moving freeze up is just going to create churn and other PITA activities
16:31:11 <jreznik> tflink: well, that resize stuff is pretty bad but before we knew it, fesco already changed schedule and people on go/no-go were still in favour of it
16:31:39 <kparal> #info final change deadline is now 2013-11-26
16:31:43 <jreznik> tflink: for anaconda - I'd say there's no big difference - it's always post freeze work
16:32:01 <tflink> jreznik: just more pressure for them and more churn for the rest of us
16:32:27 * nirik tries to read up, but notes that updates is already flowing. We unfreze them after all the items from the beta were in stable.
16:32:27 <kparal> so, if there's no point in creating the request today, I'll create an action point for adamw to create it tomorrow (or once everything is ready)
16:32:40 <jreznik> tflink: well, I asked on the go/no-go if we still want to proceed with that change, nobody objected even knew about the resize issues
16:33:10 * tflink should have been paying better attention
16:33:14 <kparal> nirik: so, can Final TC1 compose start happening today?
16:33:19 <tflink> oh well, same old, same old, I guess :-/
16:33:34 <nirik> kparal: I suppose it could, sure.
16:33:57 * Viking-Ice should have attended that meeting but death and all...
16:34:01 <kparal> #info correction: Final TC1 compose can be fired off today
16:35:01 <kparal> so, who wants to create the ticket?
16:35:01 <jreznik> Viking-Ice: compared to real life happening, this is just Fedora
16:35:25 <kparal> https://fedorahosted.org/rel-eng/ticket/5787 seems to cover only Beta, a new ticket should be created for Final
16:35:43 <tflink> correct, we create new releng tickets for each milestone
16:36:16 <jreznik> sgallagh: btw. the agreement was - if Beta slips one more, we will aim next year, otherwise it would be non-sense one slip = new year for final as we short it a bit just to gain this one week as buffer... but we agreed not to try to release a christamas gift :)
16:36:54 <kparal> tflink: roshi: can one of you take this please? I guess guys from CZ want to disconnect asap
16:37:16 <tflink> kparal: unless pschindl wants to do it
16:37:17 <jreznik> btw. for the question why I reopened the Beta ticket - with dennis, we agreed that for transparency and trackability, we want it to be stated somewhere and ticket looked like a good candidate
16:37:56 <roshi> sure, I can take it
16:38:16 <pschindl> tflink: I won't be near my computer this evening. So not today :(
16:38:24 <kparal> roshi: thanks again
16:38:39 <kparal> #action roshi to file Final TC1 compose request
16:38:51 <roshi> no problem
16:38:53 <roshi> :)
16:39:00 <kparal> roshi: please fill the same CC as in the Beta ticket
16:39:10 <roshi> will do
16:39:41 <kparal> ok, anything else regarding Final schedule?
16:40:31 <kparal> #topic Fedora.next thoughts so far
16:40:42 <kparal> the agenda says: "     The fedora.next proposal has been moving along quite rapidly, and we haven't yet come up with any kind of formal evaluation or plan for input into the WGs "
16:40:54 <kparal> unfortunately, I haven't followed WGs closely
16:41:03 <tflink> has anyone been keeping up with all the WGs?
16:41:06 <kparal> anyone can say something interesting?
16:41:09 <Viking-Ice> for the most part
16:41:25 * jreznik is trying to follow up with WGs
16:41:43 <Viking-Ice> things are just progressing on the path one ( or at least I ) expected
16:42:19 <kparal> Viking-Ice: do you have some comments related to QA field?
16:42:26 <jreznik> but we as Base WG have the same issue - we need input from other WGs/groups so we probably need some sort of higher level group consisting from WGs members, QA and other teams for coordination
16:42:32 <Viking-Ice> kparal, things are no where there yet
16:42:55 <Viking-Ice> kparal, but each WG will have to handle that anyway for their "products"
16:43:00 <jreznik> so how would QA feel about being part of this group? not sure about how to implement it, but definitely worth discussion
16:43:11 <Viking-Ice> we focus only on core/base
16:43:31 <kparal> jreznik: does it have to be a formal group with regular meetings, or can we just set some time and meet to discuss stuff?
16:43:43 <jreznik> Viking-Ice: that's the question - I think teams like QA, design etc. should back up all the products as a service for them
16:43:45 <Viking-Ice> jreznik, what are you proposing exactly
16:44:18 <tflink> "qaaas" :)
16:44:26 <jreznik> Viking-Ice: I'm not sure - see what kparal asked, how formal it would be, regular or on demand... but at least in the beginning all parties should be in touch regularly
16:44:51 <Viking-Ice> jreznik, we arent' going to be backing up anything officially or provide resources explicitly to those groups
16:44:57 * jreznik is asking people what they think about it before doing formal proposal to board/fesco
16:45:18 <Viking-Ice> they willl reach out into these communities and ask for assistance if no responds to that they have to do the work themselves
16:45:58 <jreznik> Viking-Ice: why? I think it's the only way how we can succeed... share as much resources, do not fragment more than needed
16:46:11 <Viking-Ice> jreznik, because we dont have any resources to share
16:46:23 <Viking-Ice> and we should not do that explicitly
16:47:00 <Viking-Ice> sub-communities need to stand on their own feed and wg's are nothing more then sub-communites ( just with a bit of direction )
16:47:33 <kparal> jreznik: personally I'm afraid I don't have time to sit in yet another committee / discussion group / something. but if we set up a time for multiple teams to meet and discuss the problems, I would probably attend. and I guess other QA members as well
16:47:46 <kparal> maybe start with one-shot meetings?
16:47:48 <tflink> yeah, the timing of this isn't great
16:48:08 <jreznik> Viking-Ice: for this, we don't have resources :)
16:48:22 <jreznik> kparal: that's my concern about overcommiting people
16:48:30 * nirik thinks it's hard to talk about QA'ing something where we don't yet know whats being produced/delivered.
16:48:43 <Viking-Ice> jreznik, I think tflink or adamw pointed that out at flock
16:49:06 <Viking-Ice> matt promised to pull a rabbit out  of hat and spawn resources like a wild fire
16:49:20 <tflink> Viking-Ice: I don't remember the conversation going quite like that
16:49:21 <jreznik> but at least for initial picture where we stand, it would be great to meet - at least that one shot, everyone has some expectations he assume :)
16:51:11 <Viking-Ice> jreznik, that things and how they stand are simple RH product manager magically thought hey could tap into QA resources to handle this failing to understand those resources dont exist
16:51:19 * jreznik will try to propose it this week, just would like to speak with more people to get a clue how to make it... mostly it seems, people are in favor of it
16:51:40 <kparal> #info jreznik from Base WG would like to arrange a meeting with other teams members to discuss the future processes
16:52:05 <Viking-Ice> I've been trying to get some goddam answers from the anconda people what they can or cannot so we can find space to handle multiple "products" but getting answer from them is like pulling a candy from a baby
16:52:12 <jreznik> Viking-Ice: agree, something I'm trying to tell people here, just there are no PM involved :)
16:52:29 <Viking-Ice> jreznik, I will be going head against the baseWG with my FedoraOS proposal
16:52:59 <jreznik> Viking-Ice: share it pls :)
16:53:07 <Viking-Ice> when it's ready
16:53:52 <jreznik> Viking-Ice: when it's ready is late as WGs are progressing
16:54:29 <Viking-Ice> jreznik, well I asked FESCO to hold the presses until I could present it to the community
16:54:42 <Viking-Ice> and they rickrolled me apparently
16:54:58 <jreznik> we are bit OT now
16:55:09 * tflink has a couple of things for open floor
16:55:24 <jreznik> but you know, showing stuff early make sense in communities
16:55:54 <kparal> alright, anything else to add?
16:56:21 <kparal> #topic Open floor
16:56:43 <kparal> tflink: what do you have?
16:56:47 <tflink> as a heads up, we're going to be doing a new blockerbugs release soon (hopefully in the next several days)
16:56:57 <Viking-Ice> jreznik, being allowed to come up with alternative proposal otthen RH product manager living in their ivory tower in phonex tossing prd's which arent applicable to open community between themselves makes no sense but here we are...
16:57:06 <kparal> #info a new blockerbugs app release will happen soon
16:57:18 <tflink> it should be pretty transparent, but the login mechanism has changed and a few minor-looking changes came in
16:57:38 <tflink> the biggest thing is the API support from GSoC
16:57:51 <kparal> tflink: do we already have some consumer?
16:58:05 <jreznik> Viking-Ice: RH product managers don't touch Fedora at all :)
16:58:10 * pschindl has to leave.
16:58:16 <kparal> pschindl: see you
16:58:24 <tflink> kparal: that ended up not happening for GSoC and nobody's written anything yet
16:58:33 <kparal> ok
16:58:34 <tflink> should be pretty easy, though
16:58:59 <kparal> #info blockerbugs app will have an API
16:59:07 <tflink> the other thing is that taskbot is going to be getting a name change
16:59:22 <Viking-Ice> jreznik, and applying prd's ( without mrd's  ) just appeared from nowhere aha
16:59:29 <kparal> we had the old one for way too long :)
16:59:40 <tflink> the name 'taskbot' did not get approval from legal, so we're going to be changing to 'taskotron'
16:59:50 <tflink> which does have approval from legal
17:00:16 <kparal> heh. doesn't that violate the Tron brand? :)
17:00:16 <jreznik> taskotron :)
17:00:33 <tflink> kparal: well, legal did approve the use of the name :)
17:00:41 <kparal> #info taskbot will be renamed to taskotron to avoid name trademark clashes
17:00:50 <jreznik> kparal: you can say it comes from cyclotron :)
17:01:16 <tflink> fortunately, we got this taken care of before anything got into production
17:01:25 <tflink> so a pain, but it could have been so much worse :)
17:01:36 <kparal> taskotron is cool, love it :)
17:02:02 * kparal needs to check english pronunciation, however
17:02:26 * jreznik should leave now to move home before another late evening meeting...
17:02:36 <kparal> jreznik: thanks for coming
17:02:42 <kparal> tflink: anything else?
17:02:46 <kparal> or anyone?
17:02:49 <tflink> nope, that was it
17:03:23 <kparal> ok, thanks for coming, everyone
17:03:34 <kparal> #endmeeting