fesco
LOGS
18:01:19 <notting> #startmeeting FESCO (2013-10-30)
18:01:19 <zodbot> Meeting started Wed Oct 30 18:01:19 2013 UTC.  The chair is notting. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:22 <mitr> Hello
18:01:26 <notting> #meetingname fesco
18:01:26 <zodbot> The meeting name has been set to 'fesco'
18:01:26 <notting> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:01:26 <notting> #topic init process
18:01:26 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:01:28 <nirik> hey.
18:01:35 * nirik runs to get coffee, back in a minute
18:01:46 * mattdm has coffee in hand
18:02:11 <sgallagh> I'm around; closing out the Server WG meeting
18:02:31 <mattdm> I'll be leaving in 55 minutes to start the cloud wg meeting :)
18:03:19 <pjones> hello.
18:03:33 * abadger1999 shows up
18:03:42 <pjones> mattdm: sgallagh: so this is becoming an increasingly bad time slot then, eh?
18:04:05 <sgallagh> pjones: It works for me; I like having an upper limit on the Server WG slot
18:04:10 <mattdm> pjones or we could keep this meeting to an hour :)
18:04:19 <notting> is that everyone except mmaslano?
18:04:27 <notting> looks like it
18:04:30 <mattdm> but for the cloud wg, this week probably isn't representative
18:04:46 <mattdm> (not sure if we will even be able to find a regular time)
18:05:21 <mmaslano> hi
18:05:43 <nirik> also, US changes time next week...
18:05:44 <notting> ok, i believe that's everyone.
18:05:45 <sgallagh> Before we get started.
18:05:52 <sgallagh> nirik: beat me to it
18:06:33 <abadger1999> (and eu changed already)
18:06:43 <notting> is everyone ok with the meeting staying at 1800UTC , with their local time shifted back?
18:06:51 <t8m> I am ok with that
18:06:57 <t8m> actually I prefer that
18:07:13 <nirik> sure.
18:07:17 * nirik hates timezones
18:07:44 <mattdm> i slightly prefer the later time but either works
18:07:48 <abadger1999> Works for me.
18:07:50 <mmaslano> yeah, it's okay
18:07:56 * t8m hates DST
18:08:01 <sgallagh> So that moves it to 1:00 EDT next week?
18:08:05 <sgallagh> err, EST
18:08:11 <nirik> if we stay at 18UTC, we might ask the server and cloud WG's to also stay if they don't want to overlap
18:08:23 <pjones> sgallagh: right
18:08:29 <pjones> t8m: don't we all
18:08:36 <sgallagh> In the case of the Server WG, we're going to do another WhenIsGood in any case
18:08:42 <mattdm> Ditto
18:08:45 <t8m> pjones, sure :)
18:09:01 <mattdm> (with the distinct possibility of NothingIsGood)
18:09:15 <abadger1999> mmaslano: speaking of WG meetings, we haven't arranged an Env and Stacks meeting yet, have we?
18:09:30 <handsome_pirate> abadger1999:  Working on it
18:09:31 <jwb> workstation wg is going to just avoid live meetings for the time being
18:09:39 <notting> proposal: keep meeting at 1800UTC until further notice
18:09:43 <mmaslano> abadger1999: just writing email
18:09:43 <abadger1999> Cool.  Just making sure I didn't miss any announcements.
18:09:43 <nirik> +1
18:09:48 <t8m> notting, +1
18:10:04 <mitr> +1
18:10:05 <sgallagh> notting: +1
18:10:08 <abadger1999> +1
18:10:19 <mattdm> +1
18:10:48 <pjones> +1
18:11:09 <mmaslano> +!
18:11:21 <notting> #agreed meeting stays at 1800UTC until further notice (+:9)
18:11:43 <notting> ok, ye olde business
18:11:47 <notting> #topic #1170 Working Group call for volunteers
18:11:47 <notting> .fesco 1170
18:11:48 <zodbot> notting: #1170 (Working Group call for Volunteers) – FESCo - https://fedorahosted.org/fesco/ticket/1170
18:11:49 <pjones> that actually makes my wednesday schedule /way/ easier.
18:12:16 <mattdm> just as long as meetings don't still go to 2030UTC :)
18:12:34 <nirik> ok, on this we need to approve the base design group?
18:12:35 <mattdm> I think we can close the call-for-volunteers ticket
18:12:40 <mattdm> oh wait that. :)
18:13:00 <sgallagh> Ok, as noted on the mailing list, jwb isn't insistent on his membership and I'd kind of like to see Lennart on board here.
18:13:26 <nirik> well, what does pknirsch think?
18:13:32 <jwb> unknown
18:13:52 <pknirsch> i'd be fine with that
18:14:00 <jwb> ah, good.  pknirsch is here
18:14:05 <pknirsch> ofc :)
18:14:20 <Viking-Ice> he must have his own reason for not choosing him and bunch of other people one might have expected there
18:14:20 <pknirsch> sorry, was just lurking and doing other stuff on the side
18:14:28 <pknirsch> the idea was to have either Harald or Lennart on the group
18:14:31 <mitr> With the "This is the common base on which the Fedora OS products will be built. " wording it's not clear to me that systemd is a core aspect - I'd rather have the toolchain and basic libraries as the fox (I know others have a different opinion)
18:14:48 <jwb> er
18:14:50 <mitr> s/fox/focus/
18:15:06 <jwb> i fail to see how the init process isn't part of the core aspect of the OS, particularly given it's current place
18:15:20 <jwb> and the role it will play with cgroups going forward
18:15:24 <sgallagh> As well as its ever-increasing roles
18:15:29 <mattdm> yeah, I'm pretty sure we need systemd there
18:15:43 <pjones> I don't really see any way systemd wouldn't be part of it, but that's not what's important here.
18:15:43 <nirik> well, harald is already there too...
18:15:49 <mitr> jwb: Booting a localized implementation detail, same as KMS for display is.  (cgropus are another matter)
18:15:55 <pknirsch> or as lennart calls it: "Das PID Eins" hihiihih
18:15:57 <abadger1999> nirik: <nod>
18:15:57 <t8m> mitr, +1
18:15:58 <pjones> the question is: do we have people familiar with the sort of problems the group will face
18:16:10 <nirik> but note also that this is just voting members, I surely expect involved people to be... well, involved.
18:16:21 <mattdm> +1 pjones, also +1 nirik
18:16:23 <jwb> mitr, if that's your perspective, i think you've clearly missed what is going on in fedora for the past 5 releases
18:16:41 <jwb> systemd has increased scope.  ignoring that as "implemenation detail" is disingenuous
18:16:58 <nirik> anyhow, pknirsch: would you like to amend the proposal base group any? or leave it as mentioned in the ticket?
18:17:13 <mitr> jwb: In my view, the APIs that are a part of the increased scope are important - the fact that it is tied to systemd isn't
18:17:17 <nirik> s/has increased/continues to increase/ ;)
18:17:42 <mitr> Anyway, I'll not be voting if there is a vote.
18:17:57 <sgallagh> Proposal: Substitute Lennart for Josh, accept the rest as-is?
18:18:03 <jwb> mitr, sure.  and the APIs amazon provides are important to cloud development.  but amazon is just an implemenation detail.
18:18:10 <abadger1999> mitr: I think that may be a fine long-term distinction.  short term, they're probably equivalent (we're still i nthe stage where we are growing the apis along with a single implementation).
18:18:12 <pjones> personally, I would have liked to se lennart on this list, but I do think the current list is pretty good.
18:18:14 <notting> sgallagh: would prefer that proposal come from pknirsch
18:18:17 <nirik> sgallagh: -1
18:18:19 <mitr> jwb: "Booting" is an implementation detail, not the APIs
18:18:21 <nirik> what notting said.
18:18:27 * jwb just shuts up
18:18:43 <mitr> sgallagh: 0
18:19:07 <pjones> pknirsch: so, what say ye?
18:19:37 <pknirsch> well, whats the reason against harald? I know lennart is leading the systemd development, but kay is doing udev and harald is dracut, all of which would be essential, too
18:19:41 <pknirsch> same goes for anaconda
18:19:44 <notting> i guess i would say i, as fesco member ,would approve the list  both as is, or with s/jwb/lennart/.
18:20:01 <sgallagh> pknirsch: No one said anything against (well, anyone).
18:20:04 <nirik> yeah, me too.
18:20:34 <pknirsch> don't get me wrong, i have nothing against lennart, but harald can cover the topics just as well imho
18:20:58 <mmaslano> pknirsch: don't you miss someone from security?
18:20:59 <sgallagh> I'm -1 as-is, but not because I don't like jwb :) I just think that the guy who's doing all of the work should have a say.
18:21:14 <mitr> mmaslano: Dan walsh
18:21:18 <mmaslano> it's not clear to me which area will be covered by Base, so it's hard to say, whoshould be there
18:21:21 * nirik does feel a little annoyed at lennarts reaction to not being chosen in the first place, but perhaps thats just me.
18:21:23 <mmaslano> okay
18:21:33 <pknirsch> so especially sgallagh, what are your reasons for wanting lennart on the team
18:21:35 <pknirsch> ?
18:21:41 <pjones> sgallagh: hopefully nobody is doing /all/ the work.  and as pknirsch rightly pointed out, there's more than just systemd involved.
18:21:44 * abadger1999 would like to see jwb on there as the kernel guy
18:21:58 <pjones> sgallagh: also hopefully skilled, involved people will have /a say/ even if they don't get /a vote/.
18:22:06 <jwb> abadger1999, i'll still do the kernel thing either way.  my involvement doesn't hinge on voting
18:22:12 <abadger1999> <nod>
18:22:12 * pknirsch nods
18:22:13 <jwb> so i'm good with whatever
18:22:17 <pjones> if you don't get to make salient points and influence others because you're not a voting member, something has gone horribly wrong.
18:22:34 <pknirsch> my expectation is that anyone who wants to get involved should just do so
18:22:53 <pknirsch> and come to the meetings, voice his opinions and discuss with us what the product will look like
18:23:10 <pknirsch> and everyone is invited to do so
18:23:17 <nirik> +∞
18:23:28 <sgallagh> Shall we just vote on the proposal as-is? If I'm the only hold-out, so be it.
18:23:50 <sgallagh> And yes, I agree that non-voting members must still be valued participants
18:24:05 <notting> i'm +1 to the proposal in the ticket. and/or abstaining b/c i'm on it.
18:24:09 <nirik> +1 as it is.
18:24:13 <t8m> +1 as it is
18:24:19 <mmaslano> +1 as it is
18:24:21 <pjones> I'm +1 to it.
18:24:31 <abadger1999> +1 as is
18:24:35 <mattdm> +1 as well.
18:24:49 <mitr> +1 to having something / 0 on the specific membership question
18:25:18 <mattdm> I do hope that as this develops we are able to bring more non-rh community members in at this level.
18:25:30 <pknirsch> ++
18:26:10 <sgallagh> Seems decided then. Let's move on.
18:26:26 <nirik> all done with this ticket and close?
18:26:38 <sgallagh> Yes
18:26:50 <notting> #agreed base design WG approved (+:8, -:0)
18:27:02 <nirik> perhaps open a new one to trac gov docs proposals (due nov 15th)
18:27:28 <t8m> nirik, +1
18:27:29 <notting> ok. ticket #1180 was closed out after being added to the agenda (yay!)
18:27:38 <pknirsch> small request: as we're a bit behind for Base Design, this might be delayed by a week (potentially), but we'll see
18:27:42 <sgallagh> notting: That should have been -1, sorry if it wasn't clear
18:27:48 <pknirsch> other groups had a head start!
18:27:48 <pknirsch> :)
18:27:50 <sgallagh> A weak -1
18:27:52 <notting> #undo
18:27:52 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x2fa8ea50>
18:27:56 <notting> #agreed base design WG approved (+:8, -:1)
18:28:17 <notting> nirik: would you like to open said ticket?
18:28:41 <nirik> sure, I can...
18:29:13 <pjones> pknirsch: let's ask them to meet and see if they really need it pushed back first?
18:29:17 <notting> #info nirik to open a ticket to track working group governance proposals
18:29:17 <pjones> it's not a race after all ;)
18:29:38 <sgallagh> pjones: But if it was, you'd be winning? :)
18:29:40 <mitr> I'd be happiest if one group finished the charter and the others just copied it unmodified :)
18:29:43 <notting> new business. 30 minutes or less!
18:29:50 <notting> #topic #1185 Enable "-Werror=format-security" by default
18:29:51 <notting> .fesco 1185
18:29:54 <zodbot> notting: #1185 (Enable "-Werror=format-security" by default) – FESCo - https://fedorahosted.org/fesco/ticket/1185
18:30:20 <t8m> mitr, yep that would be good :)
18:30:20 <notting> i'd agree this seems reasonable, but i'm willing to wait on mass rebuild results to see how doomed we are
18:30:24 <pjones> I'm +1 to this, really, though I would be interested in the mass rebuild results
18:30:29 <sgallagh> Proposal to defer this until we see how bad it is?
18:30:35 <mitr> sgallagh: +1
18:30:42 <pjones> sgallagh: sure, +1
18:30:55 <t8m> sgallagh, +1
18:31:06 <notting> sgallagh: yeah, +1
18:31:11 <sgallagh> I mean, I strongly advise all upstreams to voluntarily enable that flag, but who knows how many packages are already out there that will fail.
18:31:12 <nirik> sure, +1
18:31:37 <mmaslano> +1
18:31:38 <mattdm> +1
18:32:40 <notting> #agreed defer pending results of mass rebuild (+;8, -0, 0:0)
18:32:53 <notting> #info packagers are encouraged to voluntarily enable and test for issues
18:33:01 <mitr> sgallagh, halfie: The logical conclusion would be to enable the flag in the compiler by default (... at least as a warning)
18:33:23 <abadger1999> +1
18:33:26 <notting> #undo
18:33:26 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1d0c8590>
18:33:28 <mitr> (not a FESCo matter at this point)
18:33:30 <notting> #agreed defer pending results of mass rebuild (+;9, -0, 0:0)
18:33:36 <abadger1999> We should probably ask for one example of fixing code.
18:33:44 <pjones> sgallagh: well, there's still the question of how reliable the detection is, but yeah
18:34:02 <sgallagh> mitr: The warning is already enabled as part of -Wall these days, I think
18:34:02 <pjones> (in terms of false negatives or false positives)
18:34:04 <nirik> abadger1999: good idea
18:34:45 <notting> there are links in the ticket that show you what to do, i believe
18:34:55 <sgallagh> pjones: It's pretty simplistic: if the format specification is anything but a static string, it throws a warning
18:35:00 <notting> (in short, printf(buf) -> printf("%s", buf) )
18:35:00 <mitr> sgallagh: it's not even in -Wextra on F19
18:35:29 <sgallagh> mitr: Really? That *is* wrong. Ok, yeah. Let's ask for -Wformat-security added at least.
18:35:29 <pjones> well, then it's also very easy to fix then
18:35:47 <mitr> halfie: would you care to file a gcc RFE?
18:35:54 <sgallagh> mitr: gcc?
18:35:59 <t8m> Why isn't it in -Wall ?
18:36:14 <t8m> sgallagh, it should be in -Wall
18:36:14 <pjones> proposal: we ask gcc to make this warning part of -Wall now, and defer for enabling it as an error until the mass rebuild is done
18:36:15 <sgallagh> I was just thinking redhat-rpm-config, but adding it to -Wall seems smart too
18:36:23 <t8m> pjones, +1
18:36:38 <sgallagh> pjones: +1
18:36:45 <mattdm> pjones +1
18:36:46 <mitr> sgallagh: redhat-rpm-config fixes the distribution; gcc has a chance of fixing the ecosystem
18:36:48 <notting> pjones: +1
18:36:52 <mitr> pjones: +1
18:36:56 * pjones also +1
18:36:57 <mmaslano> +1
18:37:00 <sgallagh> mitr: Yeah, I wasn't thinking big enough. You are absolutely right.
18:38:00 <nirik> sure, although there might be reason for it.
18:38:22 <sgallagh> nirik: Then that will be communicated back in the bug report.
18:38:28 <notting> #agreed ask gcc to make warning part of -Wall now, defer enabling it as an error until the mass rebuild test is done (+:7, -:0, 0:0)
18:39:20 <notting> halfie: can you take care of that RFE?
18:40:22 <notting> ... ok, will put that in the ticket.
18:40:24 <notting> moving on
18:40:31 <notting> #topic #1186 FESCo liason role in WGs
18:40:31 <notting> .fesco 1186
18:40:33 <zodbot> notting: #1186 (FESCo liason role in WGs) – FESCo - https://fedorahosted.org/fesco/ticket/1186
18:41:07 <jwb> so there are really 2 questions here, if you want me to summarize
18:41:13 <mattdm> please do :)
18:41:14 <sgallagh> Proposal: revamp FESCo selection process so that five of the seats are populated from the WGs.
18:41:25 <jwb> holy balls
18:41:27 * nirik waits for jwb
18:41:36 <jwb> sgallagh, i think that's another ticket entirely.
18:42:01 <jwb> so the two questions on the liaison role are this:
18:42:22 <jwb> 1) is the liaison always supposed to be a voting member of the WGs
18:42:28 <pjones> sgallagh: that's kind of terrible
18:42:44 <jwb> 2) is the liaison always appointed by FESCo, or can that role be filled by someone the WG chooses
18:43:03 <abadger1999> sgallagh: Let's let the board revamp occur first ;-)
18:43:24 <pjones> jwb: I would think 1) yes, and 2) the former
18:43:26 <sgallagh> jwb: Right, and my counter-argument is that the WG could simply volunteer one of its voting members to be their seat on FESCo.
18:43:39 <abadger1999> #1 I would agree with mattdm and say yes.
18:43:57 <notting> jwb: in order, 1) yes 2) no
18:43:58 <pjones> sgallagh: but since fesco approved who's on the WGs, at that point fesco has elected itself.
18:43:59 <mattdm> I agree with myself, ftr
18:44:00 * nirik isn't sure fesco can redo how it's formed, that might be a board question/ack?
18:44:13 <pjones> nirik: I'm not sure we want to anyway
18:44:17 <t8m> notting, 2) no for what?
18:44:24 <sgallagh> pjones: Not after the governance is decided.
18:44:40 <pjones> sgallagh: you may be just a *bit* ahead of yourself
18:44:41 <abadger1999> #2 I lean towards it being a role like "secretary" which can be determined by the WG (and vary from week to week) but I could easily be swayed.
18:44:42 <notting> t8m: sorry. 2) no, not always appointed by fesco. up to WG.
18:44:50 <mitr> 1) not essential, but "yes" is more practical, 2) yes - let's make this (formally) one-directional instead of interdependent; we can always talk to each other
18:45:22 <pjones> so it looks like we've got some differing opinions about question #2
18:45:26 <jwb> ok, so far everyone says the liaison is required to have a voting seat.  can you settle that one and then get to question 2 since none of you agree
18:45:27 <nirik> 1) yes, 2) meh... could be swayed either way there.
18:45:30 <mmaslano> mitr: I agree with mitr
18:45:44 <t8m> 1) yes 2) undecided
18:45:45 <jwb> proposal: the liaison role is always a voting seat in the WGs
18:45:46 <pjones> Proposal: require that the fesco liason on a WG always has a voting seat
18:45:50 <abadger1999> nirik: Well, fesco originally formed itself without Board governanance -- but likely at this point we'd ask the Board to confirm changes that we come up with -- weI think this tangent is in the weeds though.
18:45:55 <mitr> jwb/pjones: +1
18:45:57 <pjones> jwb: you don't get to make proposals in this meeting any more do you? ;)
18:46:00 * pjones +1 to himself too
18:46:02 <sgallagh> pjones: +1
18:46:03 <mattdm> jwb/pjones: +1
18:46:08 <jwb> pjones, i do not.  got ahead of myself.  vote on pjones
18:46:16 <Viking-Ice> why on earth cant the groups a) contact fesco if needed on their own and b) appoint one additional willing participating member other then fesco ?
18:46:17 <nirik> +1
18:46:18 <t8m> pjones, +1
18:46:18 <abadger1999> #1: +1
18:46:20 <notting> um, one monkey wrench. what if the WG decries voting as its decision making mechanism?
18:46:34 <abadger1999> heh :-)
18:46:35 <pjones> notting: well, that'll be odd.
18:46:35 <jwb> notting, i dislike you.
18:46:48 <pjones> but I think we just inadvertently voted to ban that, too.
18:46:49 <sgallagh> notting: I doubt we'd approve that governance
18:46:56 <jwb> in that case, i would assume 1 turns into "the liaison role must exist within the WG"
18:46:58 <mattdm> notting eh. "voting" = "member of core group whatever that is"
18:47:12 <mitr> Viking-Ice: My thinking is that the voting seat implies an obligation to be present and involved => ensures that the person is actually actively participating in both FESCo and the WG and fully aware of all agenda items
18:47:13 <notting> if you want to phrase it as 'member of the WG's decision-making body', that's fine.
18:47:14 <mattdm> +1 jwb
18:47:19 <mattdm> +1 notting
18:47:21 <pjones> sure, that's fine.
18:47:22 <mattdm> +1s all around
18:47:24 <abadger1999> notting: I'm good with that wording
18:47:27 <Viking-Ice> mitr, but still not necessary
18:47:47 <Viking-Ice> yeah sure for the initial members but tying fesco to participate in this forever
18:48:08 <jwb> notting, turn that into a counter-proposal to vote on?
18:48:10 <mattdm> tying everything together is exactly the point
18:48:28 <pjones> #agreed require that the fesco liason on a WG is always a member of that WG's decision making body (+:8, 0:0, -:0
18:48:35 <jwb> or that
18:48:35 <notting> pjones: yeah, +1 to that
18:48:38 <pjones> the parens will just have to stay broken
18:48:47 <pjones> notting: oh, I counted your verbal affirmation as a yes
18:49:04 <sgallagh> FESCo's purpose is to direct technical decisions in Fedora. If we aren't directly involved in the WGs, we're redundant.
18:49:05 * pjones recounts
18:49:06 <Viking-Ice> and what happens if that liason gets outvoted
18:49:16 <Viking-Ice> fesco steps in and overtakes the whole thing
18:49:17 <pjones> yeah, it's right.
18:49:20 <mattdm> Viking-Ice you mean within the group?
18:49:28 <pjones> Viking-Ice: then the liason gets out voted.
18:49:31 <mitr> Viking-Ice: nothing happens
18:49:38 <sgallagh> Within reason...
18:49:40 <pjones> by default, the vote is the vote.
18:49:48 <mattdm> not nothing. then it's their responsibility to communicate to fesco the vote of the group
18:49:49 <nirik> then they are... unless it's something so dire it's brought back to fesco to overrule I guess.
18:49:50 <notting> the point is to have a defined point of contact for fesco to get decisions that are the Voice of the WG. if the liason is misrepresenting his personal opinions as the will of the WG, that is a separate issue that can be solved.
18:50:02 <pjones> people can bring any decisions up with fesco no matter how fesco's liason votes.  that doesn't mean we'll vote to reverse, and it doesn't mean we won't.
18:50:05 <mattdm> +1 notting
18:50:19 <abadger1999> Viking-Ice: then they have to report to fesco the desires of the wg -- they can give their minority opinion as well.. but then, any member of the WG can do that as well.
18:50:19 <nirik> right, so on to the second part?
18:50:35 <jwb> please
18:50:49 <mattdm> as i said in the ticket, I don't think it's _necessary_
18:50:57 <pjones> I'm not sure it's actually reasonable to answer #2 right now?
18:50:57 <sgallagh> Proposal: liason is always assigned by FESCo
18:50:59 <sgallagh> I'm -1
18:51:09 <mitr> +1
18:51:09 <pjones> I mean, it depends on what kind of governance the WGs want, really?
18:51:36 <jwb> thus far that has been "minimal"
18:51:39 <pjones> What if we phrased it "the liason is always approved by fesco"?
18:51:54 <t8m> pjones, +1
18:51:55 <pjones> thus letting us let either group pick it as long as fesco is okay with who gets picked.
18:52:01 <Viking-Ice> there is a difference in liason be assigned to fesco by the wg themselves or fesco assigning a liason to the wg
18:52:05 <sgallagh> pjones: I'm good with that.
18:52:08 <abadger1999> confirmation hearings? ;-)
18:52:16 <mattdm> I'm +0. I'm having trouble imaginging a plausible scenrio where it would really be a problem yet there isn't some even more gigantic problem which fesco picking a liaison would not solve
18:52:27 <mitr> pjones: works for m
18:52:29 <pjones> abadger1999: we could have a grandstanding competition at flock ;)
18:52:30 <mattdm> that could probably use some punctuation
18:52:30 <notting> pjones: i'd even say that's overkill
18:52:51 <pjones> notting: just give us the right to reject one, like an ambassador?
18:53:10 <notting> whichever poor soul a WG nominates to take crap from both sides... ok.
18:53:18 <nirik> if we reject someone and appoint another one, that bumps a member from that group right?
18:53:26 <mattdm> I'm kind of coming down on -1 here
18:54:01 <mattdm> if a wg nominates someone and we somehow can't get along, we have a bigger problem
18:54:03 <pjones> Honestly I'm really not sure we need to have a firm rule on this
18:54:21 <nirik> well, WG's need to know right?
18:54:33 <nirik> if we are appointing then they only have 8 seats to fill...
18:54:35 <pjones> Clearly we have the right to remove somebody from that roll, since we're the overseeing body above the WGs
18:54:36 <Viking-Ice> nirik, I would think if fesco ( for whatever unimaginable reason ) would reject the wg assigned as an acting liason between fesco and the wg it would only grant fesco the rights to choose from other voting members of that wg
18:54:52 <notting> yeah, i believe jwb wanted to know so he can clarify his governing docs
18:54:53 <nirik> Viking-Ice: yeah, could be.
18:54:58 <abadger1999> nirik: actually -- WGs are allowed to determine thenumber of people on them as well.
18:55:01 <jwb> i would like to know, yes
18:55:15 <abadger1999> nirik: but yeah, they may want to plan an extra seat because of that.
18:55:35 <jwb> abadger1999, after Jan i believe that is true
18:55:44 <jwb> until then, it's 9 and the 9 approved by fesco
18:55:56 <abadger1999> jwb: <nod>  Yeah.
18:56:24 <mattdm> proposal: WGs can decide how the fesco liaison is selected, including the possibility of asking fesco to make the selection
18:56:41 <t8m> mattdm, I can be +1 to that
18:56:42 <abadger1999> I'm kinda with pjones -- if we can't get along with the liason from the WG our first step would probably to  let the WG know that there's an issue with the person representing them to us.
18:56:46 <notting> mattdm: +1
18:57:18 <abadger1999> at which point the rational next step is simply for them to select someone else on the WG to liase with us.
18:57:21 <pjones> mattdm: I can get behind that.  Obviously still with the caveat that if they chose to chose, we can always ask them to chose again.
18:57:31 <mitr> mattdm: -1; FESCo should have the ultimate authority
18:57:40 <nirik> sure, +1 to mattdm's proposal.
18:57:48 <pjones> mitr: I don't think we can even /give away/ the ultimate authority.
18:57:59 <abadger1999> mattdm + pjones caveat:  +1
18:58:04 * mattdm has 3 minutes
18:58:11 <sgallagh> mattdm: +1 that seems reasonable
18:58:13 <mattdm> is fine with caveat if it comes down to that
18:58:27 <sgallagh> mitr: FESCo retains the right to disband the WGs at any time, if it came to that
18:58:34 <sgallagh> I don't think it gets much more "ultimate"
18:58:37 * pjones is +1 to mattdm+caveat that uses chose as much as possible
18:58:46 <notting> sgallagh: with that, is the caveat even necessary?
18:59:02 <pjones> notting: no, it's really implicit.  hence "obviously"
18:59:05 * abadger1999 notes that two of those "chose"s should be "choose"
18:59:11 <pjones> abadger1999: yes ;)
18:59:23 <pjones> abadger1999: or arguably only the last one, but still.
18:59:30 * mattdm is outta here.
18:59:53 * frankieonuonga is here.
19:00:04 * frankieonuonga waves
19:00:42 <jwb> i didn't see a #agreed
19:00:52 <sgallagh> frankieonuonga: #fedora-meeting-1 for Cloud WG
19:00:52 <pjones> I'm not sure anything was agreed upon
19:01:02 <abadger1999> There are 5 +1's -- did this pass or do we want to clarify whether we're leaving the caveat implicit or explicit?
19:01:07 <sgallagh> I think we have +1s
19:01:16 <notting> #agreed WGs can decide how the FESCo liason is selected, including the possibility of asking FESCo to select. (As FESCo is above the WGs, FESCo could ask WGs to re-choose.) (+:7, -:1, 0:0)
19:01:25 <notting> sorry, was counting
19:01:25 <pjones> that works
19:01:37 <notting> pjones: didn't mean to materially re-phrase
19:01:48 <pjones> looks fine to me
19:02:02 <notting> jwb: does that cover your concerns?
19:02:03 <jwb> ok, thanks for the clarifications.  i now return you sgallagh wanting to completely restructure your group ;)
19:02:16 * sgallagh is willing to leave that for another day
19:02:26 <notting> ok. sgallagh - please file a ticket if you have a proposal
19:02:43 <frankieonuonga> sgallagh: thanks
19:02:47 <notting> lastly (there were two late tickets we can leave for next week)....
19:02:47 <mitr> notting: With the parentesized part, I can be +1 (not that it matters)
19:02:56 <notting> #undo
19:02:56 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x35de2750>
19:03:03 <notting> #agreed WGs can decide how the FESCo liason is selected, including the possibility of asking FESCo to select. (As FESCo is above the WGs, FESCo could ask WGs to re-choose.) (+:8, -:0, 0:0)
19:03:13 <pjones> mitr: nice typo.
19:03:20 <notting> #topic #1187 Packagers should be not be allowed to ignore RH bugzilla
19:03:20 <notting> .fesco 1187
19:03:21 <zodbot> notting: #1187 (Packagers should be not be allowed to ignore RH bugzilla) – FESCo - https://fedorahosted.org/fesco/ticket/1187
19:04:58 <nirik> There's not enough info here really to do much on IMHO
19:05:06 <abadger1999> I think the initial bug report is just pointing out a problem.
19:05:14 <nirik> handsome_pirate: you around?
19:05:30 <notting> so... i don't think we can mandate a particular level of responsiveness to individual bugs other than what's clarified by the non-responsive mantainer policy, but i do think "blocker bugs are filed in RH bugzilla; ignoring them is not appropriate maintainer behavior" is reasonable
19:05:32 <mitr> I agree with the general sentiment, but our options are limited
19:05:47 <sgallagh> There are a lot of package maintainers who don't pay attention to bugs and just ship out upstream releases
19:06:20 <abadger1999> mitr had one partial solution.  another option is removing people from packager group or orphaning/retiring packages that accumulate too many (of some class?) of bug.
19:06:21 <t8m> notting, +1
19:06:26 <nirik> and there's also maintainers who have priorities that may not match all the people who file bugs against their packages priorities.
19:06:31 <sgallagh> Yeah, I think we should just say that people who ignore blocker bugs shortcut the non-responsive policy
19:06:51 <pjones> mitr: I vaguely like your suggestion, but possibly not /any other sponsored packager/ - there's no reason to encourage personality conflicts
19:06:54 <nirik> I'd be curious what bug(s) prompted this? were they blockers? proposed as blockers?
19:07:00 <pjones> mitr: at the same time - isn't this why we have proven packager?
19:07:03 <notting> nirik: for example, for better or worse, individual abrt bugs that aren't heavily duplicated are waaaaaaaay at the bottom of my priority
19:07:17 <nirik> notting: me too
19:08:09 <nirik> but for example, there was someone in #fedora the other day very intent on the vty bug that doesn't display the f19 release right... but I can see that not being very high on the kernel maintainers to do anything with. ;)
19:08:29 <notting> nirik: closed->get a better vga bios font
19:08:36 <nirik> yeah
19:08:55 <notting> anyway...
19:08:58 <jwb> the kernel is the worst case bugzilla example ever.  pick something else please
19:09:00 <Viking-Ice> if you want this fix open up contribution for everybody to fix spec files without having a hard requirement on proven packager or being a packager
19:09:37 <mitr> pjones: provenpackagers are busy - I wanted to give interested newbies access to core packages (= motivation for newbies to look at core packages more, and motivation for owners to core packages to work on them more to keep them if they don't want newbies).  The personality conflict aspect is therefore kind of intentional - which may very well be a horrible idea.
19:09:41 <Viking-Ice> that will solve at least the packaging bbug
19:09:43 <notting> sgallagh: hm. i guess one issue is that anything that has a blocker is likely something that shouldn't be shortcutted to orphaning/blocking, which means we'd need a maintainer, or provenpackager shephard, ayway
19:10:05 <nirik> Viking-Ice: that also opens up to a flood of bugs/brokenness from people who don't understand the package...
19:10:24 <sgallagh> Or security issues from people who understand it too well...
19:10:43 <Viking-Ice> nirik, if we cant a) detect that b) revert that then we have more serious issue
19:10:43 <nirik> or people ignoring freezes, etc.
19:11:04 <mitr> Viking-Ice: pragmatically we can't detect that, so reverting is moot
19:11:32 <sgallagh> mitr: Well, the other official maintainers will get an email that something was changed
19:11:39 <sgallagh> So presumably they can take action as needed
19:11:44 <pjones> isn't "detecting that" the same issue we're talking about here to begin with?
19:11:51 <nirik> proposal: if blocker bugs are ignored, escalate to fesco.
19:11:57 <pjones> sgallagh: sure, but they also get bz emails and whatnot
19:12:03 <mitr> nirik: and what will we do?
19:12:16 <nirik> for me it would depend on the situation.
19:12:17 * mitr notes two bug escalations have been filed in the past 3 hours
19:12:29 <notting> so, what part of 'deal with reported bugs in a timely manner' section on https://fedoraproject.org/wiki/Package_maintainer_responsibilities is incorrect/needs fixing?
19:12:32 <pjones> proposal: let people come to fesco on a package-by-package basis if they think there are package maintenance issues
19:12:33 <Viking-Ice> I'm still waiting for pp to step in and fixing the cron dependence ( yeah and those had patches ) so people cant act like they are whole sale savior of them all
19:12:34 <sgallagh> pjones: Certainly, but I suspect people will pay more attention to "l33thacker3 pushed a commit" than BZ
19:12:39 <pjones> (i.e. exactly what we're doing now)
19:12:54 <nirik> pjones: +1
19:12:57 <t8m> pjones, this is probably just #info because they can surely do that already
19:13:02 <pjones> sgallagh: if they're dumb enough to use l33thacker3 as a nick, I doubt if that much attention is needed
19:13:06 <pjones> t8m: sure.
19:13:06 <sgallagh> pjones: Well "timely" and "accurately" are different
19:13:20 <sgallagh> pjones: hahaha
19:13:30 <notting> i'd almost say the wiki part overstates it, because it assigns responsibility to address (all?) filed bugs, even including abrt crud, etc.
19:14:03 <nirik> t8m: I guess I read an implied "and close this ticket, nothing to do without more info" there.
19:14:29 <t8m> nirik, +1
19:14:48 <nirik> perhaps I was reading too much into pjones proposal tho
19:14:52 <Viking-Ice> nirik, btw there exist no place or process for us that want to fix packaging issues as we come across them without having to become first a) packager b) proven packager. maybe people arent interested and maintaining package in the distribution and just want to fix things because it annoy's them
19:15:16 <pjones> nirik: no, you're reading it right
19:15:22 <sgallagh> Viking-Ice: Then they can submit patches
19:15:30 <sgallagh> And if the patches are ignored, escalate that to FESCo?
19:15:37 <sgallagh> We had a case like that a few months ago
19:15:38 <Viking-Ice> sgallagh, which get fracking stuck in bugzilla
19:15:41 <nirik> Viking-Ice: there was some talk about making a process for mass changes that was better, but not sure it ever went anywhere.
19:15:46 <sgallagh> We ended up removing a maintainer for that reason
19:15:58 <Viking-Ice> sgallagh, did escalate that to fesco
19:16:11 <Viking-Ice> and I still have to deal with 50 more packages then 500 on top of that so...
19:16:52 <sgallagh> Viking-Ice: Have you requested provenpackager access?
19:17:12 <Viking-Ice> sgallagh, you seem to have forgotten that you and or abadger1999 did so years ago
19:17:13 <abadger1999> sgallagh: I requested provenpackager for Viking-Ice for a specific set of changes.
19:17:41 <sgallagh> Viking-Ice: I have trouble remembering what I did this morning, so forgive me.
19:17:49 <Viking-Ice> sgallagh,  but due to account of one single maintainer I got thwerted and yes I still think nfs is broken
19:18:11 <nirik> I think this is a different case, and we are driving off in the weeds.
19:18:16 <sgallagh> Viking-Ice: Please file a ticket and we'll deal with it next week
19:18:48 <notting> pjones' proposal was:  let people come to fesco on a package-by-package basis if they think there are package maintenance issues
19:18:56 * pjones is +1 to that
19:19:00 <sgallagh> pjones: +1
19:19:01 * nirik is also +1 to that
19:19:20 * sgallagh oO(isn't that the current state?)
19:19:25 <pjones> sgallagh: yes
19:19:28 <nirik> yes.
19:19:29 <t8m> +1 although this is the current state
19:19:36 <mmaslano> +1 it is current state
19:19:41 * notting is +1
19:19:49 <mitr> The followup from this would be asking handsome_pirate to s/gnome/$specific_packages/ for next week?
19:19:50 <abadger1999> +1
19:19:59 <pjones> mitr: sure.
19:20:04 <notting> #agreed let people come to fesco on a package-by-package basis if they think there are package maintenance issues (+:7, -:0, 0:0)
19:20:16 <notting> should we re-iterate the bug handling portion of the maintainer responsibilities?
19:20:17 <nirik> mitr: yes.
19:20:27 <abadger1999> Maybe mention the portion of https://fedoraproject.org/wiki/Package_maintainer_responsibilities  that notting quoted earlier in the ticket.
19:20:38 <mitr> notting: Can't hurt
19:20:41 <pjones> #info if the person filing the ticket has specific issues, he should bring them up, as per: https://fedoraproject.org/wiki/Package_maintainer_responsibilities
19:20:43 <abadger1999> notting: Yeah, +1
19:21:10 <notting> #info Note that handling bugs is part of package maintainership https://fedoraproject.org/wiki/Package_maintainer_responsibilitiesresponsibilities, per
19:21:22 <pjones> notting: might have typoed a bit there
19:21:30 <notting> #undo
19:21:30 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x328cb3d0>
19:21:42 <notting> #info Note that handling bugs is part of package maintainership, per https://fedoraproject.org/wiki/Package_maintainer_responsibilitiesresponsibilities
19:21:46 <notting> #undo
19:21:46 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2a031550>
19:21:49 <notting> paste-os everywhere
19:22:04 <notting> #info Note that handling bugs is part of package maintainership, per https://fedoraproject.org/wiki/Package_maintainer_responsibilities
19:22:36 <notting> #topic next week's chair
19:22:40 <notting> volunteers?
19:23:02 <abadger1999> I haven't been in a while, I'll do it.
19:23:14 <notting> #info abadger1999 to chair next week's meeting
19:23:22 <notting> #topic Open Floor
19:24:08 <notting> anything? i
19:24:10 <abadger1999> heh, if I get the UTC/DST transition wrong, someone ping me to start the meeting ;-)
19:24:16 <jwb> i have one thing
19:24:17 <notting> i'll leave the bug escalations for next week's meeting.
19:24:55 <notting> jwb: ok
19:24:57 <jwb> i've seen several references scattered around about waiting for a board restructure for various things.  is that something FESCo is actively waiting on?
19:25:12 * nirik hasn't really been
19:25:20 * abadger1999 hasn't
19:25:34 <abadger1999> I would wait on a fesco restructure until the board restructure happens.
19:25:59 <jwb> ok, well, in general that whole thread is on a burner back far enough that it is almost falling off the stove.
19:26:03 <jwb> so don't wait for it.
19:26:14 <abadger1999> :-(
19:26:34 <nirik> alright
19:26:36 * abadger1999 was looking forward to that
19:26:43 <jwb> or if you would like to see progress, push for it
19:27:02 <jwb> where "it" is change, not necessarily what i proposed
19:27:04 * nirik recalls the gov discussion at fudcon tempe... never really went anywhere tho
19:27:26 <jwb> i was not present
19:27:47 <jwb> i will say that any such change is going to require sustained effort and clear calls for action
19:27:59 <jwb> it can't be "what about this?" and wait and see.
19:28:41 <nirik> http://fedoraproject.org/wiki/Board/Possible_Future_of_Fedora_Governance (old and drafty)
19:29:02 <jwb> that's all i had.  thanks.
19:30:31 * abadger1999 notes that the linked page mostly described what is rather than the discussion of what we'd like it to be.
19:30:56 <nirik> yeah, couldnt find much better off hand.
19:31:32 <abadger1999> nirik: yeah -- now that I read that i remember we got off in the weeds and so what we wrote up in the wiki didn't get into the "exciting" stuff.
19:31:46 <nirik> yeah
19:31:55 <notting> anything else for open floor?
19:32:39 <notting> if not, will close in 2 minutes
19:35:04 <notting> #endmeeting