fedora-kernel
LOGS
18:00:25 <jwb> #startmeeting
18:00:25 <zodbot> Meeting started Fri Oct 18 18:00:25 2013 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:25 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:25 <jwb> #meetingname fedora-kernel
18:00:25 <jwb> #meetingtopic Fedora Kernel
18:00:25 <jwb> #topic init
18:00:25 <zodbot> The meeting name has been set to 'fedora-kernel'
18:00:38 <jwb> #chair jforbes davej jwb
18:00:38 <zodbot> Current chairs: davej jforbes jwb
18:01:00 <jwb> we'll do a quick meeting today.  who all is around?
18:01:06 * nirik is lurking
18:01:18 <jwb> yay!  our token non-kernel team guy ;)
18:01:25 * nirik bows
18:01:37 * jforbes is here
18:01:43 * brunowolff is here
18:02:08 <jwb> ok, let's get rolling
18:02:16 <jwb> #topic f18/f19/f20
18:02:26 <jwb> jforbes, wanna cover these?
18:03:07 <jforbes> Sure.  F18 is in a weird state because there have been problems with a push, but the 3.11.4 rebase should be going out to stable as soon as a push happens, and 3.11.5 should be in updates-testing
18:03:29 <nirik> fingers crossed the 18/19 push goes out in a bit.
18:04:00 <jforbes> F19 has 3.11.5 waiting for a push as well, hopefully it makes it before 3.11.6
18:04:14 <jforbes> F20 beta should also be on 3.11.5
18:04:25 <jwb> #info f18 3.11.4 rebase coming soon
18:04:32 <jwb> #info f19/f20 both on 3.11.5
18:04:39 <jwb> there's one more keys patch i need to add for f20
18:04:52 <jwb> fixes a memory/quota leak that prevents the krb5 feature thing from working
18:04:58 <jwb> i'll do that after the meeting
18:05:05 <jforbes> jwb: can we get that in?
18:05:14 <nirik> will that need a freeze break?
18:05:16 <nirik> or after beta?
18:05:22 <jwb> freeze break most likely
18:05:40 <jwb> the original bug is still open.  i'm sure we'll discuss it next blocker meeting
18:05:45 <jwb> unless there are no more blocker meetings?
18:05:56 <nirik> there are. oh there are. ;)
18:06:00 <jwb> figured
18:06:09 <jforbes> Once the rebase is out on F18, I will be doing a mass update asking for people to test with 3.11 as there are a lot of stale bugs in f18
18:06:21 <jforbes> That's pretty much it
18:06:22 <jwb> #action jwb to add fix for big_keys quota issue to F20
18:06:51 <jwb> #action jforbes will do a mass bug update for f18 asking people to test with 3.11
18:06:52 <jforbes> #info Mass bug update for f18 coming, please retest your issues on 3.11 kernels
18:06:56 <jforbes> doh
18:06:56 <jwb> heh
18:07:00 <jwb> #undo
18:07:00 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x16cdf310>
18:07:19 <jwb> jforbes, maybe when you do that, tell them to reassign the bug to f19 if it's still there?
18:08:06 <jforbes> jwb: Possible that it is not visible in f19 though if the trigger changed.  I know that is a small number of bugs
18:08:24 <jwb> yeah, it doesn't matter hugely either way
18:08:55 <jwb> ok, anything else on the releases?
18:09:01 <jforbes> nothing at the moment
18:09:06 <jwb> #topic rawhide
18:09:16 <jwb> so we're at 3.12-rc5-gitBLAH right now
18:09:27 <jwb> from what i can tell, 3.12 is pretty stable at this point
18:09:41 * nirik can now test secureboot/efi junk...
18:09:47 <nirik> working ok here for the most part.
18:09:48 <jwb> there's nothing really major feature-wise, but i'll take boring over broken any day
18:10:27 <brunowolff> I occasionally get stalls when doing lots of disk I/O (yum updates), but that goes back a ways and doesn't happen that often.
18:10:33 <nirik> did run into backlight woes and problems with ideapad_laptop module on the new laptop... should I file those? or all just well known?
18:10:45 <jwb> i think i'm going to look at adding the win8 backlight issues patches queued for 3.13 soon.  a number of people are hitting that, and getting extra testing before 3.13 isn't bad
18:11:01 <jwb> nirik, some known.  not all.  probably not "well" either ;)
18:11:23 <nirik> ok. I can file the ideapad one (or ask on kernel list first)
18:11:33 <jwb> either is fine for me
18:12:03 <jwb> aside from that, i did some janitorial cleanup this week.  shouldn't really impact anything at runtime as it was mostly dead patches, etc
18:12:18 <jwb> #info rawhide at 3.12-rc5-gitX
18:12:35 <jwb> #action jwb to look at adding win8 backlight issue patches from 3.13 queue
18:12:53 <jwb> anything else on rawhide?
18:12:55 <nirik> whats the status on beagleboneblack?
18:13:05 <nirik> (if any)
18:13:06 <jwb> working in f20 afaik.  not in rawhide
18:13:19 <jwb> mostly because of time and an underlying moving target in rawhide
18:13:25 <nirik> ok
18:13:34 <brunowolff> Are kernels appropriate for OLPC devices coming soon?
18:13:42 <nirik> so tc* beta images should work on them?
18:13:49 <jwb> brunowolff, what?
18:14:16 <jwb> nirik, i _think_ so.  might want to ask pbrobinson and/or kylem
18:14:22 <jwb> or in #fedora-arm
18:14:34 <nirik> can do.
18:14:35 <brunowolff> Right now olpc runs mostly Fedora, but use special kernels. I was wondering if Fedora ARM kernels will be available on OLPC soon.
18:14:48 <brunowolff> Maybe that's a question for the ARM people?
18:15:06 <jwb> probably.  i haven't paid attention to OLPC in ages.  i didn't even realize they were using ARM
18:15:20 <jwb> sounds like a great step up from geode or whatever they were using before
18:15:52 <brunowolff> I thought my 1.75 was using ARm, but maybe I am wrong.
18:16:47 <jwb> ok, let's open floor it
18:16:50 <jwb> #topic open floor
18:17:31 <brunowolff> Any advice in trying to narrow down kernels bugs that look like they may have been triggered by build system changes as opposed to just kernel code?
18:18:29 <jwb> i saw your question on the list and didn't have any great ideas.  if it's really a toolchain issue, you can always use mock to init the root to a certain state, copy in different toolchain rpms, and chroot in update/rebuild
18:18:36 <jwb> aside from that, not really
18:18:54 <brunowolff> I'm still working on tracking down a bug that came in with 2.6.29.1. But it seems like it might really have been something that changed with the build system.
18:18:55 <nirik> brunowolff: wonder if that reproducable builds thing that halfie was working on could help?
18:19:07 <nirik> then you would have the exact same buildroot and could tweak just one thing at a time?
18:19:55 <brunowolff> I am not sure if I can still get all of the rpms. It was pre-f11 release when the problem showed up,
18:19:59 <nirik> https://github.com/kholia/ReproducibleBuilds
18:20:12 <nirik> yeah, dunno.
18:20:22 <jforbes> brunowolff: it came in with 2.6.29.1, but is it still a problem?
18:20:38 <brunowolff> Yes, the problem is current.
18:20:40 <pbrobinson> jwb: BBone Black question?
18:20:56 <brunowolff> However the machine seems to hang in a way that makes it very hard to get crash dumps.
18:21:05 <nirik> pbrobinson: just wondering if it works with f20beta-tc* images?
18:21:07 <jwb> pbrobinson, nirik was curious if the f20 tcs for beta are working on BBB (and also what rawhide status was)
18:21:21 <brunowolff> I haven't been able to get one.
18:21:38 <brunowolff> Otherwise I'd be attacking it from that angle.
18:22:00 <pbrobinson> nirik jwb: yes, they are from tc4 and later but you need a serial cable. I've got 3 half written blog posts on the BBBlack which I need to complete tomorrow
18:23:00 <nirik> pbrobinson: cool. no worries.
18:24:49 <brunowolff> I actually haven't tested in on a current kernel for a month or so. I did want to retest after the gcc fix that was recently highlighted, but I don't think that is likely to affect this.
18:25:39 <brunowolff> When I tried last night I found the pulse audio config tool was broken so I couldn't switch sound over to the speakers instead of the headset on rawhide.
18:27:11 <brunowolff> And my F10 testing has been complicated by some other audio problem where I am also having trouble switching audio over to the speakers. But I just started playing with that late last night.
18:28:22 <brunowolff> All of my tests on kernels built pn f11 after it was released have had the problem. So I wanted to go back to f10 to see how builds on that worked.
18:30:12 <jwb> if we have any ideas on that, we'll reply on-list
18:30:27 <jwb> anything else for open floor?
18:31:00 * nirik has nothing
18:31:27 <jwb> ok, let's close it out then.  for the next meeting we'll get into some updates on the test stuff, etc
18:31:34 <jwb> trying to do that monthly
18:31:43 <jwb> thanks for coming everyone
18:31:45 <jwb> #endmeeting