fesco
LOGS
18:00:18 <sgallagh> #startmeeting FESCO (2013-10-16)
18:00:18 <zodbot> Meeting started Wed Oct 16 18:00:18 2013 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:22 <sgallagh> #meetingname fesco
18:00:22 <zodbot> The meeting name has been set to 'fesco'
18:00:25 <sgallagh> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:00:25 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:00:28 <sgallagh> #topic init process
18:00:32 <mitr> Hello
18:00:33 <pjones> hello party people.
18:00:34 * abadger1999 here
18:00:35 <t8m> hello
18:00:48 <mmaslano> hi
18:01:02 <mattdm> hi!
18:01:02 <sgallagh> I am here, but it turns out I have a hard stop in two hours. Hopefully this is irrelevant information.
18:01:06 * nirik is here.
18:01:29 <abadger1999> sgallagh: thanks, you've just cursed the rest of us to a thre hour meeting. ;-)
18:02:22 <mattdm> i think notting is likely to be busy
18:02:23 <mmaslano> sgallagh: two?
18:02:46 <sgallagh> Ok, with notting out, I think we're all accounted for
18:03:08 <sgallagh> First, old business:
18:03:13 <sgallagh> #topic #1164 F20 Changes - Progress on Changes Freeze
18:03:18 <sgallagh> .fesco 1164
18:03:19 <zodbot> sgallagh: #1164 (F20 Changes - Progress on Changes Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/1164
18:03:39 <sgallagh> jreznik helpfully provided us with an update this morning
18:04:40 <sgallagh> I'm slightly concerned about the few changes that haven't responded about their incomplete status
18:05:04 <sgallagh> abadger1999: You're one of those :)
18:05:08 <jreznik> sorry I wasn't able to ping everyone personally and get status but will try to do so
18:05:10 <sgallagh> How's setuptools 0.7?
18:05:24 <abadger1999> baked, done.
18:05:38 <t8m> yep, the incomplete features with no recent updates are worrying
18:05:47 <jreznik> abadger1999: so pls ON_QA in the bug :)
18:06:44 <mitr> sgallagh: It's a little tiresome, OTOH what's the adverse effect?  (on the distribution and on the change owners?)
18:06:46 <abadger1999> jreznik: ah okay... where is it published that we're supposed to change status to that?  The last status change was in an email sent to me or in the bug?
18:06:51 <mitr> I'm fine with this particular set of unknowns
18:07:34 <jreznik> abadger1999: sent to devel-announce and then in bug itself, I tried to ping as many people I saw online
18:07:37 <mitr> abadger1999: "Fedora 20 Schedule reminders - Changes 100% Complete in one week" to devel-announce
18:07:42 <sgallagh> Well, setuptools concerned me a bit. I thought I remembered that needing a rebuild in most cases.
18:07:50 <sgallagh> But if abadger1999 says all is well. I'm good.
18:07:59 <abadger1999> sgallagh: the change was in before the mass rebuild
18:08:21 <abadger1999> sgallagh: and things didn't need a rebuild; rebuild was thought nice to determine if anything would be broken by the update.
18:08:28 <sgallagh> Got it
18:08:52 <sgallagh> Ok, anyone else have any concerns at this time, or shall we just politely request that jreznik hound these folks for updates?
18:09:06 <nirik> well, when do we drop the ones that aren't responding.
18:09:17 <nirik> Ryu, hadoop...
18:09:39 <sgallagh> Good point
18:10:35 <mattdm> do all of the blockers for the web assets change need to be done for the feature to be considered done, or is having a place for those packages to be updated to considered "done" for the feature?
18:11:07 <jreznik> nirik: unfinished ones are not in announcement... that is main idea of having that list tracked
18:11:12 <sgallagh> Proposal: all Changes not currently marked as complete should be treated as postponed unless the maintainer shows that they were already completed before this meeting started/
18:11:45 <sgallagh> s/maintainer/owner/
18:12:24 <mitr> Proposal: All Changes not marked as complete and not updated within the last month will be dropped from the list of changes to be announced at F20 (... with no way to re-add expected)
18:12:45 <jreznik> well I just want a way how to track what's done and not for release announcements and what should be in release notes and docs but don't thing with a new process it has to be removed from the list - it's not features list anymore
18:12:49 <pjones> hrm.
18:13:27 <mitr> sgallagh: I think it would be fine if the "complete" state happens by Beta Release, not necessarily today.
18:13:28 <pjones> mitr: that seems a little weird - if they haven't been changed in the last month, that means it's /more/ likely that merely the feature page is wrong
18:13:51 <pjones> s/feature/you know what I meant/ ;)
18:14:11 <sgallagh> mitr: Well, the process suggests that it should have been complete by beta freeze, not beta release
18:14:27 <sgallagh> (Freeze-exception bugs notwithstanding)
18:14:31 <jreznik> let me a week to try to get missing updates but still I prefer not to remove it from list - the reason why we renamed it from features to changes
18:14:48 <nirik> well, if it's not done, we shouldn't announce it...
18:14:48 <mattdm> also I have the same question as above for the unversioned docdirs
18:14:50 <mattdm> https://bugzilla.redhat.com/showdependencytree.cgi?id=998579&hide_resolved=1
18:14:56 <mattdm> "Bug 998579 depends on 201 open bugs"
18:15:16 <mitr> pjones: "things" happen upstream all the time; I think that what makes this a Fedora Change worthy of marketing is that it has been coordinated and tested within Fedora.
18:15:52 <pjones> mitr: right.  but the change not being maintained isn't the same thing as the actually thing being changed and testing being done within Fedora.
18:16:01 <pjones> the *Change* not being maintained.
18:16:03 <nirik> mattdm: yeah... although I don't think we expect them all to be done.
18:16:47 <mitr> pjones: yes.  That would lead to a conversation of what the change process is for...
18:16:58 <mitr> ... which I'd rather not have at this hour.
18:17:02 <pjones> fair.
18:18:21 <nirik> well, I guess I would personally be in favor of dropping/moving to f21 the ryu and hadoop ones... since they are completely unknown
18:18:25 <mitr> I'd like to withdraw my proposal, and back giving jreznik one more week for updates
18:18:31 <nirik> and giving more time for others.
18:18:35 <mmaslano> could we move on? I would ask jreznik to ask people in simple mail - update your bugs or they won't be included
18:18:49 <t8m> mmaslano, +1
18:19:03 <mitr> +1
18:19:18 <mmaslano> + to me
18:19:21 <mmaslano> +1
18:19:22 <mattdm> +1
18:20:05 <sgallagh> Doesn't really sound any different from my proposal above. So +1
18:20:31 <nirik> ok
18:20:53 <sgallagh> nirik: Was that a +1?
18:21:03 <abadger1999> +1
18:21:24 <abadger1999> sgallagh: differs in that we aren't commiting to actually not including them?
18:21:30 <nirik> sure, +1
18:21:35 <sgallagh> ok
18:21:37 <pjones> sure, +1
18:21:57 <sgallagh> #agreed Ask jreznik to ask people in simple mail - update your bugs or they won't be included (+8, 0, -0)
18:22:09 <sgallagh> Moving on...
18:22:11 * jreznik will do so
18:22:21 <sgallagh> #topic #1166 F20 System Wide Change: Migrate to Bluez 5 - https://fedoraproject.org/wiki/Changes/Bluez5
18:22:24 <abadger1999> My understanding of the process hasn't meant that they'd be removed from some list at beta freeze but the contingency plans enacted then.
18:22:27 <abadger1999> if needd.
18:22:29 <sgallagh> .fesco 1166
18:22:30 <zodbot> sgallagh: #1166 (F20 System Wide Change: Migrate to Bluez 5 - https://fedoraproject.org/wiki/Changes/Bluez5) – FESCo - https://fedorahosted.org/fesco/ticket/1166
18:22:50 <sgallagh> We were explicitly going to check on this at Beta Freeze
18:23:14 <kalev> this is done, we have BlueZ 5 in F20 and important users have been ported over
18:23:24 <t8m> great
18:23:26 <mitr> abadger1999: yes
18:23:40 <sgallagh> kalev: That's great to hear
18:23:48 <mattdm> awesome
18:23:57 <sgallagh> Excellent work.
18:24:03 * nirik still never looked at the split out applet. oh well.
18:24:31 <sgallagh> Nothing to see here, moving right along...
18:24:33 <sgallagh> #topic #1170 Working Group call for Volunteers
18:24:38 <sgallagh> .fesco 1170
18:24:40 <zodbot> sgallagh: #1170 (Working Group call for Volunteers) – FESCo - https://fedorahosted.org/fesco/ticket/1170
18:24:50 <sgallagh> So... nomination period is over.
18:25:26 <sgallagh> I suppose it's time for us to at least volunteer for who is going to liase with each of the Working Groups.
18:25:55 <mattdm> Yes -- I think we should get the fesco members assigned
18:26:16 <sgallagh> Given that my $DAYJOB is pretty much in perfect alignment with the Server WG, I volunteer for that role there.
18:26:17 <mattdm> and then those people should work with the list of candidates to select the initial membership
18:26:31 <sgallagh> mattdm: Right, as agreed in the FESCo meeting two weeks ago
18:26:57 <mattdm> sgallagh right that second part was just restating
18:27:14 <mattdm> +1 sgallagh for server wg
18:27:34 <mattdm> do we need to have a full fesco vote on each of these?
18:27:46 <mmaslano> +1 for sgallagh for server wg
18:27:56 <mitr> +1
18:27:57 <sgallagh> I'm inclined to suggest that we only vote if anyone objects to a volunteer.
18:28:08 <mmaslano> as you wish
18:28:08 <pjones> sgallagh: +1 to that
18:28:09 <mattdm> that sounds good to me.
18:28:19 <mattdm> I volunteer for Cloud WG
18:28:39 <nirik> sure, sounds reasonable
18:28:40 <t8m> surprise
18:28:43 <mmaslano> I volunter for Stack&environment WG
18:28:43 <t8m> :)
18:28:46 <mattdm> right :)
18:28:50 <abadger1999> So one thing that came up two meetings ago that affects this is -- the scope of the Base design and the environments and stacks group.
18:28:56 <mmaslano> if abadger1999 doesn't want it
18:29:24 <abadger1999> mmaslano: yeah --trying to decide... I have a thought that we might want to have another group as well.
18:29:39 <mattdm> I think working out the scope is part of the process for each group
18:29:49 <mattdm> and for all of us here
18:30:53 <mmaslano> abadger1999: I would take it, you already suffer on two meetings ;-) and it's close to my job anyway
18:30:57 <abadger1999> mattdm: <nod>  The thing I'm thinking of is that "how things are packaged" was brought up as an item that would fall under the scope of the WGs which wasn't really something I'd thought was in play there.
18:31:12 <mmaslano> yeah
18:31:13 <abadger1999> mmaslano: <nod>  yeah -- if you wnt to lead, I think that would be good.
18:31:52 * mitr owns up to the "how things are packaged"
18:32:00 <abadger1999> mattdm: After thinking about it-- I don't think it really falls under any of the working groups.
18:32:03 <sgallagh> So "Base Design" and "Workstation" are left.
18:32:24 <abadger1999> and it's a larger scope than FPC handles atm (beyond rpm packaging).
18:32:29 <mitr> Or, more precisely, "what is a Linux application?" is, I think, a core are of the Base Design WG; I'd love to see if others view it differently.
18:32:35 <sgallagh> I rather wish notting was here today, as I suspect he'd volunteer for the former.
18:32:37 <abadger1999> I think we should create a new group for that.
18:32:38 <mattdm> notting for base design?
18:32:49 * abadger1999 would like to volunteer notting for base design too :-)
18:33:14 <jwb> all this volunteering is for fesco leads?
18:33:16 <jwb> or?
18:33:25 <mattdm> let's do that and then if he comes back and says "wait no" then we will revisit
18:33:25 <sgallagh> jwb: For FESCo liason, yeah
18:33:28 <t8m> jwb, yep
18:33:29 <jwb> ok
18:33:33 <nirik> coordinators...
18:33:35 <mitr> abadger1999: I'd suggest putting a 1-year moratorium to creating more bureaucracy.  We already have the problem of having established groups and not being precisely sure what their scope is, let's not make that worse.
18:33:38 <abadger1999> He can read that as a vote of confidence or a vote of get-someone-else-to-do-that-work as he wishes :-)
18:33:38 <sgallagh> Sure
18:33:40 <nirik> basically provide reports back to fesco
18:33:50 <t8m> mitr, +1
18:34:13 <jwb> nirik, yeah.  i just came in late, so i wanted to make sure it wasn't some bizarre in-person volunteering for being on the gruop
18:34:22 <pjones> so the obvious problem we have here is this: nobody on FESCo works on desktop stuff, so nobody is volunteering for Workstation.
18:34:31 * nirik nods.
18:34:42 <jwb> pjones, one could imagine a delegate would be acceptable.
18:35:01 <mmaslano> #info notting was volunteered as co-ordinator for Base Design WG
18:35:06 <pjones> jwb: i.e. the liason being /from/ the WG?
18:35:23 <sgallagh> #info sgallagh has volunteered as coordinator for Server WG
18:35:31 <sgallagh> #info mattdm has volunteered as coordinator for Cloud WG
18:35:51 <jwb> pjones, yes.  i mean, if nobody is comfortable doing the liason for the WG because of lack of experience in that area... not to knock anyone but it doesn't take a lot of experience to provide status to FESCo
18:36:01 <sgallagh> #info mmaslano has volunteered as coordinator for Environments/Stacks WG
18:36:06 <jwb> i could obviously be missing something
18:36:13 <abadger1999> mitr: Only if you're fine with the FPC carrying that burden for now (talked with geppetto earlier and he felt FPC could carry that if needed so there was at least one other person who felt that could be done).
18:36:23 <sgallagh> jwb: Well, the FESCo coordinator will be a voting member of the WG
18:36:38 <sgallagh> so we want someone who will participate (and potentially be a tie-breaking vote)
18:37:10 <mitr> abadger1999: In principle i'm not, in practice I don't expect things in this area to change for F21 so I don't care that much...
18:37:13 <sgallagh> I was rather hoping that nirik would volunteer for this, since of all of us he has the most desktop experience (with XFCE)
18:37:50 <jwb> sgallagh, forcing a voting member that doesn't understand what they're voting for sounds... well it sounds strange :)
18:38:06 <nirik> well, I am low on time... and I don't know that the workstation product will have anything to do with xfce
18:38:08 <pjones> sgallagh: ... which arguably either makes him most or least qualified ;)
18:38:39 <abadger1999> mitr: k.  then we can call it a compromise until we are ready to get a new group formed :-)
18:38:40 <jwb> sgallagh, i understand the intentions, i really do.  sometimes things don't work out perfectly
18:38:44 <sgallagh> pjones: I'm willing to say that having a non-GNOME voice on that WG would be a good sign that it's not going to be "Whatever GNOME upstream does"
18:38:47 <nirik> so, if we could find someone more involved I think it might be better...
18:39:14 <mitr> sgallagh: ... or signs them up for an exercise in endless frustration?
18:39:19 <mmaslano> nirik: who else from fesco?
18:39:31 <sgallagh> mitr: They're already on FESCo. Plenty of practice.
18:39:59 <abadger1999> sgallagh: or that they will be continuously pushing round rocks uphill :-)
18:40:10 <mattdm> I don't think the person necessarily needs to be involved with the development as long as they're involved in the fedora community and are willing to _become_ involved in the topic enough to contribute
18:40:33 <jwb> mattdm, yes, fair
18:41:06 <nirik> sure, which means more time... :)
18:41:14 <mattdm> but that still apparently leaves us stuck :)
18:41:18 <jwb> i see everyone now jumping at once with mattdm's clarification.
18:41:24 <jwb> :)
18:41:28 <mattdm> nirik yes -- it's definitely a time commitment
18:42:23 <nirik> so, for that would we consider a non fesco coordinator?
18:42:29 <sgallagh> Ok... does anyone want to vacate their chair and make room for a new member?
18:43:17 <mattdm> again don't everyone jump at once :)
18:43:29 * abadger1999 thinks that as long as fesco is elected we'll need to cross nirik's bridge eventually.
18:43:42 <mattdm> "nirik
18:43:45 <mattdm> 's bridge"?
18:43:47 <sgallagh> Actually, I have an important question: with the schedule delay, are we pushing back the elections cycle as well? Or should we be concerned about one of these coordinators being booted next month?
18:44:02 * pjones nominates jwb
18:44:07 <abadger1999> mattdm: having non-fesco WG liasons/coordinators.
18:44:17 <pjones> abadger1999: I really think you're right.
18:44:29 <abadger1999> I think we should push back the elections as well.
18:44:40 <t8m> abadger1999, +1
18:44:45 <sgallagh> abadger1999: I'm inclined to agree, until at least after the WG report-out
18:44:54 <sgallagh> Although I *think* that may need to come from the Board.
18:45:14 <t8m> What about giving the non-fesco WG coordinator voting power in FESCo for topics related to the WG?
18:45:17 <pjones> I think that does have to come from the board, but I think it's a reasonable thing for us to request from them.
18:45:23 <jreznik> well I always wanted to have fesco aligned with release
18:45:39 <mattdm> yes, I don't think fesco should have the ability to unilaterally declare ourselves president for life
18:45:43 <mattdm> but +1 to asking for it
18:45:50 <jwb> wait, which thing are you asking the board about?
18:45:58 <jwb> elections or non-fesco WG liasons?
18:46:00 <sgallagh> jwb: Moving the elections
18:46:07 <mattdm> fesco elections
18:46:10 <jwb> oh, ok.  i don't find that unreasonable
18:46:11 <drago01> mattdm: fwiw yeah that sounds very odd to me
18:46:27 <drago01> mattdm: in theory fesco could always "push back the elections" and never get relected
18:46:54 <sgallagh> Yeah, I suggest we ask the Board for a one-time push until after WG report-out, lest we end up doing this dance again then
18:46:56 <pjones> except nobody on fesco seems to think we can ;)
18:47:07 <jwb> though tbh, i don't think there's anything that says the board has to approve changes to the fesco election cycle/composistion
18:47:17 <mattdm> so, I'm okay with non fesco wg liason _or_ with someone stepping down and electing that position
18:47:30 <sgallagh> Anyway, back to the original issue: jwb are you volunteering for the Workstation WG as non-FESCo coordinator if we opted for one?
18:47:46 * nirik wonders if kalev might be willing if we are looking for non fesco
18:47:48 <sgallagh> Partly joking
18:48:03 <sgallagh> Ah, yeah kalev might be a good choice
18:48:05 <jwb> i would do it if needs be.  you might also ask mjg59, who has dealt with more of that area than i
18:48:09 <jwb> or kalev
18:48:24 <jwb> but yes, i would volunteer if a more suitable person wasn't found
18:48:26 <sgallagh> Or possibly Marina?
18:49:02 <mitr> sgallagh: who?
18:49:16 <pjones> I think either of the former-FESCo members (jwb, mjg59) would be completely reasonable choices.
18:49:22 <sgallagh> mitr: http://blogs.gnome.org/marina/
18:49:44 <pjones> sgallagh: I'd rather somebody who has more history with fesco.
18:50:07 <mattdm> mjg59 had some strong feelings about the direction of the product in the board meeting
18:50:25 <pjones> mattdm: and also some history working with e.g. gnome successfully.
18:50:58 <sgallagh> Not that I don't like anyone here, but if someone was tired of their role in FESCo, having the community vote for a replacement that would fill this role as well might be a good move.
18:51:27 * nirik notes jwb then kalev were the two runners up in the last election.
18:52:24 <mattdm> I think any of these proposals would work. (Which is nice, but doesn't help make a decision.)
18:52:40 <abadger1999> nirik: good point
18:52:55 <mjg59> I'm happy to do it
18:53:07 <mjg59> But obviously this is a fesco decision
18:53:32 <mitr> proposal: FESCo would like jwb to coordinate the workstation WG.
18:53:53 <pjones> mitr: +1
18:54:04 * nirik is +1 to mitr's proposal provided jwb wants it. ;)
18:54:05 <mitr> If we have to decide, let's stop dancing around it...
18:54:15 <jwb> i said i would
18:54:23 <nirik> ok, great
18:54:41 <t8m> great
18:54:42 <sgallagh> no offense intended to jwb, but I'd rather hear kalev turn it down first.
18:54:53 <abadger1999> mitr: +1
18:55:11 <pjones> sgallagh: why?  we have a volunteer who seems to be a perfectly reasonable person to do it?
18:55:26 <jwb> perhaps sgallagh is trying to save me suffering.
18:55:28 <jwb> :)
18:55:37 <sgallagh> jwb: I do owe you a favor for the krb5 fixes
18:55:59 <jwb> anyway, you have two people who said they'd do it (me and mjg59).  if you want kalev to do it that's fine with me.  just let me know
18:56:05 <jwb> i just want things to progress
18:56:09 <sgallagh> Yeah, me too.
18:57:08 <sgallagh> Ok, I'm +1 for jwb as well
18:57:21 <mattdm> I am +1 too in case that wasn't clear
18:57:36 <pjones> assuming mitr is +1 that's +6
18:57:42 * mitr is +1 for the record
18:57:48 <drago01> pjones: wouldn't mclasen fit best in your description?
18:58:06 <sgallagh> drago01: did mclasen volunteer for the job?
18:58:29 <drago01> sgallagh: not that I am aware off just done reading scrollback
18:58:59 <mitr> (sgallagh: to be fair he wasn't given a chance)
18:59:13 <mattdm> this isn't a lifetime job, in any case.
18:59:27 <t8m> +1 to jwb
18:59:35 <jwb> my feelings will not be hurt if someone more suitable is found
18:59:50 <pjones> mitr: I don't think that's a fair statement.  jwb and mgj59 both showed up and mentioned they'd be willing to do it.
19:00:08 <mmaslano> +1 for jwb
19:00:08 <sgallagh> Do we want to send a message to the devel list and ask for volunteers?
19:00:22 <mattdm> although sometimes showing up at an irc meeting doesn't match with timezones and schedules and whatever else
19:00:27 <pjones> no.  we don't need to find the best person ever.  we need to find somebody good enough and willing.
19:00:31 * nirik thinks we approve jwb and move on
19:00:32 <mitr> pjones: you're right
19:00:32 <sgallagh> Given that we're selecting outside of FESCo in any case, it seems limiting to only pick people who happened to come to the meeting
19:00:43 <jwb> look, if it makes it easier you can call me interim coordinator and do the call
19:00:45 <abadger1999> nirik: yes
19:00:51 <mitr> mattdm: having available time during the time FESCo meets is somewhat of a precondition
19:01:16 <abadger1999> otherwise we'll hit sgallagh's two hour limit ;-)
19:01:19 <sgallagh> jwb: Well, the first order of business is to select the rest of the group
19:01:37 <sgallagh> jwb: So it seems a little obnoxious to let you pick the WG and then dump it on someone else :)
19:01:49 <jwb> is there a deadline set for that?
19:01:52 <sgallagh> If we go with you, it's you until January
19:02:00 <sgallagh> Not yet, that was going to be the next order of business.
19:02:19 <jwb> ok
19:02:24 <sgallagh> I was originally going to suggest that the coordinators prepare their lists for ratification at next week's meeting
19:03:42 <mattdm> to be clear, picking the group is much sooner than january.
19:03:49 <mattdm> like, something for the next two weeks.
19:03:51 <sgallagh> Right
19:04:02 <jwb> there's nothing listed about numbers either, correct?
19:04:07 <jwb> number of members i mean
19:04:33 <sgallagh> Proposal: Ask the volunteers listed on the WG_Nominations page if any of them want to be the non-FESCo coordinator and select from that list next week. Ratify working groups in the meeting after that one.
19:04:37 <abadger1999> jwb: correct.
19:04:48 <sgallagh> I thought we agreed on nine, was I imagining that?
19:05:14 <nirik> well, 8
19:05:17 <abadger1999> sgallagh: yeah -- we tossed numbers around but never said you shall be nine, no more no less.
19:05:24 <nirik> if we have a coordinator taking one slot already
19:05:24 <sgallagh> Right, eight besides the coordinator
19:05:33 <jwb> the wiki pages (which i've been following) make no mention
19:05:45 <sgallagh> jwb: It was discussed in the meeting two weeks ago
19:05:57 <sgallagh> I think we may not have come to an agreement on that, though
19:06:05 <jwb> and you didn't update the wiki pages ;)
19:06:05 <abadger1999> sgallagh: oooh... or perhaps we said the wg should determine how many were in its final going-forward form.
19:06:13 <abadger1999> whereas this is an initial seed.
19:06:16 <sgallagh> abadger1999: Yeah, I think that's what it was.
19:06:25 <sgallagh> Nine to bring the ring to Mordor...
19:06:26 <mmaslano> 8 voting members and so many as want attend?
19:06:26 <abadger1999> <nod>
19:06:30 <mmaslano> sgallagh: yeah
19:06:45 <mattdm> mmaslano yes, absolutely want to encourage non-voting-member participation
19:06:55 <nirik> yes. +100
19:07:04 <sgallagh> Unreservedly, yes
19:07:16 <nirik> everything should default to open, public meetings and discussion and input from anyone who wants in the community
19:07:17 <mattdm> okay, so: proposal: working groups will have 9 initial voting members, including fesco coordinator
19:07:27 <sgallagh> mattdm: +1
19:07:28 <nirik> sure, +1
19:07:29 <pjones> mattdm: +1
19:07:37 <t8m> mattdm, +1
19:07:38 <mmaslano> mattdm: you write faster, +1
19:07:41 <abadger1999> mattdm: +1
19:08:13 <sgallagh> Assuming mattdm is +1 to his own proposal, that's +7
19:08:14 <mitr> +1 (I don't care let's stop talkig about this)
19:08:28 <sgallagh> #agreed working groups will have 9 initial voting members, including fesco coordinator (+8, 0, -0)
19:08:56 <sgallagh> Ok, so can we vote on my proposal? A +1 indicates waiting a week to find a Workstation coordinator, a -1 means select jwb as we already voted.
19:09:06 <abadger1999> -1
19:09:10 <sgallagh> We can vote  on the second half (timing for group selection) separately.
19:09:14 <mitr> -1
19:09:16 <sgallagh> I'm +1
19:09:22 <abadger1999> let's get to having the working groups selected by next week already :-)
19:09:24 <mitr> Let's start getting things done
19:09:43 <nirik> -1
19:09:45 <mattdm> I'm in favor of jwb as coordinator _and_ of moving on, but I want to make sure we have a fair, transparent process
19:09:53 <mattdm> so +1
19:10:20 <sgallagh> +2,-3 thus far
19:10:45 <Southern_Gentlem> mattdm,  read the vote question you may want to change your vote
19:11:06 <pjones> -1
19:12:12 <sgallagh> +2, -4. mmaslano? t8m?
19:12:15 <pjones> sgallagh: as I read that, your proposal is not going to get enough votes to pass with the current number of people present.
19:12:23 <sgallagh> yes
19:12:23 <pjones> at best it could tie.
19:12:27 <mmaslano> sgallagh: I was waiting for proposal, which I can parse
19:12:38 <t8m> -1
19:12:53 <sgallagh> Ok, with -5 we go with jwb
19:13:21 <sgallagh> mmaslano: Sorry, the idea was to spend a week looking for other volunteers before making a decision. It did not pass
19:13:55 <sgallagh> #agreed Proposal to defer a week to seek other volunteers for Workstation WG coordinator fails (+2, 0, -5)
19:14:14 <sgallagh> Next proposal: Initial working groups due next FESCo meeting for ratification
19:14:43 <nirik> yeah, I think that would be nice.
19:14:48 <pjones> sure, +1
19:14:51 <sgallagh> jwb: Sorry for your loss :-P
19:15:10 <jwb> i'm a big boy.  i'll be fine
19:15:15 <abadger1999> +1
19:15:36 <mitr> +1
19:15:49 <sgallagh> +1 (for the record)
19:15:55 <nirik> +1 if it wasn't clear above
19:15:58 * mattdm looks at calendar
19:16:03 <mattdm> okay +1 let's do it
19:16:10 <t8m> +1
19:16:27 <mmaslano> +1
19:16:43 <sgallagh> #agreed Initial working groups due next FESCo meeting for ratification (+8, 0, -0)
19:16:53 <sgallagh> Ok, let's put this topic to rest for today
19:17:02 <sgallagh> New business!
19:17:09 <sgallagh> #topic #1181 Fedora still vulnerable to BEAST
19:17:13 <sgallagh> .fesco 1181
19:17:14 <zodbot> sgallagh: #1181 (Fedora still vulnerable to BEAST) – FESCo - https://fedorahosted.org/fesco/ticket/1181
19:18:07 <sgallagh> So we have a known security vulnerability in Fedora that's unpatched because it negatively impacts unknown programs.
19:18:36 <sgallagh> (One program, pidgin-sipe is listed, others are suggested but not named)
19:18:47 <t8m> I'd rather prefer making TLS1.2 default in nss in Fedora
19:19:02 <sgallagh> t8m: versus what?
19:19:05 <t8m> this solves BEAST as well
19:19:14 <mattdm> as I understand it, the security team is in favor of patching it now and fixing any problems in the packages as they come up
19:19:18 <pjones> sgallagh: versus taking the patch again
19:19:19 <t8m> versus the fix for BEAST which is a hack
19:19:30 <sgallagh> t8m: Ok
19:19:43 <sgallagh> Are the two moves mutually-exclusive?
19:19:47 <t8m> nope
19:20:07 <Sparks> .
19:20:12 <pjones> the better question is: is moving to TLS1.2 by default enough, or do we also need to disable TLS1.0?
19:20:21 <sgallagh> Proposals: 1) Re-apply the patch and ask maintainers to fix their packages. 2) Change the default to TLS 1.2
19:20:28 <sgallagh> I'm +1/+1
19:20:42 <t8m> pjones, of course you'll be still vulnerable to beast if the TLS1.0 is negotiated
19:20:42 <pjones> sgallagh: could we talk about this for long enough to have an understanding before making and voting on proposals?
19:20:55 <mitr> 2) isn't that simple, I think it might require per-application patches again (t8m?)
19:21:18 <t8m> mitr, nope no application patches I think
19:21:19 <nirik> proposal: tell maintainer we want beast fixed, even if it causes problems for some fringe package, ask them to figure out the best way to do that.
19:21:37 <mattdm> _what_ would be change to default to tls 1.2? is that just changing the library?
19:21:41 * nirik is trying to do as little micromanaging as possible
19:21:46 <mitr> Note that the BEAST issue/broken applications have been around for almost two years.  If application patching hasn't happened by itself so far, I don't think we should assume that it will happen by itself now.
19:22:07 <pjones> nirik: that appears to have already happened and /unhappened/ which is why this is here now?
19:22:19 <mattdm> +1 nirik
19:22:31 <sgallagh> mitr: I'm willing to say that if they don't fix themselves, it's not our problem.
19:22:31 <t8m> the problem is that the fix breaks applications/protocols interoperability so I can understand why nss devs do not want it
19:22:43 <abadger1999> mitr: drop packages that won't fix?  isn't that the normal Fedora procedure?
19:22:46 <nirik> pjones: well, the maintainer didn't think beast fixing was important enough to break some apps, but we do? or do we?
19:22:57 <mitr> abadger1999: drop them within F18/F19?  The bug suggests that F20 is already OK
19:23:04 <pjones> nirik: I don't think we've answered that yet.  *I* do.
19:23:06 <mattdm> nirik security team does
19:23:29 <mitr> sgallagh: In principle, yes.  (Change page for F18 :-)?)
19:23:32 * nirik does too. Sorry pidgin-cipe. ;)
19:23:44 <nirik> sipe.
19:25:05 <pjones> t8m: hrm.  so either way breaks compatibility then, since we effectively need to either a) do this hacky patch, or b) disable TLS1.0
19:25:31 <t8m> pjones, the severity of BEAST attack is very low
19:25:43 <mattdm> can tls1.0 be renabled by individual applications that want to be insecure?
19:25:45 <mitr> Given the schedule, I think requiring this for F18 is not really worth it.
19:25:58 <mattdm> t8m but BEAST sounds very scary!
19:26:01 <mattdm> mitr lol
19:26:19 <mitr> mattdm: That's what the bug asks for - fixing this in f18 and f19
19:26:37 <mitr> mattdm: It's also a matter of interoparability; deployment of 1.2 is not that widespread
19:27:01 <Sparks> If I may...
19:27:06 <sgallagh> Sparks: Please
19:27:50 <Sparks> implementing TLSv1.2 is a great idea but won't fix BEAST since many servers only support TLSv1.0 as their high end.
19:28:29 <Sparks> Disabling TLSv1.0 fixes BEAST (kinda) but leaves us with not many options for establishing a circuit since TLSv1.1 and 1.2 aren't really out there.
19:29:41 <Sparks> BEAST is low, right now, because most servers "fixed" it by using an awful encryption option: RC4.  We're trying to get away from the bad cipher now but that introduces the BEAST problem when the clients aren't "fixed".
19:30:00 <abadger1999> mitr: Note -- I think we're talking about F20+ as well.  See this comment for what the nss maintainer has been doing in the past: https://bugzilla.redhat.com/show_bug.cgi?id=770682#c23
19:30:35 <Sparks> abadger1999: Yeah, I was confused by what he meant but I didn't like what I was thinking.
19:31:05 <abadger1999> mitr: I believe he's saying the same thing in https://bugzilla.redhat.com/show_bug.cgi?id=1005611#c4  but his wording is extremely confusing there... much easier to understand in 770682#c23
19:31:34 <mitr> abadger1999: I read both as "f20 is fixed"
19:31:40 <mitr> Let's look at the package
19:33:03 <mitr> abadger1999: you're right, it seems enabled in F20 (not rawhide)
19:33:28 <abadger1999> <nod>
19:33:36 <mitr> Sparks: So, if there no urgency "right now", is it likely to become more urgent during the lifetime of F19?
19:34:48 <Sparks> mitr: I believe there is urgency now.
19:35:18 <Sparks> mitr: The SSL/TLS implemtation guidance is now to disable RC4 which is the bandaid for BEAST
19:35:44 <mitr> Sparks: That's true whether or not Fedora has a workaround for Beast, isn't it?
19:36:02 <Sparks> Yes.  So that will mean that all Fedora users will be vulnerable soon
19:36:20 <mitr> Sparks: sorry, I have misread.
19:37:11 <Sparks> The only hold outs have been Apple.
19:37:20 <mitr> So I'm fairly sure about asking the maintainers to drop the workaround for F20, about not really caring for F18, and unsure about F19
19:37:27 <Sparks> But even Microsoft patched IE pretty quickly
19:38:11 <mitr> IIRC browsers have infrastructure for site-specific whitelists already; the role of NSS is somewhat more difficult in this regard
19:38:52 <Sparks> site-specific whitelists?
19:39:26 <pjones> F18 really does seem out of scope
19:39:41 <t8m> Is there really serious attack in the wild that uses BEAST or are we talking about theoretical MITM attacks?
19:39:44 <mitr> Sparks: IE has the list of sites to use the compat view; site-specific configuration not to use particular TLS options would be a natural extension, but doing this in the current NSS API is difficult
19:39:49 <sgallagh> Sparks: Do you have a proposal?
19:40:02 <mitr> t8m: By the time there will be an attack in the wild we won't be able to get this fixed
19:40:15 <sgallagh> We're over the fifteen minute mark (not that we've really been paying attention to it)
19:40:17 <pjones> sgallagh: in the ticket he asked us basically to have the nss patch re-applied and tell apps to patch if needed to make it work.
19:40:59 <Sparks> sgallagh: My proposal is to make the default implementation BEAST resistant and then if individual packages have problems have them patch their software with the undo settings.
19:41:03 <mattdm> right and I'm still +1 to that
19:41:05 <pjones> t8m: it's been public for two years.  we can assume there's an attack in the wild and we simply don't know about it.
19:41:22 <pjones> mattdm: yeah, I think I'm +1 to that as well.
19:41:35 <pjones> in F20 and F19, though.
19:41:44 <sgallagh> mattdm: "that" is reapplying the existing patch, right? If so, +1
19:41:47 <mitr> pjones: attacking this is not really trivial, probably not a script kiddie stuff
19:42:06 <pjones> mitr: I didn't figure it was, no.
19:42:30 * nirik is also +1 to 19 and 20 at least
19:44:22 <sgallagh> We're at +4. Any other votes?
19:44:27 <abadger1999> +1
19:44:48 <mmaslano> +1
19:44:55 <t8m> +0
19:45:02 <sgallagh> Also, I have to leave in fifteen minutes. We still have one item on the agenda, plus adamw asked me to raise something in open floor. Does someone else want to take over as chair?
19:45:09 <mitr> +1 to f20
19:45:17 <sgallagh> mitr: Not F19?
19:45:34 <pjones> we're at +7,0:1,-:0 for F20, and one less than that for F19.
19:46:03 <sgallagh> pjones: I only count +6/+5,
19:46:18 <sgallagh> I miscounted
19:46:27 <sgallagh> Okay, so that's F19 and F20 then
19:46:32 <mitr> sgallagh: I'm not sure about changing F19 applications and just cavalierly seeing what breaks
19:46:52 <mitr> I can live with it
19:46:57 <pjones> might we want to look at that in F20 and then come back and reconsider F19?
19:47:02 <sgallagh> #agreed Apply BEAST patches on F19 (+7,0,-0) and F20 (+6, 0, -0)
19:47:09 <pjones> (eh, whatever.)
19:47:17 <mitr> Just please make sure that this is announced on fedora-devel well enough
19:47:21 <mattdm> it can go in updates-testing and live there for a while
19:47:31 <pjones> mattdm: yeah.
19:47:32 <sgallagh> Sparks: Can you handle the announcement?
19:47:40 <abadger1999> #undo
19:47:40 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x1414c290>
19:47:40 <Sparks> sgallagh: I can.
19:47:53 <abadger1999> #agreed Apply BEAST patches on F19 (+6,0,-0) and F20 (+7, 0, -0)
19:47:58 <sgallagh> oops, thanks
19:48:09 <sgallagh> #agreed Apply BEAST patches on F19 (+6,0,-0) and F20 (+7, 0, -0)
19:48:20 <pjones> #info sparks to announce on fedora-devel
19:48:29 <sgallagh> Ok, moving on to the last item
19:48:34 <sgallagh> #topic #1182 Python 3 as the Default Implementation - https://fedoraproject.org/wiki/Changes/Python_3_as_Default
19:48:39 <sgallagh> .fesco 1181
19:48:40 <zodbot> sgallagh: #1181 (Fedora still vulnerable to BEAST) – FESCo - https://fedorahosted.org/fesco/ticket/1181
19:49:47 <sgallagh> abadger1999: Mind taking the lead here?
19:49:51 <abadger1999> .fesco 1182
19:49:54 <zodbot> abadger1999: #1182 (F21/F22 System Wide Change: Python 3 as the Default Implementation - https://fedoraproject.org/wiki/Changes/Python_3_as_Default) – FESCo - https://fedorahosted.org/fesco/ticket/1182
19:50:04 <sgallagh> oops
19:50:06 <mitr> +1 to the general idea; not sure about timing - the software mgmt plan proposed dnf to be ready in "1-2 years" as opposed to this change proposing a change by f22
19:51:00 <abadger1999> The owners haven't communicated with me any more than anyone else -- discussion is on devel or python-devel@lists.fp.o
19:51:09 <pjones> I'm +1 to this.
19:51:14 <sgallagh> mitr: Well, F22 will likely be at least 16 months from now
19:51:14 <abadger1999> I think I'm mostly for this but there are some details I'd iron out.
19:51:28 <abadger1999> Dennis had some issues with the contingency plan
19:51:28 * nirik didn't have time to fully read it. Could we punt to next week since we have been here almost 2 hours?
19:51:43 <sgallagh> I'm +1 in general to this. I agree that some of the timing needs to be coordinated.
19:51:51 <mmaslano> obviously +1
19:51:52 <abadger1999> I think a contingency plan of "We ship with some things using python3 and other thigns using python2" might be more appropriate.
19:51:58 <sgallagh> I'd rather give them the approval to go ahead early on.
19:52:15 <t8m> +1
19:52:15 <mmaslano> abadger1999: I'd like to have concrete problems, anyway we don't have to migrate relengs scripts to python3
19:52:19 <mitr> It's not obvious to me that we will need the side tag _that_ much, but we can figure that out later.
19:52:23 <abadger1999> We need to clarify whether DNF will have bindings for both python2 and python3.
19:52:24 <sgallagh> abadger1999: Mind communicating that back to them?
19:52:31 <pjones> nirik: I'm fine with that too.
19:52:33 <abadger1999> That might affect releng/infrastructure.
19:52:54 <abadger1999> It would definitely affect package maintainers if mock (python2) couldn't work with dnf.
19:52:59 <mmaslano> abadger1999: python2 will be still in distribution, so relengs need only dnf bindings
19:53:10 * mattdm would also like to punt to next week. i don't have the brainpower for this left right now.
19:53:23 <abadger1999> mmaslano: right -- that's why I want to have it clarified that dnf will provide both py2 and py3 bindings.
19:53:41 <mitr> abadger1999: I don't think that will happen, but let's have this discussion on the mailing list
19:53:43 <abadger1999> sgallagh: I could but -- dgilmore already communicated that to them on the list.
19:53:52 <mmaslano> ok, let's move to mailing list
19:54:06 <abadger1999> mitr: don't think what will happen?
19:55:10 <sgallagh> Proposal: move to devel list and revisit next week
19:55:11 * abadger1999 good to move this onto the list
19:55:18 <t8m> sgallagh, +1
19:55:26 <abadger1999> +1
19:55:40 <mitr> sgallagh: +1
19:55:52 <mmaslano> +1
19:55:58 <mitr> abadger1999: Actually, scratch that; I don't know anyway
19:56:03 <abadger1999> okay
19:56:04 <pjones> sgallagh: +1
19:56:13 <mattdm> +1
19:56:49 <nirik> +1
19:57:30 <sgallagh> #agreed Discuss the Change on the mailing list for one week and revisit (+8, 0, -0)
19:57:36 <sgallagh> #topic Next week's chair
19:58:07 <sgallagh> Who gets the conch shell next week?
19:58:15 * sgallagh wonders how many people get that reference
19:58:32 <adamw> everyone who ever took an english class
19:58:42 <Viking-Ice> you guys dont want to settle the prelink this time around. Do you guys need a formal proposal having it removed from the standards group or?
19:58:54 * abadger1999 managed to not have that book assigned to him ever
19:59:10 <adamw> abadger1999: witch!
19:59:13 <pjones> Viking-Ice: if you'd like to file a ticket proposing something, that'd be a thing we could take up next week, yeah.
19:59:16 <sgallagh> Viking-Ice: Yes please. I for one will vote for it to be burned at the stake
19:59:37 <abadger1999> <nod>  I think we should definitely take it up -- a ticket will help make sure that happens.
19:59:40 <sgallagh> Ok, so chair volunteer?
19:59:48 * nirik is also in favor of killing prelink with fire.
20:00:02 * sgallagh notes we're not yet in open floor
20:00:06 <mattdm> fire, acid, whatever it takes :)
20:00:51 <nirik> sgallagh: I can take it if no one else is willing
20:00:58 <sgallagh> Thanks nirik
20:01:09 <sgallagh> #action nirik to chair next week's meeting
20:01:15 <sgallagh> #topic Open Floor
20:01:23 * adamw has somehing
20:01:24 <sgallagh> adamw: You had some concerns to raise?
20:01:47 <adamw> yeah. really just wanted to note that we had a blocker review meeting for beta this week, and overall, we're somewhat worried that all  blockers may not be addressed in time for go/no-go
20:02:13 <adamw> go/no-go is the 24th, there are 9 open blockers, and several assigned to anaconda team, who are working on Other Products atm too
20:02:32 <mitr> (jreznik has left already)
20:02:34 <adamw> not sure if anyone can do anything much about this, but it seemed worth forewarning
20:02:35 <Viking-Ice> that will always be an issue btw
20:02:49 <mitr> adamw: Just wanted to ask whether we have any options :)
20:03:16 * abadger1999 is okay with voting for extending the schedule if that's needed
20:03:21 <adamw> well, if anyone can help provide a patch for any blockers it wouldn't hurt :)
20:03:26 <adamw> the list is at https://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist
20:03:38 <sgallagh> adamw: Well, we can assume that the blockers for Fedora are also issues in Other Products, so hopefully they'll just get priority
20:03:47 <sgallagh> Otherwise, that's what Go/No-Go is for
20:03:51 <adamw> yeah
20:04:02 <abadger1999> #info help needed for solving blockers: https://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist
20:04:10 <mattdm> also, there do not seem to be ec2 images to test
20:04:23 <sgallagh> adamw: Would you mind indicating the deadlines on those blockers, so they're certain to be aware of the impact?
20:04:24 <Viking-Ice> I'm personally more concerned how the heck we are supposed to deal with multiple products then slippage which is kinda a la tradition
20:04:33 <sgallagh> Just in case they aren't aware of the schedule
20:05:00 <adamw> Viking-Ice: this meeting's already gone on for like three hours
20:05:09 <adamw> sgallagh: i know anaconda team knows about it, i'll make sure the others do too
20:05:10 <sgallagh> Viking-Ice: It's a valid question and one that deserves consideration. That said, it's already been a two-hour meeting and I'd rather table that for the moment if it's okay with you.
20:05:16 <adamw> i can send a blocker bug summary email out too
20:05:48 <sgallagh> adamw: That would be very helpful, thank you
20:06:04 <sgallagh> #action adamw to send out blocker bug summary email
20:06:17 <adamw> mattdm: have you checked with dgilmore about that?
20:06:51 * adamw doesn't remember if we always do ec2
20:06:52 <sgallagh> #info blocker list is at https://qa.fedoraproject.org/blockerbugs/milestone/20/beta/buglist. If anyone can help provide a patch for any blockers it wouldn't hurt :)
20:07:21 <Viking-Ice> sgallagh, there is nothing to talk about until I get a meaningful response from the anaconda team what they can do and what they cannot do ( or are not willing to do ) so no worries dragging this on atleast not on my behalf
20:07:39 <Viking-Ice> ( the meeting that is )
20:07:40 <sgallagh> Viking-Ice: Much obliged. And thank you for taking point on that.
20:07:44 <mattdm> adamw there were apparently problems with generating images _at all_ for tc3, but qcow2 images showed up for tc4. i haven't asked dennis yet.
20:07:53 <mattdm> because, busy.
20:09:37 * abadger1999 notes dgilore will be on vacation soon.
20:10:10 <adamw> mattdm: tc4 was done almost immediately after tc3 with a workaround for the image generation issue (which only affected pungi-derived images aiui)
20:10:17 <adamw> anyhoo, deep background.
20:10:17 <mattdm> who is responsible for this while dennis is on vacation?
20:12:15 <nirik> he should still be available to do rc's.
20:12:38 <sgallagh> Do we allow dgilmore to take vacations? Isn't he critical infrastructure?
20:12:43 <sgallagh> (only mostly kidding)
20:13:30 <sgallagh> mattdm: Do you need any kind of decision here, or should we just note it and move on?
20:13:42 <dgilmore> tc4 reverted the cloud image kickstart firewall changes
20:13:43 <mattdm> note and move on for now
20:13:54 <dgilmore> there wa sa couple of missed packages that got pulled in also
20:14:39 <mattdm> yeah that firewall change was based on a bug in anaconda being addressed but apparently the change didn't trickle into appliance-creator
20:14:42 <sgallagh> Ok, do we have any other open-floor business or can we call it a day?
20:15:09 <dgilmore> mattdm: well anaconda is not involved at all
20:15:17 <dgilmore> so seriously bad call
20:15:59 * sgallagh will close the meeting in one minute
20:16:01 <mattdm> a) I expected that it would be the primary build method at this point and b) the code path goes through pykickstart, so it is *not* as separate as all of that
20:16:04 <adamw> that's enough for my topic
20:16:39 <mattdm> the bad call is clinging to appliance-creator when no one is maintaining it.
20:17:02 <sgallagh> #endmeeting