i18n
LOGS
06:01:27 <tagoh_> #startmeeting i18n
06:01:27 <zodbot> Meeting started Thu Oct  3 06:01:27 2013 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:01:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:01:27 <tagoh_> #meetingname i18n
06:01:27 <zodbot> The meeting name has been set to 'i18n'
06:01:28 <tagoh_> #topic agenda and roll call
06:01:28 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2013-10-03
06:01:34 <anish_> Hi!
06:01:35 <tagoh_> okay, shall we have i18n meeting
06:02:15 <paragan> hi
06:02:35 <fujiwarat> hi
06:07:46 <juhp> hello
06:08:08 <dueno> hi
06:08:13 <tagoh_> sorry.. okay, let's get started.
06:08:20 <tagoh_> #topic Upcoming schedule
06:08:21 <tagoh_> #info 2013-10-08        Software Translation Deadline
06:08:21 <tagoh_> #info 2013-10-15        Beta Change Deadline
06:08:21 <tagoh_> #info 2013-10-15        Accepted Changes 100% Complete
06:08:22 <tagoh_> #info 2013-10-29        Beta Release
06:08:42 <tagoh_> and Oct 29th for our test day btw
06:09:01 <paragan> F20 Beta TC1 is now available
06:10:10 <pravins> hi
06:10:14 <tagoh_> if you have any packages for translations you may need to update your packages with it next week until beta change deadline
06:10:30 <tagoh_> just fyi
06:11:47 <tagoh_> paragan: yes. thanks for info
06:12:09 <juhp> paragan, oh :)
06:12:10 <skore> hi
06:12:44 <tagoh_> #topic Outstanding topics
06:12:44 <tagoh_> #info #24: Fedora 20 i18n docbeats (i18n@lists.fedoraproject.org)
06:12:45 <tagoh_> #link https://fedorahosted.org/i18n/ticket/24
06:13:11 <tagoh_> fujiwarat: thanks for updating docbeats btw
06:14:18 <tagoh_> wiki freeze is next Monday so if you have anything else, please update with it ASAP
06:15:21 <pravins> tagoh_: yes sure
06:16:06 <smaitra__> hi
06:16:21 <tagoh_> #info #25: Bugs Corner (i18n@lists.fedoraproject.org)
06:16:21 <tagoh_> #link https://fedorahosted.org/i18n/ticket/25
06:16:34 <tagoh_> any bugs we may want to discuss today?
06:18:59 <juhp> definitely not! ;o)
06:19:04 <juhp> sorry that was irony :)
06:19:39 <tagoh_> if everything is going well that would be nice though...
06:19:54 * juhp notes we have well over 100 bugs in New
06:20:05 <juhp> well i18n-bugs
06:20:12 <tagoh_> right
06:21:13 <tagoh_> well, including needinfo too
06:21:31 <tagoh_> anyway
06:21:36 <juhp> aha
06:21:50 <juhp> I can't think of any bug right off the top of my head
06:22:15 <tagoh_> should we exclude needinfo bugs from status? or separate
06:22:28 <juhp> tagoh_, good point
06:22:37 <juhp> probably good to separate them
06:23:03 <tagoh_> okay
06:24:02 <tagoh_> will do work on it after the meeting then
06:24:13 <tagoh_> #info #26: proposal: move to using IMEs for ASCII/Latin input (i18n@lists.fedoraproject.org)
06:24:13 <tagoh_> #link https://fedorahosted.org/i18n/ticket/26
06:25:10 <tagoh_> so need to remember the discussion in the last meeting though
06:27:38 <tagoh_> is there any objections to have this feature for all engines in f21?
06:28:59 <juhp> I guess for hangul need agreement from upstream
06:29:16 <tagoh_> right
06:29:23 <juhp> not sure iirc maintainer might be opposed to the idea
06:29:36 <juhp> but we could try
06:30:24 <tagoh_> who would ask upstream about this?
06:31:00 <juhp> I guess this feature is really only useful for those who primarily only use one IME/layout
06:31:19 <juhp> but I reckon that is probably most IME users
06:31:24 <tagoh_> yes
06:31:35 <juhp> well let's majority at least
06:31:41 <juhp> let's say *
06:32:35 <juhp> anyway two things here: 1) adding functionality to more IMEs and 2) question of whether we need separate layout source
06:32:51 <juhp> 2 seemed less popular last week
06:33:09 <juhp> though it was actually the main thrust behind my proposal
06:34:09 <juhp> conversely maybe need some UI to configure layout used by each IME?
06:34:41 <juhp> for phonetic ("transliterated") input methods at least
06:35:12 <juhp> currently we leverage the layout source for that
06:35:31 <tagoh_> not as just a feature in engine?
06:36:12 <juhp> well my thinking was forcing all engines to support Latin might be hard so start with those that support Latin
06:36:42 <juhp> tagoh_, it could be but seems unnatural to have different config UI for each IME for layout
06:37:22 <juhp> if one could set/override layout when adding an IME that would be natural to me
06:37:26 <pravins> juhp: one of the feature on Enhanced inscript (inscript2) in addition of English/Latin layer
06:37:30 <tagoh_> right. so expecting to integrate it to GNOME as well?
06:37:36 <juhp> tagoh_, right
06:37:37 <pravins> So in windows, they turns on Latin with Caps lock
06:37:44 <juhp> pravins, aha
06:38:09 <pravins> we did no added that layer, saying one can switch to Latin by contol-space rather than CAps
06:38:28 <juhp> I see
06:38:46 <tagoh_> juhp: so need to discuss with desktop though they might think what's difference between Latin mode and keyboard layout without ibus?
06:38:57 <juhp> tagoh_, right
06:39:22 <juhp> anyway hence my suggest to start with IMEs that already support this
06:39:28 <juhp> suggestion
06:39:50 <juhp> tagoh_, not sure if they will like the change but we can try at least
06:41:18 <juhp> ah holiday in Germany so Mike is not here to say can just use it already :)
06:42:01 <tagoh_> anyone can explain that? it may reduce the cost regarding ibus on switching source though I have no idea otherwise.
06:42:14 <juhp> right I agree :)
06:43:09 <juhp> it seems to me even for multi-IME user it should be possible to get by without any separate kbd source setup
06:43:15 <tagoh_> dunno if that is enough to push this
06:43:21 <juhp> if IMEs support Latin input
06:43:42 <juhp> I think it makes some sense
06:43:57 <juhp> but some might argue the current "compromise" is simpler
06:44:23 <tagoh_> right
06:44:31 <juhp> I think we also need ibus status icon to reflect input state for this to be good though
06:44:41 <juhp> input mode
06:45:13 <juhp> that is only downside I see since I am not using gnome-shell - I can't tell from icon which mode it is in
06:45:25 <juhp> I think fujiwarat is already trying to do something for that
06:45:48 <fujiwarat> yes
06:46:00 <juhp> though maintainer seems to have other ideas ;)
06:46:29 <juhp> any other thoughts comments?
06:46:43 <juhp> dueno, ?
06:46:45 <tagoh_> anyway we have to negotiate this earlier since it depends on upstream work. otherwise we will miss this in f21 if we are really plannning to go with it
06:47:17 <juhp> anyway maybe we can discuss more next week or later when more people here
06:47:21 <juhp> tagoh_, agreed
06:47:44 <juhp> I can try to discuss with rtcm and see what he thinks
06:48:08 <tagoh_> okay
06:49:25 <tagoh_> let's continue to discuss this next week then.
06:49:33 <tagoh_> #topic Outstanding task
06:49:34 <tagoh_> #info #23: Fedora 20 i18n test day (i18n@lists.fedoraproject.org)
06:49:34 <tagoh_> #link https://fedorahosted.org/i18n/ticket/23
06:50:13 <tagoh_> as I said earlier we may want to finish review anytime soon
06:50:37 <tagoh_> maybe by the end of next week
06:51:16 <tagoh_> I did some and update the ticket
06:52:15 <juhp> anyone else?
06:52:31 <tagoh_> aside from that if there are any candidate to be added/removed, any suggestions are welcome.
06:54:59 <tagoh_> if that helps, I'll add some comments with assignments
06:55:21 <tagoh_> or if you aren't sure which one you should review
06:56:33 <juhp> that might be good to get things moving
06:57:26 <tagoh_> or here to log it
06:57:48 <juhp> :)
06:58:49 <tagoh_> I don't mind either anyway just wanted to make all reviewed before starting test day
07:01:12 <juhp> or both?
07:01:33 <tagoh_> aha. yep, sounds good
07:07:19 <tagoh_> okay
07:07:23 <tagoh_> #action fujiwarat to review https://fedoraproject.org/wiki/QA:Testcase_ibus_input and https://fedoraproject.org/wiki/QA:Gnome_Input_Method_Integration_IBus
07:07:24 <tagoh_> #action mfabian and anish_ to review https://fedoraproject.org/wiki/QA:Testcase_ibus-typing-booster
07:07:24 <tagoh_> #action pravins and paragan to review https://fedoraproject.org/wiki/QA:Inscript2_Keymaps and https://fedoraproject.org/wiki/QA:Testcase_Fonts_HarfbuzzNG
07:07:28 <tagoh_> #action dueno to review https://fedoraproject.org/wiki/QA:Libkkc and https://fedoraproject.org/wiki/QA:Hangul
07:07:28 <tagoh_> #action paragan to review https://fedoraproject.org/wiki/QA:Langpack_Yum_Application
07:07:40 <paragan> ok
07:07:49 <tagoh_> picked up by package owner and from interests
07:08:10 <paragan> sure
07:08:11 <tagoh_> need some volunteers for chewing and bogo
07:08:29 <tagoh_> pwu might review chewing maybe?
07:09:24 <tagoh_> of course double-check others would be also nice.
07:09:37 <tagoh_> #action pwu to review https://fedoraproject.org/wiki/QA:Chewing
07:10:26 <tagoh_> anyway if you think you may want testers to test any other features or find out outdated descriptions etc, please update to the latest.
07:11:03 <tagoh_> #topic Open Floor
07:11:13 <tagoh_> any other topics to discuss before stop the meeting?
07:15:11 <tagoh_> okay, let's stop then.
07:15:33 <tagoh_> thanks everyone for your attendance.
07:15:36 <tagoh_> #endmeeting