fesco
LOGS
18:00:15 <mmaslano> #startmeeting FESCO (2013-09-11)
18:00:15 <zodbot> Meeting started Wed Sep 11 18:00:15 2013 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:21 <mmaslano> #meetingname fesco
18:00:21 <zodbot> The meeting name has been set to 'fesco'
18:00:26 <mmaslano> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:00:26 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:00:32 <pjones> hello
18:00:34 <nirik> morning
18:00:49 <mmaslano> nirik: ha
18:01:07 <mattdm> hi!
18:01:20 * notting is here
18:01:22 * abadger1999 here
18:02:45 <t8m> Hello
18:03:09 <mattdm> my fingers are here typing but my brain is still catching up :)
18:03:45 <mmaslano> t8m: is mitr still on vacation?
18:04:06 <mmaslano> sgallagh_afk: is on vacation, I guess
18:04:07 <t8m> mmaslano, I think so
18:04:29 <mmaslano> let's start
18:04:32 <mattdm> sgallagh_afk has a new baby. I don't know if that counts as vacation :)
18:04:48 <mmaslano> it's called vacation in our country ;-)
18:04:49 <notting> mattdm: it's official now?
18:04:51 <mmaslano> #topic init process
18:05:05 <mmaslano> #topic #1117 Generalize policy about privilege escalation and Administrator user accounts
18:05:11 <mmaslano> .fesco 1177
18:05:11 <zodbot> mmaslano: An error has occurred and has been logged. Please contact this bot's administrator for more information.
18:05:30 <nirik> odd
18:05:33 <mmaslano> .fesco #1177
18:05:33 <zodbot> mmaslano: Error: '#1177' is not a valid integer.
18:05:38 <abadger1999> typo
18:05:41 <nirik> ah yeah.
18:05:42 <abadger1999> .fesco 1117
18:05:43 <zodbot> abadger1999: #1117 (Generalize policy about privilege escalation and Administrator user accounts) – FESCo - https://fedorahosted.org/fesco/ticket/1117
18:05:57 <mmaslano> thanks
18:06:05 <mattdm> i talked to halfie, who started a thread on fedora-devel and will drive this
18:06:13 <abadger1999> yay!
18:06:16 <t8m> nice
18:06:32 <mattdm> also started a thread on the fedora security sig about whether they wanted their own ticketing system for tracking this kind of thing :)
18:06:57 <mattdm> should we leave this ticket open in the meantime or close it as "yay someone's dealing with it?"
18:07:22 <abadger1999> I guess open but take meeting off
18:07:22 * nirik would say close and let him reopen with a proposal later?
18:07:29 <nirik> or that. I don't care much. ;)
18:07:30 <mmaslano> abadger1999: I'm ok with that
18:07:41 * abadger1999 doesn't care much either
18:07:49 <mattdm> +1 close
18:08:21 <notting> either close or remove meeting is fine with me
18:08:37 <t8m> I think just removing the meeting keyword is more appropriate if it is clear someone is working on this
18:08:53 <mattdm> okay I'm good with that too
18:09:28 <abadger1999> +1 to either
18:09:31 <mmaslano> 4 remove?
18:10:08 <mmaslano> okay, five I didn't count me
18:10:53 <mmaslano> #agreed remove this ticket from meetings, because someone is currently working on it. Now FESCo action at the moment. (+5,-0,0)
18:10:59 * mattdm removes keyword
18:11:07 <mmaslano> #topic #1161 fqdn should be clearly display at login and command prompt
18:11:14 <mmaslano> .fesco 1161
18:11:16 <zodbot> mmaslano: #1161 (fqdn should be clearly display at login and command prompt) – FESCo - https://fedorahosted.org/fesco/ticket/1161
18:11:59 <mattdm> from the mailing list discussion, it looks like this is a place where desktop and server might diverge
18:12:21 <mattdm> i mean, in the glorious future where that's a possibility :)
18:12:22 * nirik looks to see what the actual question is now.
18:13:06 <mmaslano> mattdm: I'm not so sure. commandline will use the same setting on server and desktop, UI can show something else
18:13:30 <mattdm> mmaslano fair enough
18:13:43 <notting> i could see login prompt. command prompt... no. (although terminal title could change)
18:14:15 <mattdm> yeah, I'm +1 to what notting just said
18:14:33 <frankieonuonga> hi guys...sorry I am late again.
18:14:52 <abadger1999> notting: +1
18:15:09 <t8m> notting, +1 from me as well - it does not make sense to put whole fqdn to command line - it would take too much real estate of terminal
18:15:09 <nirik> notting: +1 here too.
18:15:23 <mattdm> (and if you _really_ love that, you can set it)
18:15:44 <mmaslano> +1
18:16:35 <pjones> notting: +1
18:17:19 <mmaslano> #agreed fqdn should be clearly display on login prompt, but not on commandline prompt (+7,-0,0)
18:17:27 <mmaslano> #topic #1148 F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller
18:17:33 <mmaslano> .fesco 1148
18:17:35 <zodbot> mmaslano: #1148 (F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller) – FESCo - https://fedorahosted.org/fesco/ticket/1148
18:19:03 <mmaslano> abadger1999: notting: were your questions answered?
18:19:46 <notting> yes, it seems testable
18:19:54 <mattdm> so, looks like that's converging to agreement and asking for a test day?
18:20:59 * mattdm is ready to +1 something and move on
18:21:09 <abadger1999> Sounds like the packaging team would be happy with just a properly publicized test day so yep.
18:21:42 <mmaslano> +1 on move on, test day will be run, both teams are speaking together
18:21:44 <t8m> hooray
18:21:57 * nirik nods. good.
18:22:00 <mattdm> +1
18:22:12 <mmaslano> 6 nods
18:23:11 <pjones> do eet
18:23:17 <mmaslano> #agreed Packaging team would be happy with properly publicized test day. No other action needed here (+7,-0,0)
18:23:27 <mmaslano> #topic #1164 F20 Changes - Progress on Changes Freeze
18:23:33 <mmaslano> .fesco 1164
18:23:35 <zodbot> mmaslano: #1164 (F20 Changes - Progress on Changes Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/1164
18:24:38 <mattdm> um. wow. that week went fast.
18:25:11 <mmaslano> if I see it correctly, there are no actions needed for changes
18:26:26 <mmaslano> no actions, great new business
18:26:32 <mmaslano> #topic #1173 provenpackager request
18:26:34 <mmaslano> .fesco 1173
18:26:35 <zodbot> mmaslano: #1173 (provenpackager request) – FESCo - https://fedorahosted.org/fesco/ticket/1173
18:26:46 <mmaslano> I ask about opinion on this provenpackager rdieter
18:26:51 <mmaslano> please read his response in ticket
18:27:13 <abadger1999> <nod>
18:27:37 <mmaslano> as you can see rdieter believes that vicodan improved very much
18:27:41 <abadger1999> With rdieter's endorsement I'm willing to +1
18:27:42 <mmaslano> I'm +1
18:28:37 <t8m> I am +1 as well, if he doesn't behave properly we can demote him :)
18:28:59 <mattdm> yeah +1 with rdieter's endorsement as well.
18:29:10 <t8m> I think he is experienced well although there surely are some controversies in history.
18:29:12 <nirik> I agree he's improved a good deal... not sure if enough for this right now, but I guess I'm +1
18:30:00 <mmaslano> more votes?
18:30:51 <mmaslano> no?
18:30:56 <mmaslano> #agreed vicodan's request for provenpackager was approved (+5,-0,0)
18:30:56 <notting> rex was pretty convincing. i can be +1.
18:31:08 <mmaslano> #undo
18:31:08 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x29804550>
18:31:20 <mmaslano> nirik: could you give him permission later?
18:31:26 <mmaslano> #agreed vicodan's request for provenpackager was approved (+6,-0,0)
18:31:29 <nirik> sure.
18:31:34 <mmaslano> #topic #1174 Exception - F20 Self Contained Change: WildFly 8 - https://fedoraproject.org/wiki/Changes/WildFly8
18:31:37 <mmaslano> .fesco 1174
18:31:38 <zodbot> mmaslano: #1174 (Exception - F20 Self Contained Change: WildFly 8 - https://fedoraproject.org/wiki/Changes/WildFly8) – FESCo - https://fedorahosted.org/fesco/ticket/1174
18:32:12 <mattdm> I like "All of above is already done and the wildfly package is available in both Rawhide and Fedora 20 repos."
18:32:47 <t8m> +1, why not
18:32:51 <mmaslano> what I heard from Java people around: current jbosssomethng doesn't work at all in F20, WildFly8 will be improvement. But they have to work a lot on it
18:32:55 <abadger1999> I said in the ticket this should be a system-wide change (similar to the ruby on rails 4.0) but considering there only seems to be one package in Fedora that is using this as a platform to build their app, I'm +1 to it.
18:33:19 * nirik is +1
18:33:23 <mattdm> +1
18:33:29 <mmaslano> +1
18:33:36 * abadger1999 just wants people to list their Changes properly so when they do get more popular they don't keep submitting as self-contained changes.
18:33:41 <mattdm> I'm going to ping them on the release notes, though.
18:33:42 <mmaslano> abadger1999: sure
18:33:52 <notting> i'm +1
18:33:59 <mmaslano> #action mattdm will ping Wildfly people about release notes
18:34:19 <mmaslano> #agreed WildFly 8 feature is approved (+6,-0,0)
18:34:50 <mmaslano> #topic #1170 Working Group call for Volunteers
18:34:55 <mmaslano> .fesco 1170
18:34:56 <zodbot> mmaslano: #1170 (Working Group call for Volunteers) – FESCo - https://fedorahosted.org/fesco/ticket/1170
18:35:06 <mmaslano> Viking-Ice want more time for his proposal
18:35:16 <mmaslano> do you want speak about working groups now or postpone it?
18:35:30 * nirik notes a bunch of people already added their nominations before we even announced it. ;)
18:35:50 <pjones> (er, +1 to the last one as well.  sorry, horribly distracted today)
18:36:19 <mmaslano> at least we know that someone is willing to work on it ;-)
18:37:22 <mattdm> Given that my / our existing proposal has already been approved by the board, I'm not really excited to delay.
18:37:30 <notting> cloud looks a little lonely
18:37:51 <frankieonuonga> mattdm: just seen your email
18:38:04 <frankieonuonga> I am in
18:38:14 <frankieonuonga> I think it would be nice to get this going
18:38:15 <mattdm> And considering how long it took to put that proposal together and build consensus around it... well, I don't want to wait that long for a second proposal
18:38:41 <mmaslano> mattdm: I was wondering if it wouldn't be better to have also "customers" in this group. For example in cloud could be someone doing collections etc.
18:38:41 <frankieonuonga> considering I also work for a company that is building a cloud architecture and we are in beta phase now
18:39:10 <mattdm> I'd like to move forward as planned with sending out the invite, and if the board wants to revisit and halt things, fine.
18:39:25 <t8m> mattdm, +1
18:39:32 <frankieonuonga> mattdm +1
18:39:35 <mmaslano> mattdm: +1
18:39:38 <pjones> mattdm: yeah.
18:39:39 <mattdm> mmaslano customers is interesting. i thought about that too and intentionally included ambassadors as a user-representative group
18:39:58 <mattdm> frankieonuonga actually only people on fesco get to vote but I appreciate the sentiment. :)
18:40:04 <nirik> mattdm: +1
18:40:10 <abadger1999> mattdm: +1
18:40:17 <notting> mattdm: sure, +1. curious what happens when if a WG ends up with 75 people
18:40:23 <frankieonuonga> mattdm: my bad...but i was so excited i just had to
18:40:48 <nirik> well, fesco is appointing from the pool of volenterrs right? do we have desired numbers in a group?
18:41:22 <mmaslano> #agreed let's move on with proposal of Working Groups (+6,-0,0)
18:41:31 <mmaslano> mattdm: ok, so what's now?
18:41:36 <mattdm> nirik We did not put a number on it. I was kind of thinking that they would be sized like our existing committees _or smaller_. but figuring that out is part of the next step.
18:41:49 <mattdm> #action mattdm to send out message as drafted
18:41:53 <frankieonuonga> mattdm: kindly update on groups status on private chat  after meeting.
18:42:01 <mattdm> frankieonuonga yep
18:42:23 <nirik> well, leaving it large in inclusive, but more likely not to get things done. ;)
18:42:38 <mattdm> note that the current message says that the nomination period will be a month from the message.
18:42:49 <mattdm> anyone think that that is not the right timeframe? too long? too short?
18:42:53 <Viking-Ice> the qa has not nominated one
18:43:23 <mattdm> Viking-Ice yeah everyone on the current page is kind of jumping the gun. I am happy to see the enthusiasm, though.
18:43:58 <notting> mattdm: a month seems long, but given the f20 work, is probably fine
18:44:04 <nirik> a month seems ok to me, but we should discuss next steps and anything while that period is ongoing (ie, we shouldn't just stop doing anything for a month until it's done)
18:44:26 <mattdm> nirik that sounds good
18:44:36 <mattdm> and yeah, the f20 work is why i made it so long.
18:44:41 <mmaslano> nirik: yeah
18:44:53 <Viking-Ice> And I think you guys are rushing that wg proposal forward which we should not be doing
18:44:58 <mattdm> also i was afraid there would be, like, two people signing up total. but i guess that is not a problem :)
18:45:33 <Viking-Ice> but I guess I will just have to have the board or higher up the hierarchy to decide if my proposal does not warrant community voting
18:46:50 <mmaslano> proposal was already approved by board and fesco, sort of. So why should we stop
18:47:04 <mmaslano> I'm not against reading your proposal and speaking about it
18:47:04 <mattdm> Viking-Ice Yes, I think talking to the board is your next step there if that's really the direction you want to go.
18:48:01 <Viking-Ice> mattdm, yes because I *firmly* believe that the direction that 3 product proposal is not the one we should be steering ourselves into
18:48:13 <mattdm> Viking-Ice so noted. :)
18:48:45 <frankieonuonga> wait a min....if board has approved...is there anyway we can change
18:48:53 <Viking-Ice> mattdm, but arguably the meeting ground could be the core/baseOS as in there is no point in delaying any work involving that
18:49:06 <Viking-Ice> meeting/common
18:49:53 <frankieonuonga> viking-ice: with all due respect, dont we all have to agree on that
18:50:27 * nirik doesn't think we can discuss a proposal that as far as I know doesn't exist yet.
18:50:40 <t8m> nirik, +1
18:50:40 <pjones> indeed.
18:50:46 <Viking-Ice> frankieonuonga, some form of that has already been agreed in mattdm proposal
18:50:56 <pjones> apparently t8m can vote on one though ;)
18:50:57 <Viking-Ice> nirik, which is why I asked for the delay
18:51:18 <t8m> pjones, I'm voting for not discussing proposal that does not exist :D
18:51:51 <abadger1999> frankieonuonga: later decisions can override/modify earlier ones.  So things can theoretically change but usually various voting bodies in fedora don't want to stop people who are doing work so it's more likely that you'd be able t modify proposals that have been approved than to go in a totlly different direction.
18:52:02 <Viking-Ice> I'm all for that as well people can shoot me down when I have the chance to present it
18:52:03 <t8m> -1 to delay - I mean if there will be 1 month nomination period I don't think we need more delay
18:52:06 <nirik> Viking-Ice: since all these plans are talking about next cycle anyway, why should we stop all forward movement for competing proposals? if your proposal shows up and is desired over the current one we could adjust for that?
18:52:21 <mmaslano> t8m: good point
18:52:39 <frankieonuonga> makes sense to me 2
18:53:02 <t8m> nirik, or even somehow adjust the original proposal to accommodate the good points of the new one
18:53:17 * nirik nods.
18:53:48 <mattdm> The current proposal is the result of a lot of adjustment as I've talked to many people in the community. Further adjustment is good too.
18:54:15 <Viking-Ice> nirik, yeah makes sense actually worst case the working group would be dismantled
18:54:28 <nirik> right, or repurposed or whatever.
18:54:43 <mmaslano> mattdm: ok, do we move on? so do you want to approval of sending draft of groups?
18:55:06 <mattdm> i thought we already approved that several pages back
18:55:25 <mattdm> but if we want to vote on that specifically, I am +1 to it :)
18:55:33 <pjones> right, so we're at 15 minutes on this subject, with not even discussion of a proposal or what one might look like.
18:55:51 <nirik> +1 to sending call for nominations.
18:56:13 <mmaslano> +1 ^
18:56:19 <pjones> sure, +1 to that :)
18:56:20 <t8m> +1
18:56:28 <t8m> and let's move on
18:56:30 <abadger1999> +1 (w/ my note in ticket that we should also publicize that f21 cycle will be longer than normal)
18:56:33 * notting is +1
18:56:44 * nirik is with abadger1999 on the longer cycle note too.
18:57:07 <pjones> abadger1999: sure
18:57:07 <mattdm> abadger1999 or nirik -- do you want to send out a separate message to that effect? or should I?
18:57:21 <mmaslano> #agreed Once more agreed Working Group proposal should be sent as draft and members have month for joining those groups (+6,-0,0)
18:57:56 <mmaslano> #undo
18:57:56 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x29cf9e90>
18:58:01 <mmaslano> #agreed Once more agreed Working Group proposal should be sent as draft and members have month for joining those groups (+5,-0,0)
18:58:08 <mmaslano> move on to another topic?
18:58:16 <mattdm> yep
18:58:18 <nirik> mattdm: I don't know that it needs a seperate email... Might be worth mentioning in the nomination announcement?
18:58:29 <abadger1999> <nod>
18:58:45 <mattdm> but then I have to do more than press "send" :)
18:58:55 <frankieonuonga> :-)
18:59:17 <mattdm> also I actually do think it's important enough for a separate email
18:59:49 <mmaslano> #topic #1142 F20 System Wide Change: Change Packaging Guidelines to discourage requires into /bin and /sbin - https://fedoraproject.org/wiki/Changes/NoBinDeps
18:59:52 <mmaslano> .fesco 1142
18:59:53 <zodbot> mmaslano: #1142 (F20 System Wide Change: Change Packaging Guidelines to discourage requires into /bin and /sbin - https://fedoraproject.org/wiki/Changes/NoBinDeps) – FESCo - https://fedorahosted.org/fesco/ticket/1142
19:00:07 <mmaslano> this one had action after I send agenda
19:00:12 <abadger1999> mattdm: k.  How about I write a draft and have you review it later today.
19:00:13 <mmaslano> do you want to quickly look at it?
19:00:32 <abadger1999> mmaslano: we could -- from the prior decisions I think we could close it now.
19:00:41 <mmaslano> abadger1999: do you have proposal? I guess reporter (akozumpl) could approve it
19:00:47 <mmaslano> you are faster
19:00:55 <abadger1999> mmaslano: Unless someone wants to dispute the FPC decision.
19:01:19 <mmaslano> I'm fine +1 to close it
19:01:21 * nirik doesn't
19:01:51 * pjones is also for closing it.
19:02:02 <Viking-Ice> btw it would have been good if you had actually pinged me about my ticket login prompt ticket...
19:02:10 <abadger1999> +1 close
19:02:26 <t8m> +1 to close
19:02:46 * notting is +1 to close
19:03:10 <mattdm> Viking-Ice You are right. We should have.
19:03:38 <mattdm> +1 to close.
19:04:19 <mmaslano> #agreed Packaging Guidelines were already approved by FPC. No FESCo action needed now. (+7,-0,0)
19:04:38 <mmaslano> #topic Next week's chair
19:05:39 <mmaslano> I wonder if IRC failed or everyone so busy now...
19:06:00 <frankieonuonga> mmaslani: not failed for me
19:06:04 <mattdm> i will be at Linuxcon
19:06:14 <notting> i will be as well
19:06:18 <mmaslano> frankieonuonga: joking :)
19:06:21 <frankieonuonga> mattdm: I am so jealous..
19:06:22 <nirik> I can take it if no one else wants it...
19:06:38 <frankieonuonga> mmaslano: sorry
19:06:42 <mmaslano> I could take next week...
19:06:57 <t8m> I wasn't chair for long time but I am not sure I will be able to make it next week
19:06:59 <mmaslano> nirik: as you wish..
19:07:00 * pjones will also be in NOLA
19:07:18 <t8m> will we be able to meet even?
19:07:18 * nirik wonders if we will have quorum next week... I guess we will see.
19:07:21 <mattdm> will we have quorum? maybe we should cancel?
19:07:21 <mmaslano> nirik: I can take it and we won't have quorum, what do youthink? :)
19:07:28 <mattdm> lol mmaslano
19:07:48 <pjones> well, right now it looks like we'll have exactly 5?  but that's not great
19:08:04 <mmaslano> mattdm: I'm serious
19:08:14 <frankieonuonga> I will be there as usual.so make that 6.
19:08:38 <t8m> frankieonuonga, you're not fesco member
19:08:43 <nirik> mmaslano: either way. You can take it or I can... if we don't have quorum it can be a short meeting.
19:08:55 <mmaslano> #action mmaslano will chair also next meeting
19:09:05 <mmaslano> #topic Open Floor
19:09:10 <mmaslano> I didn't find any other tickets
19:09:21 <mmaslano> I will close meeting in 5 minutes
19:09:22 <frankieonuonga> t8m: oh yeah....sorry I keep assuming that we are taking about people who are usually in and not necessarily fesco...my bad.
19:11:43 <frankieonuonga> just to say thank you to the whole community for all the help being given...I appreciate it.
19:11:50 <frankieonuonga> I do not take it for granted.
19:14:41 <nirik> thanks for participating frankieonuonga
19:14:42 <t8m> mmaslano, thanks for chairing
19:15:04 <mmaslano> #endmeeting