fesco
LOGS
18:00:30 <mattdm> #startmeeting FESCO (2013-08-28)
18:00:30 <zodbot> Meeting started Wed Aug 28 18:00:30 2013 UTC.  The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:35 <mattdm> #meetingname fesco
18:00:35 <zodbot> The meeting name has been set to 'fesco'
18:00:38 <mattdm> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:00:38 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:00:43 <mattdm> #topic init process
18:00:44 <mitr> Hello
18:00:47 <sgallagh> Ciao
18:00:50 <mattdm> hello everyone
18:00:51 <t8m> Hello
18:00:58 <nirik> morning
18:01:20 <mattdm> I have not chaired a fedora irc meeting in a while so be gentle on me
18:01:52 <pjones> heh.
18:02:00 <sgallagh> mattdm: Then you're about to get a new badge!
18:02:14 <notting> sgallagh: nah, it goes to everyone on the #chair line
18:02:18 <mattdm> i knew there was some reason
18:02:20 <notting> so he should already have it
18:02:23 <mmaslano> hi
18:02:27 <mattdm> meh.
18:02:33 * abadger1999 here
18:02:47 <mattdm> okay, so that's everyone, yeah?
18:03:02 <mattdm> let's start...
18:03:05 <mattdm> #topic #1115 guidance from FESCO on packagekit upstream policykit change
18:03:08 <mattdm> .fesco 1115
18:03:10 <zodbot> mattdm: #1115 (guidance from FESCO on packagekit upstream policykit change) – FESCo - https://fedorahosted.org/fesco/ticket/1115
18:03:21 <mattdm> I reopened this...
18:03:35 <mattdm> the last activity suggested some sort of documentation of policy.
18:03:50 <mattdm> which i then couldn't find when a user asked about it on fedora-users
18:04:38 <sgallagh> Also, I'm concerned about what that user reported, since it did not appear to align with our previous decision
18:04:38 <mattdm> is it just https://fedoraproject.org/wiki/Privilege_escalation_policy
18:04:44 * nirik looks
18:05:01 <mitr> mattdm: The policy part is https://fedorahosted.org/fesco/ticket/1117 , deferred until ... ~never
18:06:01 <mitr> How much the 1115 decision is or isn't in conflict with the governing privilege escalation policy is not entirely clear, but also no longer relevant because we have made a specific decision for that case (and it has been implemented)
18:06:37 <nirik> perhaps we should stick 1117 back on the agenda and in the mean time modify the policy with what we did agree?
18:07:01 <mattdm> +1 nirik
18:07:06 <sgallagh> nirik: +1
18:07:57 <notting> sure, +1
18:08:05 <sgallagh> mattdm: I didn't get a chance to dive in and test the behavior reported on users@ though. Are we really allowing ANY user to update the system? I thought our ruling was that they had to be in wheel (or be prompted to auth as someone who is)
18:08:26 <mattdm> sgallagh yeah that is definitely what 1115 says
18:08:35 <mitr> ... and what /usr/share/polkit-1/rules.d/org.freedesktop.packagekit.rules seems to implement
18:08:38 <abadger1999> nirik: +1 to the second part -- For the first, is there someone who can drive 1117?
18:08:54 <mattdm> I suspect that the users in question were actually in wheel. but followup would be good.
18:09:05 * mitr echoes abadger1999 - last time there wasn't anybody really interested in driving this
18:09:05 <sgallagh> mattdm: Please avoid ambiguous pronouns. Define "that"?
18:09:14 <nirik> abadger1999: not sure, perhaps bress or halfie would be willing to?
18:09:40 <sgallagh> Ok, so you were agreeing with what I thought I remembered. Sorry for being dense.
18:09:56 <t8m> nirik, +1
18:10:02 <mitr> mattdm: I have tried on F19, and (pkcon install) does ask for authentication for a non-wheel user and does abort if it doesn't get it.
18:10:12 <mattdm> thanks mitr
18:10:22 <sgallagh> mitr: Ah, thank you very much
18:10:28 <abadger1999> nirik: bress said he didn't have time (looking at the ticket -- that must have been a msg to the securiy mailing list).  You may be onto something with halfie, though.
18:10:48 <nirik> we can ask. I don't want to volenteer anyone...
18:11:53 <abadger1999> bress saying he doesn't have time: https://lists.fedoraproject.org/pipermail/security/2013-August/001591.html
18:11:54 <nirik> so if we want to amend the policy on the wiki now, do we know what we are changing?
18:11:56 <mitr> Personally I'm quite fine with the current policy - I dont't see any need to relax it.
18:12:43 <mitr> nirik: Something like s/Add, remove, or downgrade any system-wide application or shared resource (packaged or otherwise)/&, with the exception of installing Fedora-signed packages from administrator-configured repositories/
18:12:59 <mattdm> nirik yes -- current policy says auth is required and allows auth-as-self for wheel users. change allows "update/remove/etc" without even auth as self
18:13:17 <mitr> mattdm: It's org.freedesktop.packagekit.package-install only
18:13:35 <nirik> ok, can someone just do that? or are there any folks who don't want the change?
18:13:55 <abadger1999> The simplest change to PrivilegeEscalation that implements 1115 is probably "We define an unprivileged user as neither the root account nor an account which is in the wheel group".
18:13:59 <mitr> mattdm: ... and installation, right
18:14:20 <mitr> mattdm: s/installation/update/ sorry
18:14:33 <t8m> mitr, I am fine with the current policy as well
18:14:34 <mattdm> mitr re-reads more closely
18:15:12 <mitr> abadger1999: no what an administrator is, is already covered in one of the "requirements" paragraph
18:15:40 <mitr> abadger1999: And we empatically don't want to relax it to "wheel without entering their password can do anything".
18:16:38 <abadger1999> mitr: <nod>  I would vote -1 or 0 on that... otoh, that seemd to be the root of the pro argument for 1115.
18:16:55 <mitr> So, s/Add, remove, or downgrade any system-wide application or shared resource (packaged or otherwise)/&, with the exception that for installing Fedora-signed packages from administrator-configured repositories, the requirement to ask for a password is vaiwed  for members of the wheel group who are local and active./
18:16:56 <abadger1999> anyhow.. that's probably more ticket 1117...
18:17:17 <abadger1999> s/vaiwed/waived/
18:17:29 <nirik> mitr: +1 (with abadger1999's typo correction. ;)
18:17:45 <mitr> ^^^ is, I think, the gist of it (... with an akward wording referring to "wheel" where the rest of the document doesn't, but using the other wording would be at least as awkward)
18:17:56 <notting> mitr: seems ok
18:18:11 <mattdm> +1 mitr
18:18:12 <t8m> mitr, +1
18:18:40 <sgallagh> mitr: +1
18:19:03 <mmaslano> mitr: +1
18:19:30 <pjones> eh, okay.  +1
18:19:33 * mitr goes ahead and edits the wiki page
18:19:53 <mitr> Also, Proposal: Close #1117; we don't need a ticket to say "we are waiting for contents of this ticket".
18:19:54 * abadger1999 thinks he was 0 to the original ticket. But  I'm +1 to mitr's statement of what was agreed :-)
18:20:19 <abadger1999> mitr: -1 -- let's ask halfie first and then close if he isn't interested.
18:20:26 <mitr> abadger1999: ok
18:20:28 <nirik> mitr: well, there's some questions in that ticket? and possibly someone interested in driving it.
18:20:46 <mattdm> (what was the vote count there?)
18:21:13 <pjones> mattdm: +6,-1,0
18:21:46 <pjones> excuse me, +7,-1,0
18:22:00 <nirik> well, there's two seperate things there...
18:22:01 <pjones> actually I can't tell what abadger1999 voted, but I've counted him on both sides there.
18:22:09 <abadger1999> pjones: thanks ;-)
18:22:11 <nirik> the vote on doing the change, but then the vote to close 1117
18:22:27 <notting> i'm fine with closing 1117 if there's no proposal to put there
18:23:01 <abadger1999> policy was changed via 1115.  If we're revoting that policy, I'm 0 or -1.  If we're just voting on wording to express that change, then I'm +1.
18:23:13 <mattdm> #agreed Change Privledge Escalation Policy doc to be in line with ticket 1115 and current practice (+7,-1,0)
18:23:23 <mattdm> i don't think we're revoting
18:23:26 <abadger1999> 1117 -- leave open for a week -- meeting chair to ping halfie on ticket to ask if he'd care to drive it forward.
18:23:30 <pjones> excellent, abadger1999 is counted twice in the final vote as well ;)
18:23:38 <mitr> abadger1999: +1
18:23:45 <nirik> abadger1999: +1
18:23:50 <pjones> abadger1999: +1
18:23:58 <abadger1999> +1
18:24:00 <mattdm> abadger1999: +1
18:24:19 <sgallagh> abadger1999: +1
18:24:26 <mmaslano> +1
18:24:37 <notting> abadger1999: +1
18:25:22 <mattdm> #agreed leave ticket 1117 (generalize priv esc policy) open for a week -- mattdm to ping halfie on ticket to ask if he'd care to drive it forward (+8,0,0)
18:25:35 <t8m> abadger1999, +1
18:26:11 <mattdm> #undo
18:26:11 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x25cced90>
18:26:14 <mattdm> #agreed leave ticket 1117 (generalize priv esc policy) open for a week -- mattdm to ping halfie on ticket to ask if he'd care to drive it forward (+9,0,0)
18:26:21 <mattdm> okay, next up...
18:26:30 <mattdm> #topic #1148 F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller
18:26:33 <mattdm> .fesco 1148
18:26:35 <zodbot> mattdm: #1148 (F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller) – FESCo - https://fedorahosted.org/fesco/ticket/1148
18:27:18 <mitr> 1 week to go... and gnome-software AFAICS doesn't even have a review request
18:27:23 <nirik> so, where are we here?
18:27:30 <abadger1999> panu's comment looks like a good starting place for a future roadmap
18:27:46 <abadger1999> but not for the f20 debate.
18:27:50 <mattdm> panu: " Given that none of the above exists yet AFAIK, obviously this is not going happen for F20."
18:27:52 <mitr> abadger1999: comment #27 is the primary set of requirements AFAICS
18:28:12 <notting> it wasn't clear to me whether panu's coment did or did not address gnome-software/zif writing directly to yumdb on an interim basis
18:28:16 <nirik> yeah, I was happy to see that comment. Hope for the future.
18:28:58 <abadger1999> notting: I think it omits answering that question.
18:29:21 <mitr> I've been told that there are ...disagreements as to the appropriate format of yumdb.  I've also informally threatened at least one of the parties with FESCo micromanaging that decision.
18:29:23 <notting> abadger1999: right. but certainly answering that question would be useful
18:29:30 <abadger1999> <nod>
18:29:41 <nirik> mitr: yeah, doesn't help short term tho. ;(
18:29:55 <mattdm> so what do we need short term?
18:30:03 * nirik thinks it's looking more and more likely we punt for f20.
18:30:05 <pjones> mitr: us micromanaging it is completely the wrong thing to do, so that should be quite an encouraging threat!
18:30:12 <pjones> nirik: indeed
18:30:12 <mitr> pjones: exactly
18:30:36 <mitr> nirik: Given the timeline, we should probably expect having to institute the contingency of using the yum backend (per our previous decision), however we don't even have a package to impose the contingency on, currently ...
18:30:56 <nirik> no package review, no response about icons and descriptions they wanted, no work on compose tools to provide multiple packages, so, not sure...
18:31:18 <jreznik> no update in the tracking bug neither...
18:31:29 <mitr> Proposal: Leave open to revisit after the alpha freeze has happened, to follow the decision.  Then decide
18:31:39 <mmaslano> mitr: +1
18:31:53 <sgallagh> mitr: +1
18:31:55 <mitr> (with the non-voted-on expectatin that by that time the change will be punted/refused, and adding a blocker bug of "GNOME does not ship the app installer" to verify the outcome)
18:31:59 <nirik> mitr: +1
18:32:04 <notting> mitr: +1
18:32:44 <pjones> mitr: +1
18:32:48 <t8m> mitr, +12
18:32:53 <t8m> +1 that is
18:32:56 <pjones> EINVAL
18:32:58 <t8m> :)
18:33:02 <nirik> so, thats +17... ;)
18:33:11 <abadger1999> +1
18:33:19 <mattdm> I'm +0. I don't see the point in delaying the decision, but whatever :)
18:33:27 <mitr> Is it enough to have rhughes on the FESCo ticker, or should we make an extra effort to make sure the situation is understood by the change owners??
18:33:46 * jreznik can try to help
18:33:57 <nirik> I think it would be good to ping mclasen and rhughes too...
18:33:59 <mitr> mattdm: If they all agree, implementing this in a week seems realistic
18:34:22 <mitr> The owners are rhughes, Ryan Lerch and Allan Day; not actually mclassen
18:34:30 <nirik> ok
18:35:07 <nirik> jreznik: can you ping them for us?
18:35:24 <mattdm> #agreed leave app change installer change open to revisit after the alpha freeze has happened, to follow the decision. Then decide. (+8,0,1)
18:35:35 <mattdm> #action jreznik to ping feature owners
18:35:42 <jreznik> nirik: sure
18:35:52 <nirik> thanks mucho
18:36:08 <mattdm> okay next :)
18:36:11 <mattdm> #topic #1158 post-Flock Fedora rings + target products draft proposal for Fedora board
18:36:14 <mattdm> .fesco 1158
18:36:15 <zodbot> mattdm: #1158 (post-Flock Fedora rings + target products draft proposal for Fedora board) – FESCo - https://fedorahosted.org/fesco/ticket/1158
18:36:28 <mattdm> toshio and I were editing this right up until the meeting
18:36:41 <mattdm> which is not _really_ the most helpful timing
18:36:42 <nirik> yeah, I didn't get all the last minute edits yet.
18:37:03 <mattdm> this was mostly integrating feedback recieved, not anything dramatic and new
18:37:36 <nirik> so, do we want to nitpick specific items? or what are we looking to do right now in this meeting?
18:37:55 <jwb> the Board was supposed to get back to you on it
18:37:58 <mattdm> i'd prefer nitpicking to happen outside of the meeting
18:38:06 <mattdm> jwb There was board feedback in the ticket
18:38:11 <jwb> from one person
18:38:23 <mattdm> jwb two!
18:38:46 <mattdm> but yes not lots
18:39:00 <mattdm> also mitr has some significant last-minute feedback.
18:39:04 <nirik> we still need to try and get more feedback from all the various groups right?
18:39:06 <inode0> there was also board feedback at the last board meeting
18:39:17 <jwb> i emailed the board.  myself, rdieter, and inode0 all seemed to agree with the general approach
18:39:22 <sgallagh> jwb: IIRC, the Board was going to either get back to us or if they didn't, vote on it as is
18:39:48 <mattdm> there is one thing that came up in the last minute edits i'd like to discuss briefly
18:40:10 <pjones> sgallagh: in the past, that hasn't been the most... reliable feedback loop.
18:40:23 <mattdm> abadger1999 was concerned that the post-approval responsibilities leaned too heavily to planning with not enough push to actually get to doing
18:40:39 <sgallagh> mattdm: Perhaps a deadline should be specified?
18:40:54 <mattdm> sgallagh exactly. and that's the point to discuss :)_
18:41:08 <mattdm> https://fedoraproject.org/wiki/Fedora.next/boardproposal#Product_Working_Groups
18:41:16 <mitr> mattdm: Continuing in my last comments, I think the first WGs should just be decided by FESCo, implying FESCo essentially coordinating the initial PRDs to fit well together.  Otherwise we might end up with completely disjoint proposals coming out of the election/pre-election compaign process.
18:41:38 <sgallagh> Going from past experience, no matter how much time we allot, people will wait until 72 hours before it's due to start it.
18:41:42 <mattdm> for product working groups, we added that the first requirement, a PRD, be done by F21.
18:41:43 <mitr> (Is that a FESCo overreach?)
18:41:45 <sgallagh> So perhaps we aim to be ambitious?
18:42:00 <mattdm> that is a very conservative date from my pov.
18:42:11 <notting> sgallagh: well, that's a truism entirely separate from fedora
18:42:13 <mattdm> I'd rather say that they're due a month after f20 release.
18:42:15 <nirik> well, since we have no f21 schedule... ;)
18:42:33 <mattdm> nirik six day f21 schedule! go!
18:42:38 <pjones> mitr: I'm not sure if it's an overreach or not - we're largely tasked with defining what our responsibilities are, so as long as it's "steering engineering" it's okay, right? ;)
18:42:41 <nirik> f20 will release and then we have a bunch of holidays...
18:42:49 <abadger1999> mitr: +1 to that idea.  We can slim down/eliminate  the "First responsibility of the working groups will be to establish a governance charter for their working group and elect an initial membership." sentence if we do that.
18:43:03 <sgallagh> mattdm: I'd rather have them due *at* Fedora 20 release. Most people shift to FN+1 work at FN Beta
18:43:04 <mitr> pjones: yes, as long as it's consistent with what the last year's voters kind of expected
18:43:17 <mitr> mattdm: A month after F20 would be ideal, I think, yes.
18:43:30 <mattdm> sgallagh I feel like that might leave out participation from qa and releng.
18:43:36 <nirik> 1 month after f20 (provided it doesn't slip) is the day after xmas. ;)
18:43:37 <sgallagh> mattdm: Valid point.
18:43:39 <pjones> mitr: restructuring was discussed in e.g. the town halls in the last election, to some extent
18:43:55 <pjones> mitr: so I think we're /fairly/ safe there.  kind of.
18:44:09 <sgallagh> nirik: Perhaps the end of the New Year week?
18:44:13 <pjones> And if not... an opposition party next election wouldn't be the worst thing that ever happened.
18:44:13 * nirik definitely would like to see plans emerge as soon as possible... for deadline it might make sense to be in january sometime.
18:44:20 <mitr> pjones: I did actually propose that thing above :)  I just wanted to make sure objections, if any, had a chance.
18:44:28 <sgallagh> Bringing it shorter during the holiday season is doomed to failure
18:44:31 * nirik is ok with mitr's proposal
18:44:35 <pjones> *nod*
18:44:55 <mattdm> mitr's proposal re working group composition?
18:45:00 <nirik> yeah
18:45:03 <pjones> yes
18:45:07 <sgallagh> mitr: Could you make a formal proposal so we can vote?
18:45:14 <mjg59> mattdm: I'd like more clarity in the proposal as to why the new working groups aren't just the existing SIGs
18:45:40 <sgallagh> mjg59: I think they will be, plus a FESCo shepherd
18:46:01 <mattdm> mjg59 the sigs are too informal, and in the case of the server sig, never got off the ground.
18:46:06 <sgallagh> and with mitr's current proposal, the initial working group would be FESCo-selected.
18:46:07 <pjones> sgallagh: well, we're kind of changing the definition on top of the thing.  which maybe is what he's asking us to explain?
18:46:31 <nirik> in my mind the problem with SIGs is that they are 'just whoever shows up' and that makes it hard to task them with some deliverable item they agree on.
18:46:50 <mitr> Actually the existing text already says "indpeendent sub-comittees of FESCo" in one part...
18:46:56 <mitr> nirik: It's hard to task _us_ :)
18:47:01 <mmaslano> nirik: yes
18:47:11 <sgallagh> nirik: Exactly. For anyone who joins a Working Group, it should be clear that they're committing to at least some level of contribution.
18:47:13 <mattdm> +1 nirik
18:47:23 <mattdm> mitr -- yeah, actually initially fesco appointed was my thinking at some point.
18:47:48 <sgallagh> mattdm: Mine as well, though I was willing to waver on that if the wind blew against it
18:47:59 <mattdm> it sounds like the wind is blowing for it
18:48:43 <sgallagh> At least among FESCo members.
18:48:57 <sgallagh> It's kind of like how US Congress is allowed to vote for their own salary increases :-P
18:48:58 <nirik> we could perhaps tie membership to commits on packages in that product? I guess that all depends on how things organize.
18:49:35 <sgallagh> nirik: I think we are probably okay with FESCo setting up provisional governance and overseeing a charter
18:49:55 <nirik> well, of course _we_ are. ;) If the board and everyone else is then great. ;)
18:50:04 <abadger1999> nirik, sgallagh: Yeah.  the SIGs are good at discussion.  but they aren't great at making group action happen.  For instance, in the devendorize desktop files project, the desktop sig asked fpc to change the rules about desktop files but it was a wide body of other packagers who implemented the change throughout the packageset.
18:50:53 <pjones> Would it be enough to simply define the SIGs and the WGs as two different things, with a line that simply says the WGs are to work with the SIGs as much as practical?
18:51:11 <pjones> (and then defined the WGs as, ahem, "indpeendent sub-comittees of FESCo")
18:51:29 <sgallagh> pjones: Probably reasonable. I expect that the overlap will be rather substantial, but that's okay.
18:51:33 <nirik> sure. However, it's not clear at all how many SIGs there really are and how active most of them are.
18:51:43 <sgallagh> pjones: I might drop "independent", honestly
18:51:45 * abadger1999 notes that the working group section was one of the things that was revised pre-meeting
18:51:46 <mattdm> nirik well, we do have a cloud, server, and desktop sig
18:51:50 <pjones> sgallagh: I was just quoting there.
18:51:50 <nirik> or even how to contact some of them
18:51:51 <mattdm> and that's the relevant thing
18:51:53 <abadger1999> in case anyone is reading the old version
18:52:05 <sgallagh> pjones: Sure, but it seemed an opportune time to mention it
18:52:40 <nirik> mattdm: whats the server sig done of late? there's also kde, xfce, astronomy, formal methods, education, medical, java, perl, etc, etc.
18:52:49 <abadger1999> sgallagh: <nod> independent is ill-defined there.
18:52:56 <mattdm> of those, cloud is low-traffic but basically functional as long as I drive things.
18:53:05 <mitr> nirik: I think we'd just take over the mailing list and start using it.
18:53:12 <mattdm> nirik: right, getting to that. server sig never got off the ground
18:53:32 <mitr> (We could actually just start using the lists for the PRD work, and use _that_ to seed the non-FESCo WG appointees)
18:53:42 <notting> ... but given the existence of the sig already, what is changing now to activate it?
18:54:01 <sgallagh> notting: Necessity?
18:54:05 <mattdm> and the desktop sig generally communicates in other places
18:54:09 <mitr> notting: A specific task to be done
18:54:18 <nirik> in any case this is another reason sigs are ill suited to being decision making bodies... there's no clear contact or voting membership or even a standard way to get feedback from the sig.
18:54:26 <abadger1999> <nod>
18:54:30 <mitr> mattdm: "the non-existent workstation sig" you mean? :)
18:55:13 <nirik> anyhow, I have no problem saying the working groups or whatever should work with SIGs and the community whereever possible.
18:55:14 <mattdm> mitr right, proposed workstation target is a change from the current default user targetted by desktop right now
18:55:34 <mattdm> nirik +1 I'll try to work that in.
18:56:11 <mattdm> any more thoughts on the prd deadline?
18:56:36 <mattdm> proposal: prd deadline january 10th 2014
18:56:45 <sgallagh> mattdm: Proposal: PRD deadline of Jan 10
18:56:46 <nirik> how about 2 deadlines...
18:56:58 <jreznik> mattdm: it's too early after christmas I'd say - everyone is going to be out that days
18:56:58 <mjg59> mattdm: More justification for the difference between the workstation audience and the desktop audience would be appreciated
18:57:05 <mitr> +1 both, with the option to brigh forward if we are done earlier
18:57:06 <nirik> a 'final draft' and a 'final' ?
18:57:11 * abadger1999 is fine with earlier prd deadlines
18:57:24 <mitr> Realistically we'll have to coordinate at least the cloud and server PRDs to a non-trivial extent
18:57:31 <mjg59> mattdm: Since right now the proposed workstation audience is one that many of the people doing the work aren't terribly interested in
18:57:48 <notting> sgallagh: i guess i'm a little confused. "we should work with existing sigs", except "we want existing sigs to do something different than what they're doing now"
18:57:55 <sgallagh> mjg59: I'd rather leave that out of the initial proposal and leave it up to the WG to resolve
18:58:02 <mmaslano> I guess interested people are already working on some drafts...
18:58:10 <mmaslano> Jan 10 is fine with me
18:58:24 <mjg59> sgallagh: This isn't really the time to discuss it (I guess we can tomorrow), but I'm not voting for anything without that being done
18:58:50 <nirik> proposal: draft due 2013-12-03, final due 2014-01-10? (revisit as needed)?
18:59:16 <t8m> nirik, +1
18:59:17 <mattdm> mjg59 understood
18:59:19 <sgallagh> notting: How is that in conflict? Expressing our needs and trying to actually steer development in a meaningful way seems like a good idea to me
18:59:20 <mattdm> nirik +1
18:59:35 <sgallagh> nirik: Works for me. +1
18:59:46 <mmaslano> nirik: +1
18:59:52 <abadger1999> nirik: so is draft/final for community feedback?
18:59:55 <notting> sgallagh: it moves the SIG model from people organized around a goal they have set collectively to people organized around a goal that has been imposed?
19:00:15 <pjones> nirik: I mean, I'm fine with that, but it seems like we're putting them in a situation where they've got deadlines they don't know if they need to care about yet
19:00:15 <nirik> abadger1999: yeah, wider feedback for sure. I would hope work would be done as much as possible in the open before that too.
19:00:25 <mjg59> Yeah. *personally* I have no interest in working on the proposed workstation product.
19:00:26 <mitr> mjg59: This is just me, but if the end effect ends up as  "workstation" being (fairly random example) XFCE + eclipse, driven by the eclipse team, I... wouldn't think that's a disaster.
19:00:44 <abadger1999> notting: I think the SIG model isn't about people organized aroung a goal normally... they're organized around a technology or an existing community.
19:01:09 <kalev> also, regarding imposed goals:
19:01:12 <kalev> < abadger1999> Yeah.  the SIGs are good at discussion.  but they aren't great at making group action happen.  For instance, in the devendorize desktop files project /.../
19:01:18 <kalev> That's not true. mclasen and I devendorized most of the GNOME packages _before_ someone else brought it to FPC; it was my fix to a package that triggered all the FPC invelvement in the first place.
19:01:24 <mitr> To the extent the WGs are more or less FESCo, we are imposing goals on _ourselves_, and actually giving the existing SIGs extra say
19:01:25 <mattdm> hi kalev!
19:01:36 <kalev> hi mattdm :)
19:02:07 <sgallagh> notting: We need to strive to get people to go along with a cohesive vision of Fedora (whatever that turns out to be).
19:02:22 <sgallagh> In some (many?) cases this may no longer be exactly what the project's upstream is doing.
19:02:37 <sgallagh> If there's any one fundamental piece of this proposal, I'd claim that this is it.
19:02:41 <mattdm> I'm pretty confident that we can get better alignment between the current draft and the doing-the-work goals
19:02:59 <mattdm> and I'm okay with a little delay on the whole thing while that gets worked out
19:03:33 <nirik> reworking the products to things people do want to work on/toward seems like a good thing to do before we form a group with the goal listed
19:03:58 <sgallagh> nirik: In the current proposal, that's intended to be the job of the provisional WG
19:04:19 <mattdm> although we do want to have the high level set by the board initially
19:04:25 <sgallagh> We've provided three general ideas, these groups make them more clear
19:04:27 <abadger1999> kalev: So -- it's a question of follow through then?  SIGs are capable of making changes to local packages but not good at making systemic changes?
19:04:32 <nirik> ok, so why do we even have those there? starting points?
19:04:44 <kalev> abadger1999: Yep, I would say so.
19:04:47 <abadger1999> k
19:04:58 <mattdm> nirik: not just starting points but we want a statement of direction.
19:05:10 <sgallagh> nirik: "those"?
19:05:33 <nirik> sgallagh: target audience and purpose
19:05:41 <nirik> if the working group sets those...
19:06:01 * mattdm notes that this is kind of a meandering discussion. it's important but I wonder if we want to note specific areas here to work on and move on....
19:06:03 <mitr> nirik: I personally want fairly precisely those three, not a random other three.
19:06:04 <sgallagh> nirik: No, the board should set those, the working groups should figure out the best way to move in that direction
19:06:12 <mjg59> sgallagh: Right now the proposal includes them
19:06:25 <mjg59> sgallagh: If it's the intention that the board set them, then they shouldn't be in the proposal
19:06:38 <sgallagh> nirik: If the Board doesn't like those three approaches, it can veto one or more of them as it sees fit
19:06:39 <nirik> ok, then yeah, we should amend the proposal to ask the board to set them
19:06:48 <sgallagh> General direction of the Fedora Project is a Board decision
19:07:01 <mattdm> but we can make proposals to the board, right?
19:07:04 <sgallagh> Once that general direction is set, FESCo and the WGs should be responsible for executing on it
19:07:04 <mattdm> like these?
19:07:19 <mjg59> mattdm: Sure, but it's unclear as to why
19:07:31 <mattdm> mjg59 why propose things?
19:07:40 <sgallagh> mjg59: Sorry, it's the intention that the board *ratifies* them or refuses them and makes a counter-proposal.
19:07:48 <nirik> sure. So, how about we edit it to say: "here's our starting point for products, the board is welcome to amend/add/whatever"
19:07:52 <mjg59> mattdm: No, why include them in a proposal that's intended to produce a more agile Fedora
19:08:00 <mjg59> mattdm: You're mixing process changes with direction changes
19:08:06 <nirik> right now the proposal says they will be set by the working group
19:08:25 <nirik> "The following targets and purposes are the initial guiding statements; fully-developed versions will be the first deliverables for product working groups as described below."
19:08:30 <mattdm> mjg59 Yes, it is absolutely true that this mixes two separate ideas.
19:08:43 <mattdm> we can split them up if that would be more helpful
19:08:46 <mjg59> mattdm: It's unclear to me why the direction is part of the proposal. Isn't the entire point to be to decouple things enough that the direction of the workstation product doesn't impact the cloud or server products?
19:08:48 * sgallagh really wishes we stuck to keeping the two proposals seperate
19:09:14 <pjones> sgallagh: mattdm: I think that would at least be more helpful in the short term
19:09:24 <sgallagh> pjones: "that"?
19:09:26 <pjones> if they're both broadly approved, it won't make much differnece in the long term
19:09:37 <pjones> sgallagh: splitting them.  the thing you spoke of on the previous line.
19:09:43 <mattdm> okay, I'll do that.
19:09:46 <sgallagh> pjones: Thanks
19:10:03 <mattdm> #action mattdm to split merged proposal back into separate ones to make things more clear
19:10:42 <sgallagh> mjg59: To quickly explain, there are two main points here.
19:10:44 <mitr> I'm not sure - there isn't that  much _near-term_ left of the original rings proposal AFAICS
19:10:45 <mattdm> in which case let's definitely move on to the next thing because that's a lot of work :)
19:10:56 <sgallagh> One is setting the direction for three basic products shipped out of the Fedora Project.
19:11:01 <notting> mjg59: well, they're interdependent in that a more agile fedora that doesn't change its deliverables is somewhat nonsensical, and split products is not really achievable without a somewhat more agile Fedora
19:11:24 <sgallagh> The other is how we address those things in the greater Fedora ecosystem that aren't an essential part of those products.
19:11:30 <mattdm> (yes, what notting said is why we decided to make one merged proposal in the first place)
19:11:33 <mjg59> notting: The deliverables would clearly change, but that seems like a technical issue rather than a direction issue
19:11:50 <sgallagh> or rather than "non-essential", for a better term are "add-ons"
19:12:05 <t8m> I have to leave now
19:12:12 <mattdm> mjg59 deliverables change is technical? that seems more like exactly the opposite of what I'd say
19:12:14 <mjg59> I don't understand why replacing the existing desktop target with the proposed workstation one results in an improved cloud or server product
19:12:32 <mattdm> t8m goodbye. do you have comments onthe other agenda items?
19:12:45 <notting> mjg59: right - the 'more agile fedora' thing is on its face not as board-relevant - is whether things are packaged in bucket A or bucket B  really a board concern?
19:13:01 <mitr> Can I, as a quick intervention, ask whether any FESCo members would accept any other products than these three?
19:13:21 <pjones> mitr: is there some other product you have in mind?
19:13:30 <mjg59> notting: Right. That's what I mean - restructuring the way the base distribution is produced in order to make it easier to produce deliverables seems like a technical issue.
19:13:46 <sgallagh> mitr: I would vote against Fedora Tablet or Fedora Phone, if that's what you're asking?
19:13:56 <t8m> mattdm, on the provenpackager policy I'd vote to keep one week timeout - I don't think shortening to 3 or 4 days is really necessary
19:14:06 <t8m> mattdm, no comments on the Feature progress
19:14:07 <mattdm> mitr: these are the three i want. although if someone came up with a lot of people very enthuastic about making an embedded target or something i would like there to be an incubation process
19:14:11 <mitr> pjones: Not at all, but we're talking as if using different products was a realistic thing we need to structure the board proposals for.  (I'm suggesting that no, these three are _it_ and 99% not negotiable.)
19:14:12 <mattdm> t8m thx
19:14:52 <mattdm> mjg59 By the procedures we have, establishing new more-formal-than-sigs groups with any authority needs board approval
19:15:02 <notting> mitr: i think those three are a reasonable minimum number of things produced by fedora out of its currently composed universe. i would not want to rule out others in the future
19:15:04 <pjones> mitr: I think if somebody had a good case for another one we'd be willing to hear them out, but...
19:15:08 <abadger1999> truthfully, I'm worried that attempting to make three products in round 1 of this is going to be much harder to coordinate than making one product in round 1.  but then again, it proves the concept of being able to produce more than one thing so it has an offsetting benefit.
19:15:20 <mitr> notting: sure, but that's thinking way ahead
19:15:24 <abadger1999> mattdm: hasn't fesco delegated authority before?
19:15:31 <nirik> mattdm: it is?
19:15:33 <mjg59> mattdm: That doesn't seem to be in response to anything I said
19:15:34 <notting> mitr: given arm as primary, it may not be *that* much further aheda
19:15:39 <sgallagh> abadger1999: I wasn't aware we had any to delegate...
19:15:42 * abadger1999 can't recall if the feature wrangler, for instance, went through fesco or the board.
19:15:56 <notting> mitr: there is a conceivable future where an interested arm group might want to do a fedora phablet rather than a workstation
19:16:03 * nirik is fine with the 3 products, but thinks the board should adjust the target/purpose if they think there's better for those products.
19:16:16 <pjones> mattdm: huh?  no.
19:16:32 <mattdm> mjg59 that's in repsonse to the "restructuring the way the base distribution is produced..."
19:16:34 <sgallagh> notting: The question there has to be "Are those Fedora, or are those Fedora-derived?"
19:16:42 <mattdm> pjones I am going by https://fedoraproject.org/wiki/Defining_projects
19:16:45 <mattdm> last line.
19:16:47 <sgallagh> I think we should leave open the door for Fedora-derived right from the start
19:16:57 <mjg59> mattdm: Again, I don't know what you're actually responding to
19:16:59 <sgallagh> And revisit promotion to Fedora as a Board decision down the line
19:17:01 <abadger1999> nirik: I guess it would depend on whether someone(s)  is saying, "I'm willing to drive these three products as our proof of concept" vs "I'd like to see these three products be our proof of concept"
19:17:07 <mitr> notting: I can see such possibilities.  I wouldn't see them as a possible result of the _current_ decision we are asking the board to make.
19:17:15 <nirik> mattdm: well, what new project are we doing here? fedora new?
19:17:27 <mjg59> mattdm: There's a proposal for a technical change in the way that Fedora is produced. There's a separate proposal for a change in the defined audiences.
19:17:29 <notting> sgallagh: well, we're redefining deliverables entirely. i mean, it's potentially blowing up the entire spin & remix contexts, so saying what buckets deliverables falls into doesn't mean much without defining the possible buckets
19:17:50 <mjg59> mattdm: I just have no idea why these are being conflated, since they seem to have nothing to do with each other
19:17:52 <mattdm> the five (!) working groups I'm proposing pretty clearly fit the category of "project" by that page.
19:18:12 <sgallagh> notting: Considering we really only have a handful of spins that can manage to deliver something that works, I'm not overly worried about breakage there.
19:18:38 <abadger1999> If the first, then it's really the someone(s) proposal.  If it's the latter, then the board could certainly evaluate whether they think there will be someone to drive that product vs some other defined product.
19:18:40 <nirik> mattdm: thats sure a blast from the past. ;) That was not changed really any since being imported from the old wiki.
19:18:46 <mattdm> but if we are happy with saying that we can set up fesco subgroups on our own authority, than I'm happy.
19:19:14 <mattdm> and if we think that only the target projects part has to go to the board, I am likewise perfectly happy.
19:20:34 * mitr decides to tune out the meta-discussion about the form of the proposal.  We have no idea what we'd do if the board didn't approve both anyway...
19:20:41 <mattdm> mjg59 I am happy to de-conflate them.
19:21:07 <nirik> proposal: collect more feedback for another week, see if we think things are ready to start doing/ask for board ack then?
19:21:23 <pjones> mitr: consider the meta-discussion as "how do we structure them so that the board will approve them".
19:21:29 <sgallagh> nirik: We didn't get any feedback this week. What's going to change?
19:21:39 <pjones> (though it seems some actual changes may still be needed.)
19:21:43 <nirik> you didn't? there were edits right up to before the meeting no?
19:22:02 <sgallagh> nirik: *Only* right before
19:22:04 <mattdm> we didn't get much _board_ feedback but I felt like i got consderable feedback
19:22:05 <jwb> sgallagh, i don't think anything will change from a board perspective.  as far as i can tell, the board is giving you a green light
19:22:19 <jwb> come back to the board for specific items if needs be
19:22:34 <mmaslano> mattdm: no feedback = everyone is happy
19:22:37 <sgallagh> jwb: Umm, I saw no vote at the meeting.
19:23:07 <sgallagh> Nor announcement about a decision
19:23:12 <inode0> We meet again tomorrow if you want a vague go ahead with it vote
19:23:43 <abadger1999> hmm...
19:23:47 <mattdm> inode0, jwb: do you think splitting out the target products and core/ring2 working groups into separate proposals is worth doing?
19:24:02 <abadger1999> If the board is willing to give a green light... is de-merging the proposals jsut busy work?
19:24:14 <abadger1999> jinx
19:24:18 <sgallagh> inode0: I don't want "vague". I want "The Fedora Board asserts that this is our future. Get started on it!"
19:24:20 <jwb> mattdm, personally?  no.  at least i think the target products _needs_ the concept of a common core to succeed
19:24:37 <inode0> sgallagh: then provide a very detailed proposal for us to vote on
19:24:40 <mattdm> I especially don't want to de-merge them and then be asked to put them back.
19:25:05 <pjones> sgallagh: "vague" is essentially what we've previously stated we were interested in
19:25:09 <sgallagh> inode0: The board isn't responsible for technical decisions. That's FESCo. Your job is to assert the project direction.
19:25:11 <mjg59> mattdm: The risk is that if you produce a proposal which redefines the target audience in a way that the board dislikes, you also lose the core/ring2 split
19:25:24 <sgallagh> pjones: vague proposal, not vague approval
19:25:26 <sgallagh> :)
19:25:27 <pjones> sgallagh: And now you're asking them for both things.
19:25:43 <jwb> sgallagh, you don't get explicit approval for a vague propsal
19:25:45 <sgallagh> No, I'm asking them for definitive approval of a *direction*
19:25:59 <mjg59> sgallagh: Then make a definitive proposal of that direction
19:26:04 <sgallagh> That we want the Fedora Project to produce these three Products
19:26:14 <abadger1999> mjg59: although --- I suppose you could ask for both things since that's what's there now and if it fails, then you separate and get the bits passed that you can.
19:26:19 <inode0> sgallagh: thank for clarifying that - still be clear what you want a vote one if our generally telling you to go ahead isn't enough
19:26:20 <sgallagh> I thought I was doing that. If it got lost somewhere, help me rephrase it.
19:26:34 <abadger1999> mjg59: my pronouns in that sentence were a mess... apologies.
19:26:59 <abadger1999> I think it reads right if you s/you/mattdm/
19:27:10 <sgallagh> inode0: "Proposal: The Fedora Project must produce three Products: Fedora Server, Fedora Cloud and Fedora Workstation with target audiences as listed in the proposal. Implementation is up to FESCo"
19:27:24 <sgallagh> That's the tl;dr version of what *I* am looking for
19:27:26 <jwb> sgallagh, i don't even think fesco is currently agreeing that is what they want to ask the board
19:27:44 <jwb> mattdm clearly wants to also get core/rings approved
19:27:48 <jwb> or disapproved
19:28:00 <jwb> so... figure it out and ask us as a body, not individually
19:28:10 <sgallagh> Hence why I've been grumbling this whole time about combining them into a single proposal
19:28:16 <sgallagh> Because I think that confuses the issue.
19:28:29 <sgallagh> We *can* do either alone, though they are a better fit together
19:28:36 <jwb> personally, i don't think i'd be comfortable with 3 products without a claerly defined common core
19:28:59 <jwb> because that invites disaster, no oversight, and no reasonable expectation of compromise
19:29:02 <sgallagh> jwb: Ok, I'm in agreement about that
19:29:02 <abadger1999> jwb: +1
19:29:09 <nirik> +lots
19:29:14 <sgallagh> If the language in the proposal doesn't speak to that, it's a shortcoming
19:29:34 <jwb> it does.  and the board is already generally agreeing to it.  not sure why we're not in this complicated loop
19:29:47 <mattdm> +10000 not sure why in complicated loop
19:29:49 <sgallagh> In a very real way, I expect Fedora Cloud to be that common core, since it's going to be the tightly-controlled minimal set
19:29:54 <abadger1999> mattdm: one problem that brings back to the fore is how the base design working group interacts with the product working groups.
19:30:11 <mattdm> "very nicely, thank you very much"
19:30:17 <abadger1999> mattdm: and also -- from the rings proposal, whether these three products would or would not be able to override things in ring1
19:30:28 <mitr> sgallagh: I think there'll be a noticeable difference, but we actually need to soft this out - elsewhere and later
19:30:33 <notting> jwb: because there is nothing that cannot be complicated by a committee meeting
19:30:43 <pjones> truth
19:30:47 * nirik nods.
19:30:58 <mattdm> So, seriously, what is too vague about the proposal as it stands?
19:31:34 <mattdm> set aside for now alignment of desktop/workstation target as separate issue to figure out.
19:31:55 <notting> "something end-usery"
19:32:19 <mattdm> notting I am quite certain that those words are never used.
19:32:30 <abadger1999> * Need some idea of how product WG and base design WG interact. (timeline, how dependent on each other?)
19:32:41 <notting> mattdm: well ,more end-usery than cloud or server, certainly
19:32:44 <sgallagh> notting: Not end-user. Workstation should imply "getting **** done"
19:32:49 <abadger1999> * for the first release with these products, can they override things in Ring1?
19:33:12 <mattdm> notting, sgallagh hey! now you're talking about the thing I asked to set aside
19:33:16 <abadger1999> (can adjust that later as environments and stacks has a chance to experiment and think things through)
19:33:31 <sgallagh> mattdm: Ack. Withdrawing
19:33:32 <mattdm> abadger1999 that is a good question. but is it the vagueness inode0 is talking about?
19:33:45 <mattdm> or is it a technical detail to work out at a lower level?
19:33:55 <inode0> mattdm: I was talking about the board's vagueness, not yours.
19:34:24 <sgallagh> inode0: So is there anything left in this proposal that you feel is too vague for the Board to vote on?
19:34:26 <abadger1999> mattdm: heh, I can't speak to that -- it should be in the proposal so that fesco can implement it, though :-)
19:34:44 <inode0> We expressed support of your work in vague terms
19:34:47 <mjg59> sgallagh: Like I said, the current proposal provides no justification for the change in direction
19:34:58 <nirik> should/can it address how non default products are created/distributed, etc?
19:35:12 <sgallagh> mjg59: We're hemmorhaging users because no one can point to a particular thing we're useful for?
19:35:20 <mjg59> sgallagh: So put that in the damned proposal
19:35:30 <inode0> sgallagh: yeah, as you rephrased it it became more problematic for me
19:35:37 <pjones> sgallagh: look, we've got to make a specific proposal to them, not answer in one-liners on irc when they tell us what's missing.
19:35:38 <sgallagh> mjg59: Works for me
19:35:49 <sgallagh> inode0: What became more problematic?
19:36:07 <mattdm> mjg59 can we just link to http://mjg59.dreamwidth.org/27517.html?
19:36:12 <sgallagh> pjones: I'm trying to find out what they want...
19:36:16 <mjg59> mattdm: No
19:37:15 <mattdm> mjg59 In serious, though, you would like to see a preamble with justification along those lines?
19:37:25 <mattdm> or, are you asking for something else that I'm not understanding?
19:37:29 <mjg59> mattdm: No, I'd like to see every change justified alongside the proposed change
19:37:35 <inode0> sgallagh: it reads like an edict now rather than a direction
19:37:50 <jwb> i have literrally no fscking idea what the hell anyone is now looking for.  good job.
19:38:28 <mmaslano> jwb: now? I don't have for more than 30 minutes
19:38:49 <jwb> i'm good at wading through confusion.
19:39:19 * nirik thinks we need another week of working on it, but it's not clear what the board might seek from it. If they don't like something tho, they could always punt it back for revision.
19:39:44 <notting> just have a FAD and fly the board and fesco somewhere in person
19:39:47 <jwb> the board wasn't really seeking anything to begin with
19:39:50 <notting> (seriously, it would go much faster)
19:40:01 <jwb> notting, not a horrible idea
19:40:08 <jwb> notting, except for money
19:40:11 <mjg59> nirik: If we end up with a single proposal that's proposing two very different things, the likely outcome is that it'll get punted back and forth far more than two separate documents
19:40:18 <abadger1999> notting: agreed on the faster.
19:40:34 <nirik> notting: yeah. I suggested that back when we started talking about this in fact. ;)
19:41:10 <nirik> anyhow, what can we do right now? we seem to be spinning.
19:41:15 <jreznik> well, it real discussion should start before flock and then at flock, just eat the cherry from the cake...
19:41:46 <nirik> jreznik: it did, just didn't get fully finished there.
19:41:48 <notting> but anyway, my reading: split proposals. re: 3 products, there is concern that explicitly describing the one that relates to what we produce now as being significantly different from what we produce now is confusing, so... rework it to be less so, perhaps? do this for a week, continue to gather feedback, present to board for a stamp, and...?
19:42:31 <jwb> notting, if you want to split them, fine.  but personally i think 3 products needs to say it depends on common core.
19:42:36 <mmaslano> is it whole board confused? what board wants from us?
19:42:42 <jwb> nothing afaik
19:42:49 <notting> jwb: please, don't make it depend on a math curriculum
19:43:07 <notting> </obscure parent joke>
19:43:18 * mattdm got joke.
19:43:19 <jwb> they want you to figure out how you're going to implement the proposal in concrete steps, and then come back to them if there are issues they think need clarifying/approval
19:43:22 <jwb> notting, heh
19:43:59 <nirik> abadger1999: I think your second question is probibly one for the 'core' working group, the first one is something to discuss for us probibly.
19:44:13 <mmaslano> jwb: kidding
19:44:19 <abadger1999> notting: you been to back to school night recently? ;-)
19:44:26 <mattdm> jwb except that's not what mjg59 just said. He's asking for justification for each change line by line.
19:45:05 <jwb> from a fesco or board perpective?  he wears two hats
19:45:22 <pjones> er, no?
19:45:22 <abadger1999> nirik: Well -- I think both would be answered in addressing jwb's concern.
19:45:34 <mattdm> jwb no he's just got the board hat
19:45:44 <jwb> oh my mistake
19:46:06 <jwb> i disagree but whatever
19:46:20 <nirik> jwb: perhaps. I have no idea on my question... :)
19:46:38 * notting notes we are at the 1:45 mark and still have agenda items
19:46:59 <mattdm> yeah. and the meeting chair is confused and lost over the current item.
19:47:01 <abadger1999> mattdm: way to hog the meeting time mr chairman ;-)
19:47:09 <mattdm> right. :)
19:47:24 <pjones> So maybe it's time to move on to other agenda items we can beat to mush ;)
19:47:46 <mattdm> As stated before, I'm happy to work further over the next week, and there are clearly things to do there regardless of all of the current confusion.
19:48:12 <mattdm> I don't think I _will_ split the proposal but will try to make it more clear why they are tied
19:48:26 <notting> mattdm: ok with that
19:48:28 * nirik thinks thats good, can ask his question(s) in ticket I guess.
19:48:55 <drago01> mattdm: what is is "server" ?
19:48:58 <mattdm> I think that the background and the "purpose" lines cover the "why this change" fairly well, but will try to make them stronger where I can.
19:49:11 <drago01> mattdm: web server? file server? database server? application server ... ?
19:49:29 <mattdm> drago01 can we take that offline now? we need to move on to other agenda items
19:49:30 <nirik> a base for any of thosre.
19:49:34 <nirik> and yeah
19:49:40 <mattdm> #info moving on
19:49:42 <drago01> mattdm: sorry to late yeah
19:49:53 <mattdm> (i would like to talk about it though)
19:50:00 <mattdm> #topic #1160 Change provenpackager policy
19:50:04 <mattdm> .fesco 1160
19:50:10 <zodbot> mattdm: #1160 (Change provenpackager policy) – FESCo - https://fedorahosted.org/fesco/ticket/1160
19:50:20 * mattdm clears brain, resets
19:50:33 <sgallagh> -1, I think the week is appropriate.
19:50:46 <mmaslano> -1
19:50:47 <mattdm> t8m was also -1
19:51:08 <mattdm> hey notting -- what's the benefit of this?
19:51:26 <notting> faster turnaround for requesters
19:51:43 * nirik doesn't care much either way
19:51:46 <pjones> I'm really 0 on this.  I don't see how less than a week is practical - if it's proposed on a thursday, we're still not likely to have gotten around to voting on it until the next wednesday, because we suck at voting in tickets.
19:51:56 <pjones> but at the same time - what does it hurt?
19:52:30 * abadger1999 is with pjones on this.
19:52:51 <notting> ok then. withdrawn, and move on?
19:53:02 <mattdm> okay
19:53:39 <mattdm> #rejected basically people think a week is okay or don't care (+1,-3,3)
19:53:49 <mattdm> #topic F20 Changes - Progress on Changes Freeze
19:53:50 <mattdm> .fesco 1164
19:53:51 <zodbot> mattdm: #1164 (F20 Changes - Progress on Changes Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/1164
19:54:11 <mattdm> jreznik you still awake?
19:54:22 <mmaslano> I have no comments to these features and have to leave now. Good night
19:54:32 <notting> shouldn't no default {sendmail,syslog} be modifed/closed?
19:54:34 <jreznik> mattdm: yep
19:54:37 <mattdm> bye mmaslano
19:54:51 <jreznik> notting: well, it's up to mattdm ;-)
19:54:53 <nirik> this is just heads up for next week right?
19:55:04 <sgallagh> I spoke to the FreeIPA guys, they've updated their tickets with ETAs now
19:55:39 <mattdm> I have all of mine sitting in my inbox looking angrily at mine. will get to updating after this exciting meeting ends :)
19:56:17 <mattdm> anything else needed?
19:56:50 <jreznik> mattdm: thanks
19:57:12 <mattdm> (and that last question is in the general sense, not just _my_ tickets.)
19:57:26 <mattdm> oh s/angrily at mine/angrily at me/
19:58:06 <mattdm> anyone? anything?
19:58:33 <nirik> will see where we are next week. ;)
19:58:39 <sgallagh> Nothing to see here. Move along.
19:58:45 <mattdm> okay then.
19:58:46 <mattdm> #topic Next week's chair
19:59:08 <mattdm> volunteers?
19:59:15 <sgallagh> The chances of me being around for next week's meeting are asymptotically approaching zero
19:59:36 <nirik> I guess I can do it if no one else steps up
19:59:37 <mitr> Same here
19:59:48 <mitr> (... i.e. I'll probably not be around, sorry)
19:59:48 <notting> i can do it
20:00:03 * nirik is happy to let notting do it. ;)
20:00:48 <mattdm> #action notting to chair next week
20:00:52 <mattdm> #topic Open Floor
20:01:17 <nirik> I meant to submit a ticket about my spins process change proposal, but I didn't. ;( I guess next week...
20:01:43 <mattdm> okay. let's... next week.
20:01:46 <gholms> So let me just double-check here:  what would you like the board to do tomorrow?  I can try to bring that up.
20:02:14 <mattdm> gholms I would like any feedback on the draft proposal in the ticket.
20:02:28 <gholms> Nothing new beyond that, though?
20:02:46 <mattdm> gholms As noted, there was not much feedback this week.
20:02:54 <gholms> Indeed.  :(
20:04:26 <mattdm> So yeah, I think that's pretty much all.
20:04:38 <mattdm> #endmeeting