fesco
LOGS
18:00:37 <abadger1999> #startmeeting FESCO (2013-08-21)
18:00:37 <zodbot> Meeting started Wed Aug 21 18:00:37 2013 UTC.  The chair is abadger1999. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:38 <abadger1999> #meetingname fesco
18:00:38 <zodbot> The meeting name has been set to 'fesco'
18:00:40 <abadger1999> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
18:00:40 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
18:00:41 <abadger1999> #topic init process
18:00:45 <mitr> Hello all
18:00:52 <nirik> morning
18:00:52 <pjones> hi.
18:00:53 * notting is sitting in a different meeting, may not be fully here
18:01:01 <pjones> have pitty for notting.
18:01:07 * mattdm mattdm ducked out of that meeting :)
18:01:10 * abadger1999 watches notting phase in and out of existence
18:01:20 <sgallagh> I'm here-ish
18:02:03 <abadger1999> IIRC mmaslano and t8m weren't going to be able to make it.
18:02:18 <abadger1999> #topic #1077 Drop usage of --vendor from .desktop files
18:02:19 <abadger1999> .fesco 1077
18:02:20 <zodbot> abadger1999: #1077 (Drop usage of --vendor from .desktop files) – FESCo - https://fedorahosted.org/fesco/ticket/1077
18:02:25 <abadger1999> This is done.
18:02:38 <abadger1999> Oops, t8m is here :-)
18:02:48 <t8m> hello
18:03:04 <abadger1999> had a badge issued to the list of people as a thank you.
18:03:17 <abadger1999> I'll close this unless anyone wants to do more on it.
18:03:27 <mattdm> yay
18:03:39 * nirik notes we could look at badge rewarding other groups that help with things like this. might help them get done.
18:03:39 <abadger1999> #topic #1148 F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller
18:03:41 <abadger1999> .fesco 1148
18:03:43 <zodbot> abadger1999: #1148 (F20 System Wide Change: Application Installer - https://fedoraproject.org/wiki/Changes/AppInstaller) – FESCo - https://fedorahosted.org/fesco/ticket/1148
18:03:55 <abadger1999> nirik: <nod> I think that would be a good idea to test out for a while.
18:04:12 <nirik> for example, the long running systemd migrations stuff.
18:04:21 <notting> abadger1999: what happened to the glibc thing? was that first or last?
18:04:41 <abadger1999> notting: First thing in the new business sectoin -- unless you would like it discussed now?
18:04:50 * abadger1999 is flexible
18:04:51 <notting> no, that works
18:05:00 <abadger1999> Okay -- so App Installer.
18:05:11 <abadger1999> The packaging team gave a list of requirements in the ticket.
18:05:32 <abadger1999> There's been some back and forth with the Change Owners.
18:06:04 <mitr> Note that mclasen is not an owner
18:06:10 <sgallagh> From what I understand, the major question here is whether we consider 'yum history' to be a guaranteed stable API
18:06:21 <mitr> In fact we haven't heard from rhughes in 3 weeks
18:06:27 <notting> sgallagh: and/or a *required* one
18:06:44 * nirik notes fedup already doesn't update/care about it. ;( Sadly.
18:06:49 <sgallagh> mitr: He's the supervisor of the engineer implementing the App Installer. Functionally, he should be treated as an owner
18:06:53 <notting> if it's not required, the question of whether it's stable isn't really relevant
18:06:58 <mitr> We have sort of decided that they have to agree :)
18:07:21 <mitr> sgallagh: That would be a new mechanism :) but point taken, I was being pedantic
18:08:27 <drago01> well asking to write to a database and at the same time saying "its a private db do not touch it" makes no sense
18:08:30 <abadger1999> I'll note that we basically gave the packaging team veto power over the change when we accepted it so I think the burden's on the Change Owners at this point.
18:08:35 <sgallagh> mclasen will be joining this meeting momentarily
18:09:04 <mitr> drago01: That's not the case here
18:09:18 <sgallagh> abadger1999: While that's true, the fact remains that they raised a valid point that there are multiple other pieces of the system apparently exempt from this compatibility
18:09:33 <sgallagh> I think it's fair to revisit the question as to whether this is the right requirement
18:09:35 <notting> drago01: i'm fine with "if it's writing to it, it needs to write to it compatibly"
18:09:43 <abadger1999> sgallagh: Did they?  The other pieces of the system are not default with the exception of rpm.
18:09:56 <abadger1999> And that's designed to operate at a lower level, not the same or higher.
18:09:59 <sgallagh> abadger1999: I'd contest that RPM and fedup are fundamental
18:10:09 <sgallagh> s/contest/contend/
18:10:13 <mitr> sgallagh: fedup is not as much exempt as "surprisingly not doing it" as I understand
18:11:01 <mitr> $everybody was $always talking of fedup as "just a yum upgrade in a controlled environment" and it turns out it's not that
18:11:03 <nirik> at least it was surprising to me, but I guess thats what I get for assuming it was using yum. ;)
18:11:04 <mclasen> not sure if hughsie is still around, but I talked to him this morning
18:11:23 <t8m> mitr, +1
18:12:16 <mattdm> fedup-not-using-it bug:
18:12:20 <mattdm> .bug 979083
18:12:28 <zodbot> mattdm: Bug 979083 yumdb/history data is not available after upgrade from F18 => F19 (possible chroot problem?) - https://bugzilla.redhat.com/show_bug.cgi?id=979083
18:12:47 <sgallagh> Well, the fact that we aren't mandating that calls to librpm or the rpm command-line tool also update this history suggests to me that we may have selected integration at the wrong layer
18:13:15 <nirik> there's some history there... yum folks asked rpm folks for a db for this info and were told no.
18:13:25 <drago01> sgallagh: yeah that's what I said in the ticket as well
18:13:27 <pjones> mitr: eh, I don't think that's a fair criticism tbh
18:13:52 <pjones> mitr: the real question is: if everything is expected to do something if it does yum-like things, how come using the yum api isn't enough to do that?
18:14:16 <mitr> pjones: There's also the dimension of some callers not wanting to use Python / yum...
18:14:41 <pjones> that's a separable issue about the choices we've made as fedora, though
18:14:47 <notting> pjones: b/c "the yum api". calling python from !python
18:14:51 <mitr> sgallagh: I'm not actually sure whether it's "dnf has a plan that is just not implemented yet", or "dnf roadmap didn't account for PackageKit wanting a C API"
18:15:16 <pjones> notting: which isn't impossible, it's just somewhat distasteful
18:15:31 <notting> pjones: also, the question of whether things are exposed in a reliable API-stable manner from yum
18:16:32 <mitr> .... anyway....
18:16:45 <t8m> What do we have as possible solutions to the problem here?
18:17:00 <mitr> As I understand the progress from the FESCo decision 2 weeks ago, _nothing is actually new_ except for the packaging team asking for explicit Fedora QA involvement.
18:17:03 <mclasen> ftr, I don't mind updating the yumdb or any other logs from the app installer. I'd prefer if it was automatic, and would require us to take locks
18:17:16 <notting> mclasen: would or would not?
18:17:20 <mitr> Is the Fedora requirement a problem?
18:17:26 <mclasen> would not, of course
18:17:28 <mitr> s/Fedora/& QA/
18:17:35 <drago01> mclasen: can't it simply run yum syncdb after each transaction?
18:18:13 <notting> drago01: hooray undocumented option
18:18:14 <mclasen> drago01: discussion in the fedup bug seemed to indicate that thats not the preferred way to update the yumdb
18:18:14 <mitr> drago01: That would lose the scriptlet output, wouldn't it?
18:18:29 <drago01> notting: https://bugzilla.redhat.com/show_bug.cgi?id=979083#c2
18:18:29 <notting> drago01: oh, wait, it's "yumdb sync"
18:18:31 <nirik> yeah, that wouldn't give it all the info it normally has
18:18:35 <drago01> notting: yeah sorry
18:18:51 <drago01> I have no idea
18:19:13 <drago01> just looks like a way to do it without having to worry about yum locks
18:19:55 * abadger1999 notes we've hit 15 minutes of discussion.
18:20:02 <sgallagh> +1 to continue
18:20:12 <mitr> (What are we actually trying to decide here?)
18:20:24 <t8m> mitr, can I join your question? :)
18:20:28 <abadger1999> mitr: yeah
18:20:49 * nirik is also +1 to continue if we can get some kind of proposals. ;)
18:20:54 * pjones as well
18:20:57 <abadger1999> so currently I think things fesco could do: 1) allow discussion to continue on the ticket (alpha is coming up,though  and we'd need a decision by then). 2) ask the App Installer owners to definitely say whether they can or cannot comply with the packaging-team's requirements
18:21:08 <sgallagh> Straw-man Proposal: Withdraw the requirement to update the yum history and allow AppInstaller to behave as it sees fit
18:21:28 <mitr> proposal: FESCo acknowledges comment#28 and asks feature owners to discuss this with Fedora QA.
18:21:37 * nirik re-reads to see what those requirements are again.
18:21:51 <mitr> abadger1999: s/need a decision/need an implementation/
18:21:55 <abadger1999> sgallagh: -1  I'm still definitely for leaving the requirements to the packaging team...
18:22:15 <mitr> abadger1999: What I hear above, change owners are fine in principle with updating yumdb
18:22:17 <abadger1999> mitr: true that... so maybe we're already getting dangerously close to forcing a slip in the Change?
18:22:47 <mitr> abadger1999: per the previous decision we'd be forcing the contingency plan already
18:23:10 <t8m> mitr, +1 to your proposal
18:23:21 <t8m> (after reading the comment #28)
18:23:48 <t8m> or invoke the contingency plan
18:24:01 * nirik is +1 to mitr's proposal. -1 to sgallagh's.
18:24:14 <mitr> sgallagh: 1) re yum history, I'm concerned about loosing it but could see a way to relax.  2) The working "to behave as it sees fit" is not acceptable to me.  I'm not having two separate packaging universes that are allowed to ignore each other, if I can help it.
18:24:30 <abadger1999> alpha freeze is 09-03 isn't it?
18:24:34 <nirik> yes
18:24:35 * mitr really can't type today.
18:24:51 <abadger1999> If we're voting, mitr: +1, sgallagh -1
18:24:56 <notting> mitr: "system("yumdb sync")" post-transaction seems to be an implied solution that is compatible per that comment #28
18:25:14 <notting> (at least, if 'yumdb sync' is incompatible with yum, we have larger problems)
18:25:55 <sgallagh> Sure, I'm also -1 to my proposal, but I wanted us to explain our reasons at least.
18:26:13 <pjones> I'm +1 to mitr's proposal
18:26:24 <mitr> notting: maybe.  The previous FESCo resolution "Approve the change conditional on 1) the packaging team and appinstaller both agreeing on a solution _and writing the solution down_" still applies I suppose.
18:26:57 <sgallagh> mclasen: Refresh my memory what the specific sticking point is with the packaging team's requirements on you?
18:27:21 <mitr> proposal#2: FESCo reiterates its 2013-08-07 decision and asks for the written down solution
18:27:22 <nirik> interfacing with yum instead of dnf, right?
18:27:30 <notting> mitr: sure. but i would assume the package team can not be against *both* 'yumdb sync' or 'updates the yumdb with its own code'
18:28:14 <mitr> notting: Yes.  AFAICS from the locking standpoint there shouldn't be any difference either, I just don't want to get FESCo into specifying yumdb contents field by field.
18:28:49 <mclasen> sgallagh: there's no particular sticking point. I still think that this sort of history is ideally suited for the journal, but I seem to be the only one thinking that so far
18:29:08 <nirik> we should really also (seperate from this) come up with a longer term plan. I mean, dnf is planned, but should yumdb/dnfdb get moved to rpm? seperate journal? etc
18:29:12 <mclasen> there's a general unease with the yumdb design and (lack of) api, too
18:29:28 <abadger1999> notting: Couldn't they be given geppetto's statement that yumdb sync isn't meant for this purpose?  (it's to fix things up after something messes up, not to record the full range of information)?
18:29:29 <mattdm> yes longer term plan
18:29:32 <mitr> nirik: s/we/the relevant experts/ hopefully
18:29:38 <notting> mclasen: i wonder if just calling out to yumdb sync might be better short term until dnf comes up with a better api
18:29:53 <mclasen> sure, thats ok for me
18:29:55 <notting> abadger1999: that would imply that they are then ok with PK using its own code to write to yumdb
18:29:59 <nirik> mitr: yeah. Just would love to see a written down plan. ;)
18:30:04 <mitr> nirik: same here
18:30:05 <abadger1999> notting: I think they said that....
18:30:06 <mattdm> If there is a reasonable longer-term plan I'm happy with whatever ugly ting gets it working now.
18:30:21 <mclasen> I'll add this to the feature page
18:30:25 <pjones> Proposal: recommend using yumdb sync for now, as well as asking the packaging and appinstaller teams to come up with a real long term plan for this _and writing it down_.
18:30:39 <pjones> (possibly s/asking/requiring/)
18:30:45 <mitr> notting: Last I heard, the packaging team was OK with app installer having its own code.
18:30:47 <mitr> pjones: -1
18:30:55 <mitr> (to the first part)
18:31:17 <mitr> *we are seeing problems and conflicts that aren't there and don't need to be solved*, people
18:31:19 <abadger1999> " would it be ok for you to implement a layer that would record AppInst? transactions into yum and/or dnf databases? If the answer is yes, I don't think we have any other problem here and the feature can be approved with this implementation as a requirement."
18:31:26 <abadger1999> https://fedorahosted.org/fesco/ticket/1148#comment:21
18:31:47 <notting> abadger1999: hm. i find the  "you must be 100% compatible" but "you shouldn't just call out to our code" does seem somewhat... obstinate? to me.
18:31:48 <abadger1999> pjones: -1
18:32:08 <pjones> notting: that's how it seemed at the time, too
18:32:22 <mattdm> pjones +1
18:32:24 <nirik> well, yumdb sync doesn't have all the info that actually writing it would have...
18:32:31 <mitr> notting: I read it just as stringent wording of a fairly ordinary requirement
18:32:32 <t8m> pjones, -1
18:32:52 <abadger1999> notting: well -- otoh, people are being asked to maintain two package managing stacks two releases before they wanted to do so.  So....
18:33:02 <nirik> abadger1999: was there an answer to that? i'm not sure I see one.
18:33:14 <notting> nirik: true. but that's an additional amount of correctness
18:33:59 <mitr> nirik: above in the meeting. "mclasen:  ftr, I don't mind updating the yumdb or any other logs from the app installer. "
18:34:12 <nirik> mitr: yeah, but from the package team side... ?
18:34:25 <notting> i am +1 to pjones, but also could be +1 to mitr's proposal, if pjones' doesn't pass
18:34:26 <nirik> I guess the comment about asking qa to test.
18:34:39 <mitr> nirik: comment#21
18:35:12 <abadger1999> nirik: I thought of that as implicit in the packaging team's requirements -- "We're willing to keep the second stack working to high standards *if*  the app installer owners are willing to do these things to not make our jobs harder"
18:35:18 <mitr> 'm +1 to the second part of pjones's proposal, asking for a written plan.
18:35:21 <abadger1999> nirik: but yeah -- it wasn't explicitly stated.
18:35:27 <notting> note that if PK ends up writing to yumdb, there should also be notification to the appinstaller team if there are yumdb changes between releases (or in a release) before full dnf
18:36:04 <mitr> Insiting on (yumdb sync) would be FESCo unnecessarily mandating a suboptimal solution when both parties are OK with doing better.
18:36:07 <drago01> notting: ins't yum more or less in "maintaince mode" anyway?
18:36:21 <abadger1999> mitr: yeah, that sounds right to me.
18:36:27 <nirik> so, I am +1 to mitr's proposal, -1 to the first part of pjones and +1 to the second part and +1 to making it difficult for abadger1999 to count votes. :)
18:36:34 <abadger1999> nirik: :-P
18:36:36 <drago01> notting: which means don't really expect any such changes but who knows
18:37:11 <notting> drago01: for some value of more or less. but i think it's good to document that there is now an external user
18:37:26 <drago01> notting: ok fair enough
18:37:58 <t8m> I can second the nirik's vote - +1 to mitr's -1 to first part of pjones +1 to second and +1 to making it difficult to count votes :)
18:38:00 <nirik> so where are we?
18:38:05 <t8m> but please count it :)
18:38:20 <pjones> I think maybe somebody should re-propose something they think is coherent ;)
18:38:26 <pjones> and then we should vote on that.
18:38:28 <adamw> ahoyhoy?
18:38:49 <abadger1999> what does writing down a long term plan to do it right mean in the context of them having code to write to the yum db in the F20 version?
18:38:53 <nirik> adamw: https://fedorahosted.org/fesco/ticket/1148#comment:28 is being looked at, which asks qa to test before beta that appinstaller handles yumdb transactions sanely
18:39:28 * abadger1999 goes looking at what the votes might stand at now
18:39:43 <adamw> yeah, uh, reading c#28, i have to admit I have no idea what that would entail.
18:39:51 <nirik> proposal: FESCo acknowledges comment#28 and asks feature owners to discuss this with Fedora QA. Further we ask packaging stakeholders to come up with a roadmap for dnf and yumdb and app installer items.
18:40:04 <adamw> i don't know how to go about testing '100% compatibility with internal representations of entities in yumdb'.
18:40:14 <nirik> (could phrase that better I know)
18:40:27 <pjones> to be honest, I think that requirement is *bit* of an overreach
18:40:34 <mitr> nirik: "FESCo reiterates its 2013-08-07 decision and asks for the written down solution.  FESCo acknowledges comment#28 and asks feature owners to discuss this with Fedora QA. Further we ask packaging stakeholders to come up with a roadmap for dnf and yumdb and app installer items." ?
18:40:42 <nirik> adamw: yeah, not fully sure either. I would more think 'not corrupted' and 'contains valid looking info' would be better
18:40:47 <pjones> it's a nice goal, but it's very difficult to measure in any meaningful way
18:41:30 <pjones> So if people are going to be held to it, we should define specific things like nirik just did (but even more quantifiable), and set up an evaluative criteria.
18:41:52 <adamw> i'm a dumb test monkey, so mostly what i'd be _expecting_ to do in relation to a feature like this is some testing of the general form 'do a lot of stuff with yum and a lot of stuff with the new dnf-based apps and see if anything breaks'
18:42:14 <adamw> if we want something more sophisticated than that then it's gonna require some help i think
18:42:17 <mitr> adamw: I guess something like "both ways to install/update result in {structurally same changes to the DB, materially equal results when viewing the database}"
18:42:35 <nirik> I agree "100% compatibility with internal representations of entities in yumdb" is too high a bar, unless packaging team provides a test suite. ;)
18:42:39 <adamw> okay, now you're dumbing down to a level where i can play along. :)
18:42:40 <mitr> Perhaps only the second part
18:42:43 <abadger1999> Okay -- current vote
18:43:12 <abadger1999> mitr's proposal passes: +1 t8m, nirik abadger1999 pjones notting
18:43:27 * abadger1999 notes mitr didn't explicitly +1 his own proposal.
18:43:40 <mitr> +1 my very first proposal for the record
18:43:51 <abadger1999> pjones proposal is at +4 to the second portion and +2 in its entirety
18:44:15 <sgallagh> I think I missed pjones' proposal
18:44:24 <abadger1999> I think if we want to go ahead with the second portion, nirik's phrasing is better.
18:44:31 <tflink> the idea would be to test for db representation consistency in both app installer and yum before beta?
18:44:35 <nirik> mclasen: does that work ok for you? or do you still have concerns/issues?
18:44:40 <nirik> tflink: yes
18:44:54 <abadger1999> Oh sorry, that was mitr's phrasing, not nirik's.
18:44:56 <sgallagh> I'm +1 for mitr's proposal in any case
18:45:11 <sgallagh> or rather, mitr's phrasing of nirik's proposal
18:45:48 <mclasen> nirik: sounds like a lot of concern about something that hasn't really figured in qa plans at all so far (or have we been testing 'yumdb structural integrity in the past ?)
18:46:04 <tflink> mclasen: not directly ,no
18:46:06 <mclasen> as long as we're only expected to call yumdb sync in a strategic place, thats ok with me
18:46:39 <nirik> well, the plan was to talk to it directly I thought... which it sounded like there already was code for.
18:46:41 <abadger1999> Hmm... then it may fall apart -- I don't know that that's what the packaging team had in mind.
18:46:53 <abadger1999> yeah, what nirik said.
18:47:24 * abadger1999 notes we're at 46minutes into the meeting
18:47:29 <mclasen> I don't know about any code to 'talk directly'. as far as I know, the yumdb is just a pile of files somewhere
18:47:32 <abadger1999> Does anyone have a hard stop today?
18:47:33 <mitr> abadger1999: Don't need to solve this, we wan't a written agreed plan, let them figure it out :)
18:47:35 <mclasen> I will have to investigate
18:47:53 <mattdm> abadger1999 my head is slowly slipping and will hit the table eventually, so there's that
18:47:54 <t8m> mitr, +1
18:48:03 <abadger1999> mattdm: Buy a pillow ;-)
18:48:25 <abadger1999> Trust me, it'll come in handy for other meetings too ;-)
18:48:42 <nirik> mclasen: it's a sqlite db I think... but "I'm happy reading and writing to the yumdb if the yum team are happy with this. I got in a lot of trouble when Zif started writing to it in the past, so I don't want to add support without at least a +1 from someone like zpavlas."
18:49:00 <drago01> nirik: no it isn't afaik
18:49:13 <nirik> ok. Doesn't matter. it's some bits somewhere. ;)
18:49:28 <drago01> nirik: it is a folder / files structure thing (this is why I call it "non db")
18:49:35 <nirik> ok.
18:49:46 <abadger1999> okay... as mitr says, I think we're at implementation details without one of the parties involved.
18:49:55 <t8m> abadger1999, exactly
18:49:57 <abadger1999> So let's leave this topic.
18:49:59 * nirik nods.
18:50:02 <t8m> next topic please :)
18:50:19 <mitr> A moment...
18:50:24 <drago01> nirik: ls /var/lib/yum/yumdb ;)
18:50:31 <abadger1999> #info mitr's proposal  FESCo acknowledges comment#28 and asks feature owners to discuss this with Fedora QA. accepted  +7:0:0
18:50:49 <abadger1999> Does any fesco member have a hard stop in 10 minutes?
18:50:55 * nirik doesn't
18:51:03 <mitr> Proposal: Further we ask packaging stakeholders to come up with a roadmap for dnf and yumdb and app installer items (the final state palnned for ~F22).
18:51:20 <pjones> mitr: definitely +1 to that
18:51:23 <abadger1999> +1
18:51:26 <t8m> mitr, +1
18:51:27 <sgallagh> mitr: +1
18:51:30 <nirik> sure, +1
18:51:33 <mattdm> what does "final state" mean?
18:51:41 <mattdm> other than that, I'm probably +1
18:51:45 <mitr> mattdm: "no currently forseeable changes"
18:52:01 <pjones> mattdm: he means "where we want it to be when it all lands in F22"
18:52:04 <pjones> I think.
18:52:16 <mattdm> pjones okay that I'm good with
18:52:36 <pjones> mitr: that's what you mean, right?
18:52:55 <abadger1999> #info  Proposal: Further we ask packaging stakeholders to come up with a roadmap for dnf and yumdb and app installer items (the final state palnned for ~F22).  accepted: +6:0:0
18:53:06 <mitr> pjones: yes.
18:53:09 <abadger1999> #topic BlueZ System Wide Change - https://fedoraproject.org/wiki/Changes/Bluez5
18:53:12 * nirik notes also some of this would be good to know for the fedora.next planning.
18:53:29 <abadger1999> There's no ticket for this in fesco's trac due to us voting on it early I think.
18:53:47 <nirik> yeah
18:53:49 <abadger1999> There's been extensive discussion on the mailing list and we have to keep track of one thing to evaluate it later.
18:54:33 <nirik> should we file a ticket to note that/trac it?
18:54:37 <abadger1999> Whether the other desktops are: (a) okay with having bluetooth broken for them  (b) have a solution in place (c) object to the change.
18:54:43 <abadger1999> yeah
18:55:01 <jreznik> abadger1999: yeah, you were faster than me, I'll create ticket
18:55:08 <abadger1999> jreznik: Cool.
18:55:26 <abadger1999> Does anyone have an idea of who we should ask to state a position for each desktop?
18:55:29 <sgallagh> abadger1999: I doubt very much that (a) is ever valid
18:55:37 <sgallagh> Is parallel-installation possible?
18:55:40 <drago01> no
18:55:45 <abadger1999> sgallagh: according to the ml, no.
18:55:50 <mitr> sgallagh: I think someone mentioned xfce is actually in that position
18:56:04 <nirik> not that I know of, no.
18:56:09 <sgallagh> mitr: XFCE is okay with no bluetooth?
18:56:18 <nirik> There's a very early xfce applet... it's not likely to be very usable for f20.
18:56:22 <mitr> My impression from the thread was that nobody was explicitly objecting, and most were working to get something done.
18:56:48 <nirik> I'm fine with no bluetooth tho, as I don't want to hold back other desktops with more resources. If people find this horrible, they can step up to help with the applet. ;)
18:57:06 <abadger1999> I saw some objections but I'm not certain that they speak for the desktops.
18:57:12 <mitr> nirik: OK, I miunderstood.  Sorry.
18:57:34 <sgallagh> Are both GNOME and KDE functional at the moment? (Those are generally our two blocker desktops)
18:57:36 <nirik> as soon as the applet is usable I intend to ship it, and likely it will get better over time for f20 users.
18:57:41 <notting> drago01: hadess implied that parallel *packaging* was possible. they just couldn't be installed simultaneously
18:57:42 <sgallagh> Sorry, I haven't been following that thread on the ml
18:57:55 <jreznik> sgallagh: rdieter packaged bluedevil snapshot as far as I know
18:58:12 <jreznik> there are still some features missing, upstream working on it right now
18:58:24 <nirik> kalev and raveit65 were working on a applet for mate and other desktops with systray
18:58:28 <mitr> sgallagh: there's still time till the alpha freeze
18:58:36 <mclasen> for gnome, we also still need nm and pa updates
18:59:04 <sgallagh> mclasen: What is "pa" in this context?
18:59:09 <mclasen> pulseaudo
18:59:13 <mclasen> audio, even
18:59:19 * sgallagh nods
19:00:04 * jreznik would really like to see alpha change deadline as the point to start contingency plan - it's quite a big thing to go with or revert on time
19:00:05 <nirik> proposal: keep an eye out on progress, revisit as and if needed?
19:00:53 <mitr> nirik: Is that different from "not keep an eye on progress"?
19:01:06 <abadger1999> nirik: pretty much :-)  I think that's the default :-)
19:01:07 <notting> would fesco allow conflicting bluez and bluez5 packages?
19:01:19 <nirik> well, counter proposal would I guess be: don't file a ticket, revisit at change freeze to see if it needs contingency plan
19:01:34 <mitr> notting: would this impact the multi-desktop DVD?
19:01:39 <jreznik> mitr: no
19:01:40 <sgallagh> Proposal: if BlueZ isn't ready by alpha, start contingency plan and allow conflicting bluez/bluez5 packages
19:01:48 <jreznik> multi desktop are several spins on one dvd
19:01:50 <notting> mitr: that's separate lives, so no.
19:01:52 <sgallagh> (so that development can proceed for F21)
19:01:52 <abadger1999> notting: That would be FPC.
19:02:20 <abadger1999> I've been thinking about having FPC reevaluate that as a whole but it might not be discussed and voted on in time for alpha.
19:02:37 <jreznik> abadger1999: exception for bluez5?
19:02:39 <notting> abadger1999: ? we have conflicting packages in repo, don't we?
19:02:51 <mitr> sgallagh: I'm not sure about yanking a month of time from people actually writing code like this.
19:02:52 <t8m> sgallagh, what problems would be with conflicting bluez/bluez5 packages? Some desktops would not be installable in parallel?
19:03:10 <sgallagh> t8m: Exactly
19:03:16 <t8m> I don't like tish
19:03:18 <abadger1999> notting: ohh... Actually already covered.
19:03:20 <t8m> this
19:03:27 <sgallagh> mitr: I'm not talking about taking a month away, I'm talking about adding 7 months :)
19:03:29 <abadger1999> http://fedoraproject.org/wiki/Packaging:Conflicts#Compat_Package_Conflicts
19:03:40 <abadger1999> That's couched in terms of file conflicts as the justification.
19:03:59 <abadger1999> So compat bluez package smight violate the spirit but not the letter of that guideline.
19:04:55 <abadger1999> sgallagh: Development for f20 should already be in process (we gave teh Change the go ahead last week).
19:05:04 <sgallagh> t8m: Well, it's not ideal, but IMHO it beats the alternative of having no support in some desktops
19:05:16 <jreznik> is dbus interface the issue for parallel installation? shouldn't be possible do the same as with NM? (yeah, it caused a lot of troubles...)
19:05:25 <mattdm> sooo, what's wrong with the contingency plan as written in the change page?
19:05:53 <t8m> sgallagh, that's tru
19:05:55 <mattdm> just that the beta change deadline seems too late?
19:06:27 <sgallagh> mattdm: Yeah, I don't like seeing a major piece of functionality reverted at that late date
19:06:40 <abadger1999> mattdm: also -- Change was submitted late so we made it potentially block on other desktops, not just gnome+kde.
19:06:41 <jreznik> mattdm: for me it really seems too late, pretty widespread to revert for final
19:06:56 <sgallagh> I don't think there's likely to be enough time to retest sanely before final
19:07:25 <sgallagh> Frankly, if I'd realized how much trouble this was going to be originally, I'd have voted to defer it to F21 in the first place.
19:08:02 <t8m> so is there proposal for earlier date to invoke the contingency plan?
19:08:03 <sgallagh> (of course, that probably would have meant that no one would have bothered to deal with it until branch of F21, leaving us in the same position...)
19:08:13 <sgallagh> t8m: That was my proposal above
19:08:25 <jreznik> sgallagh: kalev invested quite a lot of work coordinating stuff, so I'd trust him at least for now
19:08:31 <sgallagh> Proposal: if BlueZ isn't ready by alpha, start contingency plan and allow conflicting bluez/bluez5 packages
19:08:51 <t8m> ah ok
19:08:51 <mclasen> sgallagh: the underlying problem is that it is not parallel installable, pushing it out won't get you out of that
19:09:04 <sgallagh> I can amend that to "if kalev says at alpha 'we're definitely going to make it', revisit then"
19:09:25 <sgallagh> mclasen: No, but it gains us six months to add support to the other desktops in Rawhide
19:09:29 <pjones> your contingency doesn't seem to work.
19:09:30 <abadger1999> mclasen: Doesn't allowing conflicts get you out of that?
19:09:31 * nirik is fine punting to before alpha change deadline... there's really actually a lot of work going on.
19:09:32 <mattdm> Alt proposal: accept plan is as is, except contingency plan deadline at alpha
19:09:34 <mitr> sgallagh: -1.  I'd be open to moving forward the contingency activation ~2 weeks
19:09:40 <pjones> abadger1999: no?
19:10:02 <pjones> abadger1999: I mean, they're not going to magically both work just by us taking away the requirement that causes them to not both be allowed.
19:10:06 <nirik> +1 mattdm  (alpha change deadline right? not alpha release?)
19:10:18 <mattdm> nirik yes
19:10:22 <pjones> mattdm: +1 to alpha change deadline
19:10:42 <sgallagh> Perhaps we should just agree to revisit progress at Alpha change deadline, reserving the right to invoke the contingency plan at that time (but no earlier)?
19:11:04 <abadger1999> pjones: I'm not understanding something... I thought, if old is installed bluez and not the new one things linked to it work.  If new bluez is installed and not the old one, then things linked to it work.
19:11:13 <abadger1999> Conflicts prevent the two from being installed at the same time.
19:11:18 <mitr> sgallagh: I can agree to that without actually changing my opinion :), so....
19:11:45 <abadger1999> Which is the road to icky but gets around the problem of non-functional programs installed.
19:11:52 <pjones> abadger1999: but you still can't actually have both dep chains installed at the same time
19:11:57 <sgallagh> mitr: Yeah, I think it's reasonable to just say we'll decide whether an extra week or two is warranted at that point
19:12:00 <abadger1999> pjones: correct.  "road to icky"
19:12:24 <t8m> sgallagh, +1
19:12:42 <abadger1999> adamw: So to be clear -- we still have the previous acceptance criteria.  We're just *adding* contingency plan change to alpha?
19:13:12 <abadger1999> err
19:13:15 <abadger1999> mattdm: ^
19:13:49 <abadger1999> Previous acceptance criteria is: http://www.fpaste.org/33861/77112410/
19:13:51 <nirik> abadger1999: I think the proposal is moving it from beta to alpha
19:14:02 <mattdm> yeah, what nirik said.
19:14:23 <mattdm> s/Beta Change Deadline/Alpha Change Deadline/ in the proposal
19:14:48 <nirik> http://fedoraproject.org/wiki/Changes/Bluez5#Contingency_Plan (change that here)
19:15:20 <abadger1999> mattdm: right.. I mean -- we aren't dropping the previous criteria.  We're just adding a new criteria "We will do the contingency plan evaluation at alpha, not at beta".
19:15:46 <notting> hm
19:16:05 <notting> given that it implies new work to adapt, moving contingency *up* seems somewhat self-defeating
19:16:24 <abadger1999> b/c the previous criteria included non-release-blocker desktops and I want to know that we're on the same page about that.
19:16:41 <mattdm> the alternatives are a) defering to f21 b) accepting the risk that beta is not enough time to back out
19:17:09 <mattdm> or c) to hack in the bluez5 package, which might not be much less work than b).
19:17:22 <notting> mclasen: what is the mechanism NM uses to talk to bluez?
19:17:36 <notting> mclasen: (similarly, PA)
19:18:20 <nirik> abadger1999: I'm still ok with that provided we can figure out who speaks for each.
19:18:21 <mattdm> abadger1999 Ah I see what you're getting at. Do we have a good mechanism (or history, for that matter) for getting that? I think we _definitely_ need a reasonable deadline for such objections
19:18:33 <notting> in f19, looks like NM would use dbus, PA uses library linking
19:18:42 <nirik> but really, I know kalev is working on an applet, so all this gnashing of teeth may be moot in a week or two
19:18:56 <notting> so a 'conflicting packages' scenario implies PA-module-bluetooth and NM's bluetooth only works on one of the two package sets
19:19:41 <mclasen> notting: I don't know
19:20:23 <nirik> proposal: defer and see where we are next week
19:20:24 <abadger1999> notting: <nod>  Good point.
19:21:17 <notting> and if it's talking to those things that people would need an old-version applet for, conflicting packages therefore may be a pointless solution
19:21:18 <t8m> nirik, +1
19:21:31 <abadger1999> nirik: I'll add -- ask on devel@ for desktop owners to register any objection.
19:21:36 <nirik> sure
19:21:42 <mattdm> i'm only +1 to defering if we promise to time-box the conversation next week :)
19:21:42 <t8m> abadger1999, +1 to that as well
19:21:56 <abadger1999> +1
19:22:07 <notting> nirik: ok, can live with that. +1
19:22:40 <nirik> if there's a working systray applet in the next few weeks we should be fine.
19:22:44 <abadger1999> <nod>
19:22:53 <abadger1999> That's +5.
19:23:15 <abadger1999> #info defer and see where we are next week and ask on devel@ for desktop owners to register any objection by next week
19:23:32 <abadger1999> #topic https://fedoraproject.org/wiki/Changes/GLIBC218
19:23:36 <abadger1999> Something easy I hope
19:23:49 * sgallagh sighs. Twenty minutes of arguing to decide not to decide.
19:23:57 <abadger1999> This got lost in the shuffle because it should be a systemwide change but hte owner didn't update the Change.
19:24:25 <mitr> I really don't like the precedent, but, ... it's glibc and it's been built already, so +1?
19:24:27 <sgallagh> Since it's past the deadline, I think that means we reject it automatically (kidding!)
19:24:27 <abadger1999> It's presently in rawhide/f20
19:24:29 <nirik> sure, +1
19:24:44 <sgallagh> +1 rubber stamp
19:24:45 <abadger1999> +1
19:24:49 <pjones> +1
19:25:13 <notting> +1
19:25:14 <t8m> +1
19:25:34 <abadger1999> #info GLIBC2.18 Change Approved +6:0:0
19:25:53 <abadger1999> #topic #1157 change the way Initial Hosting Requests are processed
19:26:06 <abadger1999> .fesco 1157
19:26:09 <zodbot> abadger1999: #1157 (change the way Initial Hosting Requests are processed) – FESCo - https://fedorahosted.org/fesco/ticket/1157
19:27:31 <abadger1999> nirik: Do you have some ideas about this?  Should we just leave it to infra whether to implement it?
19:27:34 <nirik> I'm not sure it's too feasable to match people with sponsors before they submit everything, but I could be wrong.
19:28:17 <nirik> well, there's an infra side to it, and then a sponsoring workflow side (which is more fesco's business)
19:28:48 <t8m> I don't have any problem with the sponsoring workflow side
19:30:04 * nirik also wonders if this is really that much of a problem. Yes, a few requests were slow to process, but everyone was at flock, etc.
19:30:05 <abadger1999> So if we say this is available but no sponsors step up to pre-sponsor, then we may create more disappointment than presently.
19:31:18 <nirik> actually I think requests already go to all sponsors, but many can't add people to fedorabugs
19:32:19 <abadger1999> Solution -- make all package sponsors fedorabugs sponsors?
19:32:21 <t8m> abadger1999, that's true
19:33:08 * nirik is looking to see if thats the case.
19:33:25 <mattdm> proposal: change this to a fedora infrastructure ticket, let infrastructure team do whatever seems best
19:34:05 * nirik shrugs, ok.
19:34:33 <nirik> abadger1999: looks like just tibbs gets them now... so that could be improved with more folks.
19:35:01 <drago01> notting: you can parallel package pretty much anything
19:35:12 <drago01> notting: if it isn't parallel installable it is worthless
19:35:25 <nirik> could be changed to fedorabugs-sponsor-members or the like. I'm fine with dealing with this ticket outside fesco if fesco is ok with that
19:36:26 <abadger1999> nirik: +1.  let's take this up with fedorabugs members and then package-sponsors if need be.
19:36:40 <sgallagh> Yeah, I don't think FESCo really needs to be involved here
19:37:09 <t8m> nirik, +1
19:37:19 <mitr> mattdm: +1
19:37:20 <mattdm> +1 again in case that wasn't clear :)
19:37:40 <pjones> +1
19:38:04 * abadger1999 considers that +5
19:38:41 <notting> i'm fine with doing it outside of fesco
19:38:48 <abadger1999> #info infra team (nirik and abadger with a different hat) to take the question up with fedorabugs sponsors/members
19:38:59 <abadger1999> #toic 1158 post-Flock Fedora rings + target products draft proposal for Fedora board
19:39:04 <abadger1999> #topic 1158 post-Flock Fedora rings + target products draft proposal for Fedora board
19:39:09 * mattdm wakes up
19:39:20 <abadger1999> mattdm: What would you like us to do with this at this point?
19:39:27 <abadger1999> Just read and give you feedback?
19:39:30 <mattdm> give me feedback on the draft on the wiki
19:39:32 <mattdm> yes please
19:39:55 <abadger1999> Cool.  Anyone have feedback at present?
19:40:03 <nirik> link again?
19:40:10 <abadger1999> https://fedoraproject.org/wiki/Fedora.next/boardproposal
19:40:53 <mattdm> at this point it really is mostly the whiteboard conversation from hackfest at flock
19:41:02 <mattdm> with a little expansion
19:41:17 <abadger1999> mattdm: Do you have a particular place you'd like to receive feedback?  devel list, irc/private mail, fesco ticket?
19:41:30 <abadger1999> all of the above :-)
19:41:35 <mattdm> any of the above is okay
19:42:01 <abadger1999> #action Read https://fedoraproject.org/wiki/Fedora.next/boardproposal and give mattdm feedback anywhere
19:42:25 <abadger1999> #topic Next week's chair
19:42:28 <nirik> I like it ok in general, but I think we could flesh it out and make it more detailed perhaps? or is this meant to just be a 10,000' view for the board?
19:42:36 <abadger1999> #undo
19:42:36 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x27d32c50>
19:42:47 <nirik> thats fine, I can send comments in mail. ;)
19:42:48 <nirik> carry on
19:42:53 <mattdm> nirik open to discussion
19:43:10 <mattdm> I don't want to nail things down too hard, but I do want to make it non-vague
19:43:17 <mattdm> and there's definitely some vague points.
19:43:46 <abadger1999> #topic Next week's chair
19:43:47 <mattdm> I know the board discussed the generalities at the last meeting, and maybe I'll ask at the next one which areas they'd like to be more specific
19:43:51 <abadger1999> #undo
19:43:51 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x27d32210>
19:43:51 <nirik> sure.
19:43:57 * abadger1999 has rotten timing :-)
19:44:00 <mattdm> (sorry for continually making you undo)
19:44:14 <abadger1999> #topic Next week's chair
19:44:28 <abadger1999> Okay -- next week's vic^Wvolunteer?
19:44:31 <pjones> mattdm: were there conclusions, or just discussion?
19:44:38 <mattdm> pjones just discussion.
19:44:45 <mattdm> seemed generally favorable
19:45:56 <mattdm> so anyway I can chair next week -- I haven't volunteered yet :)
19:46:02 <abadger1999> yay!
19:46:09 <abadger1999> #info mattdm to chair next week
19:46:16 <abadger1999> #topic Open Floor
19:46:39 <abadger1999> #topic badges as fesco rewards
19:46:49 <abadger1999> nirik mentioned this earlier
19:47:00 <abadger1999> I actually requested a few badges that fall into this area earlier today.
19:47:03 <mattdm> +1 to badges
19:47:07 <nirik> I'm fine trying this out if there's specific tasks we want done.
19:47:09 <mattdm> just in general.
19:47:14 <pjones> we should *totally* get badges for being on fesco!  yeah!
19:47:19 <pjones> (I bet that's not what you mean ;)
19:47:21 <mattdm> lol
19:47:22 <t8m> :)
19:47:48 <abadger1999> fedora-badges requests 115, 116, and 117 -- with 117 being my favorite: https://fedorahosted.org/fedora-badges/ticket/117
19:48:14 <abadger1999> pjones: You can get a badge from chairing a meeting ;-)
19:49:11 <abadger1999> anyhow, if you can think of more, let's try out the concept and see how it goes.
19:49:21 <mattdm> yep. sounds good to me.
19:49:22 <abadger1999> #topic Open Floor
19:49:37 <abadger1999> Anyone else?
19:49:39 <mattdm> schedule for f21.
19:49:40 <nirik> I had one quick item... which I can just file for next week if peopel prefer...
19:49:49 <abadger1999> #topic Schedule for F21
19:49:51 <mattdm> i don't think we should hash that all out now....
19:49:57 <nirik> impossible to decide now.
19:50:13 <mattdm> but I'd like to ask QA, RelEng, etc., to put together "what we would do if we had N months to work on it"
19:50:30 <nirik> a lot of that is going to depend on how much fedora.next we want to implement.
19:50:45 <nirik> or is 21 too soon to land any of that?
19:50:50 <t8m> I need to leave now
19:50:54 <mattdm> I would definitely like to get started.
19:51:08 <mattdm> And so, yeah, let's talk about what extra time would get us for that.
19:51:16 <mattdm> (not talk about it now. too long already.)
19:51:23 <abadger1999> <nod>
19:51:23 <nirik> so, for example, rel-eng a lot of work would be related to retooling for fedora.next, but that depends on what we are producing and when, etc.
19:51:36 <mattdm> true.
19:51:52 <mattdm> but I think there's things that would be nice regardless...
19:51:58 <tflink> qa would be automation and testing tools
19:51:59 <mattdm> more automation of image production
19:52:04 <nirik> side note: release schedules should be part of the fedora.next thing... could we look at 9months? ;)
19:52:25 <mitr> mattdm: Then let's be explicit that we're not doing this for fedora.next?
19:52:48 <mitr> (I always assumed fedora.next to be fairly gradual, without needing a big bang for retooling.  But we'll see...)
19:52:49 <abadger1999> 9 month cycles and 19 month supported releases?  That might be interesting.
19:53:08 <mattdm> mitr Well, let's right now ask what people could benefit from without even considering any "big bang" changes
19:53:15 <mitr> mattdm: works for me
19:53:18 <nirik> we could easily divide this... for now say: given that f21 is the same as we have been doing, for what and how much time would you want if you could have more time.
19:53:22 <mattdm> and then when we consider those, ask about what morettime they will take.
19:53:23 <notting> abadger1999: i would think that changing the cycle for f21 does not imply a global change
19:53:29 <mattdm> +1 nirik
19:53:42 <abadger1999> notting: -- yeah ; replying to nirik's suggestion.
19:53:44 <nirik> abadger1999: I've often thought so, but not sure how to make it work.
19:53:54 <mattdm> yeah, longer schedule for f21 and longer cycle overall are separate concerns
19:54:00 <nirik> because at least sometimes you land at bad times.
19:54:04 <nirik> right.
19:55:04 <mattdm> so anyway, it sounds like no one has grand objections so I'm going to post a message to fedora devel
19:55:13 * nirik nods.
19:55:13 <mattdm> an info-gathering message.
19:55:48 <abadger1999> #action mattdm to kick off discussion about what various groups could accomplish in a single 9 month release cycle that they can't with 6 month cycles.
19:56:02 <abadger1999> #topic SCLs and FPC
19:56:15 <abadger1999> I brought this up with FPC last week.
19:57:03 <abadger1999> It was kinda controversial but I think there was some agreement that if fesco would like to see parallel stacks we could approve guidelines on how to do it.
19:57:06 <mattdm> awesome.
19:57:21 <mattdm> i know a proposal is being worked on to give to fpc
19:57:24 <abadger1999> So mattdm, that puts you o nthe hook to produce a strawman ;-)
19:57:27 * nirik still has concerns about SCL's, but if we can make them work sanely that would be great
19:57:37 <abadger1999> mattdm: Col -- feel free to rope me into that discussion.
19:57:44 <mattdm> abadger1999 I handed the strawman off to langdon and others
19:58:12 <mattdm> abadger1999 i will suggest they rope you in :)
19:58:17 <abadger1999> mattdm: <nod>  Feel free to have them include me (toshoio@fp.o) in any rounds of rewriting drafts.
19:58:23 <abadger1999> toshio
19:58:27 * abadger1999 can't type his own name
19:58:32 <mattdm> heh
19:58:50 <mattdm> also I did check and the current proposal does not include asking for any special bundling exceptions
19:58:59 <mattdm> any such exceptions would go through the normal procedure
19:59:27 <abadger1999> There was some concern that precedent is to make backwards compat packaging hard in Fedora... but it was pointed out that the major examples ofthat came from fesco.
19:59:31 <nirik> SCL's are just bundling? or you mean bundling a thing inside a SCL'ed thing?
19:59:58 <abadger1999> (ie: the python-2.4 for zope decision)
20:00:14 <notting> scls aren't necessarily bundles
20:00:23 <nirik> right, there's overlap there too... since one of the reasons for that was that the python maintainer didn't want bugs from the old python
20:00:28 <abadger1999> So if fesco is okay with backwards compat now, it's a direction shift that we can work with.
20:00:55 <nirik> ie, if you have a python variant SCL, will users report bugs against python package or against the SCL?
20:00:56 <abadger1999> where backwards compat == "more bigger"
20:01:01 <mattdm> yeah, i think it _is_ a direction shift.
20:01:06 <mattdm> nirik: against the scl.
20:01:17 <nirik> mattdm: ideally. but will they? ;)
20:01:30 <mattdm> or, more specifically, against the python package which is part of the scl.
20:01:32 <abadger1999> mattdm: that's where they should report it -- I think the previous arguments were that users won't be so clueful.
20:01:34 <mitr> abadger1999: The way I think of it, if there is an entire ecosystem built around the assumption of parallel installation, we can only fight/persuade them so far.
20:01:44 <mattdm> nirik eh, people misfile bugs all the time.
20:01:49 <mattdm> fact o' bugzilla.
20:02:07 <nirik> sure, but if there's 50 pythons in 49 SCL's that makes life a lot worse for the python package maintainer. ;)
20:02:10 * notting assigns mattdm to defaultcc on 'distribution'
20:02:18 <nirik> so, barrier to whats "supported" might help.
20:02:43 <mitr> abadger1999: Within "the OS infrastructure", we shouldn't have parallel stacks at the same time (like we are not particularly spending extra effort on making bluez[45] simultaneously, the default is to migrate)
20:03:04 <mattdm> notting badge for triaging misfiled bugs!
20:03:15 <notting> mattdm: error, depends on bugzilla.
20:03:16 <abadger1999> nirik: <nod>  that might be someting to consider.  although I would want to discuss with the scl drafters what would make acceptable barriers.
20:03:36 <mattdm> nirik yes, this proposal also includes curation of scls, not arbitrary explosion.
20:03:43 * nirik nods.
20:03:56 * mattdm does not actually know the details offhand of how that is intended to work
20:04:01 <nirik> "I need different version of python in my SCL" should have a very very clear why. ;)
20:04:22 <notting> SCLs *should*, in general, should be limited to stacks for third-parties to use, potentially across multiple fedora releases (imo)
20:04:32 <abadger1999> mitr: depends on the definition of OS infrastructure but sure.  (for instance, python should be parallel stackable even if we use it in fundamental ways within the distro)
20:04:39 <mitr> abadger1999: yes
20:04:46 <mattdm> notting +1. it's that multiple-fedora-release thing that I'm interested in addressing
20:05:14 * nirik nods.
20:05:50 <nirik> so, any actions here, or just a heads up and continue discussion?
20:05:53 <abadger1999> notting: hmm... so you don't wnat them to "solve" puppet, rails, ruby?
20:06:08 <notting> abadger1999: .........maaaaaaaybe?
20:06:12 <abadger1999> :-)
20:06:20 <abadger1999> Until next time!
20:06:21 <notting> it also might imply puppet being a third party
20:06:25 <abadger1999> <nod>
20:06:28 <notting> or the equivalent thereof
20:06:41 <mitr> abadger1999: They might solve this, not sure how much it's worth specifying this in detail; the other option is to wait for non-rpm rings
20:06:42 <mattdm> ruby on rails is a good example with v4 hitting f20.
20:07:14 <abadger1999> Okay, we're getting into our third hour so I'm going to cut this for now.
20:07:22 * mattdm yep
20:07:22 <abadger1999> #topic Open floor
20:07:30 <abadger1999> Any urgent business?
20:07:39 <abadger1999> If not I'll close in 60
20:07:45 <nirik> I had a quick one, it can wait for next time I guess since we are so long.
20:08:01 <abadger1999> nirik: what is it?
20:08:10 <abadger1999> I'm curious since you've mentioned it a couple times.
20:08:14 <nirik> addition to the package maintainer responsibilities page:
20:08:25 <nirik> "Try and solve bugs or issues for the release against which they were
20:08:25 <nirik> reported, or if that is impractical note to bug reporters why their bug
20:08:25 <nirik> cannot be fixed in that release"
20:09:01 <abadger1999> Let's take a quick vote.  If it doesn't have quorum today we'll discuss next week
20:09:04 <abadger1999> +1
20:09:46 <mattdm> does this include making a note when the reported bug is "upstreamed"?
20:09:59 <nirik> I don't think it will have much impact, and it's impossible to legislate 'being nice', but it seems fine to add to me.
20:10:04 <mattdm> +1 to just what you said as a start though
20:10:08 <mitr> +1 (with "why" possibly being "I don't have time to backport/test just for this")
20:10:14 <sgallagh> +1, certainly
20:10:15 <notting> +1
20:10:41 <sgallagh> (Unattended bugs are a pet peeve of mine)
20:10:43 <pjones> +1
20:11:08 <nirik> cool
20:11:21 <abadger1999> #info update to the maintainer responsiblity wording approved +6:0:0
20:11:34 <abadger1999> #endmeeting