fesco
LOGS
17:29:37 <nirik> #startmeeting FESCO (2013-08-14)
17:29:37 <zodbot> Meeting started Wed Aug 14 17:29:37 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:29:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:29:37 <nirik> #meetingname fesco
17:29:37 <nirik> #chair abadger1999 mattdm mitr mmaslano notting nirik pjones t8m sgallagh
17:29:37 <nirik> #topic init process
17:29:37 <zodbot> The meeting name has been set to 'fesco'
17:29:37 <zodbot> Current chairs: abadger1999 mattdm mitr mmaslano nirik notting pjones sgallagh t8m
17:29:59 <pjones> hello, world.
17:30:05 <sgallagh> Aloha
17:30:08 <mattdm> hello, pjones
17:30:13 <mattdm> also everyone else
17:30:24 <mmaslano> hi
17:30:25 <pjones> sgallagh: was I supposed to be wearing my aloha shirt today?
17:30:40 <mmaslano> t8m regrets, he can't make it today
17:30:43 <sgallagh> I'd prefer that to you *not* wearing it ;-)
17:31:16 <notting_> Hello
17:31:27 <mitr> Hello all
17:31:40 <nirik> abadger1999: you around?
17:31:48 <abadger1999> Ah.. yeah.
17:32:10 * abadger1999 stops reading about SCLs and pays attention to the meeting :-)
17:32:13 <nirik> cool. Lets go ahead and get started then...
17:32:25 <nirik> We have first up our sendmail/rsyslog tickets:
17:32:31 <nirik> #topic #1143 F20 System Wide Change: No Default Sendmail - https://fedoraproject.org/wiki/Changes/NoDefaultSendmail
17:32:31 <nirik> .fesco 1143
17:32:31 <nirik> https://fedorahosted.org/fesco/ticket/1143
17:32:32 <zodbot> nirik: #1143 (F20 System Wide Change: No Default Sendmail - https://fedoraproject.org/wiki/Changes/NoDefaultSendmail) – FESCo - https://fedorahosted.org/fesco/ticket/1143
17:32:38 <nirik> what do we want to do here?
17:32:47 <mmaslano> did you speak about it on FLock? ;-)
17:32:57 <sgallagh> mmaslano: It was a running joke at Flock -_-
17:33:27 <mmaslano> cool
17:33:28 <mitr> If we are splitting into products post-F20, I think it's reasonable to give spins the freedom for F20
17:33:45 * nirik is ok with that too.
17:33:58 <sgallagh> mitr: I can get behind that (especially since most of the spins plan on killing off sendmail)
17:33:58 <abadger1999> mitr: That combined with what notting said in ticket about the current status makes sense to me.
17:34:05 * pjones is too.  would also vote +1 again to just removing the damned thing
17:34:07 <mattdm> i'm okay with that too
17:34:08 <mmaslano> yeah, I don't care about it if we have really tiny minimal, core
17:34:27 * nirik would also vote to remove it, but unless anyone else changed votes...
17:34:35 <mattdm> I think that we do need some sort of story about alerting in the base design.
17:34:53 <sgallagh> nirik: Perhaps worth just re-voting to make sure? I forget who was against it originally
17:35:03 <mattdm> and i don't think that sendmail is that story, but...
17:35:22 <abadger1999> Would rather not vote again on removal but is +1 to letting hte spins do their own thing.
17:35:24 <mattdm> it was my understanding that mitr argues that it _should_ be in the fedora base design. is that correct?
17:35:38 <kalev> I'd note that if most spins are already removing sendmail, it might make sense to instead remove it from @core, and list it in comps for to the spins want to ship it
17:35:40 <abadger1999> Kinda defining what we meant as "this applies to the dvd install" for F20
17:35:47 <nirik> kalev: it is removed from core.
17:35:47 <mitr> mattdm: No.  If you were 0 based on that understanding, just be +1 and make everyone happy :)
17:35:51 <mattdm> kalev we *did* rmeove it from core
17:35:53 <nirik> it's only still in standard.
17:35:59 <kalev> sorry, I mixed up the names.
17:36:00 <mattdm> mitr: that is, in fact, the case.
17:36:00 <pjones> mattdm: since nobody gets alerted by it, it would be hard for it to be the alerting mechanism.
17:36:11 <mattdm> pjones a-yup.
17:36:12 <mitr> My argument was that 1) lacking a specific product/direction, we should be doing locally optimal decisions, and 2) removing sendmail for the space/time savings is not locally optima.
17:36:23 <mmaslano> I agree with mitr
17:36:34 <mmaslano> wouldn't make more sense to review all groups and cut them down?
17:36:56 <mattdm> what is "locally" in your argument?
17:36:59 <notting_> I would guess that even if we did put a MTA in an official base design it probably wouldn't end up being sendmail
17:37:06 <mattdm> local to spins? local to fedora? local teach install?
17:37:06 <mmaslano> mattdm: if you already did it, and you didn't like only those two, then fine
17:37:09 <nirik> proposal: revisit: remove sendmail from standard
17:37:10 <mattdm> +1 notting_
17:37:44 <abadger1999> -1
17:37:46 <mitr> mattdm: "local" as in "this decision alone, without giving significant weight to any particular spin/target use case"
17:38:08 <notting_> nirik: +1 (as before)
17:38:16 * nirik is +1 to his proposal as before
17:38:17 <sgallagh> nirik: +1 Kill it with fire, I'll provide the matches.
17:38:24 <nirik> thats +3, -1 so far
17:38:29 <mattdm> (wait, are we voting on "should we revote"?)
17:38:34 <abadger1999> heh
17:38:40 <mmaslano> yeah, what' the current proposal?
17:38:42 <Southern_Gentlem> 85% of installs sendmail gets disabled so why keep pushing it
17:38:44 <sgallagh> I assumed we were revoting on "Remove it"
17:38:45 <mitr> nirik: -1 (but would be automatically revisited / abolished by seetting up the products)
17:38:46 <nirik> mattdm: no, I am asking for a revote to see if anyone changed their minds.
17:38:55 <mmaslano> Southern_Gentlem: prove it ;-)
17:39:17 <nirik> thats +3, -2 so far
17:39:30 <nirik> mmaslano: proposal: revisit: remove sendmail from standard
17:39:33 <mattdm> my abstaining was totally based on the argument I heard that /usr/bin/sendmail (not necessarily sendmail the mta) should be part of the standard base we are offering to people
17:39:52 <abadger1999> <nod> -- I agree with that argument.
17:40:01 <mattdm> and I was abstaining pending giving people some time to actually draw up what that standard base is beyond "we know it when we try to remove things from it and people yell"
17:40:03 <pjones> notting_: and it's unclear how much good that can do without user configuration anyway, given that most people's port 25 outbound in many countries looks like: http://www.fpaste.org/32126/50382013/
17:40:05 <nirik> I'm fine if no one changed their minds, just wanted to know that.
17:40:32 * pjones is still +1
17:40:51 <nirik> thats +4, -2 so far
17:41:21 <nirik> who's not yet voted? :)
17:41:26 <sgallagh> abadger1999 and mattdm
17:41:36 <abadger1999> I voted -1 and was counted
17:41:46 <sgallagh> Oh, I missed that. Sorry
17:41:50 <abadger1999> mmaslano and mattdm
17:41:55 <mmaslano> I didn't vote, I'm 0 now
17:42:04 <nirik> ok, so no pass. ;)
17:42:07 <nirik> next proposal:
17:42:08 <abadger1999> Proposal: Let spins contain the package set they want.  Our previous proposal should be seen as applicable to the dvd and netinstall rather than spins.
17:42:10 <sgallagh> And once again it's up to mattdm
17:42:26 <sgallagh> nirik: Well, if mattdm moves to +1, it's a pass...
17:42:33 <mmaslano> mattdm: couldn't you rework all groups? :)
17:42:41 <nirik> sgallagh: sure. I just thought he was continuing to abstain. ;)
17:43:03 <mattdm> Well, since we are allowing removing from spins _anyway_, the argument of "meh, let's not change it until we have a base design document" isn't much weight
17:43:23 <pjones> also most people can't meaningfully run an mta without configuring it manually.
17:43:25 <mattdm> so I guess I'm +1 to "everyone's removing it anyway so let's just remove it from @standard"
17:43:25 <nirik> abadger1999: +1 (with the caveat that if they go too crazy we can revisit)
17:43:27 <abadger1999> mattdm: heh -- are you trying to get me to vote -1 to my own proposal ;-)
17:43:31 <pjones> which makes installing it manually not much of a hurdle.
17:43:34 * sgallagh gets grumpy when people abstain where an abstention is the same as a -1
17:43:36 <nirik> ok, so then it passed?
17:43:42 <pjones> it seems to have passed.
17:43:42 <mattdm> yes.
17:44:11 <mattdm> huzzah?
17:44:14 <pjones> huzzah.
17:44:18 <sgallagh> \o/
17:44:18 <nirik> #agreed revisited no default sendmail proposal and approved it this time: (+5, -2)
17:44:23 <nirik> next up...
17:44:26 <abadger1999> sgallagh: I thought in fesco abstentions didn't work that way -- only in FPC were abstentions equivalent to -1
17:44:33 <nirik> #topic #1144 F20 System Wide Change: No Default Syslog - https://fedoraproject.org/wiki/Changes/NoDefaultSyslog
17:44:33 <nirik> .fesco 1144
17:44:33 <nirik> https://fedorahosted.org/fesco/ticket/1144
17:44:34 <zodbot> nirik: #1144 (F20 System Wide Change: No Default Syslog - https://fedoraproject.org/wiki/Changes/NoDefaultSyslog) – FESCo - https://fedorahosted.org/fesco/ticket/1144
17:44:54 <mattdm> abadger1999 it was only the case because it was on the line and everyone knows one more +1 would push it over
17:45:04 <sgallagh> abadger1999: In this particular instance, abstaining (and thereby forcing no decision) is equivalent to voting against it.
17:45:14 <sgallagh> Since "no decision" is the opposing option
17:45:34 <pjones> moving on...
17:45:38 <wwoods> so if it's e.g. +4/-4, and the last person abstains, that's the same as voting -1, right?
17:45:48 <sgallagh> wwoods: Effectively, yes.
17:46:03 <abadger1999> wwoods: yes but +4/-3/ and two abstentions would pass
17:46:14 <nirik> right, so do we want to see if anyone changed their minds on this one too?
17:46:14 <mattdm> okay, so, for rsyslog... are we redoing the same vote?
17:46:21 <sgallagh> abadger1999: No, all votes from FESCo have to be +5 to pass
17:46:22 <nirik> abadger1999: ? I never saw it that way.
17:46:27 <sgallagh> Unless that changed when I wasn't looking.
17:46:30 <mattdm> I'm pretty sure I was +1/+1 for remove from @core/@standard on this one
17:46:37 <mattdm> which means that there was a different split
17:46:37 <pjones> abadger1999: no...
17:46:54 <sgallagh> I changed my view after playing with journalctl more, so I'm +1/+1 as well (which last I saw did *not* change the outcome)
17:47:21 <abadger1999> nirik: okee dokee -- that was what I saw historically but maybe I haven't been reading close votes for a long time.
17:47:37 <notting> i am +1 (as before)
17:47:49 <nirik> huh. I always saw it was majority of votes needed to pass something...
17:48:01 * pjones is +1
17:48:41 <pjones> abadger1999: I don't know if you're wrong or if we accidentally changed or if we intentionally changed before I was on fesco or what, but AFAIK it's always been you need 5 + votes to pass.
17:48:43 <abadger1999> +0 (same as last time)
17:48:48 <mattdm> so, before it was Current vote: +3 (mattdm, notting, pjones):-4 (mitr, mmaslano, t8m, sgallagh)
17:48:55 <mitr> +1/-1 to core/standard (like last time)
17:49:07 * abadger1999 notes that he was on the first elected fesco so his information could be.... dated.
17:49:10 <mattdm> this means that the point of order comes in pretty significantly with t8m not at this meeting
17:49:13 <notting> pjones: it's always been +5 in fesco afaik
17:49:38 <mitr> https://fedoraproject.org/wiki/Fedora_Engineering_Steering_Committee?rd=Development/SteeringCommittee#Agenda
17:49:42 * nirik is with mitr
17:49:43 <mitr> says 5 votes
17:49:59 <mmaslano> stil +1/-1
17:51:09 <nirik> so where are we then...
17:51:34 <mattdm> okay. the vote for remove from @standard changes from +3/-4/2 to +4/-3/3, I think
17:51:49 <pjones> Er.
17:51:53 <pjones> Both numbers shouldn't go up.
17:51:54 <mattdm> wait no +4/-2/3
17:52:05 <mattdm> (better?)
17:52:11 <nirik> in any case it doesn't pass.
17:52:15 <pjones> At least the total count is right now ;)
17:53:10 <nirik> so, next then would be if we care if spins remove it...
17:53:12 <sgallagh> So now on to proposing whether spins can override this?
17:53:40 <mitr> +1 to letting spins override
17:53:43 <mattdm> If the answer for that isn't the same as the answer for sendmail, I'd like to hear some good 'splaining
17:53:53 <nirik> Proposal: Let spins contain the package set they want. (within reason).  Our previous proposal should be seen as applicable to the dvd and netinstall rather than spins.
17:53:57 <abadger1999> +1
17:54:19 <mattdm> +1
17:54:20 <pjones> I'm +1 to letting spins override, but that's predictable because that'd be the outcome of +1 on the previous thing (just the override would be backwards.)
17:54:26 <sgallagh> +1 to letting spins override
17:54:26 <nirik> +1
17:54:59 <mmaslano> +1 to override by SIGs
17:55:15 <notting> i am +1, especially in the area of straight package removals
17:55:45 <nirik> #agreed Let spins contain the package set they want. (within reason).  Our previous proposal should be seen as applicable to the dvd and netinstall rather than spins. (+8,0,0)
17:55:58 <nirik> ok, on to new business
17:56:00 <nirik> #topic #1156 F20 System Wide Change: Ruby on Rails 4.0 - https://fedoraproject.org/wiki/Changes/Ruby_on_Rails_4.0
17:56:01 <nirik> .fesco 1156
17:56:01 <nirik> https://fedorahosted.org/fesco/ticket/1156
17:56:03 <zodbot> nirik: #1156 (F20 System Wide Change: Ruby on Rails 4.0 - https://fedoraproject.org/wiki/Changes/Ruby_on_Rails_4.0) – FESCo - https://fedorahosted.org/fesco/ticket/1156
17:56:35 <sgallagh> So this is going to be an interesting one.
17:56:36 <mmaslano> +1 I'm not even sure if it's needed to vote again
17:56:50 <sgallagh> mmaslano: "again"?
17:57:02 <nirik> well, it was a isolated change and we asked it be made system wide
17:57:02 <mmaslano> why? I was on CC, Josef wrote on Ruby SIG and many projects, no one complained about rails4, so...
17:57:22 <mmaslano> I read few go for it
17:57:26 <mattdm> so... I am +1 to this because "we bring you all the new stuff and break your software" is the traditional fedora way....
17:57:31 <nirik> +1 here.
17:57:32 <sgallagh> mmaslano: I was under the impression that it was not backwards-compatible and thus would be breaking a bunch of stuff.
17:57:37 <abadger1999> +1 on this.
17:57:52 <sgallagh> Is there a coherent plan on dealing with breakage?
17:57:58 <mitr> I'm not quite clear what the plan for openshift is... the page just lists a name and email.
17:58:09 <mattdm> is the plan SCLs?
17:58:14 * nirik sure hopes no
17:58:17 <mmaslano> no
17:58:23 <sgallagh> mattdm: Wishful thinking
17:58:34 <mattdm> no, serious question.
17:58:47 <pjones> mitr: obviously we should make that guy do it ;)
17:58:47 <nirik> depending on that I would be -1
17:58:48 <mitr> mattdm: That would violate temporal consistency
17:58:50 <mattdm> I don't think SCLs helps for the stuff packaged _in fedora_
17:58:57 <mmaslano> I guess we are sending these proposals, so people can complain, no one was complaining, so they are fine with update...
17:59:04 <mattdm> but does help the pain of people trying to use fedora to do stuff
17:59:30 <notting> i'd like to figure out how to do this better in the future (vis-a-vis scls, the rings proposal, etc.) in the meantime, i ca nbe +1 to this for now
17:59:45 <sgallagh> Is the switch ready to be flipped if we approved it today?
17:59:53 <nirik> mattdm: thats how I see it.
18:00:07 <sgallagh> I'm wary of approving a probably-disruptive change so late
18:00:23 <nirik> Here's this SCL hammer we made for you, it's nice and shiny and you can use it to go build your own house of SCLs. Have fun! :)
18:00:25 <sgallagh> I don't want to hear that it's not going to land until Alpha freeze too
18:00:26 <mattdm> sgallagh better now than next week
18:00:36 <mmaslano> I found reply from Troy, who is working in OpenShift: The change has got to come sometime, and since this is in rawhide it's better to get it done early than late. ... I'd much rather this came now so I/we can get it over with
18:00:42 <pjones> notting: yeah, I'm feeling pretty similar.  +1 for this now.
18:00:43 <sgallagh> mattdm: Yes, that's my point. If it's not even ready to land, I'm against it
18:01:18 <mitr> OK, +1
18:01:18 <abadger1999> We're at +6 atm
18:01:35 <nirik> ok, any other votes?
18:01:48 <sgallagh> Since no one answered my concerns, I'm going to vote -1 on principal
18:01:57 <mattdm> lol fair enough
18:02:11 <sgallagh> *principle
18:02:11 <mmaslano> sgallagh: you mean switch ready? :)
18:02:41 <sgallagh> mmaslano: I had two questions: 1) can the packages land immediately? 2) Do we know how much stuff will break?
18:02:42 <mitr> sgallagh: WRT rails itself, there's only 1 outstanding item on the page, and the Alpha deadline applies to everyone equally, doesn't it?
18:02:46 <mattdm> sgallagh do you want to modify the proposal to "approved if ready to land"?
18:03:14 <mitr> The contingency plan _is_ rather naive, though
18:03:21 <sgallagh> mitr: Yes, but if a platform-breaking change lands at Alpha, that's not enough time for the other packages to clean up
18:03:25 <mattdm> for #2, _very much stuff will break_.
18:03:32 <mmaslano> sgallagh: 1/ they are already in because noone complained about it, 2/ hard to say
18:03:53 <mitr> sgallagh: see "dependencies" in that page
18:03:55 <notting> mattdm: there's actually fairly little rails-using stuff *in fedora proper*
18:04:11 <pjones> external stuff will break, but...
18:04:21 <mattdm> "but who cares! It's fedora?"
18:04:23 <sgallagh> Ok, if we're already landed, I suggest we ask for an announcement about that being the case on the list and go for it. +1
18:04:36 <mmaslano> mattdm: how would you like to communicate such changes with not only cloud projects ?
18:04:43 <mmaslano> mattdm: I mean next time
18:04:53 <nirik> #agreed Change is approved (+7,0) Please announce that it's landed.
18:05:13 * sgallagh wants to give downstreams time to deal with it before Alpha
18:05:22 <mattdm> mmaslano next time i'd like to tell people that they could use openshift cartridges or scls or something else to provide a consistent stack across releases
18:05:28 <mitr> mattdm: With SCLs/rings, we would just leave the old stuff in as long as someone pretends to be interested in maintaining it.  Less visible pain, not sure about invisible pain.
18:05:37 <mmaslano> mattdm: that would be better yes.
18:05:50 <nirik> #topic Fedora future plans/proposals discussion
18:06:11 <mattdm> So....
18:06:14 <nirik> so mattdm wanted to discuss this a bit and see about sending something to the board if we were all ok with the general direction of things.
18:06:22 <mattdm> yeah.
18:06:40 <mattdm> i am working on a polished proposal to send to the board
18:06:43 * sgallagh notes that Slashdot already has a grossly-misleading story about this
18:06:47 <mattdm> but it feels like flock was like 5 minutes ago
18:06:51 <mattdm> yay slashdot!
18:06:54 <sgallagh> So we probably want to get out in front of this story quickly.
18:07:03 <mitr> My impression from Flock is that we have a general agreement
18:07:14 <nirik> I personally like the "inner" part of the rings idea in general... the outer parts need more discussion and planning, but would be ok asking the board if they are generally liking this direction or not.
18:07:16 <mattdm> +1 general agreement!
18:07:25 <mitr> My impression from post-Flock is that there's a _lot_ of implied details that we tend to differ on, that are only discovered when written down.
18:07:30 <mattdm> 1. In order to build what we need for the future of Fedora, FESCO endorses
18:07:32 <mattdm> the idea of moving from a one-policy-fits-all-software policy to a tiered
18:07:33 <nirik> mitr: +1
18:07:33 <mattdm> model as roughly laid out in http://mattdm.org/fedora/next, and
18:07:35 <mattdm> recommends this to the board as the technical underpinning of our
18:07:38 <mattdm> strategic direction.
18:07:53 <mitr> So, "yes, let's do this", but I'm not in favor of formally voting on something so close to a blank check
18:07:53 <mattdm> (that's a paste from an email i sent to fedora-devel like an hour ago)
18:07:57 <sgallagh> mitr: That's a fair assessment
18:08:05 <abadger1999> inner part +1; outer part I have several ideas of what that would look like that I like a lot and several ideas of it that I hate horribly ;-)
18:08:08 <pjones> mitr: yeah, that's definitely true
18:08:19 <nirik> abadger1999: me too.
18:08:21 <sgallagh> mitr: Well, we're basically asking the Board "do we have a go-ahead to try to work this out?"
18:08:36 <pjones> sgallagh: right, and I think we need to phrase it that way
18:08:39 <sgallagh> Because if they Board smacks it down (I doubt it), I don't want to spend weeks coming up with a solution
18:08:44 <nirik> right.
18:08:51 <mitr> sgallagh: OK, that makes sense
18:09:16 <sgallagh> Further, as mentioned above, I think we want to get ahead of the story before it bites us.
18:10:15 <mitr> mattdm, sgallagh: ISTM that the 3 products are an essential component of what we need the Board to ack (because it changes the visible identity of Fedora, not just internal rules)
18:10:17 <nirik> so, should we vote on the '1' above from mattdm and ask him (or someone) to bring it to the board for general "ok, try and come up with a concrete detailed proposal"
18:10:34 <sgallagh> mitr: My point exactly.
18:10:37 <jreznik> what we need is some sort of plan, break things into steps (as I understood mattdm there's no plan to do everything in once) a start working on these steps + say the idea is to come to this in the end... so pepple can prepare, we will know how many resources will be needed and when
18:10:53 <abadger1999> How about something like: FESCo would like to move forward with exploring concrete ways of implementing the tiered model roughly laid out in  http://mattdm.org/fedora/next and would like the Board to let us know if they object to that general direction
18:10:59 <nirik> also to note where we need more resources for sure.
18:11:05 <mattdm> reading the slashdot highly-voted comments, I get: "just use arch; just use centos; how to spell my name; don't make a one-size-fits-all os; and, of course, fedora lts!"
18:11:14 <nirik> abadger1999: +1
18:11:22 <mattdm> abadger1999 +1
18:11:24 <mmaslano> abadger1999: +1
18:11:30 <sgallagh> abadger1999: +1
18:11:32 <notting> abadger1999: +1
18:11:34 <jreznik> abadger1999: yeah
18:11:37 <abadger1999> +1
18:11:49 <mattdm> yay!
18:11:58 <mitr> abadger1999: +1 to that part, but I'd really like the 3 products to be explicitly mentioned.
18:12:10 <nirik> #agreed FESCo would like to move forward with exploring concrete ways of implementing the tiered model roughly laid out in  http://mattdm.org/fedora/next and would like the Board to let us know if they object to that general direction (+7,0)
18:12:12 <sgallagh> mitr: mattdm lead with "1.". I assume there's more :)
18:12:21 <nirik> yeah, next item?
18:12:22 <mattdm> yeeesss.
18:12:28 <mattdm> 2. FESCO-created working group to draft Fedora Base Design as called for
18:12:29 <mattdm> in that proposal.
18:13:03 <mattdm> Does that need more explanation?
18:13:12 <mattdm> I've talked about this so much I forget what is obvious and what isn't :)
18:13:26 <nirik> I'm ok with that, as long as it's clear that what they write up will almost surely require tweaks and changes when it gets full input from everyone involved.
18:13:30 <sgallagh> mattdm: I assume you mean "create a group of people to formalize it"?
18:13:42 <mattdm> nirik Hence draft
18:13:43 <notting> create a group of people? like, cloning?
18:13:49 <mattdm> yes! cloning
18:14:04 <sgallagh> nirik: I agree, but we should also like to choose folks who are prone to sticking to their guns.
18:14:07 <mattdm> "Decide that a group will be created." Not sure we need that group created Right Now.
18:14:23 <nirik> also, it might be good once we populate this group to have them setup a FAD somewhere. I think this might be concrete enough for a FAD deliverable.
18:14:28 <sgallagh> Because once it goes to devel@, there's going to be a lot of dissent. We know we cannot please everyone
18:14:29 <abadger1999> Yep.  Drafting is good.
18:14:33 <mattdm> sgallagh Not people who waffle on whether to remove sendmail or rsyslog
18:14:36 <jreznik> nirik: FAD would be nice
18:14:43 <mattdm> +1 FAD
18:14:54 <sgallagh> Yes, definitely a FAD
18:15:02 <nirik> anyhow, when would we populate this group then?
18:15:12 * jreznik would like to at least help this group, even you say no to have me there :)
18:15:15 <abadger1999> sgallagh: eh.... there's also the fact that what consitutes the Base Design can change from release to release.... we don't have to get it perfect for the first Fedora release.
18:15:19 <sgallagh> nirik: Put it on the schedule for the meeting following Board approval?
18:15:24 <pjones> nirik: fwiw I'm +1 on the agreed abadger1999 proposal above.
18:15:28 <abadger1999> We just need to set expectations of what it means and should look like.
18:15:28 <sgallagh> abadger1999: Fair enough
18:15:30 <pjones> (sorry, got pulled away temporarily)
18:15:30 <nirik> wfm
18:15:39 <nirik> pjones: ok, sorry.
18:16:07 <mattdm> I'm up for asking for volunteers and picking some people. Is that too undemocratic?
18:16:30 <sgallagh> Perhaps treat it like the Board? Pick three appointees and four volunteers?
18:16:32 <mmaslano> no, I guess we have experts in some area ;-)
18:16:47 <abadger1999> mattdm: +1 to appointments from a pool of volunteers.
18:17:00 <nirik> mattdm: +1 from me...
18:17:01 <sgallagh> Yeah, abadger1999's plan makes more sense
18:17:13 <sgallagh> (or translation of your plan)
18:17:18 <jreznik> who's going to appoint from these volunteers? :D
18:17:27 <abadger1999> fesco.
18:17:29 <sgallagh> jreznik: FESCo
18:17:33 * nirik nods.
18:17:42 <sgallagh> "FESCO-created group"
18:17:46 <mitr> Wait, are we now discussing a proposal for the board or all the things that are contingent on that proposal?
18:17:55 <pjones> contingent really
18:18:10 <sgallagh> mitr: Yeah, we should probably get back to the proposal.
18:18:17 <nirik> mitr: contingent... if they say "no, the way we do things now is fine" we don't do this. ;)
18:18:19 <sgallagh> I was going to suggest jumping to the product message
18:18:29 <mitr> ... actulally - is 2. a proposal for the board or an unrelated item?
18:18:37 <mattdm> unrelated item
18:18:40 * mitr apologizes for being confused
18:18:41 <nirik> so, perhaps we defer 2 until the board comes back...
18:18:42 <mitr> never mind then
18:18:47 <nirik> and we can just do it / set it up then.
18:18:48 <pjones> nirik: yeah
18:19:03 <mitr> +1 to abadger1999's plan
18:19:06 * mattdm is eager to get started
18:19:11 <jreznik> or let Board appoint a few members, same for FESCo or other groups?
18:19:23 <pjones> jreznik: no, fesco appointed like fpc
18:19:33 <pjones> board shouldn't need to be involved in implementation details like that
18:19:34 <mattdm> +1 pjones
18:19:41 * nirik nods.
18:19:48 <jreznik> pjones: well, this group should set future Fedora vision
18:19:51 <nirik> so, the next few points are in the same boat IMHO.
18:19:59 <jreznik> and previously it was Board to set it and fail
18:20:01 <mattdm> So I also want to propose a working group for figuring out ring 2. but that's even more contingent.
18:20:17 <nirik> mattdm: right, I say we skip those and go to discssion at the end.
18:20:31 <mattdm> Well, can we put the SCL part in?
18:20:58 <nirik> mattdm: sure, that could be anytime, but not sure what FESCo has to do there.
18:21:16 <nirik> unless we want to override FPC
18:21:31 <mattdm> Would prefer at this point to work with FPC
18:21:39 <abadger1999> The SCL thing -- to get it into the current Fedora repo should just require going back to FPC and asking them to consider guidelines for doing it inside of Fedora.
18:21:41 * nirik would be -1 to any override
18:21:55 <nirik> (in this area/case)
18:22:00 <pjones> abadger1999: yeah, and that's a reasonable way of working with them I think
18:22:08 <abadger1999> I think I've changed my (FPC) mind about those and there's been turnover in other members.
18:22:30 <abadger1999> So FPC will have a lively debate about it if nothing else :-)
18:22:31 <mmaslano> abadger1999: really? I can show you my proposal later than
18:22:33 <mattdm> Okay. So if that's not a FESCO thing at this point, I'll just continue what I was doing, which was trying to talk to everyone nicely.
18:22:36 <nirik> additionally there's RHEL using them to look at for maintainability, etc.
18:22:37 <abadger1999> mmaslano: excellent
18:23:04 <mattdm> okay then. moving on to the fedora os product strategy discussion?
18:23:09 <sgallagh> please
18:24:28 <mattdm> I can post the notes from the whiteboard @ flock...
18:24:40 <mattdm> they may not make much sense without explaining but it gives a starting point?
18:24:46 <sgallagh> That's probably a good start. Pastebin?
18:25:02 * notting notes he has to leave in 5 minutes
18:25:10 <nirik> so, to clarify... this is something we want to add to our note to the board and see if they agree with this general direction?
18:25:24 <notting> oops, n/m. meeting got moved
18:25:26 <nirik> (well, once we see if we all mostly agree)
18:25:39 <mattdm> nirik: this is either part of that note or a separate note.
18:25:41 <mattdm> I. Summary Statement
18:25:43 <mattdm> - my presentation well-received
18:25:46 <mattdm> - technical details fesco
18:25:48 <mattdm> - practical implementation asks for some changes on direction of fedora which we feel require board approval
18:25:50 <mattdm> II. Target Products
18:25:52 <mattdm> A. Workstation
18:25:54 <mattdm> Target audience: Creatives, Developers, Sysadmins, and other IT professionals
18:25:56 <mattdm> Purpose: Keep Linux users on Fedora (This is a niche market; we recognize that. But let's make it our niche.)
18:25:58 <mattdm> B. Server
18:25:59 <mattdm> Target: People for whom RHEL and CentOS don't move fast enough, and people who want to see and influence the future of RHEL
18:26:02 <mattdm> Purpose: Build a better RHEL, and engage customers in development of RHEL, OpenStack, and other emerging technologies.
18:26:03 <mattdm> C. Cloud
18:26:06 <mattdm> Target: Development; DevOps in production; OpenShift
18:26:08 <mattdm> Purpose: We do not become entirely irrelevant.
18:26:10 <mattdm> III. Support Structures
18:26:11 <mattdm> A. Product working groups
18:26:14 <mattdm> B. Base design
18:26:15 <mattdm> C. Policy rings
18:26:18 <mattdm> (psh, fpaste. pasting into irc works just fine)
18:26:32 * sgallagh kicks mattdm
18:26:33 <mattdm> The product strategy here is *clearly* board material.
18:26:41 <nirik> so, could B and C be the same thing? or B is "larger"
18:26:51 <sgallagh> B is certainly larger
18:27:02 <mattdm> nirik: marketed differently. also, installer-focused vs. image focused.
18:27:07 <nirik> well, I could want to run any number of "server" things on my cloud instances.
18:27:08 <sgallagh> B is where our recommended infrastructure servers would likely live.
18:27:44 <mattdm> but _mostly_ they share a lot
18:27:54 <nirik> mattdm: ok, but note that arm might be more image centric and server...
18:27:56 <sgallagh> nirik: Sure, but those would be selected add-ons to the cloud image, where I (at least) kind of envision having something as a more comprehensive base at least
18:28:06 <mattdm> nirik good point
18:28:33 <abadger1999> The cloud target is: guests that run in the cloud?  whereas the servers to host the cloud would be included in (B)?
18:28:39 <pjones> That raises the question of if every arch has to provide every product
18:28:40 <mattdm> abadger1999 yes
18:28:41 <mitr> mattdm: I'll go ahead and say that I'm not thrilled about the "creatives" item.  I can see how it got there
18:28:43 <sgallagh> abadger1999: precisely
18:28:46 <abadger1999> <nod>
18:29:02 <nirik> alternate desktops would be their own products, right?
18:29:08 <mattdm> nirik yes.
18:29:10 <sgallagh> mitr: by "creatives" we basically mean coders (but leaving the door open)
18:29:36 <BCrookAtRA> mattdm: nice work on the presentation, and the idea in general.  I think it brings great clarity to the organization of Fedora
18:29:39 <notting> sgallagh: .... oh? i think that's different than what was represented in the room
18:29:41 <mattdm> And the proposal here is that Fedora as a project will focus on providing these products, but also on the toolkit to build them, and encourage that toolkit to build other things
18:29:42 <mitr> sgallagh: ok then
18:29:49 <mattdm> xfce spin
18:29:50 <sgallagh> nirik: This proposal also does not mandate (at this time) a specific desktop. Just a target audience that we will attempt to serve.
18:29:53 <pjones> sgallagh: pretty sure that's the "developers" types, and "creatives" is the utterly broken term for graphical design people.
18:30:06 <sgallagh> notting: Was it? Maybe I missed it
18:30:09 <nirik> right, and part of the working group design would be requirements for what things go into these products. ie, what requirements for desktop, etc.
18:30:29 <sgallagh> nirik: Yes
18:30:40 <notting> sgallagh: well, don't want to put emily in a box, but she certainly straddles the line between designer/coder/etc.
18:30:43 <nirik> or web server, or cloud server, or whatever.
18:30:43 <sgallagh> We also had something on the working groups on the board, but Matthew didn't paste it
18:31:03 <sgallagh> notting: Fair enough. I'm fine with handling the Inkscape/Gimp crowd there
18:31:33 <jreznik> nirik: and that's why I say Board should take part of this working group - at least the first part to say what products are, for the next step and technical decisions, it's not as much needed...
18:31:34 <sgallagh> nirik: We suggested that the working groups should be created per-target audience and chaired by a sitting member of FESCo
18:31:37 <mattdm> sgallagh matthew apparently didn't transcribe that part from his phone image on the plane
18:31:39 <nirik> these would just be products made by/tested by/fedora and someone could surely add on whatever stuff they want right?
18:31:55 <sgallagh> mattdm: That's fine. I just wanted to cover it
18:32:15 <mattdm> nirik Yes indeed.
18:32:21 <mattdm> nirik where you goin' with this? :)
18:32:26 <sgallagh> Absolutely
18:32:29 <nirik> jreznik: well, what goes into a product seems like a more technical decision to me... where 'should we even think of products' or 'what products do we ship/test/by default' would be more board...
18:32:43 <sgallagh> nirik: Yes, that's my view as well
18:33:04 <notting> nirik: well, given the ring2/env/stacks/etc. - there's a bit of a dicsussion to be had about where bits come from to make other things outside of these three, and therefore what they might be called. that may be a discussion for further down the line
18:33:11 <nirik> mattdm: not sure. ;) Someone could take the workstation product and decide they wanted to change up desktops or whatever and do so much like they would now
18:33:21 <nirik> notting: sure.
18:33:27 <mattdm> abadger1999 suggested that in the future the board could have a representative for each project (changing how board is structured slightly)
18:33:42 <sgallagh> nirik: Certainly. There's nothing stopping them from doing that, but it won't be our problem to test it :)
18:33:47 <nirik> sgallagh: right.
18:34:11 <mattdm> (we would still, i hope, make best effort to not break our favorite alternative desktops)
18:34:14 <sgallagh> One of the key points that we need to make clear: we want to reduce the number of things that need testing
18:34:22 <nirik> all the stuff that builds and is in the 3 products would be 'ring 2' ?
18:34:32 <notting> mattdm: only our favorite ones?
18:34:41 <sgallagh> nirik: Can you rephrase that question, please?
18:35:29 <nirik> sgallagh: does the set of items used to make products imply they are in a lower ring that things that don't make up the 3 above products? I guess this is just what notting was saying and we may have to look at it down the road.
18:35:33 <mitr> sgallagh: (reduce the number of things that "need" testing while actually increasing the number of things that have to be and are tested)
18:35:44 <mattdm> notting I was joking with that phrasing, but, realistically, yeah, we'll care more about the ones where people in the community are putting in sigificant effort. so for that wording of favorite.
18:36:03 <nirik> anyhow, I'm +1 to sending this direction to the board as well. If they don'
18:36:12 <mmaslano> nirik: I agree +1
18:36:13 <sgallagh> nirik: No, my stance is that the basic deliverables should *not* need to be self-hosting (provided that they are *reproducible* by the public Fedora build system)
18:36:18 <nirik> t like it, we can not waste time making it detailed proposal.
18:36:43 <mattdm> One part I want to make particularly clear here is that the vision for Fedora's products here may differ from the vision of any upstream projects we use to compose them.
18:36:56 <abadger1999> nirik: +1
18:37:40 <nirik> sgallagh: well, but we want to test the build chain too, or we can't make the deliverables... so to me that implies they are in a similar testing/policy or lower than the products.
18:37:45 <sgallagh> mattdm: And when that arises, the various working groups have authority to change from upstream to meet the needs of the target audience? +1
18:38:05 <mattdm> To take the big example: the Gnome project has a certain vision for their desktop environment, and while I respect that vision and wish them the best in targetting it, it is not necessarily the same vision as that needed to meet _our_ goals for Fedora Workstation
18:38:06 <abadger1999> mattdm: that works for me.
18:38:11 <nirik> so, thats +4 for sending this to the board for a broad ack
18:38:19 <mattdm> uh, +1?
18:38:22 <nirik> mattdm: +1
18:38:29 * sgallagh is +1, obviously
18:38:34 <nirik> sorry, did I miss your vote. ;)
18:38:43 <notting> nirik: i'm +1 to the general idea of the main proposals. still catching up, as behind on list mail
18:38:50 * pjones is +1 on that
18:39:20 <nirik> So, not clear I guess what we are voting on, let me make a proposal here:
18:39:20 <notting> mattdm: i think for something like that it would be good to have a much more defined goal/userbase than just the couple of lines above, so active designs can be made rather than anecdotal "i don't like this thing over here"
18:39:24 <mjg59> One thing I'm not hugely clear on here - would the expectation be that Workstation would be equivalent to the current Desktop in terms of visibility?
18:39:37 <mattdm> notting absolutely
18:39:43 <mattdm> mjg59 define visibility?
18:39:45 <mmaslano> mjg59: which desktop?
18:39:50 <mjg59> mattdm: The thing on the front page of the website
18:39:51 <mjg59> mmaslano: Desktop
18:39:56 <nirik> proposal: send to the board the idea of fedora producing 'products' and allow fesco to work on a detailed proposal around those and what might be in them, etc.
18:40:04 <JSchmitt_> &quit
18:40:12 <notting> nirik: +1 to that
18:40:19 <sgallagh> nirik: +1
18:40:20 * nirik is +1 to his own proposal.
18:40:25 <mattdm> mjg59 I think we will put all three things on the front page.
18:40:25 <pjones> mjg59: I think for this to work it needs to be the most prominent thing on the page, but all of these things need to be on there
18:40:28 <nirik> mjg59: yes, as I understand it.
18:40:31 <pjones> nirik: +1
18:40:41 <mattdm> I'm okay with having desktop on the top
18:40:51 <mitr> nirik: +1
18:40:51 * abadger1999 envisions that we'd see a page attempted to push people towards one of the three products depending on what they wanted to do with it.
18:40:51 <sgallagh> Proposed Addendum: mattdm will send his proposal draft to the FESCo list for tweaks before it goes to the board
18:40:52 <nirik> all three should be very visible.
18:41:06 <mjg59> Ok, so the natural thing is that the people defining Workstation would be the existing Desktop SIG?
18:41:17 <mattdm> right. right now, it's desktop is visibile, others are in the basement.
18:41:28 <mjg59> (And Server the Server Sig, and Cloud the Cloud Sig)
18:41:30 <Viking-Ice> why the desktop sig?
18:41:31 <mitr> mjg59: To the extent that the visions differ it's not quite obvious
18:41:37 <sgallagh> mjg59: Not exactly. They should be implementing a technical vision identified by FESCo and the Board.
18:41:37 <nirik> mjg59: I don't think so, since "sigs" don't really exist...
18:41:41 <pjones> Viking-Ice: benefactors in kind
18:41:46 <nirik> I would prefer a concrete listing of who is in them.
18:41:50 <mjg59> Well ok, that's why I'm asking
18:41:50 <pjones> but the broad answer is "not really"
18:42:01 <mmaslano> nirik: +1 to your proposal
18:42:24 <abadger1999> nirik: +1
18:42:25 <sgallagh> abadger1999: That's an implementation detail, but I'd like to see that too
18:42:30 <mjg59> There's a set of people who currently produce what you get by default from the website
18:42:41 <mattdm> nirik Cloud SIG -- we're a real thing.
18:42:47 <mjg59> If the proposal changes who that set of people is, I think it needs to justify that pretty strongly
18:42:49 <pjones> sgallagh: that's sort of a mixed bag.  we're setting a vision for layout and consumption, but they're still the ones defining e.g. desktop experience in a real way
18:42:56 <sgallagh> mjg59: Yes, but right now it's "Whatever upstream produced"
18:43:03 <nirik> #agreed send to the board the idea of fedora producing 'products' and allow fesco to work on a detailed proposal around those and what might be in them, etc. (+7,0)
18:43:11 <sgallagh> We're proposing that Fedora should have some leeway to adjust that where it's better for Fedora
18:43:16 <mjg59> sgallagh: No, it's just that there's significant overlap between upstream and them
18:43:19 <nirik> mattdm: perhaps I phrased that poorly... but it's not a concrete membership, voting, etc.
18:43:38 <jreznik> so idea is to give power to sigs but cut that power by saying what sigs has to do :)
18:43:45 <nirik> there are places where gnome the project and fedora desktop are different... browser choice for example
18:43:46 <mattdm> nirik I'm okay with asking for these sigs to become more formal -- progress to Team in the existing model
18:44:12 <sgallagh> mjg59: Ok, I think we're talking in circles here. My point is that if we and the Board define a target audience, and the existing Desktop SIG is *not* targeting that audience, we have leeway to course-correct
18:44:21 <sgallagh> Using the mechanism we see fit.
18:44:57 <notting> it's all about enshrining cross-department hostilities
18:44:59 <abadger1999> jreznik: heh.  I don't think the idea has SIGs involved... or perhaps better stated... not the current definition of SIGs.
18:45:07 <nirik> I think the groups that control the products should be formal enough to where someone can ask them something and get a concrete answer that is from that group, instead of someone in a sig said.
18:45:25 <sgallagh> (i.e. that mechanism might be as simple as carrying an extension or as grandiose as picking a different DE, but it needs to be in our power)
18:45:47 <mjg59> Ok. As a board member (but not speaking for the board), I think any real proposal is going to have to include examples of cases where things would be different, and how that's going to be managed within the context of existing Fedora contributors
18:46:08 <mattdm> mjg59 noted
18:46:17 <nirik> yeah, detailed proposal shoudl def enshrine that process and differences from current
18:46:18 <mjg59> But personally, I'm broadly enthusiastic
18:47:00 <nirik> ok, any further discussion or voting needed on this topic for now?
18:47:25 <sgallagh> I think we're good at least until the draft is produced.
18:47:47 * mattdm had thought he could relax after flock. aahahhhhahahhhhhh.
18:47:50 <jreznik> sgallagh: but you know, we rely on our upstreams... we are not canonical to fork old desktop and create exactly what they want... and I envy them sometimes for being able to do it
18:47:51 <nirik> well, until we need to populate the groups that will make the draft...
18:48:23 <mattdm> nirik I'm going to draft a basic proposal
18:48:28 <sgallagh> jreznik: I'd like to believe that there are sensible-enough individuals out there that they'll work *with* us.
18:48:30 <mitr> jreznik: that's not exactly set in stone, just a tradition
18:48:48 <nirik> we had another ticket come in this morning... https://fedorahosted.org/fesco/ticket/1157 do we want to do it this meeting? or defer to next? I'm not sure how many of you had time to look at it.
18:48:57 * sgallagh hasn't read it
18:49:04 <nirik> mattdm: great. ;) It's always good to have something to pick holes in. ;)
18:49:11 <pjones> jreznik: sgallagh: this is why above I said: "that's sort of a mixed bag.  we're setting a vision for layout and consumption, but they're still the ones defining e.g. desktop experience in a real way"
18:49:34 <Viking-Ice> jreznik, there is Gnome SIG forming which will allow it to be closer to upstream and desktop SIG or workstation SIG or whatever tailor it to Fedora
18:49:34 <pjones> we're really not going to be in a position to tell the desktop people "hey, switch the stuff you're working on to CDE", because they're not working on CDE.
18:50:10 <mattdm> nirik I could either defer on that or proxy my vote to you because I think this is kinda an infrastructure thing
18:50:26 <sgallagh> pjones: Right, but at the same time we have some limited ability to say "This is what we need from you. If you don't want to provide it, we'll look at alternatives"
18:50:29 <nirik> lets just defer. I don't think folks have had time to read it.
18:50:49 <mjg59> sgallagh: Can you define "we" in that situation?
18:50:54 <sgallagh> FESCo
18:50:59 <mattdm> and board
18:51:04 <sgallagh> and board, yes
18:51:07 <jreznik> Viking-Ice: good point, but someone has to step in (and same for server... we have better cloud because mattdm stepped into)
18:51:09 <pjones> It's pretty limited.
18:51:24 <pjones> Our truth-or-consequences knob isn't particularly easy to turn.
18:51:44 <sgallagh> jreznik: mmaslano has been trying to get her server SIG off the ground, and I'm willing to help there.
18:51:56 <mitr> pjones: Desktops are the one are where we actually have several 80%-viable options
18:52:01 <abadger1999> nirik: ticket 1157: I agree with mattdm that this seems mostly like an infra question.
18:52:30 <nirik> #topic next week's chair
18:52:34 <nirik> who wants it? ;)
18:52:35 <mmaslano> sgallagh: I wouldn't say me, but there are few members
18:52:50 <mmaslano> of server sig who can run it
18:52:53 <notting> i may be unavailable next week
18:52:59 <Viking-Ice> sgallagh, is that some thing other then the current Server SIG/sub-community ( I've not seen any proposals or nothing from her on that mailing list although I might have missed it )
18:53:03 <mmaslano> I won't attend next week
18:53:04 <abadger1999> nirik: I'll take the chair next week.
18:53:13 * abadger1999 adds it to his calendar
18:53:14 <sgallagh> Viking-Ice: It's still coming up to steam.
18:53:20 <nirik> thanks abadger1999
18:53:22 <abadger1999> Are we all done with features for now?
18:53:29 <nirik> #action abadger1999 to chair next week
18:53:32 <mattdm> proposal: naptime!
18:53:34 <nirik> jreznik: ^
18:53:40 <notting> mattdm: +12
18:53:44 <notting> or +1, even
18:53:59 <jreznik> abadger1999: there's Bluez 5
18:54:00 <kalev> if there's a few minutes of the meeting time left, I'd like to briefly touch the BlueZ 5 topic
18:54:01 <sgallagh> -1. Counter-proposal: cocktails
18:54:12 <abadger1999> jreznik: k.
18:54:20 <kalev> It affects a number of spins so I wanted to be sure FESCo is on board with this
18:54:22 <nirik> jreznik: is it ready? or next week?
18:54:28 <nirik> #topic Bluez5
18:54:33 <nirik> kalev: take it away
18:54:36 <sgallagh> kalev: That sounds like something that should go through the Changes process, then...
18:54:46 <mattdm> kalev: will this unbreak the thing where bluetooth is always on after my thinkpad boots or resumes from sleep?
18:55:09 <kalev> mattdm: uh, I have no idea
18:55:24 <kalev> hadess is really the resident bluetooth expert, I'm just filling in the shoes while he's on vacation
18:55:47 <kalev> anyway, this is going through the Changes process and jreznik announced it today
18:55:48 <jwb> mattdm, just blacklist the bluetooth driver.
18:56:13 <abadger1999> sgallagh: I believe it is a Change -- just filed late: http://fedoraproject.org/wiki/Changes/Bluez5
18:56:20 <kalev> however, we don't have so much time left and I think it would make sense to move forward with updating the packages
18:56:20 <sgallagh> Sorry, I see that now.
18:56:34 <kalev> my plan is to land bluez 5 today / tomorrow to leave more time to fix up issues / integrate
18:56:50 <kalev> and I'd like to emphazise that there's a contingency plan to revert back to bluez 4 if it turns out we can't make it propely work for Beta for all the release blocking desktop
18:57:10 <mitr> kalev: Has the code to update bluez users actually been written?
18:57:35 <kalev> mitr: what do you mean, update bluez users?
18:57:36 <mattdm> kalev Is the plan to switch back for beta if the alpha doesn't work?
18:57:54 <mattdm> because switching back after beta has been proven to be practically too late
18:58:05 <mitr> kalev: port applications from v4 to v5
18:58:53 <kalev> mitr: yep, most apps have been ported -- gnome-bluetooth, PulseAudio, NetworkManager (still pending some patch review, but the code is available), BlueDevil
18:59:11 <notting> so gnome is fairly ready, kde has a branch that can be used, mate has an experimental thing, and lxde and xfce are....?
18:59:21 <nirik> doomed. ;)
18:59:35 <nirik> we could use the same think mate does if that exists.
18:59:41 <sgallagh> nirik: So, par for the cource?
18:59:41 <kalev> I believe mate and lxde and xfce are somewhat in the same boat
18:59:45 <sgallagh> *course
18:59:59 <nirik> right. all the systray using desktops
19:00:05 <notting> nirik: were you using blueman before?
19:00:13 <nirik> yeah
19:00:14 <kalev> the important thing to have, I believe, is to have a working panel applet, which can be used by all of these three
19:00:40 <kalev> regarding blueman, its owner seemed to want to retire it anyway
19:00:55 <mattdm> kalev When is the planned go/no-go and contingency activation plan, and how much un-porting will that require?
19:01:23 <nirik> if there's not a pannel applet I would be ok with just saying those desktops get no bluetooth support... rather than trying to hold everything else back
19:01:24 <kalev> mattdm: I believe the contingency plan requires maybe 3 days. I was planning on activating it right before the Beta freeze, is that too late?
19:02:06 <kalev> nirik: it shouldn't be hard to get a working panel applet by resurrecting the old panel that got removed from gnome-bluetooth
19:02:16 <mitr> If we had to revert, doing it right before the beta freeze would be appropriate I think
19:02:39 <mattdm> If you think your 3-day estimate is good, then, yeah, sounds fine.
19:02:42 <kalev> so maybe we could schedule it to discuss a week before the beta freeze, at a fesco meeting?
19:02:47 * mattdm is therefore +1 to the wholething.
19:02:49 <nirik> kalev: possibly. Also that will pull in any deps gnome-bluetooh has
19:02:59 <mitr> "So f21 is Ok as goal, but f20 is definitely to early for KDE!"
19:03:06 <mitr> Conversations seem to be still ongoing...
19:03:15 <kalev> mitr: I _just now_ talked to Kevin Kofler on #fedora-kde
19:03:44 <kalev> and he said it should be okay to try to package up the git snapshot; jreznik is also on the channel and saw the conversation, I believe
19:04:05 <mitr> I suppose I'm +1 if 1) we review this before beta, and 2) gnome and kde are required to be by that time
19:04:22 <mitr> 1 is a process matter, not really a requirement
19:04:38 <sgallagh> mitr: +1
19:04:42 <nirik> sure, +1
19:04:45 <mmaslano> +1
19:04:49 <abadger1999> nirik: if the other desktop teams agree I could be +1 as well... otherwise, I'd say that fixing them should be a requirement.... If the feature came in before the deaadline I think I'd be the opposite.
19:05:00 <pjones> mitr: sure.  +1
19:05:27 <nirik> abadger1999: ok, so you are -1 to the above proposal?
19:05:31 <mitr> abadger1999: Right, we _should_ get everything; I'm not willing to compromise on these two
19:05:36 <abadger1999> anyhow... I'd be some sort of contingent +1....
19:05:44 <abadger1999> So that bluez can land now.
19:05:51 <mitr> abadger1999: We do retain the right to activate the contingency before Beta in any case and for any reason :)
19:05:57 <abadger1999> mitr: <nod>
19:06:05 <abadger1999> mitr: yeah, that might be the wayto go.
19:06:50 <nirik> so, counter proposal?
19:07:17 <mitr> nirik: I think we are at +5 (with me voting for my proposal)
19:07:17 <jreznik> mitr: I'm definitely for Beta to fire up contingency plan
19:07:27 <mitr> jreznik: will you make sure this gets on the agenda, please?
19:07:29 <kalev> sounds like a good plan to me
19:07:34 <abadger1999> So -- approve bluez5 landing now -- if the other alternate desktop envs agree to not be blocking, they do not need to be fixed in order for the feature to stay in.  If they don't we'll need to see that they can get bluez5 support in time for F20 or evaluate whether to trigger the contingency plan.
19:07:51 <nirik> sure, +1 for abadger1999's proposal
19:08:14 * notting can be +1 to that
19:08:22 <abadger1999> +1
19:08:29 <pjones> It's only barely any different, so it's pretty easy to be +1 with.
19:08:37 <mmaslano> +1
19:08:44 <mitr> abadger1999: +1
19:08:46 <pjones> so sure, +1
19:08:49 <abadger1999> pjones: yeah -- that's pretty much what we all agreed on with just some things more explicit.
19:09:11 <nirik> #agreed approve bluez5 landing now -- if the other alternate desktop envs agree to not be blocking, they do not need to be fixed in order for the feature to stay in.  If they don't we'll need to see that they can get bluez5 support in time for F20 or evaluate whether to trigger the contingency plan. (+7,0)
19:09:18 <nirik> thanks kalev!
19:09:23 <Viking-Ice> I got one request for proven packager assistance in completing tracker bug 947037 which adds an missing requirements on crontabs to corresponding packages ( as stated by the guidelines ) and all these bugs there have patches submitted to them that does exactly that...
19:09:27 <nirik> #topic Open floor
19:09:33 <kalev> thanks!
19:10:07 <nirik> Viking-Ice: sure. We can note that here... or perhaps you could also send to devel-announce about it?
19:10:58 <nirik> #info proven packager assistance wanted for crontab cleanup, tracker bug: 947037 see Viking-Ice for more info
19:11:02 <Viking-Ice> nirik, the request for proven packagers? ( would have done this myself but you know my hands are tied in that regard  )
19:11:16 <Viking-Ice> thanks
19:11:31 <nirik> Viking-Ice: you can send the request... subscribe to devel-announce and send email to it and it can moderated through...
19:11:43 <nirik> any other items for open floor?
19:12:33 <nirik> If nothing else will close out in a minute.
19:13:33 <nirik> Thanks for coming everyone!
19:13:36 <nirik> #endmeeting