fesco
LOGS
18:00:00 <nirik> #startmeeting FESCO (2013-06-19)
18:00:00 <zodbot> Meeting started Wed Jun 19 18:00:00 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:00 <nirik> #meetingname fesco
18:00:00 <nirik> #chair abadger1999 jwb mitr mmaslano notting nirik pjones t8m sgallagh
18:00:00 <nirik> #topic init process
18:00:00 <zodbot> The meeting name has been set to 'fesco'
18:00:00 <zodbot> Current chairs: abadger1999 jwb mitr mmaslano nirik notting pjones sgallagh t8m
18:00:08 <nirik> who all is around for fesco meeting?
18:00:09 <mitr> Hello
18:00:29 <sgallagh> Greetings, programs
18:00:36 * notting is here
18:01:00 <jwb> hi
18:01:05 * handsome_pirate waves
18:01:59 <pjones> I'm sortof partly here.
18:02:22 * abadger1999 here
18:02:24 <nirik> ok. t8m voted in tickets and won't be able to attend.
18:02:42 <nirik> I think we have quorum, so lets go ahead and get started.
18:02:48 <nirik> #topic ticket #1123 Request owner change for dkms
18:02:49 <nirik> .fesco 1123
18:02:49 <nirik> https://fedorahosted.org/fesco/ticket/1123
18:02:50 <zodbot> nirik: #1123 (Request owner change for dkms) – FESCo - https://fedorahosted.org/fesco/ticket/1123
18:03:01 <nirik> so, I changed ownership here per our process.
18:03:14 <nirik> however, there's a number of other changes to the package the new maintainer would like to make.
18:03:39 <sgallagh> nirik: Given that he's now the package maintainer, is there a reason we should interfere here?
18:03:51 <mitr> I'm -1 to the sysv/systemd chage and rename - user-visible/script-breaking incompatible change
18:03:55 <sgallagh> ah, sorry. The start-by-default stuff
18:04:00 <nirik> yes, because they are things that fesco would have to approve.
18:04:05 <nirik> Switch from "dkms_autoinstaller" to "dkms" for all branches
18:04:05 <nirik> Switch to systemd already for f17 and f18
18:04:05 <nirik> Enable by default on el5, el6 through chkconfig
18:04:05 <nirik> Enable by default on f17 through systemd
18:04:05 <nirik> Ask for systemd preset inclusion for f18, f19 and rawhide
18:04:11 <notting> yeah, shouldn't change sysv -> systemd in a release
18:04:25 <nirik> well, the reason for that is that we can't know if the user had it enabled in sysv.
18:04:28 <notting> so could do it for f20, f19 (if really fast)
18:04:39 <nirik> if we also say they can start by default, that should be possible?
18:04:46 <sgallagh> Yeah, no sysv->systemd change in the release.
18:05:17 <mitr> For starting by default, does dkms actually require an exception to https://fedoraproject.org/wiki/Starting_services_by_default ?
18:05:21 <sgallagh> I'm okay with renaming for F19+, but not installed systems
18:05:30 <jwb> sgallagh, we're past change deadline
18:05:42 <jwb> sgallagh, which means a rename would show up as a 0-day update.  not very nice
18:05:54 <notting> ok then, f20.
18:05:59 <sgallagh> jwb: Well, unless it got a freeze exception, but yes.
18:06:11 <jwb> if it got a freeze exception, i would weep.
18:06:16 <sgallagh> (I'm not voting for a freeze exception)
18:06:19 <nirik> mitr: not sure. Does dkms need config? or does it just work?
18:06:39 * nirik hasn't used it in so long, no idea.
18:06:56 <mitr> nirik: I haven't looked either
18:08:11 <nirik> it sounds like no config...
18:08:46 <nirik> so, ask for more info? or should we vote on each part?
18:08:47 <abadger1999> When I had it installed many years ago, it just worked.
18:08:52 <nirik> or...
18:09:26 <mitr> Arguably the f<=18 situation is sort of moot - even if it violated the policy we might not want to prohibit it now
18:10:03 <nirik> proposal: if no exception needed on starting by default, allow name change/systemd in f20+ only, leave others alone?
18:10:11 <pjones> I think we've explicitly allowed it before.
18:10:16 <jwb> +1
18:10:25 <abadger1999> +1
18:10:27 <pjones> nirik: +1
18:10:36 <notting> +1
18:10:38 <nirik> I don't actually thing the systemd move would harm anything in existing releases aside from confusing people..
18:10:53 <mitr> +1
18:10:57 <sgallagh> +1
18:11:18 <nirik> #agreed if no exception needed on starting by default, allow name change/systemd in f20+ only, leave others alone. (+7,0,0)
18:11:35 <nirik> #topic ticket #1125 httpd-itk broken over release because httpd updated without dependencies caring and maintainer refuse
18:11:35 <nirik> fixing .fesco 1125
18:11:35 <nirik> https://fedorahosted.org/fesco/ticket/1125
18:11:37 <abadger1999> yeah -- if they turned it off but left the package installed, when they yum updated, it would suddenly be back on again.
18:11:48 <abadger1999> but htat's it
18:12:19 <nirik> that could be anoying for some I suppose.
18:12:46 <sgallagh> Proposal: Leave jorton alone to do his work in peace
18:12:47 * jkaluza is here in any need, but he's just comaintainer
18:13:30 <notting> sgallagh: i wouldn't phrase it like that, but i'm fine with waiting for the upstream release with the added API before doing anything with httpd
18:13:54 <jwb> notting, yes
18:13:59 <mitr> In _principle_ this kind of thing should be possible - "upstream first", not "upstream only"
18:14:00 <nirik> so if this is a fork, why does it need the main one to change anything?
18:14:11 <nirik> I guess it just builds a module for httpd?
18:14:15 <jkaluza> If I understand it right, httpd-itk was in current state for 16 months
18:14:16 <mitr> However I don't see a strong case for overriding upstream
18:14:18 * nirik meant to look more into this, but hasn't.
18:14:32 <sgallagh> nirik: It's not *exactly* a fork
18:14:46 <sgallagh> It used to carry a bundled copy of the older HTTPD 2.2 with these patches.
18:14:53 <notting> nirik: it's a MPM for apache. you used to have to build them by including the httpd source code. httpd 2.4 had changes to allow building them as modules, but (i assume) they're not complete enough to allow it to build/work
18:15:09 <sgallagh> The upstream accepted them into the mainline for 2.4, so they want to drop their bundle, but jorton doesn't want to pull the patches until they're in a stable release.
18:15:28 <jkaluza> ^ that's it
18:15:30 <nirik> ok, so cannot they continue to bundle for now?
18:15:34 <jwb> they can
18:15:59 <jkaluza> that's what I suggested in the fesco ticket
18:16:28 <jkaluza> bundle for now, build httpd-itk and once the upstream release version with the patches they need, they can build it as module
18:16:41 <nirik> seems reasonable to me.
18:16:44 <sgallagh> I agree with this plan fully
18:16:55 * pjones is going to be afk for a few, apologies.
18:17:10 <nirik> someone care to put forward a proposal?
18:17:12 <mitr> Well, it does mean having to manually mirror every httpd patch in the httpd-itk copy, which is pretty ugly
18:17:38 <jkaluza> mitr: it used to work like that with 2.2, right?
18:17:40 <sgallagh> mitr: But no worse than their traditional approach
18:17:42 <nirik> sure, it's non ideal...
18:17:48 <notting> proposal (from jkaluza): bundle code in httpd-itk for now, build httpd-itk and once the upstream httpd version is released with the patches they need, they can build it as module
18:17:54 <nirik> +1
18:18:00 <sgallagh> notting: +1
18:18:19 <mitr> notting: Can the migration be transparent for users?  It might mean waiting for F20
18:18:29 <mitr> +1 to the general idea
18:18:34 <notting> mitr: i don't know. jkaluza - ideas?
18:18:47 <jwb> i think the maintainer of httpd-itk can worry about that
18:18:53 <mitr> notting: Right now httpd-itk says "disable httpd service; enable httpd-itk".  But what jwb said.
18:19:03 <jwb> i don't think we need to force the httpd maintainers to worry about itk at all
18:19:37 <mitr> Well, in a "can't we all get along" sense, it would be nice if they did anyway :)
18:20:00 <jwb> we aren't here to make people get along.
18:20:07 <jwb> that's the CWG.
18:20:14 <jkaluza> mitr: what migration do you mean? from the proposed httpd-itk built with bundled httpd-2.4 to some future version build against system 2.4?
18:20:18 <nirik> I think it's more just a disagreement about carrying non upstreamed patches. I don't think anyone is being difficult to get along with.
18:20:56 <jwb> nirik, right.  and i don't think there are sufficient reasons why the itk maintainers can force the httpd maintainers to carry patches they don't want to
18:21:05 * nirik nods.
18:21:10 <mitr> jkaluza: Yes.  I agree with the general resolution ("let itk do the work this time"), just pointing out that the migration will not necessarily be user-invisible.
18:21:11 <jwb> it's a separate package currently, it can continue to be so
18:21:17 * notting is +1 to the proposal, if it wasn't obvious
18:21:28 <nirik> thats +4
18:21:30 <nirik> more votes?
18:21:34 <abadger1999> eh bundling probably needs an FPC exception which might not be grantd -- otoh, might be granted for a limited time frameframe... we've done that before.
18:21:41 <jwb> did i vote +!?
18:21:44 <jwb> er, +1?
18:21:46 <jwb> if not, +1
18:21:56 <jkaluza> mitr: if we accept the patches for httpd now and they will build httpd-itk against system httpd-2.4, then users will have to change their configuration anyway
18:22:02 <abadger1999> I'm for the general concept of *not* forcing the httpd maintainer on this though.
18:22:02 <nirik> abadger1999: is it on the tracker? it hopefully does seem like a limited time thing
18:22:22 <jkaluza> mitr: they at least have to unload default MPM in httpd configuration file and load httpd-itk MPM
18:22:56 <nirik> so, thats +5...
18:23:03 <nirik> any other votes before I close it out? ;)
18:23:15 <abadger1999> nirik: there hasn't been an FPC ticket that I can recall.
18:23:43 <abadger1999> but that's all I know so far :-)
18:23:51 <dan408> wasnt there one FPC ticket filed against leigh123linux?
18:23:51 <mitr> jkaluza: that's a change at time of switch to itk.  I'm talking about a possible change on itk upgrade from the non-bundled to bundled version.  Anyway, let's leave this to the httpd-itk maintainer.
18:24:38 <jkaluza> mitr: I'm not sure I follow now, there's no non-bundled httpd-itk version available in fedora right now.
18:25:11 <nirik> #agreed bundle code in httpd-itk for now, build httpd-itk and once the upstream httpd version is released with the patches they need, they can build it as module. (+5)
18:25:39 * nirik notes the review for this package seems very cursory. :(
18:25:48 <nirik> #topic ticket #1126 Need a procedure for tracking FESCo release blockers
18:25:48 <nirik> .fesco 1126
18:25:48 <nirik> https://fedorahosted.org/fesco/ticket/1126
18:25:49 <zodbot> nirik: #1126 (Need a procedure for tracking FESCo release blockers) – FESCo - https://fedorahosted.org/fesco/ticket/1126
18:26:42 * nirik is +1 to the proposal, seems fine.
18:26:57 <notting> yes, +1. the proposal sounds good.
18:27:00 <mitr> +1
18:27:07 <sgallagh> +1 worksforme
18:27:08 <abadger1999> +1
18:28:38 <nirik> #agreed proposal in ticket is approved (+5)
18:28:51 <nirik> #topic Next week's chair
18:28:54 <nirik> who wants it?
18:29:06 <abadger1999> I can do it.
18:29:11 <abadger1999> oh wait.
18:29:15 <nirik> thanks! oh?
18:29:19 <abadger1999> actually... I might not be around next week
18:29:25 * abadger1999 withdraws volunteering
18:29:29 <nirik> ok.
18:29:32 <nirik> anyone else?
18:29:39 <notting> sure, i'll do it
18:29:41 <sgallagh> I haven't had a turn in a whiel
18:29:46 <sgallagh> or notting is fine too
18:30:55 * nirik doesn't care. :) I guess notting was first?
18:31:01 <nirik> #info notting to chair next week
18:31:05 <nirik> #topic Open Floor
18:31:11 <nirik> any items for open floor?
18:31:25 <jwb> vote
18:31:38 <nirik> #info elections in progress. Please vote!
18:31:42 <sgallagh> -1 ;-)
18:31:45 <nirik> when is the new fesco first meeting?
18:32:00 <jwb> 26th?
18:33:01 <nirik> there's a week on the schedule to 'announce results'
18:33:15 <nirik> anyhow, everyone should try and attend next week and any new folks can also...
18:34:01 <nirik> any other open floor items?
18:34:32 <sgallagh> Yeah, someone needs to patch that hole in the floor. Someone could get hurt.
18:34:42 <sgallagh> (sorry)
18:34:58 <jwb> are all the current members going to flock?
18:35:15 <sgallagh> jwb: I know mmaslano wasn't going to make it
18:35:21 <sgallagh> (Having just been at Summit)
18:36:41 * nirik should be there.
18:37:02 <mitr> me as well
18:37:02 <sgallagh> I'll be there, for the record. You are forewarned.
18:37:09 <notting> i'll miss the first day, but should be there for the rest
18:37:19 <jwb> sgallagh, i hope so.  you're giving 1/2 the talks.
18:37:37 <sgallagh> Well, unless my daughter makes an early appearance.
18:37:52 <sgallagh> jwb: Crap, did it seriously work out that way?
18:37:56 <jwb> no
18:38:00 <jwb> but you have a lot.
18:38:17 <nirik> jwb: schedule is going to be announced later this week?
18:38:33 <sgallagh> Well, most of them are supposed to be discussions, not presentations. I would hope to be more a moderator than anything else
18:38:37 <jwb> i'm hoping so.  the committee seems to have all weighed in.
18:38:51 <jwb> waiting for final approval from everyone i guess
18:39:45 <nirik> excellent.
18:40:56 <nirik> ok, will close out the meeting in a min if nothing more.
18:41:58 <nirik> thanks for coming everyone!
18:42:01 <nirik> #endmeeting