infrastructure
LOGS
19:00:01 <nirik> #startmeeting Infrastructure (2013-02-28)
19:00:01 <zodbot> Meeting started Thu Feb 28 19:00:01 2013 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:01 <nirik> #meetingname infrastructure
19:00:01 <nirik> #topic welcome to all
19:00:01 <nirik> #chair smooge skvidal CodeBlock ricky nirik abadger1999 lmacken dgilmore mdomsch threebean
19:00:01 <zodbot> The meeting name has been set to 'infrastructure'
19:00:01 <zodbot> Current chairs: CodeBlock abadger1999 dgilmore lmacken mdomsch nirik ricky skvidal smooge threebean
19:00:05 * abadger1999 here
19:00:10 * puiterwijk around
19:00:18 * Adran is alive
19:00:19 * maayke is here
19:00:26 <smooge> is here
19:00:29 * relrod is here
19:00:31 <relrod> kind of
19:00:40 * mdomsch 
19:00:59 * pingou is here
19:01:19 * G is lurking
19:01:43 <abadger1999> G: Hey, welcome!
19:01:46 * skvidal is here
19:01:51 * rossdylan is here
19:01:52 * threebean is here
19:01:52 <nirik> hey G. Long time no see. ;)
19:02:03 <nirik> ok, lets go ahead and get started.
19:02:10 <nirik> #topic New folks introductions and Apprentice tasks.
19:02:23 <nirik> any new folks or apprentice questions or comments?
19:03:19 <nirik> ok then...
19:03:27 <nirik> do chime in anytime with questions or comments. ;)
19:03:33 <nirik> #topic Applications status / discussion
19:03:41 <nirik> Any application / development news?
19:03:47 <skvidal> coprs is back up and running
19:03:51 <pingou> \ó/
19:03:59 <pingou> pkgdb-cli got a couple of releases
19:04:00 <skvidal> it is building - but still generating some instance-creation errors
19:04:04 <skvidal> which I'm trying to resolve
19:04:06 <puiterwijk> yes, if I do not find any new bugs, I will be declaring FAS-OpenID production-ready in five days from now
19:04:10 <abadger1999> Yay!
19:04:10 <skvidal> as always help on copr devel is quite welcome
19:04:14 <pingou> puiterwijk: cool!
19:04:38 <threebean> skvidal: getting closer to coprs+fedmsg here.  phx2 is almost ready to receive.
19:04:41 <nirik> #info coprs is back up. One outstanding instance bug being worked.
19:04:48 <pingou> I worked on the api for the next generation pkgdb this week-end
19:04:48 <skvidal> threebean: great
19:04:50 <nirik> #info pkgdb-cli has had some new releases.
19:04:54 <nirik> puiterwijk: cool!
19:05:08 * cyberworm54 is here sorry
19:05:10 <abadger1999> fas update today.
19:05:13 <nirik> #info fas-openid is going to production in 5 days if no new stoppers found.
19:05:15 * SmootherFrOgZ is around
19:05:26 <pingou> pkgdb2-api got the "abadger1999 approved" stamp
19:05:28 <nirik> #info fas update planned for later today
19:05:43 <nirik> excellent
19:05:49 <abadger1999> I hope to get both a python-fedora nad a pkgdb update into stg sometime next week.
19:05:59 * abadger1999 crosses fingers that that isn't too ambitious :-)
19:06:22 * pingou is late on the jenkins stuff
19:06:36 <pingou> but jenkins has been running fine on the new cloud skvidal :)
19:06:54 <nirik> I've not noticed any issues with our apps from the rhel6.4 updates so far...
19:07:09 * mdomsch has more testing to do on MM1.4.  Due to work and spring break, I likely won't get back at it much before 3/18
19:07:11 <skvidal> pingou: we will need to talk about that htis week - as I need to trade out the images it is running under
19:07:17 <skvidal> pingou: err - next week - not this week
19:07:27 <pingou> skvidal: sure
19:07:42 <nirik> #info fedocal has finished review
19:07:53 <nirik> mdomsch: :( anything we can do to help out there?
19:07:58 <pingou> oh yeah, that too thanks to threebean
19:08:10 <threebean> :)
19:08:30 <nirik> so we should look at a stg one soon...
19:08:39 <pingou> yup that would be very nice
19:08:45 <nirik> also, we can add it to the list of things to fedmsg... or is it already?
19:08:55 <mdomsch> nirik: I have 3 items left to check:
19:08:58 <threebean> nope, not on the list.
19:09:14 <nirik> we should make sure it's fedmsg aware before it goes to prod.
19:09:25 <nirik> also, should fas-openid have some fedmsg love?
19:09:26 <mdomsch> a) any changes to the apache config files that I don't have in master
19:09:32 <pingou> but we should stg it before :)
19:09:35 <mdomsch> b) test the database migration once again
19:09:40 <threebean> pingou: cool :)
19:09:47 <mdomsch> 3) test the location= code in the mirrorlists.  That is brand new, straightforward, but never exercised
19:09:49 <puiterwijk> nirik: I can't see anything that we should do with fedmsg in fas-openid
19:09:52 <pingou> threebean: "we need to talk"
19:09:55 * mdomsch counts like click and clack
19:10:25 <threebean> "yes, we do"
19:10:33 * pingou scared of threebean
19:10:36 <mdomsch> all 3 can be done on app01.stg where it's installed now
19:10:37 <nirik> mdomsch: if you can send something to the list, we could try and find folks to work on those things...
19:10:38 <threebean> no!
19:10:38 <puiterwijk> threebean: you have any ideas for fedmsg in FAS-OpenID? I'd think not, because of the nature of the details
19:10:41 <mdomsch> k
19:11:16 <threebean> puiterwijk: yeah.. I had some "so and so logged in" message types in the very beginning, but we ended up throwing them out
19:11:25 <abadger1999> puiterwijk: yeah... I think we want to log to syslog but not fedmsg
19:11:37 <puiterwijk> abadger1999: it does log to syslog
19:11:41 * nirik is fine with that, just wanted to bring it up.
19:11:41 * threebean nods
19:12:02 <abadger1999> so that infra admins could review if there was some sort of security issue but not so that $random contributor can see who's logging in to where
19:12:15 <abadger1999> puiterwijk: Cool.
19:12:23 <puiterwijk> abadger1999: yep. it logs who logs in to which account, and which openid they claim, etc
19:12:25 <nirik> the only use case I can think of is:
19:12:51 <nirik> if we wanted to give a badge for using fas-openid X times... so we would need a message: user foo used fas-openid
19:13:28 <nirik> but we can always look at that down the road.
19:13:32 <nirik> there's much lower fruit
19:13:32 * threebean nods
19:13:38 * puiterwijk doesn't know if that's a good idea...
19:13:58 <puiterwijk> it might promote the use, but we do provide info that might be considered private
19:14:07 <puiterwijk> (not sure, just thinking out loud)
19:14:14 <nirik> sure, I would think it wouldn't say anything about what it was used for. but anyhow...
19:14:19 <nirik> any other application news?
19:14:37 <nirik> #topic Sysadmin status / discussion
19:14:43 <nirik> we did mass reboots last night...
19:14:50 <skvidal> and they mostly worked :)
19:14:51 <nirik> things went long sadly for a few reasons. ;(
19:14:59 <skvidal> *cough*log02*cough*
19:15:15 <nirik> I think the lv and guest renaming took a bit more time too.
19:15:19 <abadger1999> nirik, puiterwijk: If we did that badge, I'd store number of times X user logged into fas-openid in its db.  then emit that after a set point is met.
19:15:27 <skvidal> nirik: but is fantastic that it got done
19:15:35 <nirik> yes, I agree.
19:15:42 <puiterwijk> abadger1999: yeah, agreed on that. but I don't like to announce every signon
19:15:51 <nirik> anyhow, everything should mostly be upgraded to rhel 6.4, so do shout if you see any problems.
19:16:28 <puiterwijk> also, the lb repo has been added. if anyone finds a host that has haproxy, but doesn't have the rhel6-lb repo, also shout please
19:16:37 <nirik> upcoming I do hope to work on ansible promoting. :) If fires would stay out for a while.
19:16:39 <puiterwijk> (it should be on proxy0* and busmon0*)
19:16:43 * nirik nods.
19:17:29 <skvidal> nirik: question - have we had any progress on fas-clients PUSH?
19:17:39 <nirik> not sure. abadger1999 / SmootherFrOgZ ?
19:17:46 <abadger1999> SmootherFrOgZ: ^
19:18:01 * abadger1999 guesses SmootherFrOgZ has been working on the fas otp stuff, though.
19:18:15 <nirik> no worries.
19:18:25 <SmootherFrOgZ> skvidal: yeah, I'm working on it. Actually I thinking on rewriting fas-client
19:18:48 <skvidal> SmootherFrOgZ: ok
19:19:11 <SmootherFrOgZ> skvidal: you will be able to fas-client against specific group as well
19:19:18 <nirik> so that would push out via ansible? or fas would push it?
19:19:51 <skvidal> nirik: I was thinking it would generate what a host set needs
19:19:56 <skvidal> and shove it via ansible on change
19:20:01 <SmootherFrOgZ> yeah
19:20:02 <skvidal> that was the idea, I think
19:20:12 * nirik couldn't recal the details.
19:20:15 <nirik> sounds reasonable.
19:20:57 <nirik> ok, any other sysadmin news?
19:21:11 <nirik> #topic Private Cloud status update / discussion
19:21:25 <skvidal> moving persistent instances over to openstack
19:21:27 <skvidal> that's moving apace
19:21:31 <nirik> cool.
19:21:33 <skvidal> and we may have a fix for the resizing issue in qcow
19:21:40 <skvidal> I've not tested it yet - yesterday kinda went sideways
19:21:53 <skvidal> however, it looks promising
19:21:54 <nirik> yeah, hopefully that will work for us.
19:22:03 <skvidal> I'm working on cleaning up the playbooks for them
19:22:09 <nirik> it's a package that does resize in initramfs
19:22:23 <skvidal> and all the keys/access codes needed for openstack are on lockbox
19:22:34 <skvidal> that piece works now for transient and persistent instances
19:22:42 <skvidal> coprs is building there and generating instances as well
19:22:57 <nirik> excellent.
19:23:00 <skvidal> if/when the ec2 tagging api for openstack starts working/existing - we'll take that on
19:23:07 <skvidal> I talked to some folks about setting up a second cinder service
19:23:10 <skvidal> on another server
19:23:14 <skvidal> for having more persistent volume space
19:23:21 <skvidal> and the general answer is 'yes should work, not tried it'
19:23:24 <skvidal> which is quaint :)
19:23:30 <brundlfly> Hi, sorry that I am late but can I still introduce myself?
19:23:33 <nirik> we seem to get that a lot. ;)
19:23:42 <nirik> brundlfly: sure, welcome. ;) Chime right in.
19:23:59 <skvidal> but once I get things off of fed-cloud03 - I think bringing it up as a new compute node and cinder volume server would be a good test for us
19:24:14 <nirik> sounds good .
19:24:21 <brundlfly> My name is Daniel and I am currently a second year University student in
19:24:21 <brundlfly> a Computing and Information systems program. What I can offer is basic
19:24:22 <brundlfly> scripting in Bourne, Bash, and Python. I have more advanced skills in
19:24:22 <brundlfly> Java programming since this is the main language is used in my
19:24:22 <brundlfly> University program. I spend additional time with reading Linux related
19:24:22 <brundlfly> literature such as "The Linux Administration Handbook" and the "Linux
19:24:24 <brundlfly> Programming Interface". The latter inspired me learn the C language so I
19:24:28 <brundlfly> can apply the concepts I have learned and experiment with kernel system
19:24:30 <brundlfly> calls. I also work part time as Technical Support Representative in a
19:24:32 <brundlfly> Cable/Internet Company.
19:24:34 <brundlfly> My goal for the next 3 years is to become a Software Developer with good
19:24:36 <brundlfly> coding practice and a solid foundation in algorithmic computation and
19:24:38 <brundlfly> design patterns. I have a keen interest in the kernel structure and the
19:24:40 <brundlfly> lower level aspect of hard- and software communication. I want to
19:24:42 <brundlfly> contribute to the team that provided me with an operation system that
19:24:44 <brundlfly> gave me possibilities to be as creative as I wanted to be - and that is
19:24:46 <brundlfly> for free. I want to become a valuable member of this community and I
19:24:48 <brundlfly> want to be known for my commitment and skill. I will join the fedora
19:24:50 <brundlfly> meetings on a regular basis to get the big picture of what is going on
19:24:52 <brundlfly> right know. I cannot always attend the meeting since I work and
19:24:54 <brundlfly> day/night shift rotations, but I'll do my best.
19:25:06 * pingou has read this somewhere before :)
19:25:17 <threebean> brundlfly: cool, welcome.
19:25:23 <pingou> welcome brundlfly :)
19:25:29 <brundlfly> thanks you guys
19:25:31 * cyberworm54 waves
19:25:33 <nirik> brundlfly: just FYI, on irc folks typically use pastebins and provide a link. :)
19:25:36 <nirik> but welcome.
19:26:06 <nirik> and if you have questions do ask. ;)
19:26:15 <brundlfly> as soon as I know what a pastebin is I will stop pasting 30 lines into the chat :)
19:26:19 <abadger1999> brundlfly: Are you interested in working on sysadmin stuff or programming (mostly python) stuff?
19:26:23 <brundlfly> IRC is still somewhat new to me
19:26:43 <brundlfly> Both programming and sys admin are my focus
19:26:51 <nirik> http://paste.fedoraproject.org/ <- paste your content there, submit and then just paste the url it gives to the channel, then everyone can load it and see it. ;)
19:27:01 <skvidal> brundlfly: #fedora-apps is a great place - lots of programming tasks that interact with systems stuff
19:28:04 <nirik> brundlfly: cool. Do look at our apprentice program and see if thats something you might be interested in, if so, see me after meeting in #fedora-admin: http://fedoraproject.org/wiki/Infrastructure_Apprentice
19:28:06 <brundlfly> Right know I study the C language to get a better understanding of memory allocation, my plan was to move on to Python (Shouldn't be that hard to switch) since it it very popular in open source
19:28:24 <abadger1999> brundlfly: <nod>  You can talk to nirik/skvidal/smooge about straight sysadmin stuff in #fedora-admin and #fedora-noc  #fedora-apps and #fedora-admin for more of the apps/programming lmacken. pingou, threebean, puiterwijk, SmootherFrOgZ, and I are all available there.
19:28:25 * nirik nods. python is very popular around here.
19:28:50 <brundlfly> I would like to learn more about the apprentice program
19:29:27 <abadger1999> brundlfly: relrod is currently probably doing the most splitting of his time between sysadmin and apps side.
19:29:28 <nirik> excellent.
19:29:39 <nirik> shall we move on to upcoming items?
19:29:49 <nirik> #topic Upcoming Tasks/Items
19:29:50 <relrod> abadger1999: :)
19:30:01 <nirik> (get ready for info dump)
19:30:03 <nirik> #info 2013-02-28 end of 4th quarter
19:30:03 <nirik> #info 2013-03-01 nag fi-apprentices
19:30:03 <nirik> #info 2013-03-07 remove inactive apprentices.
19:30:03 <nirik> #info 2013-03-19 to 2013-03-26 - koji update
19:30:03 <nirik> #info 2013-03-29 - spring holiday.
19:30:04 <nirik> #info 2013-04-02 to 2013-04-16 ALPHA infrastructure freeze
19:30:05 <nirik> #info 2013-04-16 F19 alpha release
19:30:07 <nirik> #info 2013-05-07 to 2013-05-21 BETA infrastructure freeze
19:30:09 <nirik> #info 2013-05-21 F19 beta release
19:30:11 <nirik> #info 2013-05-31 end of 1st quarter
19:30:13 <nirik> #info 2013-06-11 to 2013-06-25 FINAL infrastructure freeze.
19:30:15 <nirik> #info 2013-06-25 F19 FINAL release
19:30:17 <nirik> is there anything folks would like to schedule or note?
19:30:26 <abadger1999> threebean, lmacken, and I are going to be at pycon us march 12 through the 21st.  network was pretty good last year but of course, we'll all be busy with lots of other stuff so you probably don't want to count to heavily on us for that week and a half
19:30:29 <puiterwijk> #info 2013-03-05 Maybe FAS-OpenID release
19:30:38 * nirik adds those things.
19:31:22 <nirik> anything else pending?
19:31:27 <nirik> well, that we can schedule... ;)
19:31:36 <pingou> fedocal? :)
19:31:38 <threebean> lots of unscheduled good stuff :)
19:31:47 <nirik> yeah, lots of irons in the fire. ;)
19:31:58 <nirik> pingou: I can make a stg anytime, unless you want to wait for ansible...
19:32:28 <pingou> nirik: well my puppett isn't great but if we team up let's go for it
19:32:37 <nirik> sure, it should be pretty simple...
19:32:40 <nirik> I would think
19:32:45 <puiterwijk> pingou: I can help with the puppet part
19:33:00 <puiterwijk> (I already did FAS-OpenID in puppet, which is also flask)
19:33:19 <nirik> cool.
19:33:21 <pingou> it is pretty simple, the rpm and 2 files basically (and generating the DB)
19:33:22 <nirik> we can get it done. ;)
19:33:38 <nirik> #topic Open Floor
19:33:51 <nirik> anyone have anything for open floor? general questions, comments?
19:34:12 <pingou> I found back what I wanted to talk about last week
19:34:15 <pingou> GSoC
19:34:32 <nirik> #topic GSoC
19:34:38 <pingou> Do we want? Do we have ideas? Do we have someone looking at this?
19:34:48 <nirik> There's often lots of ideas related to infrastructure put forth.
19:34:54 <nirik> but some of them are... not things we want. ;)
19:35:20 <nirik> I mentored last year, I think I would prefer to not this year... it was a fair bit of time.
19:35:29 <nirik> but if any others would like to, please do.
19:35:46 <nirik> https://fedoraproject.org/wiki/GSOC_2013
19:35:57 <pingou> last year with abadger1999 we teamed up
19:36:03 <pingou> so that's always an option
19:36:09 * abadger1999 would rather not mentor (at least full time) either.  I'll definitely help integrate anyone into infra/answer questions/ review pull requests.
19:36:10 <pingou> and it does reduces the load a bit
19:36:37 <abadger1999> yeah, teaming with pingou was good.
19:36:42 <nirik> we could discuss on list perhaps? and then find out who is interested?
19:36:49 <pingou> +1
19:37:29 <threebean> mizmo might be organizing for Fedora OPW candidates for this summer again too
19:37:30 <nirik> pingou: you want to send an email on that?
19:37:37 <threebean> I think the time slot coincides with GSOC
19:37:45 <pingou> nirik: sure I can do that
19:38:04 <nirik> threebean: ok, good to know. We shouldn't over subscribe ourselves.
19:38:08 * threebean nods
19:38:34 <skvidal> nirik: question for the future
19:38:44 <skvidal> nirik: daylight savings time is coming up soon
19:38:50 <skvidal> what time will this meeting be?
19:39:03 <nirik> good question.
19:39:13 <nirik> I don't personally care. We can move with the time change or not.
19:39:16 <puiterwijk> same time UTC?
19:39:34 <nirik> I'd think sticking to the same time utc would be least confusing
19:39:48 <pingou> I'd go for let's just keep it at the current time
19:39:58 <pingou> there will be one week of confusion, then it's back on track
19:40:21 <puiterwijk> pingou: but the confusion is only for those who change times soon
19:40:36 <pingou> puiterwijk: us :)
19:40:38 <nirik> the only problem with keeping it the same is that it may mess with people's lunch schedules.
19:40:39 * skvidal has no idea what time it is in the next couple of weeks
19:40:42 <nirik> but I'm flexable.
19:40:44 <puiterwijk> pingou: no, we were in December, weren't we?
19:40:48 <smooge> it is already on my lunch
19:41:04 * cyberworm54 missed lunch for the meeting :)
19:41:23 <pingou> puiterwijk: I must miss-knowledge there
19:41:35 <puiterwijk> pingou: I believe our times change in December and June, and US is coming up soon?
19:41:36 <pingou> err lack*
19:41:36 <nirik> so, sticking with same time might be good for folks. ;)
19:41:48 <pingou> puiterwijk: afaik in the US it is one week after us
19:42:02 <puiterwijk> pingou: oh? /me is checking now...
19:42:11 <skvidal> we're march 10th, I think
19:42:12 <nirik> pingou: how does fedocal handle things? ;)
19:42:13 * skvidal googles
19:42:22 <pingou> nirik: all times are stored in UTC
19:42:32 <skvidal> yah march 10th
19:42:43 <nirik> pingou: excellent.
19:42:44 <pingou> nirik: but I must say, I do wonder how that will go :)
19:42:45 <puiterwijk> pingou: you are correct... we change march 31th
19:42:54 <skvidal> for the US - except for AZ and indianna? and parts of NM? and hawaii?
19:43:00 <nirik> right.
19:43:02 * skvidal cannot even remotely recall the ass-brained exceptions
19:43:07 <nirik> not indiana anymore.
19:43:10 * cyberworm54 live in indianapolis...
19:43:15 <pingou> Dr jones
19:43:17 <nirik> just az and hawaii.
19:43:30 <nirik> anyhow.
19:43:35 * puiterwijk hates timezones, and also changing of timezones...
19:43:38 <skvidal> http://www.youtube.com/watch?v=84aWtseb2-4
19:43:40 <skvidal> there you go
19:43:42 <nirik> #topic Open Floor redux
19:43:45 <smooge> oooh a reason to move to hawaii
19:43:49 <skvidal> that explains it in copious details
19:43:52 <nirik> anything further for open floor?
19:43:53 <skvidal> smooge: couldn't you just move to AZ
19:43:58 <nirik> smooge: fudcon hawaii!
19:44:00 <pingou> skvidal: +1000!!
19:44:04 <skvidal> nirik: I'd like to recommend repealing daylight savings time
19:44:05 <smooge> the politics gives me a rash
19:44:05 <pingou> nirik: +1000²!
19:44:20 <skvidal> nirik: could we get that started here?
19:44:28 <nirik> sure, all in favor? :)
19:44:33 <skvidal> aye
19:44:35 <pingou> oeuf corse!
19:44:39 <cyberworm54> yes!
19:44:42 <G> Just a quick re-introduction from myself that I'm thinking of lurking around again :)
19:44:47 <nirik> #agreed daylight savings time is repealed.
19:44:49 <pingou> spot is in as well!
19:44:59 <pingou> nirik: I was voting for the FUDCon in Hawaii
19:45:04 <nirik> G: welcome back, go ahead.
19:45:19 <G> nirik: can we amend the proposal that timezones be repealed? :)
19:45:38 <nirik> when it's high noon there, it's high noon everywhere! :)
19:45:39 <smooge> G is the best guy ever
19:46:18 <smooge> actually G I think you would have been able to answer our problems with the bnfs(old bkoji) storage...
19:46:32 <G> So for those that don't remember me from back in '08/'09-ish my name is Nigel, I'm back out in New Zealand, main interests are in Adminish stuff (although I'm now working on development stuff)
19:46:42 <G> err development stuff = dayjob :)
19:46:46 * pingou remembers G
19:47:31 <G> smooge: hmmm bnfs sounds like a vaguely familiar hostname :)
19:47:35 <nirik> anyhow, welcome back G.
19:47:52 <skvidal> die bnfs, die
19:47:55 <skvidal> oh, sorry
19:47:57 <abadger1999> :-)
19:48:28 <nirik> speaking of bnfs01... it's copying along: 12T  8.0T  3.7T  69% /mnt/kojibackup
19:48:35 <skvidal> yay?
19:48:41 <nirik> yep. yay.
19:48:50 <nirik> ok, if nothing else will close out the meeting in a minute...
19:49:25 <nirik> thanks for coming everyone.
19:49:32 <nirik> #endmeeting