i18n
LOGS
06:03:48 <tagoh_> #startmeeting i18n
06:03:48 <zodbot> Meeting started Thu Dec  6 06:03:48 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:03:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:03:48 <tagoh_> #meetingname i18n
06:03:48 <zodbot> The meeting name has been set to 'i18n'
06:03:49 <tagoh_> #topic agenda and roll call
06:03:50 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2012-12-06
06:03:59 <tagoh_> okay, shall we have i18n meeting now
06:05:14 * tagoh_ added new topic from aalam
06:05:15 <__anish__> hi
06:05:23 <dueno> hi
06:05:29 <mfabian> hi
06:05:47 <fujiwarat> hi
06:06:20 <paragan> hi
06:06:37 <juhp> hi
06:07:20 <tagoh_> hi guys, okay, let's get started
06:07:27 <tagoh_> #topic Upcoming schedule
06:07:28 <tagoh_> #info 2012-12-11        Final Change Deadline
06:07:28 <tagoh_> #info 2013-01-08        Fedora 18 Final Release
06:07:56 <tagoh_> please note, as announced, final change deadline was moved by one week earlier.
06:07:59 <pravins> hi
06:08:09 <tagoh_> no changes in the release date, so far.
06:08:24 <tagoh_> just fyi
06:08:41 <tagoh_> #topic Outstanding topics
06:08:41 <tagoh_> #info #8: Hinting related issues for Liberation_Fonts_2 on Fedora 18 (pravins)
06:08:41 <tagoh_> #link https://fedorahosted.org/i18n/ticket/8
06:08:47 <tagoh_> pravins: how is it going on?
06:09:19 <pravins> tagoh_: not very well :)
06:09:43 <pravins> i think we need to wait for this feature for some more time
06:09:49 <tagoh_> personally it looks like better postpone this feature on f18
06:10:01 <juhp> pravins, yeah - that may be safest
06:11:03 <pravins> i need to learn something more about why Ascender changed bytecode of fonts
06:11:22 <mfabian> Is it possible to ask Ascender directly?
06:11:59 <pravins> mfabian: yeah, that is problem. No contact. But may be can ask thorugh Google who actually purchased Croscore from them recently
06:12:08 <pravins> but it will take time.
06:12:26 <pravins> nim-nim: mentioned on mailing list " hi-dpi screens hitting Apple customers
06:12:26 <pravins> nows, and Android tablet producers following suit, Liberation1-style
06:12:27 <pravins> hinting is going to be irrelevant in a few years."
06:12:49 <pravins> i think this might be reason
06:12:59 <paragan> pravins, i think we can move this feature to F19 and same time gather more feedback based on F18 GA
06:12:59 <mfabian> Yes, that’s what I think as well.
06:13:07 <paragan> but how are we going to revert the changes?
06:13:29 <pravins> paragan: yeah, me too thinking for same. What is best approach now
06:13:44 <mfabian> High resolution hardware makes this sharp rendering at a font size of only a few pixels irrelevant.
06:14:46 <pravins> yes, its no more 16*16 grid
06:15:09 <pravins> tagoh_: juhp what do you suggest for reverting?
06:16:01 <juhp> pravins, good point (HD) was also thinking about that
06:16:03 <pravins> we have liberation-fonts-1.07.2 release in upstream
06:16:04 <tagoh_> I'm not sure if it's worth shipping both version of packages because, given that we give different name to lib2, 1) we don't have substitution rule for lib2 2) little complicated to add it as separate config file, 3) and without it, I suspect users don't use it with changing configuration by themselves
06:16:54 <juhp> pravins, I think for f18 we should revert to 1.07.2 and bump Epoch and drop the Liberation2 feature
06:17:09 <tagoh_> so IMHO just shipping lib1 sounds good to me.
06:17:17 <juhp> pravins, yeah
06:17:31 <juhp> s/pravins, /
06:17:39 <pravins> tagoh_: hmm, sound good to me. For next time we can keep it in rawhide
06:17:42 <tagoh_> juhp: so yeah, using epoch would be realistic.
06:18:42 <juhp> pravins, I can help with that if you wish
06:19:06 <pravins> juhp: yeah, it will be helpful not done it yet
06:19:14 <juhp> ok
06:19:33 <tagoh_> okay, anything else?
06:20:12 <pravins> tagoh_: no. I am looking forward to come at this feature with better results next time.
06:20:18 <juhp> we probably need to update Fesco about the feature - are they already aware of it?
06:20:24 <tagoh_> #agreed postpone Liberation_Fonts_2 feature and revert to 1.07.2
06:21:13 <pravins> juhp: they are not.
06:21:32 <tagoh_> juhp: I think just removing tag on wiki and back to FeaturePageIncomplete would be enough
06:21:42 <juhp> okay maybe
06:21:58 <juhp> sure - if they have questions we can follow up
06:22:03 <tagoh_> but instead, we need to submit a request on bz to update rel-notes
06:22:14 <juhp> aha
06:22:21 <pravins> i am updating feature page
06:22:27 <juhp> thanks
06:22:34 <tagoh_> we have to drop lib2 related notes there
06:23:45 <tagoh_> pravins: can you file it?
06:24:03 <pravins> tagoh_: yes
06:24:18 <tagoh_> to Fedora Documentation, release-notes component
06:24:40 <tagoh_> okay, thanks
06:25:13 <tagoh_> #action pravins to submit a request to drop Liberation_Fonts_2 feature from release-notes
06:25:27 <tagoh_> okay, let's move on then.
06:25:42 <pravins> thanks tagoh_ mfabian juhp for your continuous feedback and support
06:25:48 <tagoh_> #topic New topics
06:25:49 <tagoh_> #info #9: Fedora 19 Feature planning (tagoh)
06:25:49 <tagoh_> #link https://fedorahosted.org/i18n/ticket/9
06:26:10 <tagoh_> well, as noted in the previous meeting, it may be a time to think about f19 features
06:26:55 <tagoh_> according to current draft schedule for f19, feature submission deadline is set to January 29, 2013.
06:27:51 <tagoh_> any plans so far?
06:28:38 <tagoh_> dueno: how about ibus-kkc?
06:28:46 <pravins> kkc?
06:29:10 <dingyichen> tagoh_, is ibus-kkc in the GNOME white list?
06:29:22 <tagoh_> pravins: yet another japanese engine he is developing
06:29:31 <tagoh_> dingyichen: dunno :)
06:29:39 <dueno> maybe I'll file a feature for it, whether or not it will be the default
06:30:08 <tagoh_> okay
06:30:09 <juhp> dingyichen, :)
06:30:30 <dueno> (with libanthy compat wrapper, perhaps)
06:30:33 <juhp> dueno, great :)
06:31:40 <tagoh_> dueno: also good to file a ticket first to keep it on track in the meeting too. I can ping you about feature page then :)
06:31:59 <dueno> sure
06:32:03 <tagoh_> any other plans for f19 features?
06:33:11 <tagoh_> well, we still have a time to think about it so I'll bring this topic up later if there isn't anything else so far.
06:33:19 <pravins> tagoh_: not any clear idea yet. But i would like to improve Lohit fonts hinting with ttfautohint
06:33:32 <tagoh_> pravins: aha
06:33:50 <pravins> presently we are using autohint for Lohit in fedoa
06:33:53 <pravins> Fedora
06:34:02 <tagoh_> indeed
06:34:14 <pravins> i am planning this in upstream project. i.e. ttfautohint lohit fonts .ttf
06:34:35 <tagoh_> okay
06:34:48 <mfabian> pravins: does using ttfautohint actually make a difference on systems which can use the runtime autohinting of freetype? Isn't this the same result in the end?
06:35:16 <pravins> mfabian: indeed, i think ttfautohint uses same program
06:35:18 <tagoh_> mfabian: may depends on the release cycle of freetype and ttfautohint.
06:35:43 <pravins> it might be not impact Lohit output on Fedora much, but will definitely help to project using Lohit as a web fonts.
06:35:54 <tagoh_> it should be same as long as one use freetype from git
06:36:32 <mfabian> pravins: yes, where freetype is not used for rendering, it should help.
06:36:40 <pravins> mfabian: again, we will test it with xmag ;)
06:37:07 <tagoh_> anything else?
06:37:35 <tagoh_> okay, move on then.
06:37:41 <tagoh_> #info #10: Fedora 18, KDE and Input (aalam)
06:37:41 <tagoh_> #link https://fedorahosted.org/i18n/ticket/10
06:38:32 <mfabian> I could not use  ibus in KDE on f18 either when I tested.
06:38:47 <tagoh_> right
06:39:51 <aalam> I found there are two issues:
06:40:29 <tagoh_> I'm not sure how many impact it gives users. at least the status icon on empathy works. maybe not enough to decide if it's ibus specific issue or not though
06:40:33 <aalam> 1. ibus icon is not working, no keyboard layout selection from ibus-setup
06:41:25 <aalam> not able to swtich layout with Ctrl+space (default Gnome installed and then installed KDE here)
06:41:42 <aalam> 2. if installed KDE default (from Live USB 18 Beta), then
06:42:10 <tagoh_> aalam: no IM on kde live is a known issue
06:42:12 <aalam> - no ibus,no im-chooser installed, even I did installation with Punjabi locale, locale set with Punjabi (other than English)
06:42:17 <aalam> ok
06:42:18 <juhp> I think we should try to propose as f18 locker anyway - if only to highlight the issue
06:42:20 <tagoh_> due to the disk space
06:42:25 <juhp> blocker even
06:42:39 <aalam> I try to install yum groupinstall Punjabi-support,
06:42:51 <juhp> aalam, there is just no IM in kde live
06:42:52 <aalam> then im-chooser not installed, which help to start ibus in kde
06:43:34 <juhp> also I couldn't add anthy or any IME using ibus-setup
06:43:53 <juhp> seems all items are disabled
06:43:53 <tagoh_> aalam: I think lang group should be gone in f18?
06:43:54 <aalam> juhp: ibus-setup keep layout disable, right?
06:43:57 <aalam> yes
06:44:00 <juhp> nod
06:44:19 <aalam> tagoh_: it installed various pkgs for Punjabi with lang support group
06:45:34 <aalam> installed from Development tree (not live iso), ibus is working as expected in KDE
06:45:45 <tagoh_> thought yum-langpacks takes care of lang group now? am I wrong?
06:46:29 <aalam> - working - ctrl+space, input
06:46:42 <aalam> - Not working - Icon click, ibus-setup layout list
06:47:05 <tagoh_> right. I see same issue on KDE installed from netinst
06:47:10 <juhp> so I was actually wondering if it is a gtk theme issue
06:47:48 <aalam> juhp: then pidgin (as tagoh_ told) should not work
06:48:03 <mfabian> tagoh_ mentioned empathy.
06:48:05 <tagoh_> aalam: pidgin doesn't use gtk3
06:48:13 <aalam> ok
06:48:26 <tagoh_> and xchat too.
06:48:32 <aalam> can try with gnote
06:48:40 <tagoh_> dunno if there are any gtk3 applets in fedora
06:50:15 <aalam> installed gnote, but it is not in kde system try
06:50:19 <tagoh_> aha. theme... just remember, when installing empathy, themes were also installed by deps. let me test again.
06:50:31 <juhp> yeah
06:50:45 <juhp> but doesn't seem to help immediately at least
06:51:42 <juhp> well I managed to add anthy but not sure if it is related
06:52:27 <tagoh_> did it help for the systray issue?
06:52:41 <juhp> hmm it is funny - the menu seems to popup the first time - but then after that it disappears immediately
06:52:58 <juhp> I think no
06:53:47 <tagoh_> juhp: I can see the menu 2 times :) indeed, it disappeared immediately though
06:53:54 <tagoh_> but anyway
06:54:40 <juhp> now the ibus icon is too big for me though
06:54:45 <juhp> can only see part of it
06:54:54 <juhp> all quite strange
06:55:11 <aalam> juhp: big icon is random issue for me, it was some time during in Fedora 17, but later it gone (don't know how)
06:55:15 <juhp> Ctrl+Space works though
06:55:22 <juhp> aalam, ah I see
06:56:31 <tagoh_> any other comments on this issue?
06:57:11 <aalam> tagoh_: should need to open bug for ibus (list is disabled)?
06:57:46 <juhp> aalam, can you try clicking on the ">" on the left side?
06:57:59 <tagoh_> list?
06:58:03 <juhp> yeah
06:58:12 <juhp> s/the/one of the/
06:58:33 <juhp> it worked for me now (after installing adwaita admittedly)
06:58:54 <tagoh_> aha
06:59:33 <tagoh_> aalam: can you file a bug for that then?
06:59:47 <fujiwarat> I think they are filed.
06:59:48 <aalam> ok
06:59:59 <tagoh_> fujiwarat: do you have bug#?
07:00:00 <aalam> ah
07:00:48 <fujiwarat> zodbot: bug 869584
07:00:57 <zodbot> fujiwarat: Bug 869584 ibus menu in kde panel does not work, disappears immediately - https://bugzilla.redhat.com/show_bug.cgi?id=869584
07:02:16 <aalam> fujiwarat: it is for icon, right, not ibus-setup list
07:02:17 <fujiwarat> zodbot: bug 867484
07:02:18 <aalam> ?
07:02:20 <zodbot> fujiwarat: Bug 867484 ibus icon unresponsive in kde - https://bugzilla.redhat.com/show_bug.cgi?id=867484
07:04:00 <tagoh_> fujiwarat: we are talking about two issues here. it's one of the issue. apparently it's not for the engine list? on ibus-setup
07:05:01 <mfabian> What is not on the engine list in ibus-setup?
07:05:07 <mfabian> Anthy?
07:05:20 <fujiwarat> zodbot: bug 821221
07:05:23 <zodbot> fujiwarat: Bug 821221 Unable to select input methods under KDE - https://bugzilla.redhat.com/show_bug.cgi?id=821221
07:05:24 <mfabian> I have it listed in ibus-setup in KDE.
07:06:53 <aalam> mfabian: ibus-setup showed all lauguage, but not able to select
07:07:01 <mfabian> I can select.
07:07:09 <fujiwarat> It's 821221
07:07:44 <tagoh_> okay
07:07:46 <tagoh_> thanks
07:08:06 <paragan> I think aalam is facing a problem that he can see all the engines in ibus-setup
07:08:11 <mfabian> Yes, it is this gui design thing, I clicked on the > without thinking about it.
07:08:12 <paragan> but he is not able to select them
07:08:19 <paragan> all are there but disabled
07:08:28 <paragan> he cannot click any of them
07:09:32 <tagoh_> juhp said it may be related to theme?
07:10:02 <juhp> let me try again in a new instance...
07:11:03 <aalam> not sure how to change theme for gnome application in KDE if only KDE installed (with specific gnome app)
07:12:07 <tagoh_> aalam: IIRC /etc/kde/env/gtk2_rc_files.sh is the trick.
07:12:28 <aalam> juhp: tagoh_ :it is theme issue
07:12:55 <juhp> aalam, ah ok
07:13:28 <tagoh_> should we propose it as a blocker?
07:13:48 <mfabian> Default theme for gtk apps in KDE seems to be oxygen-gtk and that seems to have that problem.
07:14:05 <aalam> I did with K (systemsetting->Application Appearence->GKT+ Appearance)
07:14:09 <aalam> mfabian: yes, it has problem
07:14:49 <juhp> clicking on any ">" works for me at at least
07:14:54 <mfabian> aalam: selecting adwaita there makes it work more like one is used to from gnome.
07:14:59 <juhp> but it is confusing that entries are shadowed out
07:15:10 <juhp> mfabian, even without it seems
07:15:19 <juhp> ah ok
07:15:19 <mfabian> But I didn't even notice the problem when I tested first because I immediately clicked on the >
07:15:33 <juhp> I see
07:15:57 <juhp> I think under gnome the ui here works more intuitively
07:16:18 <juhp> mfabian, yes
07:16:21 <mfabian> Mainly the graying out seems to cause the confusion.
07:16:25 <juhp> nod
07:16:29 <tagoh_> hm, it sounds like having more impact for gtk apps on kde.
07:17:03 <tagoh_> maybe good to propose it as a blocker?
07:17:44 <juhp> hmm yeah the popup always disappears
07:17:53 <juhp> tagoh_, I feel so too
07:17:58 <juhp> can't hurt
07:18:26 <juhp> "18. All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use"
07:19:08 <juhp> ^ as tagoh_ mentioned to me earlier today
07:19:27 <juhp> so who will propose it?
07:19:48 <tagoh_> juhp: for the systray issue right
07:19:50 <juhp> or I will :)
07:20:27 <tagoh_> juhp: please then :)
07:20:36 <juhp> not sure if the theme issue is a blocker?  though might be nice to install adwaita themes by default?  (personally i would recommend that)
07:20:38 <juhp> okay
07:21:40 <juhp> they are one of the few consistent standard themes we have available for both gtk2 and gtk3
07:22:03 <juhp> is someone filing a bug for the theme issue?
07:22:07 <tagoh_> juhp: if it's a common issue on gtk apps, hard to add deps of theme in all of packages. dunno if it's not a bug in the theme, then maybe good to add awaita theme in @kde-desktop in comps? dunno
07:22:26 <juhp> tagoh_, right that would be my suggestion
07:22:49 <juhp> I think various @*-desktop do that
07:22:55 <tagoh_> sounds like need to discuss about it with KDE SIG people
07:23:01 <juhp> sure
07:23:31 <juhp> I would file against some generic KDE component or KDE Live?
07:23:48 <tagoh_> juhp: I guess we can use the above bug for theme issue?
07:24:13 <tagoh_> .bug 821221
07:24:16 <zodbot> tagoh_: Bug 821221 Unable to select input methods under KDE - https://bugzilla.redhat.com/show_bug.cgi?id=821221
07:25:16 <tagoh_> juhp: is this live specific?
07:25:23 <aalam> tagoh_: it is for Fedora 17
07:25:44 <tagoh_> but still there in f18 too right
07:26:14 <aalam> need to clone then
07:26:21 <mfabian> it is in f18 and it is not live specific.
07:26:25 <tagoh_> wonder if we should have duplicate bugs for that.
07:27:01 <aalam> 18 is development and can be blocker (if need)
07:27:09 <juhp> I think I need to do a ja kde install...
07:28:19 <tagoh_> okay, anything else?
07:28:43 <juhp> tagoh_, ah thanks looks like that is the theme bug perhaps
07:28:57 <juhp> I don't it is live specific
07:28:57 <tagoh_> yep
07:29:00 <juhp> doubt
07:30:10 <tagoh_> #action juhp to propose the theme issue and the systray issue as blockers
07:30:29 <tagoh_> if not, let's move on.
07:30:44 <tagoh_> #topic Open Floor
07:30:55 <tagoh_> any other topics to discuss in the meeting?
07:32:18 <tagoh_> if not, let's stop the meeting here then.
07:32:53 <juhp> hmm I am not really sure the adwaita helps
07:33:11 <juhp> s/the/that/
07:33:45 <tagoh_> aha
07:35:09 <mfabian> Why not?
07:36:49 <juhp> mfabian, seems about same to me now but maybe i need to more
07:38:25 <juhp> test
07:38:25 <tagoh_> okay, better stop then. thanks everyone for the meeting
07:38:37 <tagoh_> #endmeeting