i18n
LOGS
06:01:33 <tagoh_> #startmeeting i18n
06:01:34 <zodbot> Meeting started Thu Nov 29 06:01:33 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:01:34 <tagoh_> #meetingname i18n
06:01:34 <zodbot> The meeting name has been set to 'i18n'
06:01:34 <tagoh_> #topic agenda and roll call
06:01:35 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2012-11-29
06:01:48 <tagoh_> okay, time to have i18n meeting now
06:02:26 <juhp> hi
06:02:28 <__anish__> hi
06:02:32 <epico> hi
06:02:43 <mfabian> hi
06:04:31 * tagoh_ looks at pravins
06:04:44 <pravins> tagoh_: hi
06:05:02 <paragan> hi
06:05:08 <tagoh_> hi guys, okay, let's get started then.
06:05:19 <tagoh_> #topic Upcoming schedule
06:05:19 <tagoh_> #info 2012-12-18        Final Change Deadline
06:05:20 <tagoh_> #info 2013-01-08        Fedora 18 Final Release
06:06:25 <fujiwarat> hi
06:06:38 <tagoh_> well, beta is out finally. it looks good to me so far though, we still need to test more.
06:07:46 <tagoh_> #topic Outstanding topics
06:07:46 <tagoh_> #info #8: Hinting related issues for Liberation_Fonts_2 on Fedora 18 (pravins)
06:07:47 <tagoh_> #link https://fedorahosted.org/i18n/ticket/8
06:07:56 <tagoh_> pravins: please go ahead
06:08:01 <pravins> tagoh_: for easy testing, i have created http://pravins.fedorapeople.org/liberation-fonts-ttf-1-07-2.tar.gz
06:08:27 <pravins> this will install liberation 1-07-2 fonts with family name appended with 1-07-2
06:09:28 <tagoh_> well, just to summarize: we need to have a decision to go or no-go with liberation fonts 2.
06:09:37 <tagoh_> for f18
06:10:51 <tagoh_> looking at the bug, it seems happens on firefox only right? at least as the user said.
06:11:05 <pravins> tagoh_: yes, mostly firefox affected
06:11:30 <pravins> i have added some more screenshot http://pravins.fedorapeople.org/liberation/comparison-liberationsans-1-and-2in-ftsstring.png
06:11:32 <tagoh_> is it our build? or SuSE's?
06:11:52 <mfabian> https://bugzilla.redhat.com/show_bug.cgi?id=881051#c3 is not firefox but kedit.
06:11:54 <pravins> .bug 881051
06:11:56 <zodbot> pravins: Bug 881051 hinting regression with liberation sans - https://bugzilla.redhat.com/show_bug.cgi?id=881051
06:12:04 <pravins> this is tested on f18 Beta
06:12:52 <pravins> mfabian: yes.
06:13:07 <pravins> i tried to reproduce issues raise by  Ilya in bugzilla
06:13:23 <pravins> only one is valid as per my testing
06:13:27 <pravins> and that is "Some thick letters in the right window fuse such as letters "ым" in the word "лицензированными"."
06:13:32 <juhp> pravins, that's the only screenshot?
06:13:52 <pravins> juhp: yes
06:14:03 * juhp was hoping to see a cascade too at least
06:14:07 <juhp> and for each family etc
06:14:09 <pravins> juhp: i have added one more .odt file http://pravins.fedorapeople.org/liberation/liberation-2-and-1-and-croscore-testing.odt
06:14:15 <pravins> juhp: hmm
06:14:16 <juhp> yeah I see
06:14:28 <juhp> as we talked about earlier I think
06:14:30 <mfabian> Ilya writes: “The broken hinting also makes the lower part of the "в" letter to appear smaller than the upper part (look at the word "шрифтов")”
06:14:33 <mfabian> I can also see that.
06:14:43 <pravins> this odt has text with fonts applied liberation 2 & 1 and also google croscore
06:15:09 <pravins> mfabian: i tried that in ftstring but not able to reproduce
06:16:17 <pravins> while more testing. One point is very clear that Liberation 2.0 hinting output is not compatible with Liberation 1.0
06:17:41 <tagoh_> pravins: no screenshots in ftstring say for that?
06:18:58 <juhp> not compatible?
06:19:07 <pravins> tagoh_: no, i can add
06:19:19 <pravins> juhp: yes, liberation 1.0 hinting output is sharp
06:19:33 <pravins> but liberation 2.0 is more bold and bit blurred compare to version 1.0
06:19:39 <juhp> ok - sure it is different
06:19:44 <juhp> hmm yeah
06:19:56 <pravins> and users are used to Liberation 1.0 hinting style
06:20:46 <juhp> right in retrospect we should have started this analysis/comparison before changing...
06:21:39 <pravins> the problem is subjectivity on hinting output, the one which i feel better
06:21:43 <pravins> other might not
06:21:46 <juhp> right
06:21:51 <mfabian> *some* users are used to the old style.
06:22:03 <mfabian> It is really subjective.
06:22:06 <juhp> definitely - others might not notice ;)
06:22:17 <pravins> yes
06:22:25 <juhp> it is certainly a considerable change
06:22:34 <pravins> but looks like SUSE are using Liberation fonts in firefox Menu items as well
06:22:42 <juhp> interesting
06:22:53 <juhp> so they default to Liberation on the desktop now?
06:23:49 <juhp> pravins, can 2.0 be further fixed for f18??
06:24:05 <pravins> juhp: it need more work
06:24:12 <juhp> okay
06:24:19 <pravins> we need to fix its hinting instruction and make output compatible with Liberation 1.0
06:24:42 <juhp> does it have to be the same?
06:24:44 <pravins> i am sure regarding one point that fork from Croscore was successful
06:24:56 <juhp> (well guess that is what some are saying)
06:25:13 <pravins> juhp: consider extensive uses of Liberation 1.0, i think we should keep backward compatibility
06:25:21 <juhp> right
06:25:39 <juhp> pravins, can you say more on success part?  you mean technically?
06:25:57 <pravins> Yes
06:26:13 <pravins> 1. Liberation 2.0 has more coverage than Liberation 1.0
06:26:19 <juhp> right
06:26:41 <pravins> 2. Output rendering is now more brighter compate to 1.0, which someone might prefer better
06:26:49 <pravins> s/compate/compare
06:26:53 <juhp> yes heavier
06:27:02 <pravins> i would like to make one point here
06:27:13 <pravins> last time i was talking with one font designer, for font for WEb
06:27:19 <juhp> I feel like we still need more input from the Fedora community before making a decision but that could also be for f19
06:27:47 <juhp> also more screenshots :)
06:27:50 <pravins> he said web fonts weight (thickness) should be bit more
06:27:56 <juhp> to make that decision :)
06:28:18 <juhp> pravins, okay - maybe that is why Google preferred the heavier style
06:28:39 <pravins> juhp: yeah, but it is not mentioned anywhere. just i related it littlebit
06:28:56 <pravins> and one more point to change my mind was. I tested Windows 8 and Mac
06:29:07 <pravins> there desktop, menu fonts are very sharp
06:29:25 <juhp> you tested Croscore on Windows 8 and Mac ?
06:29:32 <pravins> juhp: not
06:29:35 <pravins> but there UI fonts
06:29:56 <tagoh_> how does Liberation2 look like on other platforms say?
06:30:20 <pravins> tagoh_: not tested it :(
06:30:27 <pravins> i will
06:30:27 <juhp> any difference in reading now between Cros and Lib2?
06:30:33 <juhp> erm rendering!
06:30:34 <pravins> juhp: no
06:30:37 <juhp> ok
06:30:43 <pravins> if you open http://pravins.fedorapeople.org/liberation/liberation-2-and-1-and-croscore-testing.odt
06:30:58 <tagoh_> pravins: so similar issue should be there in croscore fonts too?
06:31:01 <pravins> on f18 Beta
06:31:07 <pravins> tagoh_: yes
06:31:51 <pravins> http://pravins.fedorapeople.org/liberation-fonts-ttf-1-07-2.tar.gz by installing this, we can have all fonts liberation2, croscore and liberation1 same time on system
06:33:52 <pravins> i think we should defer this feature consider wider liberation fonts use community and need for backward compatibility in hinting output.
06:34:14 <pravins> it means that we have to improve liberation 2.0 hinting output to match with liberation 1.0
06:34:31 <pravins> or add glyphs in liberation 1.0
06:35:48 <tagoh_> so you mean you are suggesting to revert the package or ship both?
06:36:38 <pravins> tagoh_: reverting looks good. Shipping both not required i think
06:37:47 <tagoh_> sure. then how to get feedback to liberation2? or plans to fix those issues.
06:37:57 <pravins> tagoh_: aha, valid point
06:38:12 <juhp> well guess upstream release will still be available at least
06:38:32 <pravins> yes, we should ship both then
06:38:41 <juhp> how?
06:38:44 <pravins> liberatoin 2.0 may be with name Liberation2
06:38:52 <pravins> bad name :(
06:39:09 <juhp> I wonder how Suse is doing it
06:39:46 <tagoh_> well, honestly I don't think that makes any difference in the situation. the users who are complaining to this may not use it at any rate.
06:40:32 <tagoh_> and the users who aren't complaining may not report anything as they are possibly comfortable with it
06:40:37 <pravins> https://bugzilla.novell.com/show_bug.cgi?id=788838#c26  they are shipping with the bad name i suggestion :)
06:40:57 <mfabian> I also guess it is only a small minority of users  complaining loudly.
06:41:58 <juhp> I see they have liberation2-fonts
06:42:47 <tagoh_> well, honestly I don't see any "rainbow" effect on the above kedit screenshot - I may be blind.
06:43:16 <pravins> yeah, even i do not agreed with rainbow effect
06:44:11 <mfabian> I see the rainbow effect in *both*, the old and the new.
06:44:41 <juhp> we could keep 2.0 in rawhide for now
06:44:46 <juhp> for testers
06:44:50 <tagoh_> it may depends on LCD?
06:44:53 <mfabian> Ilya writes: “* Due to subpixel smoothing this also creates an "rainbow" effect with colorful (reddish) play while the text in the text in the left window looks evenly black (in the both examples the subpixel smoothing is on).”
06:45:04 <mfabian> No  way this is evenly black in the left window.
06:46:20 <juhp> tagoh_, do you have any scripts or recipies for generating screenshot comparison, or anyone?
06:46:27 <tagoh_> anyway, it sounds like very subjective to me though.
06:46:30 <mfabian> You can see it easier if you magnify it, for example with “xmag”
06:46:46 <mfabian> tagoh_: Yes, I also think this is subjective.
06:46:48 <juhp> it might still be worth querying fedora devel/test lists for more opinions
06:47:04 <pravins> juhp: i remember tagoh_ tried some script for autohinting output testing
06:47:19 <juhp> or we just plough ahead with 2.0 ??
06:47:47 <juhp> pravins, problems are only at small sizes?
06:48:13 <pravins> juhp: output is bit thicker compate to 1.0
06:48:20 <tagoh_> pravins: yeah, it was to do taking a screenshot with a lot of fonts. it may depends on what we want to do here. not sure if it helps for just comparing two fonts.
06:48:21 <pravins> compare
06:48:27 <mfabian> For pointsize >= 18, there is very little difference.
06:48:32 <juhp> okay
06:48:58 <juhp> can some generate a cascade comparison for each family?
06:49:05 <juhp> someone
06:49:24 <tagoh_> waterfall rendering may helps for comparison and the amount of screenshots I suppose though
06:49:27 <mfabian> What is “cascade comparison”?
06:49:28 <pravins> mfabian: yes, above it difference is not notably
06:49:38 <juhp> yes waterfall
06:50:09 <juhp> mfabian, means descending over many sizes
06:50:18 <pravins> gnome-font-viewer gives it
06:50:28 <juhp> screenshot :)
06:50:47 <pravins> juhp:  i am adding it, 1 min
06:50:59 <epico> `pango-view --waterfall  -t test`?
06:51:12 <juhp> without enough information it is really hard for people to make any informed decision
06:51:25 <tagoh_> okay, well, spending a lot of time here.. apparently we don't have enough information to decide so far.
06:51:40 <tagoh_> maybe good to postpone the decision to the next meeting I guess
06:52:10 <juhp> sounds good - perhaps we may still consider reverting anyway if the new version is still too controversial
06:52:50 <juhp> for f18
06:53:05 <tagoh_> pravins: can you prepare more information for comparison, at least with things suggested above?
06:53:21 <pravins> http://pravins.fedorapeople.org/liberation/font-viewer-liberation-sans-2.png
06:53:26 <pravins> http://pravins.fedorapeople.org/liberation/font-viewer-liberationsans-1.png
06:53:32 <pravins> tagoh_: yes, i will do it today itself
06:53:58 <tagoh_> okay, then let's discuss it in the next meeting.
06:55:08 <tagoh_> #action pravins to prepare more information and screenshots to compare between liberation1 and liberation2
06:55:22 <tagoh_> #topic Open Floor
06:55:31 <tagoh_> well, just one topic from me
06:56:30 <dan408> okay one question, tagoh_ what's the plan for imsettings-mate? gunna drop it and go with imsettings-gnome?
06:57:03 <tagoh_> f19 schedule is in draft. current plan in draft for feature submission is set to Jan 29 next year.
06:57:34 * juhp feels this Liberation argument a little resembles Chinese users who prefer bitmap rendering at small sizes
06:58:02 <juhp> (which I personally find quite ugly but it is more readable I guess)
06:58:09 <tagoh_> dan408: no. I've pushed new version to updates-testing with gsettings support because MATE use different key and imsettings-gnome didn't work.
06:58:38 <tagoh_> dan408: no need to change anything in comps
06:59:46 <epico> juhp, yes
06:59:52 <tagoh_> dan408: as I filed a bug, mate-session-manager has a problem to run IM automatically. so need to do run imsettings-switch manually so far.
06:59:53 <dan408> tagoh_: thank you very much
07:00:06 <dan408> tagoh_: i saw that, trying to figure out what to do with it :)
07:00:09 <tagoh_> or do it with im-chooser
07:00:19 <dan408> we'll work together in the future. thanks!
07:00:23 <tagoh_> okay. thanks
07:00:29 <pravins> juhp: between two screenshot i have given above http://pravins.fedorapeople.org/liberation/font-viewer-liberation-sans-2.png  http://pravins.fedorapeople.org/liberation/font-viewer-liberationsans-1.png it shows clearly that liberation2.0 make bit bold
07:00:58 <pravins> just make it fullscreen and change images
07:01:02 <tagoh_> anyway, it's good time to think about f19 features.
07:01:12 <juhp> yes
07:01:20 <tagoh_> we I'll remind it here later anyway.
07:01:26 <pravins> tagoh_: might be that can be one of the topic for next meeting
07:02:18 <tagoh_> yep. just bringing it up today so that it looks like we don't have so much time to think about.
07:02:52 <pravins> i will send you mail later, with screenshots for testing
07:03:13 <tagoh_> anything else prior to close the meeting?
07:04:34 <tagoh_> pravins: ah, are you talking about the above screenshots? sure, yeah, I think so :)
07:04:41 <pravins> tagoh_: yes
07:05:00 <tagoh_> okay, stop here today then.
07:05:06 <tagoh_> thanks everyone for the meeting!
07:05:12 <tagoh_> #endmeeting