fesco
LOGS
17:00:01 <nirik> #startmeeting FESCO (2012-10-10)
17:00:01 <zodbot> Meeting started Wed Oct 10 17:00:01 2012 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:01 <nirik> #meetingname fesco
17:00:01 <zodbot> The meeting name has been set to 'fesco'
17:00:01 <nirik> #chair notting nirik mjg59 mmaslano t8m pjones mitr limburgher jwb
17:00:01 <zodbot> Current chairs: jwb limburgher mitr mjg59 mmaslano nirik notting pjones t8m
17:00:08 <nirik> #topic Init process
17:00:15 <jwb> here
17:00:18 <nirik> who all is around for a probibly short fesco meeting?
17:00:29 <mitr> Hello
17:00:30 * notting is here
17:00:33 <notting> i lke short
17:00:35 <jwb> i challenge us to be done in 15min or less
17:00:42 <nirik> :)
17:01:14 <mjg59> Hey
17:01:31 <nirik> thats quorum I think... so we can go ahead and dive in.
17:01:46 <nirik> #topic #946 Fedora 18 Beta freeze readiness: is major functionality in place?
17:01:47 <nirik> .fesco 946
17:01:47 <nirik> https://fedorahosted.org/fesco/ticket/946
17:01:50 <zodbot> nirik: #946 (Fedora 18 Beta freeze readiness: is major functionality in place?) – FESCo - https://fedorahosted.org/fesco/ticket/946
17:01:51 <nirik> we met on monday on this...
17:02:05 <nirik> do we have anything we would like to add now? or just wait and see how things look next monday?
17:02:54 <nirik> #info will watch progress and see how things look monday.
17:03:12 <nirik> #topic #932 F18 Features - progress at Feature Freeze
17:03:12 <nirik> .fesco 932
17:03:12 <nirik> https://fedorahosted.org/fesco/ticket/932
17:03:14 <zodbot> nirik: #932 (F18 Features - progress at Feature Freeze) – FESCo - https://fedorahosted.org/fesco/ticket/932
17:03:23 <nirik> so due to the week more slip... folks have another week on features. ;)
17:03:34 <nirik> do we see anything on the list that concerns us now?
17:03:42 <t8m> hi
17:03:45 <nirik> or shall we just wait on all of them until next meeting.
17:03:47 <nirik> hey t8m
17:04:02 <notting> well, if jreznik knows of any that definitely won't make next week, we could discuss them
17:04:12 <nirik> jreznik: you happen to be around?
17:04:59 * jreznik is around
17:05:14 <nirik> any features we should look at now? or shall we wait on all of them next meeting?
17:05:52 <t8m> what will we do with features that are not finished by next week?
17:05:54 <jreznik> the LLVM on PPC but it's not primary arch and I'm in touch with Feature owner
17:06:27 <jreznik> we never get any update for Usermode Migration... after gazillions of pings :( I'll try again
17:06:34 <mitr> It would be interesting to see at least a single sentence describing the missing piece instead of just a number... but that might be too much to ask
17:06:50 <nirik> "At the Beta Change Deadline new features must be code complete meaning that all the code required to enable to the new feature is finished."
17:06:53 <jreznik> then for sure New Installer UI and Secure Boot as two main features of F18
17:06:54 <nirik> "The level of code completeness is reflected as a percentage which is expected to be 100%. It does not mean the feature has been fully tested."
17:07:08 <mitr> t8m: ideally pull them out of release notes, or let feature owners reduce the scope (and update the relnotes) to get to 100%
17:07:16 <jreznik> mitr: that's what I ask everyone, at least to comment the status, issues etc
17:07:25 <mjg59> jreznik: Secure boot is code complete, we're waiting for the final legal go-ahead so we can upload the binary for beta
17:07:42 <jreznik> mjg59: ok, could you update the feature page to reflect that?
17:07:42 <notting> jreznik: usermode migration requires manpower to do the packaging. the infrastructure is there, the manpower did not magically materialize. *shock*
17:08:04 <mjg59> jreznik: Sure, I'll get that done
17:08:07 <jreznik> notting: I understand - but a single "we can't make it, we do not man power" is enough for me
17:08:38 <nirik> I think the 100% thing confuses people... they think it should mean in and tested and all functional (which in a more ideal world...)
17:08:56 <jreznik> otherwise I don't see any bigger troubles in the list
17:09:31 <nirik> for perhaps usermode migration should rescope to 'infra in place' now and have a part2 next cycle for the packaging work?
17:09:37 <jreznik> a lot of people promised updates within the week (some even insisted they want more testing to update to 100% as nirik pointed out ;-)
17:09:51 <jreznik> mjg59: thanks
17:10:08 <nirik> anyhow, if nothing is concerning, we can just revisit next week. ;)
17:10:16 <nirik> #info feature owners, please update your features!
17:10:28 <nirik> anything else on this topic? or shall we move on?
17:10:53 * jreznik will continue poking people to update status of features
17:10:54 <nirik> #topic #945 Policies for spin-based systemd presets
17:10:54 <nirik> .fesco 945
17:10:54 <nirik> https://fedorahosted.org/fesco/ticket/945
17:10:56 <zodbot> nirik: #945 (Policies for spin-based systemd presets) – FESCo - https://fedorahosted.org/fesco/ticket/945
17:11:01 <nirik> this came up on the list...
17:11:12 <nirik> #info there has been some discussion of this on the spins list.
17:11:29 <nirik> I was kind of waiting for the systemd folks to chime in some, but thats not happened.
17:12:25 <nirik> do we want to take any action here? or just try and come up with some plans on list?
17:12:50 <nirik> http://lists.fedoraproject.org/pipermail/spins/2012-October/002586.html is the spins thread.
17:13:13 * limburgher here finally, distracted
17:15:13 * nirik doesn't think we are going to come up with an answer here, but could be wrong. ;)
17:15:30 <limburgher> <nods>
17:15:32 <t8m> What I think is they should really develop the preset out of the rpm
17:16:08 <t8m> perhaps it could be hosted on fedorahosted and if they insist to ship it in a package to ship it as %doc
17:16:09 <nirik> issues are: a) should presets be rpm or non rpm packaged. b) what happens when you have multiple of them. c) what should they be numbered/named.
17:16:56 <t8m> for b) - systemd devs would have to answer
17:17:00 <mitr> I think c) is the only one that is a distribution-global issue
17:17:10 <nirik> b and c are closely tied. ;)
17:17:10 <mitr> b) - it is well-defined, but I can't say I care that much
17:17:21 <mitr> at least wrt mixing spin-specific presets
17:17:32 <nirik> If I make a 00-xfce preset it will override all the ones with numbers after it.
17:17:33 <mitr> In general, the priority numbers govern
17:17:41 <notting> right, if you were to install a openstack-node preset and a gnome-desktop preset , i'm not sure i care about the results you get
17:18:27 <nirik> you just want your desktop to be a compute node... whats wrong with that? ;)
17:19:11 <nirik> anyhow, shall we just ask for more ideas before doing anything more here?
17:19:16 * mattdm shows up sorry
17:19:41 <limburgher> The only problem is when there's a conflict.  The correct solution is obvious.  For many values of obvious.
17:19:42 <nirik> hey mattdm. We were just looking at the presets thing.
17:19:42 <t8m> nirik, yep we could ask for some proposal that we can then adjust
17:19:58 <limburgher> t8m, nirik: +1
17:20:14 <mattdm> for the cloud preset, should we just pick a number?
17:20:21 <mattdm> i'm okay with that. :)
17:20:42 <nirik> mattdm: we don't know. ;) But we should come up with more of a convention for sure.
17:20:48 <limburgher> It's The Cloud.  Shouldn't the number be *? :)
17:21:12 <mitr> mattdm: yes, it seems to me that the ticket boils down to picking a number.
17:21:49 <mattdm> the other question is "fedora-cloud-presets" or "cloud-presets"
17:21:55 <mitr> ... and ideally getting an ack from systemd developers to make sure that they don't have different plans, but I'm not sure we can block on that.
17:21:56 <notting> defining numbers for the big spins we know of, and guidelines for picking your own?
17:22:04 * nirik is pondering something like ranges...
17:22:13 <mitr> notting: why not the same number for all spins?
17:22:32 <nirik> desktops ordered in 60-80 range in reverse order they were added to fedora? ;)
17:22:47 <mattdm> mitr: and make the packages conflict?
17:22:49 <nirik> mitr: because that leaves which one wins to the name?
17:22:51 <notting> mitr: *shrug* that could work, obviously you don't want to install multiples as above, as that falls back to alphabetical
17:23:07 <mattdm> (i mean, not that giving them the same number would make them conflict, but that we _could_ make them conflict)
17:23:16 <nirik> conflicts are bad
17:23:58 <mitr> nirik: see b) above - will there ever be two at the same time?
17:24:02 <nirik> I'd think cloud preset would be a lower range... since you would want to do that on any cloud type client...
17:24:07 <mattdm> I can see wanting to make the cloud presets higher priority than the desktop presets
17:24:16 <mattdm> jinx
17:24:17 <nirik> mitr: there could be.
17:24:51 <mattdm> what if you have a multi-user system and want to mix kde and xfce?
17:25:01 <nirik> I'd like it so groupinstall of a desktop more closely matches a 'spin' install of a desktop... which would mean the preset should be packaged for that case.
17:25:19 <nirik> mattdm: there would need to be an ordering...
17:25:38 <nirik> all I can come up with is the order they were added to the collection...
17:26:01 <notting> nirik: the biggest issue you have the is the enablement of multiple dms
17:26:03 <nirik> gnome, then kde, then xfce, then lxde, then sugar, then mate, ?
17:26:22 <t8m> nirik, apparently some presets should be able to get packaged others probably not - I'd really like to avoid accidental installs of the preset that enables the openstack cloud init
17:26:25 <nirik> if we do that then it's: gdm, kdm, lightdm, lxdm, whatever sugar uses, mdm, etc
17:26:56 <nirik> t8m: good point. but if it's in a 'cloud' group and called 'cloud-presets' wouldn't that be enough?
17:27:32 <nirik> jwb: sorry, we didn't make 15min. ;)
17:27:46 <notting> nirik: it wouldn't even need to be in a group - just available to be pulled into the cloud spin kickstart
17:27:55 <jwb> nirik, such is life
17:27:56 <mattdm> on multiple dms: if we prioritize by order added to the collection, does that mean the newer dms win the conflict or are only fallbacks?
17:28:05 <nirik> notting: true...
17:28:38 <nirik> mattdm: newer looses to older. If you install gnome-desktop and xfce-desktop, you get gdm not lightdm.
17:28:44 <nirik> (at least under this idea... )
17:29:01 <t8m> nirik, but then we effectively change the policy of making some daemons and other things not enabled on package install
17:29:19 <t8m> nirik, you'll just install the daemon and the appropriate preset package and ...
17:29:29 <nirik> true
17:29:33 <mattdm> given that gnome is the default and that the others are "add ons", that might be the exact opposite of expected. (I took this thing and added it to the default, and the default overrode it...)
17:29:51 <t8m> mattdm, +1
17:30:04 <nirik> mattdm: not sure I think of Xfce as a gnome addon
17:30:28 <limburgher> nirik: No, it's an Emacs abstraction layer.
17:30:37 <nirik> I installed these two desktops and the default one's DM is running...
17:30:51 <mattdm> nirik: I didn't mean it that way; "add ons" to the default fedora desktop experience (which happens to be gnome)
17:31:12 <mattdm> although of course there _are_ things which are basically gnome addons or modifications (or subtractions)
17:31:25 <nirik> yeah, I guess I would think of that case as 'you get the default' if there's a conflict of things...
17:31:37 <nirik> but thats just a proposal.
17:31:51 <nirik> I guess I should write it up and get feedback on it.
17:32:04 <t8m> please do
17:32:43 <nirik> #action nirik to write up a proposal for people to pick apart.
17:32:46 <mattdm> I would like the cloud presets to override the desktops. So as long as there's room for that I'm happy.
17:32:49 <nirik> Anything else on this for now?
17:33:29 * nirik thinks that makes sense to him.
17:33:45 <nirik> you could very well have a cloud instance that you want to install a desktop on too.
17:34:32 <nirik> #topic Next week's chair
17:34:39 <nirik> Who wants the gavel next week?
17:34:53 <jwb> not sure i'll be present next week
17:35:33 <mjg59> I'm flying Tuesday night, so should be here but won't have a chance to do agendas or anything
17:35:59 <mitr> I can chair next week
17:36:38 <nirik> cool. Thanks mitr
17:36:45 <nirik> #info mitr to chair next week
17:36:49 <nirik> #topic Open Floor
17:36:52 <nirik> Anything for open floor?
17:37:13 <limburgher> Not here.
17:38:08 <nirik> Will close out in 1 min if nothing else.
17:38:21 <abadger1999> I had a ticket
17:38:29 <abadger1999> the libibetry task  one
17:38:32 <nirik> abadger1999: oh? did I miss it...
17:38:47 <abadger1999> https://fedorahosted.org/fesco/ticket/956
17:39:03 <nirik> ah, no meeting keyword. Sorry about that.
17:39:10 <abadger1999> I probably didn't specify meeting
17:39:14 <abadger1999> yeah, not a problem.
17:39:35 <nirik> so, really we are looking for folks to do this work, right?
17:40:02 <abadger1999> Yep.  It's a task that needs doing but currently no one to do it.
17:40:06 <limburgher> I can help with working on the bugs once filed.
17:40:49 <limburgher> Has the Ask ajax step been done?
17:41:11 <abadger1999> nope -- I've been busy this past week with infra tasks.
17:41:28 <abadger1999> I'll ping him after this meeting.
17:41:31 <limburgher> Ok.
17:41:50 <limburgher> Thanks, maybe make a tracker BZ for the BZs filed.
17:42:00 <nirik> sounds good.
17:42:05 <limburgher> How many do we think there will be?
17:42:14 <nirik> probibly 20-30?
17:42:18 <limburgher> k
17:42:30 <abadger1999> Would a good first step be -- I'll ping ajax and if he has some f13 results, I'll attach them.  If not, FESCo can put out a cattlecall for identifying the packages?
17:42:37 <nirik> Its times like these I wish we had an exploded tree of all packages to search thru
17:42:54 <abadger1999> yeah, it was 24 in F13
17:42:56 <t8m> nirik, +1
17:43:36 <t8m> nirik, ideally with a fulltext index over them
17:44:03 <nirik> yeah, I've toyed with the idea of some of the source code indexers... but they all seemed pretty dire
17:44:12 <nirik> anyhow, if nothing else will close out in a minute. ;)
17:44:29 <mitr> Things like that exist, I'm not sure whether they could be shared but we would need a permanent volunteer to maintain it in Fedora infrastructure as a first step
17:44:51 <nirik> yep.
17:45:11 <mitr> (I was particularly referring to http://hub.opensolaris.org/bin/view/Project+opengrok/ )
17:45:39 <nirik> yeah. nice pile of java/tomcat I think...
17:46:38 <nirik> anyhow. Thanks for coming everyone!
17:46:41 <nirik> #endmeeting