i18n
LOGS
06:01:44 <tagoh_> #startmeeting i18n
06:01:44 <zodbot> Meeting started Thu Oct  4 06:01:44 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:01:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:01:44 <tagoh_> #meetingname i18n
06:01:44 <zodbot> The meeting name has been set to 'i18n'
06:01:45 <tagoh_> #topic agenda and roll call
06:01:46 <tagoh_> #link https://fedoraproject.org/wiki/I18N/Meetings/2012-10-04
06:01:54 <tagoh_> okay, shall we have i18n meeting now
06:02:11 <anish_> hi
06:02:27 <juhp> hi
06:02:38 <dueno> hi
06:03:06 <pravin_s> hi
06:04:00 <fujiwarat> hi
06:04:25 <mfabian> hi
06:05:38 <tagoh_> okay, let's get started.
06:05:55 <tagoh_> #topic Upcoming schedule
06:05:56 <tagoh_> #info 2012-10-09        Beta Change Deadline
06:05:56 <tagoh_> #info 2012-10-09        Features 100% Complete
06:05:56 <tagoh_> #info 2012-10-23        Beta Release
06:05:56 <tagoh_> #info 2012-11-12        Final Change Deadline
06:06:20 <tagoh_> fwiw the release schedule of GNOME 3.6.1 is 17th October.
06:06:34 <tagoh_> just FYI
06:06:46 <tagoh_> #topic Outstanding topics
06:06:46 <tagoh_> #info #1: FEAT: GNOME IBus Integration (fujiwara)
06:06:46 <tagoh_> #link https://fedorahosted.org/i18n/ticket/1
06:07:10 <tagoh_> https://fedoraproject.org/wiki/Features/GNOMEIBusIntegration
06:07:19 <tagoh_> fujiwarat: so any chance to update the feature page?
06:07:48 <tagoh_> deadline is coming up next Tuesday.
06:08:10 <fujiwarat> tagoh_: I moved two items into Contingency Plan.
06:09:33 <juhp> fujiwarat, it still says 80%......
06:09:44 <fujiwarat> yes
06:09:48 <juhp> heh
06:10:23 <juhp> so what is the renaming 20% exactly?
06:10:25 <fujiwarat> Today I heard three plans for beta.
06:10:32 <tagoh_> well, I think we can just drop it from scope but adding in the contingency plan. it's plan to revert the feature.
06:10:37 <juhp> indeed
06:12:10 <juhp> fujiwarat, is it the last 2 items in the Scope section?
06:13:03 <juhp> fujiwarat, can you tell us about the 3 alternatives?
06:13:07 <fujiwarat> yes
06:14:44 <tagoh_> though I was about to talk about part of it in next topic, Rui agreed to provide a solution to migrate ibus configuration to the input source in 3.6.1. as I noted, it may be too late for Beta nor the feature 100% complete deadline.
06:14:45 <fujiwarat> One is the converting ibus dconf value to g-s-d gsettings value about engine lists for the upgrading installation.
06:14:59 <anish_> great
06:15:41 <fujiwarat> Another is that g-s-d sources value for the initial login.
06:16:40 <fujiwarat> The third is to support variants and options.
06:16:42 <juhp> I think it is probably ok to make migration optional in the scope of the feature
06:17:00 <tagoh_> indeed
06:17:35 <fujiwarat> After the three items are implemented, the feature will be 100.
06:17:37 <juhp> we don't need to beat ourselves up here :)  the feature is already significant IMO
06:17:45 <fujiwarat> s/100/100%/
06:17:53 <tagoh_> given that the fix is merged in upstream git, if we can backport it prior to Beta, that would be ideal though.
06:18:02 <juhp> fujiwarat, will be happen before the feature freeze...?
06:18:19 <juhp> ie next Tue
06:18:23 <fujiwarat> I hope so.
06:18:28 <juhp> hm
06:19:02 <tagoh_> any changes in the release schedule of 3.6.1 ?
06:19:05 <juhp> well up to you if you want to risk the feature not being accepted officially
06:19:31 <juhp> I guess if it is 90% or 95% it might be ok
06:20:16 <fujiwarat> juhp: ok, changed to 90%
06:20:31 <juhp> still think better to think of setting migration as a bugfix
06:20:54 <fujiwarat> http://bugzilla-attachments.gnome.org/attachment.cgi?id=225737
06:21:09 <tagoh_> sure. I guess it can be landed by GA. so maybe no problem as bug fixes.
06:21:30 <fujiwarat> Currently the initial IME is ja, ko, zh only.
06:21:46 <tagoh_> so then it can be 100% ?
06:21:49 <juhp> I see yes
06:22:15 <juhp> Indian people probably won't be so happen
06:22:24 <anish_> hmm
06:22:28 <fujiwarat> It would be good to comment your languages:
06:22:33 <fujiwarat> https://bugzilla.gnome.org/show_bug.cgi?id=685457
06:23:09 <fujiwarat> I think this will be integrated in beta.
06:24:02 <juhp> in F17 and earlier we start ibus for: locales for as bn gu hi ja kn ko mai ml mr ne or pa si ta te th ur vi zh
06:24:38 <juhp> and also X compose for: am_ET el_GR fi_FI pt_BR ru_RU
06:24:44 <juhp> for reference anyway
06:24:56 <tagoh_> right
06:25:05 <fujiwarat> Can someone create the pair list of (language, ime).
06:25:13 <juhp> at least CJK is a start... :)
06:25:33 <anish_> can we create wiki ?
06:25:38 <anish_> wiki-page
06:25:43 <juhp> yeah good to add to above bug I guess
06:26:13 <juhp> anish_, sure, well we probably have such info in the wiki already
06:26:23 <juhp> paragn, ?
06:27:08 <juhp> for Indic inscript is default, right?
06:27:19 <anish_> yeah i think so
06:27:48 <fujiwarat> The default IME list may be a bit urgent task to meet beta.
06:27:51 <juhp> anyway please all help fujiwarat and rtcm with input for this
06:27:54 <juhp> yes
06:28:14 <tagoh_> juhp: something in relnote are you referring to?
06:28:28 <juhp> ah
06:29:13 <juhp> tagoh_, well not particularly
06:29:22 <tagoh_> okay
06:29:31 <juhp> I was thinking of some of the wiki pages with tables for fonts and IMEs
06:29:38 <juhp> well the IMEs at least
06:29:40 <juhp> but yeah
06:29:49 <juhp> I think
06:31:05 <fujiwarat> Maybe it's nice to add the IME table in https://fedoraproject.org/wiki/I18N/InputMethods
06:32:12 <tagoh_> fujiwarat: sure, you can go ahead :)
06:32:39 <anish_> fujiwarat, thanks
06:33:05 <fujiwarat> I'm a bit busy to create the table in this week.
06:33:12 <juhp> http://fedoraproject.org/wiki/I18N/Indic
06:33:24 <juhp> sure
06:33:28 <juhp> please
06:33:38 <fujiwarat> ok
06:33:45 <juhp> ^ has info for indic anyway which you can copy
06:33:51 <tagoh_> propose #agreed deal with migration for configuration and initial setup for shortcut key and default IMEs as bug fixes
06:33:57 <juhp> made by Parag iirc
06:34:48 <tagoh_> then updated the feature to 100%
06:35:00 <tagoh_> s/updated/update/
06:35:12 <juhp> for th and vi no completely sure about the defaults... maybe you know, dueno?
06:35:40 <tagoh_> do we have any engines for them in ibus?
06:35:50 <juhp> probably just m17n maps?
06:35:55 <tagoh_> ah
06:36:22 <juhp> (reminds me no Thai in anaconda it seems)
06:36:28 <juhp> erm Thai font
06:36:51 <tagoh_> aha
06:37:55 <tagoh_> hmm, I guess we already have a consensus for the above proposal ;)
06:39:05 <paragn> juhp, hi
06:39:37 <tagoh_> well, any other concerns on this feature? maybe good to share prior to make the feature 100% if any.
06:41:41 <tagoh_> fujiwarat: if no objections, please update the feature page to 100% then.
06:42:26 <juhp> before Tue anyway :)
06:42:33 <tagoh_> right
06:43:44 <fujiwarat> Currently I leave it due to the three items till Tue.
06:43:56 <fujiwarat> Actually the scope includes:
06:44:02 <fujiwarat> In Fedora we would also like to:
06:44:08 <fujiwarat> setup input method hotkey for CIJK users
06:44:14 <fujiwarat> setup default IMEs for CIJK users
06:45:19 <fujiwarat> I will update the page later to follow the progress.
06:45:36 <tagoh_> fujiwarat: bugs is not a feature. so we are proposing the above we can deal with them as a bug and fix it while the feature meets 100%
06:46:06 <fujiwarat> So probably the two items can be dropped in scope.
06:46:18 <juhp> ok
06:46:42 <tagoh_> sure
06:47:34 <tagoh_> so, again, are we okay for that? :)
06:48:05 <fujiwarat> Changed to 100%
06:48:15 <tagoh_> thanks!
06:48:33 <tagoh_> #agreed deal with migration for configuration and initial setup for shortcut key and default IMEs as bug fixes
06:48:40 <tagoh_> okay, time to move on then.
06:49:08 <tagoh_> #topic New topics
06:49:08 <tagoh_> #info #7: ibus configuration migration on upgrading (tagoh)
06:49:08 <tagoh_> #link https://fedorahosted.org/i18n/ticket/7
06:49:15 <tagoh_> there are nothing to discuss anymore. move on
06:49:23 <tagoh_> #topic Open Floor
06:49:42 <tagoh_> anything more topics to discuss in this meeting prior to finish?
06:50:02 <juhp> I worked a little on workaround for the f18 anaconda issue
06:50:25 <pravin_s> tagoh_: Liberation fonts is still pending, actually due some couple of bugs not able to release fonts early this week
06:50:33 <pravin_s> but resolved issues now, will release it today
06:50:35 <juhp> will update my patch anyway in a bit
06:51:02 <tagoh_> #link https://bugzilla.redhat.com/show_bug.cgi?id=858591
06:51:31 <tagoh_> thanks for taking a look.
06:51:41 <juhp> trying a test build now which i hope might be last one... http://koji.fedoraproject.org/koji/taskinfo?taskID=4558149
06:51:45 <juhp> sure
06:51:58 <mfabian> Did anybody try to install Beta-TC1 yet? After a Japanese install in qemu I saw the frowney that "something went wrong" again from Gnome.
06:52:12 <paragn> hope to see it will get fixed by F18 release
06:52:21 <juhp> I hope by Beta :)
06:52:44 <paragn> that will be great
06:53:03 <tagoh_> mfabian: I did from Live. works fine except gdm refuse to log in with root anyway.
06:53:11 <juhp> essential IMHO - anyway it is now re-proposed as a beta blocker
06:53:34 <paragn> yes :)
06:53:41 <juhp> mfabian, seems net/dvd installs have problems
06:53:54 <mfabian> tagoh_: I used the Fedora-18-Beta-TC1-x86_64-netinst.iso
06:53:59 <tagoh_> aha
06:54:09 <juhp> right - I couldn't log in either
06:54:33 <juhp> I guess there will be TC2 soon, new anaconda should fix some more bugs
06:54:45 <mfabian> And unfortunately I forgot to set the root password in the beginning, therefore I could not login via ssh to see what went wrong.
06:54:54 <juhp> mfabian, maybe try Live if you have a chance
06:55:12 <juhp> seems to work better - maybe because of older packages
06:55:18 <tagoh_> there are new anaconda in updates-testing already.
06:55:46 <tagoh_> so yeah, it should be available in next TC
06:56:01 <tagoh_> anyway, anything more?
06:56:29 <juhp> yeah above build should be off latest anaconda - you can test it in Live if you want to have fixed locale
06:57:45 <tagoh_> if not, let's close the meeting shortly
06:58:20 <juhp> mfabian, I guess something is broken in updates-testing...
06:58:38 <juhp> but dunno what
06:59:01 <tagoh_> mfabian: it's the side-effect of the above bug - i.e. fail to run firstboot, which is responsible to create an account
06:59:26 <juhp> right that too
06:59:34 <mfabian> tagoh_: that sounds likely. So it might work in English?
06:59:40 <tagoh_> yes
07:00:01 <juhp> but feel like there could also be some new breakage lurking?
07:00:21 <tagoh_> perhaps
07:00:43 <juhp> I didn't try updating Live to latest packages yet, anyway.....
07:01:00 <mfabian> How to update Live to the latest packages?
07:01:38 <tagoh_> Live image itself? I guess you could try the nightly build
07:02:12 <juhp> (Live install I meant)
07:02:13 <tagoh_> http://dl.fedoraproject.org/pub/alt/nightly-composes/
07:02:37 <juhp> yeah I think TC1 Live is still latest
07:02:41 <mfabian> juhp: so you installed live and then updated.
07:02:50 <tagoh_> juhp: yeah, I thought so
07:02:53 <juhp> I didn't update yet I think :)
07:03:41 <tagoh_> okay, we can stop here if not particularly.
07:03:44 <juhp> anyway about to test my new anaconda build
07:03:49 <juhp> sure :)
07:03:58 <tagoh_> cool
07:04:09 <tagoh_> okay, thanks everyone for the meeting!
07:04:12 <tagoh_> #endmeeting