fesco
LOGS
17:00:27 <mmaslano> #startmeeting FESCO (2012-07-30)
17:00:27 <zodbot> Meeting started Mon Jul 30 17:00:27 2012 UTC.  The chair is mmaslano. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:32 <mmaslano> #meetingname fesco
17:00:32 <zodbot> The meeting name has been set to 'fesco'
17:00:33 <dan408> hi
17:00:38 <mmaslano> #chair notting nirik mjg59 mmaslano t8m pjones mitr limburgher jwb
17:00:38 <zodbot> Current chairs: jwb limburgher mitr mjg59 mmaslano nirik notting pjones t8m
17:00:38 <mitr> Hello
17:00:40 * nirik is here. Morning all
17:00:41 * notting is here
17:00:44 <dan408> here
17:00:48 * jwb is here
17:01:09 <mmaslano> #topic init process
17:01:25 * limburgher here
17:01:38 <mmaslano> great
17:01:50 <mmaslano> I've asked you to vote in tickets, because we have a lot of them
17:02:02 <mmaslano> I could add those features with +5 votes at the end of agenda
17:02:05 <mmaslano> if you wish
17:02:19 * pknirsch here
17:02:25 <mmaslano> ~7 features were already approved in tickets
17:02:25 <dan408> +1 mmaslano
17:02:27 * twaugh here
17:02:27 <nirik> mmaslano: sounds good.
17:03:19 <mmaslano> we have only new business, so first feature
17:03:23 <mmaslano> #topic #911 F18 Feature: Samba 4.0 - https://fedoraproject.org/wiki/Features/Samba4
17:03:27 <mmaslano> .fesco 911
17:03:28 <zodbot> mmaslano: #911 (F18 Feature: Samba 4.0 - https://fedoraproject.org/wiki/Features/Samba4) – FESCo - https://fedorahosted.org/fesco/ticket/911
17:04:39 <mitr> Silence?
17:04:41 <mitr> +1
17:04:44 <limburgher> +1
17:04:52 <mmaslano> it looks almost ready, +1
17:05:03 <pjones> +1
17:05:06 <mjg59> +1
17:05:06 <nirik> +1 here as well...
17:05:10 <jwb> +1
17:05:41 <notting> i'd like more clarity on 4 vs 3 -
17:06:47 <mmaslano> notting: it's a blocker for approval?
17:06:58 <mjg59> mmaslano: If possible, could we cover #917 (mate) early?
17:07:08 <mmaslano> sure
17:07:10 <dan408> i'd appreceiate that, i have work to do
17:07:34 <mjg59> mmaslano: I'm +1 to everything except that, could do with a few questions on mate
17:07:44 <notting> mmaslano: not a blocker, but i'd prefer not to ship two versions
17:07:55 <mmaslano> notting: ok, i'll mention it
17:08:20 <mmaslano> #agreed Samba4.0 is an approved feature (+8,-0)
17:08:24 <mitr> notting: ticket comment 3 suggests that is what will happen
17:08:31 <mmaslano> #topic #917 F18 Feature: MATE Desktop - https://fedoraproject.org/wiki/Features/MATE-Desktop
17:08:36 <mmaslano> .fesco 917
17:08:38 <zodbot> mmaslano: #917 (F18 Feature: MATE Desktop - https://fedoraproject.org/wiki/Features/MATE-Desktop) – FESCo - https://fedorahosted.org/fesco/ticket/917
17:08:41 <mmaslano> it has +5 already
17:08:51 <mmaslano> mjg59: please ask your questions
17:09:17 <mjg59> My main concern here is symbol naming
17:09:19 <dan408> yes please
17:09:30 <mjg59> If a process ends up with libwnck and libmatewnck in process at once, what happens?
17:10:17 <nirik> hopefully the symbols are also different? or are they not?
17:10:26 <dan408> they are different.
17:10:57 <mjg59> All of them?
17:11:01 <dan408> mjg59: i'd have to ask upstream about that to be 100% sure, but it shouldn't happen since A) mate is forked from Gnome 2, B) mate has its own place and naming for everything.
17:11:05 <dan408> all of them.
17:11:12 <mjg59> Including internal implementation details?
17:11:16 <dan408> so unless you installed gnome 2 and mate at the same time
17:11:23 <dan408> how could that happen?
17:11:34 <dan408> does gnome 3 use the gnome 2 libwnck?
17:11:42 * nirik thinks this is a concern to bring up with upstream mate.
17:11:47 <dan408> yes
17:11:53 <pjones> well, the gnome3 libwnck might still have similar internal naming
17:12:10 <dan408> in general, i see that everything mate creates it puts in its own directory and names it appropriately.
17:12:17 <mjg59> dan408: libmatewnck doesn't conflict with libwnck
17:12:33 <mitr> nirik: well, "will the PackageKit GUI work" is somewhat an interesting question
17:12:36 <dan408> pjones: I have gnome3 and Mate installed together with no issue.
17:12:51 <mjg59> The common case is that binaries will only be linked against one
17:12:52 <dan408> mitr: it works.
17:12:53 <Discordian> as indeed do I
17:12:57 <dan408> in a weird gnome 2 kind of way
17:13:03 <dan408> you do get updates about alerts
17:13:05 <mjg59> Ending up with multiple libraries in process is a corner case
17:13:17 <mjg59> And we have to care about corner cases
17:13:30 <dan408> we have packaged mate so that we don't provide files that gnome3/gtk2 already provide
17:13:49 <mjg59> It's not about the files
17:14:02 <mjg59> Look I'm sorry but if you don't understand what I'm talking about then you shouldn't be packaging a desktop
17:14:13 <Discordian> It is about the symbols etd
17:14:16 <Discordian> etc
17:14:33 <mjg59> There are subtle ways that this can go wrong
17:14:46 <mjg59> And when they do go wrong you'll get bizarre crashes that can't be explained
17:14:54 <dan408> mjg59: again, in what case would such an issue occur? how would you trigger an event? please provide us with steps that we can try to trigger this problem and plan for it.
17:15:06 <pjones> the question is whether or not if you've got them both linked in, ldso might stitch them together in such a way that one is using and changing the state of the other
17:15:15 <Discordian> I understand mjg59's point
17:15:34 <mjg59> Now if every symbol is renamed (including private API) then this isn't a problem
17:15:52 <mjg59> And it certainly looks like the intention in the mate code is that all these symbols be renamed
17:15:55 <dan408> mjg59: I believe it is, on purpose, for that specific reason dude.
17:15:56 * nirik thinks any places that interfere with other packages are bugs and must be fixed. Unless this is a widespread problem and upstream refuses to fix it, I don't know that this has much to do with feature acceptance.
17:16:30 <Discordian> Point
17:16:42 <dan408> i have worked very hard to avoid that issue nirik
17:16:54 <Discordian> i don't have a vote of course
17:17:00 <mmaslano> mjg59: do you have other questions?
17:17:22 <mjg59> But I do worry about the sheer number of interfaces present in the gnome2 stack - it's not straightforward to ensure that they've all been cleaned up
17:17:23 <mmaslano> I agree with nirik'
17:17:45 <mjg59> And so I'd really prefer that we do a release with it before indicating that we support it
17:17:46 <nirik> it will/is indeed a ton of work. Time will tell if it's viable.
17:18:23 <dan408> thanks for bringing this up mjg59
17:18:47 <mjg59> But in the absence of actual identified problems in the wild, I'm a vague +1
17:18:48 <mitr> mjg59: As long as we can ensure that mate objects are not dragged into "pure" GNOME 2/3 applications, I don't see much reason for FESCo to complain.  (OTOH ensuring this is still not trivial from my PoV of someone who doesn't know all the plugin mechanisms.)
17:19:02 <Discordian> the point is whether it can be accepted as a feature for f18
17:19:09 <mmaslano> another vote?
17:19:13 * pjones also +1
17:19:16 <jwb> +1
17:19:16 <dan408> i do not see why not, since it works fine on f17
17:19:26 <mitr> +1
17:19:33 <dan408> thank you
17:19:36 <limburgher> +1
17:19:47 <mjg59> Ok, I have to head out now - I think I've voted in all the tickets
17:19:54 <mjg59> Sorry about the timing, was a last minute thing
17:19:58 <notting> i'm ok with it... really it's on mate if it breaks. so, +1
17:20:07 <dan408> :)
17:20:14 <mmaslano> #agreed MATE is accepted as a feature (+9,-0)
17:20:19 <nirik> mjg59: thanks for noting that. At least upstream can be made aware of the issue.
17:20:24 <dan408> thank you all
17:20:28 <mmaslano> (+votes from ticket)
17:20:45 <mmaslano> #topic #913 F18 Feature: oVirt engine 3.1 - https://fedoraproject.org/wiki/Features/oVirtEngine_3.1
17:20:51 <mmaslano> .fesco 913
17:20:52 <zodbot> mmaslano: #913 (F18 Feature: oVirt engine 3.1 - https://fedoraproject.org/wiki/Features/oVirtEngine_3.1) – FESCo - https://fedorahosted.org/fesco/ticket/913
17:21:01 <mitr> +1
17:21:20 * nirik was +1 in ticket, still is.
17:21:27 <pjones> +1
17:21:31 <jwb> +1
17:21:47 <mmaslano> +1
17:22:58 <mmaslano> +2 notting, limb from ticket?
17:23:06 <notting> yes
17:23:49 <mmaslano> #agreed oVirt is approved as a feature (+7,-0)
17:23:57 <mmaslano> #topic #915 F18 Feature: Agent-Free Systems Management - https://fedoraproject.org/wiki/Features/AgentFreeManagement
17:24:02 <mmaslano> .fesco 915
17:24:04 <zodbot> mmaslano: #915 (F18 Feature: Agent-Free Systems Management - https://fedoraproject.org/wiki/Features/AgentFreeManagement) – FESCo - https://fedorahosted.org/fesco/ticket/915
17:24:37 <notting> this seems poorly worded
17:24:50 <pjones> notting: well, I think it's jargon worded, but yeah
17:25:01 <notting> in as much as 'agent free' means 'we move all the agents into the OS instead of adding them later'
17:25:03 * nirik would like the same questions mitr asked answerecd.
17:25:30 <jwb> are the anaconda changes in or submitted?
17:25:57 <notting> jwb: not afaict
17:26:00 <pjones> (Also a little concerned that it's at 30%)
17:26:04 <pjones> jwb: not that I know of
17:26:19 * nirik would say defer and ask questions of feature owners?
17:26:35 <mmaslano> could we postpone it? I'd like to see answeres to questions on discussion page
17:26:44 <mitr> I'm fine with approving pending implementation - we do that fairly often anyway
17:27:13 <mitr> one more thing that I'd really want to see described - is any of this hardware-specific code supposed to run by default?
17:27:17 * mitr adds it to the talk page
17:27:39 <jwb> right.  i was just thinking "am i going to have to turn all of these daemons off on my laptop"
17:28:39 <limburgher> So I'd postpone pending answers.
17:28:44 <mmaslano> me too
17:29:01 <mmaslano> I see +3 postpone, more votes?
17:29:02 * nirik nods
17:29:04 * mitr would obviously like to see answers to his questions as well
17:29:15 * pjones is for postponing to get questions answered as well
17:29:27 <notting> +1 to postpone
17:29:29 <jwb> postpone
17:30:21 <mmaslano> #agreed Agent-Free Systems Management's owner must answer few question first (+6,-0)
17:30:29 <mmaslano> #topic #916 F18 Feature: Sugar 0.98 - https://fedoraproject.org/wiki/Features/Sugar_0.98
17:30:35 <mmaslano> .fesco 916
17:30:37 <zodbot> mmaslano: #916 (F18 Feature: Sugar 0.98 - https://fedoraproject.org/wiki/Features/Sugar_0.98) – FESCo - https://fedorahosted.org/fesco/ticket/916
17:30:56 <mitr> +1
17:31:09 <pjones> 0% - awesome.
17:31:10 <mmaslano> +1
17:31:22 * pjones still says +1 if they can pull it off
17:31:42 * nirik is +1 in ticket and still +1
17:31:47 <mmaslano> it's self contained feature without impact on other packages...
17:31:48 <jwb> +1
17:31:56 <pjones> mmaslano: yeah, hence I'm +1 on it
17:32:01 <notting> +1 as in ticket
17:32:32 <mmaslano> #agreed Sugar 0.98 is approved as a feature (+6,-0)
17:32:35 <limburgher> +1, thought I voted
17:32:43 <mmaslano> #topic #919 F18 Feature: LTTng 2.0 - https://fedoraproject.org/wiki/Features/LTTng
17:32:49 <mmaslano> .fesco 919
17:32:51 <zodbot> mmaslano: #919 (F18 Feature: LTTng 2.0 - https://fedoraproject.org/wiki/Features/LTTng) – FESCo - https://fedorahosted.org/fesco/ticket/919
17:33:48 * pjones +1
17:34:16 <jwb> i kind of question the "rebuild fedora packages with UST" part, but it's voluntary and not really part of the feature i guess
17:34:35 <mitr> We should decide on a preferred tracing infrastructure one day... but that's not a blocker to this feature, so +1
17:34:35 <limburgher> +1 like in ticket.
17:34:36 <notting> tracing frameworks must be the new irc clients
17:34:37 <mmaslano> +4 limb, tmraz, mmaslano, mjg59 in the ticket
17:35:08 <jwb> +1 i guess
17:35:17 * nirik had some question, but now cannot recall it.
17:35:37 <nirik> oh, kernel module?
17:35:41 <jwb> no
17:35:47 <mitr> nirik: dropped from scope
17:35:47 <notting> i don't think it's great to have an explosion of frameworks here, but it's not a full reason to drop it, so ... meh. +1
17:35:52 <nirik> should it not mention that, or is that going to be carried in the kernel...ok
17:36:05 <nirik> the feature still talks about the kernel module
17:36:27 <pjones> yeah, that's a good question
17:36:30 <jwb> sigh.  i told them to remove that
17:36:30 <pjones> jwb: thoughts on that?
17:36:32 <mitr> oh, right.  I remember seeing the edits that removed it from some places
17:36:44 <jwb> it was dropped from the summary, but i guess the detailed and test portions still have it
17:36:47 <jwb> needs to be removed
17:36:55 <jwb> we're not carrying the kernel module portion at all
17:36:56 <mmaslano> #info LTTng feature must update the feature page (notes about kernel module)
17:37:22 <nirik> with that fixed, I'm +1
17:37:50 <mmaslano> jwb: could you poke them about it?
17:37:59 <scientist> will change it
17:38:04 <mmaslano> scientist: great
17:38:07 <jwb> great, thanks
17:38:13 <mmaslano> #agreed LTTng 2.0 is approved as a feature (+8,-0)
17:38:19 <mmaslano> #topic #920 F18 Feature: ownCloud - https://fedoraproject.org/wiki/Features/OwnCloud
17:38:24 <mmaslano> .fesco 920
17:38:30 <zodbot> mmaslano: #920 (F18 Feature: ownCloud - https://fedoraproject.org/wiki/Features/OwnCloud) – FESCo - https://fedorahosted.org/fesco/ticket/920
17:39:10 * nirik was +1 in ticket, still +1
17:39:15 <mmaslano> +5 limb, notting, kevin,mmaslano, mjg59
17:39:19 <jwb> +1
17:39:20 <pjones> +1
17:39:23 <mitr> +1
17:39:45 <mmaslano> #agreed ownCloud is approved as a feature (+8,-0)
17:39:55 <mmaslano> #topic #923 F18 Feature: Print Service - https://fedoraproject.org/wiki/Features/PrintService
17:40:02 <mmaslano> .fesco 923
17:40:03 <zodbot> mmaslano: #923 (F18 Feature: Print Service - https://fedoraproject.org/wiki/Features/PrintService) – FESCo - https://fedorahosted.org/fesco/ticket/923
17:40:16 <jwb> 3%?
17:40:16 <pjones> +1
17:40:26 <twaugh> It's probably a little more than that now
17:40:35 <twaugh> But there isn't a great deal of code yet :-(
17:40:48 <mitr> I'm not _really_ happy having "second-class printers", but it's probably a necessary step
17:40:54 <mitr> So +1
17:41:13 <nirik> yeah, +1 here...
17:41:18 <jwb> twaugh, do you feel you'll get it written in time?
17:41:42 <pjones> if he doesn't, we can bump it to F19 when he decides it won't hit.
17:41:50 <twaugh> I hope I can at least get the service itself done.
17:41:52 <notting> i'd honestly prefer some sort of tech-preview type status here before it's touted as a feature, as it just sounds like it's not going to be fully baked in time
17:42:04 <jwb> notting, that's what i was thinking
17:42:05 <twaugh> Realistically I'm not sure there will be much more done before freeze
17:42:25 <pjones> twaugh: huh.  then F19 might be better.
17:42:36 <limburgher> notting: +1
17:42:39 <jwb> yeah.  i'd say we defer this to F19
17:42:49 <mmaslano> twaugh: defer to F19?
17:42:54 <twaugh> Sounds fair, yes
17:43:36 <mmaslano> #agreed Print Service will be postponed to F-19. In F-18 will be tech preview.
17:43:51 <mmaslano> #topic #926 F18 Feature: SELinux Systemd Access Control - https://fedoraproject.org/wiki/Features/SELinuxSystemdAccessControl
17:43:56 <mmaslano> .fesco 926
17:43:58 <zodbot> mmaslano: #926 (F18 Feature: SELinux Systemd Access Control - https://fedoraproject.org/wiki/Features/SELinuxSystemdAccessControl) – FESCo - https://fedorahosted.org/fesco/ticket/926
17:44:20 <pjones> +1
17:44:28 <jwb> +1
17:44:32 <limburgher> See my question in the ticket.
17:44:32 <mitr> +1
17:44:40 <mmaslano> in the ticket is question about default setting
17:45:05 <notting> it was locked down, pre-systemd. this is returning to that state
17:45:13 * nirik is +1
17:45:19 <limburgher> notting:  Thanks.
17:45:19 <mmaslano> I understand from the feature page, that it will be the default behaviour
17:45:20 <limburgher> +1
17:46:01 <mmaslano> +1
17:46:32 <mmaslano> +2 tmraz, mjg59 in the ticket
17:46:48 <mmaslano> #agreed SELinux Systemd Access Control is approved as a feature (+8,-0)
17:46:49 * notting is +1 in the ticket
17:47:00 <mmaslano> ah
17:47:06 <mmaslano> #agreed SELinux Systemd Access Control is approved as a feature (+9,-0)
17:47:21 <mmaslano> now we have features already approved in tickets
17:47:31 <mmaslano> #topic #921 F18 Feature: IPA v3 trusts update - https://fedoraproject.org/wiki/Features/IPAv3Trusts
17:47:36 <mmaslano> .fesco 912
17:47:37 <zodbot> mmaslano: #912 (F18 Feature: IPA v3 trusts update - https://fedoraproject.org/wiki/Features/IPAv3Trusts) – FESCo - https://fedorahosted.org/fesco/ticket/912
17:47:52 <jwb> i didn't get to the tickets over the weekend as i was out.  i'm +1 to the rest of them
17:47:52 <pjones> Why are we even going through these?
17:48:00 <mitr> +1
17:48:05 <nirik> are the rest all +5?
17:48:09 <mmaslano> does anyone have a problem with rest of them?
17:48:10 <limburgher> pjones:  Not everyone voted on every ticket.
17:48:12 * pjones is also +1 to the rest of them, but doesn't think we even need iterate them since they're approved
17:48:13 <mmaslano> nirik: yes
17:48:24 <mitr> mmaslano: can you list "rest of them"?
17:48:26 <nirik> yeah, perhaps just add #approved for them?
17:48:32 <mmaslano> ok
17:48:49 <limburgher> Works for me.
17:49:04 <mmaslano> #agreed Feature: IPA v3 trusts update (+5,-0)
17:49:09 <mmaslano> #topic #914 F18 Feature: Python 3.3 - https://fedoraproject.org/wiki/Features/Python_3.3
17:49:30 <mmaslano> #agreed Feature: Python 3.3 (+5,-0)
17:49:40 <mmaslano> #topic #918 F18 Feature: FedFS - https://fedoraproject.org/wiki/Features/FedFS
17:49:57 <mmaslano> #agreed Feature: FedFS (+5,-0)
17:50:05 <mmaslano> #topic #921 F18 Feature: Server KMS Drivers - https://fedoraproject.org/wiki/Features/ServerKMSDrivers
17:50:26 <mmaslano> #agreed Feature: Server KMS Drivers (+5,-0)
17:50:34 <mmaslano> #topic #922 F18 Feature: LLVM support on 64-bit POWER systems - https://fedoraproject.org/wiki/Features/LLVMonPPC64
17:50:50 <mmaslano> #agreed  Feature: LLVM support on 64-bit POWER systems (+5,-0)
17:50:57 <mmaslano> #topic #924 F18 Feature: Systemtap 2.0 - https://fedoraproject.org/wiki/Features/Systemtap2
17:51:12 <mmaslano> #agreed Feature: Systemtap 2.0 (+5,-0)
17:51:20 <mmaslano> #topic #925 F18 Feature: NFSometer - https://fedoraproject.org/wiki/Features/NFSometer
17:51:37 <mmaslano> #agreed Feature: NFSometer (+5,-0)
17:51:49 <mmaslano> #topic #927 F18 Feature: VNCServer support for LLVMpipe/Mesa on 64-bit IBM Power Systems -https://fedoraproject.org/wiki/Features/VNCServerWithLLVMpipe
17:52:04 <mmaslano> #agreed Feature: VNCServer support for LLVMpipe/Mesa on 64-bit IBM Power Systems (+5,-0)
17:52:11 <mmaslano> #topic #928 F18 Feature: QXL/Spice KMS Driver - https://fedoraproject.org/wiki/Features/QXLKMSSupport
17:52:25 <mmaslano> #agreed Feature: QXL/Spice KMS Driver (+5,-0)
17:52:54 <mmaslano> that's all
17:53:15 <mmaslano> in case I missed something I'll leave it for next week
17:53:21 <nirik> cool.
17:53:27 <mmaslano> problem or question with some feature?
17:53:28 <nirik> thanks for all that housekeeping mmaslano. :)
17:53:31 <ab> has the samba4 ticket been processed in first half?
17:53:39 <Discordian> yes
17:53:41 <mmaslano> yes, it was approved
17:53:49 <ab> thanks, I came a bit late
17:54:23 <mmaslano> ok, no problems
17:54:27 <mmaslano> #topic Next week's chair
17:54:52 <notting> i'm likely to miss next week, so i'm out
17:55:16 <mitr> I can chair next week
17:55:21 <mmaslano> thanks
17:55:32 <mmaslano> #action mitr will be chairman next week
17:55:39 <mmaslano> #topic Open Floor
17:56:12 * nirik has nothing off hand
17:57:08 <mitr> Last week we decided to postpone firewalld+avahi to today.. without a clear action.
17:58:15 <mmaslano> I don't see the ticket, give me a minute
17:58:39 <jwb> the ticket was closed because the feature was accepted
17:58:41 <mmaslano> https://fedoraproject.org/wiki/Features/AvahiDefaultOnDesktop
17:58:55 <mmaslano> #topic 897
17:58:58 <mmaslano> .fesco 897
17:59:00 <zodbot> mmaslano: #897 (F18 Feature: Avahi by Default on the Desktop - https://fedoraproject.org/wiki/Features/AvahiDefaultOnDesktop) – FESCo - https://fedorahosted.org/fesco/ticket/897
18:00:18 <mmaslano> there is a discussion page
18:00:42 <mmaslano> we can open the ticket and follow up
18:00:51 <notting> what is the question?
18:00:52 <limburgher> Sounds reasonable.
18:00:55 <mmaslano> is there a volunteer who will contact both parties?
18:01:02 <nirik> so the issue was how to enable avaihi with firewalld?
18:01:04 <mmaslano> q: is there a some kind of cooperation between you and Firewalld guys?
18:01:18 <mmaslano> twoerner didn't reply yet
18:01:20 <mitr> I brought it up, so I suppose I can take the action item
18:02:12 <mmaslano> #action mitr will ask twoerner about co-operation of firewalld and avahi
18:02:54 <limburgher> Thanks mitr.
18:03:10 <mmaslano> #topic Open Floor
18:06:06 <jwb> i think we're done?
18:06:22 <mmaslano> I hope so
18:06:32 <mmaslano> good night
18:06:42 <mmaslano> #endmeeting