cloud_sig
LOGS
19:01:50 <rbergeron> #startmeeting Cloud SIG
19:01:50 <zodbot> Meeting started Fri Jun 22 19:01:50 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:54 <rbergeron> #meetingname Cloud SIG
19:01:54 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:58 * rbergeron goes to wrangle peeps
19:02:02 <rbergeron> #topic Who's around?
19:02:03 * maxamillion is here
19:02:20 * tdawson is here also.
19:02:21 * jsmith is lurking
19:02:25 * strace is here
19:02:42 * gholms lurks
19:02:51 <rbergeron> hey gholms. get that release out the door!
19:02:56 * blentz lurks, too.
19:03:01 <gholms> That's why I'm lurking. :)
19:03:16 <maxamillion> release?
19:03:36 <gholms> I work for eucalyptus rel-eng.  I'm kind of busy right now.  Sorry.  :(
19:03:51 * gholms runs to find lunch really fast
19:03:56 <maxamillion> gholms: ahhh, cool cool
19:04:06 <rbergeron> okay. well, let's start, eh?
19:04:10 <gholms> (The release is due next week)
19:04:11 <rbergeron> #topic OpenShift
19:04:12 <maxamillion> gholms: I do rel-eng for openshift :)
19:04:15 <rbergeron> since I see the shifters here. :)
19:04:36 <rbergeron> How you guys coming along?
19:04:45 <maxamillion> I'm starting to think we need an openshift+fedora t-shirt that says something like "shifters unite!" on it
19:04:51 <strace> I think right now the big hold up is passanger
19:05:05 <maxamillion> rbergeron: cranking away, got some updates to the wiki ... mostly just book keeping stuff now
19:05:37 <tdawson> blentz it getting our fork of passenger ready ... still waiting for legal on the name.
19:05:59 <maxamillion> rbergeron: there's some dev things happening on the github upstream that I think we'll want to pull into the feature if the timelines match up, it allows for easy setup/deploy of openshift origin
19:06:13 * rbergeron nods
19:06:20 <rbergeron> freedom to shift! yay
19:06:27 <rbergeron> maxamillion: like that?
19:06:56 <maxamillion> rbergeron: so right now the openshift origin liveCD is a "single node" and will stay that way because its meant to be a self contained preview/dev environment
19:06:59 <strace> maxamillion: re: tshirts, only if we can hide a panda on em
19:07:05 <rbergeron> #info OpenShift = some updates to wiki, mostly bookkeeping right now; passenger work is still plugging away
19:07:27 <maxamillion> rbergeron: the new stuff offers a way to easily setup a scaled environment with the different components on different nodes/machines if desired
19:08:53 <maxamillion> rbergeron: I don't know the exact status on it's timeline, but I know the code is upstream out in the open for folks to play with
19:09:03 * maxamillion should actually check into that :X
19:09:19 <rbergeron> maxamillion: ah, interesting
19:09:23 * rbergeron nods
19:09:33 <rbergeron> yeah, i still haven't figured out exatly how your release schedule works ;)
19:10:03 <maxamillion> rbergeron: well, it changed not to long ago
19:10:09 <maxamillion> rbergeron: too*
19:10:22 <rbergeron> yup.
19:10:25 <maxamillion> rbergeron: also, we've got a ruby 1.9 cartridge under heavy development ---> https://github.com/openshift/crankcase/tree/master/cartridges/ruby-1.9
19:10:26 <tdawson> We have moved from a two week release cycle to a three week cycle.
19:10:44 <maxamillion> rbergeron: that's been something I know a number of users and community members have been asking for
19:11:03 <rbergeron> #info openshift upstream is workign on a way to easily set up a scaled env. with the different components on different nodes/machines, if desired
19:11:19 <rbergeron> #info moved from a two-week release cycle to a three-week release cycle
19:11:40 <rbergeron> so, i guess i have to ask (from a program manager curiosity): how the hell are you going to pick which one is the fedora one?
19:11:48 <rbergeron> is one of the three-week releases more stable than another?
19:11:51 <rbergeron> or .... ?
19:12:07 <rbergeron> #info a ruby 1.9 cartridge under heavy development - https://github.com/openshift/crankcase/tree/master/cartridges/ruby-1.9
19:12:14 <maxamillion> rbergeron: every release is the preferred release .... release early, release often ;)
19:12:15 <strace> tdawson: Do you have an answer for that?
19:12:37 <rbergeron> maxamillion: are you going to be repackaging every three weeks? how many old releases are you going to carry?
19:12:51 <maxamillion> rbergeron: honestly though, from a fedora perspective ... that needs to be sorted out to be honest, we need to find a way to make that manageable from a Fedora packaging standpoint
19:13:17 * maxamillion can't think and type at the same time apparently
19:13:35 <maxamillion> rbergeron: we'll call that an action item to be determined
19:13:48 * rbergeron nods
19:14:08 <maxamillion> rbergeron: or better yet, I'll defer that to tdawson ... he's the feature owner and might even have a plan cooked up already :D
19:14:16 <rbergeron> #info trying to sort out how to do 3-week release cycles and make it work in a fedora packaging world
19:14:19 <rbergeron> oh
19:14:22 * rbergeron looks at tdawson
19:14:31 * tdawson blinks as the spotlight get's turned on him.
19:14:39 <maxamillion> ;)
19:14:40 <rbergeron> too bright?
19:14:43 <rbergeron> i can turn that down a bit :)
19:14:52 <skvidal> a mole man!
19:14:56 <skvidal> I knew they existed!
19:15:00 <wwoods> q
19:15:19 * rbergeron looks at wwoods
19:15:33 <wwoods> whoops, dropped this
19:15:34 * skvidal expects he meant /q
19:15:36 * wwoods picks up his q and leaves
19:15:54 <tdawson> Most of the cartridges are actually fairly stable, so they won't be changing too much, but the internal stuff is still in a bit of flux.
19:16:11 * rbergeron nods
19:16:26 <rbergeron> but knowing how long the "old release" is supported is probably useful as well.
19:16:31 <tdawson> There are several features that we have to have in, such as the multi-node stuff that maxamillion talked about earlier.
19:17:14 <strace> tdawson: the question was, how often are we going to bump the fedora release and how many old versions do we want to keep around
19:17:17 * rbergeron nods
19:17:53 * tdawson thinks a bit and finally answer.  "I'm going to have to say, I currently don't know, but I will bring that up with the OpenShift community."
19:18:02 <maxamillion> tdawson: +1
19:18:31 <rbergeron> #action tdawson to bring up the "how often are we going to bump the fedora release andhow many old versions do we want to keep around" question in the openshift community
19:18:34 <rbergeron> :D thank you sir
19:18:39 <rbergeron> anything else on the openshift end?
19:19:16 <tdawson> On a related note, we *have* started testing the newer server code on older clients.
19:19:56 <tdawson> Not the same thing, but it's gotten some of the developers thinking about stability.
19:20:30 <maxamillion> tdawson: +1
19:21:47 <tdawson> I think that's about it for OpenShift, unless any of the other Shifters have anything to add.
19:21:56 <rbergeron> yeah. i think it's all well and good to do whateve ryou want in the "official service" or whatever, but i tink to be able to build community around how it works... it's gotta live long enough for someone to actually be able to play with it for more than 3 minutes before it changes again
19:22:14 <rbergeron> IMHO
19:22:17 <rbergeron> (always, always H)
19:22:18 <rbergeron> :D
19:22:39 <tdawson> Yep, I totally agree with you.
19:22:52 <maxamillion> I agree as well
19:23:05 <rbergeron> alrighty! /me shall move onwards then
19:23:07 <strace> rbergeron: are you suggesting we have a stable tag in our source for the fedora project?
19:23:31 <strace> and only update it with bug fixes until X amount of weeks/months?
19:23:33 <rbergeron> strace: well, it's a suggestion :) or maybe something like every 3rd or 4th release, maybe longer, i don't know whatis optimal for you guys.
19:23:39 <maxamillion> we just move really fast internally ... gotta try to find a way to make the more consumeable(sp?) to the more wide spread community
19:25:00 <rbergeron> strace: i tihnk it's just hard for anyone to sit down and even get started with it (in or out of fedora) if they want to contribute beyond just making cartridges ... if it's a part-time community thing, barely getting in the code and having it change makes it hard
19:25:18 <rbergeron> it's okay if you're totally familiarized with the code bt... yeah
19:25:50 <rbergeron> or maybe it's just certain components live longer? i don't know.
19:25:59 <strace> rbergeron: ok, i will pass it along to the people working on getting openshift in fedora and see how they feel about it
19:26:26 <strace> s/pass it along/work with/
19:26:33 * maxamillion works to recruit strace into that list of people getting openshift into fedora
19:26:43 <strace> maxamillion: i am already in that list
19:27:16 <maxamillion> strace: then get your name on it ---> https://fedoraproject.org/wiki/Features/OpenShift_Origin :D
19:27:28 <strace> pfft i am on the internal list :)
19:27:44 <rbergeron> i'm not sure what this "internal list" stuf is that you speak of :)
19:27:54 <strace> rbergeron: it was a joke :)
19:28:02 <rbergeron> i know ;) lol
19:28:09 <rbergeron> okay, who's next?
19:28:18 * rbergeron scrolls up to see who's around, or she may call on skvidal ;)
19:28:22 <rbergeron> #topic Other business?
19:28:34 * skvidal looks for wwoods' q
19:28:57 <rbergeron> #info good luck to our euca friends as they get a nice flossy 3.1 out the door
19:29:20 <skvidal> rbergeron: I was just distracting agrimm and gregdek down at their office
19:29:21 <wwoods> skvidal: also if you see a 'u' around, this scrabble game would go a lot better
19:29:27 <skvidal> wwoods: qi
19:29:34 <rbergeron> skvidal: oh, that's excellent.
19:29:35 <skvidal> wwoods: secret words with friends word
19:29:49 <skvidal> wwoods: like 'za'
19:29:59 <skvidal> rbergeron: yah - seems hopeful
19:30:01 <rbergeron> the agrimm/gregdek trolling, to be clear
19:30:10 <skvidal> rbergeron: spekaing of euca and fedora
19:30:13 <rbergeron> HEY
19:30:22 <rbergeron> want to give an update? :)
19:30:23 <skvidal> our hw is all in a row - but not installated yet
19:30:28 <rbergeron> nice. is it in phoenix?
19:30:35 <rbergeron> i can just run over there real quick and plop it in the rack
19:30:36 <skvidal> smooge is arranging the deets on that
19:30:44 <skvidal> rbergeron: well we also need that pesky network
19:30:53 <rbergeron> wtf for? i have some cans and string
19:31:05 <skvidal> rbergeron: as soon as we have a timeline pinned down I will be sure to update folks
19:31:28 <rbergeron> #info Euca install is coming along - hw is all in a row, but not installed yet; arrangements are being made
19:31:43 <rbergeron> #info skvidal will share a timeline once there is a timeline
19:31:54 <skvidal> rbergeron: :)
19:31:54 <rbergeron> skvidal: and what happens once it's on?
19:32:10 <skvidal> rbergeron: it becomes self-aware and launches our missiles?
19:32:13 <skvidal> wait, wait
19:32:16 <skvidal> shit I shouldn't have said that
19:32:36 <skvidal> rbergeron: once it is on - we do the install/configuration step
19:32:46 <skvidal> and start making sure things are working like they did before
19:33:02 <skvidal> once that is the case then I think instances are to be allocated willy-nilly
19:33:07 <skvidal> well,, that's my hope at least
19:33:23 * gholms appears
19:33:25 <maxamillion> ooooo, euca install?
19:33:28 <rbergeron> skvidal: it grows pigs and turns them into bacon?
19:33:29 <maxamillion> sweet :D
19:33:45 <skvidal> maxamillion: euca cluster for fedora, yah
19:33:59 <rbergeron> s/cluster/cloud?
19:34:03 <maxamillion> skvidal: awesoem
19:34:03 <rbergeron> CLOOOOOOOUD
19:34:07 <skvidal> rbergeron: sure, sorry
19:34:11 <maxamillion> ermm... +/- some typo bits
19:34:34 <skvidal> rbergeron: I like cluster b/c I know another word that makes more sense with cluster
19:34:39 <skvidal> as the prefix
19:34:41 <skvidal> anyway...
19:34:51 * gholms whacks skvidal with a large trout
19:34:55 <rbergeron> clusterqi?
19:35:06 <skvidal> maxamillion: the goal is to provide isolated instances to folks and for us to more easily migrate around
19:35:06 <gholms> cluster controller.
19:35:13 <skvidal> gholms: is that clc or cc? :)
19:35:13 <maxamillion> skvidal: very cool
19:35:32 <gholms> skvidal: The latter.  I hate those.  :-\
19:35:32 <gregdek> euca is coming to your town!
19:35:34 <skvidal> gholms: seriously whose idea was it to distinguish cluster controller from cloud controller by adding an l?
19:35:42 <gregdek> skvidal: BAD INSANE PEOPLE.
19:35:48 <gregdek> File a bug. srsly.
19:35:49 <gholms> Yeah, that.
19:36:00 <skvidal> gregdek: I just named the cluster controller herman
19:36:03 <skvidal> and I call him that
19:36:16 <skvidal> on 'herman' you need to attache your node controllers
19:36:17 <gregdek> PATCH ACCEPTED.
19:36:43 <skvidal> rbergeron: anyway - I'm quite excited for our hw to show up and be installated :)
19:37:08 <rbergeron> #info goal is to provide isolated instances to folks and for us to more easily migrate around. skvidal is excited for the hw to show up and be installated. yay!
19:37:08 * gregdek is not kidding about someone filing a bug for the terrible CC/CLC naming convention.
19:37:11 * gholms 's build finishes
19:37:29 <gholms> gregdek: If someone who *isn't* from eucalyptus files it then it may even get attention.  Who knows?
19:37:36 <gregdek> :)
19:37:41 * skvidal makes a note
19:38:17 <rbergeron> #action skvidal to test out gregdek's theory by filing the CC/CLC naming convention bug at euca
19:38:20 <rbergeron> :D
19:38:24 <gholms> Hehe
19:38:46 <skvidal> gholms: speaking of builds - what are you using to do your sets of rpms?
19:38:57 <gholms> Define "do".
19:39:21 <skvidal> I was just going to peddle mockchain a bit more - since it is now in mock upstream
19:39:23 <gholms> Jenkins spawns workers in a Eucalyptus cloud that use mock to build RPMs.
19:39:30 <rbergeron> #info PLEASE READ AND RESPOND: http://lists.fedoraproject.org/pipermail/cloud/2012-June/001530.html <--- Cloud Interop FAD topic, let's get this puppy planned
19:39:59 <gholms> Ooh, you got it upstream.
19:40:12 <skvidal> gholms: nod
19:40:24 <skvidal> and i've got two new things I've almost got finished enough to release
19:40:24 <gholms> Yes, if you're interested in a FAD for the cloud SIG, please respond to the mailing list thread!
19:40:39 <skvidal> gholms: we can talk elsewhere
19:40:40 <skvidal> thanks
19:41:08 <rbergeron> Anyone else? :D
19:41:21 <rbergeron> pixelbeat: i saw you hop in
19:43:31 <rbergeron> Okay, i'll take that as a no
19:43:46 * rbergeron gives it about... 30 seconds and then she's gonna end the meetin'
19:45:05 * gholms looks forward to next week
19:45:06 <rbergeron> bye guys :) thanks for coming
19:45:13 <gholms> Thanks, all!
19:45:15 <tdawson> Bye
19:45:15 <strace> good bye
19:45:17 <rbergeron> gholms: o really? you might have to be in charge next week :)
19:45:29 * rbergeron will be at summit, not sure if she'll be able to escape
19:45:30 <gholms> rbergeron: There you go putting words in my mouth again.  8^)
19:45:41 <rbergeron> gholms: i like to think of it more as putting you under the bus
19:45:51 <gholms> That's obino's job.
19:47:04 <rbergeron> LOL
19:47:05 <rbergeron> okay.
19:47:06 <rbergeron> bye!
19:47:08 <rbergeron> #endmeeting