i18n
LOGS
05:01:28 <tagoh_> #startmeeting i18n
05:01:28 <zodbot> Meeting started Thu Jun 21 05:01:28 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:01:32 <tagoh_> #meetingname i18n
05:01:32 <zodbot> The meeting name has been set to 'i18n'
05:01:39 <tagoh_> #topic agenda and roll call
05:01:51 <tagoh_> https://fedoraproject.org/wiki/I18N/Meetings/2012-06-21
05:02:01 <tagoh_> hi guys, time for i18n meeting now
05:02:41 <tagoh_> please update the agenda if anything is missing
05:03:29 <epico> hi
05:03:30 <juhp> hi
05:06:15 <jni> hi
05:06:28 <tagoh_> hm, okay. time to go. let's get started then.
05:06:37 <tagoh_> #topic F18
05:07:00 <tagoh_> so any updates for features and f18 related things?
05:07:00 <anish__> hi
05:07:21 <tagoh_> anish__: hi, how about the feature page?
05:07:27 <anish__> i am working on https://fedoraproject.org/wiki/Features/Typing-Booster
05:08:16 <tagoh_> Typing-Booster? isn't it ibus-hunspell or -table? :)
05:08:42 <anish__> Typing booster is feature and project name
05:09:00 <tagoh_> aha. just got confused.
05:09:08 <anish__> ibus-hunspell is difficult to understand for users
05:10:32 <tagoh_> hm, renaming the package name too may be clearer then?
05:11:40 <tagoh_> anyway
05:12:11 <anish__> what should we do with existing typing booster packages
05:12:38 <anish__> i am going to deprecate that
05:14:32 <tagoh_> hmm, well, it can takes it over. dunno. users may expects similar thing in the package name when they are going to find it out.
05:14:46 <anish__> okay then
05:15:14 <tagoh_> any comments from anyone else?
05:15:20 <anish__> right now *-typing-booster installs , table and dictionary
05:15:29 <anish__> from now on we can
05:15:53 <anish__> install hunspell-table and hunspell-dictionary
05:15:57 <anish__> is it okay?
05:16:26 <juhp> I think ibus-hunspell-table should "Obsoletes:  *-typing-booster"
05:16:35 <tagoh_> anish__: you mean *-t-b as the meta package?
05:16:55 <anish__> yes
05:17:25 <juhp> that way if we setup yum-langpacks to handle ibus-hunspell-table it will install hunspell for locale automatically at least
05:17:35 <anish__> we are going to obsolete ibus-indic and ibus-european table
05:17:47 <juhp> yep those as well
05:19:03 <juhp> you should add those details to the feature page probably
05:19:25 <tagoh_> juhp: well, considering to change the branding affects to the package name IMHO. so going back a bit to discuss...
05:19:36 <juhp> hmm yeah
05:20:09 <anish__> sure , i want to discuss about are we going to obsolete *-t-b thing
05:20:11 <juhp> hmm Pravin is not here
05:20:48 <anish__> i am going to obsolete the packages
05:21:31 <juhp> anish__, then how about renaming ibus-hunspell-table to ibus-typing-booster?
05:21:48 <anish__> that is a good idea
05:22:09 <juhp> then we can avoid this funny naming dichotomy
05:22:44 <tagoh_> nod
05:22:46 <juhp> and get rid of "-table" once and for all ;-)
05:23:04 <anish__> how user will install typing booster for particular language
05:23:27 <tagoh_> i-t-b-<language> ?
05:23:41 <tagoh_> does it help to catch up in yum-langpacks?
05:23:44 <juhp> if it is default then they will get installed by default I guess
05:23:56 <juhp> ah the evil metapackages
05:24:01 <anish__> agree
05:24:08 <juhp> well yeah it is one approach :)
05:24:22 <tagoh_> well, if the size isn't too big, better ship in one package I guess
05:24:49 <anish__> not sure about size
05:24:52 <juhp> I think we can make yum-langpacks map directly to hunspell-*
05:25:00 <juhp> size?
05:25:07 <tagoh_> juhp: ah, yeah
05:25:44 <anish__> i am agree with this approach
05:25:51 <pravins> hi
05:26:29 <pravins> sorry for bit late, can someone paste log for me PM
05:26:30 <juhp> of course it still means people have to install hunspell-* for other languages
05:27:31 <tagoh_> dunno how to catch up hunspell-* when installing i-t-b then?
05:28:34 <tagoh_> pravins: http://meetbot.fedoraproject.org/fedora-meeting/2012-06-21/i18n.2012-06-21-05.01.log.txt
05:28:42 <pravins> thanks juhp
05:29:21 <pravins> tagoh_: thanks
05:29:22 <anish__> installation of i--t-b-lang will install hunspell dict for that language right
05:29:46 <juhp> aha
05:30:12 <tagoh_> well, without the meta package I mean. if it can be done without it, that would be better.
05:30:24 <juhp> I think we need to think carefully about doing metapackages anyway - maybe better to add some UI for installing additional dictionaries perhaps
05:30:53 <juhp> tagoh_: yeah
05:31:32 <tagoh_> pravins: so any comments for renaming btw?
05:31:32 <anish__> okay
05:32:54 <pravins> i think its fine to have pkg name as ibus-hunspell-table
05:33:08 <tagoh_> juhp: yeah, that may be an idea.
05:33:52 <juhp> pravins: but then why feature is called Typing Booster
05:34:15 * juhp is using ibus-hunspell-table now...
05:34:21 <pravins> Typing booster is already known to most of the users, it is concept
05:34:38 <anish__> ibus-hunspell is confusing for users
05:34:49 <juhp> right - so why not use the brand for the IME too? :)
05:35:05 <tagoh_> pravins: can say same thing in the package name too. so sugestting to rename now :)
05:36:03 <pravins> tagoh_:  we have played lot with lohit naming :)
05:36:04 <juhp> well anyway I think we should with one or the other (TB or )Hunspell)
05:36:22 * juhp thinks he has found a bug perhaps...
05:36:48 <pravins> may be feature likn "Extension to TB (i-hunspell-table)"
05:36:48 <juhp> should go *
05:36:55 * anish__ bugs are welcome :)
05:37:00 <juhp> :)
05:37:03 <pravins> s/likn/like
05:37:48 <juhp> anish_: see my line above my last action ^
05:38:04 <juhp> but I will try to report it
05:38:29 <anish__> juhp, okay thanks
05:39:01 <tagoh_> pravins: well, any reason to keep it as ibus-hunspell-table?
05:40:11 <pravins> tagoh_: nothing specifically, just if we say it indicates its dependency on hunspell-dictionaries (but that is minor)
05:40:27 <juhp> anish_: ')' gets prepended (I guess for '(' it is a )feature?)
05:41:18 <anish__> juhp, no it is a bug
05:41:28 <juhp> ok
05:42:01 <pravins> tagoh_: juhp if feature name should be consistent with the pkg name, then i think we should go for renaming. else writing steps in testing, how to install should solve this problem
05:42:16 <juhp> hmm ok anyway maybe we can discuss more about the naming later
05:42:21 <juhp> mmm
05:42:21 <pravins> yes
05:42:28 <anish__> summary of till now
05:42:39 <tagoh_> pravins: there are many projects that has different name, which is working as frontend for something. so that should be ok. if we want to keep TB name as the project, it should be kept in the package name as well IMHO.
05:42:45 <anish__> Approch 1:  rename it i-t-b. Give UI to install dictionaries
05:42:45 <juhp> but I don't really see what value we are getting with the split naming
05:43:08 <anish__> Approch 2: Replace existing t-b packages with ibus-hunspell-table
05:44:28 <tagoh_> anish__, pravins: anyway, the feature name and the package name should be better to have same. can you guys discuss which one is better please.
05:44:49 <juhp> yeah right - my test of C-q in i-h-t failed ;)
05:45:02 <pravins> tagoh_: sure, will do. naming discussion always takes time :)
05:45:05 <tagoh_> jni: how about ibus-libpinyin?
05:45:15 <anish__> tagoh_, sure thanks
05:45:21 <tagoh_> pravins, anish__: thanks
05:45:32 <juhp> anish__, either way the old packages need need to be rpm obsoleted
05:45:44 <juhp> just one need
05:45:58 <anish__> juhp, yes i will do that
05:45:59 <epico> tagoh_: pushed libpinyin-0.6.0-2 for F16.
05:46:24 <juhp> :)
05:46:34 <tagoh_> epico: cool. sorry, you. typo ;)
05:46:40 <epico> np
05:46:51 <tagoh_> how about feature page btw?
05:47:06 <epico> sorry, will create one later.
05:47:09 <tagoh_> okay
05:48:21 <tagoh_> how about the feature page for ibus gnome integration this time? should be integrated into gnome 3.6 or better have separate page for that purpose?
05:48:46 <tagoh_> I thought we didn't have any conclusion about it right?
05:49:29 <tagoh_> fujiwarat: any comments for that?
05:52:10 <fujiwarat> I'm not sure if the integration can be done in gnome 3.6. I think now the first priority is to integrate the input source.
05:53:00 <tagoh_> fujiwarat: okay. so no features for ibus to be advertised in f18 so far?
05:54:43 <fujiwarat> I guess it may be good to have that topic in Aug again.
05:55:47 <tagoh_> fujiwarat: hmm, but the feature submission deadline is July 24 and August 7 to be the feature freeze.
05:57:28 <fujiwarat> OK, probably I should ask ruim the current target till the next i18n meeting.
05:57:29 <tagoh_> then may be good to postpone it to f19 perhaps.
05:57:38 <tagoh_> fujiwarat: okay. thanks!
05:58:42 <tagoh_> #action fujiwarat to ask ruim the target release of gnome for ibus integration.
05:58:51 <tagoh_> anything else for f18?
06:00:36 <tagoh_> will open one for fontconfig by next meeting maybe. pondering to have one for 2.10 instead of one specific feature, since it has a lot of improvements. maybe good to use this opportunity for advertisement anyway.
06:00:40 <juhp> I think mclasen said he would add it to the
06:00:43 <juhp> oops
06:00:46 <juhp> https://fedoraproject.org/wiki/Features/InitialExperience
06:01:09 <juhp> tagoh_, aha
06:01:34 <tagoh_> aha
06:03:13 <pravins> interesting and good one, since users normally dont know how to customize
06:03:15 <juhp> hmm talk pages...
06:03:31 <juhp> but unclear on language choice
06:03:47 <tagoh_> hm
06:04:06 <juhp> "The gdm mode of running an application instead of the login screen, with the option to smoothly transition into a user session may also be used to run the 'try-or-install?' application on the live cd, before starting the liveuser session. Doing things this way will allow us to offer a language choice for the liveuser session in the 'try-or-install?' application (which is something we've lost when we switched to autologin for the liveuser)."
06:04:15 <juhp> allow at least ;)
06:05:24 <tagoh_> okay. have to move on..
06:05:32 <tagoh_> #topic Bugzilla clean up
06:06:06 <tagoh_> I'll postpone other topic this time but have to bring this one up here since f15 EOL is coming soon.
06:07:13 <tagoh_> there was a little activities in f15 bugs last week though, again, please re-review bugs until EOL for your bugs.
06:07:38 <tagoh_> still 41 bugs open in f15
06:08:24 <tagoh_> will try to ping on bz or irc this week if no updates. thanks
06:08:49 <tagoh_> #topic Open Floor
06:09:09 <tagoh_> any other urgent topics before closing the meeting?
06:09:32 <juhp> (nor here https://live.gnome.org/GnomeOS/Design/Whiteboards/InitialSetup :-/)
06:10:11 <tagoh_> juhp: hmm, guess better ask the desktop team then?
06:10:49 <juhp> yes
06:11:12 <juhp> actually I am lying it is there
06:11:33 <juhp> under Tentative Design
06:11:37 <juhp> ok
06:12:07 <juhp> looks pretty cool anyway
06:12:40 <tagoh_> aha
06:12:56 <tagoh_> okay, let's close the meeting then. thanks everyone for the meeting!
06:13:03 <tagoh_> #endmeeting