i18n
LOGS
05:06:37 <tagoh_> #startmeeting i18n
05:06:37 <zodbot> Meeting started Thu Jun 14 05:06:37 2012 UTC.  The chair is tagoh_. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:06:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:06:41 <tagoh_> #meetingname i18n
05:06:41 <zodbot> The meeting name has been set to 'i18n'
05:06:46 <tagoh_> #topic agenda and roll call
05:06:53 <tagoh_> https://fedoraproject.org/wiki/I18N/Meetings/2012-06-14
05:07:00 <pravins> hi
05:07:05 <tagoh_> sorry for late start.
05:07:13 <paragan> hi
05:07:33 <tagoh_> hi guys
05:07:44 <anish_> Hi
05:07:45 <epico> hi
05:07:50 <dueno> hi
05:09:10 <juhp> hi
05:09:17 <tagoh_> okay, let's get started.
05:09:24 <tagoh_> #topic F18
05:10:03 <tagoh_> well, so any updates or suggestions for i18n related features on f18?
05:10:48 <pravins> tagoh_: anish_ we have lot to do for ibus-hunspell-table :)
05:10:49 <anish_> i am going to file ibus-hunspell-table feature in this week
05:11:06 <tagoh_> anish_: cool
05:11:08 <pravins> as a first step i have retired all IT-booster packages in F18
05:11:22 <anish_> pravins, thanks i will do that
05:11:30 <tagoh_> pravins: okay
05:12:15 <epico> ibus-libpinyin is imported into rawhide.
05:12:47 <tagoh_> #action anish_ to file a feature proposal for ibus-hunspell in this week
05:13:00 <tagoh_> epico: cool
05:14:51 <tagoh_> anything more on f18?
05:16:11 <tagoh_> if there are any important features upstream is about to introduce in f18 timeframe, it may be good to consider proposing a feature on f18
05:16:35 <epico> okay
05:16:58 <tagoh_> feel free to ask if you are not sure
05:18:04 <tagoh_> even if it's good enough without feature proposal, it may be a good idea to write something in relnotes. sharing information here would be helpful to remind it for relnotes.
05:19:44 <tagoh_> anyway, if no particular things to talk about f18, shall we move on then
05:20:10 <tagoh_> #topic Bugzilla cleanup
05:20:59 <tagoh_> any activities to recheck f14/15 bugs? for reminder, f15 EOL is June 26.
05:21:04 <juhp> does anything obsolete the booster packages?
05:21:42 <tagoh_> juhp: I guess ibus-hunspell does?
05:21:58 <anish_> tagoh_, juhp yes
05:22:28 <juhp> maybe not yet? :)
05:22:35 <juhp> I mean at the rpm level :)
05:24:18 <tagoh_> juhp: true. looks like not.
05:24:54 <juhp> so that should be done before alpha at least
05:25:04 <tagoh_> agree
05:25:23 <juhp> (sorry late comment to previous section)
05:25:44 <tagoh_> juhp: np. thanks for bringing it up
05:26:19 <pravins> juhp: yes, i have created bug for ibus-hunspell table, interesting part is <lang>-typing-booster should be obsolete by hunspell-<lang>
05:26:39 <juhp> pravins, aha
05:26:55 <juhp> hmm yeah maybe
05:27:04 <pravins> .bug 829658
05:27:10 <zodbot> pravins: Bug 829658 should Obsoleted/Provided marathi-typing-booster at least for Fedora 18 - https://bugzilla.redhat.com/show_bug.cgi?id=829658
05:27:14 <pravins> .bug 829637
05:27:17 <zodbot> pravins: Bug 829637 ibus-hunspell-table should Obsoleted/Provided indic-typing-booster from Fedora 18 onwards - https://bugzilla.redhat.com/show_bug.cgi?id=829637
05:27:21 <tagoh_> hmm, but hunspell-<lang> itself isn't alternatives for ITB right?
05:27:22 <juhp> pravins, or maybe we could do it with yum-langpacks dunno
05:27:30 <juhp> right
05:27:54 <pravins> tagoh_: ibus-hunspell-table need hunspell-<lang> to get language displayed in ibus-preferences
05:28:07 <paragan> I was saying the same to pravins that hunspell-<lang> is not alternative to ITB
05:28:14 <juhp> I think also it might be better for i-h-t (why isn't it called i-h ;-P) to obsolete tb-*
05:28:22 <pravins> so if someone wants to install marathi-typing-booster. I think it should install ibus-hunspell-table and hunspell-mr
05:28:32 <juhp> right
05:28:41 <juhp> pravins, and yum-langpacks can do that...
05:28:56 <juhp> once configured of course
05:29:17 <tagoh_> pravins: no explicit deps to hunspell-* in ibus-hunspell-table though, how are you going to pick up for certain languages then?
05:29:37 <juhp> did I mention yum-langpacks :)
05:30:08 <juhp> but yeah that will only work for one's locale
05:30:28 <juhp> otherwise maybe "tough luck"
05:30:29 <juhp> ?
05:30:34 <tagoh_> what if no hunspell-* corresponding to the lang? :)
05:30:44 <juhp> hmm
05:30:47 <juhp> ditto? :)
05:31:28 <pravins> in that case, there will be no display of engine for that lang in ibus-preference-table :)
05:31:28 <juhp> well maybe we need more thought on this - can't see a simple perfect solution anyway
05:31:33 <tagoh_> dunno if there are any safe-check in i-h-t in that case
05:31:42 <pravins> anish_: frankly i am still bit confuse for this ;)  But since we are planning to make it default we have to take care for these things
05:32:07 <tagoh_> pravins: aha
05:32:34 <juhp> I guess other question is how confident are we about making it the default for Indic input?
05:33:12 <tagoh_> good question
05:33:32 <anish_> we are replacing it with typing booster package
05:33:43 <juhp> anyway we definitely need a feature page for that as soon as possible
05:33:45 <pravins> I am confident since now we are using libtranslit which uses m17n in background. So we can assure user will get same result as m17n by using ibus-hunspell-table
05:33:55 <tagoh_> juhp: right. it should be mentioned there.
05:34:20 <juhp> yes as already brought up earlier
05:34:38 <juhp> ok
05:34:50 <pravins> but i am sure, it will pop-up some challenges. We need to start early
05:35:02 <juhp> so let's discuss the feature page next week here?
05:35:14 <juhp> pravins, I think so
05:35:23 <tagoh_> pravins: okay. the point is if it's visible public. that would be useful when one has similar question.
05:35:32 <anish_> but are we making lang-typing booster or just typing-booster
05:35:44 <juhp> anish_, ?
05:36:11 <anish_> do we require marathi or english typing booster
05:36:15 <juhp> I thought we were dropping *-tb completely
05:36:24 <juhp> or do you propose new metapackages?
05:36:25 <pravins> yes
05:36:49 <anish_> can't we have only typing  booster package
05:36:55 <pravins> anish_: we will work together on feature proposal
05:37:05 <anish_> pravins, okay
05:37:23 <juhp> pravins, how about f17 and earlier though - no change there?
05:37:25 <pravins> i think writing feature will make some doubts more clear :)
05:37:29 <juhp> yes
05:37:31 <tagoh_> anyway, would be nice if you can prepare the feature page before next meeting. so we can discuss about it then.
05:37:37 <juhp> right
05:37:41 <anish_> tagoh_, thanks
05:38:01 <pravins> ibus-hunspell-table there so yes user can test, if they can switch from m17n .mim to hunspell-table
05:38:22 <juhp> pravins, I mean we will still keep TM packages there for now?
05:38:38 <juhp> or also transition?
05:38:48 <juhp> erm s/TM/TB/
05:39:13 <juhp> anyway
05:39:41 <tagoh_> ideal plan I guess would be to migrate to i-h-t. but it may depends on its quality and stability etc?
05:40:10 <juhp> yeah anyway I agree it is not urgent and can wait
05:40:54 <tagoh_> okay, we can discuss it too in next meeting what to do for contingency plan anyway.
05:41:10 <juhp> sure
05:41:18 <anish_> sure
05:42:48 <pravins> yes
05:43:18 <tagoh_> so back to the topic, please spend some time to have a look at bugzilla for any of your bugs or any interesting bugs in 43 + 6 i18n related bugs.
05:43:59 <tagoh_> will try to catch up in next meeting or later if we have time but definitely before EOL.
05:44:07 <paragan> ok
05:44:16 <tagoh_> #topic Input Methods
05:44:59 <tagoh_> any updates on IM?
05:46:09 <tagoh_> I see some discussion again for the default keybinding issue on bz recently though
05:47:19 <juhp> yes
05:47:39 <juhp> ah do you mean gnome bz?
05:47:50 <tagoh_> no, our bz
05:47:53 <juhp> ah
05:48:17 <juhp> also I saw some discussion about switcher UI in upstream bz
05:48:32 <tagoh_> aha
05:49:07 <tagoh_> related to ibus gnome integration right?
05:50:37 <tagoh_> fujiwarat: talking about switcher UI discussion in gnome bz. can you summarize what's going on? or juhp?
05:51:20 <juhp> https://bugzilla.gnome.org/show_bug.cgi?id=641531
05:51:37 <fujiwarat> Currently there is no IME switcher UI in the latest patch although it's provided in ibus 1.5.
05:52:08 <fujiwarat> Probably I need to ask previous toggle hotkey in the latest patch.
05:52:47 <juhp> well I saw some questions about why the switch popup is needed and then if so they were saying it should be done using gnome-settings-daemon iiuc
05:53:12 <juhp> anyway seems to be proceeding at least
05:53:28 <fujiwarat> Yeah, I'm not sure if they understand the UI.
05:53:41 <tagoh_> aha
05:53:54 <juhp> right - I was going to suggest they try it themselves...
05:54:12 <juhp> tagoh_, what was the issue about fedora keybindings?
05:54:46 <tagoh_> keybinding conflict on eclipse it has been brought up some while ago
05:54:47 <juhp> I think mclasen also commented that gnome should control the IM shortcuts
05:54:50 <juhp> ah
05:55:30 <juhp> any new "developments" there?
05:55:30 <tagoh_> as far as I tried on f17, there seems no default assignment to ctrl+space on eclipse though.
05:55:37 <juhp> aha
05:55:47 <juhp> I see
05:56:05 <fujiwarat> https://bugzilla.gnome.org/show_bug.cgi?id=641531#c108
05:56:18 <juhp> so we can all live happily together now? :)
05:56:22 <tagoh_> juhp: one suggestion to rethrow the key event when pressing to ctrl+space.
05:56:23 <fujiwarat> The 'frontend' means 'initialize'?
05:56:30 <juhp> aha
05:56:57 <juhp> fujiwarat, I think frontend means gnome :)
05:57:04 <fujiwarat> Ah, ok.
05:57:23 <tagoh_> juhp: given that we do so, wanted to make sure if UI or anything doesn't conflict to typing.
05:57:26 <juhp> s/to/the/ I guess
05:57:52 <fujiwarat> https://bugzilla.gnome.org/show_bug.cgi?id=676102
05:58:09 <juhp> tagoh_, interesting idea
05:58:40 <tagoh_> juhp: yep
05:58:57 <juhp> though also sounds a little risky :)
06:00:23 <juhp> "FWIW, Windows 8 uses Windows+Space to switch input sources."
06:00:24 <tagoh_> indeed. that would mean application behaves something prior to input. which may be not expected for one who is going to use IM right.
06:01:06 <juhp> fujiwarat, how is that discussion going?
06:01:15 <pravins> juhp: aha, interesting. i think earlier they were using "control-shift" or "Alt-shift"
06:01:46 <juhp> pravins, yeah it might have depended on the language I think
06:01:49 <tagoh_> pravins: isn't it to switch the language?
06:01:52 <fujiwarat> I think it's still on progress.
06:02:02 <tagoh_> or IME
06:02:22 <juhp> fujiwarat, any obstacles?
06:02:58 <fujiwarat> Currently the latest patch has no default trigger key :(.
06:03:39 <pravins> tagoh_: it was for input method
06:04:01 <fujiwarat> I think Windows+space is next/prev trigger key instead of toggle trigger key.
06:05:16 <tagoh_> I see
06:05:25 <juhp> fujiwarat, ok
06:05:59 <juhp> fujiwarat, but there will be UI to allow setting a trigger key?
06:06:49 <juhp> is there any impact for other desktops/generic X?
06:07:00 <tagoh_> juhp: guess they may want to integrate it into the shortcut settings perhaps?
06:07:17 <fujiwarat> I think rtcm will notice that issue today. Yes, technically the trigger key can be added.
06:07:48 <juhp> ok
06:08:16 <fujiwarat> I'm not sure if IME switcher dialog is implemented or trigger key. I think they need to play f17.
06:08:32 <juhp> I see
06:08:42 <tagoh_> hm, I'll postpone the keyboard layout issue to next meeting since it's not so urgent btw.
06:09:25 <tagoh_> anyway, anything more on IM?
06:10:09 <juhp> tagoh_, sorry was the eclipse issue or something else?
06:10:18 <juhp> ah ibus?
06:10:38 <juhp> s/was/was that/
06:10:47 <tagoh_> juhp: adding the unexpected keyboard layout after turning on ibus.
06:10:53 <juhp> ok right
06:11:39 <tagoh_> okay, better move on
06:11:43 <tagoh_> #topic Fonts and Rendering
06:12:22 <tagoh_> development snapshot of fontconfig is available on rawhide now, which contains various fixes and improvements. fyi
06:12:43 <juhp> nice
06:13:29 <pravins> .bug 825104
06:13:31 <zodbot> pravins: Bug 825104 Glyphs of NGA and NYA with vowel signs in Lohit Kannada font are improperly formed - https://bugzilla.redhat.com/show_bug.cgi?id=825104
06:13:31 <pravins> resolved this
06:13:41 <pravins> .bug 829143
06:13:44 <zodbot> pravins: Bug 829143 [ta_IN] Fix Rendering of Letter RA,RI,RII per GoTN standards - https://bugzilla.redhat.com/show_bug.cgi?id=829143
06:14:05 <tagoh_> didn't still have a time to check the font packages that possibly be warned due to the malformed config files. probably try to do that shortly.
06:14:19 <pravins> this is interesting one, Unicode has different standard and Tamil Govt. has different :)
06:14:24 <tagoh_> pravins: cool
06:14:31 <juhp> oh
06:14:38 <tagoh_> aha
06:14:42 <juhp> pravins, any resolution?
06:14:42 <pravins> finally community member came to some consensus :)
06:15:10 <pravins> Yes, We have presently 2 Tamil fonts. "Lohit Tamil"  and "Lohit Tamil Classical"
06:15:17 <juhp> ah right
06:15:25 <juhp> hm
06:15:35 <pravins> Changes specific to Tamil govt. doing in Lohit Tamil
06:15:45 <pravins> and keeping Lohit Tamil Classical as per Unicode
06:15:56 <juhp> I see
06:15:56 <tagoh_> pravins: which one is default for Tamil?
06:16:08 <pravins> Lohit Tamil is default
06:16:27 <pravins> for ta_IN
06:16:52 <pravins> https://bugzilla.redhat.com/show_bug.cgi?id=829143#c8 this person is from wikipedia
06:16:55 <juhp> so Gov is more "modern"? :)
06:17:00 <tagoh_> is it maybe a good idea to mention in relnotes how to switch the font?
06:17:35 <pravins> tagoh_: yeah, yesterday replied regarding same on lohit-devel
06:17:38 <pravins> yes will add it.
06:17:43 <tagoh_> great
06:17:52 <pravins> juhp: yeah, we can say. Or rather govt. does not follow Unicode ;)
06:18:20 <pravins> While fixing this bug i have optimized Lohit Tamil by removing around 13 glyphs.
06:18:24 <juhp> okay
06:18:36 <pravins> hoping to complete this soon.
06:18:53 <juhp> just wondered if name "Lohit Tamil" would be better for Unicode but I guess it is a detail
06:19:07 <tagoh_> #action pravins to add relnotes how to change Lohit Tamil to Lohit Tamil Classical for the default font
06:19:23 <pravins> tagoh_: fonts-tweak-tool :)
06:19:51 <tagoh_> heh. sure
06:20:05 <pravins> juhp: yeah, i am still not sure. But i think yes we have to support community.
06:20:16 <pravins> tagoh_: yes, will do it.
06:20:44 <tagoh_> okay, anything more?
06:20:57 <juhp> pravins, well I am just thinking from global perspective (Lohit Tamil and Lohit Tamil Modern) but maybe it is fine, shrug
06:21:25 <juhp> eg if Lohit Tamil was to be a Unicode reference font...
06:21:43 <juhp> anyway
06:21:49 <juhp> just a comment
06:22:27 <pravins> juhp: yes. i do agree.  But same time it is default for ta_IN locale
06:22:36 <pravins> and same time we do not have any other ta_* locale ;)
06:22:38 <juhp> but if Classic is new then it doesn't make sense to rename Lohit tamil
06:22:45 <paragan> I am doing the Lohit Tamil Classical font package review. Was just thinking if this font can be added to lohit-tamil upstream tarball
06:22:55 <juhp> aha
06:23:44 <tagoh_> okay, shall we move on
06:23:47 <pravins> juhp: i saw the SakalBharati fonts release by Govt. is also following standard defined by Tamil Govt.
06:24:33 <pravins> paragan: since both Tamil and Tamil Classical are 80% same. I think user will use either of them. So better to have different release tarball and different packages
06:24:34 <juhp> pravins, or maybe Unicode should be updated?
06:24:59 <paragan> pravins, ok
06:25:00 <pravins> juhp: yes exactly. that is what i am to thinking. Need to ask with CDAC once
06:25:05 <pravins> paragan: thanks
06:25:10 <pravins> s/to/too
06:25:28 <tagoh_> juhp: sounds reasonable since no competitors to keep current one.
06:26:37 <tagoh_> #topic Open Floor
06:26:58 <tagoh_> okay, any other topics we are missing in the agenda?
06:27:23 <tagoh_> guess it would be better bringing something up in next meeting atm ;)
06:29:17 <tagoh_> okay, if not, will close the meeting shortly
06:30:07 <tagoh_> thanks everyone for the meeting!
06:30:11 <tagoh_> #endmeeting